Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> как передать переменную с клиента на сервер          
lolmatrix Подменю пользователя
сообщение 19.06.18, 14:33
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

Здравствуй, уважаемые специалисты, помогите пожалуйста новичку, НаКлиенте получаю переменную , ее надо передать наСервер, как можно это сделать ,
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    Запчасть = СтрокаТЧ.Наименование;

Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";

    Запрос.УстановитьПараметр("Запчасть", Запчасть);

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ТД.Цена =  ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;

КонецПроцедуры

Vofka Подменю пользователя
сообщение 19.06.18, 15:57
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 13021
Из: Киев
Спасибо сказали: 3953 раз
Рейтинг: 3085.1

&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    СписокЗЧНаименованиеПриИзмененииНаСервере(СтрокаТЧ.Наименование);
КонецПроцедуры


Signature
Услуги 1С программиста

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 03.07.18, 14:15
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

Vofka @ 19.06.18, 16:57 * ,
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'

Vofka @ 19.06.18, 16:57 * ,
а как передать всю строку

Petre Подменю пользователя
сообщение 03.07.18, 14:25
Сообщение #4

Живет на форуме
Иконка группы
Группа: Местный
Сообщений: 2582
Из: Київ, Україна
Спасибо сказали: 688 раз
Рейтинг: 659.2

lolmatrix @ Today, 14:15 * ,
А зачем ее передавать?
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    
    // . . .

КонецПроцедуры


Signature
Допрацьовую:
- "Бухгалтерія для України 2.0";
- "Альфа-Авто: Автосалон+Автосервіс+Автозапчастини, українська версія".

Спасибо сказали: lolmatrix,

ed.kharkov Подменю пользователя
сообщение 03.07.18, 14:38
Сообщение #5

Говорящий
Иконка группы
Группа: Mecтный
Сообщений: 55
Из: Бровары
Спасибо сказали: 19 раз
Рейтинг: 19

Petre @ Сегодня, 15:25 * ,
ТекущиеДанные недоступны на сервере.

На сервере можно получить так:

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    СтрокаТЧ = Объект.СписокЗЧ[Элементы.СписокЗЧ.ТекущаяСтрока];
    
    // . . .

КонецПроцедуры

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 03.07.18, 15:06
Сообщение #6

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

ed.kharkov @ Сегодня, 15:38 * ,
ed.kharkov @ Сегодня, 15:38 * ,
теперь вопрос цена попала в оттладчике она есть, но на форме не отразилась

lolmatrix @ Сегодня, 15:55 * ,
огромное спасибо, за помощь вопрос решен ответом Ed. kharkov
НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
СтрокаТЧ = Объект.СписокЗЧ[Элементы.СписокЗЧ.ТекущаяСтрока];

// . . .

КонецПроцедуры

ed.kharkov Подменю пользователя
сообщение 03.07.18, 15:07
Сообщение #7

Говорящий
Иконка группы
Группа: Mecтный
Сообщений: 55
Из: Бровары
Спасибо сказали: 19 раз
Рейтинг: 19

lolmatrix @ Сегодня, 15:55 * ,
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
   СписокЗЧНаименованиеПриИзмененииНаСервере();
   Прочитать();
КонецПроцедуры

lolmatrix Подменю пользователя
сообщение 15.01.19, 13:19
Сообщение #8

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

второй, логичный вопрос, как передать переменную обратно на клиент

awp Подменю пользователя
сообщение 15.01.19, 13:26
Сообщение #9

Оратор
Иконка группы
Группа: Местный
Сообщений: 437
Спасибо сказали: 49 раз
Рейтинг: 35

lolmatrix @ Сегодня, 13:19 * ,
Вместо Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
Пишите Функция и возвращайте значение

Можете объяснить
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ТД.Цена =  ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;


Signature
Бухгалтер - это не профессия! Это диагноз!

lolmatrix Подменю пользователя
сообщение 15.01.19, 13:38
Сообщение #10

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
СтрокаТЧНаименование =  строкаТЧ.Наименование
    СписокЗЧНаименованиеПриИзмененииНаСервере(СтрокаТЧНаименование);
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    Запчасть = СтрокаТЧНаименованиее;

Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Цена
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";

    Запрос.УстановитьПараметр("Запчасть", Запчасть);

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СтрокаТЧ.Цена =  ВыборкаДетальныеЗаписи.Цена;
    КонецЦикла;

КонецПроцедуры


Как на клиен теперь вернуть Цена из запроса


 ! 

Правила: 9
 


Сообщение отредактировал Vofka - 15.01.19, 14:31

awp Подменю пользователя
сообщение 15.01.19, 13:44
Сообщение #11

Оратор
Иконка группы
Группа: Местный
Сообщений: 437
Спасибо сказали: 49 раз
Рейтинг: 35

Попробуйте так

&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    СтрокаТЧ.Цена = ПолучитьЦенуНаСервере(СтрокаТЧ.Запчасть);
КонецПроцедуры


&НаСервере
Функция ПолучитьЦенуНаСервере(Элемент)
     Возврат = РегистрыСведений.Цены.ПолучитьПоследнее(ТекущаяДата(),Новый Структура("Запчасть",Элемент)).Цена;
КонецФункции


Сообщение отредактировал awp - 15.01.19, 13:45


Signature
Бухгалтер - это не профессия! Это диагноз!

lolmatrix Подменю пользователя
сообщение 15.01.19, 13:54
Сообщение #12

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

Спасибо попробую


выдает ошибку
{Документ.ВыдачаЗапасныхЧастей.Форма.ФормаДокумента.Форма(5,13)}: Ожидается выражение
Возврат<<?>> = РегистрыСведений.Цены.ПолучитьПоследнее(ТекущаяДата(),Новый Структура("Запчасть",Элемент)).Цена; (Проверка: Сервер)

awp Подменю пользователя
сообщение 15.01.19, 13:59
Сообщение #13

Оратор
Иконка группы
Группа: Местный
Сообщений: 437
Спасибо сказали: 49 раз
Рейтинг: 35

lolmatrix @ Сегодня, 13:54 * ,
Возврат РегистрыСведений.Цены.ПолучитьПоследнее(ТекущаяДата(),Новый Структура("Запчасть",Элемент)).Цена;


Signature
Бухгалтер - это не профессия! Это диагноз!

Спасибо сказали: lolmatrix,

lolmatrix Подменю пользователя
сообщение 16.01.19, 12:08
Сообщение #14

Общительный
**
Группа: Пользователи
Сообщений: 28
Спасибо сказали: 1 раз
Рейтинг: 1

Возврат РегистрыСведений.Цены.ПолучитьПоследнее(ТекущаяДата(),Новый Структура("Запчасть",Элемент)).Цена;


спасибо уважаемый AWP работает

Сообщение отредактировал Vofka - 16.01.19, 12:24

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.08.19, 7:11
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!