Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Как передать параметр с формы в отчет на СКД , для выолнения отчета          
burza Подменю пользователя
сообщение 25.04.18, 12:09
Сообщение #1

Завсегдатай
****
Группа: Пользователи
Сообщений: 170
Спасибо сказали: 0 раз
Рейтинг: 0

Нужно при нажатие кнопки с документа брать его объект и передать в отчет для авто формирования на СКД. Вот что наваял.
Это форма
&НаКлиенте
Процедура ПоказатьОстатки(Команда)
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Подразделение", Объект.Подразделения);
    
    ОткрытьФорму("Отчет.ФПиФЗ.Форма.ФормаОтчета", ПараметрыФормы);
    
КонецПроцедуры

Это в отчете
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Параметр = ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Подразделение"));
    Параметр.Значение = Параметры.Подразделение;
        
КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
        
    Параметр = ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("Подразделение"));
    
КонецПроцедуры

Ну нечего не заполняет. Помогите.

Vofka Подменю пользователя
сообщение 25.04.18, 12:47
Сообщение #2

У нас здесь своя атмосфера...
***********
Группа: Основатель
Сообщений: 12771
Из: Киев
Спасибо сказали: 3847 раз
Рейтинг: 2969.9

Может надо добавить:
Параметр.Использование = Истина;


Signature
Услуги 1С программиста

burza Подменю пользователя
сообщение 25.04.18, 13:06
Сообщение #3

Завсегдатай
****
Группа: Пользователи
Сообщений: 170
Спасибо сказали: 0 раз
Рейтинг: 0

Vofka @ Сегодня, 13:47 * ,
не помогает(

sava1 Подменю пользователя
сообщение 25.04.18, 13:15
Сообщение #4

Крутой
Иконка группы
Группа: Местный
Сообщений: 1933
Из: Проскуров
Спасибо сказали: 450 раз
Рейтинг: 440.1

А в курсе, что настроек бывает не одна ? что сначала нужно прочитать, изменить, а потом применить ?

burza Подменю пользователя
сообщение 25.04.18, 13:21
Сообщение #5

Завсегдатай
****
Группа: Пользователи
Сообщений: 170
Спасибо сказали: 0 раз
Рейтинг: 0

что еще можно дописать подсоветуйте

sava1 Подменю пользователя
сообщение 25.04.18, 13:44
Сообщение #6

Крутой
Иконка группы
Группа: Местный
Сообщений: 1933
Из: Проскуров
Спасибо сказали: 450 раз
Рейтинг: 440.1

вооще-то параметры надо устанавливать при компоновке.
При создании у компоновщика нет настроек, после, если были, он считывает пользовательские.

вариант - в отчете добавьте реквизит для параметра, при создании - заполняйте, при компоновке, если он заполнен - применяйте.

burza Подменю пользователя
сообщение 25.04.18, 13:48
Сообщение #7

Завсегдатай
****
Группа: Пользователи
Сообщений: 170
Спасибо сказали: 0 раз
Рейтинг: 0

sava1 @ Сегодня, 14:44 * ,
значение могут быть разные до 3.

Как тогда это сделать через компоновщика?

sava1 Подменю пользователя
сообщение 25.04.18, 14:24
Сообщение #8

Крутой
Иконка группы
Группа: Местный
Сообщений: 1933
Из: Проскуров
Спасибо сказали: 450 раз
Рейтинг: 440.1

Цитата(burza @ 25.04.18, 14:48) *
Как тогда это сделать через компоновщика?


что сделать ?

ПриКомпоновке
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();
    //  а тут устанавливаем параметры
    КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);



Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 16.12.18, 9:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне