Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 9, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Этикетка товара , создание          
XacTLa Подменю пользователя
сообщение 25.06.18, 15:32
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 69
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)

Не могу понять как мне создать этикетку с назначением товара, а именно что бы был номер заказа на этикетке при печати. Что бы информацию брать с назначения товара с производства. Уже все облазил не могу понять как.

XacTLa Подменю пользователя
сообщение 19.10.18, 10:06
Сообщение #2

Говорящий
***
Группа: Пользователи
Сообщений: 69
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

XacTLa @ 25.06.18, 16:32 * ,

Вообщем ситуация такая , что проще создать внешнюю печатную форму в виде этикетки, и вставить туда все параметры, пока не могу понять как вставить штрих код, а именно отобразить его в модуле сам штрих код я вставил а вот как в коде его отобразить не понимаю, может кто что подскажет вот код :
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
    
    ТабличныйДокумент = Новый ТабличныйДокумент;     
    МакетОбработки = ПолучитьМакет("Наклейка");
    ТабличныйДокумент.АвтоМасштаб = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    
    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");
    
        ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
        
        

        
        ТабличныйДокумент.Вывести(ОбластьШапки);
                
    
            
        ОбластьПодвала = МакетОбработки.ПолучитьОбласть("Подвал");
        
    ОбластьПодвала.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;

    
        ТабличныйДокумент.Вывести(ОбластьПодвала);
    
    
    Возврат ТабличныйДокумент;
        
КонецФункции // СформироватьПечатнуюФорму()

XacTLa Подменю пользователя
сообщение 23.10.18, 15:37
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 69
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

Не пойму выдает ошибку "Значение не является значением объектного типа 1"

Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
    
    ТабличныйДокумент = Новый ТабличныйДокумент;     
    МакетОбработки = ПолучитьМакет("Наклейка");
    ТабличныйДокумент.АвтоМасштаб = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    
    
    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");
    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Рисунки.ШтрихКод.Объект.ТипКода = 1;
    ОбластьШапки.Рисунки.ШтрихКод.Объект.Сообщение = "1234567890128";        
        

        
        ТабличныйДокумент.Вывести(ОбластьШапки);
                
    
            
        ОбластьПодвала = МакетОбработки.ПолучитьОбласть("Подвал");
        
    ОбластьПодвала.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;

    
        ТабличныйДокумент.Вывести(ОбластьПодвала);
    
    
    Возврат ТабличныйДокумент;
        
КонецФункции // СформироватьПечатнуюФорму()

Функция ПолучитьЗначениеТипаШтрихкодаДляЭУ(ТипКода)
    Перем Значение;
    
    Если ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN8 Тогда
        Значение = 0;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13 Тогда
        Значение = 1;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN128 Тогда
        Значение = 2;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code39 Тогда
        Значение = 3;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code128 Тогда
        Значение = 4;
    Иначе
        Значение = -1;
    КонецЕсли;
    
    Возврат Значение;
КонецФункции     

Процедура ВывестиШтрихКодВПечатнуюФорму(Кнопка)
    
    //Для типовых конфигураций
    ТипКода = ПолучитьЗначениеТипаШтрихкодаДляЭУ(ПланыВидовХарактеристик.ТипыШтрихкодов.EAN8);    
    
    //Для произвольных конфигураций
    ТипКода = 0;  //EAN8
    ТипКода = 1;  //EAN13
    ТипКода = 2;  //EAN128
    ТипКода = 3;  //CODE39
    ТипКода = 4;  //CODE128
    ТипКода = 5;  //CODE16K
    ТипКода = 6;  //PDF417
    ТипКода = 7;  //Industrial2of5
    ТипКода = 8;  //Interleaved2of5
    ТипКода = 9;  //Code39FullASCII
    ТипКода = 10; //CODE93
    ТипКода = 11; //ITF14
    ТипКода = 12; //RSS14
    ТипКода = 13; //CodaBar
    ТипКода = 14; //EAN13 AddOn 2
    ТипКода = 15; //EAN13 AddOn 5

    
    
КонецПроцедуры

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 18.11.18, 17:17
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне