Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> Доп реквизиты в маршрутном листе (печатная форма) , Не проставляет характеристику (хранение) номенклатуры          
XacTLa Подменю пользователя
сообщение 19.03.18, 15:48
Сообщение #1

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

1С:Предприятие 8.3 (8.3.9.2309)

1С:ERP Управление предприятием 2.0 (2.0.9.66)

Ситуация такая, что сделал маршрутный лист я уже и в модуль обьекта добавлял:
ОбластьСтроки.Параметры.ЕденицаИзмерения = ТекущаяСтрока.ЕденицаИзмерения;


что уже не пробовал, нечего не получается и в свойства тоже параметры вставлял.


 ! 

Правила: 8
 


Сообщение отредактировал Vofka - 19.03.18, 15:52

logist Подменю пользователя
сообщение 19.03.18, 16:21
Сообщение #2

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Ничего не понятно.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 19.03.18, 16:49
Сообщение #3

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 16:21 * ,


Сообщение отредактировал Vofka - 19.03.18, 17:11

logist Подменю пользователя
сообщение 19.03.18, 17:06
Сообщение #4

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Название темы с содержимым как-то не связуется. А еще какую-то информацию предоставите, или догадываться самостоятельно?


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 19.03.18, 17:41
Сообщение #5

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 17:06 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
                ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции // СформироватьПечатнуюФорму()

logist Подменю пользователя
сообщение 19.03.18, 17:49
Сообщение #6

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

В коде нет заполнения единицы измерения. Покажите макет, свойства ячейки - в ней указан параметр?

В самом документе оно заполнено?


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 19.03.18, 17:52
Сообщение #7

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 17:48 * ,
Я уже указывал ЕденицуИзмерения нечего не помогает, мне нужно в коде заполнить
ОбластьСтроки.Параметры.ЕденицаИзмерения = ТекущаяСтрока.ЕденицаИзмерения;
и в свойствах документа указать параметр к ячейке ЕденицаИзмерения?

logist Подменю пользователя
сообщение 19.03.18, 17:58
Сообщение #8

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Цитата(XacTLa @ 19.03.18, 17:52) *
Я уже указывал ЕденицуИзмерения нечего не помогает,

Цитата(logist @ 19.03.18, 17:49) *
Покажите макет, свойства ячейки - в ней указан параметр?



Покажите документ, в котором видно что реквизит заполнен


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 27.03.18, 14:44
Сообщение #9

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ 19.03.18, 18:58 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
        ОбластьСтроки.Параметры.ЕдиницаИзмеренияНаименование = ТекущаяСтрока.ЕдиницаИзмеренияНаименование;
                        ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции // СформироватьПечатнуюФорму()




и выдает ошибку что типо нет такого параметра как ЕдиницаИзмеренияНаименование хотя я его указал

Сообщение отредактировал Vofka - 27.03.18, 15:33

logist Подменю пользователя
сообщение 27.03.18, 15:51
Сообщение #10

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

На скрине у макета другое имя.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 27.03.18, 15:53
Сообщение #11

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 16:51 * ,
Как понять имя? одинаковый макет и свойства к нему

logist Подменю пользователя
сообщение 27.03.18, 16:09
Сообщение #12

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Цитата(XacTLa @ 27.03.18, 15:53) *
Как понять имя?

У вас в коде макет называется "МакетМаршрутныйЛист", а на скрине видно что курсор стоит на имени "ПФ_....."


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 27.03.18, 16:10
Сообщение #13

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 17:09 * ,
просто скрин верный а там стоит курсор на оригинальном маршрутном, так как пытался от туда взять данные извините если туплю.

logist Подменю пользователя
сообщение 28.03.18, 10:54
Сообщение #14

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Тогда возвращаемся к вопросу:
Цитата(logist @ 19.03.18, 17:58) *
Покажите документ, в котором видно что реквизит заполнен

А лучше в отладчике покажите что там что-то заполнено.


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

XacTLa Подменю пользователя
сообщение 29.03.18, 8:06
Сообщение #15

Говорящий
***
Группа: Пользователи
Сообщений: 59
Из: Киев
Спасибо сказали: 0 раз
Рейтинг: 0

logist @ Сегодня, 11:54 * ,


И даже когда вставляю ЕдиницаИзмерения, тоже такая ошибка, хотя данные беру с оригинального маршрутного листа, не могу понять в чем прикол, я уже и упаковку вставлял, и что только не пробовал нечего не выходит


 ! 

Правила: 8
 


Сообщение отредактировал Vofka - 29.03.18, 8:45

logist Подменю пользователя
сообщение 29.03.18, 11:21
Сообщение #16

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9266
Из: Харьков
Спасибо сказали: 2440 раз
Рейтинг: 1511.1

Тогда вернусь к варианту что вы используете не тот макет. Если вы сами не можете определить проблему, тогда без обследования больного специалистом можно только продолжать гадать...


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 20.04.18, 5:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне