Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> чтение ТХТ файла , построчное прочтение ТХТ файла          
cao0603 Подменю пользователя
сообщение 18.06.17, 18:16
Сообщение #1

Общительный
**
Группа: Пользователи
Сообщений: 45
Спасибо сказали: 0 раз
Рейтинг: 0

помогите пожалуйста, необходима или готова обработка или код,
форма,на форме кнопка при нажатии на которую мы выбираем файл ТХТ или не важно какой формат, но внутри это текстовый файл просто с другим расширение
и после выбора файла идет чтение построчное файла, потом парсинг в любом формате,и сохранение в другое место

nik389 Подменю пользователя
сообщение 18.06.17, 21:46
Сообщение #2

Общительный
**
Группа: Пользователи
Сообщений: 34
Из: Украина
Спасибо сказали: 9 раз
Рейтинг: 9

cao0603 @ Сегодня, 19:16 * ,
готовый код.. лень было писать - загуглил специально для вас:

выбор файла:
// Создать новый диалог для открытия файлов.
ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
// Какие типы файлов будут предложены для выбора.
ДиалогФыбораФайла.Фильтр = "Картинка (*.bmp)|*.bmp|Картинка формата jpg (*.jpg)|*.jpg";
ДиалогФыбораФайла.Заголовок = "Выберите файл";                                        
// В диалоге будет открыт предварительный просмотр файлов
ДиалогФыбораФайла.ПредварительныйПросмотр = Истина;
// При открытии диалога сначала для выбора будут предложены файлы
// первого типа, из типов, перечисленных в свойстве "Фильтр".
ДиалогФыбораФайла.ИндексФильтра = 0;
// Открыть диалог выбора файла.
Если ДиалогФыбораФайла.Выбрать() Тогда
   // Действия, выполняемые тогда, когда файл выбран.
КонецЕсли;


чтение файла
Процедура ЗагрузкаЛи()
    ТФ=Новый ТекстовыйДокумент;
    ТФ.Прочитать("c:\сотрудникиСчет93.txt");
    КолСтрок=ТФ.КоличествоСтрок();
    Для л=1 По КолСтрок Цикл
        Сообщить(" "+ТФ.ПолучитьСтроку(л));
    КонецЦикла;
КонецПроцедуры


сохранение думаю найдете сами.. гугл рулит

cao0603 Подменю пользователя
сообщение 19.06.17, 6:47
Сообщение #3

Общительный
**
Группа: Пользователи
Сообщений: 45
Спасибо сказали: 0 раз
Рейтинг: 0

А как потом из выбранного файла получить путь как на втором куске кода?

nik389 @ Вчера, 22:46 * ,
А как потом из выбранного файла получить путь как на втором куске кода?

nik389 Подменю пользователя
сообщение 19.06.17, 8:35
Сообщение #4

Общительный
**
Группа: Пользователи
Сообщений: 34
Из: Украина
Спасибо сказали: 9 раз
Рейтинг: 9

cao0603 @ Сегодня, 7:47 * ,
ДиалогВыбораФайла.ПолноеИмя кажись.. точку поставите - конфигуратор подскажет метод..

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.17, 6:01
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне