Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Вход | Зарегистрироваться )

> 1C 7.7 Проводки по зп          
Valerka1 Подменю пользователя
сообщение 05.02.18, 15:41
Сообщение #1

Молчаливый
*
Группа: Пользователи
Сообщений: 5
Спасибо сказали: 0 раз
Рейтинг: 0

Добрый день!
Помогите пожалуйста, в 1С 7.7 при формировании проводок на зарплату выбивает вот такая ошибка: ТекСчет = ТекПроводка.СчетДебета;{Документ.ФормированиеПроводокЗарплата.Модуль Документа(636)}: Значение не представляет агрегатный объект (СчетДебета)
Что это может быть?
Спасибо

Gazulo Подменю пользователя
сообщение 05.02.18, 15:55
Сообщение #2

Завсегдатай
****
Группа: Пользователи
Сообщений: 158
Спасибо сказали: 17 раз
Рейтинг: 17

Valerka1 @ Сегодня, 15:41 * ,
Справочники - Прочие- Формирование проводок-Хоз. операции. Где то там надо искать проблему

Valerka1 Подменю пользователя
сообщение 05.02.18, 16:05
Сообщение #3

Молчаливый
*
Группа: Пользователи
Сообщений: 5
Спасибо сказали: 0 раз
Рейтинг: 0

Gazulo @ Сегодня, 15:55 * ,
Спасибо за ответ, там уже все пересмотрели, все ок
Может ли быть в чем то еще проблема?

Gazulo Подменю пользователя
сообщение 05.02.18, 16:28
Сообщение #4

Завсегдатай
****
Группа: Пользователи
Сообщений: 158
Спасибо сказали: 17 раз
Рейтинг: 17

Valerka1 @ Сегодня, 16:05 * ,
Вот процедура для получения хоз. операции:
// порядок: Назначение => Подраделение => Категория
Функция ПолучитьХозОперацию(Сотрудник)                                
    ХозОперация = "";
    
    ОснНазн = Сотрудник.ОсновноеНазначение.Получить(КонМесяца(ДатаДок));
    
    Если ПустоеЗначение(ОснНазн.ХозОперация) = 0 Тогда
        ХозОперация = ОснНазн.ХозОперация;
    Иначе
        Подразделение = ОснНазн.МестоРаботы.Владелец;
        Пока (ПустоеЗначение(Подразделение.Родитель) = 0) и (ПустоеЗначение(Подразделение.ХозОперация) = 1) Цикл  
            Подразделение = Подразделение.Родитель;
        КонецЦикла;
        ХозОперация = Подразделение.ХозОперация;
        
        Если ПустоеЗначение(ХозОперация) = 1 Тогда
            Попытка
                Категория = ОснНазн.МестоРаботы.Должность.Категория;
            Исключение
                глКомментарий("Не могу определить Категорию по Назначению "+ОснНазн+" для Сотрудника "+Сотрудник,1);
                Категория = 0;
            КонецПопытки;
            ХозОперация = Категория.ХозОперация;
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат ХозОперация;
КонецФункции

Спасибо сказали: Valerka1,

Valerka1 Подменю пользователя
сообщение 05.02.18, 16:32
Сообщение #5

Молчаливый
*
Группа: Пользователи
Сообщений: 5
Спасибо сказали: 0 раз
Рейтинг: 0

Gazulo, Gazulo @ Сегодня, 16:28 * ,
Это нужно заходить через атладчик?
не совсем в этом понимаю, я просто бухгалтер(

Gazulo Подменю пользователя
сообщение 05.02.18, 16:48
Сообщение #6

Завсегдатай
****
Группа: Пользователи
Сообщений: 158
Спасибо сказали: 17 раз
Рейтинг: 17

Valerka1 @ Сегодня, 16:32 * ,
сначала в ОсновноеНазначение хоз. операция, если не заполнена тогда в подразделении хоз. операция, если и там не заполнено тогда в категории
проще посмотрите в основном назначении сотрудников, чтоб были заполнены хоз. операции. и к ним проводки

Zaval Подменю пользователя
сообщение 05.02.18, 16:52
Сообщение #7

Крутой
Иконка группы
Группа: Местный
Сообщений: 1993
Из: Киева и окрестностей
Спасибо сказали: 403 раз
Рейтинг: 256.9

Цитата(Valerka1 @ 05.02.18, 16:05) *
там уже все пересмотрели, все ок
Может ли быть в чем то еще проблема?

Тем не менее, в одной из проводок счет Дт не указан.
Попробуйте подумать, когда и после чего стала появляться ошибка.
Нпр, добавили подразделение...

logist Подменю пользователя
сообщение 05.02.18, 16:59
Сообщение #8

Про1С-ник
Иконка группы
Квалифицированный бухгалтерГений телепатии и социального моделированияЗа заслуги на форуме в 2010 годуМодератору Про1С (за заслуги в 2011 году)
Группа: Команда
Сообщений: 9334
Из: Харьков
Спасибо сказали: 2453 раз
Рейтинг: 1523.4

Цитата(Gazulo @ 05.02.18, 16:28) *
Вот процедура для получения хоз. операции:

Форум специально разделен на разделы для пользователей и программистов, поэтому не надо давать подобные ответы в разделе для пользователей


Signature
Весь комплекс услуг по 1С 8.х. От консультаций до внедрения. ИТС. 1С-Звіт. Интеграция IP-телефонии. Написание конфигураций под требования заказчика, доработка типовых решений. Переход с 7.7 на 8.х.
Пишите в ЛС. Звоните +380 (44) 2227507, (57) 7547700, (98) 5147778, (50) 7147778, (93) 2147778 (участник "САБ")

Valerka1 Подменю пользователя
сообщение 05.02.18, 17:07
Сообщение #9

Молчаливый
*
Группа: Пользователи
Сообщений: 5
Спасибо сказали: 0 раз
Рейтинг: 0

Zaval @ Сегодня, 16:52 * ,
это новое предприятие которое копировалось их старого, все налоги и хоз операции перенесены идентично

Zaval Подменю пользователя
сообщение 05.02.18, 17:15
Сообщение #10

Крутой
Иконка группы
Группа: Местный
Сообщений: 1993
Из: Киева и окрестностей
Спасибо сказали: 403 раз
Рейтинг: 256.9

Цитата(Valerka1 @ 05.02.18, 17:07) *
новое предприятие которое копировалось их старого

Там система подчиненных справочников. При бездумном применении "ввода копированием" такая картина и получается: все сделано, но не работает.

Спасибо сказали: Valerka1,

Valerka1 Подменю пользователя
сообщение 05.02.18, 17:21
Сообщение #11

Молчаливый
*
Группа: Пользователи
Сообщений: 5
Спасибо сказали: 0 раз
Рейтинг: 0

Valerka1 @ Сегодня, 16:32 * ,
у нас выбивает какую то ошибку, но не могу залить сюда фото, как это можно сделать?

Zaval @ Сегодня, 17:15 * ,
Спасибо за ответ

Не нашли ответа на свой вопрос?
Зарегистрируйтесь и задайте новый вопрос.


Ответить Новая тема
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 

RSS Текстовая версия Сейчас: 23.10.18, 22:53
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне