Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Печать двух экземпляров документа на одной странице
Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 > Программисту > Программирование в 1С Предприятие 8.2 > Программирование обычных форм 1С 8.2 и не интерфейсной логики
f12
Добрый день.
К сожалению я не 1С программист (сейчас изучаю это дело..), но бухгалтер. Необходимо постоянно распечатывать два экземпляра документов (расх.накладная, счет, акт вып.работ) на 1 странице.
Стандартные настройки 1С не срабатывают. Подскажите где и как подправить...
Используем - 1С Бухгалтерия 8.2
Flexy
Не подскажу как в 8-ой версии, но в 7-ке есть такая штука, как методы таблиц.Там есть метод "КоличествоЭкземпляровНаСтранице".
ЭкземпляровНаСтранице(<?>)
Синтаксис:
ЭкземпляровНаСтранице(<Колво>)
Назначение:
Определить количество печатаемых экземпляров на странице. Возвращает: текущее числовое значение количества печатаемых экземпляров на странице (на момент до исполнения метода).
Параметры:
<Колво> - число печатаемых экземпляров на странице. Может принимать значения:
1 - один экземпляр на странице
2 - два экземпляра на странице
0 - автоматический режим размещения двух экземпляров на странице исходя из размеров документа.
Замечание:
Метод может использоваться при работе с таблицей в режиме ввода данных.

Поройтесь в Синтаксис-помощнике...думаю там должно быть что-то подобное.
f12
Цитата(Flexy @ 24.01.11, 17:31) необходимо зарегистрироваться для просмотра ссылки
Не подскажу как в 8-ой версии, но в 7-ке есть такая штука, как методы таблиц.Там есть метод "КоличествоЭкземпляровНаСтранице".
ЭкземпляровНаСтранице(<?>)
Синтаксис:
ЭкземпляровНаСтранице(<Колво>)
Назначение:
Определить количество печатаемых экземпляров на странице. Возвращает: текущее числовое значение количества печатаемых экземпляров на странице (на момент до исполнения метода).
Параметры:
<Колво> - число печатаемых экземпляров на странице. Может принимать значения:
1 - один экземпляр на странице
2 - два экземпляра на странице
0 - автоматический режим размещения двух экземпляров на странице исходя из размеров документа.
Замечание:
Метод может использоваться при работе с таблицей в режиме ввода данных.

Поройтесь в Синтаксис-помощнике...думаю там должно быть что-то подобное.

===============================
Да, нашел я где можна это дело подправить (В универсальных механизмах), но есть одно но..
Процедура НапечататьДокумент(ПечДокумент, КоличествоЭкземпляров = 2, НаПринтер = Истина, Заголовок = "", НепосредственнаяПечать = Ложь, Ссылка = Неопределено, ИмяМакета = "") Экспорт
    Если ПечДокумент = Неопределено тогда
        Возврат;
    КонецЕсли;

    // Получить необходимое количество копий
    Если КоличествоЭкземпляров > 1 Тогда
        ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров;
    КонецЕсли;

    Если НЕ ПечДокумент.АвтоМасштаб
       И НЕ ЗначениеЗаполнено(ПечДокумент.ИмяПринтера) Тогда
        ПечДокумент.АвтоМасштаб = Истина;
    КонецЕсли;

    Если НаПринтер Тогда

        ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);

    Иначе

Изменил я количество с 1 на 2. Но не печатает 2 экземпляра на 1 странице. Только когда укажу количество копий = 2, то тогда действительно печатает одну страницу с двумя экземплярами документа на ней, но ведь по лигике (как я понимаю) - раз указано 2 экземпляра на одной странице - значит не нужно указывать еще и количество копий 2.
Может еще где-нибудь необходимо подправить, что-бы действительно при необходимости печаталось два екземпляра на ОДНОЙ!!! странице...
DneprPepe
Цитата(f12 @ 24.01.11, 17:06) необходимо зарегистрироваться для просмотра ссылки
Добрый день.
К сожалению я не 1С программист (сейчас изучаю это дело..), но бухгалтер. Необходимо постоянно распечатывать два экземпляра документов (расх.накладная, счет, акт вып.работ) на 1 странице.
Стандартные настройки 1С не срабатывают. Подскажите где и как подправить...
Используем - 1С Бухгалтерия 8.2

Через внешние печатные формы. Вот расходная и счет две на одном листе необходимо зарегистрироваться для просмотра ссылки + инструкция. Сделано для 1С Бухгалтерии 8.2. Перед печать не забываем ставить настройки печати по ширине и ландшафт. Акт сделайте по подобию.
f12
Цитата(DneprPepe @ 25.01.11, 10:42) необходимо зарегистрироваться для просмотра ссылки
Через внешние печатные формы. Вот расходная и счет две на одном листе необходимо зарегистрироваться для просмотра ссылки + инструкция. Сделано для 1С Бухгалтерии 8.2. Перед печать не забываем ставить настройки печати по ширине и ландшафт. Акт сделайте по подобию.

===============================
Супер!!! То, что надо!!!
Orelka
Цитата(DneprPepe @ 25.01.11, 11:42) необходимо зарегистрироваться для просмотра ссылки
Через внешние печатные формы. Вот расходная и счет две на одном листе необходимо зарегистрироваться для просмотра ссылки + инструкция. Сделано для 1С Бухгалтерии 8.2. Перед печать не забываем ставить настройки печати по ширине и ландшафт. Акт сделайте по подобию.

Перезалейте плиз еще, ссылка не доступна
27vk
Цитата(Orelka @ 08.02.11, 9:32) необходимо зарегистрироваться для просмотра ссылки
Перезалейте плиз еще, ссылка не доступна



Поделитесь плиз.
loginlogin
Открываете, к примеру, расходную накладную (или тот документ, который вам нужно напечатать 2 экземпляра на 1 листе), нажимаете кнопку "расходная накладная" для вывода дока на печать, далее жмем - файл, предварительный просмотр, параметры страницы (это такие две стрелки перпендикулярные), внизу есть блок - "экземпляров на страницу", выбираем "2", нажимаем "ок" и печать. Теперь все документы данного типа (т.е. именно того где вы делали данную настройку, в нашем случае расходные накладные) всегда будут печататься по 2 штуки на одной странице. Другие доки (например - налоговые, счета и т.д.)будут печататься по 1 экземпляру на 1 страницу. Если нужна настройка на другой тип документа, то делаем тоже самое при выводе на печать этого дока.
logist
Цитата(loginlogin @ 30.07.15, 10:14) необходимо зарегистрироваться для просмотра ссылки
Теперь все документы данного типа

Уточню - не документы данного типа, а конкретная печатная форма, если у документа несколько печатных форм, то настройка сохраняется для каждой отдельно (в типовых решениях)
Kami4
DneprPepe @ 25.01.11, 12:42 необходимо зарегистрироваться для просмотра ссылки ,
Презалейте плиз........

f12 @ 25.01.11, 13:36 необходимо зарегистрироваться для просмотра ссылки ,
Перезалейте плиз....
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.