Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Flexy ::: Спасибо сказали: 199 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
16.10.17, 16:14 Как можно сохранить значения ТЗ в нормальный документ в формате csv?
lensky @ Сегодня, 15:18 * ,
тДок = Новый ТекстовыйДокумент;
Для Каждого Строка Из ТЗ Цикл
тДок.ДобавитьСтроку(Строка.Знач1 + ";" + Строка.Знач2 + ";" + Строка.Знач3);
КонецЦикла;
тДок.Записать("D:\MyCsv.csv");
lensky,
12.10.17, 11:56 УникальныйИдентификатор() запросом
Цитата(lensky @ 12.10.17, 11:40) *
А как отобрать по данным КА из ТЗ (запрос выгружен в ТЗ) УИД и добавить отдельной колонкой. Прошу прощение за наглость, конечно, но я начинающий.

Т = Запрос.Выполнить().Выгрузить();
Т.Колонки.Добавить("УИД");
Для Каждого Стр Из Т Цикл
Стр.УИД = Стр.Контрагент.УникальныйИдентификатор();
КонецЦикла;
lensky,
12.10.17, 10:18 УникальныйИдентификатор() запросом
lensky @ Сегодня, 10:15 * ,
В запросе - никак.
УИД = Выборка.Контрагент.УникальныйИдентификатор();
lensky,
11.10.17, 10:06 Помогите пожалуйста поправить запрос
"ВЫБРАТЬ
|    Номенклатура.Ссылка КАК Товар
|ПОМЕСТИТЬ втТовары
|ИЗ
|    Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|    Номенклатура.Ссылка В ИЕРАРХИИ(&Категория)
|    И Номенклатура.ЭтоГруппа = ЛОЖЬ
|    И Номенклатура.ПометкаУдаления = ЛОЖЬ
|    И НЕ Номенклатура.ВидНоменклатуры В (&ВидыНоменклатуры)
|
|ИНДЕКСИРОВАТЬ ПО
|    Товар
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
|    втТовары.Товар,
|    ЕСТЬNULL(ТоварыНаСкладахОстатки.КоличествоОстаток, 0) КАК Остаток,
|    ЕСТЬNULL(ЦеныНоменклатурыСрезПоследних.Цена, 0) КАК Цена
|ИЗ
|    втТовары КАК втТовары
|        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах.Остатки(
|                ,
|                Номенклатура В
|                        (ВЫБРАТЬ
|                            втТовары.Товар
|                        ИЗ
|                            втТовары)
|                    И Склад = &СкладОстатков) КАК ТоварыНаСкладахОстатки
|        ПО втТовары.Товар = ТоварыНаСкладахОстатки.Номенклатура
|        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
|                ,
|                Номенклатура В
|                        (ВЫБРАТЬ
|                            втТовары.Товар
|                        ИЗ
|                            втТовары)
|                    И ТипЦен = &ТипЦенНоменклатуры) КАК ЦеныНоменклатурыСрезПоследних
|        ПО втТовары.Товар = ЦеныНоменклатурыСрезПоследних.Номенклатура
|
|УПОРЯДОЧИТЬ ПО
|    втТовары.Товар.Наименование"
berkut_0,
03.10.17, 11:40 Программное управление справочниками и документами в режиме "ТолькоПросмотр"
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
       Отказ = Не ОбщийМодульПроверкаДоступа.ПроверитьДоступ(ТекущийПользователь, ТекущийДокумент);
           // ТолькоПросмотр = ОбщийМодульПроверкаДоступа.ПроверитьДоступ(ТекущийПользователь, ТекущийДокумент);
КонецПроцедцры

...

// Общий модуль
Функция ПроверитьДоступ(ТекущийПользователь, ТекущийДокумент) Экспорт
      Запрос = НовыйЗапрос("ВЫБРАТЬ РежимПросмотра ИЗ РегистрСВ ... ГДЕ Пользователь = &ТекущийПользователь И Документ = &ТекущийДокумент);
      Результат = Запрос.Выполнить().Выбрать();
     РазрешенДоступ = Ложь;
      Если Результат.Следующий() Тогда
      Разрешен.Доступ = Результат.РежимПросмотра;
      КонецЕсли;

      Возврат РазрешенДоступ;

КонецФункции
Constantus,
01.09.17, 21:45 как очистить сообщение на сервере
Ооочень много букв. На сервере нет форм в явном виде, что бы отработал данный метод.
Вы наверное не очень понимаете архитектуру "клиент-сервер".

Если по делу, то имхо метода такая:
1. С клиента вызываете функцию на сервере, которая делает что-то и возвращает результат на клиента.
2. На клиенте получаете результат и обрабатываете его.
3. Если в процессе обработки результат нужно выводить/очищать сообщения на клиенте - используете для этого методы доступные на клиенте.

Реализацию процента выполнения процедуры/функции описали выше. Так же, можно посмотреть более детально, как это реализовано в БСП.

Цитата(sava1 @ 01.09.17, 14:53) *
Цитата(Gigi @ 01.09.17, 15:21)
нет времени разбираться.

А написать столько буков есть?

laugh.gif
Gigi,
31.08.17, 11:30 Список значений в строку
Спис = Новый СписокЗначений;
Спис.Добавить(1);
Спис.Добавить(2);
Спис.Добавить(3);
Спис.Добавить(4);
Спис.Добавить(5);
Результат = "";
Для Каждого Элем Из Спис Цикл
Результат = ?(Спис.Индекс(Элем) > 0,  Результат+","+Элем.Значение, Результат+Элем.Значение)     
КонецЦикла;
salton,
25.08.17, 17:00 Не получается добавить нужные колонки в номенклатуру
ГДЕ
    НЕ СпрНоменклатура.ЭтоГруппа И
    ЦеныНоменклатурыСрезПоследних.ВидЦены.Наименование = ""Розничная""
Bulzavr,
21.08.17, 10:53 Аналог функции ПолучитьЦенуНоменклатуры
ПродажиСервер.ПолучитьЦенуПоОтбору(ПараметрыОтбора)
ЗакупкиСервер.ПолучитьЦенуПоОтбору(ПараметрыОтбора)
Pashaboston,
12.08.17, 14:35 Отчеты в скд
Murano @ Сегодня, 13:50 * ,
Е.Ю. Хрусталева - Разработка сложных отчетов.

А вообще пройдитесь поиском по форуму...данных на эту тему полно.
Murano,
08.08.17, 15:12 Как перенести журнал регистрации полностью в регистр сведений
ЕстьОшибки = Ложь;
    
    Попытка
        
        ТЗ = Новый ТаблицаЗначений;
        ВыгрузитьЖурналРегистрации(ТЗ);
        
        // Запись ТЗ в РС
        Рег = РегистрыСведений.РегЖР.СоздатьНаборЗаписей();
        Рег.Загрузить(ТЗ);
        Рег.Записать();
        
    Исключение
        
        ЕстьОшибки = Истина;
        //Сообщить(ОписаниеОшибки());
        
    КонецПопытки;
    
    Если Не ЕстьОшибки Тогда
        // Очистка ЖР
        Фильтр = Новый Структура; // пустой фильтр
        ОчиститьЖурналРегистрации(Фильтр);
    КонецЕсли;
cao0603,
02.08.17, 16:13 Себестоимость при формировании возврата от покупателя
Цитата(Zene4ka @ 02.08.17, 15:59) *
От чего это зависит?

От видов запасов. Вы делаете возврат товара, который не имеет вида запаса. Т.е. Вы его как бы не проводили по партиям и не продавали ранее.
Zene4ka,
21.07.17, 14:27 Запрос во внешнем отчёте
Цитата(roman457 @ 21.07.17, 14:24) *
Увы но комментировать нельзя нужен результат по условиям с текстом автора. в ответе выше моего . спасибо .

ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&ТекДата, &УСловиеСоставное )

Условие в параметрах виртуальной таблицы не подходит?
roman457,
07.07.17, 10:05 Ошибка блокировки информационной базы для конфигурирования
Цитата(Vidocq05 @ 06.07.17, 14:54) *
Пытаюсь запустить конфигуратор под пользователем "Тест" - пишет "Ошибка блокировки информационной базы для конфигурирования".

Если не ошибаюсь, у каждого пользователя хранилища должна быть "своя" база из которой происходит подключение к хранилищу. А Вы вторым пользователем пытаетесь открыть конфигуратор, который уже используется.
Vidocq05,
05.07.17, 15:11 Собственная обработка расшифровке в макете отчета
Constantus @ Сегодня, 13:47 * ,
Процедура ПолеТабличногоДокументаРезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    Сп = Новый СписокЗначений;
    Сп.Добавить(1);
    Сп.Добавить(2);
    Рез = Сп.ВыбратьЭлемент("Выберите документ");
    Если Не Рез = Неопределено Тогда
        ОткрытьЗначение(Рез);
    КонецЕсли;

КонецПроцедуры


Или так:
Процедура ПолеТабличногоДокументаРезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
Если ТипЗнч(Расшифровка) = Тип("СписокЗначений") Тогда
Если Расшифровка.Количество() > 1 Тогда
// документы в списке должны быть одного типа.
СтандартнаяОбработка = Ложь;
ФормаСп = Документы.РеализацияТоваровУслуг.ПолучитьФорму("ФормаСписка",,ЭтаФорма);
ФормаСп.Отбор.Ссылка.Использование = Истина;
ФормаСп.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
ФормаСп.Отбор.Ссылка.Значение = Расшифровка;
ФормаСп.Открыть();
КонецЕсли;
КонецЕсли;
КонецПроцедуры


З.Ы. Не проверял.

Цитата(Constantus @ 05.07.17, 13:47) *
Область.Параметры.расшифровка = Документы.Рейс.НайтиПоНомеру(ВыборкаЭкс.Номер);

faceoff.gif
Почему не воткнуть сразу ссылку на документ (ВыборкаЭкс.Ссылка)???
Constantus,
03.07.17, 15:01 Как записать постоянное значение индивидуального доступа
Gigi @ Сегодня, 14:58 * ,
Что бы рулить сохраненными значениями формы есть события формы:
&НаСервере
Процедура ПриЗагрузкеДанныхИзНастроекНаСервере(Настройки)
    //Вставить содержимое обработчика
КонецПроцедуры

&НаСервере
Процедура ПриСохраненииДанныхВНастройкахНаСервере(Настройки)
    //Вставить содержимое обработчика
КонецПроцедуры

Там уже можно писать свою логику.
Gigi,
03.07.17, 14:33 Как записать постоянное значение индивидуального доступа
Используйте АвтоматическоеСохранениеДанныхВНастройках. Это в свойствах формы.
Gigi,
03.07.17, 11:59 Создать общую процедуру из процедуры на форме
Цитата(Constantus @ 03.07.17, 11:56) *
Как правильно передать значения?

Передавайте туда имена элементов формы строкой.
Мой.УстановитьДоступностьСкладов(ЭтаФорма,"ДокументСписок", "ПолеВыбора1", ПараметрыСеанса.ТекущийПользователь);
Constantus,
03.07.17, 11:28 Перенос справочника по владелцу
Цитата(Vidocq05 @ 03.07.17, 10:36) *
впихнуть туда запрос как у Контрагентов и добавить левое соединение по Справочник.ДоговорыКонтрагентов это не оптимально

Имхо это оптимальней, чем "запрос в цикле", который Вы нашли в интернете smile.gif
Vidocq05,
23.06.17, 16:22 Установить режим Только просмотр на реквизит ТЧ
// на клиенте
Элементы.ИмяЭлементаСтолбцаТаблицы.ТолькоПросмотр = Истина;


Пример:
Элементы.ТоварыНоменклатураАртикул.ТолькоПросмотр = Истина;
Gigi,
15.06.17, 15:09 Проверка открытия формы Справочника/документа
Gigi @ Сегодня, 14:54 * ,
Как-то так...
КоллекцияОкон = ПолучитьОкна();
    Для Каждого Окно Из КоллекцияОкон Цикл
        КоллекцияСодержимое = Окно.Содержимое;
        Для Каждого Содержимое Из КоллекцияСодержимое Цикл
            Сообщить(Содержимое.ИмяФормы);
        КонецЦикла;
    КонецЦикла;
Gigi,
31.05.17, 16:16 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 16:08) *
"ОбъектПринадл" это реквизит справочника "ТОЧКА". Его тип ССЫЛКА.
Вопрос в том, как в этот реквизит вставить просто текст...

Сделайте тип этого реквизита строкой и...вставляйте...
Gigi,
30.05.17, 16:31 УТ 3.1 редагування рухів регістру РасчетыСПоставщикамиПоДокументам
SaintDaemon @ Сегодня, 16:29 * ,
Наверное не был включен флаг: Отладка => Подключение => Автоматическое подключение => Фоновые задания
SaintDaemon,
29.05.17, 13:22 Как обозначить пустой результат списка
Gigi @ Сегодня, 13:12 * ,
Велосипед smile.gif
&НаКлиенте
Процедура Отобор_СубТочки()
ЗначениеОтбора="" +Объект.Код;
СтолбецОтбора="СнабжКод";    
//==========================
Если ЗначениеОтбора="" Тогда
ЗначениеОтбора="----";
КонецЕсли;
//==========================
Отбор = СубТочкиСписок.Отбор.Элементы;
СубТочкиСписок.Отбор.Элементы.Очистить();
//==========================
ЭлементОтбора=СубТочкиСписок.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ПравоеЗначение=ЗначениеОтбора;
ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных(СтолбецОтбора);
ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование=ИСТИНА;
//==========================
// Flexy
Элементы.МояКнопка.Доступность = Не Элементы.Список.ТекущаяСтрока = Неопределено;
//-----
КонецПроцедуры
Gigi,
17.05.17, 14:33 Где найти документацию по обмену с сайтом?
Вот именно при обмене с Битрикс ни какие Вэб-сервисы не используются. А происходит передача с 1С на сайт фала XML по http.
1С htpp соединением вызывает скрипт http://сайт/bitrix/admin/1c_exchange.php с параметрами авторизации.
Если прошли авторизацию в ответе с сайта приходит success, куки и токен. Куки далее используются для формирования заголовка запроса к сайту.
Не прошли авторизацию - сайт возвращает код ошибки.
Потом нужно передать скрипту тип обработки из 1С (catalog - товары, sale - заказы) - ""http://pro1c.org.ua/redirect.php?http://сайт/bitrix/admin/1c_exchange.php?type="catalog"""
И произвести отправку xml по http. Ответ сервера success или код ошибки.

Как-то так.

Если нужны конкретные детали возьмите свежую УТшку и посмотрите модули обмена с сайтом.
zey_ser,

7 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 24.10.17, 9:43
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне