Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Flexy ::: Спасибо сказали: 179 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
23.06.17, 16:22 Установить режим Только просмотр на реквизит ТЧ
// на клиенте
Элементы.ИмяЭлементаСтолбцаТаблицы.ТолькоПросмотр = Истина;


Пример:
Элементы.ТоварыНоменклатураАртикул.ТолькоПросмотр = Истина;
Gigi,
15.06.17, 15:09 Проверка открытия формы Справочника/документа
Gigi @ Сегодня, 14:54 * ,
Как-то так...
КоллекцияОкон = ПолучитьОкна();
    Для Каждого Окно Из КоллекцияОкон Цикл
        КоллекцияСодержимое = Окно.Содержимое;
        Для Каждого Содержимое Из КоллекцияСодержимое Цикл
            Сообщить(Содержимое.ИмяФормы);
        КонецЦикла;
    КонецЦикла;
Gigi,
31.05.17, 16:16 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 16:08) *
"ОбъектПринадл" это реквизит справочника "ТОЧКА". Его тип ССЫЛКА.
Вопрос в том, как в этот реквизит вставить просто текст...

Сделайте тип этого реквизита строкой и...вставляйте...
Gigi,
30.05.17, 16:31 УТ 3.1 редагування рухів регістру РасчетыСПоставщикамиПоДокументам
SaintDaemon @ Сегодня, 16:29 * ,
Наверное не был включен флаг: Отладка => Подключение => Автоматическое подключение => Фоновые задания
SaintDaemon,
29.05.17, 13:22 Как обозначить пустой результат списка
Gigi @ Сегодня, 13:12 * ,
Велосипед smile.gif
&НаКлиенте
Процедура Отобор_СубТочки()
ЗначениеОтбора="" +Объект.Код;
СтолбецОтбора="СнабжКод";    
//==========================
Если ЗначениеОтбора="" Тогда
ЗначениеОтбора="----";
КонецЕсли;
//==========================
Отбор = СубТочкиСписок.Отбор.Элементы;
СубТочкиСписок.Отбор.Элементы.Очистить();
//==========================
ЭлементОтбора=СубТочкиСписок.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ПравоеЗначение=ЗначениеОтбора;
ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных(СтолбецОтбора);
ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование=ИСТИНА;
//==========================
// Flexy
Элементы.МояКнопка.Доступность = Не Элементы.Список.ТекущаяСтрока = Неопределено;
//-----
КонецПроцедуры
Gigi,
17.05.17, 14:33 Где найти документацию по обмену с сайтом?
Вот именно при обмене с Битрикс ни какие Вэб-сервисы не используются. А происходит передача с 1С на сайт фала XML по http.
1С htpp соединением вызывает скрипт http://сайт/bitrix/admin/1c_exchange.php с параметрами авторизации.
Если прошли авторизацию в ответе с сайта приходит success, куки и токен. Куки далее используются для формирования заголовка запроса к сайту.
Не прошли авторизацию - сайт возвращает код ошибки.
Потом нужно передать скрипту тип обработки из 1С (catalog - товары, sale - заказы) - ""http://pro1c.org.ua/redirect.php?http://сайт/bitrix/admin/1c_exchange.php?type="catalog"""
И произвести отправку xml по http. Ответ сервера success или код ошибки.

Как-то так.

Если нужны конкретные детали возьмите свежую УТшку и посмотрите модули обмена с сайтом.
zey_ser,
22.04.17, 9:37 Как определить, что база запущена на андроиде?
Gavrila @ Вчера, 23:36 * ,
Что значит на Андроиде или вэб клиенте? Вы сравниваете ОС с Браузером?

По теме:
СисИнфо = Новый СистемнаяИнформация;
Сообщить(СисИнфо.ВерсияОС); // OS
Сообщить(СисИнфо.ИнформацияПрограммыПросмотра); // Browser
Сообщить(СисИнфо.ТипПлатформы); // Platform type
Gavrila,
06.04.17, 16:20 Как сделать ссылку на файл ipg
fillya @ Сегодня, 15:47 * ,
Через таблицу.
Если фс.СуществуетФайл(Ссылка на файл) = 1 Тогда
Таб.ТекущийОбьект.Загрузить(СсылкаНаФайл);
...
Таб.Вывести();
...
Таб.Показать() / Таб.Напечатать()
.

Как-то так
fillya,
06.04.17, 14:47 Как в СКД заблокировать вывод при условии?
Цитата(cos12 @ 06.04.17, 14:45) *
брать полность все значения через регистр?

Именно. Можете глянуть запрос в СКД штатной ведомости.
cos12,
06.04.17, 9:30 Как сделать ссылку на файл ipg
ИмяФайла="";
ИмяНачКаталога = "";
Если ФС.ВыбратьФайл(0,ИмяФайла, ИмяНачКаталога,,,,) = 1 Тогда
    СсылкаНаФайл = ИмяНачКаталога+ИмяФайла;
КонецЕсли;
fillya,
05.04.17, 16:04 Как програмно в печатной форме можно поменять цвет текста
    
Рез = Таб.ЗначениеТекущейЯчейки("R1C1");
Если Рез < 0 Тогда
Секция = Таб.ПолучитьСекцию("Строка");
Секция.Область("Товар").ЦветТекста(225,225,225); // Область("R1C1:R2C2")
КонецЕсли;


А вообщем это имхо делать удобней на этапе вывода таблицы:
Секция = Таб.ПолучитьСекцию("Строка");
Сумма = ПолучитьСумму(Запрос);
Если Сумма < 0 Тогда
Секция.Область("Товар").ЦветТекста(225,225,225); // Область("R1C1:R2C2")
КонецЕсли;
Таб.ВывестиСекцию(Секция);



leo10k10,
05.04.17, 11:07 Подскажите или есть метод который по заданой дате определяет предыдущую дату
Вчера = ТекущаяДата() - 1;
leo10k10,
30.03.17, 11:12 Синхронизация 1С через ESB-системы
Цитата(Bernet @ 30.03.17, 10:37) *
Можно подробнее с чем связаны грабли?

Одна из граблей - это то, что зачастую пытаются натянуть эту "шину" на "горячую" (рабочую) инфраструктуру различного ПО, особо не заморачивась на разработку самой модели взаимодействия между этим ПО.
Цитата(Bernet @ 30.03.17, 10:37) *
но до меня не доходит как будет выглядеть окончательный обмен между двумя конфигурациями: скажем УТП и Документооборот, обменяться справочником "Контрагенты"

Мне кажется Вы не до конца понимаете суть шины. Это что-то вроде очень гибкого и удобного транспорта для обмена сообщением между всем и вся с возможностью использовать транзакции и прочие фитчи. Но имхо, это не панацея для решения вопрос синхронизации. Все равно придется описывать типы, правила, маршруты, схемы...и пилить....пилить...конфиг 1с.


Bernet,
22.03.17, 14:10 СтандартнаяОбработка на булево дополнительного реквизита
Зачем так сложно? 47046430.gif
Процедура ПриОткрытии()
ЭлементыФормы.ФлагУтверждаю.Доступность = Не УправлениеДопПравамиПользователей.РазрешитьУтверждение();
КонецПроцедуры
candrey,
10.03.17, 15:02 Печать Отчета на принтер прграммно
Процедура ПриОткрытии() Экспорт
...
ПроцессорВывода.Вывести(ПроцессорКомпоновки);
Если ПечатьНаПринтер Тогда
ТабДок.Напечатать();
КонецЕсли;
...


обработка_печати = Отчеты.ПечатьТоваровИзРейса1.Создать();
обработка_печати.Рейс = Рейс;
обработка_печати.ДатаПечати = Рейс.ДатаДоставки;
обработка_печати.БезСумм = БезСумм;
обработка_печати.ТолькоИтоги = ТолькоИтоги;
// Flexy
форма = обработка_печати.ПолучитьФорму();
Режим = РежимДиалогаВопрос.ДаНет;
Ответ = Вопрос("Печатать сразу на принтер?", Режим);
Если Ответ = КодВозвратаДиалога.Да Тогда
обработка_печати.ПечатьНаПринтер = Истина;
Форма.ПриОткрытии();
Возврат;
КонецЕсли;
//-----        

форма.ЭлементыФормы.Рейс.Доступность = Ложь;
форма.Открыть();
Constantus,
02.03.17, 12:04 Хранение цвета в реквизите справочника
Цитата(bizisoft @ 02.03.17, 11:54) *
Я правильно понимаю данный реквизит должен быть типа ХранилищеЗначенй?

Правильно.
bizisoft,
01.03.17, 14:28 Хранение цвета в реквизите справочника
Цитата(bizisoft @ 01.03.17, 12:58) *
Как можно к реквизиту цвет прикрепить кнопку для выбора цвета из палитры

ДиалогВыбораЦвета (ColorChooseDialog)

Цитата(bizisoft @ 01.03.17, 12:58) *
как можно хранить выбор в реквизите?

Реквизит для цвета с типом ХранилищеЗначения
bizisoft,
27.02.17, 13:45 Беспроводной сканер штрих кода CINO F790WD
Цитата(sanytch @ 27.02.17, 1:03) *
НО сопрягти это с 1С не пойму как. Подскажите как можно (если конечно можно) на стороне 1С выполнить код С#.

Не надо выполнять код на C# В 1С 32541510.gif
В Visual Studio пишите консольную утилиту, которая принимает аргументы, к примеру "Строка передачи в сканер" и параметры COM.
Компилируйте ее в exe.
Проверяйте из командной строки Windows, как оно работает.
Потом в 1С запускайте ее через КомандаСистемы(ПутьКонсольнойУтилите.exe +ПараметрыИз1С)
Как-то так.

P.S. Кстати, есть достаточно спорный вопрос в реализации данной задачи. Придется постоянно закрывать COM-порт, который занимает 1С для отправки в него данных из консольной утилиты.
Т.к. 1С слушает COM - на вход, а после получения данных в 1С этот порт надо закрыть и открыть по новой для отправки.
Имхо Вам наверное больше ТСД нужен для решения данной задачи. Хотя....можно попробовать поизвращаться.
sanytch,
23.02.17, 17:05 Проверка регистра накопления перед записью
Если Не Результат.Пустой() Тогда

Выборка = Результат.Выбрать();
Выборка.Следующий();

Если Выборка.СуммаОстаток < СуммаВБазовойВалюте Тогда
Отказ = Истина;
Сообщить("Сумма больше чем Бюджет")
КонецЕсли;

КонецЕсли;
burza,
23.02.17, 16:24 Проверка регистра накопления перед записью
Опять не правильные имена переменных. Подставляйте свои.
burza,
23.02.17, 15:50 Проверка регистра накопления перед записью
Цитата(burza @ 23.02.17, 15:06) *
Что в запросе нужно дописать?

ГДЕ 
    Подразделение = &Подразделение И Назначение = &Назначение
burza,
23.02.17, 14:51 Проверка регистра накопления перед записью
В Вашей самописной конфигурации хоть в каком нибудь документе есть контроль превышения остатков?
Что бы 100 раз перепроводить документ, который контролирует остаток нужно перед проведением удалять его движения из регистра.
burza,
23.02.17, 13:53 Проверка регистра накопления перед записью
Потому што на дату проведения эта сумма = 0. Вы пытаетесь провести расход раньше чем было поступление.
burza,
23.02.17, 13:32 Проверка регистра накопления перед записью
Если Выборка.СуммаОстаток < СуммаВБазовойВалюте Тогда
Отказ = Истина;
КонецЕсли;
burza,
23.02.17, 13:27 Проверка регистра накопления перед записью
БюджетРасходовИПриходов <> ОстаткиБюджетРасходовИПриходов
burza,

7 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 29.06.17, 0:44
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне