Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Dartvader111 ::: Спасибо сказали: 7 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
20.02.19, 17:06 Требуется программист 1с7 и 1с8
Petre @ Сегодня, 16:55 * ,
По поводу верхней поясню, хочется что бы подчиненный был не старше начальника, оба ограничения условные, так как правильно заметили бывает что человек в 20 знает больше чем кто то в 40 , и наоборот в 50 знает больше чем 40 и выглядит лучше, соответсвенно если Вы в в 60 лет выглядите на 40 и знаете на 60 (27 лет стажа 1с) то тоже принимаем! Либо выглядите хорошо и знаете много в свои 20 так же милости просим!
awp,
22.01.19, 10:15 Отчет по движению товара Розница 2.х с Аналитикой операции
я бы сделал как то так...
ВЫБРАТЬ
    ТоварыНаСкладахОстатки.Склад,
    ТоварыНаСкладахОстатки.КоличествоОстаток КАК КоличествоНаНачало,
    ТоварыНаСкладахОстатки.Номенклатура
ПОМЕСТИТЬ НачальныйОстаток
ИЗ
    РегистрНакопления.ТоварыНаСкладах.Остатки(&ДатаНачала, ) КАК ТоварыНаСкладахОстатки
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ТоварыНаСкладахОстатки.Склад,
    ТоварыНаСкладахОстатки.Номенклатура,
    ТоварыНаСкладахОстатки.КоличествоОстаток КАК КоличествоКонечныйОстаток
ПОМЕСТИТЬ КонечныйОстаток
ИЗ
    РегистрНакопления.ТоварыНаСкладах.Остатки(&ДатаОкончания, ) КАК ТоварыНаСкладахОстатки
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ТоварыНаСкладах.АналитикаХозяйственнойОперации,
    ТоварыНаСкладах.Регистратор,
    ТоварыНаСкладах.Период,
    ТоварыНаСкладах.Склад,
    ТоварыНаСкладах.Номенклатура,
    ТоварыНаСкладах.Количество КАК КоличествоДвижения,
    ТоварыНаСкладах.ВидДвижения
ПОМЕСТИТЬ ДвиженияВПериоде
ИЗ
    РегистрНакопления.ТоварыНаСкладах КАК ТоварыНаСкладах
ГДЕ
    ТоварыНаСкладах.Период МЕЖДУ &ДатаНачала И &ДатаОкончания
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    НачальныйОстаток.Склад КАК Склад,
    НачальныйОстаток.Номенклатура КАК Номенклатура,
    НачальныйОстаток.КоличествоНаНачало,
    0 КАК ВидДвижения,
    0 КАК АналитикаХозяйственнойОперации,
    0 КАК Регистратор,
    0 КАК Период,
    0 КАК КоличествоДвижения,
    0 КАК КоличествоКонечныйОстаток
ИЗ
    НачальныйОстаток КАК НачальныйОстаток

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    КонечныйОстаток.Склад,
    КонечныйОстаток.Номенклатура,
    0,
    NULL,
    NULL,
    NULL,
    NULL,
    0,
    КонечныйОстаток.КоличествоКонечныйОстаток
ИЗ
    КонечныйОстаток КАК КонечныйОстаток

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ
    ДвиженияВПериоде.Склад,
    ДвиженияВПериоде.Номенклатура,
    0,
    ДвиженияВПериоде.ВидДвижения,
    ДвиженияВПериоде.АналитикаХозяйственнойОперации,
    ДвиженияВПериоде.Регистратор,
    ДвиженияВПериоде.Период,
    ДвиженияВПериоде.КоличествоДвижения,
    0
ИЗ
    ДвиженияВПериоде КАК ДвиженияВПериоде

УПОРЯДОЧИТЬ ПО
    Склад,
    Номенклатура,
    ВидДвижения,
    АналитикаХозяйственнойОперации,
    Период,
    Регистратор
Володька,
29.08.16, 16:50 Работа с картинками в таблице отчета
Приветсвую! Как делаю я - вставляем в отчет секцию в ней объект картинка, у картинки следующий текст

Если  путьФайла<>"" Тогда
        таб.ТекущийОбъект.Загрузить(путьФайла);
        таб.ТекущийОбъект.РежимРисования(3);
КонецЕсли;


печать справочника с картинками реализуем кодом

    сч = 1;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
        путьФайла = СокрЛП(Товар.ПутьКФото);  
        Таб.ПрисоединитьСекцию("СтТов|СтрТов");
    КонецЦикла;



 i 

Выделяйте, пожалуйста, код
 
Talkman, Vofka,
24.11.15, 9:32 Реквизит диалога(Поле ввода) смена типа 1С7.7
Может чего не понял, но у меня на форме есть тестовое поле тип и значение с типом "справочник", после ввода в тип жму энтер и выполняеться следующий код

Процедура ИзмТип()
    Справочник.ВидыДляВыбора(сокрЛП(Тип));
КонецПроцедуры


тогда в поле выбираеться тот справочник что указан(у меня справочники контрагенты илил товары соответсвенно пишу только контрагенты илил товары без префикса справочники)
mezzare,
02.10.15, 8:45 Восстановление удаленного элемента справочника в SQL базе
Приветсвую! А литтл пример... Смотрим в файле 1Cv7.DDS структуру SQL базы, находим все поля где храниться ссылка на товар вот пример из файла:
#===============================================================================
#==TABLE no 54 : Документ (Мн.ч.) Поступление
# Name |Descr |SQLTableNam|RecordLock
T=DT73 |Документ (Мн.ч.) Поступление |DT73 |
#-----Fields-------
# Name |Descr |Type|Length|Precision
F=IDDOC |ID Document's |C |9 |0
F=LINENO_ |LineNo |S |0 |0
F=SP78 |(P)товар |C |9 |0
Видим что поле SP78 таблицы DT73 - это ИД товара сооответсвенно запрос будет выглядеть так: UPDATE [BAZA].[dbo].[DT73] SET SP78 = 'старый ИД' WHERE SP78 = 'новый ИД' выполняем запрос и будет Вам счастье smile.gif

Talkman,
17.09.15, 9:33 Последнее поступление товара.
Ускорить очень просто в десятки раз.


    ТекстЗапроса = 
    "Период с (НачГода(ТекущаяДата())) по (ТекущаяДата());
    |Без итогов;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Контрагент = Документ.ПриходнаяНакладная.Контрагент;
    |ТМЦ = Документ.ПриходнаяНакладная.ТМЦ;
    |ДатаДок = Документ.ПриходнаяНакладная.ДатаДок;
    |Группировка Контрагент без групп без упорядочивания;
    |Группировка ТМЦ без групп без упорядочивания;
    |Группировка ДатаДок без групп без упорядочивания;
    |Условие(ТМЦ = тзТаблица.Товар);
    |";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;

    Запрос.Выгрузить(тбТоварыПрихода)
    тбТоварыПрихода.Сортировать("Товар,ДатаДок");
КонецПроцедуры



 i 

Код можно выделять
 
twilight_dream,

RSS Текстовая версия Сейчас: 20.08.19, 16:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!