Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику sava1 ::: Спасибо сказали: 349 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
09.08.17, 12:48 Нужен программист-методист-внедренец ERP
Возьмите меня - опят хочу на ТюраТам
Далекий Казахстан,
01.08.17, 16:40 Не обновляется реквизит формы (платформа 8.2.19.106)
Почитайте про Оповестить()
andrew76,
17.07.17, 13:41 Код обозначения текущего объекта в модуле объекта
Процедура ПередУдалением(Отказ)
Сообщить(""+Ссылка+" -- "+код);
КонецПроцедуры
Gigi,
08.07.17, 14:31 Двойное условие в запросе (=>; <=)
тимВивер в ЛС - посмотрю
Constantus,
08.07.17, 11:56 Двойное условие в запросе (=>; <=)
Такой диапазон определяется МЕЖДУ

Условия лучше формировать динамически, типа%

Если ДиапазонОстатка ИЛИ ДиапазонСумм Тогда 
   Если ДиапазонОстатка Тогда
        УсловиеЗапроса = "ГДЕ ДиапазонОстатка МЕЖДУ &ОстатокОт И &ОстатокДо";
        Запрос.УстановитьПараметр("ОстатокОт", СуммаОстаткаОт);
        Запрос.УстановитьПараметр("ОстатокДо", СуммаОстаткаДо);
    КонецЕсли;        

    Если ДиапазонСумм Тогда
        УсловиеЗапроса = УсловиеЗапроса + ?(ДиапазонОстатка, " И ", "ГДЕ ") +" ДиапазонСумм МЕЖДУ &СтоимостьОт И &СтоимостьДо";
        Запрос.УстановитьПараметр("СтоимостьОт", СуммаПродажОт);
        Запрос.УстановитьПараметр("СтоимостьДо", СуммаПродажДо);
    КонецЕсли;    
КонецЕсли;


текстзапроса = "
|....
|"+ УсловиеЗапроса+"    
......
|";
Constantus,
05.07.17, 15:54 Нет полных прав но есть возможность добавлять пользователе
Посмотреть в конфигурации по ролям - убрать права на администрирование во всех ролях
Pavlik1c,
15.06.17, 17:30 Проверка открытия формы Справочника/документа
Цитата(Gigi @ 15.06.17, 18:24) *
один пользователь отрыл форму, и параметр из перечисления на форме стал "да". т.е. форма отрыта.
И в это самое время, вдруг бац и другой на другом компе закрыл эту форму пока у первого не закрыта


Вы вооще понимаете принцып асинхронных вызовов и работу клиент-сервера?
Вы никогда не найдете открытые формы , кроме своих.
Gigi,
15.06.17, 17:15 Проверка открытия формы Справочника/документа
Цитата(Gigi @ 15.06.17, 17:59) *
на клиенте пользователей будет несколько


Они в очереди будут стоять?
Gigi,
13.06.17, 10:55 УПП 1.3: Объединение подразделений в группу
Цитата(Володька @ 13.06.17, 11:19) *
почти все документы, где есть выбор подразделения получат доступ к "группе" подразделения.

В УПП есть ограничение прав по подразделениям. В чем проблема?
Володька,
06.06.17, 17:04 Произвольный отбор в справочниках
Да. По ним идет сопоставление

В консоли сделайте запрос и скопируйте
Vidocq05,
06.06.17, 10:02 Произвольный отбор в справочниках
Цитирую и ЖК:
Цитата
Перед обработкой
Условия возникновения события
Событие выполняется перед обработкой каждого правила выгрузки один раз. Используется для установки дополнительных параметров перед выгрузкой данных, для переопределения выборки объектов, подлежащей выгрузке, либо для выгрузки дополнительной информации

Параметры:
Отказ - Булево. Если установить значение Истина, то выгрузка данных по данному правилу не производится

Параметры - Структура, в которой хранятся переменные доступные во всех обработчиках

ИмяПКО - Строка. Имя правила конвертации объектов, указанное по умолчанию в правиле выгрузки данных. При выгрузке конкретных объектов может быть изменено

Правило - ссылка на данное правило выгрузки данных

ИсходящиеДанные - Произвольный. Произвольные вспомогательные данные, доступные при выгрузке объектов выборки

ВыборкаДанных - Запрос, Результат запроса, Выборка из результата запроса или произвольная коллекция выгружаемых объектов. Используется, когда способ выгрузки данных - Произвольный алгоритм. Если определить данную переменную, то обход коллекции и выгрузка объектов будет осуществляться автоматически

Важно:
Если для выборки данных ПВД используется произвольный алгоритм и в обработчике ПВД "Перед обработкой" инициируется параметр ВыборкаДанных, то для ПКО следует установить признак "Не запоминать выгруженные объекты".


Пример:
ДатаИзмененияОбъекта = ДатаНачала;
Сообщить("Контрагенты");

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|ТекущийЭлемент = Справочник.Партнеры.ТекущийЭлемент;
|ДатаИзменения = Справочник.Партнеры.ДатаИзменения;
|Группировка ТекущийЭлемент;
|Условие(ДатаИзменения >= ДатаИзмененияОбъекта);";

Запрос.Выполнить(ТекстЗапроса);
Пока Запрос.Группировка(1) = 1 Цикл
ВыгрузитьПоПравилу(Запрос.ТекущийЭлемент, , , , "Контрагенты");
КонецЦикла;


Результат запроса (или сам запрос ) назовите ВыборкаДанных
Обязательно ! - выбирайте в запросе Ссылка /+ правильная синхронизация/
в ПКО можно не сопоставлять, если наименования совпадают


Vidocq05,
31.05.17, 20:46 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 20:38) *
вообще я отношусь к тем, которые очень не любят разные стереотипы

типизация переменніх - не стереотип, а правило.
Программирование основано на таких "стереотипах" и начинаются онм с набора команд процессора, среды исполнения,
среды разработки и т.д.
Вы ж садитесь в автомобиль и не ищете педали велосипедные, чтобы крутить колеса?
Если не нравится среда 1С - возьмите другую и работайте - не надо хаять инструмент.
Да он корявый, но работающий.
Кому-то не понравился молоток - он придумал пресс. Вам все карты в руки.
Gigi,
31.05.17, 17:49 авто-запись данных на сервер для реквизита ссылка
ИМХО - "бедный" заказчик.
Gigi,
27.05.17, 11:31 УПП продажа Тепла
Если у Вас УПП - то да. Можно одним документом за месяц.
Володька,
16.05.17, 11:34 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
Похоже, работает принцип - "хай у мене хата згорить, аби лиш у сусіда корова здохла".
donbass,
01.05.17, 15:49 Две цены 1-го товара
Практически, везде, где есть типы цен.
lelickbolick,
19.04.17, 7:28 Проблема с записью в общие реквизиты документа
В модуле документа или на Подписки смотрели ?
andrew76,
18.04.17, 9:04 Валовая прибыль (самописный) с отбором по датам (периоду)
везде в выборках добавляем конструкцию
{ГДЕ Период между &Дата1 и &Дата2}


{ГДЕ Ссылка.Дата между &Дата1 и &Дата2}


Дата1 и дата2 появятся в Параметрах СКД
Constantus,
10.04.17, 15:50 Выборка по сравнению из таблицы
вот кусок
    "ВЫБРАТЬ
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.Организация КАК Организация,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.ОсновноеСредство КАК ОсновноеСредство,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.Номенклатура КАК Номенклатура,
        |    ВЫБОР
        |        КОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат1 ССЫЛКА Справочник.ПодразделенияОрганизаций
        |                ИЛИ ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат1 ССЫЛКА Справочник.Склады
        |            ТОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат1
        |        ИНАЧЕ ВЫБОР
        |                КОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат2 ССЫЛКА Справочник.ПодразделенияОрганизаций
        |                        ИЛИ ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат2 ССЫЛКА Справочник.Склады
        |                    ТОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат2
        |                ИНАЧЕ ВЫБОР
        |                        КОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат3 ССЫЛКА Справочник.ПодразделенияОрганизаций
        |                                ИЛИ ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат3 ССЫЛКА Справочник.Склады
        |                            ТОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат3
        |                        ИНАЧЕ ""субконто, відмінне від типу ПІДРОЗДІЛИ ОРГАНІЗАЦІЙ""
        |                    КОНЕЦ
        |            КОНЕЦ
        |    КОНЕЦ КАК Склад,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СчетЗатрат КАК СчетЗатрат,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.Регистратор КАК Регистратор,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.КоличествоОборот КАК Количество,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СуммаОборот КАК Сумма,
        |    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер
        |{ВЫБРАТЬ
        |    Организация,
        |    ОсновноеСредство,
        |    Номенклатура,
        |    Склад,
        |    СчетЗатрат,
        |    Регистратор,
        |    Количество,
        |    Сумма}
        |ИЗ
        |    РегистрНакопления.ИНАГРО_МатериалыСписаныеНаТранспорт.Обороты(&ДатаНач, &ДатаКон, Регистратор, ) КАК ИНАГРО_МатериалыСписаныеНаТранспортОбороты
        |        Левое СОЕДИНЕНИЕ РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних(&ДатаКон) КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних
        |        ПО ИНАГРО_МатериалыСписаныеНаТранспортОбороты.ОсновноеСредство = ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство
        |{ГДЕ
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.Организация,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.ОсновноеСредство,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.Номенклатура,
        |    (ВЫБОР
        |            КОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат1 ССЫЛКА Справочник.ПодразделенияОрганизаций
        |                    ИЛИ ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат1 ССЫЛКА Справочник.Склады
        |                ТОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат1
        |            ИНАЧЕ ВЫБОР
        |                    КОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат2 ССЫЛКА Справочник.ПодразделенияОрганизаций
        |                            ИЛИ ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат2 ССЫЛКА Справочник.Склады
        |                        ТОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат2
        |                    ИНАЧЕ ВЫБОР
        |                            КОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат3 ССЫЛКА Справочник.ПодразделенияОрганизаций
        |                                    ИЛИ ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат3 ССЫЛКА Справочник.Склады
        |                                ТОГДА ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СубконтоЗатрат3
        |                            ИНАЧЕ NULL
        |                        КОНЕЦ
        |                КОНЕЦ
        |        КОНЕЦ) КАК Склад,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СчетЗатрат,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.Регистратор,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.КоличествоОборот КАК Количество,
        |    ИНАГРО_МатериалыСписаныеНаТранспортОбороты.СуммаОборот КАК Сумма}
nickolas,
28.03.17, 10:17 Запись нескольких значений справочника в один реквизит регистра сведений
Пишите как Вам удобно для обработки.
Yevhenii,
22.03.17, 15:47 как програмно организовать автоматическое заполнение поля многострочной части определенного докумнта
У полей Температура и плотность в формуле вписать ПриИзмененииТемпературіПлотности.

В модуле написать процедуру ПриИзмененииТемпературіПлотности
где будет написано:
ПриведеннаяПлотность = Плотность*Температура * ААА +ВВВ .....
leo10k10,
21.03.17, 21:16 Обработка Клиент-Банк для Бухгалтерии 1.2.5.3 (и старше) Украина 8.2 доточена
Возьмите обработку для iBank, попробуйте.
Liona_od, Marinel,
13.03.17, 11:51 В ЗУП из документа передать реквизит в другой документ
Цитата(Altem @ 13.03.17, 10:53) *
ОбластьМакетаШапка.Параметры.НомерПриказа = СсылкаНаОбъект.НомерПриказа;

поставьте

ОбластьМакетаШапка.Параметры.НомерПриказа = "123456";


попробуйте

Есть результат ?
Altem,
28.02.17, 13:33 Заполнение поля в цикле табличной части
Для каждого строка из ТабличнаяЧасть Цикл
    строка.Дата1 = ....;
КонецЦикла;
candrey,
28.02.17, 11:18 Как добавить кпопку фильтр в табличное поле обработки
alexandr_f @ Сегодня, 11:16 * ,
Что значит "индексировать не смогу".
Добавьте кнопки и проверьте отбор - все должно работать.
alexandr_f,

10 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 22.08.17, 22:36
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне