Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

4 страниц V   1 2 3 > » 

>  1С БП 2.0 "Фишка" счета МЦ
Володька
Отправлено: 04.07.18, 15:27


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Petre @ Сегодня, 14:03 * ,
Ну проблема куда глубже, не в получении остатков, а в "ахинеи" хранения самих остатков, ведь если Вы перемещаете или списываете, то даже указав МВО, Вы обязаны указать подразделение, в котором числиться (куда завязана партия) МА.

Если Вы еще не столкнулись, то советую провести эксперимент, гарантирую удивление.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #143137 · Ответов: 11 · Просмотров: 332
 

>  1С БП 2.0 "Фишка" счета МЦ
Володька
Отправлено: 04.07.18, 12:33


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Petre @ Сегодня, 11:15 * ,
Вопрос скорее в том, как Вы ведете учет? Ведь эта проблема никак не решена. Переписываете 3 документа?
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #143128 · Ответов: 11 · Просмотров: 332
 

>  1С БП 2.0 "Фишка" счета МЦ
Володька
Отправлено: 04.07.18, 8:51


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Люди, ау, я что один работаю в БП 2.0? Или только у меня есть МБП?
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #143106 · Ответов: 11 · Просмотров: 332
 

>  Как запретить право настройку рабочего стола
Володька
Отправлено: 29.06.18, 7:48


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Gigi @ Вчера, 13:34 * ,
Конфигуратор - Сервис - Параметры - Запуск 1с Предприятия - Дополнительно.
Снимите галочку с соответствующего пункта.
Но от себя личный вопрос: Зачем Вам это?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142988 · Ответов: 5 · Просмотров: 328
 

>  1С БП 2.0 "Фишка" счета МЦ
Володька
Отправлено: 29.06.18, 7:11


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


АПну, очень хочется услышать мнение специалистов, как Вы это объясняете своим бухгалтерам?
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #142987 · Ответов: 11 · Просмотров: 332
 

>  Как из четырех справочников, сделать такую форму как на картинке
Володька
Отправлено: 28.06.18, 10:56


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Задание "Бред сивой кобылы".

Что ж там за курс такой или книга, что заводятся дни недели в форме справочника? Собираетесь расширить неделю?)


Далее...
1. Связь между справочниками не прослеживается.
2. Фамилия в вас в дневнике почему везде разная или это фамилия учителя, это точно дневник?)
3. Для решения вам минимум нужно сделать структуру правильную.

1. Перечисления: ДниНедели (Пн,Вт,Ср...)
2. Справочники: Предметы, Учителя, Аудитории, ДомашнееЗадание.
3. Регистры: Уроки, Оценки.
4. Отчеты: Успеваемость, ДомашнееЗадание.
5. Документы: УрокиНедели, ПолучениеОценки, ПолучениеДомашнегоЗадания.
....
Можно кучу всего еще придумать, но Вам правильно ответили, результат Ваших стараний - Это Всего лишь отчет за 2 минуты, были бы данные правильные.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142974 · Ответов: 4 · Просмотров: 233
 

>  Программно отправить сообщение на почту через внешнюю обработку. Версия платформы: 8.3.10.2667, версия конфигуратора: 2.4.1.206
Володька
Отправлено: 28.06.18, 10:00


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


В любом случае для мэйла
  ПараметрыПочты.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;

вот это не пройдет. Их SMTP требует аутентификацию.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142973 · Ответов: 5 · Просмотров: 279
 

>  Что лучше изучать 8.2 (обычный интерфейс) или 8.3 С УП интерфесом?
Володька
Отправлено: 28.06.18, 9:55


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


А я вот не соглашусь, для меня УФ всё таки имеют больший ряд ограничений и пониманий, что в свою очередь свожу к тому, что если возвращаться на обычные формы, получаешь больший доступ, возможности и от этого психологически приятно, нежели это делать наоборот. Соответственно, если говорить про изучение, а не работу, то - УФ.
  Форум: Вся 1С · Просмотр сообщения: #142972 · Ответов: 9 · Просмотров: 418
 

>  Контекстная подсказка - часть подсказок невыдает. Что можно изменить?
Володька
Отправлено: 28.06.18, 9:43


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


kvital @ Вчера, 9:06 * ,
Что-то не так делаете.

Цитата
ОформлениеСтроки (RowAppearance)
ОформлениеСтроки (RowAppearance)
Свойства:

ДанныеСтроки (RowData)
ЦветТекста (TextColor)
ЦветФона (BackColor)
Шрифт (Font)
Ячейки (Cells)

Описание:

Определяет оформление строки табличного документа.

Доступность:

Толстый клиент.
См. также:

ОформлениеЯчейки
ТабличноеПоле, событие ПриВыводеСтроки
ОформленияСтрок, метод Получить
ТабличноеПоле, метод ОформлениеСтроки
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142971 · Ответов: 3 · Просмотров: 248
 

>  Как правильно перенести документы
Володька
Отправлено: 22.06.18, 9:00


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


romarker @ Сегодня, 9:58 * ,
И? В рабочей базе уже есть 1000 документов, вот эту 1000 документов, я хочу забрать именно в свой старый бэкап.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142791 · Ответов: 3 · Просмотров: 192
 

>  Как правильно перенести документы
Володька
Отправлено: 22.06.18, 8:53


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Ситуация банальна, после последнего бэкапа есть работа пользователей, как перенести эту работу в бэкап?
Что для этого делают гуру?

1С БП 2.0, Файловая база.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142788 · Ответов: 3 · Просмотров: 192
 

>  Программное создание документа ОперацияБух и его движений
Володька
Отправлено: 11.06.18, 8:05


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


            ДокОперация = Документы.ОперацияБух.СоздатьДокумент();
        ДокОперация.Дата = ДатаДокумента;
        ДокОперация.Организация = Организация;
        ДокОперация.Ответственный = ПараметрыСеанса.ТекущийПользователь;
        ДокОперация.Содержание = "Содержание";
        ДокОперация.Комментарий = "Комментарий";
        ДокОперация.Записать();

        ДокОперацияСсылка = ДокОперация.Ссылка;
        
                // Добавляем в хозрастчет.
        РегХозрасчетный = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
        РегХозрасчетный.Отбор.Регистратор.Значение = ДокОперацияСсылка;
        
                // Если нужен другой регистр
        РегНакопления = РегистрыНакопления.ДРУГОЙ_РЕГИСТР.СоздатьНаборЗаписей();
        РегНакопления.Отбор.Регистратор.Значение = ДокОперацияСсылка;
        
        
        
        Для Каждого Строка из Объект.ТАБЛИЧНАЯ_ЧАСТЬ_К_ ПРИМЕРУ Цикл
        
            РегЗапись = РегХозрасчетный.Добавить();
            РегЗапись.Период = ДатаДокумента;
            РегЗапись.Регистратор = ДокОперацияСсылка;
            РегЗапись.Организация = Организация;
            РегЗапись.Содержание  = Строка.Назначение;
            
            РегЗапись.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("СЧЕТ");        
            РегЗапись.СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("СЧЕТ");
            
            БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт, РегЗапись.СубконтоДт, "СУБКОНТОДТ", Строка.ДАННЫЕ);
              БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетКт, РегЗапись.СубконтоКт, "СУБКОНТОКТ", Строка.ДАННЫЕ);
            
            РегЗапись.Сумма = Строка.ДАННЫЕ;
            
            
            РегНакоп = РегНакопления.Добавить();
            РегНакоп.Период = ДатаДокумента;
            РегНакоп.Регистратор = ДокОперацияСсылка;
            РегНакоп.Организация = Организация;

                        /* ЗАПОЛНЯЕЙТЕ ПО ТИПУ Регистра */
            
        
        КонецЦикла;

                // Не забывайте ЗАПИСАТЬ ВСЁ ЭТО ДЕЛО //
        РегНакопления.Записать();
        РегХозрасчетный.Записать();


Разницы нет никакой в формировании. То, что у Вас стоит сумма, но нет проводок, скорее всего связано, что Вы не записали эти проводки. В данном коде всё будет наоборот, будут проводки, но не будет суммы =) Дал, просто как образец.
Думаю добавить:
ОпБух.СпособЗаполнения="Вручную";
НовДок.СуммаОперации=НовДок.Движения.Хозрасчетный.Итог("Сумма");

Найдете куда, тем более взять из Вашего листинга.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142407 · Ответов: 2 · Просмотров: 363
 

>  1С БП 2.0 Снять начисление амортизации массово
Володька
Отправлено: 30.05.18, 10:44


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Petre @ Сегодня, 9:12 * ,
Добрый день. Я и не решал, что для них начисляется амортизация. Понятное дело, что это только сообщения. Но у меня, как видно по скрину УФ и сообщение на 1500+ строк очень нагружает, как интерфейс, так и не дает возможность проанализировать "ошибки". Поэтому и хочу отключить массово амортизацию этим объектам до возможной модернизации.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #142035 · Ответов: 5 · Просмотров: 200
 

>  1С БП 2.0 Снять начисление амортизации массово
Володька
Отправлено: 30.05.18, 8:02


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Доброе утро, при расчете амортизации вываливается постоянно такая картинка

Там строк очень много, порядка 1500.
Подскажите, как снять "галочку" начислять амортизацию для тех, у кого амортизация равна 0?
Если это можно как-то реализовать стандартной обработкой Групповое изменение реквизитов, буду вообще очень счастлив!
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #142031 · Ответов: 5 · Просмотров: 200
 

>  1С УПП 1.3: Отчет Кассовая книга, ошибка формирования Страниц.
Володька
Отправлено: 04.05.18, 12:42


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Суть проблемы:
Нумерация кассовой книги дала сбой.
Описание ситуации:
Печатаю Кассовую книгу за период 13.03 - 17.03.
Нумерация 13,14,15-го - нормальная, 16-го , 17-го бред.
Смотрю отличие между этими числами и данными, а оно в том, что 15-го числа количество документов не влезло на один печатный лист.
Лезу в конфигурацию и вижу супер-функцию
Процедура НачатьНовуюСтраницу(СоответствиеНомеровГод, СоответствиеНомеровМесяц, ТекДата, СледДата, ОбластьШапка)
    
    ЧислоДокумента                          = Формат(ТекДата,"ДФ='дд';Л=uk_UA");
    ДатаДокумента                           = Формат(ТекДата,"ДФ='дд ММММ ггггр.';Л=uk_UA");
    ДатаДокументаБезЧисла                   = Прав(ДатаДокумента, СтрДлина(ДатаДокумента) - 2);
    ОбластьШапка.Параметры.ДатаПрописью       = """" + ЧислоДокумента + """" + ДатаДокументаБезЧисла;
    
    // номер листа
    НомеТекЛистаГода = СоответствиеНомеровГод.Получить(НачалоДня(ТекДата));
    СоответствиеНомеровГод.Вставить(НачалоДня(ТекДата), НомеТекЛистаГода + 1);
    НомеТекЛистаМесяца = СоответствиеНомеровМесяц.Получить(НачалоДня(ТекДата));
    СоответствиеНомеровМесяц.Вставить(НачалоДня(ТекДата), НомеТекЛистаМесяца + 1);
        
    ОбластьШапка.Параметры.НомерЛиста = НомеТекЛистаГода + 1;

    Если НачалоМесяца(СледДата) = НачалоМесяца(ТекДата) Тогда
        СоответствиеНомеровМесяц.Вставить(НачалоДня(СледДата), НомеТекЛистаМесяца + 2);
    КонецЕсли;
    
    Если НачалоГода(СледДата) = НачалоГода(ТекДата) Тогда
        СоответствиеНомеровГод.Вставить(НачалоДня(СледДата), НомеТекЛистаГода + 2);
    КонецЕсли;
    
КонецПроцедуры // НачатьНовуюСтраницу


Смотрю соответствие до:
13.03 - 1
14.03 - 2
15.03 - 3
16.03 - 4
17.03 - 5

и вижу весь этот ужас после:
13.03 - 1
14.03 - 2
15.03 - 4
16.03 - 5
17.03 - 5

По коду всё вроде логично и правильно, отрабатывает он, как и ожидалось. Вопрос, у меня у одного не вмещается на лист ПКО и РКО за день? Как побороть?

Пробовал перенумеровать оставшиеся элементы в соответствии так:
    
Для Каждого Элемент Из СоответствиеНомеровГод Цикл
        
        Если Элемент.Ключ > НачалоДня(ТекДата) Тогда
            
            СоответствиеНомеровГод.Вставить(Элемент.Ключ, Элемент.Значение + 1);            
            
        КонецЕсли;        
    
КонецЦикла;


Но это не панацея, во-первых долго, во-вторых т.к. этот код выполняется только в случае разрыва страницы, для печати другого периода он не будет учитывать нумерацию. И получится, что если мой период закончится на 6 (реальной странице), при формировании 18.03-20.03, начальная страница будет 5 (расчетная).
Подкиньте идей, я потерялся.


 ! 

Правила: 3
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141284 · Ответов: 0 · Просмотров: 356
 

>  потрібна друкована форма документа "Акт прийому передачі"
Володька
Отправлено: 03.05.18, 7:48


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


pingvin_vlad @ Вчера, 16:12 * ,
Пример создания внешних печатных форм
Откуда взять макет

Успехов!
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #141225 · Ответов: 1 · Просмотров: 417
 

>  Выходные дни в печатной форме П5
Володька
Отправлено: 27.04.18, 11:01


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Altem @ Сегодня, 11:56 * ,
Возьмите родную, сохраните, как внешнюю, в модуль напишите "магию внешних отчетов и обработок", добавьте пару строк кода, которые будут заполнять и выводить нужный результат. Там совсем не сложно!
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #141129 · Ответов: 3 · Просмотров: 276
 

>  Выходные дни в печатной форме П5
Володька
Отправлено: 27.04.18, 10:23


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Altem @ Сегодня, 11:21 * ,
Использовать (писать) внешнюю, "родная" такого не умеет.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #141127 · Ответов: 3 · Просмотров: 276
 

>  1С УПП 1.3: Перемещение мателиалов в эксплуатации и Документ передачи
Володька
Отправлено: 26.04.18, 10:07


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


prifamme @ 24.04.18, 17:58 * ,
Как я только не пробовал, но ничего не вышло и пришлось делать, через правку кода
  Форум: 1С Управление производственным предприятием 8 · Просмотр сообщения: #141089 · Ответов: 2 · Просмотров: 562
 

>  1С БП 2.0 Закрытие месяца, корректировка перемещения
Володька
Отправлено: 24.04.18, 11:22


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


sava1 @ Сегодня, 11:38 * ,
Ну я о том, что 26 счет, к примеру, не корреспондурует с 15 и производство ОС делается через Объекты строительства. Может и МБП так же? Я просто еще не разу не изготавливал МБП, только материалы, поэтому профан в этом вопросе(
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #141044 · Ответов: 7 · Просмотров: 249
 

>  1С БП 2.0 Закрытие месяца, корректировка перемещения
Володька
Отправлено: 24.04.18, 10:33


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


sava1 @ Сегодня, 10:44 * ,
Добавил, проверил, результат устроил. Делает всё, как и предполагалось. Просто хочу понять, может я действительно что-то упускаю и производство МБП к примеру в 1С должно быть оформлено иначе, другие настройки, другие документы, другой принцип.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #141042 · Ответов: 7 · Просмотров: 249
 

>  1С БП 2.0 Закрытие месяца, корректировка перемещения
Володька
Отправлено: 24.04.18, 9:13


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


logist @ Сегодня, 9:30 * ,

ПСБУ

Цитата
Счет 26 «Готовая продукция» корреспoндирует
по кредиту c дебетoм счетов:
20 «Производственные запaсы»
22 «Мaлоценные и быстроизнашивающиеся предмeты»


Цитата(logist @ 24.04.18, 9:30) *
там нет и в предыдущих редакциях конфигурации

За это большое спасибо, нет у меня возможности проверить предыдущие.

Цитата(logist @ 24.04.18, 9:30) *
позвонить в 1С и спросить почему там нет этого счета

К сожалению нет такой возможности, по сути из-за этого и спрашиваю форумы.
Одна надежда, что люди у себя на производствах делают МБП и подскажут, как выходят из таких ситуаций.


Цитата(logist @ 24.04.18, 9:30) *
либо вы не учли какие-то настройки, или делаете не правильный порядок операций

Порядок очень простой. Настройки 100 раз смотрел.
1. Делаю 1 числа ОПзС, Продукция: Отвертка - 1 штука, 20 грн, на 26 счет.
2. Делаю 2 числа ОПзС, Продукция: Гайка - 1 штука, 0.5 грн, на 26 счет.
3. Делаю 3 числа перемещение товаров, Отвертка Дт 221, Кт 26, Гайка Дт 201, Кт 26.
3. Установлены средние цены.
4. 31 числа закрываю месяц, в течении месяца добавляю 91 счет, распределение Прямые затраты.

Результат: 91 счет распределился на Отвертку и на Гайку, закрытие месяца скорректировало Гайку, а Отвертка так и осталась не скорректирована.

Гайка
31.03.2018    "Закрытие месяца 0000-000006 от 31.03.2018 23:59:59 Корректировка выпуска продукции (услуг)"
31.03.2018    "Закрытие месяца 0000-000006 от 31.03.2018 23:59:59 Корректировка стоимости перемещения"


Отвертка
31.03.2018    "Закрытие месяца 0000-000006 от 31.03.2018 23:59:59 Корректировка выпуска продукции (услуг)"


Конфигурация типовая.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #141039 · Ответов: 7 · Просмотров: 249
 

>  1С БП 2.0 Закрытие месяца, корректировка перемещения
Володька
Отправлено: 24.04.18, 7:12


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Понимаю, что вопрос может быть не полностью сформулирован, поэтому роясь в недрах конфигурации нашел модуль, который делает эту операцию
Общий модуль Корректировка стоимости


В этом прекрасном модуле, есть чудесная функция

// В СтруктураДопПараметров добавляются СписокСчетов - список счетов учета номенклатуры, 
// стоимость которой необходимо корректировать
// и СписокИсключаемыхСчетов - список счетов, которые не корректируются
Процедура УстановитьСписокСчетовУчетаНоменклатуры(СтруктураДопПараметров)
    
    ИмяПланаСчетов = "Хозрасчетный";
    
    СписокСчетов = Новый СписокЗначений;
    //СписокСчетов.Добавить(ПланыСчетов[ИмяПланаСчетов].ОборудованиеКУстановке);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПриобретениеОсновныхСредств);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПриобретениеДругихНеоборотныхМатериальныхАктивов);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПроизводственныеЗапасы);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.СырьеИМатериалы);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПокупныеПолуфабрикатыИКомплектующиеИзделия);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.Топливо);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТараИТарныеМатериалы);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.СтроительныеМатериалы);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.МатериалыПереданныеВПереработку);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ЗапасныеЧасти);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.МатериалыСельскохозяйственногоНазначения);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ДругиеМатериалы);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.Полуфабрикаты);
    
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.Товары);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ГотоваяПродукция);
    //СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТоварыОтгруженные);
    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.ПроизводствоИзДавальческогоСырья);
    
    СписокИсключаемыхСчетов = Новый СписокЗначений;
    СписокИсключаемыхСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТоварыВРозничнойТорговлеВПродажныхЦенахНТТ);
    СписокИсключаемыхСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТорговаяНаценкаНТТ);
    СписокИсключаемыхСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТранспортноЗаготовительныеРасходыМатериалы);
    СписокИсключаемыхСчетов.Добавить(ПланыСчетов.Хозрасчетный.ТранспортноЗаготовительныеРасходы);
    
    Запрос = Новый Запрос;
    
    Запрос.Текст =
    "ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    Хозрасчетный.Ссылка
    |ИЗ
    |    ПланСчетов.Хозрасчетный КАК Хозрасчетный
    |ГДЕ
    |    Хозрасчетный.Ссылка В ИЕРАРХИИ(&СписокСчетов)
    |    И НЕ Хозрасчетный.Ссылка В ИЕРАРХИИ(&СписокИсключаемыхСчетов)
    |";
    
    Запрос.УстановитьПараметр("СписокСчетов", СписокСчетов);
    Запрос.УстановитьПараметр("СписокИсключаемыхСчетов", СписокИсключаемыхСчетов);
    
    Счета = Запрос.Выполнить().Выгрузить();
    
    Результат = Новый Массив;
    
    Для Каждого Счет Из Счета Цикл
        Результат.Добавить(Счет.Ссылка);
    КонецЦикла;    
    
    СтруктураДопПараметров.Вставить("СписокСчетов", Результат);
    
    Запрос = Новый Запрос;
    
    Запрос.Текст =
    "ВЫБРАТЬ РАЗЛИЧНЫЕ
    |    Хозрасчетный.Ссылка
    |ИЗ
    |    ПланСчетов.Хозрасчетный КАК Хозрасчетный
    |ГДЕ
    |    Хозрасчетный.Ссылка В ИЕРАРХИИ(&СписокИсключаемыхСчетов)
    |";
    
    Запрос.УстановитьПараметр("СписокИсключаемыхСчетов", СписокИсключаемыхСчетов);
    
    Счета = Запрос.Выполнить().Выгрузить();
    
    Результат = Новый Массив;
    
    Для Каждого Счет Из Счета Цикл
        Результат.Добавить(Счет.Ссылка);
    КонецЦикла;    
    
    СтруктураДопПараметров.Вставить("СписокИсключаемыхСчетов", Результат);
    
КонецПроцедуры // УстановитьСписокСчетовУчетаНоменклатуры()


в которой, по моему мнению не хватает

    СписокСчетов.Добавить(ПланыСчетов.Хозрасчетный.МалоценныеИБыстроизнашивающиесяПредметыНаСкладе);


Аргументы, которыми я пользуюсь: Проводка Дб 22 Кт 26 - есть и вполне логична, а Дб 22 Кт 20 - нет (это если выпуск класть на 20 счет, где добавляется эта чудо-корректировка, а потом магией ручных операций создавать перемещение)

Как считаете?
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #141035 · Ответов: 7 · Просмотров: 249
 

>  1С БП 2.0 Закрытие месяца, корректировка перемещения
Володька
Отправлено: 23.04.18, 15:06


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Добрый день, объясните, кто знает, почему:

1. Делаю много ОПзС.
2. Перемещаю по складам и счетам учета товары. Что-то на 201, что-то на 221.
3. Закрываю месяц.

Всё что было перемещено на 201 Закрывает отлично, добавляет 91, и делает корректировки, включая корректировку перемещения, а вот всё что перемещаю на 221 - корректировку перемещения не делает и сумма на 26 зависает.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #141010 · Ответов: 7 · Просмотров: 249
 

>  1С БП 2.0 "Фишка" счета МЦ
Володька
Отправлено: 18.04.18, 12:04


Говорящий
***

Группа: Пользователи
Сообщений: 96
Регистрация: 24.05.17
Пользователь №: 56151


Petre @ Сегодня, 12:53 * ,
Это понятно, но допустим у меня есть сотня лопат, я купил эти лопаты и ввел в эксплуатацию на "Огород 1" отразил затраты и всё отлично (они особо мне дальше не интересны), теперь, прошло 2 месяца и 100 рабочих перекопали "Огород 1" =)
Понятное дело, что лопаты может и износились, может и сломались, но что-то да осталось. Я делаю "Огород 2", в котором уже новые, пусть 50 человек, должны взять эти, оставшиеся лопаты и "ломать полностью", я передаю лопаты им. Поломали они их окончательно, а вот уже списать не смогут (по-человечески), так как они будут учитываться и в документ списания подтягиваться, только как лопаты "Огорода 1".

Мне же и интересно, разве такая простая ситуация не приходила в голову разработчикам? =(

Цитата(Petre @ 18.04.18, 12:53) *
указывать в документе все то же подразделение

Проблема и в этом, хорошо, когда у Вас 2 подразделения, а когда у Вас 100+ котельных + 1500 человек? Ведь посмотреть тот же остаток и что-где числится не удастся. Выход разве что вести их, как ОС (100%)?
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #140838 · Ответов: 11 · Просмотров: 332
 

4 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 15.08.18, 14:27
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне