Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

4 страниц V   1 2 3 > » 

>  Договор с контрагентом
XacTLa
Отправлено: Вчера, 10:05


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Prospero @ Вчера, 21:22 * ,
Короче вспомнил админ который был до меня пытался поменять ндс с 18% на 20% так как программа российская и менял все подряд в конфигураторе там такая каша была что капец, поэтому у меня бока вылазят(((

Но теперь как быть есть ли у кого то как должно быть или обработка валяется? Договор с контр агентом
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148952 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 14.01.19, 21:07


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Prospero @ Сегодня, 21:05 * ,
да
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148931 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 14.01.19, 20:45


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Prospero @ Сегодня, 20:33 * ,
нет, не помогла, в перечислениях такого нет смотрел сегодня(( видеть бы оригинал кода , я то не знаю изменен он или нет, но скорее всего нет
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148929 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 14.01.19, 16:14


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Prospero @ Вчера, 19:08 * ,
Вот код сверху там в рублях написано, только опять же при чем тут в рубли ели в программе настроены гривны
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148922 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 13.01.19, 10:19


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Prospero @ Сегодня, 0:11 * ,
Вот такая конфа, а можно оригинал пжл кода ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148880 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 11.01.19, 16:44


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Справочник.ДоговорыКонтрагентов.Форма.ФормаЭлемента.Форма(456). Я ее открыл нашел эту форму и больше нечего там не видно. Я вижу куда обращается но что менять не пойму вот код:
Процедура ВалютаВзаиморасчетовПриИзмененииСервер()
    
    Если Объект.ВалютаВзаиморасчетов = Константы.ВалютаРегламентированногоУчета.Получить() Тогда
        Объект.ПорядокОплаты = Перечисления.ПорядокОплатыПоСоглашениям.РасчетыВРубляхОплатаВРублях;
    ИначеЕсли Объект.ПорядокОплаты = Перечисления.ПорядокОплатыПоСоглашениям.РасчетыВРубляхОплатаВРублях Тогда
        Объект.ПорядокОплаты = Перечисления.ПорядокОплатыПоСоглашениям.ПустаяСсылка();
    КонецЕсли;
    
    ПорядокОплатыПриИзмененииСервер();
    
КонецПроцедуры


Я так понимаю тут борода?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148859 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 10.01.19, 21:31


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Bernet @ Сегодня, 15:55 * ,
Вот и прикол в том какая разница какая валюта((( да росийская, он ссылаться на форму документа
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148834 · Ответов: 13 · Просмотров: 204
 

>  Договор с контрагентом
XacTLa
Отправлено: 10.01.19, 15:46


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)

Суть такова задали задачу что бы у всех клиентов сделать лимит по отгрузке, я думал что раз плюнуть есть же договора. Ставлю галочку что будем использовать договора, захожу на клиента что бы создать договор и тут неожиданность причем тут рубли вообще не пойму валюта взаиморасчета стоит UAH а мне выдает ошибку про рубли
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148827 · Ответов: 13 · Просмотров: 204
 

>  Этикетка товара
XacTLa
Отправлено: 23.10.18, 15:37


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Не пойму выдает ошибку "Значение не является значением объектного типа 1"

Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
    
    ТабличныйДокумент = Новый ТабличныйДокумент;     
    МакетОбработки = ПолучитьМакет("Наклейка");
    ТабличныйДокумент.АвтоМасштаб = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    
    
    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");
    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Рисунки.ШтрихКод.Объект.ТипКода = 1;
    ОбластьШапки.Рисунки.ШтрихКод.Объект.Сообщение = "1234567890128";        
        

        
        ТабличныйДокумент.Вывести(ОбластьШапки);
                
    
            
        ОбластьПодвала = МакетОбработки.ПолучитьОбласть("Подвал");
        
    ОбластьПодвала.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;

    
        ТабличныйДокумент.Вывести(ОбластьПодвала);
    
    
    Возврат ТабличныйДокумент;
        
КонецФункции // СформироватьПечатнуюФорму()

Функция ПолучитьЗначениеТипаШтрихкодаДляЭУ(ТипКода)
    Перем Значение;
    
    Если ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN8 Тогда
        Значение = 0;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13 Тогда
        Значение = 1;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN128 Тогда
        Значение = 2;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code39 Тогда
        Значение = 3;
    ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code128 Тогда
        Значение = 4;
    Иначе
        Значение = -1;
    КонецЕсли;
    
    Возврат Значение;
КонецФункции     

Процедура ВывестиШтрихКодВПечатнуюФорму(Кнопка)
    
    //Для типовых конфигураций
    ТипКода = ПолучитьЗначениеТипаШтрихкодаДляЭУ(ПланыВидовХарактеристик.ТипыШтрихкодов.EAN8);    
    
    //Для произвольных конфигураций
    ТипКода = 0;  //EAN8
    ТипКода = 1;  //EAN13
    ТипКода = 2;  //EAN128
    ТипКода = 3;  //CODE39
    ТипКода = 4;  //CODE128
    ТипКода = 5;  //CODE16K
    ТипКода = 6;  //PDF417
    ТипКода = 7;  //Industrial2of5
    ТипКода = 8;  //Interleaved2of5
    ТипКода = 9;  //Code39FullASCII
    ТипКода = 10; //CODE93
    ТипКода = 11; //ITF14
    ТипКода = 12; //RSS14
    ТипКода = 13; //CodaBar
    ТипКода = 14; //EAN13 AddOn 2
    ТипКода = 15; //EAN13 AddOn 5

    
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146539 · Ответов: 2 · Просмотров: 960
 

>  Этикетка товара
XacTLa
Отправлено: 19.10.18, 10:06


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


XacTLa @ 25.06.18, 16:32 * ,

Вообщем ситуация такая , что проще создать внешнюю печатную форму в виде этикетки, и вставить туда все параметры, пока не могу понять как вставить штрих код, а именно отобразить его в модуле сам штрих код я вставил а вот как в коде его отобразить не понимаю, может кто что подскажет вот код :
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
    
    ТабличныйДокумент = Новый ТабличныйДокумент;     
    МакетОбработки = ПолучитьМакет("Наклейка");
    ТабличныйДокумент.АвтоМасштаб = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    
    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");
    
        ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
        
        

        
        ТабличныйДокумент.Вывести(ОбластьШапки);
                
    
            
        ОбластьПодвала = МакетОбработки.ПолучитьОбласть("Подвал");
        
    ОбластьПодвала.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;

    
        ТабличныйДокумент.Вывести(ОбластьПодвала);
    
    
    Возврат ТабличныйДокумент;
        
КонецФункции // СформироватьПечатнуюФорму()
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146427 · Ответов: 2 · Просмотров: 960
 

>  ТТН для бухгалтерии
XacTLa
Отправлено: 04.07.18, 16:59


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


sava1 @ Сегодня, 17:57 * ,
{ВнешняяОбработка.ТТН2018.МодульОбъекта(61)}: Поле объекта не обнаружено (Документ)
Документ = ПараметрыПечати.Документ;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143142 · Ответов: 5 · Просмотров: 466
 

>  ТТН для бухгалтерии
XacTLa
Отправлено: 04.07.18, 16:05


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


podcast @ Сегодня, 16:36 * ,
{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(233)}: В обработчике печати не был сформирован табличный документ для: ТТН2018
ВызватьИсключение(ТекстСообщенияОбОшибке);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143139 · Ответов: 5 · Просмотров: 466
 

>  ТТН для бухгалтерии
XacTLa
Отправлено: 04.07.18, 14:34


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
Бухгалтерия для Украины, редакция 2.0. (2.0.9.2)

Добрый день, скажи те мне не понимающему делаю ТТН для бухгалтерии Ошибка у меня в том что функция печати код:
 Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТТН") Тогда
            
        
            
    
            ТабДокумент = ПечатьТТН(ПараметрыПечати);
        КонецЕсли;
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТТН", НСтр("ru='Товарно-транспортная накладная (1-ТН)';uk='Товарно-транспортна накладна (1-ТН)'"),
            ТабДокумент,,"Обработка.ПечатьТТН.ПФ_MXL_ТТН");
    
    
    
КонецПроцедуры


Выдает ошибку {ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(233)}: В обработчике печати не был сформирован табличный документ для: ТТН2018
ВызватьИсключение(ТекстСообщенияОбОшибке);

Вот весь код:
Функция СведенияОВнешнейОбработке()Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ТТН2018"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Информация", "Это 2018 ТТН ");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "ТТН 2018", "ТТН2018", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;
    
КонецФункции // СведенияОВнешнейОбработке()

Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТТН") Тогда
            
        
            
    
            ТабДокумент = ПечатьТТН(ПараметрыПечати);
        КонецЕсли;
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТТН", НСтр("ru='Товарно-транспортная накладная (1-ТН)';uk='Товарно-транспортна накладна (1-ТН)'"),
            ТабДокумент,,"Обработка.ПечатьТТН.ПФ_MXL_ТТН");
    
    
    
КонецПроцедуры

Функция ПечатьТТН(ПараметрыПечати) Экспорт

    УстановитьПривилегированныйРежим(Истина);
    
    мВалютаРегламентированногоУчета = ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета();
    
    Документ                 = ПараметрыПечати.Документ;
    МаркаИГосНомерАвтомобиля = ПараметрыПечати.МаркаИГосНомерАвтомобиля;
    ГосНомерПрицепа          = ПараметрыПечати.ГосНомерПрицепа;
    ПунктПогрузки            = ПараметрыПечати.ПунктПогрузки;
    ПунктРазгрузки           = ПараметрыПечати.ПунктРазгрузки;
    Водитель                 = ПараметрыПечати.Водитель;
    Перевозчик               = ПараметрыПечати.Перевозчик;
    ВидПеревозки             = ПараметрыПечати.ВидПеревозки;
    НомерТТН                 = ПараметрыПечати.НомерТТН;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ДатаСреза",          Документ.Дата);
    Запрос.УстановитьПараметр("СтруктурнаяЕдиница", Документ.Склад);
    Запрос.УстановитьПараметр("ТекущийДокумент",  Документ);
    Запрос.УстановитьПараметр("ПустойКонтрагент", Справочники.Контрагенты.ПустаяСсылка());

    Запрос.Текст =
    "ВЫБРАТЬ
    |    Ссылка       КАК Документ,
    |    Номер,
    |    Дата         КАК ДатаДокумента,
    |    Организация,
    |    Организация  КАК ЮрФизЛицо,
    |    Организация  КАК Поставщик,
    |    Организация  КАК Контрагент,
    |    Организация  КАК Руководители,
    |    ВЫБОР КОГДА Грузополучатель = &ПустойКонтрагент
    |          ТОГДА Контрагент
    |          ИНАЧЕ Грузополучатель КОНЕЦ КАК Грузополучатель,
    |     Организация  КАК Грузоотправитель,
    |    БанковскийСчетОрганизации КАК БанковскийСчет,
    |    Контрагент   КАК Покупатель,
    |    Контрагент   КАК Плательщик,
    |    ОтветственныеЛица.ФизическоеЛицо КАК ОтветственноеЛицо,
    |    ВалютаДокумента,
    |    КурсВзаиморасчетов       КАК Курс,
    |    КратностьВзаиморасчетов  КАК Кратность,
    |    СуммаВключаетНДС,
    |    Получил,
    |    ДоверенностьСерия,
    |    ДоверенностьНомер,
    |    ДоверенностьДата
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |    РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
    |ПО
    |    ОтветственныеЛица.СтруктурнаяЕдиница = РеализацияТоваровУслуг.Склад
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";

    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", Документ);

    Если Документ.ВалютаДокумента = Документ.ДоговорКонтрагента.ВалютаВзаиморасчетов Тогда
        // Документ оформлен в валюте взаиморасчетов
        Запрос.УстановитьПараметр("Курс", Документ.КурсВзаиморасчетов);
        Запрос.УстановитьПараметр("Кратность", Документ.КратностьВзаиморасчетов);
    Иначе
        // Документ оформлен в валюте регламентированного учета
        Запрос.УстановитьПараметр("Курс", 1);
        Запрос.УстановитьПараметр("Кратность", 1);
    КонецЕсли;

    Запрос.Текст =
    "ВЫБРАТЬ
    |    ВложенныйЗапрос.Номенклатура                                 КАК Номенклатура,
    |    ВложенныйЗапрос.Номенклатура.НаименованиеПолное              КАК ТоварНаименование,
    |    ВложенныйЗапрос.Номенклатура.Код                             КАК Артикул,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление               КАК БазоваяЕдиницаНаименование,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Код                          КАК БазоваяЕдиницаКодПоОКЕИ,
    |    ВложенныйЗапрос.ЕдиницаИзмерения                             КАК ЕдиницаИзмерения,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление                КАК ВидУпаковки,
    |    ВложенныйЗапрос.СтавкаНДС           КАК СтавкаНДС,
    |    ВложенныйЗапрос.Цена                КАК Цена,
    |    ВложенныйЗапрос.Количество          КАК Количество,
    |    ВложенныйЗапрос.Сумма               КАК Сумма,
    |    ВложенныйЗапрос.СуммаНДС            КАК СуммаНДС,
    |    ВложенныйЗапрос.НомерСтроки         КАК НомерСтроки,
    |    ВложенныйЗапрос.Метка               КАК Метка
    |ИЗ
    |
    |    (
    |    ВЫБРАТЬ
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения                      КАК ЕдиницаИзмеренияМест,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена * &Курс / &Кратность             КАК Цена,
    |        СУММА(РеализацияТоваровУслуг.Количество)                     КАК Количество,
    |        СУММА(РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность)  КАК Сумма,
    |        СУММА(РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность)  КАК СуммаНДС,
    |        МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки)                  КАК НомерСтроки,
    |        0                                                            КАК Метка
    |    ИЗ
    |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |    ГДЕ
    |        РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена
    |
    |    ) КАК ВложенныйЗапрос
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Номенклатура                    КАК Номенклатура,
    |    РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное КАК ТоварНаименование,
    |    РеализацияТоваровУслуг.Номенклатура.Код                  КАК Артикул,
    |    РеализацияТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Представление               КАК БазоваяЕдиницаНаименование,
    |    РеализацияТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Код                         КАК БазоваяЕдиницаКодПоОКЕИ,
    |    РеализацияТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения                             КАК ЕдиницаИзмерения,
    |    NULL                                                  КАК ВидУпаковки,
    |    ""Без НДС""                                           КАК СтавкаНДС,
    |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность      КАК Цена,
    |    РеализацияТоваровУслуг.Количество                     КАК Количество,
    |    РеализацияТоваровУслуг.Сумма * &Курс / &Кратность     КАК Сумма,
    |    0                                                     КАК СуммаНДС,
    |    РеализацияТоваровУслуг.НомерСтроки                    КАК НомерСтроки,
    |    2                                                     КАК Метка
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |УПОРЯДОЧИТЬ ПО Метка ВОЗР, НомерСтроки ВОЗР
    |
    |";

    ЗапросТовары = Запрос.Выполнить().Выгрузить();

    ТабДокумент = Новый ТабличныйДокумент;

    Если Шапка.ДатаДокумента < Дата("20140114") Тогда
        ЗаполнитьТТН (Шапка, ЗапросТовары, ТабДокумент,ПараметрыПечати)
    Иначе
        ЗаполнитьТТН2014 (Шапка, ЗапросТовары, ТабДокумент,ПараметрыПечати)
    КонецЕсли;
    
    Возврат ТабДокумент;

КонецФункции // ПечатьТТН()
    
Процедура ЗаполнитьТТН (Шапка, ЗапросТовары, ТабДокумент, ПараметрыПечати)
    
    Документ                 = ПараметрыПечати.Документ;
    МаркаИГосНомерАвтомобиля = ПараметрыПечати.МаркаИГосНомерАвтомобиля;
    ГосНомерПрицепа          = ПараметрыПечати.ГосНомерПрицепа;
    ПунктПогрузки            = ПараметрыПечати.ПунктПогрузки;
    ПунктРазгрузки           = ПараметрыПечати.ПунктРазгрузки;
    Водитель                 = ПараметрыПечати.Водитель;
    Перевозчик               = ПараметрыПечати.Перевозчик;
    ВидПеревозки             = ПараметрыПечати.ВидПеревозки;
    НомерТТН                 = ПараметрыПечати.НомерТТН;
    
    // Зададим параметры макета
    ТабДокумент.ПолеСверху              = 0;
    ТабДокумент.ПолеСлева               = 5;
    ТабДокумент.ПолеСнизу               = 0;
    ТабДокумент.ПолеСправа              = 5;
    ТабДокумент.АвтоМасштаб             = Истина;
    ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;

    Макет = УправлениеПечатью.ПолучитьМакет("Обработка.ПечатьТТН.ПФ_MXL_ТТН");
    
    КодЯзыкаПечать = "uk";
    
    // Выводим общие реквизиты шапки
    СведенияОПокупателе       = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель,       Шапка.ДатаДокумента);
    СведенияОГрузополучателе  = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузополучатель,  Шапка.ДатаДокумента);
    СведенияОГрузоотправитель = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузоотправитель, Шапка.ДатаДокумента);

    Если ЗначениеЗаполнено(Документ.БанковскийСчетОрганизации) Тогда
        НомерСчета = Документ.БанковскийСчетОрганизации.НомерСчета;
        Банк       = Документ.БанковскийСчетОрганизации.Банк;
        МФО           = Документ.БанковскийСчетОрганизации.Банк.Код;
        
        СведенияОГрузоотправитель.Вставить("НомерСчета",       НомерСчета);
        СведенияОГрузоотправитель.Вставить("Банк",             Банк);
        СведенияОГрузоотправитель.Вставить("МФО",              МФО);
    КонецЕсли;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.НомерДокумента                = НомерТТН;
    ОбластьМакета.Параметры.ДатаДокумента                 = Шапка.ДатаДокумента;
    ОбластьМакета.Параметры.Грузоотправитель              = Шапка.Грузоотправитель;
    ОбластьМакета.Параметры.Грузополучатель               = Шапка.Грузополучатель;
    ОбластьМакета.Параметры.Плательщик                    = Шапка.Покупатель;
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузополучательПредставление  = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузополучателе,  "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузоотправительЕДРПОУ = СведенияОГрузоотправитель.КодПоЕДРПОУ;
    ОбластьМакета.Параметры.ГрузополучательЕДРПОУ  = СведенияОГрузополучателе.КодПоЕДРПОУ;
    ОбластьМакета.Параметры.ПлательщикЕДРПОУ       = СведенияОПокупателе.КодПоЕДРПОУ;
    
    ОбластьМакета.Параметры.МаркаИГосНомерАвтомобиля = МаркаИГосНомерАвтомобиля;
    ОбластьМакета.Параметры.ФИОВодителя = Водитель;
    ОбластьМакета.Параметры.ВидПеревозки = ВидПеревозки;
    ОбластьМакета.Параметры.ГосНомерПрицепа = ГосНомерПрицепа;
    
    ОбластьМакета.Параметры.ПунктПогрузки = ПунктПогрузки;
    ОбластьМакета.Параметры.ПунктРазгрузки = ПунктРазгрузки;
    
    ОбластьМакета.Параметры.ОрганизацияПеревозчик = Перевозчик;
    
    ТабДокумент.Вывести(ОбластьМакета);

    СтрокНаСтранице = 23;
    СтрокШапки      = 10;
    СтрокПодвала    = 9;
    НомерСтраницы   = 1;

    // Выводим заголовок таблицы
    ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    ТабДокумент.Вывести(ЗаголовокТаблицы);

    КоличествоСтрок = ЗапросТовары.Количество();

    Если КоличествоСтрок = 1 Тогда
        ПереноситьПоследнююСтроку = 0;
    Иначе
        ЦелыхСтраницСПодвалом     = Цел((СтрокШапки + КоличествоСтрок + СтрокПодвала) / СтрокНаСтранице);
        ЦелыхСтраницБезПодвала    = Цел((СтрокШапки + КоличествоСтрок - 1) / СтрокНаСтранице);
        ПереноситьПоследнююСтроку = ЦелыхСтраницСПодвалом - ЦелыхСтраницБезПодвала;
    КонецЕсли;

    // инициализация итогов по странице
    ИтогоКоличествоНаСтранице = 0;
    ИтогоСуммаСНДСНаСтранице  = 0;

    // инициализация итогов по документу
    ИтогоМест       = 0;
    ИтогоКоличество = 0;
    ИтогоСуммаСНДС  = 0;
    Ном             = 0;

    // Выводим многострочную часть докмента
    ОбластьМакета = Макет.ПолучитьОбласть("Строка");
    Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл

        Если НЕ ЗначениеЗаполнено(ВыборкаСтрок.Номенклатура) Тогда
            Сообщить(НСтр("ru='В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.';uk='В одному з рядків не заповнене значення номенклатури - рядок під час друку буде пропущений.'"), СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;

        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрок);
        ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрок.ТоварНаименование;
        //        Мест        = ВыборкаСтрок.КоличествоМест;
        Количество  = ВыборкаСтрок.Количество;
        СуммаСНДС   = Окр((ВыборкаСтрок.Сумма + ?(Шапка.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС)), 2);
        ОбластьМакета.Параметры.Сумма = СуммаСНДС;

        ОбластьМакета.Параметры.Цена = ?(Количество = 0, 0, СуммаСНДС / Количество);

        ТабДокумент.Вывести(ОбластьМакета);

        // увеличим итоги по дукументу
        ИтогоКоличество = ИтогоКоличество + Количество;
        ИтогоСуммаСНДС  = ИтогоСуммаСНДС  + СуммаСНДС;

    КонецЦикла;

    // Выводим итоги по документу в целом
    ОбластьМакета = Макет.ПолучитьОбласть("Всего");
    ОбластьМакета.Параметры.ИтогоКоличество = ИтогоКоличество;
    ОбластьМакета.Параметры.ИтогоСуммаСНДС  = ИтогоСуммаСНДС;

    ТабДокумент.Вывести(ОбластьМакета);

    // Выводим подвал документа
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");

    Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);
    
    // Отпуск товара разрешил
    ФИООтпускРазрешил       = Руководители.РуководительПредставление;
    ДолжностьОтпускРазрешил = Руководители.РуководительДолжность;
    
    ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ДолжностьОтпускРазрешил;
    ОбластьМакета.Параметры.ДоверенностьЧерезКого   = Шапка.Получил;
    
    ОбластьМакета.Параметры.СерияДоверенности = Шапка.ДоверенностьСерия;
    ОбластьМакета.Параметры.НомерДоверенности = Шапка.ДоверенностьНомер;
    ОбластьМакета.Параметры.ДатаДоверенности  = Формат(Шапка.ДоверенностьДата, "ДФ = ""дд.ММ.гггг""");
    ОбластьМакета.Параметры.ОтпущеноНаСуммуПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(ИтогоСуммаСНДС, Константы.ВалютаРегламентированногоУчета.Получить(), КодЯзыкаПечать);
    ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("ПогрузочныеОперации");
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("ПрочиеСведения");
    ТабДокумент.Вывести(ОбластьМакета);

КонецПроцедуры // ЗаполнитьТТН()

Процедура ЗаполнитьТТН2014 (Шапка, ЗапросТовары, ТабДокумент, ПараметрыПечати)
    
    Документ                 = ПараметрыПечати.Документ;
    МаркаИГосНомерАвтомобиля = ПараметрыПечати.МаркаИГосНомерАвтомобиля;
    ГосНомерПрицепа          = ПараметрыПечати.ГосНомерПрицепа;
    ПунктПогрузки            = ПараметрыПечати.ПунктПогрузки;
    ПунктРазгрузки           = ПараметрыПечати.ПунктРазгрузки;
    Водитель                 = ПараметрыПечати.Водитель;
    Перевозчик               = ПараметрыПечати.Перевозчик;
    ВидПеревозки             = ПараметрыПечати.ВидПеревозки;
    НомерТТН                 = ПараметрыПечати.НомерТТН;

    
    // Зададим параметры макета
    ТабДокумент.ПолеСверху              = 0;
    ТабДокумент.ПолеСлева               = 5;
    ТабДокумент.ПолеСнизу               = 0;
    ТабДокумент.ПолеСправа              = 5;
    ТабДокумент.АвтоМасштаб             = Истина;
    ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;

    Макет = УправлениеПечатью.ПолучитьМакет("Обработка.ПечатьТТН.ПФ_MXL_ТТН2014");
    
    КодЯзыкаПечать = "uk";
    
    // Выводим общие реквизиты шапки
    СведенияОПокупателе       = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель,       Шапка.ДатаДокумента);
    СведенияОГрузополучателе  = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузополучатель,  Шапка.ДатаДокумента);
    СведенияОГрузоотправитель = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузоотправитель, Шапка.ДатаДокумента);
    
    Если ЗначениеЗаполнено(Документ.БанковскийСчетОрганизации) Тогда
        НомерСчета = Документ.БанковскийСчетОрганизации.НомерСчета;
        Банк       = Документ.БанковскийСчетОрганизации.Банк;
        МФО           = Документ.БанковскийСчетОрганизации.Банк.Код;
        
        СведенияОГрузоотправитель.Вставить("НомерСчета",       НомерСчета);
        СведенияОГрузоотправитель.Вставить("Банк",             Банк);
        СведенияОГрузоотправитель.Вставить("МФО",              МФО);
    КонецЕсли;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.НомерДокумента                = НомерТТН;
    ОбластьМакета.Параметры.ДатаДокумента                 = Шапка.ДатаДокумента;
    ОбластьМакета.Параметры.Грузоотправитель              = Шапка.Грузоотправитель;
    ОбластьМакета.Параметры.Грузополучатель               = Шапка.Грузополучатель;
    ОбластьМакета.Параметры.Плательщик                    = Шапка.Покупатель;
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузополучательПредставление  = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузополучателе,  "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать);
    
    ОбластьМакета.Параметры.МаркаИГосНомерАвтомобиля = МаркаИГосНомерАвтомобиля;
    ОбластьМакета.Параметры.ФИОВодителя = Водитель;
    ОбластьМакета.Параметры.ВидПеревозки = ВидПеревозки;
    ОбластьМакета.Параметры.ГосНомерПрицепа = ГосНомерПрицепа;
    
    ОбластьМакета.Параметры.ПунктПогрузки = ПунктПогрузки;
    ОбластьМакета.Параметры.ПунктРазгрузки = ПунктРазгрузки;
    
    ОбластьМакета.Параметры.ОрганизацияПеревозчик = Перевозчик;
    
    Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);
    
    // Отпуск товара разрешил
    ФИООтпускРазрешил       = Руководители.РуководительПредставление;
    ДолжностьОтпускРазрешил = Руководители.РуководительДолжность;
    
    ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ?(ЗначениеЗаполнено(ФИООтпускРазрешил), ФИООтпускРазрешил + ", " + ДолжностьОтпускРазрешил, "");
    
    ОбластьМакета.Параметры.СерияДоверенности = Шапка.ДоверенностьСерия;
    ОбластьМакета.Параметры.НомерДоверенности = Шапка.ДоверенностьНомер;
    ОбластьМакета.Параметры.ДатаДоверенности  = Формат(Шапка.ДоверенностьДата, "ДФ = ""дд.ММ.гггг""");
    
    СуммаСНДС   = Окр((ЗапросТовары.Итог("Сумма") + ?(Шапка.СуммаВключаетНДС, 0, ЗапросТовары.Итог("СуммаНДС"))), 2);
    ОбластьМакета.Параметры.ОтпущеноНаСуммуПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаСНДС, Константы.ВалютаРегламентированногоУчета.Получить(), КодЯзыкаПечать);
    ОбластьМакета.Параметры.СуммаНДС                = ОбщегоНазначенияБПВызовСервера.ФорматСумм(ЗапросТовары.Итог("СуммаНДС"), Константы.ВалютаРегламентированногоУчета.Получить());
    
    Количество = ЗапросТовары.Итог("Количество");
    КоличествоМест = ?(Цел(Количество) = Количество, Количество, Цел(Количество) + 1);
    КоличествоМестПрописью = НРег(ЧислоПрописью(КоличествоМест,"Л=uk_UK"));
    ОбластьМакета.Параметры.КоличествоМестПрописью  = Лев(КоличествоМестПрописью,СтрДлина(КоличествоМестПрописью)-3);
    
    ТабДокумент.Вывести(ОбластьМакета);
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    
    // Выводим заголовок таблицы
    ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    ТабДокумент.Вывести(ЗаголовокТаблицы);
    
    КоличествоСтрок = ЗапросТовары.Количество();

    // инициализация итогов по странице
    ИтогоКоличествоНаСтранице = 0;
    ИтогоСуммаСНДСНаСтранице  = 0;

    // инициализация итогов по документу
    ИтогоМест       = 0;
    ИтогоКоличество = 0;
    ИтогоСуммаСНДС  = 0;
    Ном             = 1;

    // Выводим многострочную часть докмента
    ОбластьМакета = Макет.ПолучитьОбласть("Строка");
    Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл

        Если НЕ ЗначениеЗаполнено(ВыборкаСтрок.Номенклатура) Тогда
            Сообщить(НСтр("ru='В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.';uk='В одному з рядків не заповнене значення номенклатури - рядок під час друку буде пропущений.'"), СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;

        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрок);
        ОбластьМакета.Параметры.НомерСтроки = Ном;
        ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрок.ТоварНаименование;
        //        Мест        = ВыборкаСтрок.КоличествоМест;
        Количество  = ВыборкаСтрок.Количество;
        СуммаСНДС   = Окр((ВыборкаСтрок.Сумма + ?(Шапка.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС)), 2);
        СуммаБезНДС = СуммаСНДС - ВыборкаСтрок.СуммаНДС;
        
        ОбластьМакета.Параметры.Сумма = СуммаСНДС;

        ОбластьМакета.Параметры.Цена = ?(Количество = 0, 0, СуммаБезНДС / Количество);

        ТабДокумент.Вывести(ОбластьМакета);

        // увеличим итоги по дукументу
        ИтогоКоличество = ИтогоКоличество + Количество;
        ИтогоСуммаСНДС  = ИтогоСуммаСНДС  + СуммаСНДС;
        Ном             = Ном + 1;

    КонецЦикла;

    // Выводим итоги по документу в целом
    ОбластьМакета = Макет.ПолучитьОбласть("Всего");
    ОбластьМакета.Параметры.ИтогоКоличество = ИтогоКоличество;
    ОбластьМакета.Параметры.ИтогоСуммаСНДС  = ИтогоСуммаСНДС;

    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("ПогрузочныеОперации");
    ТабДокумент.Вывести(ОбластьМакета);
    
КонецПроцедуры  //ЗаполнитьТТН2014
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143135 · Ответов: 5 · Просмотров: 466
 

>  Этикетка товара
XacTLa
Отправлено: 25.06.18, 15:32


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)

Не могу понять как мне создать этикетку с назначением товара, а именно что бы был номер заказа на этикетке при печати. Что бы информацию брать с назначения товара с производства. Уже все облазил не могу понять как.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142885 · Ответов: 2 · Просмотров: 960
 

>  МаршрутныйЛистПроизводства
XacTLa
Отправлено: 22.05.18, 9:09


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Всем гадалка и экстрасенсам спасибо Сам разобрался. Тему можно закрыть
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141796 · Ответов: 5 · Просмотров: 266
 

>  МаршрутныйЛистПроизводства
XacTLa
Отправлено: 22.05.18, 7:16


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Вчера, 23:37 * ,
ее нет смысла показывать мне нужно добавить код номенклатуры в печатную форму? немного не доганяю, знаю что через настройки можно сделать, но как только я это делаю, сразу же ошибка в стандартном "маршрутном листе" что параметр код не обнаружен
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141792 · Ответов: 5 · Просмотров: 266
 

>  МаршрутныйЛистПроизводства
XacTLa
Отправлено: 21.05.18, 22:10


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)
Есть внешняя печатная обработка "МаршрутныйЛистПроизводства", но могу понять как как засунуть туда КодНоменклатуры.
Так как этикетки нужно печатать с маршрутного листа.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141776 · Ответов: 5 · Просмотров: 266
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 23.04.18, 8:03


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ 29.03.18, 12:21 * ,
можно ли указать в данной внешней обработке что бы Единицу измерения эти данные брались с другой таблицы? и как это делать добавить нужно реквизит?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140988 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 29.03.18, 8:06


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 11:54 * ,


И даже когда вставляю ЕдиницаИзмерения, тоже такая ошибка, хотя данные беру с оригинального маршрутного листа, не могу понять в чем прикол, я уже и упаковку вставлял, и что только не пробовал нечего не выходит


 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140201 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 27.03.18, 16:10


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 17:09 * ,
просто скрин верный а там стоит курсор на оригинальном маршрутном, так как пытался от туда взять данные извините если туплю.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140125 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 27.03.18, 15:53


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 16:51 * ,
Как понять имя? одинаковый макет и свойства к нему
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140122 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 27.03.18, 14:44


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ 19.03.18, 18:58 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
        ОбластьСтроки.Параметры.ЕдиницаИзмеренияНаименование = ТекущаяСтрока.ЕдиницаИзмеренияНаименование;
                        ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции // СформироватьПечатнуюФорму()




и выдает ошибку что типо нет такого параметра как ЕдиницаИзмеренияНаименование хотя я его указал
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140111 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 17:52


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 17:48 * ,
Я уже указывал ЕденицуИзмерения нечего не помогает, мне нужно в коде заполнить
ОбластьСтроки.Параметры.ЕденицаИзмерения = ТекущаяСтрока.ЕденицаИзмерения;
и в свойствах документа указать параметр к ячейке ЕденицаИзмерения?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139790 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 17:41


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 17:06 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
                ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции // СформироватьПечатнуюФорму()
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139787 · Ответов: 17 · Просмотров: 753
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 16:49


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 16:21 * ,
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139782 · Ответов: 17 · Просмотров: 753
 

4 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 16.01.19, 6:24
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне