Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 11, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

7 страниц V   1 2 3 > » 

>  Мак адресс клиента
Vladal
Отправлено: 16.10.18, 9:48


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(l2d808 @ 09.10.18, 16:27) *
Как узнать MAC адрес компьютера, с которого заходил пользователь?

У Вас получилось получить адреса?

Интересно, зря ли я трудился? (себе я ответ знаю - я себе алгоритм положил в копилку)

Имеет ли смыл делать вторую часть вопроса?
Цитата(l2d808 @ 09.10.18, 16:27) *
А также записать этот МАК в справочник.

  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #146317 · Ответов: 3 · Просмотров: 172
 

>  Как вытянуть в печ. таблицу несколько списков значений, с разным количеством значений
Vladal
Отправлено: 16.10.18, 9:44


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(nysysimara @ 16.10.18, 8:03) *
Мне кажется, задача сводится к построению 2х мерного массива из перечня одномерных,

Именно так.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #146315 · Ответов: 9 · Просмотров: 172
 

>  не запускается толстый клиент
Vladal
Отправлено: 16.10.18, 9:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Уважаемый автор!

Было бы интересно узнать результат.
  Форум: Прочее 1С 8 · Просмотр сообщения: #146314 · Ответов: 3 · Просмотров: 141
 

>  Как вытянуть в печ. таблицу несколько списков значений, с разным количеством значений
Vladal
Отправлено: 14.10.18, 12:52


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Когда-то делал такую задачу, но без вывода на печать.

Выборка из нескольких документов, в счетчике по количеству документов добавлял колонки "Номенклатура_" + Сч, "Количество_" + Сч.
Получил максимальное количество ТЧ документов и по ним программно создал таблицу с нужным количеством строк.

Затем в цикле по документам и по строкам документов в нужные координаты ТЗ (Документ, НомерСтроки) записывал данные из документа.

И в конце стандартно выводил таблицу значений.

В Вашей задаче просто вывести и присоединить все секции шапок, построчно выводить номенклатуру и количество, а если значений номенклатуры в колонке не заполнено, значит вывести дно таблицы и поместить, что этому не наливать для этой колонки подвал выведен.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #146285 · Ответов: 9 · Просмотров: 172
 

>  Расшифровка в один клик с помощью настройки макета
Vladal
Отправлено: 14.10.18, 12:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


На форуме есть заметка о расшифровке:
http://pro1c.org.ua/index.php?showtopic=13696

Вот и сделаем согласно описанию:

На форме в поле результата добавить обработчик

Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
    
    Перем ВыполненноеДействие;
    
    Если ТипЗнч(Расшифровка)= Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда
        
        Попытка
            Поля = ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля();
            Если Поля.Количество() Тогда
                Значение = Поля[0].Значение;
            Иначе
                Значение = Неопределено;
            КонецЕсли;
        Исключение
            Значение = Неопределено;
        КонецПопытки;
        
        // Здесь описано условие на типы данных, открываемых сразу
        Если ТипЗнч(Значение) = Тип("ДокументСсылка.РеализацияТоваровУслуг")
         ИЛИ ТипЗнч(Значение) = Тип("СправочникСсылка.Номенклатура") Тогда
            
            //Если значение определенного типа тогда
            СтандартнаяОбработка = Ложь;
            СписокДействий = Новый СписокЗначений;
            ДоступныеДействия = Новый Массив();
            ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение);
            ОбработкаРасшифровки=Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
            Настройки = ОбработкаРасшифровки.Выполнить(Расшифровка, ВыполненноеДействие, ДоступныеДействия, СписокДействий);
            
            Если Настройки <> Неопределено Тогда
                //КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
                //ЭлементыФормы.Результат.Очистить();
                //СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки);
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЕсли;
    
КонецПроцедуры


В результате при клике на ячейки с типом "СправочникСсылка.Номенклатура" и Регистратор с типом "ДокументСсылка.РеализацияТоваровУслуг" откроется непосредственно сам объект.



Можно подумать, как это нарисовать полностью программно - это наверно написано в книге Хрусталёвой по СКД.
  Форум: Система компоновки данных · Просмотр сообщения: #146284 · Ответов: 3 · Просмотров: 198
 

>  не запускается толстый клиент
Vladal
Отправлено: 13.10.18, 17:17


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Смотрите в сторону разделения серверных и клиентских вызовов.

Почему работало на файловой - грубо говоря, файловый запуск это "клиент", которому доступны все методы клиента и сервера.
Когда запустили клиент-серверный вариант, то произошло разделение функций на "сервер" и "клиент".
"серверу" (процесс rphost.exe, который находится на пером сервере) недоступны элементы формы, потому что он физически изолирован от клиента (процесс 1cv8.exe выполняется на втором сервере, терминальном).

Новый Действие
Наверно процедура находится в общем модуле со свойством Сервер.
Создайте новый общий модуль, назовите ПроцедурыКлиент и поставьте ему свойство "Клиент".
Соответственно, перепишите вызов этого модуля из форм объектов.

В синтакс-помощнике обращайте внимание на доступность объектов - "на сервере", "на клиенте" и пр.
  Форум: Прочее 1С 8 · Просмотр сообщения: #146276 · Ответов: 3 · Просмотров: 141
 

>  Кофигурация для пивного магазина
Vladal
Отправлено: 11.10.18, 14:19


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Автоматизировал розничную сеть пивных.
На фронт-офис поставили Розницу.
Допилили подключение-отключение кег.
Бэкофис на УТП, чтобы потом из УТ не гонять документы в Бухгалтерию для реглотчетности.
  Форум: Помогите подобрать конфигурацию · Просмотр сообщения: #146205 · Ответов: 11 · Просмотров: 205
 

>  Расшифровка в один клик с помощью настройки макета
Vladal
Отправлено: 11.10.18, 14:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Нужен сферический пример в вакууме.
Пусть это будет Номенклатура на Складах по Регистраторам.
  Форум: Система компоновки данных · Просмотр сообщения: #146204 · Ответов: 3 · Просмотров: 198
 

>  Вывод двух табличных документов в один с сохранением группировок
Vladal
Отправлено: 11.10.18, 12:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


До конца не уверен, но можно попробовать метод Разместить.
Получить область справа от таблицы, где должна находиться диаграмма и объект диаграммы Разместить в указанной области.
По крайней мере, так работает с рисунками, штрихкодами и другими внедренными объектами.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #146200 · Ответов: 6 · Просмотров: 676
 

>  Мак адресс клиента
Vladal
Отправлено: 11.10.18, 9:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата
Как узнать MAC адрес компьютера, с которого заходил пользователь?


MAC-адрес можно узнать командой getmac из командной строки Windows:
Так же не забывайте, что в системе могут быть установлены несколько сетевых карт и протоколов, а вызов свойств сетевой карты клиента надо делать локально, если подключаетесь к серверу удаленно.

|C:\Program Files\PostgreSQL\9.4.2-1.1C\bin>getmac
|
|Физический адрес  Имя транспорта
|================= ==========================================================
|10-7B-44-16-C7-79 \Device\Tcpip_{4B9F7E56-610E-460F-90A7-AE2D91F2A575}
|00-FF-16-0D-B3-13 \Device\Tcpip_{160DB313-5615-466C-8497-D972C58FA97B}
|00-FF-32-A9-18-E2 \Device\Tcpip_{32A918E2-ECF9-4C8C-8DD8-417D7B1794B9}
|00-FF-86-45-FA-82 \Device\Tcpip_{8645FA82-14B3-412B-ACD9-60885857F52A}
|
|C:\Program Files\PostgreSQL\9.4.2-1.1C\bin>


Пишем запрос к объекту Win32_NetworkAdapter:

Процедура ОпределитьMAC_адресНажатие(Элемент)
    
    ServicesSet = ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера() + "\root\cimv2");
    Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapter");
    Для каждого Item Из Items Цикл
        MACAddress = Item.MACAddress;
        Если Не ЗначениеЗаполнено(MACAddress) Тогда // -- если убрать это условие, можно получить еще больше интересной информации
            Продолжить;
        КонецЕсли;
        AdapterType = Item.AdapterType;
        Caption  = Item.Caption; //-- переименуйте эту переменную, потому как она меняет заголовок окна обработки, это английский синоним свойства Форма.Заголовок
        Manufacturer = Item.Manufacturer;
        Status  = Item.Status;
        Name = Item.Name;
        PermanentAddress = Item.PermanentAddress;
        Line = "AdapterType: " + AdapterType
            + символы.ПС + "Caption: " + Caption
            + символы.ПС + "Manufacturer: " + Manufacturer
            + символы.ПС + "MACAddress: " + MACAddress
            + символы.ПС + "Name: " + Name
            + символы.ПС + "Status: " + Status;
        Сообщить(Line);
    КонецЦикла;
    
КонецПроцедуры


И вот вывод моей процедурки на моем сервере:

Цитата
AdapterType: Ethernet 802.3
Caption: [00000009] Realtek PCIe GBE Family Controller
Manufacturer: Realtek
MACAddress: 10:7B:44:16:C7:79
Name: Realtek PCIe GBE Family Controller #2
Status:
AdapterType: Ethernet 802.3
Caption: [00000012] TAP-Win32 Adapter V9
Manufacturer: TAP-Win32 Provider V9
MACAddress: 00:FF:16:0D:B3:13
Name: TAP-Win32 Adapter V9 #3
Status:
AdapterType: Ethernet 802.3
Caption: [00000013] TAP-Win32 Adapter V9
Manufacturer: TAP-Win32 Provider V9
MACAddress: 00:FF:32:A9:18:E2
Name: TAP-Win32 Adapter V9
Status:
AdapterType: Ethernet 802.3
Caption: [00000015] TAP-Win32 Adapter V9
Manufacturer: TAP-Win32 Provider V9
MACAddress: 00:FF:86:45:FA:82
Name: TAP-Win32 Adapter V9 #2
Status:


Развивая тему, вытащил IP-адреса для каждой сетевухи:

Цитата
MAC адрес: 10:7B:44:16:C7:79
.IP адрес: 192.168.0.7
.IP адрес: fe80::c52f:4618:2c8b:851e
MAC адрес: 00:FF:16:0D:B3:13
.IP адрес: 10.12.12.1
MAC адрес: 00:FF:32:A9:18:E2
.IP адрес: 10.10.10.1
MAC адрес: 00:FF:86:45:FA:82
.IP адрес: 10.11.11.1

Процедура ОпределитьIPНажатие(Элемент)
    
    // Определение MAC и IP адресов
    
    MACAddress = "";
    ServicesSet = ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера() + "\root\cimv2");
    Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapter");
    Для каждого Item Из Items Цикл
        MACAddress = Item.MACAddress;
        
        Если MACAddress <> Null Тогда
            Сообщить("MAC адрес: " + MACAddress);
            
            Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapterConfiguration");
            Для каждого Item Из Items Цикл
                Если Item.MACAddress = MACAddress Тогда
                    Если Item.MACAddress <> Null Тогда
                        Для каждого IPAddress Из Item.IPAddress Цикл
                            Сообщить(".IP адрес: " + IPAddress);
                        КонецЦикла;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #146185 · Ответов: 3 · Просмотров: 172
 

>  Программист 1С, Одесса
Vladal
Отправлено: 11.10.18, 5:08


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(Flexy @ 09.10.18, 21:50) *
В старт посте 12К. Я что-то пропустил???
Это ЗП на испытательном сроке. Рассуждаю, что после испытательного должно быть около 16 или выше.

Э.... То и на испытательном сроке надо работать не с 9 до 18, а с 9 до 15?

Цитата(Flexy @ 09.10.18, 22:45) *
От куда такие вакансии

// да тут не только мягкий знак, тут и пробел западает. Я не придираюсь. Отнюдь.

Вот откуда: из рынка
https://www.work.ua/jobs-программист+1с/

Сегодня в топе обычные торговцы - "Червоний Маркет", 35 тыс, торгуют мелочевкой по низким ценам. Летом предлагали еще по 30 тыс.

Листаем дальше
- Эко Маркет. Белая зарплата, 30-35 тыс. Считайте ФОТ сами.
- Мета Капитал уже в топ вылез. Наверно робот Ворка его поднял. 45.
- Агромарс, УПП, от 35. Давно не следил, на УПП это мало или норм?
- Какая-то жадная галера, до 20 грн предлагает. Там точно нужны вьюноши с горящими глазами и широкими ушами, чтобы по ним поездить.
- Кривой Рог, недоработа в Харькове - в пределах 20, не рассматриваем.
- Одесса. Витол. 35 грн в месяц.
- опять Харьков, 12500, и из тех 12 тыс скромно 4 на карточку.
- Теллур Харьков. 10 тыс. Это позорище.
- ВиЯр - торговля, 30 грн.
- галера Фортолис - пишут 30, но наверно при условии закрытия 700 часов в месяц. Ладно, утрирую, меньше.
- КТ Украина, производитель инструментов. 30 тыс. Наверно УПП или что похуже - УТП.
- еще одна галера ИТ-фабрика, 40 в потолке.
- ювелирные магазины ищут программиста-консультанта на 25 тыс.
- Адамакс, оптовая торговля, дистрибьюция - ищет младшего специалиста-падавана под присмотр ведущего программиста, 20 тыс.
- Розетка. 52 тыс. Но зато какие требования! Между прочим, довольно интересный там зоопарк технологий.

Это Киев. Учитывая стоимость съемного жилья в Киеве и Одессе - они на равных.

Дальше.
- ломбард Благо - 40 тыс на УТ. Каждые 3-4 месяца эта вакансия висит месяц
- ТПК Алеф - х.з. что там, тоже 40 тыс.
- АВК - кондитерский концерн. Последний раз видел от них вакансию в мае, повторно в июле. УПП, 45 было тогда. Сейчас не пишут.
- завод меллопластиковых окон как-то вяло ищет на 20 тыс, может найдется студент из Одессы, который месяца 3 поработает на 12 с бесплатными обедами и найдет ту вакансию
- дальше какие-то ФОПы ищут в Полтаву и Киев по 15 и 17 тыс, скорее всего субподряд на распилы.
- торговая компания Будпостач - 40 тыс

Вот откуда эти деньги?
Да просто кто жмется, кто не жмется.

Если бы у нас была экономика стабильная как в Германии, Чехии, Польще, то и знали бы, что, например, рабочий на заводе - 20-22 тыс в месяц получает, программист 25-30, инженер на заводе до 40 и т.д. В любом городе, на любом заводе.
Вкруговую примерно одинаковые цены на рабочую силу.

А пока мы наблюдаем местами нормальных контор, и пока еще много охреневших бояр, считающих "да я вот вам, мерзким людишкам, РАБОТУ ДАЮ!!!!1111адын"
  Форум: Предложения работы · Просмотр сообщения: #146184 · Ответов: 60 · Просмотров: 1290
 

>  Программист 1С, Одесса
Vladal
Отправлено: 07.10.18, 9:53


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


-тся/-ться,

Я нанимаю Вас на 8000 грн, это аж в 2 раза дороже минимальной зарплаты.
  Форум: Предложения работы · Просмотр сообщения: #146045 · Ответов: 60 · Просмотров: 1290
 

>  податкова соціальна пільга на 2-х дітей один з яких інвалід
Vladal
Отправлено: 05.10.18, 12:29


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(SPBatyus @ 03.10.18, 15:17) *
Что нужно добавить чтобы программа считала количество льгот не 2, а 2,5, т.е применила бы льготу на ребенка инвалида?

В алгоритм расчета добавить суммирование коэффициентов. пока похоже, коэффициенты льгот работают как вытеснение меньшего большим.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #146005 · Ответов: 2 · Просмотров: 117
 

>  Новая "заява-розрахунок" больничных для ФСС 2018
Vladal
Отправлено: 05.10.18, 12:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


[ворчание]... совсем эти бухи обленились... в медок не могут ручками вбить несколько больничных[/ворчание]
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #146004 · Ответов: 5 · Просмотров: 342
 

>  Подойдет ли для Украины УТ 11 для России?
Vladal
Отправлено: 05.10.18, 12:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Есть CRM для Украины. Её и связывать с украинской Торговлей.

И вобще будут бегать справочники и документы.
Все связи можно настраивать в Правилах обмена.
А так - разные планы счетов, разные бланки, разные методики.

CRM для России почему? Для российских менеджеров? Или просто "что нашли в интернете"?
С помощью "Конвертации Данных" настраивали обмен между самописной конфой на 1С 7.7 с Бухгалтерией на 1С 8.

И как уже сказали выше - ваш программист пользуется вашей некомпетентностью либо сам некомпетентен.
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #146003 · Ответов: 8 · Просмотров: 189
 

>  Как Свернуть даные по нескольким значениям группировочных колонок
Vladal
Отправлено: 03.10.18, 9:36


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(Sirius83 @ 03.10.18, 0:29) *
Например Строка Код 33 должна включать в себя 34 и 37.

Добавьте свою новую колонку, куда для строк с кодами 33, 34 и 37 будете помещать условный идентификатор "Код33", а для остальных - их обычный. Потом эту колонку включить в свертку вместо той, по которой сейчас сворачивается.

Как пример: в цикле перебрать все строки таблицы и прописать:

ТЗ.ДобавитьКолонку("ГруппировкаКод");
...
цикл по перебору ...

    Если Код = 33 Или Код = 34 Или Код = 37 Тогда
        СтрокаТЗ.ГруппировкаКод = "33";
        СтрокаТЗ.Вид = "Вина виноградні";
    Иначе
        СтрокаТЗ.ГруппировкаКод = СтрокаТЗ.Код;
    КонецЕсли;

КонецЦикла;

// Было: (как пример)
//ТЗ.Свернуть("Код, Вид", "НачОстаток, реализация1, реализация2, реализация3");

// Заменить на:
ТЗ.Свернуть("ГруппировкаКод, Вид", "НачОстаток, реализация1, реализация2, реализация3");


Затем отсортировать и вывести таблицу.

Но это если просто свернуть.
А если свернуть по группировке, сохраняя данные вложенных строк (34 и 37), то надо подумать чуть больше.
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #145931 · Ответов: 7 · Просмотров: 177
 

>  Программист 1С, Одесса
Vladal
Отправлено: 02.10.18, 9:30


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(TipsyKID @ 27.09.18, 16:25) *
а потом уже все остальное: деньги, слава, еда.

Да? Вьюноши с горящими глазами?
Я за совмещение получения опыта и достойной оплаты труда.
  Форум: Предложения работы · Просмотр сообщения: #145888 · Ответов: 60 · Просмотров: 1290
 

>  Какой купить компьютер под сервер 1с?
Vladal
Отправлено: 01.10.18, 14:17


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(Vofka @ 27.09.18, 10:39) *
Vladal, при установке SQL-я в режиме "Next - Next - Next", не изменяя после этого его настройки, он со временем может съедать и 600 Гб. Как выше уже заметили, это можно отрегулировать настройками. Для 10 пользователей, мне кажется, 8 Гб под SQL будет более чем.

Цитата(Vladal @ 26.09.18, 15:37) *
но это просто - одноразово наймите ИТ-фирму и заплатите специалистам, выполняйте все их рекомендации.

  Форум: Администрирование и настройка компьютера, железо · Просмотр сообщения: #145866 · Ответов: 5 · Просмотров: 198
 

>  Модуль №21 для 1С: Автоматизация сервиса
Vladal
Отправлено: 01.10.18, 14:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Цитата(assory @ 26.09.18, 12:06) *
Помогите плизз найти Модуль №21 для 1С:

Вот, пожалуйста:
Компания-разработчик "Первый модуль" - автор
Список партнеров фирмы 1С в Украине - дилеры, франчайзи
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #145865 · Ответов: 1 · Просмотров: 168
 

>  Сервер под 1с
Vladal
Отправлено: 01.10.18, 14:11


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Я вбил в поисковик "аренда сервера до 100-150 у.е. в месяц." и дальше не знаю, какой резултат Вам подойдёт.
Можно еще поискать "услуги дата-центров в городе ХХХХХ" и задать вопрос менеджеру той компании, думаю, они ответят на все вопросы.
  Форум: Администрирование и настройка компьютера, железо · Просмотр сообщения: #145864 · Ответов: 2 · Просмотров: 149
 

>  "Ошибка при выполнении файловой операции" при обновлении конфигурации
Vladal
Отправлено: 29.09.18, 6:24


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Мое предположение - ошибка платформы или последовательность действий.

Я заметил, что конфигурация поставщика иногда слетает, если при обновлении релиза накатывать .cf, выгруженный из копии базы, предварительно не обновив конфигурацию поставщика из меню Поддержка.

Потом можно слететь любая из конфигураций поставщика. У меня их несколько от разных поставщиков, каждая со своей подсистемой.

Когда при обновлении делаю сравнение и объединение с .cf изменённой конфигурации и соглашаюсь при вопросе о постановке на поддержку, тогда и слетает.
Но не всегда.

Но это замечено только на клиент-серверном варианте базы, на файловых не замечал. Или наоборот, конфигурация поставщика нарушается при выгрузке из файловой базы.

В любом случае, по размеру вынужденного .cf нельзя определить, слетела или нет конфигурация поставщика.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145832 · Ответов: 5 · Просмотров: 220
 

>  1C и термопринтер TSC ttp-244 pro
Vladal
Отправлено: 28.09.18, 13:46


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


"из утилиты печатает".
Это тот принтер со своим скриптовым языком?
Тогда в 1С надо генерировать скрипт для каждой этикетки - так можно настроить очень точно печать этикетки, особенно если он сложный а шаг сетки таблицы 1С это не позволяет.
Либо переключить принтер в режим стандартной печати Windows и забыть эту проблему.
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #145814 · Ответов: 5 · Просмотров: 1522
 

>  Получить две последние цены товара
Vladal
Отправлено: 28.09.18, 13:22


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Смотрите, пользуйтесь.

ВЫБРАТЬ
    Номенклатура.Ссылка КАК Номенклатура
ПОМЕСТИТЬ втНоменклатура
ИЗ
    Справочник.Номенклатура КАК Номенклатура
ГДЕ
    Номенклатура.Родитель = &Родитель
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ЦеныНоменклатуры.Период КАК Период,
    ЦеныНоменклатуры.Активность,
    ЦеныНоменклатуры.ТипЦен,
    ЦеныНоменклатуры.Номенклатура КАК Номенклатура,
    ЦеныНоменклатуры.Цена КАК Цена
ПОМЕСТИТЬ втЦеныНоменклатуры
ИЗ
    РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
ГДЕ
    ЦеныНоменклатуры.Период <= &ДатаПолученияЦен
    И ЦеныНоменклатуры.Активность
    И ЦеныНоменклатуры.ТипЦен = &ТипЦен
    И ЦеныНоменклатуры.Номенклатура В
            (ВЫБРАТЬ
                втНоменклатура.Номенклатура
            ИЗ
                втНоменклатура КАК втНоменклатура)
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    втНоменклатура.Номенклатура КАК Номенклатура,
    ЕСТЬNULL(втЦеныНоменклатуры.Цена, 0) КАК ПоследняяЦена,
    ЕСТЬNULL(втЦеныНоменклатуры.Период, ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)) КАК ДатаПосленейЦены
ПОМЕСТИТЬ втПоследняяЦена
ИЗ
    втНоменклатура КАК втНоменклатура
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ втЦеныНоменклатуры КАК втЦеныНоменклатуры
        ПО втНоменклатура.Номенклатура = втЦеныНоменклатуры.Номенклатура
            И (втЦеныНоменклатуры.Период В
                (ВЫБРАТЬ ПЕРВЫЕ 1
                    втЦеныНоменклатуры.Период КАК Период
                ИЗ
                    втЦеныНоменклатуры КАК втЦеныНоменклатуры
                ГДЕ
                    втЦеныНоменклатуры.Период <= &ДатаПолученияЦен
                    И втЦеныНоменклатуры.Номенклатура = втНоменклатура.Номенклатура
                УПОРЯДОЧИТЬ ПО
                    Период УБЫВ))
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    втПоследняяЦена.Номенклатура КАК Номенклатура,
    втПоследняяЦена.ПоследняяЦена КАК ПоследняяЦена,
    втПоследняяЦена.ДатаПосленейЦены КАК ДатаПосленейЦены,
    ЕСТЬNULL(втЦеныНоменклатуры.Цена, 0) КАК ПредпоследняяЦена,
    ЕСТЬNULL(втЦеныНоменклатуры.Период, ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)) КАК ДатаПредпоследнейЦены
ИЗ
    втПоследняяЦена КАК втПоследняяЦена
        ЛЕВОЕ СОЕДИНЕНИЕ втЦеныНоменклатуры КАК втЦеныНоменклатуры
        ПО втПоследняяЦена.Номенклатура = втЦеныНоменклатуры.Номенклатура
            И (втЦеныНоменклатуры.Период В
                (ВЫБРАТЬ ПЕРВЫЕ 1
                    втЦеныНоменклатуры.Период КАК Период
                ИЗ
                    втЦеныНоменклатуры КАК втЦеныНоменклатуры
                ГДЕ
                    втЦеныНоменклатуры.Период < втПоследняяЦена.ДатаПосленейЦены
                    И втЦеныНоменклатуры.Номенклатура = втПоследняяЦена.Номенклатура
                УПОРЯДОЧИТЬ ПО
                    Период УБЫВ))

УПОРЯДОЧИТЬ ПО
    Номенклатура,
    ДатаПосленейЦены,
    ДатаПредпоследнейЦены
АВТОУПОРЯДОЧИВАНИЕ


В результате будет таблица с последними двумя ценами номенклатуры с указанием дат установки цены.

Если надо сгруппировать по товару, то просто в последнем подзапросе таблицы не соединять, а объединять и потом сгруппировать по номенклатуре.

  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #145813 · Ответов: 5 · Просмотров: 191
 

>  Программист 1С, Одесса
Vladal
Отправлено: 27.09.18, 13:58


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Похоже, что я зажрался.
  Форум: Предложения работы · Просмотр сообщения: #145775 · Ответов: 60 · Просмотров: 1290
 

>  "Ошибка при выполнении файловой операции" при обновлении конфигурации
Vladal
Отправлено: 27.09.18, 12:02


Завсегдатай
****

Группа: Пользователи
Сообщений: 201
Регистрация: 20.05.09
Из: Купянск
Пользователь №: 539


Такая проблема возникает, если нарушается конфигурация поставщика.
Если её попробовать выгрузить в файл, то файл будет пустой.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145773 · Ответов: 5 · Просмотров: 220
 

7 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 19.10.18, 20:16
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне