Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

3 страниц V   1 2 3 >

>  ТТН для бухгалтерии
XacTLa
Отправлено: 04.07.18, 16:59


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


sava1 @ Сегодня, 17:57 * ,
{ВнешняяОбработка.ТТН2018.МодульОбъекта(61)}: Поле объекта не обнаружено (Документ)
Документ = ПараметрыПечати.Документ;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143142 · Ответов: 5 · Просмотров: 178
 

>  ТТН для бухгалтерии
XacTLa
Отправлено: 04.07.18, 16:05


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


podcast @ Сегодня, 16:36 * ,
{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(233)}: В обработчике печати не был сформирован табличный документ для: ТТН2018
ВызватьИсключение(ТекстСообщенияОбОшибке);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143139 · Ответов: 5 · Просмотров: 178
 

>  ТТН для бухгалтерии
XacTLa
Отправлено: 04.07.18, 14:34


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
Бухгалтерия для Украины, редакция 2.0. (2.0.9.2)

Добрый день, скажи те мне не понимающему делаю ТТН для бухгалтерии Ошибка у меня в том что функция печати код:
 Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТТН") Тогда
            
        
            
    
            ТабДокумент = ПечатьТТН(ПараметрыПечати);
        КонецЕсли;
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТТН", НСтр("ru='Товарно-транспортная накладная (1-ТН)';uk='Товарно-транспортна накладна (1-ТН)'"),
            ТабДокумент,,"Обработка.ПечатьТТН.ПФ_MXL_ТТН");
    
    
    
КонецПроцедуры


Выдает ошибку {ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(233)}: В обработчике печати не был сформирован табличный документ для: ТТН2018
ВызватьИсключение(ТекстСообщенияОбОшибке);

Вот весь код:
Функция СведенияОВнешнейОбработке()Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ТТН2018"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("Информация", "Это 2018 ТТН ");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "ТТН 2018", "ТТН2018", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;
    
КонецФункции // СведенияОВнешнейОбработке()

Функция ПолучитьТаблицуКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыПечати) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ТТН") Тогда
            
        
            
    
            ТабДокумент = ПечатьТТН(ПараметрыПечати);
        КонецЕсли;
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТТН", НСтр("ru='Товарно-транспортная накладная (1-ТН)';uk='Товарно-транспортна накладна (1-ТН)'"),
            ТабДокумент,,"Обработка.ПечатьТТН.ПФ_MXL_ТТН");
    
    
    
КонецПроцедуры

Функция ПечатьТТН(ПараметрыПечати) Экспорт

    УстановитьПривилегированныйРежим(Истина);
    
    мВалютаРегламентированногоУчета = ОбщегоНазначенияБПВызовСервераПовтИсп.ПолучитьВалютуРегламентированногоУчета();
    
    Документ                 = ПараметрыПечати.Документ;
    МаркаИГосНомерАвтомобиля = ПараметрыПечати.МаркаИГосНомерАвтомобиля;
    ГосНомерПрицепа          = ПараметрыПечати.ГосНомерПрицепа;
    ПунктПогрузки            = ПараметрыПечати.ПунктПогрузки;
    ПунктРазгрузки           = ПараметрыПечати.ПунктРазгрузки;
    Водитель                 = ПараметрыПечати.Водитель;
    Перевозчик               = ПараметрыПечати.Перевозчик;
    ВидПеревозки             = ПараметрыПечати.ВидПеревозки;
    НомерТТН                 = ПараметрыПечати.НомерТТН;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ДатаСреза",          Документ.Дата);
    Запрос.УстановитьПараметр("СтруктурнаяЕдиница", Документ.Склад);
    Запрос.УстановитьПараметр("ТекущийДокумент",  Документ);
    Запрос.УстановитьПараметр("ПустойКонтрагент", Справочники.Контрагенты.ПустаяСсылка());

    Запрос.Текст =
    "ВЫБРАТЬ
    |    Ссылка       КАК Документ,
    |    Номер,
    |    Дата         КАК ДатаДокумента,
    |    Организация,
    |    Организация  КАК ЮрФизЛицо,
    |    Организация  КАК Поставщик,
    |    Организация  КАК Контрагент,
    |    Организация  КАК Руководители,
    |    ВЫБОР КОГДА Грузополучатель = &ПустойКонтрагент
    |          ТОГДА Контрагент
    |          ИНАЧЕ Грузополучатель КОНЕЦ КАК Грузополучатель,
    |     Организация  КАК Грузоотправитель,
    |    БанковскийСчетОрганизации КАК БанковскийСчет,
    |    Контрагент   КАК Покупатель,
    |    Контрагент   КАК Плательщик,
    |    ОтветственныеЛица.ФизическоеЛицо КАК ОтветственноеЛицо,
    |    ВалютаДокумента,
    |    КурсВзаиморасчетов       КАК Курс,
    |    КратностьВзаиморасчетов  КАК Кратность,
    |    СуммаВключаетНДС,
    |    Получил,
    |    ДоверенностьСерия,
    |    ДоверенностьНомер,
    |    ДоверенностьДата
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |    РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
    |ПО
    |    ОтветственныеЛица.СтруктурнаяЕдиница = РеализацияТоваровУслуг.Склад
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";

    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();

    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", Документ);

    Если Документ.ВалютаДокумента = Документ.ДоговорКонтрагента.ВалютаВзаиморасчетов Тогда
        // Документ оформлен в валюте взаиморасчетов
        Запрос.УстановитьПараметр("Курс", Документ.КурсВзаиморасчетов);
        Запрос.УстановитьПараметр("Кратность", Документ.КратностьВзаиморасчетов);
    Иначе
        // Документ оформлен в валюте регламентированного учета
        Запрос.УстановитьПараметр("Курс", 1);
        Запрос.УстановитьПараметр("Кратность", 1);
    КонецЕсли;

    Запрос.Текст =
    "ВЫБРАТЬ
    |    ВложенныйЗапрос.Номенклатура                                 КАК Номенклатура,
    |    ВложенныйЗапрос.Номенклатура.НаименованиеПолное              КАК ТоварНаименование,
    |    ВложенныйЗапрос.Номенклатура.Код                             КАК Артикул,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление               КАК БазоваяЕдиницаНаименование,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Код                          КАК БазоваяЕдиницаКодПоОКЕИ,
    |    ВложенныйЗапрос.ЕдиницаИзмерения                             КАК ЕдиницаИзмерения,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление                КАК ВидУпаковки,
    |    ВложенныйЗапрос.СтавкаНДС           КАК СтавкаНДС,
    |    ВложенныйЗапрос.Цена                КАК Цена,
    |    ВложенныйЗапрос.Количество          КАК Количество,
    |    ВложенныйЗапрос.Сумма               КАК Сумма,
    |    ВложенныйЗапрос.СуммаНДС            КАК СуммаНДС,
    |    ВложенныйЗапрос.НомерСтроки         КАК НомерСтроки,
    |    ВложенныйЗапрос.Метка               КАК Метка
    |ИЗ
    |
    |    (
    |    ВЫБРАТЬ
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения                      КАК ЕдиницаИзмеренияМест,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена * &Курс / &Кратность             КАК Цена,
    |        СУММА(РеализацияТоваровУслуг.Количество)                     КАК Количество,
    |        СУММА(РеализацияТоваровУслуг.Сумма    * &Курс / &Кратность)  КАК Сумма,
    |        СУММА(РеализацияТоваровУслуг.СуммаНДС * &Курс / &Кратность)  КАК СуммаНДС,
    |        МИНИМУМ(РеализацияТоваровУслуг.НомерСтроки)                  КАК НомерСтроки,
    |        0                                                            КАК Метка
    |    ИЗ
    |        Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |    ГДЕ
    |        РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    |        РеализацияТоваровУслуг.Номенклатура,
    |        РеализацияТоваровУслуг.Коэффициент,
    |        РеализацияТоваровУслуг.ЕдиницаИзмерения,
    |        РеализацияТоваровУслуг.СтавкаНДС,
    |        РеализацияТоваровУслуг.Цена
    |
    |    ) КАК ВложенныйЗапрос
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    РеализацияТоваровУслуг.Номенклатура                    КАК Номенклатура,
    |    РеализацияТоваровУслуг.Номенклатура.НаименованиеПолное КАК ТоварНаименование,
    |    РеализацияТоваровУслуг.Номенклатура.Код                  КАК Артикул,
    |    РеализацияТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Представление               КАК БазоваяЕдиницаНаименование,
    |    РеализацияТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения.Код                         КАК БазоваяЕдиницаКодПоОКЕИ,
    |    РеализацияТоваровУслуг.Номенклатура.БазоваяЕдиницаИзмерения                             КАК ЕдиницаИзмерения,
    |    NULL                                                  КАК ВидУпаковки,
    |    ""Без НДС""                                           КАК СтавкаНДС,
    |    РеализацияТоваровУслуг.Цена * &Курс / &Кратность      КАК Цена,
    |    РеализацияТоваровУслуг.Количество                     КАК Количество,
    |    РеализацияТоваровУслуг.Сумма * &Курс / &Кратность     КАК Сумма,
    |    0                                                     КАК СуммаНДС,
    |    РеализацияТоваровУслуг.НомерСтроки                    КАК НомерСтроки,
    |    2                                                     КАК Метка
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.ВозвратнаяТара КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |    РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |УПОРЯДОЧИТЬ ПО Метка ВОЗР, НомерСтроки ВОЗР
    |
    |";

    ЗапросТовары = Запрос.Выполнить().Выгрузить();

    ТабДокумент = Новый ТабличныйДокумент;

    Если Шапка.ДатаДокумента < Дата("20140114") Тогда
        ЗаполнитьТТН (Шапка, ЗапросТовары, ТабДокумент,ПараметрыПечати)
    Иначе
        ЗаполнитьТТН2014 (Шапка, ЗапросТовары, ТабДокумент,ПараметрыПечати)
    КонецЕсли;
    
    Возврат ТабДокумент;

КонецФункции // ПечатьТТН()
    
Процедура ЗаполнитьТТН (Шапка, ЗапросТовары, ТабДокумент, ПараметрыПечати)
    
    Документ                 = ПараметрыПечати.Документ;
    МаркаИГосНомерАвтомобиля = ПараметрыПечати.МаркаИГосНомерАвтомобиля;
    ГосНомерПрицепа          = ПараметрыПечати.ГосНомерПрицепа;
    ПунктПогрузки            = ПараметрыПечати.ПунктПогрузки;
    ПунктРазгрузки           = ПараметрыПечати.ПунктРазгрузки;
    Водитель                 = ПараметрыПечати.Водитель;
    Перевозчик               = ПараметрыПечати.Перевозчик;
    ВидПеревозки             = ПараметрыПечати.ВидПеревозки;
    НомерТТН                 = ПараметрыПечати.НомерТТН;
    
    // Зададим параметры макета
    ТабДокумент.ПолеСверху              = 0;
    ТабДокумент.ПолеСлева               = 5;
    ТабДокумент.ПолеСнизу               = 0;
    ТабДокумент.ПолеСправа              = 5;
    ТабДокумент.АвтоМасштаб             = Истина;
    ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;

    Макет = УправлениеПечатью.ПолучитьМакет("Обработка.ПечатьТТН.ПФ_MXL_ТТН");
    
    КодЯзыкаПечать = "uk";
    
    // Выводим общие реквизиты шапки
    СведенияОПокупателе       = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель,       Шапка.ДатаДокумента);
    СведенияОГрузополучателе  = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузополучатель,  Шапка.ДатаДокумента);
    СведенияОГрузоотправитель = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузоотправитель, Шапка.ДатаДокумента);

    Если ЗначениеЗаполнено(Документ.БанковскийСчетОрганизации) Тогда
        НомерСчета = Документ.БанковскийСчетОрганизации.НомерСчета;
        Банк       = Документ.БанковскийСчетОрганизации.Банк;
        МФО           = Документ.БанковскийСчетОрганизации.Банк.Код;
        
        СведенияОГрузоотправитель.Вставить("НомерСчета",       НомерСчета);
        СведенияОГрузоотправитель.Вставить("Банк",             Банк);
        СведенияОГрузоотправитель.Вставить("МФО",              МФО);
    КонецЕсли;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.НомерДокумента                = НомерТТН;
    ОбластьМакета.Параметры.ДатаДокумента                 = Шапка.ДатаДокумента;
    ОбластьМакета.Параметры.Грузоотправитель              = Шапка.Грузоотправитель;
    ОбластьМакета.Параметры.Грузополучатель               = Шапка.Грузополучатель;
    ОбластьМакета.Параметры.Плательщик                    = Шапка.Покупатель;
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузополучательПредставление  = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузополучателе,  "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузоотправительЕДРПОУ = СведенияОГрузоотправитель.КодПоЕДРПОУ;
    ОбластьМакета.Параметры.ГрузополучательЕДРПОУ  = СведенияОГрузополучателе.КодПоЕДРПОУ;
    ОбластьМакета.Параметры.ПлательщикЕДРПОУ       = СведенияОПокупателе.КодПоЕДРПОУ;
    
    ОбластьМакета.Параметры.МаркаИГосНомерАвтомобиля = МаркаИГосНомерАвтомобиля;
    ОбластьМакета.Параметры.ФИОВодителя = Водитель;
    ОбластьМакета.Параметры.ВидПеревозки = ВидПеревозки;
    ОбластьМакета.Параметры.ГосНомерПрицепа = ГосНомерПрицепа;
    
    ОбластьМакета.Параметры.ПунктПогрузки = ПунктПогрузки;
    ОбластьМакета.Параметры.ПунктРазгрузки = ПунктРазгрузки;
    
    ОбластьМакета.Параметры.ОрганизацияПеревозчик = Перевозчик;
    
    ТабДокумент.Вывести(ОбластьМакета);

    СтрокНаСтранице = 23;
    СтрокШапки      = 10;
    СтрокПодвала    = 9;
    НомерСтраницы   = 1;

    // Выводим заголовок таблицы
    ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    ТабДокумент.Вывести(ЗаголовокТаблицы);

    КоличествоСтрок = ЗапросТовары.Количество();

    Если КоличествоСтрок = 1 Тогда
        ПереноситьПоследнююСтроку = 0;
    Иначе
        ЦелыхСтраницСПодвалом     = Цел((СтрокШапки + КоличествоСтрок + СтрокПодвала) / СтрокНаСтранице);
        ЦелыхСтраницБезПодвала    = Цел((СтрокШапки + КоличествоСтрок - 1) / СтрокНаСтранице);
        ПереноситьПоследнююСтроку = ЦелыхСтраницСПодвалом - ЦелыхСтраницБезПодвала;
    КонецЕсли;

    // инициализация итогов по странице
    ИтогоКоличествоНаСтранице = 0;
    ИтогоСуммаСНДСНаСтранице  = 0;

    // инициализация итогов по документу
    ИтогоМест       = 0;
    ИтогоКоличество = 0;
    ИтогоСуммаСНДС  = 0;
    Ном             = 0;

    // Выводим многострочную часть докмента
    ОбластьМакета = Макет.ПолучитьОбласть("Строка");
    Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл

        Если НЕ ЗначениеЗаполнено(ВыборкаСтрок.Номенклатура) Тогда
            Сообщить(НСтр("ru='В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.';uk='В одному з рядків не заповнене значення номенклатури - рядок під час друку буде пропущений.'"), СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;

        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрок);
        ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрок.ТоварНаименование;
        //        Мест        = ВыборкаСтрок.КоличествоМест;
        Количество  = ВыборкаСтрок.Количество;
        СуммаСНДС   = Окр((ВыборкаСтрок.Сумма + ?(Шапка.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС)), 2);
        ОбластьМакета.Параметры.Сумма = СуммаСНДС;

        ОбластьМакета.Параметры.Цена = ?(Количество = 0, 0, СуммаСНДС / Количество);

        ТабДокумент.Вывести(ОбластьМакета);

        // увеличим итоги по дукументу
        ИтогоКоличество = ИтогоКоличество + Количество;
        ИтогоСуммаСНДС  = ИтогоСуммаСНДС  + СуммаСНДС;

    КонецЦикла;

    // Выводим итоги по документу в целом
    ОбластьМакета = Макет.ПолучитьОбласть("Всего");
    ОбластьМакета.Параметры.ИтогоКоличество = ИтогоКоличество;
    ОбластьМакета.Параметры.ИтогоСуммаСНДС  = ИтогоСуммаСНДС;

    ТабДокумент.Вывести(ОбластьМакета);

    // Выводим подвал документа
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");

    Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);
    
    // Отпуск товара разрешил
    ФИООтпускРазрешил       = Руководители.РуководительПредставление;
    ДолжностьОтпускРазрешил = Руководители.РуководительДолжность;
    
    ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ДолжностьОтпускРазрешил;
    ОбластьМакета.Параметры.ДоверенностьЧерезКого   = Шапка.Получил;
    
    ОбластьМакета.Параметры.СерияДоверенности = Шапка.ДоверенностьСерия;
    ОбластьМакета.Параметры.НомерДоверенности = Шапка.ДоверенностьНомер;
    ОбластьМакета.Параметры.ДатаДоверенности  = Формат(Шапка.ДоверенностьДата, "ДФ = ""дд.ММ.гггг""");
    ОбластьМакета.Параметры.ОтпущеноНаСуммуПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(ИтогоСуммаСНДС, Константы.ВалютаРегламентированногоУчета.Получить(), КодЯзыкаПечать);
    ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть("ПогрузочныеОперации");
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("ПрочиеСведения");
    ТабДокумент.Вывести(ОбластьМакета);

КонецПроцедуры // ЗаполнитьТТН()

Процедура ЗаполнитьТТН2014 (Шапка, ЗапросТовары, ТабДокумент, ПараметрыПечати)
    
    Документ                 = ПараметрыПечати.Документ;
    МаркаИГосНомерАвтомобиля = ПараметрыПечати.МаркаИГосНомерАвтомобиля;
    ГосНомерПрицепа          = ПараметрыПечати.ГосНомерПрицепа;
    ПунктПогрузки            = ПараметрыПечати.ПунктПогрузки;
    ПунктРазгрузки           = ПараметрыПечати.ПунктРазгрузки;
    Водитель                 = ПараметрыПечати.Водитель;
    Перевозчик               = ПараметрыПечати.Перевозчик;
    ВидПеревозки             = ПараметрыПечати.ВидПеревозки;
    НомерТТН                 = ПараметрыПечати.НомерТТН;

    
    // Зададим параметры макета
    ТабДокумент.ПолеСверху              = 0;
    ТабДокумент.ПолеСлева               = 5;
    ТабДокумент.ПолеСнизу               = 0;
    ТабДокумент.ПолеСправа              = 5;
    ТабДокумент.АвтоМасштаб             = Истина;
    ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;

    Макет = УправлениеПечатью.ПолучитьМакет("Обработка.ПечатьТТН.ПФ_MXL_ТТН2014");
    
    КодЯзыкаПечать = "uk";
    
    // Выводим общие реквизиты шапки
    СведенияОПокупателе       = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель,       Шапка.ДатаДокумента);
    СведенияОГрузополучателе  = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузополучатель,  Шапка.ДатаДокумента);
    СведенияОГрузоотправитель = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Грузоотправитель, Шапка.ДатаДокумента);
    
    Если ЗначениеЗаполнено(Документ.БанковскийСчетОрганизации) Тогда
        НомерСчета = Документ.БанковскийСчетОрганизации.НомерСчета;
        Банк       = Документ.БанковскийСчетОрганизации.Банк;
        МФО           = Документ.БанковскийСчетОрганизации.Банк.Код;
        
        СведенияОГрузоотправитель.Вставить("НомерСчета",       НомерСчета);
        СведенияОГрузоотправитель.Вставить("Банк",             Банк);
        СведенияОГрузоотправитель.Вставить("МФО",              МФО);
    КонецЕсли;
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.НомерДокумента                = НомерТТН;
    ОбластьМакета.Параметры.ДатаДокумента                 = Шапка.ДатаДокумента;
    ОбластьМакета.Параметры.Грузоотправитель              = Шапка.Грузоотправитель;
    ОбластьМакета.Параметры.Грузополучатель               = Шапка.Грузополучатель;
    ОбластьМакета.Параметры.Плательщик                    = Шапка.Покупатель;
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузополучательПредставление  = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузополучателе,  "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать);
    ОбластьМакета.Параметры.ГрузоотправительПредставление = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузоотправитель, "ПолноеНаименование,ИНН,ФактическийАдрес,Телефоны,НомерСчета,Банк,МФО,КодПоЕДРПОУ,",, КодЯзыкаПечать);
    
    ОбластьМакета.Параметры.МаркаИГосНомерАвтомобиля = МаркаИГосНомерАвтомобиля;
    ОбластьМакета.Параметры.ФИОВодителя = Водитель;
    ОбластьМакета.Параметры.ВидПеревозки = ВидПеревозки;
    ОбластьМакета.Параметры.ГосНомерПрицепа = ГосНомерПрицепа;
    
    ОбластьМакета.Параметры.ПунктПогрузки = ПунктПогрузки;
    ОбластьМакета.Параметры.ПунктРазгрузки = ПунктРазгрузки;
    
    ОбластьМакета.Параметры.ОрганизацияПеревозчик = Перевозчик;
    
    Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);
    
    // Отпуск товара разрешил
    ФИООтпускРазрешил       = Руководители.РуководительПредставление;
    ДолжностьОтпускРазрешил = Руководители.РуководительДолжность;
    
    ОбластьМакета.Параметры.ОтпускРазрешилДолжность = ?(ЗначениеЗаполнено(ФИООтпускРазрешил), ФИООтпускРазрешил + ", " + ДолжностьОтпускРазрешил, "");
    
    ОбластьМакета.Параметры.СерияДоверенности = Шапка.ДоверенностьСерия;
    ОбластьМакета.Параметры.НомерДоверенности = Шапка.ДоверенностьНомер;
    ОбластьМакета.Параметры.ДатаДоверенности  = Формат(Шапка.ДоверенностьДата, "ДФ = ""дд.ММ.гггг""");
    
    СуммаСНДС   = Окр((ЗапросТовары.Итог("Сумма") + ?(Шапка.СуммаВключаетНДС, 0, ЗапросТовары.Итог("СуммаНДС"))), 2);
    ОбластьМакета.Параметры.ОтпущеноНаСуммуПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаСНДС, Константы.ВалютаРегламентированногоУчета.Получить(), КодЯзыкаПечать);
    ОбластьМакета.Параметры.СуммаНДС                = ОбщегоНазначенияБПВызовСервера.ФорматСумм(ЗапросТовары.Итог("СуммаНДС"), Константы.ВалютаРегламентированногоУчета.Получить());
    
    Количество = ЗапросТовары.Итог("Количество");
    КоличествоМест = ?(Цел(Количество) = Количество, Количество, Цел(Количество) + 1);
    КоличествоМестПрописью = НРег(ЧислоПрописью(КоличествоМест,"Л=uk_UK"));
    ОбластьМакета.Параметры.КоличествоМестПрописью  = Лев(КоличествоМестПрописью,СтрДлина(КоличествоМестПрописью)-3);
    
    ТабДокумент.Вывести(ОбластьМакета);
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    
    // Выводим заголовок таблицы
    ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    ТабДокумент.Вывести(ЗаголовокТаблицы);
    
    КоличествоСтрок = ЗапросТовары.Количество();

    // инициализация итогов по странице
    ИтогоКоличествоНаСтранице = 0;
    ИтогоСуммаСНДСНаСтранице  = 0;

    // инициализация итогов по документу
    ИтогоМест       = 0;
    ИтогоКоличество = 0;
    ИтогоСуммаСНДС  = 0;
    Ном             = 1;

    // Выводим многострочную часть докмента
    ОбластьМакета = Макет.ПолучитьОбласть("Строка");
    Для Каждого ВыборкаСтрок Из ЗапросТовары Цикл

        Если НЕ ЗначениеЗаполнено(ВыборкаСтрок.Номенклатура) Тогда
            Сообщить(НСтр("ru='В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.';uk='В одному з рядків не заповнене значення номенклатури - рядок під час друку буде пропущений.'"), СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;

        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрок);
        ОбластьМакета.Параметры.НомерСтроки = Ном;
        ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрок.ТоварНаименование;
        //        Мест        = ВыборкаСтрок.КоличествоМест;
        Количество  = ВыборкаСтрок.Количество;
        СуммаСНДС   = Окр((ВыборкаСтрок.Сумма + ?(Шапка.СуммаВключаетНДС, 0, ВыборкаСтрок.СуммаНДС)), 2);
        СуммаБезНДС = СуммаСНДС - ВыборкаСтрок.СуммаНДС;
        
        ОбластьМакета.Параметры.Сумма = СуммаСНДС;

        ОбластьМакета.Параметры.Цена = ?(Количество = 0, 0, СуммаБезНДС / Количество);

        ТабДокумент.Вывести(ОбластьМакета);

        // увеличим итоги по дукументу
        ИтогоКоличество = ИтогоКоличество + Количество;
        ИтогоСуммаСНДС  = ИтогоСуммаСНДС  + СуммаСНДС;
        Ном             = Ном + 1;

    КонецЦикла;

    // Выводим итоги по документу в целом
    ОбластьМакета = Макет.ПолучитьОбласть("Всего");
    ОбластьМакета.Параметры.ИтогоКоличество = ИтогоКоличество;
    ОбластьМакета.Параметры.ИтогоСуммаСНДС  = ИтогоСуммаСНДС;

    ТабДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
    ТабДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("ПогрузочныеОперации");
    ТабДокумент.Вывести(ОбластьМакета);
    
КонецПроцедуры  //ЗаполнитьТТН2014
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143135 · Ответов: 5 · Просмотров: 178
 

>  Этикетка товара
XacTLa
Отправлено: 25.06.18, 15:32


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)

Не могу понять как мне создать этикетку с назначением товара, а именно что бы был номер заказа на этикетке при печати. Что бы информацию брать с назначения товара с производства. Уже все облазил не могу понять как.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142885 · Ответов: 0 · Просмотров: 696
 

>  МаршрутныйЛистПроизводства
XacTLa
Отправлено: 22.05.18, 9:09


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Всем гадалка и экстрасенсам спасибо Сам разобрался. Тему можно закрыть
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141796 · Ответов: 5 · Просмотров: 174
 

>  МаршрутныйЛистПроизводства
XacTLa
Отправлено: 22.05.18, 7:16


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Вчера, 23:37 * ,
ее нет смысла показывать мне нужно добавить код номенклатуры в печатную форму? немного не доганяю, знаю что через настройки можно сделать, но как только я это делаю, сразу же ошибка в стандартном "маршрутном листе" что параметр код не обнаружен
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141792 · Ответов: 5 · Просмотров: 174
 

>  МаршрутныйЛистПроизводства
XacTLa
Отправлено: 21.05.18, 22:10


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)
Есть внешняя печатная обработка "МаршрутныйЛистПроизводства", но могу понять как как засунуть туда КодНоменклатуры.
Так как этикетки нужно печатать с маршрутного листа.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141776 · Ответов: 5 · Просмотров: 174
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 23.04.18, 8:03


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ 29.03.18, 12:21 * ,
можно ли указать в данной внешней обработке что бы Единицу измерения эти данные брались с другой таблицы? и как это делать добавить нужно реквизит?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140988 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 29.03.18, 8:06


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 11:54 * ,


И даже когда вставляю ЕдиницаИзмерения, тоже такая ошибка, хотя данные беру с оригинального маршрутного листа, не могу понять в чем прикол, я уже и упаковку вставлял, и что только не пробовал нечего не выходит


 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140201 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 27.03.18, 16:10


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 17:09 * ,
просто скрин верный а там стоит курсор на оригинальном маршрутном, так как пытался от туда взять данные извините если туплю.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140125 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 27.03.18, 15:53


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 16:51 * ,
Как понять имя? одинаковый макет и свойства к нему
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140122 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 27.03.18, 14:44


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ 19.03.18, 18:58 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
        ОбластьСтроки.Параметры.ЕдиницаИзмеренияНаименование = ТекущаяСтрока.ЕдиницаИзмеренияНаименование;
                        ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции // СформироватьПечатнуюФорму()




и выдает ошибку что типо нет такого параметра как ЕдиницаИзмеренияНаименование хотя я его указал
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140111 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 17:52


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 17:48 * ,
Я уже указывал ЕденицуИзмерения нечего не помогает, мне нужно в коде заполнить
ОбластьСтроки.Параметры.ЕденицаИзмерения = ТекущаяСтрока.ЕденицаИзмерения;
и в свойствах документа указать параметр к ячейке ЕденицаИзмерения?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139790 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 17:41


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 17:06 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ОбъектыПечати)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
                ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции // СформироватьПечатнуюФорму()
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139787 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 16:49


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 16:21 * ,
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139782 · Ответов: 17 · Просмотров: 552
 

>  Доп реквизиты в маршрутном листе (печатная форма)
XacTLa
Отправлено: 19.03.18, 15:48


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)

1С:ERP Управление предприятием 2.0 (2.0.9.66)

Ситуация такая, что сделал маршрутный лист я уже и в модуль обьекта добавлял:
ОбластьСтроки.Параметры.ЕденицаИзмерения = ТекущаяСтрока.ЕденицаИзмерения;


что уже не пробовал, нечего не получается и в свойства тоже параметры вставлял.


 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139777 · Ответов: 17 · Просмотров: 552
 

>  Ошибка при выборе характеристики
XacTLa
Отправлено: 26.02.18, 11:09


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Сегодня, 10:48 * ,
В 1с есть такая функция как характеристика номенклатуры, она придумана для того что бы не создавать однотипной номенклатуры много, вот я ее хочу применить захожу в Нормативно-Справочная информация выбираю номенклатура и для группы Готовая продукция хочу указать что она использует характеристику когда я выбираю что использует характеристику и пытаюсь записать выдает ошибку "Предопределенный элемент не уникален" просто какой то прикол!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139023 · Ответов: 3 · Просмотров: 240
 

>  Ошибка при выборе характеристики
XacTLa
Отправлено: 26.02.18, 10:19


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309) 1С:ERP Управление предприятием 2.0 (2.0.9.66)

Суть такая есть задача создать много номенклатуры но думаю что прокатит это с характеристиками, но когда указываю на вид номенклатуры использовать характеристику, выдает ошибку "Предопределенный элемент не уникален"


 ! 

Правила: 4,5
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139021 · Ответов: 3 · Просмотров: 240
 

>  настройка списка заказов клиентов
XacTLa
Отправлено: 23.02.18, 9:27


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Вчера, 18:09 * ,
Для начало хочу понять что и куда лезть, в статусы заказов? или в состояние обеспечения
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138956 · Ответов: 6 · Просмотров: 439
 

>  настройка списка заказов клиентов
XacTLa
Отправлено: 22.02.18, 17:51


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


logist @ Вчера, 0:01 * ,
так и есть в этом и прикол что нужна доработка кто поможет?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138929 · Ответов: 6 · Просмотров: 439
 

>  настройка списка заказов клиентов
XacTLa
Отправлено: 19.02.18, 9:51


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


1С:Предприятие 8.3 (8.3.9.2309)

1С:ERP Управление предприятием 2.0

Суть такая возможна настройка списка заказов клиентов таким образом, что допустим если заказ вышел с производства и он лежит на складе то в списке именно заказ выделяется зеленым цветом, якобы дает понять менеджеру что его можно отгрузить.

Я так понял можно это все сделать через настроить список , но там не понимаю что выбрать к статусу не могу привязаться так как заказ который к выполнения, в списке как готов к отгрузке а на самом деле 2-3 из 5 позиций есть на складе а остальные в работе их изготавливают.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138725 · Ответов: 6 · Просмотров: 439
 

>  Маршрутный лист
XacTLa
Отправлено: 09.10.17, 13:23


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


salton @ Сегодня, 13:16 * ,
Функция СформироватьПечатнуюФорму(СсылкаНаОбъект, ПараметрыИсточника,
        КоллекцияПечатныхФорм,
        ОбъектыПечати,
        ПараметрыВывода)
        
    ТабличныйДокумент = Новый ТабличныйДокумент;
    МакетОбработки = ПолучитьМакет("МакетМаршрутныйЛист");

    ОбластьШапки = МакетОбработки.ПолучитьОбласть("Шапка");

    ОбластьШапки.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ДатаДокумента = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy; ДЛФ=DT" );
    ОбластьШапки.Параметры.ПодразделениеПредставление = СсылкаНаОбъект.Подразделение;
    ОбластьШапки.Параметры.ИзделиеПредставление = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение = СсылкаНаОбъект.Назначение;
                          
    
    
    ТабличныйДокумент.Вывести(ОбластьШапки);
    
    
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТЧ");
    
    Для Каждого ТекущаяСтрока Из СсылкаНаОбъект.РаспоряжениеСпецификация Цикл
            
        ОбластьСтроки.Параметры.НоменклатураПредставление = ТекущаяСтрока.Номенклатура;
        ОбластьСтроки.Параметры.Норматив = ТекущаяСтрока.Количество;
        
        ТабличныйДокумент.Вывести(ОбластьСтроки);
            КонецЦикла;
           ТабличныйДокумент.АвтоМасштаб = Истина;
          Возврат ТабличныйДокумент;
    
    

    
    
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133221 · Ответов: 45 · Просмотров: 1893
 

>  Маршрутный лист
XacTLa
Отправлено: 09.10.17, 13:07


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


salton @ Сегодня, 12:07 * ,
Функция Печать(СсылкаНаОбъект, ПараметрыИсточника, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    Для Каждого ОбъектПечати Из СсылкаНаОбъект Цикл
        УправлениеПечатью.
        ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,
        "МаршрутныйНовый",
        "Маршрутный новый",
        СформироватьПечатнуюФорму(СсылкаНаОбъект, ПараметрыИсточника, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода));
    КонецЦикла;
    
    ТабДок = новый ТабличныйДокумент;
    
    Макет = ПолучитьМакет("МакетМаршрутныйЛист");
    
    ОбластьШапки   = Макет.ПолучитьОбласть("Шапка");
    ОбластьСтрокаТЧ  = Макет.ПолучитьОбласть("СтрокаТЧ");
        
    ОбластьШапки.Параметры.ТекстЗаголовка                      = СсылкаНаОбъект.Номер;
    ОбластьШапки.Параметры.ТекстЗаголовка                      = СсылкаНаОбъект.Дата;
    ОбластьШапки.Параметры.ПодразделениеПредставление       = СсылкаНаОбъект.Подразделение;
    ОбластьШапки.Параметры.ИзделиеПредставление              = СсылкаНаОбъект.Номенклатура;
    ОбластьШапки.Параметры.СпецификацияПредставление         = СсылкаНаОбъект.Спецификация;
    ОбластьШапки.Параметры.РаспоряжениеПредставление         = СсылкаНаОбъект.Распоряжение;
    ОбластьШапки.Параметры.Назначение                         = СсылкаНаОбъект.Назначение;

    
    ТабДок.Вывести(ОбластьШапки);
    
    Запрос = Новый Запрос;
    
    Запрос.Текст = "ВЫБРАТЬ
                   |    МаршрутныйЛистПроизводства.Номенклатура,
                   |    МаршрутныйЛистПроизводства.ВыходныеИзделия.(
                   |        Количество
                   |    )
                   |ИЗ
                   |    Документ.МаршрутныйЛистПроизводства КАК МаршрутныйЛистПроизводства
                   |ГДЕ
                   |    МаршрутныйЛистПроизводства.Ссылка = &Ссылка";
                  
    Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
    Запрос.УстановитьПараметр("ТекущаяДата",ТекущаяДата());
    
          
    
    
    
                  
    возврат ТабДок;
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133219 · Ответов: 45 · Просмотров: 1893
 

>  Маршрутный лист
XacTLa
Отправлено: 09.10.17, 10:42


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Может кто то знает как это чудо переделать так что бы работало, а то вообще я уже подставляю параметры все равно пишет много факт. данных
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133216 · Ответов: 45 · Просмотров: 1893
 

>  Маршрутный лист
XacTLa
Отправлено: 07.10.17, 8:28


Говорящий
***

Группа: Пользователи
Сообщений: 67
Регистрация: 22.02.17
Из: Киев
Пользователь №: 54620


Petre @ Вчера, 16:57 * ,
МаршрутныйЛистПроизводства

salton @ Вчера, 18:15 * ,
Я уже ставлю одну процедуру это "Ссылка на обьект" и все равно пишем много параметров
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #133166 · Ответов: 45 · Просмотров: 1893
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 21.07.18, 11:58
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне