Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

27 страниц V   1 2 3 > » 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: Вчера, 7:40


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Что-то я совсем не понял ситуацию... Взял эту ошибочную конфигурацию, сделал для нее узел РИБ, запустил обмен, никаких ошибок по вышеизложенному не стал давать. Всё работает как часы...

Что тогда могло случится?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143460 · Ответов: 7 · Просмотров: 118
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 16.07.18, 14:58


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(sava1 @ 16.07.18, 16:17) *
Если обмен - вооще отказаться от проверки - нафика ?


Вот не совсем понял эту фразу icon_beer17.gif
Так как правильно поступить?

ПС: зря я кажется связался с этими подписками...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143422 · Ответов: 7 · Просмотров: 118
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 16.07.18, 13:05


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Petre @ Сегодня, 15:58 * ,


#Если Клиент Тогда???

Куда вставить лучше? На весь код подписок на событие или только на код диалога?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143418 · Ответов: 7 · Просмотров: 118
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 16.07.18, 12:00


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал подписку на события с целью "мягкой" проверки правильного заполнения статей движения денежных средств с возможностью отказа запрета "ПередЗаписью":

Код
Для Каждого СТЧ из Источник.РасшифровкаПлатежа Цикл
        Если СТЧ.СтатьяДвиженияДенежныхСредств.ВаловаяПрибыль
            И НЕ ЗначениеЗаполнено(Источник.ДатаВП) Тогда
            Сообщить("Данная статья (" + СТЧ.СтатьяДвиженияДенежныхСредств + ") предусматривает участие в Отчете по валовой прибыли." + Символы.ПС + "Рекомендуется указать период учета по данной статье. Иначе данные средства не войдут в учет по валовой прибыли.");
            
            Ответ = Вопрос("Требуется ли указать период учета?", РежимДиалогаВопрос.ДаНет,0);
            Если Ответ = КодВозвратаДиалога.Нет Тогда
                Отказ = Ложь;
            Иначе
                Отказ = Истина;  
            КонецЕсли;
            
        КонецЕсли;    
    КонецЦикла;


Ну т.е. была попытка только рекомендовать, если не надо, то и не надо, документ проводится спокойно.

Когда тестировал, всё срабатывало без проблем. Обновил конфигурацию. Запустил обмен РИБ. Сначала автообмен с полными правами и выдало ошибку:


Цитата
{ОбщийМодуль.Мой.Модуль(958,57)}: Переменная не определена (РежимДиалогаВопрос)
Ответ = Вопрос("Требуется ли указать период учета?", <<?>>РежимДиалогаВопрос.ДаНет,0);
{ОбщийМодуль.Мой.Модуль(959,17)}: Переменная не определена (КодВозвратаДиалога)
Если Ответ = <<?>>КодВозвратаДиалога.Нет Тогда
{ОбщийМодуль.Мой.Модуль(958,12)}: Процедура или функция с указанным именем не определена (Вопрос)
Ответ = <<?>>Вопрос("Требуется ли указать период учета?", РежимДиалогаВопрос.ДаНет,0);


Отключил у всех своих обменников "обмен с полными правами". Обмены работают, но автообмен нет, теперь вынужден только в ручную обмен задействовать.

Почему такое случилось? Почему неопределенность переменных и функции "Вопрос" увиделось только при обмене данными? Ну и соответственно автообмен упал.
Что нужно предпринять?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143416 · Ответов: 7 · Просмотров: 118
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 16:14


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


На ИТС нашел вот такой код: https://its.1c.ru/db/metod8dev#content:2805:hdoc

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)

    
        Соответствие = Новый Соответствие;

    // Заполнение параметра - массива значений ссылками на отображаемые строки табличного поля
    СсылкиМассив = Новый Массив;
    Для каждого Стр из ОформленияСтрок Цикл

        СсылкиМассив.Добавить(Стр.ДанныеСтроки.Ссылка);
        Соответствие.Вставить(Стр.ДанныеСтроки.Ссылка, Стр);

    КонецЦикла;

    // Сформировать запрос для получения остатков
    ЗапросОстатка = Новый Запрос;
    ЗапросОстатка.Текст = "ВЫБРАТЬ
                          |    ДвиженияДенежныхСредств.Регистратор Как Регистратор
                          |ИЗ
                          |    РегистрНакопления.ДвиженияДенежныхСредств КАК ДвиженияДенежныхСредств
                          |ГДЕ
                          |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа В(&ДокументПланированияПлатежа)";

    ЗапросОстатка.УстановитьПараметр("ДокументПланированияПлатежа", СсылкиМассив);
    Выборка = ЗапросОстатка.Выполнить().Выбрать();

    //Вывести остаток в строку, найденную в соответствии по номенклатуре из запроса
    Пока Выборка.Следующий() Цикл

        Соответствие.Получить(Выборка.Регистратор).Ячейки.РРКО.Значение = Выборка.Регистратор;

    КонецЦикла;
    

    
КонецПроцедуры


Код переделал под свои нужды, но выдает такую ошибку:

{Документ.ЗаявкаНаРасходованиеСредств.Форма.ФормаСписка.Форма(146)}: Значение не является значением объектного типа (Ячейки)
        Соответствие.Получить(Выборка.Регистратор).Ячейки.РРКО.Значение = Выборка.Регистратор;




Вот нашел другой код, вроде работает:

    МассивЗаказов = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        МассивЗаказов.Добавить(Стр.ДанныеСтроки.Ссылка);
    КонецЦикла;
    // Формируем запрос к остаткам заказов
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ДвиженияДенежныхСредств.Регистратор,
        |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа
        |ИЗ
        |    РегистрНакопления.ДвиженияДенежныхСредств КАК ДвиженияДенежныхСредств
        |ГДЕ
        |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа В(&МассивЗаказов)"
;
    Запрос.УстановитьПараметр("МассивЗаказов", МассивЗаказов);
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    // Обрабатываем результат
    Для Каждого Стр Из ОформленияСтрок Цикл
        Если Выборка.НайтиСледующий(Новый Структура("ДокументПланированияПлатежа", Стр.ДанныеСтроки.Ссылка)) Тогда
            Стр.Ячейки.РРКО.Текст = Выборка.Регистратор;    
        Иначе
            Стр.Ячейки.РРКО.Текст = 0;    
        КонецЕсли;
        Стр.Ячейки.РРКО.ОтображатьТекст = Истина;
        Выборка.Сбросить();
    КонецЦикла;


  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143354 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 14:17


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(Zaval @ 13.07.18, 17:12) *
Почему в Списке РКО, если данные нужны в списке Заявок?
Запрос должен выполняться не по каждой строке, а 1 раз по списку выведенных в форму Заявок


Как раз в Списке Заявок, есть левая колонка, вот туда и прописываются.

Я выложил код. Вы предложили другую идею "Запрос должен выполняться не по каждой строке, а 1 раз по списку выведенных в форму Заявок"

Как это осуществить?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143353 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 13:12


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Вот сделал такую вещч:

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
        // Соответствие создается для заполнения остатков в строках табличного поля
    Для каждого Стр из ОформленияСтрок Цикл

        Стр.Ячейки.РРКО.Значение = ПолучитьРКО(Стр.ДанныеСтроки.Ссылка);

    КонецЦикла;
    
КонецПроцедуры

Функция ПолучитьРКО(Основа)
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |    ДвиженияДенежныхСредств.Регистратор
        |ИЗ
        |    РегистрНакопления.ДвиженияДенежныхСредств КАК ДвиженияДенежныхСредств
        |ГДЕ
        |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа = &Основа";
    
    Запрос.УстановитьПараметр("Основа", Основа);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Результат = ВыборкаДетальныеЗаписи.Регистратор;
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


     Возврат Результат;
    
КонецФункции


Вроде срабатывает, но явно тормозит... Может есчо есть пооптимальней?


Как можно получить данные из РН одной строкой, типа

Результат = РегистрыНакопления.РегистрТакойто.(?????)
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143350 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 12:14


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


иЙолки-палочки... Всё перепробовал, даже открытие формы Заявок

        Для Каждого Заявка Из РасшифровкаПлатежа Цикл
                Док = Заявка.ДокументПланированияПлатежа.ПолучитьОбъект();
                Док.РКО = Документы.РасходныйКассовыйОрдер.ПустаяСсылка();
                Форма = Док.ПолучитьФорму("ФормаДокумента");
                Форма.Открыть();
                //Форма.ЭлементыФормы.РКО = Документы.РасходныйКассовыйОрдер.ПустаяСсылка();
                //Форма.Закрыть();
                //Док.Записать(РежимЗаписиДокумента.Запись);
        КонецЦикла;


Но как сохранить изменения в открытой форме и закрыть её не получается.

Вообщем я начал паниковать icon_cuss.gif

Подскажите детально как бы Вы сделали эту хотелку без "Попытка"?
Интересная идея с дополнительным реквизитом формы списка и как при этом использовать "ПриВыводеСтроки", если это действительно не кушает ресурсы при открытии, т.к. нужно будет выделять строки, где есть РКО...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143346 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 11:19


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(Vidocq05 @ 13.07.18, 12:54) *
сделайте реквизит в форме списка (не реквизит объекта) Заявок "РКО" и получайте ссылки на РКО "ПриВыводеСтроки" в табличном поле Заявок.

Цитата(Zaval @ 13.07.18, 13:34) *
посмотрите Движения. Там все уже есть.


Идеи хорошие, не могу их как-то реализовать.
Создал реквизит формы списка "РКО" (на вкладке "Реквизиты") с ссылкой на документы РКО

Пытаюсь вставить новую колонку в ТЧ формы списка Заявок, но там нет возможность выбрать данные, т.е. выбрать этот новый реквизит "РКО".

Теперь о регистрах. Да в РН "Движения денежных средств" есть ссылка на Заявку.

Как можно одной строкой вытащить Регистратор (РКО), зная "ДокументПланированияПлатежа" (Заявка) из этого регистра накопления и "получайте ссылки на РКО "ПриВыводеСтроки" в табличном поле Заявок" как это предложил Vidocq05.

Цитата(Zaval @ 13.07.18, 13:42) *
Выполнять Запрос при выводе каждой строки? "На вас серверов не напасешься"


Значит не я один затаил сомнения... icon_beer17.gif
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143344 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 5:48


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(Zaval @ 12.07.18, 18:58) *
Зачем это вообще делать? Шоб базу положить?


Хотелка начальника... Он хочет видеть на форме списка Заявок сделан ли РКО по данной Заявке или нет...

Может есть другой способ отразить закрытую Заявку?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143336 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 12.07.18, 15:06


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Попробовал убрать "Попытку"

        Для Каждого Заявка Из РасшифровкаПлатежа Цикл
            //Попытка
            Если НЕ РазрешеныПлатежи[0].Значение Тогда
                Док = Заявка.ДокументПланированияПлатежа.ПолучитьОбъект();
                Док.РКО = Ссылка;
                Док.Записать(РежимЗаписиДокумента.Запись);
            КонецЕсли;    
            //Исключение
            //КонецПопытки;
        КонецЦикла;


Не записывает: Ошибка при вызове метода контекста (Записать)

С "Попыткой" Записывает, без не записывает... Что не так я сделал?

Цитата(sava1 @ 12.07.18, 16:46) *
попробуйте перед записью менять документы, а не при проведении


Попробовал в модуле объекта "При записи"

    Для Каждого Заявка Из РасшифровкаПлатежа Цикл
        //Попытка            
        Если НЕ РазрешеныПлатежи[0].Значение Тогда
            Док = Заявка.ДокументПланированияПлатежа.ПолучитьОбъект();
            Док.РКО = Ссылка;//Документы.РасходныйКассовыйОрдер.ПустаяСсылка();
            Док.Записать(РежимЗаписиДокумента.Запись);
        КонецЕсли;    
        //Исключение
        //КонецПопытки;
    КонецЦикла;


Та жа ошибка при записи
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143312 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 12.07.18, 13:53


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(sava1 @ 12.07.18, 16:46) *
попробуйте перед записью менять документы, а не при проведении


В случае признания документа, ссылка должна записаться, в случае отмены проведения, установки на удаление ссылка должна быть удалена, даже если там ее нет

Подскажите как правильно сделать перед записью, т.е. осуществить проверку на действие (проведение, отмена проведения, удаление)?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143308 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 12.07.18, 13:30


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Ну и код при отмене проведения

    Для Каждого Заявка Из РасшифровкаПлатежа Цикл
        Попытка            
            Док = Заявка.ДокументПланированияПлатежа.ПолучитьОбъект();
            Док.РКО = Документы.РасходныйКассовыйОрдер.ПустаяСсылка();
            Док.Записать(РежимЗаписиДокумента.Запись);
        Исключение
        КонецПопытки;
    КонецЦикла;


Т.е. ссылка на РКО в Заявке удаляется...

Мож есть какой другой метод записи ссылки в другом документе?

podcast @ Сегодня, 16:02 * ,

Прерыватель отладчика ничего не дал...

Вот не совсем понял про НачатьТранзакцию();

Мне вначале модуля проведения поставить? И что дает эта штука?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143305 · Ответов: 18 · Просмотров: 233
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 12.07.18, 12:39


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В документе РКО в модулях по проведению и распроведения имеется код:

        Для Каждого Заявка Из РасшифровкаПлатежа Цикл
            Попытка
                Док = Заявка.ДокументПланированияПлатежа.ПолучитьОбъект();
                Док.РКО = Ссылка;
                Док.Записать(РежимЗаписиДокумента.Запись);
            Исключение
            КонецПопытки;
        КонецЦикла;


Именно этот код мне сейчас и создает проблемы при проведении и отмены проведения, выдает сообщение "В данной транзакции уже происходили ошибки"

Если его убрать, то всё нормально. Однако данный код вынужденное зло, т.к. начальника потребовал, чтобы после формирования РКО в соответствующей Заявке (у нас ведется обязательный учет по Заявкам).

Именно применение "Попытка" и создает проблемы, но если это убрать, то тоже создаются проблемы при проведении и антипроведении, т.к. на филиалах применение Заявок не обязательно.

Что можно придумать, чтобы ошибки не было, но и код выполнялся для записи ссылки на документ?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143303 · Ответов: 18 · Просмотров: 233
 

>  Не срабатывают параметры страницы печати отчета
Constantus
Отправлено: 10.07.18, 11:20


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

В обработке формирую отчет и вывожу его на макет.

Пытаюсь завести параметры страницы

......................................
    Таб.Вывести( областьПодвал );
    
    таб.МасштабПечати = 80;
    таб.ПолеСлева = 5;
    таб.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    таб.Автомасштаб = Истина;
    
    Возврат Таб;


Ни масштаб, ни поляСлева и темболее Автомасштаб не срабатывают. Живет только Ориентация страницы.

Что я не так сделал?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143209 · Ответов: 1 · Просмотров: 90
 

>  Резервирование и частичное снятие с резерва
Constantus
Отправлено: 09.07.18, 12:58


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Никак не могу сообразить как правильно поступить. К сожалению так уж складывается ситуация на Предприятии

Имеем Заказ, ставим в резерв:
Товар01 = 100 шт.
Товар02 = 100 шт.

Проходит инвентаризация. В результате требуется списать
Товар01 = 20 шт.
Товар02 = 30 шт.

Но они все в резерве.

Требуется осуществить частичное снятие с резерва этого списанного товара, чтобы хоть что-то сохранить в резерве, т.е. чтобы в итоге на складе в резерве сохранилось
Товар01 = 80 шт (100-20) шт.
Товар02 = 70 шт (100-30) шт.

Есть документ "Закрытие заказов покупателей", но он снимает полностью заказ и формировать новый заказ не айз.
Есть документ "Резервирование товара", но с ним вообще не понял как работать.

Поделитесь опытом, как можно организовать подобную махинацию с минимальными потерями с учетом того, что на складе пользователи ... (не очень хорошее слово)

  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #143197 · Ответов: 1 · Просмотров: 101
 

>  Подписка на событие: Проверка заполнения и правильного выбора реквизита документов
Constantus
Отправлено: 05.07.18, 15:02


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Vidocq05 @ Сегодня, 17:07 * ,

Справочник "Подразделение" у меня иерархический по элементам.
По условиям "Головное" подразделение нельзя указывать, только те, что внутри этого подразделения.

Понимаю, что лучше сделать надо бы иерархию групп и элементов, но так уж сложились обстоятельства, что структуру справочника менять нельзя...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143169 · Ответов: 7 · Просмотров: 185
 

>  Подписка на событие: Проверка заполнения и правильного выбора реквизита документов
Constantus
Отправлено: 05.07.18, 12:53


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


А как в таком случае сделать проверку по заполнению табличной части документа?

Нужно проверить РКО на статьи движения денежных средств, которые заполнены в табличной части документа. В данном случае у статей ДДС имеется реквизит "Отключена" и при проверке должно выйти сообщение, что типа низяяя...

Процедура ПроверкаСтатьиДДСПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
    // Вставить содержимое обработчика.
    
    Если Источник.РасшифровкаПлатежа.СтатьяДвиженияДенежныхСредств.Отключена Тогда
        Сообщить("Данное статья снята с учета и не применяется." + Символы.ПС + "Необходимо выбрать активную статью.");
        Отказ = Истина;
    КонецЕсли;    
    
КонецПроцедуры



А... разобрался...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143161 · Ответов: 7 · Просмотров: 185
 

>  Подписка на событие: Проверка заполнения и правильного выбора реквизита документов
Constantus
Отправлено: 05.07.18, 10:47


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


andreydv87 @ Сегодня, 13:44 * ,

Ага... так и сделал... Знал бы раньше, жил бы 44000000.gif

Процедура ПроверкаПодразделенияПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
    
    Если Не ЗначениеЗаполнено(Источник.Подразделение) Тогда
        Сообщить("Необходимо выбрать нужное подразделение!");
        Отказ = Истина;
    КонецЕсли;    
            
    
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               |    Подразделения.Ссылка КАК Ссылка1,
               |    Подразделения.Наименование,
               |    Подразделения.ГруппаВыбора
               |ИЗ
               |    Справочник.Подразделения КАК Подразделения
               |ГДЕ
               |    Подразделения.ГруппаВыбора = ИСТИНА
               |    И Подразделения.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка", Источник.Подразделение);
Результат = Запрос.Выполнить();
Если  НЕ Результат.Пустой() Тогда
    Сообщить("Данное подразделение является группой Подразделений. Использовать нельзя. Необходимо выбрать подразделение внутри этой группы.");
    Источник.Подразделение = Справочники.Подразделения.ПустаяСсылка();
    Отказ = Истина;
Иначе
     // делайте что угодно
КонецЕсли;

  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143159 · Ответов: 7 · Просмотров: 185
 

>  Подписка на событие: Проверка заполнения и правильного выбора реквизита документов
Constantus
Отправлено: 05.07.18, 9:57


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Поставлена задача, чтобы сделать реквизит "Подразделение" обязательным для заполнения + на одно условие.

Понимаю, что нужно лезть во все документы и менять код, но подумал, может есть возможность проверки на подписки на событие... Но там не нашел событие "ПриИзменении(Подразделение)"

Можете что-нить посоветовать? Вот код для проверки при выборе "правильного" подразделения (не должен быть главным подразделением) + Еще как-то включить проверку на пустоту...

Процедура ПодразделениеПриИзменении(Элемент)
    
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               |    Подразделения.Ссылка КАК Ссылка1,
               |    Подразделения.Наименование,
               |    Подразделения.ГруппаВыбора
               |ИЗ
               |    Справочник.Подразделения КАК Подразделения
               |ГДЕ
               |    Подразделения.ГруппаВыбора = ИСТИНА
               |    И Подразделения.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка", Подразделение);
Результат = Запрос.Выполнить();
Если  НЕ Результат.Пустой() Тогда
    Сообщить("Данное подразделение является группой Подразделений. Использовать нельзя. Необходимо выбрать подразделение внутри этой группы.");
    Подразделение = Справочники.Подразделения.ПустаяСсылка();
Иначе
     // делайте что угодно
КонецЕсли;

КонецПроцедуры

  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143154 · Ответов: 7 · Просмотров: 185
 

>  Возврат денежных средств поставщиком
Constantus
Отправлено: 03.07.18, 13:27


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


alex1c @ Сегодня, 12:01 * ,

У меня учет по документам расчета и если я в РКО убираю ссылки на поступления (документы расчета), то соответственно ругается, что не может провести...
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #143083 · Ответов: 4 · Просмотров: 171
 

>  Возврат денежных средств поставщиком
Constantus
Отправлено: 03.07.18, 5:52


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


andr_andrey @ Вчера, 21:55 * ,

Учет ведется по документам расчета, следовательно убрать из РКО документы расчета (поступления) невозможно.

Пока вижу смысл, переделать эти РКО как "взнос наличными в Банк", потом провести оплату по безналу текущей датой по тем же документам поступления.

Или есть может другой способ?
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #143062 · Ответов: 4 · Просмотров: 171
 

>  Возврат денежных средств поставщиком
Constantus
Отправлено: 02.07.18, 12:41


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Ранее не сталкивался с подобным. Есть поставщик (договор ведется по документам расчетов). Ранее за товар мы ему оплатили наличными, оформив РКО.
Теперь Поставщик решил вернуть нам эти наличные деньги и оплатить товар по безналу.

Пытаюсь оформить ПКО (возврат ДС поставщиком), документы расчета выбираю в ручную егошние РКО, но выдает ошибку

Указана сумма взаиморасчетов, превышающая непогашенный остаток по документу расчетов с контрагентом!
Договор: Основной договор конфет (дурдане) , сделка не указана, документ расчетов: Расходный кассовый ордер AGSH0001041 от 22.12.2017 19:17:25;
Остаток 0 TMM;  указана сумма 1 000 TMM;  превышение 1 000 TMM


Как правильно оформить возврат денежных средств от Поставщика?
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #143040 · Ответов: 4 · Просмотров: 171
 

>  ПолучитьСуммуСкидки: если я указываю 100%, то получаю сумму скидки = 0
Constantus
Отправлено: 26.06.18, 7:42


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Я что-то не совсем догнал ситуацию с ПолучитьСуммуСкидки

Функция ПолучитьСуммуСкидки(Сумма, Скидка) Экспорт

    Если ЗначениеЗаполнено(Скидка) И Скидка <> 100 Тогда
        СуммаСкидки = Сумма / (100 - Скидка) * Скидка;
    Иначе
        СуммаСкидки = 0;
    КонецЕсли;

    Возврат СуммаСкидки;

КонецФункции


Получается, что если я указываю 100%, то получаю сумму скидки = 0, но ведь при 100% скидке сумма скидки = сумме... Как так вообще получилось в типовой конфигурации в типовой функции?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142917 · Ответов: 2 · Просмотров: 115
 

>  Справочник (иерархия элементов): форма списка раскрывать дерево субэлементы при нажатии мыши
Constantus
Отправлено: 22.06.18, 9:49


Почти ветеран
******

Группа: Пользователи
Сообщений: 674
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Изменил форму списка справочника статьи движения ДС, добавив слева деревозначений для навигации по списку. Все вроде работает, но есть неудобство: справа дерево раскрывается только при двойном клике на элементе слева.

Есть аналогичные справочники ("Подразделения"), там при нажатии на элемент на Дереве сразу раскрывается весь список суб-подразделений.

Сравнил обе формы, вроде все индентично. Где я не дотянул?

Разобрался. Нужно было в основном окне выбрать в связях по родителю
СправочникДерево.ПриАктивизацииСтроки
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #142793 · Ответов: 0 · Просмотров: 130
 

27 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 18.07.18, 6:48
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне