Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику sava1 ::: Спасибо сказали: 360 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
23.09.17, 18:59 Как ограничить доступ к странице документа
В модуле формы ПриОткрытии
Если РольДоступна("ПолныеПрава") Тогда
    ЭлементыФормы.Панель.Страница.Видимость = Истина
Иначе
    ЭлементыФормы.Панель.Страница.Видимость = ложь
КонецЕсли


Синтаксис может быть "кривой" - пишу по-памяти.
Lexveritas,
23.09.17, 16:53 Запретить проведение по условию
требуемоеЗначение = Справочники.Статус.НайтиПоКоду("0001"); // или Справочники.Статус.НайтиПоНаименованию("Закрыт")
Если Статус <> ТребуемоеЗначение Тогда
отказ =Истина;
конецЕсли;
Lexveritas,
22.09.17, 18:52 Запретить проведение по условию
Если Реквизит<>Значение Тогда
отказ =Истина;
конецЕсли;

Lexveritas,
19.09.17, 20:41 ШтрихКод в документе заказа
запрос = Новый Запрос;
    запрос.Текст ="
    | ВЫБРАТЬ
    |    Штрихкоды.Штрихкод
    |ИЗ
    |    РегистрСведений.Штрихкоды КАК Штрихкоды
    |ГДЕ
    |    Штрихкоды.Владелец = &Владелец
    |    И Штрихкоды.ХарактеристикаНоменклатуры = &ХарактеристикаНоменклатуры
    |    И Штрихкоды.ЕдиницаИзмерения = &ЕдиницаИзмерения"
    |";
    запрос.УстановитьПараметр("Владелец", Номенклатура);
    запрос.УстановитьПараметр("ХарактеристикаНоменклатуры", Характеристика);
    запрос.УстановитьПараметр("ЕдиницаИзмерения", Единица);
    результат = запрос.Выполнить().Выбрать();
Lexveritas,
19.09.17, 14:28 Порядок вывода страниц в форме
podcast, стесняюсь спросить - а зачем столько кода ? Достаточно было бы
Цитата(podcast @ 19.09.17, 9:23) *
ЭлементыФормы.ОсновнаяПанель.ТекущаяСтраница = ЭлементыФормы.ОсновнаяПанель.Страницы.ДополнительноеОписаниеНоменклатуры;

В процедуре открытия
ViktorB,
12.09.17, 11:24 Перерасчет суммы в ТЧ обработки при изменении булево
У ТЧ есть событие ПриИзменении Флажка (как-то так). Проверяйте элемент и обрабатывайте.
Constantus,
12.09.17, 10:27 1c 7.7, Formex, обратное преобразование цвета в RGB
А обратное преобразование не пробовали ?
синий = Цел(а/65536); и т.д.
Lunatik_5,
12.09.17, 9:49 Программное задание документа-основания для документа РеализацияТоваровУслуг
info230a02,

тогда только
 док.Сделка = докПТиУ.Ссылка;
info230a02,
12.09.17, 9:47 Программное задание документа-основания для документа РеализацияТоваровУслуг
Зачем советовать человеку бред, если там уже есть ссылочный реквизит ?
andreykyiv@bigmir.net,
12.09.17, 9:44 Программное задание документа-основания для документа РеализацияТоваровУслуг
док = Документы.РеализацияТоваровуслуг.Создать();
Цитата(Bernet @ 12.09.17, 10:34) *
Добавьте в документ Реализация Товаров и услуг реквизит "ДокументОснование" с типом "ДокументСсылка.ПоступлениеТоваровУслуг".

Вы в конфигурацию смотрели ? Может еще какую хрень добавить ?



докПТиУ    -  это Ваш документ поступления  //Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();

    док = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
    док.Заполнить(докПТиУ);
    Если Не ЗначениеЗаполнено(док.Ссылка) Тогда
        док.Сделка = докПТиУ.Ссылка;
    КонецЕсли;
info230a02,
05.09.17, 8:13 Новое итоговое поле в группировке
В ресурсах - Вычислить("Сумма(КолСырья)/Сумма(КолПродукции)")
salton,
09.08.17, 12:48 Нужен программист-методист-внедренец ERP
Возьмите меня - опят хочу на ТюраТам
Далекий Казахстан,
01.08.17, 16:40 Не обновляется реквизит формы (платформа 8.2.19.106)
Почитайте про Оповестить()
andrew76,
17.07.17, 13:41 Код обозначения текущего объекта в модуле объекта
Процедура ПередУдалением(Отказ)
Сообщить(""+Ссылка+" -- "+код);
КонецПроцедуры
Gigi,
08.07.17, 14:31 Двойное условие в запросе (=>; <=)
тимВивер в ЛС - посмотрю
Constantus,
08.07.17, 11:56 Двойное условие в запросе (=>; <=)
Такой диапазон определяется МЕЖДУ

Условия лучше формировать динамически, типа%

Если ДиапазонОстатка ИЛИ ДиапазонСумм Тогда 
   Если ДиапазонОстатка Тогда
        УсловиеЗапроса = "ГДЕ ДиапазонОстатка МЕЖДУ &ОстатокОт И &ОстатокДо";
        Запрос.УстановитьПараметр("ОстатокОт", СуммаОстаткаОт);
        Запрос.УстановитьПараметр("ОстатокДо", СуммаОстаткаДо);
    КонецЕсли;        

    Если ДиапазонСумм Тогда
        УсловиеЗапроса = УсловиеЗапроса + ?(ДиапазонОстатка, " И ", "ГДЕ ") +" ДиапазонСумм МЕЖДУ &СтоимостьОт И &СтоимостьДо";
        Запрос.УстановитьПараметр("СтоимостьОт", СуммаПродажОт);
        Запрос.УстановитьПараметр("СтоимостьДо", СуммаПродажДо);
    КонецЕсли;    
КонецЕсли;


текстзапроса = "
|....
|"+ УсловиеЗапроса+"    
......
|";
Constantus,
05.07.17, 15:54 Нет полных прав но есть возможность добавлять пользователе
Посмотреть в конфигурации по ролям - убрать права на администрирование во всех ролях
Pavlik1c,
15.06.17, 17:30 Проверка открытия формы Справочника/документа
Цитата(Gigi @ 15.06.17, 18:24) *
один пользователь отрыл форму, и параметр из перечисления на форме стал "да". т.е. форма отрыта.
И в это самое время, вдруг бац и другой на другом компе закрыл эту форму пока у первого не закрыта


Вы вооще понимаете принцып асинхронных вызовов и работу клиент-сервера?
Вы никогда не найдете открытые формы , кроме своих.
Gigi,
15.06.17, 17:15 Проверка открытия формы Справочника/документа
Цитата(Gigi @ 15.06.17, 17:59) *
на клиенте пользователей будет несколько


Они в очереди будут стоять?
Gigi,
13.06.17, 10:55 УПП 1.3: Объединение подразделений в группу
Цитата(Володька @ 13.06.17, 11:19) *
почти все документы, где есть выбор подразделения получат доступ к "группе" подразделения.

В УПП есть ограничение прав по подразделениям. В чем проблема?
Володька,
06.06.17, 17:04 Произвольный отбор в справочниках
Да. По ним идет сопоставление

В консоли сделайте запрос и скопируйте
Vidocq05,
06.06.17, 10:02 Произвольный отбор в справочниках
Цитирую и ЖК:
Цитата
Перед обработкой
Условия возникновения события
Событие выполняется перед обработкой каждого правила выгрузки один раз. Используется для установки дополнительных параметров перед выгрузкой данных, для переопределения выборки объектов, подлежащей выгрузке, либо для выгрузки дополнительной информации

Параметры:
Отказ - Булево. Если установить значение Истина, то выгрузка данных по данному правилу не производится

Параметры - Структура, в которой хранятся переменные доступные во всех обработчиках

ИмяПКО - Строка. Имя правила конвертации объектов, указанное по умолчанию в правиле выгрузки данных. При выгрузке конкретных объектов может быть изменено

Правило - ссылка на данное правило выгрузки данных

ИсходящиеДанные - Произвольный. Произвольные вспомогательные данные, доступные при выгрузке объектов выборки

ВыборкаДанных - Запрос, Результат запроса, Выборка из результата запроса или произвольная коллекция выгружаемых объектов. Используется, когда способ выгрузки данных - Произвольный алгоритм. Если определить данную переменную, то обход коллекции и выгрузка объектов будет осуществляться автоматически

Важно:
Если для выборки данных ПВД используется произвольный алгоритм и в обработчике ПВД "Перед обработкой" инициируется параметр ВыборкаДанных, то для ПКО следует установить признак "Не запоминать выгруженные объекты".


Пример:
ДатаИзмененияОбъекта = ДатаНачала;
Сообщить("Контрагенты");

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|ТекущийЭлемент = Справочник.Партнеры.ТекущийЭлемент;
|ДатаИзменения = Справочник.Партнеры.ДатаИзменения;
|Группировка ТекущийЭлемент;
|Условие(ДатаИзменения >= ДатаИзмененияОбъекта);";

Запрос.Выполнить(ТекстЗапроса);
Пока Запрос.Группировка(1) = 1 Цикл
ВыгрузитьПоПравилу(Запрос.ТекущийЭлемент, , , , "Контрагенты");
КонецЦикла;


Результат запроса (или сам запрос ) назовите ВыборкаДанных
Обязательно ! - выбирайте в запросе Ссылка /+ правильная синхронизация/
в ПКО можно не сопоставлять, если наименования совпадают


Vidocq05,
31.05.17, 20:46 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 20:38) *
вообще я отношусь к тем, которые очень не любят разные стереотипы

типизация переменніх - не стереотип, а правило.
Программирование основано на таких "стереотипах" и начинаются онм с набора команд процессора, среды исполнения,
среды разработки и т.д.
Вы ж садитесь в автомобиль и не ищете педали велосипедные, чтобы крутить колеса?
Если не нравится среда 1С - возьмите другую и работайте - не надо хаять инструмент.
Да он корявый, но работающий.
Кому-то не понравился молоток - он придумал пресс. Вам все карты в руки.
Gigi,
31.05.17, 17:49 авто-запись данных на сервер для реквизита ссылка
ИМХО - "бедный" заказчик.
Gigi,
27.05.17, 11:31 УПП продажа Тепла
Если у Вас УПП - то да. Можно одним документом за месяц.
Володька,

11 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 26.09.17, 19:56
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне