Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику logist ::: Спасибо сказали: 2324 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
Вчера, 13:33 Методичка по СКД
Цитата(scally @ 27.06.17, 14:15) *
При открытии файлов пароль запрашивает. Очень хочется узнать пароль.

При регистрации на форуме предлагается ознакомится с правилами. Очень хочется, что бы их читали.
scally,
24.06.17, 15:46 Не записывается документ Реализация ТоваровУслуг, конфигурация УТП 1.2.01 Платформа 8.3.8.1652
Причина в том, что вы неправильно реализовали задачу, Регистр накопления это как правило слепок данных документа, поэтому удаление строки из ТЧ должно отражаться в регистре накопления при проведении документа, а не отдельно.
bruslan,
15.06.17, 17:05 Проверка открытия формы Справочника/документа
Цитата(Gigi @ 15.06.17, 17:59) *
Такое решение не опасно?

Это вообще не решение а шопопало
Gigi,
06.06.17, 19:56 Ліцензія для "Бухгалтерія для України, редакція 2.0. (2.0.5.3)"
Цитата(sasha007 @ 06.06.17, 15:47) *
1. данна ситуація не є порушенням ліцензійних умов ?

Если организации являются аффилированными лицами, то для работы на одном ПК (нескольких ПК в одной сети) баз нескольких организации достаточно одной лицензии. Иначе вам надо начать разбор полетов (с юридической точки зрения) каким образом две независимые организации оказались на одном физическом ПК.
sasha007,
02.06.17, 15:58 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 02.06.17, 16:30) *
Потому, что ведь сами изначально ничего взамен не предложили

Предложил бы, но, я сразу написал - не понимаю задачу, поэтому ничего не могу предложить

Цитата(Gigi @ 02.06.17, 16:30) *
РЕЗУЛЬТАТ! Вот это и есть аргумент правильно или нет.

Тут вы правы, можно кишку вывести через горло, срать будет - это результат, а как оно реализовано... smile.gif
Batchir,
31.05.17, 17:25 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 18:12) *
нельзя ли сделать так, что бы реквизит имел два типа одновременно.

Можно, но это будет два разных значения, мне кажется в вашем случае это не то что надо.

Цитата(Gigi @ 31.05.17, 18:12) *
И что бы максимально было удобно..

Из того что вы пишите, мне трудно понять что же заказа заказчик, но исходя из того как вы это реализуете - он заказал тележку "костылей"
Gigi,
31.05.17, 17:02 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 17:43) *
Предположите, что есть справочник с именем "ОБЪЕКТ". И справочник: "ТОЧКА"

Задача - это то, что хочет видеть её заказчик в результате выполнения, а не то, что вы как программист придумали. Перечитал и ничего не понял, может вам надо Подчиненный справочник...
Gigi,
31.05.17, 16:15 авто-запись данных на сервер для реквизита ссылка
Цитата(Gigi @ 31.05.17, 17:08) *
"ОбъектПринадл" это реквизит справочника "ТОЧКА". Его тип ССЫЛКА.
Вопрос в том, как в этот реквизит вставить просто текст

Давайте оторву вам ногу и вместо нее попытаюсь вставить руку, какие у меня шансы? Опять же - не известна задача в целом, например, реквизит можно сделать составного типа.

Цитата(Gigi @ 31.05.17, 17:08) *
много че хочеться не так как система 1С предлогает, а так как нужно цели.

1С много чего умеет, нужно просто ставить правильно цели.
Gigi,
31.05.17, 15:50 авто-запись данных на сервер для реквизита ссылка
Подозреваю изобретаете велосипед, жаль, как всегда, не знаю исходной задачи smile.gif Вникать в "набор слов" нет желания, подожду развития событий))
Gigi,
31.05.17, 10:16 Індексація, Аванс в "Комплексний облік для бюджетних установ України", ред. 2.1
Машенька, прочтите пункт 7 правил форума, и укажите версию КОНФИГУРАЦИИ, а не платформы.
Машенька,
30.05.17, 15:21 Получить Текущую Строку Списка с помощью процедуры из общего модуля
Элементы тоже передавайте в общий модуль.

Функция Получить_ТекущуюСтрокуСписка(Элементы, ИмяСписка, Столбец) Экспорт


p.s. но тут опять же становится вопрос начальной задачи, нахрена всё это, если это можно сделать в форме одной строкой
ЗначениеКолонки = Элементы.ИмяСписка.ТекущиеДанные.ИмяКолонки;

даже если подумать, что вам нужна унифицированная процедура, то она бы выглядела скорее так
&НаКлиенте
Функция Получить_ТекущуюСтрокуСписка(ЭлементСписок, ИмяКолонки) Экспорт
// где ЭлементСписок это сам элемент списка
    Возврат ЭлементСписок.ТекущиеДанные[ИмяКолонки];
КонецФункции
Gigi,
30.05.17, 10:26 Структура. Отбор по заполненному значению - реально?
Цитата(Bernet @ 30.05.17, 10:12) *
если не ошибаюсь когда-то делал так:

Это отбор строк для отображения, а нужен подсчет.

Как вариант это так:
СтрокиГдеДокументНеЗаполнен = Объект.ТабличнаяЧасть.НайтиСтроки(Новый Структура("Документ", ПредопределенноеЗначение("Документ.АвансовыйОтчет.ПустаяСсылка")));
КоличествоГдеУказаноДокументы = Объект.ТабличнаяЧасть.Количество() - СтрокиГдеДокументНеЗаполнен.Количество();
Inkognito,
29.05.17, 14:30 Как обозначить пустой результат списка
Цитата(Gigi @ 29.05.17, 15:27) *
Тупизм! Опять вечно капризничает!
с VBA в Экселе было проще!

Точно так же могу сказать с точки зрения программиста 1с, делая что-то в VBA - в 1С было бы проще, а там тупизм какой-то. Всего лишь потому, что я в этом не разбираюсь. Продолжая винить в этом всё/всех кроме себя, вы будете зарывать в себя в еще большую яму. Берегите нервы, они источник всех болезней wink.gif
Gigi,
23.05.17, 17:40 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 23.05.17, 17:17) *
и как все просто оказывается.

учитесь правильно объяснять задачи, без кучи хрени которой вы сопровождаете свои тексты.
Gigi,
23.05.17, 15:40 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 23.05.17, 16:25) *
Платформа 8.2.

Тогда всё просто
&НаКлиенте
Процедура КнопкаДобавитьСтроку(Команда)
    ВыбранноеЗначение = ОткрытьФормуМодально("Справочник.ТОЧКА_тест1.ФормаВыбора",,ЭтаФорма);
    Если ВыбранноеЗначение <> Неопределено Тогда
        НоваяСтрока = Объект.Таб_Точка.Добавить();
        НоваяСтрока.Реквизит2 = ВыбранноеЗначение;    
        // здесь попутно заполняем РЕквизит1
    КонецЕсли;    
КонецПроцедуры
Gigi,
23.05.17, 15:08 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 23.05.17, 15:19) *
И реагирует так:

Извиняюсь, не заменил что тема про платформу 8.2, там действительно такого нет. Озвучьте версию вашей платформы, а так же включена ли поддержка модальных окон (вдруг платформа 8.3.х.х)
Gigi,
23.05.17, 12:46 Программно выбрать ссылку для строки табличной части справочника
&НаКлиенте
Процедура КнопкаДобавитьСтрокуОбработка(ВыбранноеЗначение, ДопПараметры) Экспорт
    Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда
        НоваяСтрока = Объект.Таб_Точка.Добавить();
        НоваяСтрока.Реквизит2 = ВыбранноеЗначение;    
        // здесь попутно заполняем РЕквизит1
    КонецЕсли;    
КонецПроцедуры

&НаКлиенте
Процедура КнопкаДобавитьСтроку(Команда)
    Оповещение = Новый ОписаниеОповещения("КнопкаДобавитьСтрокуОбработка", ЭтаФорма);
    ОткрытьФорму("Справочник.ТОЧКА_тест1.ФормаВыбора",,ЭтаФорма,,,,Оповещение);
КонецПроцедуры


Только не используйте стандартную команду добавить строку в ТЧ, создайте отдельную команду обработчик которой будет КнопкаДобавитьСтроку
Gigi,
23.05.17, 0:59 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 23.05.17, 1:30) *
Под переменной "ЗначениеКотороеСодержитСсылку" имеется ввиду какая нибудь константа наименования созданного и существующего элемента списка?

Под переменной имеет ввиду ссылка на ваш справочник, как её получить в эту переменную я не могу догадаться до сих пор, потому что из рассказов не могу ничего понять.
Выложите скрины метаданных, стрелочками укажите что куда должно попадать.

Gigi,
22.05.17, 23:44 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 23.05.17, 0:27) *
я просто удивляюсь почему я опять не понят

потому что вы пишите кучу бесполезного текста который сбивает с толку, вместо того что бы четко описать задачу и предоставить какие-то исходные метаданные.

Цитата(Gigi @ 23.05.17, 0:27) *
ПРИСВОИТЬ КОНКРЕТНОЕ УКАЗАННОЕ В КОДЕ ЗНАЧЕНИЕ ССЫЛКИ!!!! ДА... ЗНАЧЕНИЕ ССЫЛКИ ... ВСЕГО ЛИШЬ ... и ничего сверх того!

Элементы.Таб_Точка.ТекущиеДанные.Реквизит2 = ЗначениеКотороеСодержитСсылку;
Gigi,
22.05.17, 17:17 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 22.05.17, 18:11) *
ЧТО ТУТ НЕ ПОНЯТНОГО?

Вообще нихрена не понятно, до сих пор. Из того что понятно можно предположить, что-то такое, но если это добавление новой строки - работать не будет, т.к. не понятна задача в целом.

&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаОбъекта(вхОбъект)
    Возврат вхОбъект.ОбъектПринадИмя;    
КонецФункции

&НаКлиенте
Процедура ФормаОткрытиеОбработка(СсылкаРеузльтат, СтрокаТЧ) Экспорт
    Если ЗначениеЗаполнено(СсылкаРеузльтат) И СтрокаТЧ <> Неопределено Тогда
        // Либо СсылкаРеузльтат это и есть ссылка на выбранный справочник
        СтрокаТЧ.ИмяРеквизитаКоторомуНадоПрисвоить = ПолучитьЗначениеРеквизитаОбъекта(СсылкаРеузльтат);
    КонецЕсли;    
КонецПроцедуры

&НаКлиенте
Процедура ФормаОткрытие()
    СтрокаТЧ = Элементы.Таб_Точка.ТекущиеДанные;
    Оповещение = Новый ОписаниеОповещения("ФормаОткрытиеОбработка", ЭтаФорма, СтрокаТЧ);
    
    Если СтрокаТЧ = Неопределено Тогда
        ОткрытьФорму("Справочник.ТОЧКА_тест1.ФормаОбъекта",,ЭтаФорма,,,,Оповещение);
    Иначе
        ОткрытьФорму("Справочник.ТОЧКА_тест1.ФормаОбъекта",Новый Структура("Ключ", СтрокаТЧ.Точка),ЭтаФорма,,,,Оповещение);
    КонецЕсли;
КонецПроцедуры


Цитата(Gigi @ 22.05.17, 18:11) *
Мне просто нужно так же Вголопить просто ТЕКСТ в реквизит ссылки.
ПРОСТО ВКЛИНИТЬ ТЕКСТ!

Не понимаю что это значит. Кто-то понимает?

Это что-то типа: я несу на тарелке помидор, но это должен быть огурец?
Gigi,
22.05.17, 16:35 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 22.05.17, 16:09) *
И текст наименования выбранного вставляется в реквизит ссылки.

Не понятно, если у вас поле содержит ссылку как вы туда текст вставите, и зачем его вставлять? Честно, прочитал несколько раз, так и не понял что же надо сделать.

Цитата(Gigi @ 22.05.17, 17:24) *
Не знаю, на сколько правильный путь, но не сработало.

И не сработает, потому что вы Предопределенное значение это что-то что уже предопределено в конфигурации, а не значение какого-то реквизита, в этой функции не может быть более двух точек, и после второй должно быть наименование предопределенного элемента а не реквизит.
Gigi,
19.05.17, 16:13 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
Цитата(onsamuy @ 19.05.17, 16:25) *
Еще один дебил

Это лишь подтверждение того, что большинство т.н. "ассоциаций" кого либо - просто сборище людей которые нифига не разбираются в предмете своей ассоциации. К тому же, человек который представляет разработчиков ПО говорит такое про частоту обновлений - просто абсурд, именно поэтому национального ПО нет, потому что оно нифига не развивается под такими ассоциациями.
howlett,
17.05.17, 16:47 Где найти документацию по обмену с сайтом?
Цитата(zey_ser @ 17.05.17, 17:05) *
А если брать тиражные разработки для Битрикса, то настолько подробной документации тоже не будет?

Всё что есть - здесь https://www.1c-bitrix.ru/products/cms/1c/
zey_ser,
17.05.17, 15:54 Где найти документацию по обмену с сайтом?
Цитата(zey_ser @ 17.05.17, 16:42) *
Я правильно понял, что конкретной документации нет и разработчикам сайтов надо разбирать модули 1С?

Правильно. Для каждого сайта делаются конкретные разработки на стороне 1С. Для каких-то сайтов (например Битрикс) уже есть тиражные разработки, для каких-то "кустарные", для каких-то вообще ничего нет. В любом случае на стороне 1С необходимо что-то "допиливать".
zey_ser,
17.05.17, 12:40 Регистрация изменений добавленных реквизитов документа УНФ
Необходимо в РС "Обсуждения" добавить ресурс - ваш реквизит, и прописать в заказе его заполнение
AlexHummer,

60 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 28.06.17, 21:23
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне