Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику logist ::: Спасибо сказали: 2248 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
26.01.17, 19:57 Музей нашего форума
Цитата(000202 @ 11.01.17, 21:20) *
как на 1с 7.7 добавить базу 1с 8.3 чтобы работала ???
Zaval,
04.01.17, 19:02 Множественный выбор значений для реквизита
Цитата(PM.VIVAT @ 03.01.17, 16:01) *
Пример. Книга с двумя авторами. Необходимо в свойство "Автор" записывать два значения "Иванов" и "Петров".

Допиливали УНФ под книготорговлю, добавили независимый справочник "Авторы", если несколько авторов - пользователи при вводе разделяли ";", на сайте в т.ч., при выгрузке на сайт - сайт парсил этот момент, при загрузке с сайта, сайт уже отдавал одну строку содержащую разделители. Не знаю насколько это важно для вашей учетной системы, нашему клиенту, для учетной системы было всё равно сколько у книги авторов, поэтому они всё "ютились" в одном элементе справочника. При необходимости поиска всех элементов с участием какого-то автора - обычный полнотекстовый, или поиск по строке, отлично справлялись, хотя для них это просто информационное поле.
PM.VIVAT,
21.12.16, 15:38 Снежинки
Цитата(mister-x @ 21.12.16, 16:34) *
як саме?

Правой кнопкой на вкладке - "Отключить звук на вкладке"
mister-x,
21.12.16, 11:37 Посоветуйте литературу по разработке отчетов.
Цитата(Vlad 1C @ 21.12.16, 9:54) *
Т.е. вариант, что у предприятия оформлен договор ИТС

В большинстве случаев такой вариант считается не реальным. В любом случае, давать ссылки на закрытые сайты не есть правильно, особенно не уточняя что он закрытый, и что надо для доступа.

Цитата(Vlad 1C @ 21.12.16, 10:59) *
и получите бесплатный доступ ко всем материалам на целую неделю.

Что потом, через неделю? Вариант, что человек будет печатать книгу оттуда - исключаю, можно конечно сохранять страницы, но это как-то грустно. Вообще, Petre, сделал правильный подход, и надо сказать, что всё интересное уже так или иначе в сети лежит, в свободном доступе.
pqvv,
21.12.16, 0:51 Посоветуйте литературу по разработке отчетов.
Vlad 1C, уместней было бы дать общедоступную ссылку http://v8.1c.ru/metod/books/book.jsp?id=389
pqvv,
18.12.16, 17:40 Маска поля ввода и поиск
Цитата(Михрутка @ 18.12.16, 11:47) *
Может нужно сделать обработку

Да. Приведите все механизмы к единому стандарту.
Михрутка,
13.12.16, 9:34 Расчёт отпускных (по средней) (Бухгалтерия для Украины, внешний отчёт)
Цитата(Nadiy @ 13.12.16, 10:08) *
Метод об`єкту не виявлено (СтрШаблон)

При обновлениях эта функция была убрана, т.к. есть в платформе, а обработку не изменили. Откройте ее в конфигураторе, найдите этот текст и уберите "Локализация.", что бы осталось так:
ЭтаФорма.Заголовок = СтрШаблон(НСтр("ru='Расчет отпускных (от ¤1¤ г.)';uk='Розрахунок вiдпускних (вiд ¤1¤ р.)'"), Формат(ДатаПриказа, "ДФ=dd.MM.yy"));

по идее должно сработать
Nadiy,
13.12.16, 8:17 Расчёт отпускных (по средней) (Бухгалтерия для Украины, внешний отчёт)
Цитата(Nadiy @ 13.12.16, 9:10) *
який пароль????

Администрация форума точно так же психует когда люди не читают правила.
Nadiy, Vofka,
10.12.16, 12:58 Итоги по столбцу табличной части
Цитата(Lexveritas @ 10.12.16, 13:52) *
Попробовал всё запхать в цикл.

Ваш цикл бессмысленный, т.к. вы получили текущую строку
Стр = Элементы.СоставПластикатаПВХ.ТекущиеДанные;

И дальше перебирая всю таблицу циклом, меняете данные только в той одной строке.
   Стр.СоотношениеПроц = (Стр.МассоваяЧастьПлПВХ / Объект.Итог1)*100;
    Стр.КоличествоТП = (Объект.ВесТехпорции * Стр.СоотношениеПроц)/100;
    Стр.КоличествоТонна = (1010 * Стр.СоотношениеПроц)/100;


Что бы данные менялись в каждой строке надо использовать само определение строки в цикле "МассоваяЧастьПлПВХ "

Т.е. должно быть примерно так:
&НаКлиенте
Процедура ПриИзмененииМассоваяЧасть()
    Объект.Итог1 = Объект.СоставПластикатаПВХ.Итог("МассоваяЧастьПлПВХ");
    Для Каждого МассоваяЧастьПлПВХ Из Объект.СоставПластикатаПВХ Цикл
    МассоваяЧастьПлПВХ.СоотношениеПроц = (МассоваяЧастьПлПВХ.МассоваяЧастьПлПВХ / Объект.Итог1)*100;
    МассоваяЧастьПлПВХ.КоличествоТП = (Объект.ВесТехпорции * МассоваяЧастьПлПВХ.СоотношениеПроц)/100;
    МассоваяЧастьПлПВХ.КоличествоТонна = (1010 * МассоваяЧастьПлПВХ.СоотношениеПроц)/100;
    КонецЦикла
КонецПроцедуры

Только не надо копипастить этот код, это лишь пример как работать с циклом и табличной частью,
Lexveritas,
10.12.16, 0:57 Итоги по столбцу табличной части
У табличного поля есть событие ПриИзменении, которое срабатывает при изменении любых данных в нем, опишите в этом событии свои расчеты. Ну или в каждой колонке которая влияет на расчет - сделайте вызов одной процедуры, которая будет выполнять полный перерасчет данных.
Lexveritas,
10.12.16, 0:53 Отчет "Валовая прибыль" в УТ для Украины 3.1 не отображает себестоимость
В УТ3 себестоимость не вычисляется в момент проведения документов, поэтому пока не выполните "закрытие месяца" с пунктиком Расчет себестоимости, ничего в отчете не увидите smile.gif
Lemmy,
09.12.16, 14:17 Итоги по столбцу табличной части
Тогда так
Объект.Итог1 = Объект.СоставПластикатаПВХ.Итог("МассоваяЧастьПлПВХ");
Lexveritas,
09.12.16, 11:24 Вібор из списка
Цитата(pqvv @ 09.12.16, 11:51) *
Код не срабатывает, справочник в форме выбора отображается весь.

Ссылка на группу не пустая? А то, поиск по наименованию, это из прошлого века smile.gif При открытии формы в параметрах (через отладчик) видно что отбор заполнен?
pqvv,
08.12.16, 18:08 Оф. сайт 1С игнорирует Украину Internal,
03.12.16, 17:33 Как отправить из файловой базы на sql/pgsql сервер некоторые данные
Если связь с удаленным сервером стабильная то можно из 1С писать в базу через комобъект ADODB.Connection
cartorys,
02.12.16, 13:22 Как вернуть давальческое сырье давальцу.
Цитата(Наталья_К @ 02.12.16, 12:27) *
А другого варианта нет?

Операция (бухучет)
Наталья_К,
30.11.16, 18:09 Нажатие на картинку
&НаКлиенте
Процедура КартинкаНажатие(Элемент, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    // Вставить содержимое обработчика.
КонецПроцедуры
vlad_,
29.11.16, 17:29 Помогите с выбором конфигурации.
УНФ в отличие от УТП - конфигурация которая еще развивается, в УТП будет обновляться только регламентированный учет. Это если смотреть на перспективу.
Из того, что вам первоначально надо, я бы отметил более юзабельную систему управления заказами в УНФ, мнение основанное на внедрениях. Расчет зарплаты и ОС - сильнее в УТП. В УНФ нет бухгалтерского учета, здесь плюсом будет УТП, потому что вы можете сразу вести и УУ и БУ.
Alochka,
28.11.16, 15:16 Не систематические притормаживания 1С
Цитата(bizisoft @ 28.11.16, 15:54) *
  Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Остаток = Остаток+ВыборкаДетальныеЗаписи.КоличествоОстаток;
    КонецЦикла;  

Цитата(bizisoft @ 28.11.16, 15:54) *
  Пока Выборка.Следующий() Цикл
        Если Выборка.Номенклатура = Товар Тогда
            ВыписаноВДокументах = ВыписаноВДокументах+Выборка.Количество;
        КонецЕсли;
    КонецЦикла;

Перенесите всё это в запрос, бессмысленные циклы одна из причин тормозов.
bizisoft,
28.11.16, 14:09 Отключить движения по 28 счету
Цитата(cos12 @ 28.11.16, 12:19) *
(и не спрашивайте зачем... просто нужно...)

Думаю, в таком случае весь бухучет не имеет смысла.

Можете попробовать в регистре бухгалтерии как-то отсекать проводки где есть 28счет, это такое простое костыльное решение, но оно может не спасти от процедур контроля остатков или движений других регистров, которые выполняются до записи бухгалтерских проводок.
Если получится отсекать при записи бухрегистра - отлично, если нет - определитесь стоит ли игра свеч - выпиливать проводки из всех мест конфигурации. А то может вам надо просто из отчета спрятать цифры.

Цитата(cos12 @ 28.11.16, 15:02) *
ПроверитьПроводку(Проводка) - в ней, как я понимаю, я должен написать свое условие блокировки 28-го счета?

Нет, эта процедура лишь дополняет/изменяет данные. Вам надо в конце ПередЗаписью перебрать записи и исключить из них не нужные проводки.
cos12,
28.11.16, 14:03 В печатную форму Расходная накладная попадают услуги?
Цитата(Юля @ 28.11.16, 14:57) *
І в іншій базі такої проблеми не має.

Тут скорее проблема в той, другой базе. Потому, что в печатной форме накладной штатно выводятся и товары и услуги. В форме акта - только услуги.
Юля,
28.11.16, 13:40 Отключить движения по 28 счету
Цитата(cos12 @ 28.11.16, 13:34) *
почему?

Потому что тот список - это счета редактирование которых запрещено в форме элемента счета. К проводкам не имеет никакого отношения.
cos12,
25.11.16, 13:59 Бухгалтерия для Украины, переход с редакции 1.2 на 2.0
Цитата(cos12 @ 25.11.16, 14:34) *
не нашол в Бухгалтерии для Украины 2.0 возможности загрузить данные из ЗУП-а

Все функции - Обработки - Загрузка из ЗУП 2.1
cos12,
22.11.16, 13:29 Отчет Анализ Субконто
Цитата(nazarenko @ 22.11.16, 11:04) *
как надо было сделать?

Надо было найти 4 строки с указанными псевдонимами и заменить их на приведенные мной.
nazarenko,
21.11.16, 21:02 Отчет Анализ Субконто
    ОстаткиИОбороты.СуммаКонечныйОстатокДт - ОстаткиИОбороты.СуммаКонечныйОстатокКт КАК БУКонечныйОстатокДт,
    ОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокДт - ОстаткиИОбороты.СуммаКонечныйРазвернутыйОстатокКт КАК БУКонечныйРазвернутыйОстатокДт,
    0 КАК БУКонечныйОстатокКт,
    0 КАК БУКонечныйРазвернутыйОстатокКт,
nazarenko,

57 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 24.02.17, 10:22
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне