Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 11, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

28 страниц V   1 2 3 > » 

>  Печать из обработки с учетом фильтрации данных
Constantus
Отправлено: 29.08.18, 10:03


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


данный пример сработал для Обработки.

Теперь пытаюсь вывести на печать данные из табличной части документа с учетом отбора.

Печать идет из Модуля Объекта классическим способом...

    Для каждого СТР Из Начисления Цикл
        
    //Если НЕ ПроверитьСтроку(СТР) Тогда
        // Продолжить;  
        //КонецЕсли;

        
        
    Если СТР.ОфициальныйОклад > 0 Тогда;    
        
    ОбластьМакета.Параметры.Н = Н;
    ОбластьМакета.Параметры.ТН = СТР.Сотрудник.Код;
.....................................


Как в случае печати из модуля объекта вывести на печать только отобранные фильтром данные?

ЭлементыФормы.Начисления.ПроверитьСтроку(Стр)
- как применить или что применить?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144854 · Ответов: 4 · Просмотров: 234
 

>  Дозаполнение ТЧ документа "забытыми" или "новыми" данными из справочника
Constantus
Отправлено: 27.08.18, 11:21


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Придумал "гениальнейшее решение".
В ТЧ справочника ввел новый реквизит "ИД" (текст, 200)

При создании новой записи в ТЧ справочника добавил код:

Элемент.ТекущиеДанные.ИД = Новый УникальныйИдентификатор;


Уникальный код создается типа: d831cd77-2b82-42b1-9153-9b1a44831329

Вот теперь планирую этот код вставлять в ТЧ документа и при добавлении (обновлении) данных ТЧ сравнивать этот код с "новыми забытыми" сотрудниками... Типа если такой код есть, то ничего не предпринимать...

Теперь тогда вопрос: насколько это гениальное решение гениально? Где подводные валуны?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144791 · Ответов: 4 · Просмотров: 215
 

>  Дозаполнение ТЧ документа "забытыми" или "новыми" данными из справочника
Constantus
Отправлено: 27.08.18, 8:18


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Имеется самописные справочник "Сотрудники" и самописный документ "Начисление заработной платы.

В документе "Начисление" ТЧ заполняется автоматически по кнопке. Код обходит справочник "Сотрудники" и по определенному алгоритму заполняет нужных сотрудников в ТЧ документа "Начисление".

Код работает правильно и без проблем. Но столкнулся со следующей проблемой.

Предположим забыли добавить в справочник "Сотрудники" нового сотрудника и/или перевели в другой отдел, поменяли оклад и т.д.

Конечно, можно взять и нажать вышеупомянутую кнопку и ТЧ "Начисления" заполнится новым правильным списком, но данные расчета по "старым" сотрудникам естественно затруться и расчет нужно будет проводить заново, что крайне плохо...

Каким образом можно сделать при заполнении ТЧ документа проверку, что по такому-то сотруднику уже есть данные в ТЧ и добавлять его не нужно, т.е. оставить данные ТЧ не измененными? Т.е. дозаполнить ТЧ только "новыми" или "забытыми" сотрудниками?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144787 · Ответов: 4 · Просмотров: 215
 

>  Настройки договоров по аналогии с 10.3
Constantus
Отправлено: 13.08.18, 13:21


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Управление торговлей, редакция 11.2 (11.2.3.124)

Пытаюсь самостоятельно изучить эту конфигурацию. Много чего непонятного и навороченного, но хочу (пытаюсь) понять следующее.

В 10.3 Договора с контрагентами (покупателями) настраивались легко и визуально (интуитивно) понятно.
У меня есть контрагенты покупатели, создаю договор "Основной", указываю вести "по договору в целом", "вести учет по документам взаиморасчетов"

Пытаюсь в 11.2 сделать нечто подобное, но никак не могу настроить такой учет. При создании договора выходит несколько вариантов "по договору" (заказам/накладным)

Нигде не могу найти нечто, что позволит вести учет по документам взаиморасчетов, чтобы потом при формировании например ПКО выбирать нужную реализацию, по которой пришли деньги.

Посоветуйте куда идти? Или там вообще реализована другая логика?
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #144352 · Ответов: 1 · Просмотров: 161
 

>  АвтоОбмен РИБ: проблема с rphost.exe
Constantus
Отправлено: 13.08.18, 10:35


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Иногда возникает ситуация, что автообмен встает замертво на филиале.

Выявил долгим творческим путем, что обмен зависает из-за того, что временная папка, куда скидываются временные файлы для обмена, заблокирована процессом rphost.exe

Для устранения этой неприятности, написал БАТник, где этот процесс удаляется и автообмен восстанавливается.

Из-за чего такое может быть и как побороть эту проблему?

На филиале установлен Посгрес 9.4 1с.
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #144340 · Ответов: 0 · Просмотров: 156
 

>  Печать из обработки с учетом фильтрации данных
Constantus
Отправлено: 09.08.18, 14:34


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


ed.kharkov @ Сегодня, 17:22 * ,

Вроде сработало, но объясните логику работы кода!!!
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144229 · Ответов: 4 · Просмотров: 234
 

>  Печать из обработки с учетом фильтрации данных
Constantus
Отправлено: 09.08.18, 12:19


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Создал обработку. В обработке имеется командная панель с фильтрами отбора данных.

Создал кнопку печати

Код
    ТабДок = Новый ТабличныйДокумент;
    Макет = ПолучитьМакет("Макет");
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.ДатаНачала = Формат(ДатаНачала,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.ДатаОкончания = Формат(ДатаОкончания,    "ДФ='dd.MM.yyyy'");
    ТабДок.Вывести(ОбластьМакета);

    
    ОбластьМакета = Макет.ПолучитьОбласть("ОбластьПечати");
    
    Для Каждого Стр Из Детально Цикл
        
    ОбластьМакета.Параметры.Снят = Стр.Снят;
    ОбластьМакета.Параметры.Удален = Стр.Удален;
    ОбластьМакета.Параметры.Дата = Формат(Стр.Дата,    "ДФ='dd.MM.yyyy'");
    ОбластьМакета.Параметры.Номер = Стр.Номер;
*************
    
    ТабДок.Вывести(ОбластьМакета);
    КонецЦикла;
    
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДок, 1, Ложь, "Отчет по счет-фактурам (аналитический) за период с " + Формат(ДатаНачала, "ДФ='dd.MM.yyyy'") + " по " + Формат(ДатаОкончания,    "ДФ='dd.MM.yyyy'") );


Печатает как надо, но если я на командной панели ставлю отбор, то кнопка печати срабатывает без учета фильтров и печатает опять таки все данные, полученные обработкой

Как нужно изменить код печати из обработки с учетом фильтров, установленных на командной панели?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144221 · Ответов: 4 · Просмотров: 234
 

>  Восстановить базу Постгресс из файла *.sql
Constantus
Отправлено: 08.08.18, 8:47


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Flexy @ Вчера, 18:43 * ,

Переименование расширения не помогло
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #144154 · Ответов: 5 · Просмотров: 251
 

>  Восстановить базу Постгресс из файла *.sql
Constantus
Отправлено: 07.08.18, 14:11


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Flexy @ Сегодня, 16:36 * ,

Я пытался через pgАdmin-3, но там восстановление требует файл basename.backup
а у меня есть архив

basename.sql
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #144128 · Ответов: 5 · Просмотров: 251
 

>  Восстановить базу Постгресс из файла *.sql
Constantus
Отправлено: 07.08.18, 9:12


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


PostgresPro 1C 9.4 1c

С помощью программы PostgreSQL Backup делаю суточные бакапы (UT_ASB201808050200.sql)

Подскажите как максимально просто восстановить эту базу, если можно с картинками?
Или укажите ресурс с картинками icon_beer17.gif
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #144121 · Ответов: 5 · Просмотров: 251
 

>  При открытии не вносить изменения в поле выбора
Constantus
Отправлено: 03.08.18, 15:40


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Vidocq05 @ Сегодня, 18:35 * ,

Это реквизит объекта...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144034 · Ответов: 6 · Просмотров: 264
 

>  При открытии не вносить изменения в поле выбора
Constantus
Отправлено: 03.08.18, 15:23


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Vidocq05 @ Сегодня, 18:06 * ,

Может быть, но перенос этого кода не помог. При открытии формы данное поле пустое, хотя когда тыкаешь, то он фокусирует в списке нужное значение, а визуально всё пусто
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144032 · Ответов: 6 · Просмотров: 264
 

>  При открытии не вносить изменения в поле выбора
Constantus
Отправлено: 03.08.18, 14:44


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

У меня при открытии формы (нетипового документа) стоит код, который заполняет реквизит "ПериодНачисления" (дата) в формате "Месяц год".
Этот реквизит оформлен как поле выбора. Код заполняет список выбора и в зависимости от даты (первый день месяца) заполняет в нужном формате.

    Если НЕ ЗначениеЗаполнено(ПериодНачисления) Тогда
        СформироватьСписокВыбораМесяца(Год(ТекущаяДата()));
    Иначе
        СформироватьСписокВыбораМесяца(Год(ПериодНачисления));
        ПериодНачисления = ЭлементыФормы.ПериодНачисления.СписокВыбора[Месяц(ПериодНачисления)+1].Значение;
    КонецЕсли;



Процедура СформироватьСписокВыбораМесяца(Знач Год)
    
    Год = Число(Год);
    СписокВыбора = ЭлементыФормы.ПериодНачисления.СписокВыбора;
    СписокВыбора.Очистить();
    СписокВыбора.Добавить(Null);
    СписокВыбора.Добавить(Формат(Год-1, "ЧГ=0"), Формат(Год-1, "ЧГ=0"));
    Для М = 1 По 12 Цикл
        СформДата = Дата(Год, М, 1);
        Наим = Формат(СформДата, "ДФ='ММММ гггг"" г.""'");
        СписокВыбора.Добавить(СформДата, Наим);    
    КонецЦикла;
    СписокВыбора.Добавить(Формат(Год+1, "ЧГ=0"), Формат(Год+1, "ЧГ=0"));
    
КонецПроцедуры



Но столкнулся с такой проблемой, получается так, что всегда при открытии этот код переопределяет значение "ПериодНачисления" и если ты даже просто открыл документ для просмотра, то при закрытии сообщает, что данные были изменены и требуется сохранить.

Как можно используя эти код, при открытии не проводить переопределение старого значения на новое?

Если ремачу
//ПериодНачисления = ЭлементыФормы.ПериодНачисления.СписокВыбора[Месяц(ПериодНачисления)+1].Значение;

то реквизит после открытия пустой.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #144029 · Ответов: 6 · Просмотров: 264
 

>  Ввод на основании Заявки: не заполняются некоторые реквизиты в РКО
Constantus
Отправлено: 26.07.18, 10:37


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Нашел

В модуле формы документа в Процедуре ЗаполнитьКонтрагента() стоял код:

    УстановитьОграничениеТипаКонтрагента();
    Контрагент = ЭлементыФормы.Контрагент.ОграничениеТипа.ПривестиЗначение(Контрагент);



А нужен был:
    Если ВидОперации = Перечисления.ВидыОперацийРКО.РасходДенежныхСредствПрочее 
        ИЛИ ВидОперации = Перечисления.ВидыОперацийРКО.ВзносНаличнымиВБанк Тогда
        Контрагент = Неопределено;
    Иначе
        УстановитьОграничениеТипаКонтрагента();
        Контрагент = ЭлементыФормы.Контрагент.ОграничениеТипа.ПривестиЗначение(Контрагент);
    КонецЕсли;


Недостающее не делала Контрагента неопределенным, а там далее шла проверка на СДДС...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143770 · Ответов: 1 · Просмотров: 193
 

>  Ввод на основании Заявки: не заполняются некоторые реквизиты в РКО
Constantus
Отправлено: 26.07.18, 8:54


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

На основании Заявки пытаюсь сформировать РКО.
Когда Заявка имеет операцию "Прочий расход денежных средств", то при формировании на ее основе РКО не заполняются реквизиты:
1. Статья движения денежных средств
2. Документ основания, т.е. сама Заявка

Данные поля пустые. Если выбирать другие типы операций, то эти данные переносятся в РКО, только при этом виде операции идет такой конфуз.

Конфигурация досталась в наследство, может, что и было изменено. Но так ничего не нашел.

Прошелся по модулю "ОбработкаЗаполнения(Основание)", вроде всё нормально.
Прошелся по модулю при открытии. Обнаружил такое

При выполнении "УправлениеДенежнымиСредствами.УстановитьСтатьюДДСПоУмолчанию(СтрокаПлатеж,ВидОперации);"

    Если НЕ СтрокаПлатеж.СтатьяДвиженияДенежныхСредств=Справочники.СтатьиДвиженияДенежныхСредств.ПустаяСсылка() Тогда
        Возврат;


Условие не выполняется, т.е. при открытии статья становится пустой ссылкой. Никак не могу найти место, где происходит уничтожение ссылки на статью из Заявки...

Сравнил с другой конфигурацией (последнее обновление УТ 10.3, демо), там вроде всё тоже самое, но всё заполняется.

Помогите разобраться, где еще может происходит затирание ссылок на эти реквизиты при формировании на основании?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143764 · Ответов: 1 · Просмотров: 193
 

>  Ошибка субд: relation "tempid_0" already exists
Constantus
Отправлено: 25.07.18, 12:42


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(sava1 @ 25.07.18, 15:37) *
никакая обработка не применяет временный файл а потом его не освобождает?


Ничё не понял icon_beer17.gif
  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #143731 · Ответов: 5 · Просмотров: 258
 

>  Ошибка субд: relation "tempid_0" already exists
Constantus
Отправлено: 25.07.18, 11:55


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

PostgresPro 1C 9.4 сборка 1с

Относительно недавно начала появляться такая ошибка "Ошибка субд: relation "tempid_0" already exists"

Причем вылезает она только на Серверном компьютере, где всегда запущена конфигурация с обработкой Моби-С.

У пользователей такой ошибки вроде не выходит (ну никто не жаловался).

Что могло случится и как с этим теперь бороться? Выходит сообщение выйти или перезагрузить...



  Форум: Администрирование и настройка серверов баз данных · Просмотр сообщения: #143726 · Ответов: 5 · Просмотров: 258
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 17.07.18, 7:40


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Что-то я совсем не понял ситуацию... Взял эту ошибочную конфигурацию, сделал для нее узел РИБ, запустил обмен, никаких ошибок по вышеизложенному не стал давать. Всё работает как часы...

Что тогда могло случится?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143460 · Ответов: 7 · Просмотров: 383
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 16.07.18, 14:58


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(sava1 @ 16.07.18, 16:17) *
Если обмен - вооще отказаться от проверки - нафика ?


Вот не совсем понял эту фразу icon_beer17.gif
Так как правильно поступить?

ПС: зря я кажется связался с этими подписками...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143422 · Ответов: 7 · Просмотров: 383
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 16.07.18, 13:05


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Petre @ Сегодня, 15:58 * ,


#Если Клиент Тогда???

Куда вставить лучше? На весь код подписок на событие или только на код диалога?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143418 · Ответов: 7 · Просмотров: 383
 

>  Подписка на событие: ошибка при обмене РИБ
Constantus
Отправлено: 16.07.18, 12:00


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Сделал подписку на события с целью "мягкой" проверки правильного заполнения статей движения денежных средств с возможностью отказа запрета "ПередЗаписью":

Код
Для Каждого СТЧ из Источник.РасшифровкаПлатежа Цикл
        Если СТЧ.СтатьяДвиженияДенежныхСредств.ВаловаяПрибыль
            И НЕ ЗначениеЗаполнено(Источник.ДатаВП) Тогда
            Сообщить("Данная статья (" + СТЧ.СтатьяДвиженияДенежныхСредств + ") предусматривает участие в Отчете по валовой прибыли." + Символы.ПС + "Рекомендуется указать период учета по данной статье. Иначе данные средства не войдут в учет по валовой прибыли.");
            
            Ответ = Вопрос("Требуется ли указать период учета?", РежимДиалогаВопрос.ДаНет,0);
            Если Ответ = КодВозвратаДиалога.Нет Тогда
                Отказ = Ложь;
            Иначе
                Отказ = Истина;  
            КонецЕсли;
            
        КонецЕсли;    
    КонецЦикла;


Ну т.е. была попытка только рекомендовать, если не надо, то и не надо, документ проводится спокойно.

Когда тестировал, всё срабатывало без проблем. Обновил конфигурацию. Запустил обмен РИБ. Сначала автообмен с полными правами и выдало ошибку:


Цитата
{ОбщийМодуль.Мой.Модуль(958,57)}: Переменная не определена (РежимДиалогаВопрос)
Ответ = Вопрос("Требуется ли указать период учета?", <<?>>РежимДиалогаВопрос.ДаНет,0);
{ОбщийМодуль.Мой.Модуль(959,17)}: Переменная не определена (КодВозвратаДиалога)
Если Ответ = <<?>>КодВозвратаДиалога.Нет Тогда
{ОбщийМодуль.Мой.Модуль(958,12)}: Процедура или функция с указанным именем не определена (Вопрос)
Ответ = <<?>>Вопрос("Требуется ли указать период учета?", РежимДиалогаВопрос.ДаНет,0);


Отключил у всех своих обменников "обмен с полными правами". Обмены работают, но автообмен нет, теперь вынужден только в ручную обмен задействовать.

Почему такое случилось? Почему неопределенность переменных и функции "Вопрос" увиделось только при обмене данными? Ну и соответственно автообмен упал.
Что нужно предпринять?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143416 · Ответов: 7 · Просмотров: 383
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 16:14


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


На ИТС нашел вот такой код: https://its.1c.ru/db/metod8dev#content:2805:hdoc

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)

    
        Соответствие = Новый Соответствие;

    // Заполнение параметра - массива значений ссылками на отображаемые строки табличного поля
    СсылкиМассив = Новый Массив;
    Для каждого Стр из ОформленияСтрок Цикл

        СсылкиМассив.Добавить(Стр.ДанныеСтроки.Ссылка);
        Соответствие.Вставить(Стр.ДанныеСтроки.Ссылка, Стр);

    КонецЦикла;

    // Сформировать запрос для получения остатков
    ЗапросОстатка = Новый Запрос;
    ЗапросОстатка.Текст = "ВЫБРАТЬ
                          |    ДвиженияДенежныхСредств.Регистратор Как Регистратор
                          |ИЗ
                          |    РегистрНакопления.ДвиженияДенежныхСредств КАК ДвиженияДенежныхСредств
                          |ГДЕ
                          |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа В(&ДокументПланированияПлатежа)";

    ЗапросОстатка.УстановитьПараметр("ДокументПланированияПлатежа", СсылкиМассив);
    Выборка = ЗапросОстатка.Выполнить().Выбрать();

    //Вывести остаток в строку, найденную в соответствии по номенклатуре из запроса
    Пока Выборка.Следующий() Цикл

        Соответствие.Получить(Выборка.Регистратор).Ячейки.РРКО.Значение = Выборка.Регистратор;

    КонецЦикла;
    

    
КонецПроцедуры


Код переделал под свои нужды, но выдает такую ошибку:

{Документ.ЗаявкаНаРасходованиеСредств.Форма.ФормаСписка.Форма(146)}: Значение не является значением объектного типа (Ячейки)
        Соответствие.Получить(Выборка.Регистратор).Ячейки.РРКО.Значение = Выборка.Регистратор;




Вот нашел другой код, вроде работает:

    МассивЗаказов = Новый Массив;
    Для Каждого Стр Из ОформленияСтрок Цикл
        МассивЗаказов.Добавить(Стр.ДанныеСтроки.Ссылка);
    КонецЦикла;
    // Формируем запрос к остаткам заказов
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ДвиженияДенежныхСредств.Регистратор,
        |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа
        |ИЗ
        |    РегистрНакопления.ДвиженияДенежныхСредств КАК ДвиженияДенежныхСредств
        |ГДЕ
        |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа В(&МассивЗаказов)"
;
    Запрос.УстановитьПараметр("МассивЗаказов", МассивЗаказов);
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    // Обрабатываем результат
    Для Каждого Стр Из ОформленияСтрок Цикл
        Если Выборка.НайтиСледующий(Новый Структура("ДокументПланированияПлатежа", Стр.ДанныеСтроки.Ссылка)) Тогда
            Стр.Ячейки.РРКО.Текст = Выборка.Регистратор;    
        Иначе
            Стр.Ячейки.РРКО.Текст = 0;    
        КонецЕсли;
        Стр.Ячейки.РРКО.ОтображатьТекст = Истина;
        Выборка.Сбросить();
    КонецЦикла;


  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143354 · Ответов: 18 · Просмотров: 704
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 14:17


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Цитата(Zaval @ 13.07.18, 17:12) *
Почему в Списке РКО, если данные нужны в списке Заявок?
Запрос должен выполняться не по каждой строке, а 1 раз по списку выведенных в форму Заявок


Как раз в Списке Заявок, есть левая колонка, вот туда и прописываются.

Я выложил код. Вы предложили другую идею "Запрос должен выполняться не по каждой строке, а 1 раз по списку выведенных в форму Заявок"

Как это осуществить?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143353 · Ответов: 18 · Просмотров: 704
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 13:12


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


Вот сделал такую вещч:

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
        // Соответствие создается для заполнения остатков в строках табличного поля
    Для каждого Стр из ОформленияСтрок Цикл

        Стр.Ячейки.РРКО.Значение = ПолучитьРКО(Стр.ДанныеСтроки.Ссылка);

    КонецЦикла;
    
КонецПроцедуры

Функция ПолучитьРКО(Основа)
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |    ДвиженияДенежныхСредств.Регистратор
        |ИЗ
        |    РегистрНакопления.ДвиженияДенежныхСредств КАК ДвиженияДенежныхСредств
        |ГДЕ
        |    ДвиженияДенежныхСредств.ДокументПланированияПлатежа = &Основа";
    
    Запрос.УстановитьПараметр("Основа", Основа);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Результат = ВыборкаДетальныеЗаписи.Регистратор;
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


     Возврат Результат;
    
КонецФункции


Вроде срабатывает, но явно тормозит... Может есчо есть пооптимальней?


Как можно получить данные из РН одной строкой, типа

Результат = РегистрыНакопления.РегистрТакойто.(?????)
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143350 · Ответов: 18 · Просмотров: 704
 

>  В данной транзакции уже происходили ошибки...
Constantus
Отправлено: 13.07.18, 12:14


Почти ветеран
******

Группа: Пользователи
Сообщений: 691
Регистрация: 19.09.15
Пользователь №: 45918


иЙолки-палочки... Всё перепробовал, даже открытие формы Заявок

        Для Каждого Заявка Из РасшифровкаПлатежа Цикл
                Док = Заявка.ДокументПланированияПлатежа.ПолучитьОбъект();
                Док.РКО = Документы.РасходныйКассовыйОрдер.ПустаяСсылка();
                Форма = Док.ПолучитьФорму("ФормаДокумента");
                Форма.Открыть();
                //Форма.ЭлементыФормы.РКО = Документы.РасходныйКассовыйОрдер.ПустаяСсылка();
                //Форма.Закрыть();
                //Док.Записать(РежимЗаписиДокумента.Запись);
        КонецЦикла;


Но как сохранить изменения в открытой форме и закрыть её не получается.

Вообщем я начал паниковать icon_cuss.gif

Подскажите детально как бы Вы сделали эту хотелку без "Попытка"?
Интересная идея с дополнительным реквизитом формы списка и как при этом использовать "ПриВыводеСтроки", если это действительно не кушает ресурсы при открытии, т.к. нужно будет выделять строки, где есть РКО...
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143346 · Ответов: 18 · Просмотров: 704
 

28 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.10.18, 22:07
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне