Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

5 страниц V   1 2 3 > » 

>  Подстановка даты конца периода равного началу периода
podcast
Отправлено: Вчера, 14:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Constantus @ Сегодня, 14:34 * ,
Примерно так.
Схема = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
        
Настройки = Схема.НастройкиПоУмолчанию;
        
КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
        
КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
        
            
        
ПараметрКонецПериода = Новый ПараметрКомпоновкиДанных("КонецПериода");
    
ЗначениеПараметраДок = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрКонецПериода);
        
ЗначениеПараметраДок.Значение = Новый Граница (КонецДня (СсылкаНаОбъект.Ссылка.Дата), ВидГраницы.Исключая);
        
ЗначениеПараметраДок.Использование = Истина;
  Форум: Система компоновки данных · Просмотр сообщения: #124693 · Ответов: 3 · Просмотров: 72
 

>  Отбор документов по контрагенту
podcast
Отправлено: 23.03.17, 17:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


kot488 @ Сегодня, 17:18 * ,
Событие Выбор для списка. Там прописываете обработчик.
Примерно так.
&НаСервере
Процедура СписокВыборНаСервере()
    Контрагент = Справочники.Контрагенты.НайтиПоКоду("КодКонтрагента");
    РеквизитПлательщик = Контрагент;    
КонецПроцедуры

&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    СписокВыборНаСервере();
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124624 · Ответов: 15 · Просмотров: 230
 

>  Отчет по складу в 3-х единицах измерения
podcast
Отправлено: 23.03.17, 9:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Constantus @ Сегодня, 7:17 * ,
Сохраните отчет как внешний, и вычисляйте в запросе остатки по другим единицам измерения.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #124585 · Ответов: 4 · Просмотров: 108
 

>  Как убрать должность главного бухгалтера в документах
podcast
Отправлено: 22.03.17, 17:34


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 17:32 * ,
Смотрю в каких документах и какие должности, но если править печатные формы, то да, их только через конфигуратор, если что обращайтесь помогу.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124553 · Ответов: 10 · Просмотров: 159
 

>  Как убрать должность главного бухгалтера в документах
podcast
Отправлено: 22.03.17, 17:29


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 16:58 * ,
Проверьте Регистр сведений Ответственные лица организации.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124551 · Ответов: 10 · Просмотров: 159
 

>  Сгруппировать таблицу значений
podcast
Отправлено: 21.03.17, 9:42


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Pavlik1c @ Сегодня, 9:41 * ,
Пример запроса, дальше уже как в обычном запросе группируете по Услугам.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124434 · Ответов: 5 · Просмотров: 101
 

>  Сгруппировать таблицу значений
podcast
Отправлено: 21.03.17, 9:40


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Pavlik1c @ Сегодня, 9:36 * ,
Как вариант добавить ТЗ в запрос сгруппировать в запросе, и работать уже с результатом запроса.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124432 · Ответов: 5 · Просмотров: 101
 

>  Отчет по отработанным часам/начисленной ЗП
podcast
Отправлено: 21.03.17, 9:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Натали Шелл @ Вчера, 18:47 * ,
За какой период хотите видеть? За месяц?
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124429 · Ответов: 2 · Просмотров: 127
 

>  Как правильно начислять индексацию зарплаты?
podcast
Отправлено: 17.03.17, 10:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 10:30 * ,
Проставьте "Дату изменения", потом рассчитайте с комментарием.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124260 · Ответов: 7 · Просмотров: 183
 

>  Как правильно начислять индексацию зарплаты?
podcast
Отправлено: 17.03.17, 10:22


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 10:01 * ,
Введите на основание документа "Приём на работу", документ "Изменение параметров расчёта индексации", там будет реквизит в верхней ТЧ "Дата изменения" заполните его, а скрин который вы выложили, это вроде документ "Изменение параметров расчёта индексации (По должности)", почитайте изменения в Законодательстве когда нужно устанавливать базовый месяц по должности.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124258 · Ответов: 7 · Просмотров: 183
 

>  Как правильно начислять индексацию зарплаты?
podcast
Отправлено: 17.03.17, 9:53


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 9:48 * ,
Рассчитайте с комментарием, посмотрите какой базовый месяц установлен, если не правильно, то вносите документ "Изменение параметров расчёта индексации", и там устанавливайте нужный базовый месяц. Или выложите скрин комментария расчета.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124255 · Ответов: 7 · Просмотров: 183
 

>  Не правильно записывает движения по регистру накопления
podcast
Отправлено: 16.03.17, 14:57


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Yevhenii @ Сегодня, 14:38 * ,
 Если (СуммаОплатыТмп>=ПлатимТЕМП и СуммаОплатыТмп>0) Тогда
            ДокОбъект = ВыборкаДетальныеЗаписи.СсылкаДокПродажи.ПолучитьОбъект();
            ДокОбъект.ОплатаПоДок =ПлатимТЕМП;
            ДокОбъект.Оплата = Истина;
            ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
            
            // регистр ПродажаМатериала Приход
            Движение = Движения.ПродажаМатериала.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
            Движение.Период = Дата;
            Движение.Контрагент = Контрагент;
            Движение.Дата = Дата;
            Движение.СтоимостьДолл = ПлатимТЕМП;
            Движение.СтоимостьГрн = (ПлатимТЕМП*ВыборкаДетальныеЗаписи.КурсДокПродажи);
            
                Движения.Записать(); // !!!Вроде ж нужно записать.

        
            //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
            СуммаОплатыТмп=СуммаОплатыТмп-ПлатимТЕМП;
            ОбновитьДопИнфоВсех();
        ИначеЕсли (СуммаОплатыТмп<ПлатимТЕМП и СуммаОплатыТмп>0) Тогда
            ДокОбъект = ВыборкаДетальныеЗаписи.СсылкаДокПродажи.ПолучитьОбъект();
            ДокОбъект.ОплатаПоДок =СуммаОплатыТмп;
            ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
            
            // регистр ПродажаМатериала Приход
            
            Движение = Движения.ПродажаМатериала.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
            Движение.Период = Дата;
            Движение.Контрагент = Контрагент;
            Движение.Дата = Дата;
            Движение.СтоимостьДолл = СуммаОплатыТмп;
            Движение.СтоимостьГрн = (СуммаОплатыТмп*ВыборкаДетальныеЗаписи.КурсДокПродажи);
            Движения.Записать();

            //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
            
            СуммаОплатыТмп=0;
            ОбновитьДопИнфоВсех();
            
        КонецЕсли;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #124215 · Ответов: 7 · Просмотров: 168
 

>  Способ отражения начисления по умолчанию
podcast
Отправлено: 16.03.17, 9:31


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


drug_com @ Сегодня, 0:29 * ,
Так как отражение ФОТ не получиться, можно только премию, отнести на один счет, если указать в "Способе отражение в бух учете" нужное отражение, в самом виде расчета.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #124177 · Ответов: 6 · Просмотров: 158
 

>  Печать расчётно-платёжной ведомости
podcast
Отправлено: 13.03.17, 16:28


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 16:23 * ,
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124061 · Ответов: 7 · Просмотров: 228
 

>  Печать расчётно-платёжной ведомости
podcast
Отправлено: 13.03.17, 16:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 16:18 * ,
А в Расчетно платежная ведомость вы этого не видите?
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124059 · Ответов: 7 · Просмотров: 228
 

>  Печать расчётно-платёжной ведомости
podcast
Отправлено: 13.03.17, 16:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 16:06 * ,
Расчет зарплаты организации - Отчеты - Расчетно платежная ведомость. Если для сотрудников, то Расчетные листки организации.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #124057 · Ответов: 7 · Просмотров: 228
 

>  Как добавить в личную карточку сотрудника данные о стаже и учёбе
podcast
Отправлено: 10.03.17, 13:59


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 13:48 * ,
Заходите в карточку ФизЛица, переходите на кладку Персональные данные, на нужной табличной части нажимаете Правую кнопку мыши - выбираете добавить.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #123956 · Ответов: 1 · Просмотров: 497
 

>  Печать ведомости начисления зарплаты
podcast
Отправлено: 09.03.17, 10:29


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


Лелуш Ламперуж @ Сегодня, 10:25 * ,
Расчет зарплаты организации - Отчеты - Расчетная ведомость организации. В отчетах посмотрите там есть ещё пару отчетов в которых можете увидеть начисления.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #123913 · Ответов: 1 · Просмотров: 171
 

>  Как втянуть и подставить данные с другого документа
podcast
Отправлено: 06.03.17, 9:08


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


burza @ 04.03.17, 9:59 * ,
У вас ДатаНачала и ДатаЗавершения реквизиты не табличной части, а справочника.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #123821 · Ответов: 28 · Просмотров: 770
 

>  Как втянуть и подставить данные с другого документа
podcast
Отправлено: 03.03.17, 16:42


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


burza @ Сегодня, 16:36 * ,
СтрокаТаблицы = Объект.План.НайтиПоИдентификатору(Элементы.План.ТекущаяСтрока);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #123740 · Ответов: 28 · Просмотров: 770
 

>  Как втянуть и подставить данные с другого документа
podcast
Отправлено: 03.03.17, 16:32


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


burza @ Сегодня, 16:25 * ,
&НаКлиенте
Процедура ПланСменаПриИзменении(Элемент)
    ПланСмена();
КонецПроцедуры


&НаСервере
Процедура ПланСмена()
     Справочник = Справочники.артЦеновыеСмены.НайтиПоНаименованию("артЦеновыеСмены");
     СтрокаТаблицы = Объект.План.НайтиПоИдентификатору(Элементы.План.ТекущийЭлемент);
    
    Если СтрокаТаблицы.Смена  = Справочник Тогда
     ЗначениеВРеквизитФормы(Справочники.артЦеновыеСмены.ДатаНачала, "ДатаНачала ");
     ЗначениеВРеквизитФормы(Справочники.артЦеновыеСмены.ДатаОкончания, "ДатаОкончания ");
    КонецЕсли
        
КонецПроцедуры

Поставьте точку останова и посмотрите чему равна СтрокаТаблицы.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #123738 · Ответов: 28 · Просмотров: 770
 

>  Как втянуть и подставить данные с другого документа
podcast
Отправлено: 03.03.17, 16:01


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


burza @ Сегодня, 15:49 * ,
СтрокаТаблицы = Объект.Товары.НайтиПоИдентификатору(Элементы.Товары.ТекущаяСтрока);
&НаКлиенте
Процедура ПланСменаПриИзменении(Элемент)
    ПланСмена();
КонецПроцедуры


&НаСервере
Процедура ПланСмена()
         //Элементы.План.ТекущиеДанные.ДатаНачала = Элементы.План.ТекущиеДанные.Смена.ДатаНачала;
     Справочник = Справочники.артЦеновыеСмены.НайтиПоНаименованию("артЦеновыеСмены");
     СтрокаТаблицы = Объект.План.НайтиПоИдентификатору(Элементы.План.ТекущиеДанные);
    
    Если СтрокаТаблицы.Смена  = Справочник Тогда
     ЗначениеВРеквизитФормы(Справочники.артЦеновыеСмены.ДатаНачала, "ДатаНачала ");
     ЗначениеВРеквизитФормы(Справочники.артЦеновыеСмены.ДатаОкончания, "ДатаОкончания ");
    КонецЕсли
        
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #123734 · Ответов: 28 · Просмотров: 770
 

>  Как втянуть и подставить данные с другого документа
podcast
Отправлено: 03.03.17, 15:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


burza @ Сегодня, 15:26 * ,
&НаКлиенте
Процедура ПланСменаПриИзменении(Элемент)
    ПланСменаПриИзменении();
КонецПроцедуры

&НаСервере
Процедура ПланСменаПриИзменении()
    СправочникАртЦеновыеСмены = Справочники.артЦеновыеСмены.НайтиПоНаименованию("артЦеновыеСмены");
    Если Объект.Смена   = СправочникАртЦеновыеСмены Тогда
        ЗначениеВРеквизитФормы(СправочникАртЦеновыеСмены.ДатаНачала, "ДатаНачала ");
    КонецЕсли;    
КонецПроцедуры

На работоспособность не проверял но принцип такой.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #123732 · Ответов: 28 · Просмотров: 770
 

>  Как втянуть и подставить данные с другого документа
podcast
Отправлено: 03.03.17, 15:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


burza @ Сегодня, 14:59 * ,
Справочник = Справочники.артЦеновыеСмены.НайтиПоНаименованию("НаименованиеСправочника");

  Если Элементы.План.ТекущиеДанные.Смена = Справочник Тогда
  
КонецЕсли

НайтиПоНаименованию доступно только на Сервере, вроде.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #123730 · Ответов: 28 · Просмотров: 770
 

>  Хранение цвета в реквизите справочника
podcast
Отправлено: 01.03.17, 14:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 113
Регистрация: 23.12.15
Пользователь №: 47553


bizisoft @ Сегодня, 12:58 * ,
Выберите тип Цвет.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #123621 · Ответов: 10 · Просмотров: 351
 

5 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 25.03.17, 17:38
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне