Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

7 страниц V   1 2 3 > » 

>  Задать ширину растянуть форму
Gigi
Отправлено: Вчера, 13:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(logist @ 21.11.17, 13:39) *
Где гарантия, что после 5-го сообщения вы не скажите - ладно ребята, оставлю как есть, потому что не хочу понимать, что вы мне тут объясняете?

Да нет ... я просто стараюсь найти путь полегче... а если че не понимаю как сделать иду дальше только если вопрос имеет важное значение.
И бросаю дело если легко не получается (не важно по какой причине), только тогда когда не сильно важное дело.
Но в данном случае дело поважнее. Потому, что без окрашенных в желтый цвет строк можно обойтись. А с формой в таком виде мириться НИКАК НЕЛЬЗЯ!
Так что в данном случае вопрос не из мало важных!
Поэтому рассчитываю на помощь
Дело в том, что и для группы "Рубли" и для "Квт/ч" на РастянутьПоГоризонтали стоит "Авто"
На группе "Рубли"в РастянутьПоГоризонтали ставлю "Да" и вот как получается:

Т.е. Группа "Рубли" перемещается влево. Поэтому исчезает заголовок.
Нужно, что бы перемешалась вправо.
Так что, буду очень признателен. Потому, что вопрос не из сильно не важных
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135176 · Ответов: 2 · Просмотров: 55
 

>  Задать ширину растянуть форму
Gigi
Отправлено: Вчера, 13:26


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Всем опять привет!
Опять проблема блиин! Как надоело...
Вечно кляузы, проблемы .. дебилизм
Вообщем форме задать нужные пределы и растянуть ее в нужной величине это оказывается опять очередной раз целая проблема ...
Так пытался .. сяк старался ... ни в какую ...
Ну какие только варианты не пробуешь а делает ну просто БЕЗОБРАЗНО
Короче не буду долго демагогить, а лучше предложу посмотреть это "великолепие"

Вот как безобразно делает.
Опять вынужден возиться с ерундой, тогда как куча дел поважнее.
Нужно группу общей формы "Рубли" РАСТЯНУТЬ и сделать по ширине так как группу: "кВт/ч"
А не в таком приплюснутом безобразном виде как получается.
Как не старался никак не получается.
Увеличиваю ширину группы "Руб", а ее ширина уходит влево (т.е. уменьшая группу:"кВт/ч") , тогда как нужно что бы ширина увеличивалась не влево, а в право.
Жесть ... как все через одно место построено... достало ...
Опять проблема сделать пустячное дело .... ладно пардон!
Вообщем буду признателен если кто подскажет, как сделать.... Первое ... второе и т.д.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135168 · Ответов: 2 · Просмотров: 55
 

>  Табличный документ - окрасить строку в цвет по условию цикла
Gigi
Отправлено: Вчера, 11:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Petre @ Сегодня, 11:45 * ,
Ладно! Уважаемые ... придется отказаться от окрашивания срок.
Тем более это не столь важный вопрос. Хрен с ним...
Но все равно спасибо
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135145 · Ответов: 11 · Просмотров: 85
 

>  Табличный документ - окрасить строку в цвет по условию цикла
Gigi
Отправлено: Вчера, 10:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(Petre @ 21.11.17, 11:29) *
Какой результат я так и не понял (не увидел).
Покажите, что выводит окно сообщений.

Я сменил картинку с сообщениями ... так что там уже со списком сообщений с номерами строк.
Цитата(Petre @ 21.11.17, 11:29) *
Это надо, чтобы исключить проблемы преобразования. Да и так правильнее делать.

А исключить проблемы преобразования это как?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135143 · Ответов: 11 · Просмотров: 85
 

>  Табличный документ - окрасить строку в цвет по условию цикла
Gigi
Отправлено: Вчера, 10:23


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Petre @ Сегодня, 11:10 * ,
Заменил ...
Вариант:
ТекОбласть = ТабДок.Область(номСтр, 1, номСтр, 12);

Делает то же самое, что и вариант:
ТекОбласть=ТабДок.Область("R"+номСтр+"C1:R"+номСтр+"C12");

Один в один..
К сожалению

Gigi @ Сегодня, 11:15 * ,
Делает так ...


 ! 

Правила: 8
 
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135141 · Ответов: 11 · Просмотров: 85
 

>  Табличный документ - окрасить строку в цвет по условию цикла
Gigi
Отправлено: Вчера, 9:44


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(podcast @ 21.11.17, 10:36) *
Так сравните его с перечислением, а не с строкой.

А что в этом проблема? Сомневаюсь...
Дело в том, что в коде для теста есть линия:
Сообщить(знОплачен+" -- "+номСтр);

И не случайно так.
Т.е. Код выполняет условие алгоритма. Следовательно внутри:
Если знОплачен="Нет" Тогда
Сообщить(знОплачен+" -- "+номСтр)
....
КонецЕсли;

Выдает только список со значениями: "Нет". Т.е. в списке сообщений нет ни одного значения "Да".
Просто правильно выполняя условие не те номера строк окрашивает.
Думаю в этом дело.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135138 · Ответов: 11 · Просмотров: 85
 

>  Табличный документ - окрасить строку в цвет по условию цикла
Gigi
Отправлено: Вчера, 9:28


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(Petre @ 21.11.17, 10:21) *
Что говорит отладчик?

Да ничего он не говорит ... просто окрашивает не только нет... безобразничает и издевается... я ему говорю окрашивай только значение: "Нет", а он местами прихватывает и значение: "Да"
Цитата(podcast @ 21.11.17, 10:25) *
Реквизит СчетОплачен булево?

Нет! Это просто ссылка на перечисление:"ДаНет"... со значениями: "Да","Нет".... всего лишь
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135136 · Ответов: 11 · Просмотров: 85
 

>  Табличный документ - окрасить строку в цвет по условию цикла
Gigi
Отправлено: Вчера, 9:12


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Опять вынужден выходить на форум и опять по ерунде.
Вот фрагмент процедуры запроса на создание отчета с использованием макета:
........
знОплачен=Строка(ЗапросОбъект.СчетОплачен);
Если ОтчетныйПериод=знОтчетныйМесяц Тогда
номСтр=номСтр+1;
ОблТаблица.Параметры.Заполнить(Запрос);
    Если знОплачен="Нет" Тогда
    Сообщить(знОплачен+" -- "+номСтр);
    ТекОбласть=ТабДок.Область("R"+номСтр+"C1:R"+номСтр+"C12");
    ТекОбласть.ЦветФона=WebЦвета.Желтый;
    КонецЕсли;
ТабДок.Вывести(ОблТаблица);
КонецЕсли;
..........

Опять процедура никак не может попасть в значение "Нет" переменной "знОплачен" и окрасить строку в желтый цвет.
Т.е. окрасить те строки где реквизит: "СчетОплачен" имеет значение "Нет"
Почему?
Опять, что ли нужно строки загонять в массив или ТЗ , а уже после окрашивать .... и заставлять машину делать двойную работу. Опять что ли это делать необходимо ради какой то ерунды .
А нельзя ли одним циклом решить этот пустяк.
Короче буду опять признателен!
Суть в том, что код окрашивает не только значение "Нет", но местами прихватывает и значение "Да".
Т.е. попасть никак не может .. дурачек ...smile.gifsmile.gif ... Ладно Шутка!
Вообщем буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135133 · Ответов: 11 · Просмотров: 85
 

>  Удалить указанные стоки табличной части
Gigi
Отправлено: 17.11.17, 11:00


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Vofka @ Вчера, 16:09 * ,
Цитата(Vofka @ 16.11.17, 16:09) *
Пример как надо:

Спасибо ... понял ...
Вот оно что ... ясно. А то думал .. че за..
Но относительно других решений думаю менее простых .. первый вариант рабочий
А второй че то выдавал ошибку:
МассивУдаляемых = Новый Массив;
Для Каждого Строка Из Объект.ТабличнаяЧасть1 Цикл
    Если Строка.Реквизит2=Истина Тогда
         ТекСтрокаИдент=Строка.ПолучитьИдентификатор();
         МассивУдаляемых.Добавить(МассивУдаляемых);
   КонецЕсли;
КонецЦикла;
//---------------------------------------------------
Для Каждого Элемент Из МассивУдаляемых Цикл
      Объект.ТабличнаяЧасть1.Удалить(Элемент); // Ошибку выдавало на этой линии.
КонецЦикла;


Поэтому так был сбой...
Но сработало без сбоя только так:
МассивУдаляемых = Новый Массив;
Для Каждого Строка Из Объект.ТабличнаяЧасть1 Цикл
    Если Строка.Реквизит2=Истина Тогда
         ТекСтрокаИдент=Строка.ПолучитьИдентификатор();
         МассивУдаляемых.Добавить(ТекСтрокаИдент);
   КонецЕсли;
КонецЦикла;
//---------------------------------------------------
Для Каждого Элемент Из МассивУдаляемых Цикл
    Строка = Объект.ТабличнаяЧасть1.НайтиПоИдентификатору(Элемент);
    Объект.ТабличнаяЧасть1.Удалить(Строка);
КонецЦикла;

Ладно! Всем спасибо!







  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135025 · Ответов: 7 · Просмотров: 155
 

>  Удалить указанные стоки табличной части
Gigi
Отправлено: 16.11.17, 15:41


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ Сегодня, 15:32 * ,
Спасибо всем уважаемые
Т.е как понимается из примеров нужно обозначенное загонять в массив а уже после удалять
Ладно! Правда как работает нужно еще проверить. Ладно позже проверю и если че продолжу тему.
Пока все..
Спасибо!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135003 · Ответов: 7 · Просмотров: 155
 

>  Удалить указанные стоки табличной части
Gigi
Отправлено: 16.11.17, 15:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Привет всем!
У меня опять вопрос ерундовый. У которого наверно опять решение это .... целая проблема.
Опять как обычно.. сделать ерунду сложно, а не наоборот.
Вопрос в чем... нужно удалить строки табличной части в которых булевый "реквизит2" имеет значение ЛОЖЬ.
Ну никак это не удаеться блин.. эта опять ерунда.
Потому, что наверно команда: Объект.ТабличнаяЧасть1.Удалить(ТекСтрокаИдент); удаляет по номеру строки, а не по идентификатору.
Поэтому в цикл удаляет не все поля имеющие на пример значение реквизита: "Реквизит2": ложь.... кое что оставляет и не удаляет.
Как быть? Блиин! Опять вынужден выходить на форум из ерундового вопроса.
Думал можно в цикле удалять так:
Сторка.Удалить();

Но где такое счастье, что бы можно было такой легкой командой удалить. И не париться с номером строки.. идентификатором и т.д.
&НаКлиенте
Процедура ТЧ_УдалитьУказанныеСтроки()
Для Каждого Сторка из Объект.ТабличнаяЧасть1 цикл
ТекСтрокаНомер=Сторка.НомерСтроки;
ТекСтрокаИдент=Сторка.ПолучитьИдентификатор();
Сообщить(""+ТекСтрокаНомер+" -- "+ТекСтрокаИдент);
//------------------------------------------------
Если  Сторка.Реквизит2=ложь Тогда
//Сторка.Удалить();    // ну такой команды конечно нет ... естественно
Объект.ТабличнаяЧасть1.Удалить(ТекСтрокаИдент); // не все удаляет .. пропускает не удалив
КонецЕсли;
//------------------------------------------------
КонецЦикла;    
КонецПроцедуры

Как быть?
Может в таком случае нужно удалять по идентификатору?
И как это сделать?
Буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #135000 · Ответов: 7 · Просмотров: 155
 

>  Номер строки табличного документа - Табличной части
Gigi
Отправлено: 26.10.17, 16:58


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Vofka @ Сегодня, 16:46 * ,
Это я с вас прикалываюсь уважаемые! smile.gifsmile.gif
Я объяснил всю цель!
Цитата(Vofka @ 26.10.17, 8:17) *
А лучше опишите задачу. А то как обычно.

Это я уже неоднократно слышал smile.gifsmile.gif Вот и психанул и объяснил smile.gifsmile.gif
И ВОТ ВАМ И ВСЯ ЗАДАЧА!
ЧИТАЙТЕ НА ЗДОРОВЬЕ! smile.gifsmile.gif
И это для того,что бы следующий раз не доставали..... Объясни всю цель... нужна полная картина и прочими глупостями. Тоже мне ... анегдот!
Вот вам и вся ЦЕЛЬ и ПОЛНАЯ КАРТИНА! И вот вам и анекдот!
Надеюсь уже теперь после этого и следующий раз я такие неуместные требования больше не услышу.
И речь будет только по заданному прямому вопросу. Без необходимости таких объяснений. Да уж...
Так что,уже с вопросом полной картины подумают ... нужна ли она вообще.
Надеюсь! smile.gifsmile.gif
Ладно! Всем спасибо за помощь!


  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133992 · Ответов: 6 · Просмотров: 283
 

>  Номер строки табличного документа - Табличной части
Gigi
Отправлено: 26.10.17, 14:28


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


ОблИмя = ТабДокумент.ТекущаяОбласть.Имя;
КоличСимв = Найти(ОблИмя,"C")-2;
НомерСтроки = Сред(ОблИмя,2,КоличСимв);
Предупреждение(ОблИмя);
Предупреждение(НомерСтроки);

Работает! Наконец то …
Да .. наверно это надо отпраздновать.
Но в VBA просто пишешь ActiveCell.Row и все. Без парса …
Хотя что касается такого варианта…
Верх=ТабДокумент.ТекущаяОбласть.Верх;
Низ=ТабДокумент.ТекущаяОбласть.Низ;
Лево=ТабДокумент.ТекущаяОбласть.Лево;
Право=ТабДокумент.ТекущаяОбласть.Право;
Сообщ="Верх - "+Верх+Символы.ПС+"Низ - "+Низ+Символы.ПС+"Лево - "+Лево+Символы.ПС+"Право - "+Право;
Предупреждение(Сообщ);

Тут тоже нормально. Выдает номер без использования строковых функций.
Только до конца не догоняю, при чем тут Вниз, Вправо и Влево руля ))))
В VBA просто ActiveCell.Row и все … но в 1С для табличного документа почему то нет такой команды:
ТабДокумент.ТекущаяОбласть.НомерСтроки. Т.е. таким же макаром как в VBA.
Но ладно. Не важно. Главное работает.
Спасибо всем!

П.С. (много букв)
Цитата(Vofka @ 26.10.17, 8:17) *
А лучше опишите задачу. А то как обычно.

Задача?
Это долгий разговор. И вообще тут не любят длинные дискуссии. Был предупрежден модератором за нарушение ...
Но ладно... может изложу ..
Но предупреждаю заранее... много нюансов.. поэтому коротко объяснить не получиться.

Gigi @ Сегодня, 15:07 * ,
Ладно, так и быть излагаю. И ну и что, что сообщение получилось длинное.
За одно еще спрошу, какой вариант лучше для поставленной цели. Вариант первый второй или не важно. И еще спрошу правильный ли путь выбрал для цели вообще.
Так вот, в чем суть цели?
Дело в том, что я пишу прогу загрузки данных из табличного документа на сервер. Которую уже закончил. Т.е. примерно такую же программу, как ту, которую можно скачать готовую … в виде обработки на сайте 1С. Так вот, в подобных обработок загрузки все вроде нормально, только я хочу сделать чуть большее. И доработать.
А именно, научить МАШИНУ ДУМАТЬ!
Да, цель не так уж и простая!
Сделать так, что бы машина умела, анализировать и делать выводы.
И почему так негодую? Потому, что цель не простая, а я должен париться с какой-то выше указанной ерундой.
Допустим обычная обработка по загрузке данных. И допустим, вопрос загрузки не по созданию элементов на сервере, а загрузки по способу перезаписи уже созданных предположим документов.
Для этой цели естественно нужны реквизиты поиска и значения поиска.
Допустим реквизиты поиска: «ОтчетныйМесяц» и «ЮридическоеЛицоОтчета».
Так вот, в обычном случае, данные можно записать по соответствию найденных значений в реквизитах поиска. Но это в том, случае если эти самые значения поиска нигде в списке не дублируются. А что если они местами дублируются? И что если в таком случае нужно на каждый дубль записать разные значения?
А как быть в таком случае?
И тут, на случай дуля значений поиска, как и в отдельных командах поиска, так и в готовых обработках данные можно записать только в первое совпадение, или записать одно и то же во все совпадения без разбору.
А нужно, что бы машина была чуть умнее.
А именно, что бы дублируемые значения совпадения на сервере, она записывала в соответствии порядка таких же совпадений в табличной части.
А для этого машина должна во первых анализировать и зарегистрировать совпадения. И на клиенте (в табличном документе) и на сервере. Т.е. анализировать и делать выводы как поступать.
Так вот, для указанной цели лично у меня такое решение.
Сделать два подхода загрузки данных по поиску.
С использованием в массива или структуры. Конечно, тут есть очень удобна таблица значений…. но блииин.. она не поворотлива и ленива. Ее ведь нельзя гонять с сервера на клиент . И поэтому на хрен она тогда нужна, если нельзя, вот это понять не могу! )))))
Так вот, сделать два цикла загрузки. Первый цикл загружает данные по не дублируемым совпадениям, и при этом параллельно считает и индексирует каждое дублируемое совпадение и собирает все это в массив или структуру. И делает это и на сервере, и на клиенте. Но это первый цикл загрузки. После которого, уже запускается второй цикл, который загружает данные по дублируемым значениям поиска, по соответствующему обозначенному в массиве индексу дубля.
Т.е. на пример если указанное загонять в структуру, то будут две структуры в таком формате:
СтруктураДублируемыхЗначенийПоиска_клиент(ИндексДубля, НомерСтроки_N)  // для табличного документа
СтруктураДублируемыхЗначенийПоиска_сервер(ИндексДубля, КодИлиОбъектДокумента) // Для сервера

И получив эти структуры уже можно загружать данные соответственно по индексу дубля.
Вот собственно и решение. И вот для чего был нужен этот самый номер строки табличного документа.
И ТАКОЙ ФИШКИ НЕТ В ОБРАБОТКЕ ЗАГРУЗКИ СКАЧЕННОЙ С САЙТА 1С.
Но самое смешное, что задача не так уж и сложная, но не сильно легкая. Казалось бы… нужно заставить машину думать и анализировать. И казалось бы … цель нормальная. Но когда для поставленной такой цели на первых, же этапах этот достающий мор головы … с этим несчастным номером строки… блиииин. Вот что, доводит …. Когда не то, что научить машину анализировать, но получить какой то ерундовый номер строки, это еще оказывается нужно еще искать инфу …. и гадать как сделать эту ерунду. Вот что достает.
Ладно! В двух словах объяснить не получилось.
Часто на форуме говорят: изложите не в отдельном моменте, а в целом задачу. Типа для полной картины понимания. Часто это слышу.
Я то не против изложить, всю задачу тут объяснять это …. ну понятно же… длинные речи. Зачем это здесь нужно?
Поэтому, ладно … в данном случае решил поступить, как советуют и изложил всю цель. И вот и задача в целом, а не в отдельном вопросе.
Ладно… если кто подскажет другие решения буду признателен.
Я просто пока не взялся реализовывать решение. Поэтому может, есть другие способы. На пример, какие-то команды, которые сократят написание строк кода и при этом оптимизируют скорость выполнения.
Так что, буду признателен за толковый совет для изложенной цели.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133983 · Ответов: 6 · Просмотров: 283
 

>  Номер строки табличного документа - Табличной части
Gigi
Отправлено: 25.10.17, 22:31


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Привет всем!
Заранее извиняюсь за речи (за которые был предупрежден) вместо кода .. который никак не могу найти.
Просто удивляюсь как иногда опять для простой ерунды нужно искать рыть.. то там, то сям ... без конца края. Аж весь интернет перекапывать.... главное по ерунде
Все перерыл .. синтаксис "помощник" форумы, статьи ...
Табличный документ
Работа с выделенными областями табличного документа
http://devtrainingforum.v8.1c.ru/forum/thr...d=558594#558594
http://www.forum.mista.ru/topic.php?id=353345
И опять все что угодно только не та ерунда, которая нужна.
Если кто знает VBA ... для сравнения инфу про указанную тему можно найти ну просто где угодно. Куда бы Вы не лез ... везде можно найти как узнать номер строки или столбца таблицы. И это просто азы ... команды на пример типа :
MsgBox (ActiveCell.Address)
MsgBox (Range(ActiveCell.Address).Row)
MsgBox (ActiveCell.Row)
MsgBox (ActiveCell.Column)

А в 1С-ке точно так же как в Эксель просто получить номер строки или колонки целая проблема что ли? Да это же мелочь. Которая по идее должна быть без проблем реализуема и инфа везде доступна.
Вот методы тыка.. вынужденные ..
ТекущееПолеЗначение=ТаблДокумент.ТекущаяОбласть.Текст;
Предупреждение(ТекущееПолеЗначение); // Ну это просто текст текущей ячейки
//А как получить текущий номер строки табличного документа?

//ТекущееТекущаяСтрокаНомер=ТаблДокумент.ТекущаяОбласть.... И дальше как? После точки в выпадающем меню команд ничего нет ...
// вернее все есть кроме чего то похожего на получения номера строки или столбца
// Как получить номер строки?
//......ПолучитьИдентификатор(); // Так годится для табличной части, а такой команды нет в выпадающем меню возникающим после точки

Короче никак самому не получается получить НОМЕР СТРОКИ! Не смотря на до предела простой вопрос.
Ладно! Опять извиняюсь ...
короче опять нужна помощь
Буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133941 · Ответов: 6 · Просмотров: 283
 

>  Значение реквизита табличной части по номеру строки
Gigi
Отправлено: 23.10.17, 11:50


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ Сегодня, 11:43 * ,
Спасибо!
Вот теперь понятно!
Да! Экономия времени ... имею ввиду если сам начал бы копать.
Тут просто спросил и узнал!
Спасибо!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133800 · Ответов: 6 · Просмотров: 174
 

>  Значение реквизита табличной части по номеру строки
Gigi
Отправлено: 23.10.17, 11:37


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ Сегодня, 11:30 * ,
Цитата(Bernet @ 23.10.17, 11:30) *
у числа нету рекваизита "ПолеПойска"

тогда получается идентификатор номер возвращает?
Блиин! Номер,Индекс,Идентификатор ..
Вообще все это тогда чем отличаются от друг-друга?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133797 · Ответов: 6 · Просмотров: 174
 

>  Значение реквизита табличной части по номеру строки
Gigi
Отправлено: 23.10.17, 11:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ Сегодня, 11:03 * ,
Пардон! И пардон большой!
С первым вариантом разобрался. Ничего не пойму ... вроде реквизит указал верно.
Ладно! Не важно.
Спасибо за отклик, но осталось разобраться по второму варианту с идентификатором.
Вот тест как в у себя в оригинале:
//"ТЧ_ЗагрузкаДанных" это имя ТЧ
Строка=Объект.ТЧ_ЗагрузкаДанных[1];
СтрокаЗначРекв=Строка.ПолеПойска; // Уже нормально! Выдет значение! А "ПолеПойска" это имя реквизита ТЧ
Сообщить(СтрокаЗначРекв);

Строка=Объект.ТЧ_ЗагрузкаДанных[1];
СтрокаИдентификатор=Строка.ПолучитьИдентификатор();
СтрокаЗначРекв=СтрокаИдентификатор.ПолеПойска; // А тут пишет: "Значение не является значением объектного типа (ПолеПойска)"
Сообщить(СтрокаЗначРекв);

Почему выдает ошибку.
И вообще задача получить значение по номеру строки. А для такой задачи уместна и нужна ли команда: ПолучитьИдентификатор()?
Вот еще, что хотел спросить!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133794 · Ответов: 6 · Просмотров: 174
 

>  Значение реквизита табличной части по номеру строки
Gigi
Отправлено: 23.10.17, 10:45


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
//Вар1
СтрокаТЧ=Объект.ТабличнаяЧасть[1];
Сообщить(СтрокаТЧ[ИмяРеквизита]); // Выдает ошибку
//Вар2
СтрокаТЧидентиф=СтрокаТЧ.ПолучитьИдентификатор();
Сообщить(СтрокаТЧидентиф[ИмяРеквизита]);  // Выдает ошибку



 ! 

Прекращайте писать бессмысленные тексты
 
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133789 · Ответов: 6 · Просмотров: 174
 

>  Задать параметр пойска при загрузке данных из эксель
Gigi
Отправлено: 18.10.17, 10:37


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Привет всем!
По затронутой теме вообще я скачивал обработки для тонкого и толстого клиента ... да ...нормальные обработки... но они в каких то моментах не устраивают.
Во первых, там только можно создавать элементы справочника, рега сведений и ТЧ документа. А авто-создание самих документов почему то не предусмотрено.
Во вторых это внешняя обработка. И при каждой хотя и не сильно частой загрузке из эксель разных данных создания элементов в разных форматах, нужно каждый раз заново ставить настройки загрузки.
Поэтому решил не париться и сам написать конфигурацию загрузки данных из эксель.
И не в виде внешней обработки, а в виде просто справочника: "АвтоЗагрузкаИзЭксель". Что позволяет сохранять настройки загрузки. И для этого дополнительный код не нужно писать как при внешней обработке.
Вроде все нормально работает и данные нормально загружаются. Но один маленький нюанс.
Дело в том, что из табличного документа все данные загрузки естественно с типом строка. Поэтому естественно в настройках нужно указать параметр пойска.
И тут со справочником и перечислением все понятно. Параметр пойска это "Наименование" или "Код".
Вопрос мой в том какой параметр пойска должен быть при ссылке на документ ... хотя не знаю .... ссылка документа на документ .... это может как то ... ну не совсем.
Имею ввиду с точки зрения бухгалтерии или вообще отчетности. Хотя нет ... это думаю бывает нужно.
Так вот, ниже указан код простой функции ... на выходе текст параметра пойска по умолчанию.
Кто ни будь не подскажет как лучше сделать в вопросе пойска по умолчанию ссылки на документ?
Или может сделать вообще по другому ... т.е. без гема на счет наименования или даты а просто все по представлению ... если конечно так возможно.
Вообщем если кто подскажет буду признателен.
Функция ПараметрПойскаТекстаЗначенияСсылкиПоУмолчанию(МетаданныеГруппа) Экспорт
Если МетаданныеГруппа="Справочники" или МетаданныеГруппа="Перечисления" Тогда
Возврат "Наименование";    
ИначеЕсли МетаданныеГруппа="Документы" Тогда
Возврат "Дата";
Иначе
Возврат Ложь;
КонецЕсли;
КонецФункции
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133598 · Ответов: 0 · Просмотров: 127
 

>  Как установить наименование справочка на тип число
Gigi
Отправлено: 16.10.17, 14:16


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(sava1 @ 14.10.17, 12:09) *
Поставьте основное представление в виде кода и код - числовой

При основном представлении в виде кода представляется код. А код числовой может быть только целым числом... и дело в том, что тарифы не целые числа ... 0,60 .. 0,85 и т.д.
Так что код сделал числовой а представление в виде наименования. И так вроде удалось получить наименование из текста не целого числа.
Хотя не понятно такое наименование это число типа число или число типа текст получается. Т.е. это на пример: 0,60 или "0,60".
Нужно что бы было число. Как целое так и не целое.
Цитата(Flexy @ 14.10.17, 12:30) *
А история изменения тарифов нужна? Если да, я бы сделал периодический регистр сведений: Измерение - Тариф (справочник тарифы), Ресурс - ЗначениеТарифа (число).
В документе ЗначениеТарифа вычислять из РС на дату документа. Как-то так...

Да согласен ... так и сделал. Но просто нужно в любом случае иметь цифру с типом число в основном реквизите справочника наименование.
Не знаю так годится или нет т.е. представление в виде наименования, а код числовой, при таком решении наименование становиться типом текст или число?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133523 · Ответов: 4 · Просмотров: 217
 

>  Как установить наименование справочка на тип число
Gigi
Отправлено: 14.10.17, 10:44


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Никто не подскажет как это сделать? То о чем тема?
Дело в том, что есть реквизит "тариф" в документе или справочнике.
Нужна возможность поля выбора для тарифа. Который может в дальнейшем меняться.
Т.е. его нельзя впихнуть в перечисление.
А дело в том, что наименование справочника это строка.
Поэтому как сменить тип наименования справочника на число?

Буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133504 · Ответов: 4 · Просмотров: 217
 

>  Собрать реквизиты в Таб значения и вставить туда нужные данные
Gigi
Отправлено: 12.10.17, 14:52


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Flexy @ Сегодня, 15:31 * ,
Спасибо!
Блиин ... как сам не догнал ... ведь знал, что можно и так...
Короче ... хоть и не люблю выходить на форум... но не получается без него.
Роешь в поисковике ... целыми часами ... натыкаешься в основном на шаблоны по учебнику..
А тут за две минуты получил, что было нужно
Ладно спасибо!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133418 · Ответов: 2 · Просмотров: 168
 

>  Собрать реквизиты в Таб значения и вставить туда нужные данные
Gigi
Отправлено: 12.10.17, 14:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Никто не подскажет почему не работает ниже указанный код.
Цель простая.
Собрать все реквизиты указанного Справочника/Документа и вставить нужные значения в ТЗ. .. для того что бы все это записать на сервер.
заполнив одну строку ... т.е. все реквизиты одной строки ..
Вроде задаче не сильно сложная но блииин ... опять .. барьеры ... опять ... так нельзя ..сьяк нельзя..
Вот набросок:
 &НаСервере
Процедура ТЗ_СобратьРеквизиты(МетаДанныеГруппа,МетаДанныеИмя)
//========================================================
Попытка
    Если МетаДанныеГруппа="Справочники" тогда    
    МетаданныеИсточника=Метаданные.Справочники[МетаДанныеИмя];
    ИначеЕсли МетаДанныеГруппа="Документы" тогда
    МетаданныеИсточника=Метаданные.Документы[МетаДанныеИмя];
    Иначе
    Возврат;
    КонецЕсли;
Исключение
    Сообщить("Не коректные параметры метаданных!");
    Возврат;
КонецПопытки;

ТЗ_Реквизиты = новый ТаблицаЗначений();
Для Каждого Реквизит Из МетаданныеИсточника.Реквизиты Цикл
РеквизитИмя=""+Реквизит;
ТЗ_Реквизиты.Колонки.Добавить(РеквизитИмя);
НоваяСтрока=ТЗ_Реквизиты.Добавить();
КонецЦикла;

Для Каждого Колонка Из ТЗ_Реквизиты.Колонки Цикл
КолонкаИмя=Колонка.Имя;
Сообщить(КолонкаИмя);
НоваяСтрока=ТЗ_Реквизиты.Добавить();
НоваяСтрока.КолонкаИмя="ЗначениеЗаписи"; // ВЫДАЕТ ПОЛЕ НЕ НАЙДЕНО -- С...А    
КонецЦикла;
КонецПроцедуры


Пожалуйста подскажите ... почему на линии
НоваяСтрока.КолонкаИмя="ЗначениеЗаписи"

выдает ошибку.
Или опять так нельзя .. сьяк нельзя ... едак вообще .. и т.д.
Т.е. почему нельяз запеременить ..
Неужели можно только в таком неудобном стиле как в учебнике:
ТЗ_Реквизиты = новый ТаблицаЗначений();
ТЗ_Реквизиты.Колонки.Добавить("РеквизитыИмена");
ТЗ_Реквизиты.Колонки.Добавить("Значения");
Для Каждого РеквизитИмя Из МетаданныеИсточника.Реквизиты Цикл
НоваяСтрока=ТЗ_Реквизиты.Добавить();
НоваяСтрока.РеквизитыИмена=РеквизитИмя;    
КонецЦикла;
// и т.д.

Пожалуйста ... помогите ... smile.gifsmile.gif
И жду ответа smile.gifsmile.gif
Буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #133416 · Ответов: 2 · Просмотров: 168
 

>  Сохранить массив настроек
Gigi
Отправлено: 20.09.17, 13:58


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


logist @ Сегодня, 13:49 * ,
Цитата(logist @ 20.09.17, 13:49) *
ак обычно, перечитал несколько раз и толком не понял что надо сделать, но в общих чертах слишком заморочно.

Да что тут не понятного!
Получение данных табличной части из справочника в ТЧ документа. И получение из того столбца ТЧ справочника, который указан в поле выбора с сылкой на перечисления в форме документа. Где в ТЧ нужно получить всего лишь флажки распечатки заранее определенных строк.
Вот и вся суть решения.
И как мне кажется ничего заморочного.
Я понимаю, что может для цели так не делается, и что есть спец возможности, но если я начал бы разбираться - читать теорию .. гууу... это заняло бы время. И не малое.
А так по быстрому!
Ладно! Я думаю пойдет, так для начала
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #132404 · Ответов: 7 · Просмотров: 280
 

>  Сохранить массив настроек
Gigi
Отправлено: 20.09.17, 13:17


Завсегдатай
****

Группа: Пользователи
Сообщений: 155
Регистрация: 13.04.17
Пользователь №: 55529


logist @ Сегодня, 13:01 * ,
.
Цитата(logist @ 20.09.17, 13:01) *
Давно не хожу в кино на ужасы, ваших рассказов

Ну попросите что бы удалили .. smile.gifsmile.gif если не нравится...
Это не рассказики, а решение ... быстрое... и хотел узнать так пойдет или нет.
А что касается изложения ... да уж ... тоже мне... буду я щас прям... как при официальном выступлении за трибуной smile.gifsmile.gif
Ладно! Считайте что я не слышал и не читал такие комментарии!
пока!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #132399 · Ответов: 7 · Просмотров: 280
 

7 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.11.17, 3:54
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне