Версия для печати темы (http://pro1c.org.ua/index.php?s=97a134bae713d3f21ae9df839fc35b2e&showtopic=37991)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование обычных форм 1С 8.2 и не интерфейсной логики _ чтение ТХТ файла

Автор: cao0603 18.06.17, 18:16

помогите пожалуйста, необходима или готова обработка или код,
форма,на форме кнопка при нажатии на которую мы выбираем файл ТХТ или не важно какой формат, но внутри это текстовый файл просто с другим расширение
и после выбора файла идет чтение построчное файла, потом парсинг в любом формате,и сохранение в другое место

Автор: nik389 18.06.17, 21:46

cao0603 @ Сегодня, 19:16 * ,
готовый код.. лень было писать - загуглил специально для вас:

выбор файла:

// Создать новый диалог для открытия файлов.
ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
// Какие типы файлов будут предложены для выбора.
ДиалогФыбораФайла.Фильтр = "Картинка (*.bmp)|*.bmp|Картинка формата jpg (*.jpg)|*.jpg";
ДиалогФыбораФайла.Заголовок = "Выберите файл";                                        
// В диалоге будет открыт предварительный просмотр файлов
ДиалогФыбораФайла.ПредварительныйПросмотр = Истина;
// При открытии диалога сначала для выбора будут предложены файлы
// первого типа, из типов, перечисленных в свойстве "Фильтр".
ДиалогФыбораФайла.ИндексФильтра = 0;
// Открыть диалог выбора файла.
Если ДиалогФыбораФайла.Выбрать() Тогда
   // Действия, выполняемые тогда, когда файл выбран.
КонецЕсли;


чтение файла
Процедура ЗагрузкаЛи()
    ТФ=Новый ТекстовыйДокумент;
    ТФ.Прочитать("c:\сотрудникиСчет93.txt");
    КолСтрок=ТФ.КоличествоСтрок();
    Для л=1 По КолСтрок Цикл
        Сообщить(" "+ТФ.ПолучитьСтроку(л));
    КонецЦикла;
КонецПроцедуры


сохранение думаю найдете сами.. гугл рулит

Автор: cao0603 19.06.17, 6:47

А как потом из выбранного файла получить путь как на втором куске кода?

nik389 @ Вчера, 22:46 * ,
А как потом из выбранного файла получить путь как на втором куске кода?

Автор: nik389 19.06.17, 8:35

cao0603 @ Сегодня, 7:47 * ,
ДиалогВыбораФайла.ПолноеИмя кажись.. точку поставите - конфигуратор подскажет метод..

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
http://pro1c.org.ua