Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Vidocq05 ::: Спасибо сказали: 28 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
07.12.18, 16:13 Почему из модуля объекта нельзя вызвать команду записи элемента метаданных текущего объекта
Цитата(Gigi @ 07.12.18, 16:03) *
Короче ничего не пойму....

Что не понятного. Вы нажимаете "Записать", срабатывает Ваш код в "ПередЗаписью". В нем просходит попытка записи объекта справочника, при этом опять срабатывает Ваш код в "ПередЗаписью" в котором опять происходит попытка записи объекта справочника и так до бесконечности.
Gigi,
07.12.18, 15:54 Почему из модуля объекта нельзя вызвать команду записи элемента метаданных текущего объекта
Цитата(Gigi @ 07.12.18, 15:51) *
В том и все дело что это "ПередЗаписью".

В данном случае это одно и тоже - уходит в вечный цикл.
awp,
04.12.18, 14:01 Выборка запросом по ТаблицеЗначений
Цитата(bizisoft @ 04.12.18, 12:57) *
Добавил
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;

Это лишнее, и можно убрать.
bizisoft,
26.09.18, 15:56 "Ошибка при выполнении файловой операции" при обновлении конфигурации
levi @ Сегодня, 15:37 * ,
Спасибо.
Оказывается это довольно не редкий случай.

Пробовал, но не помогло:
1. Снял с поддержки через меню конфигурация, настройка поддержки;
2. Далее через сравнение и объединение объединил с подготовленной типовой cf-кой того же релиза. В этот момент он спрашивает о возможности поставить на поддержку, согласился.
3. Снял все галки при сравнении/объединении.
4. Принял измененя.

Помогло:
В настройке поддержки установил для всей конфигурации "Редактируется с сохранением поддержки" с установленной галочкой "Установить для подчиненных объектов".
Естественно для всех объектов конфигурации установился режим "Редактируется с сохранением поддержки", что не очень хорошо, т.к. были объекты с режимом "Объект поставщика не редактируется".
Ну судя по всему, из-за этого режима и была проблема. Наверное к одному из объектов был применен данный режим хотя сам объект был изменен.
nmf,
03.08.18, 15:06 При открытии не вносить изменения в поле выбора
Constantus @ Сегодня, 15:44 * ,
Поцепите этот код на "НачалоВыбораИзСписка".
ed.kharkov,
13.06.18, 10:27 Табличные части из Эксель документа
Цитата(Lexveritas @ 12.06.18, 17:03) *
НО!
Есть "ХАрактеристикаНоменклатуры" справочник подчиненный владельцу...
Как Здесь быть?


НоваяСтрока.ХарактеристикаНоменклатуры = Справочники.ХарактеристикаНоменклатуры.НайтиПоНаименованию(СокрЛП(Excel.Cells(Сч, "КолонкаХарактеристики").Text),,,НоваяСтрока.Номенклатура);

Lexveritas,
04.06.18, 10:05 Не регулярные конфликты блокирования
vbi @ Сегодня, 10:28 * ,
Воспользуйтесь конфигурацией "Центр управления производительностью"
vbi,
30.05.18, 10:14 Как обновить налоговую накладную?
new_1c @ Вчера, 17:58 * ,
Буду отвечать по УТП, в БП скорее всего также.
Если у вас обе конфигурации одного релиза, то скорее всего там где новая налоговая это внешний регламентированный отчет. Если это так, то в базе где новее налоговая в режиме предприятия заходите в справочник "Регламентированные отчеты", находите элемент "Налоговая накладная" и сохраняете в файл. Во второй базе загружаете.
new_1c,
10.05.18, 10:51 Обработка для выгрузки документов с УТ в самописную базу
burza @ Сегодня, 11:38 * ,
Тогда так:
Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

                    Если НЕ Док.Пустая Тогда

                           Если Док.СуммаДокумента = Выборка.СуммаДокумента Тогда
                                  Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                                  Продолжить;
                           КонецЕсли;

                           НачатьТранзакцию();
                           Док = Док.ПолучитьОбъект;
                           Док.СуммаДокумента = Выборка.СуммаДокумента;
                           Док.Записать();
                           ЗафиксироватьТранзакцию();
                    
                    КонецЕсли;
burza,
10.05.18, 10:30 Обработка для выгрузки документов с УТ в самописную базу
Допустил ошибку. Вот так правильно

Если НЕ Док.Пустая() Тогда


Цитата(Petre @ 10.05.18, 11:26) *
Судя по ошибке, возвращается что-то другое...

Возвращает пустую ссылку.
burza,
10.05.18, 10:25 Обработка для выгрузки документов с УТ в самописную базу
burza @ Сегодня, 11:09 * ,
Конечно не работает. Вы вдумайтесь в смысл выполнения кода.
&НаСервере
Процедура ПровестиИмпортВходящихПлатежей()
    
    ВыборкаБазДляИмпорта = РегистрыСведений.СоединенияСБазамиДанныхУТ.Выбрать();
    
    Пока ВыборкаБазДляИмпорта.Следующий() Цикл
        Если (ВыборкаБазДляИмпорта.ЗагружатьПриходБезналичный) Тогда
            Сообщить(ВыборкаБазДляИмпорта.СтрокаСоединения);
            
            СоединениеБух = СоединитьсяСБазой(ВыборкаБазДляИмпорта.СтрокаСоединения);
            Если СоединениеБух = неопределено тогда
                Сообщить("Произошла ошибка при соединении с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Внимание);
            Продолжить;
            иначе
                Сообщить("Успешно соединились с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Информация);
            конецЕсли;

            // Создаём запрос для выборки всех исходящих платежей за период
            запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
            |    ЗаказКлиента.Номер КАК Номер,
            |    ЗаказКлиента.Дата,
            |    ЗаказКлиента.СуммаОплаты КАК СуммаОплаты,
            |    ЗаказКлиента.СуммаДокумента КАК СуммаДокумента,
            |    ЗаказКлиента.ЧислоПутевок КАК ЧислоПутевок,
            |    ЗаказКлиента.Санаторий.Наименование КАК Санаторий,
            |    ЗаказКлиента.Партнер.Наименование КАК Партнер,
            |    ЗаказКлиента.РуководительГруппы.Наименование КАК РуководительГруппы,
            |    ЗаказКлиента.Контрагент.Наименование КАК  Контрагент
            |ИЗ
            |    Документ.ЗаказКлиента КАК ЗаказКлиента
            |ГДЕ
            |    ЗаказКлиента.Дата МЕЖДУ &НачалоПериода И &КонецПериода
            |    И ЗаказКлиента.Проведен = ИСТИНА
            |    И ЗаказКлиента.ПометкаУдаления = ЛОЖЬ
            |   И НЕ ЗаказКлиента.СуммаДокумента = &СуммаДокумента";
            
            запр.УстановитьПараметр("НачалоПериода", Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода", Объект.КонецПериода);
            запр.УстановитьПараметр("СуммаДокумента", 0);
        

            Выборка = запр.Выполнить().Выбрать();
            
                        
            Пока Выборка.Следующий() Цикл
                Сообщить("Загрузка документа №" + Выборка.Номер);

                // Это уже не нужно и функцию можете удалить
                //Если ПроверитьСуществованиеДокумента(Выборка.Номер, Выборка.СуммаДокумента, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                        //Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                        
                
                   // Иначе    
        
                    Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

                    Если НЕ Док.Пустая Тогда

                           Если Док.СуммаДокумента = Выборка.СуммаДокумента Тогда
                                  Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                                  Продолжить;
                           КонецЕсли;

                           НачатьТранзакцию();
                           Док = Док.ПолучитьОбъект();

                    Иначе
                          
                           НачатьТранзакцию();
                           Док = Документы.СписокЗаявокУТ.СоздатьДокумент();

                    КонецЕсли;
                    
                    Док.Контрагент = Выборка.Контрагент;
                    Док.ЧислоПутевок = Выборка.ЧислоПутевок;
                    Док.СуммаДокумента = Выборка.СуммаДокумента;
                    Док.НомерЗаявки = Выборка.Номер;
                    Док.Санаторий =  ПодобратьСанаторий(Выборка.Санаторий);
                    Док.РуководительГруппы = Выборка.РуководительГруппы;
                    Док.Партнер   = Выборка.Партнер;
                    Док.Дата  = Выборка.Дата;
                    Док.Оплачено  = Выборка.СуммаОплаты;
                    Док.Записать();
                    ЗафиксироватьТранзакцию();

                //КонецЕсли;

            КонецЦикла;
            

        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры
burza,
30.01.18, 10:03 Выбирается не та организация при создании заказа((
Bulzavr @ Сегодня, 10:20 * ,

Если я правильно понял вопрос то возможно так

Если Объект.Ссылка.Пустая() Тогда
        Объект.Соглашение = Константы.Соглашение.Получить();
        Объект.Организация= Объект.Соглашение.Организация;
КонецЕсли;
Bulzavr,
10.11.17, 15:38 Автозаполнение табличного документа
burza @ Сегодня, 14:00 * ,
Давно не работал с управляемым приложением.
Попробуйте так:
&НаКлиенте
Процедура ПланПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока И Не Копирование тогда
        Элемент.ТекущиеДанные.Дата = ТекущаяДата();
        Элемент.ТекущиеДанные.СтатусВыполнения = ПолучитьСтатусСервер();
    КонецЕсли;

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьСтатусСервер()
    Возврат Справочники.СтатусВыполнения.НайтиПоНаименованию("В работе");
КонецФункции

burza,
26.10.17, 8:31 Номер строки табличного документа - Табличной части
Gigi @ Вчера, 23:31 * ,

ОблИмя = ТаблДокумент.ТекущаяОбласть.Имя;
НомерСтроки = Сред(ОблИмя,2,1);


Пардон. То было только до 10 строк.
ОблИмя = ТаблДокумент.ТекущаяОбласть.Имя;
КоличСимв = Найти(ОблИмя,"C")-2;
НомерСтроки = Сред(ОблИмя,2,КоличСимв);
Gigi,
25.10.17, 13:53 Тонкости запроса
rodrigezrobert @ Сегодня, 14:03 * ,
ВЫБРАТЬ
    SimКартыТарифныеПланы.Ссылка,
    МАКСИМУМ(SimКартыТарифныеПланы.ДатаНачалаДействияТП) КАК ДатаНачалаДействияТП,
    //SimКартыТарифныеПланы.ТарифныйПлан
ПОМЕСТИТЬ АктуальныеТарифныеПланы
ИЗ
    Справочник.SimКарты.ТарифныеПланы КАК SimКартыТарифныеПланы

СГРУППИРОВАТЬ ПО
    SimКартыТарифныеПланы.Ссылка,
   // SimКартыТарифныеПланы.ТарифныйПлан

Потом создаете еще одну временную таблицу. Берете АктуальныеТарифныеПланы и соединяете левым соединением с Справочник.SimКарты.ТарифныеПланы по Ссылка и ДатаНачалаДействияТП. Выбираете с Справочник.SimКарты.ТарифныеПланы: Ссылка, ДатаНачалаДействияТП, ТарифныйПлан. А дальше так как у Вас в запросе.
rodrigezrobert,
08.09.17, 14:06 Создание Групповой обработки документов по отдельным реквизитам
Цитата(Murano @ 08.09.17, 14:03) *
Реквизит «Дата сдан в бухгалтерию» заполняется автоматически текущей датой и временем в момент смены реквизита «Сдано в бухгалтерию» по признаку «Истина».

Я так понимаю это уже реализовано.

А по всему остальному - можно делать обработкой "Групповая обработка справочников и документов". Прочитайте справку обработки и думаю все поймете.
Murano,
31.08.17, 11:29 Список значений в строку
salton @ Сегодня, 11:55 * ,
Нужно именно со списка значений?
Если с массива то вот:

СтрСоединить (StrConcat)
Синтаксис:

СтрСоединить(<Строки>, <Разделитель>)
Параметры:

<Строки> (обязательный)

Тип: ФиксированныйМассив; Массив.
Массив, содержащий объединяемые строки.
<Разделитель> (необязательный)

Тип: Строка.
Строка, которая будет вставлена между объединяемыми строками.
Если параметр не задан, строки будут объединены слитно друг с другом.
Значение по умолчанию: Неопределено.
Возвращаемое значение:

Тип: Строка.
Строка, содержащая соединенные исходные строки с разделителем между ними.
Описание:

Соединяет массив переданных строк в одну строку с указанным разделителем.


salton @ Сегодня, 11:55 * ,
Или так

МассивЭлементов = ВашСписокЗначений.ВыгрузитьЗначения();

СоединеннаяСтрока = СтрСоединить(МассивЭлементов,",");
salton,
19.06.17, 9:29 При выгрузке выкидывает с 1С
Выкидывало потому что в ПКО стояла галочка "Не запоминать выгруженные объекты". Происходило зацикливание и первый же контрагент выгружался по кругу
Acid, Flexy,
09.06.17, 10:28 Поиск в таблице значений
cao0603 @ Сегодня, 10:30 * ,

Если таблица это ТаблицаЗначений то както так...

Для Каждого СтрТЗ Из ВашаТЗ Цикл 
        
        НайденоСовпадение = Ложь;
        
        Для Каждого СтрМас Из ВашМассив Цикл
            
            Результат = Найти(СтрТЗ.ВашаКолонка,СтрМас);
            
            Если Результат = 0 Тогда
                НайденоСовпадение = Ложь;
                Прервать;
            Иначе
                НайденоСовпадение = Истина;
            КонецЕсли;
            
        КонецЦикла;
        
        Если НайденоСовпадение Тогда
            
            // Делаете со строкой что нужно
            
        КонецЕсли;
    КонецЦикла;

cao0603,
08.06.17, 12:35 Отменить создание документа в 1С 8
Gigi @ Сегодня, 13:23 * ,
Вроде как ...

Отказ = Истина;
Gigi,
07.06.17, 13:32 Программное определение проведения документа в 1с 8
Цитата(Vidocq05 @ 07.06.17, 14:13) *
Похоже Вы не знаете что такое "Точка останова" и "Вычислить выражение". Советую ознакомится и жить станет легче.

Пардон. Не заметил, что процедура на сервере


Я забыл как работают управляемые формы! Позор мне
Gigi,
25.05.17, 16:04 Отбор в запросе по группе и/или в группе из списка
Constantus @ Сегодня, 16:56 * ,
ТипЗначения поля ввода Контрагенты должен быть СписокЗначений, ТипЗначенияСписка - СправочникСсылка.Контрагенты
Constantus,
25.05.17, 14:25 Отчет обработка иерархического справочника с уровнями и спойлерами (+)
Constantus @ Сегодня, 14:38 * ,
Цитата(Constantus @ 25.05.17, 14:38) *
"Заполнить" выполняет заполнение, если наименование полей в запросе совпадает с параметрами в Макете?

Да

Цитата(Constantus @ 25.05.17, 14:38) *
И наименования идут не по порядку по возрастанию...

сделайте упорядочить по наименованию
Цитата(Constantus @ 25.05.17, 14:38) *
Отчет получился, но почему-то дублируется в детализации наименование группы:

Прошу прощения ))

Запрос.Текст = 
        "ВЫБРАТЬ
        |    Контрагенты.Ссылка КАК Ссылка,
        |    Контрагенты.Представление
        |ИЗ
        |    Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |    Контрагенты.ЭтоГруппа = ЛОЖЬ
        |ИТОГИ ПО
        |    Ссылка ИЕРАРХИЯ";
Constantus,
24.05.17, 10:48 Программно выбрать ссылку для строки табличной части справочника
Цитата(Gigi @ 23.05.17, 13:13) *
Я не хотел все так подробно объяснять.

Нужно было сразу так подробно объяснить и быстро получили бы ответ. А так как Вы объясняли выше ничего не понятно
Gigi,
23.05.17, 8:56 Программно выбрать ссылку для строки табличной части справочника
Я тоже мало что понял.

Цитата(Gigi @ 23.05.17, 1:30) *
И допустим делаю так:

ЗначениеКотороеСодержитСсылку= "значние1";
Элементы.Таб_Точка.ТекущиеДанные.Реквизит2 = ЗначениеКотороеСодержитСсылку;



ТАК НЕ РАБОТАЕТ! Блиин!

И не будет работать. Вы пытаетесь присвоить реквизиту с типом ссылка значение с типом строка.

Что я понял:
Есть табличная часть "Таб_Точка"
В ней есть два реквизита - "Реквизит1" с типом строка и "Реквизит2" с типом ссылка (и если я правильно понял то ссылка на справочник).

Вопросы????
1. Какие действия делает пользователь? (Например, вбивает текст в "Реквизит1" или нажимает сочетание клавиш или что то другое. Что?)
2. Что должно произойти после этих действий? (Например, присваивается значение ссылки реквизиту "Реквизит2", создается элемент справочника и присваивается его ссылка реквизиту "Реквизит2". Что?)
Gigi,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 19.12.18, 16:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне