Версия для печати темы (http://pro1c.org.ua/index.php?s=e23fa8fa3f9404ed2b8338077ad39a34&showtopic=46153)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Таблична частина документу

Автор: l2d808 09.06.18, 10:29

Доброго дня, щановна спільнота 1с.
Використовую самописну конфігурацію
1с8.3.12.1440

Виникло питання по додаванню фотографій в табличну частину документа.

Спробував адаптувати алгоритм
http://pro1c.org.ua/redirect.php?http://1c-uroki.ru/articles/pokaz_kartinok_v_spravochnike_1C_8.2
виходить, що завгодно, але не те, що потрібно...

Задача:
Створити документ. В табличній частині документу розмістити картинки та коментар до них.

Буду вдячний за допомогу.

Автор: l2d808 09.06.18, 11:55

&НаСервере
Процедура УстановитьКартинку(Фото)
        ////создаем новый элемент в Справочнике Файлы
        НовыйФайлКартинки = Справочники.Файли.СоздатьЭлемент();
        ////в реквизит СправочникаФайлы Файл помещаем выбранную ранее Картинку
        НовыйФайлКартинки.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Фото));
        Фото = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Файл.Получить());
        ////записываем новый элемент справочника Файлы
        НовыйФайлКартинки.Записать();
        ////устанавливаем значение реквизита Картинка Справочника Сотрудники
        //сообщить(НовыйФайлКартинки.Ссылка);
        Объект.Картинка = НовыйФайлКартинки.Ссылка;
КонецПроцедуры

Помилка в рядку:
Объект.Картинка = НовыйФайлКартинки.Ссылка;

Неправильно присвоюю. Як це зробити корректно?

Автор: sava1 09.06.18, 13:31

А как эта процедура соотносится с темой?
Если Вас интересует хранение картинок - посмотрите в любой стандартной конфигурации на спр.Номенклатура и Файлы.

Для дин. списка - укажите путь к данным и картинкаСтрок

Автор: l2d808 09.06.18, 14:31

Цитата(sava1 @ 09.06.18, 14:31) *
Для дин. списка - укажите путь к данным и картинкаСтрок

А можно по подробнее...
Я только учусь сисать на 8 версии.

Є такий скрін:

В полі №1 необхідно бачити фотографію, яку ми загружаємо з диску.

Автор: Prospero 09.06.18, 23:38

l2d808 @ Вчера, 15:31 * ,
Картинки не слишком маленькие будут?


Автор: l2d808 10.06.18, 13:14

Prospero @ Сегодня, 0:38 * ,
В принцыпе нет, если их потом можно розвернуть в большие.

Автор: Prospero 10.06.18, 15:58

Цитата(l2d808 @ 10.06.18, 14:14) *
если их потом можно розвернуть в большие.

Как вариант - в отдельной форме по клику по ячейке в колонке Картинка:



 ! 

http://pro1c.org.ua/index.php?act=announce&id=2: 8
 

Автор: l2d808 11.06.18, 8:54

Prospero @ Вчера, 16:58 * ,
Доброгодня.
Ви корректно зрозуміли мою ззадачу. А ось як її реалізувати?
Буду надзвичайно вдячний Вам за допомогу.

Автор: l2d808 11.06.18, 16:40

У спільноти ще є пропозиції?

Автор: Prospero 11.06.18, 20:11

l2d808 @ Сегодня, 17:40 * ,
Картинки из справочника будут браться, предварительно загруженные, или загружаться из формы документа по кнопке в табличную часть с диска?

Автор: Prospero 12.06.18, 7:05

l2d808 @ Вчера, 17:40 * ,
Обобщенно:
Добавили строку.
При добавлении:

&НаКлиенте
Процедура ТоварыНаименованиеПриИзменении(Элемент)
    Ссылка = ПолучитьКартинку(Элементы.Товары.ТекущиеДанные.Наименование);    
    Элементы.Товары.ТекущиеДанные.Картинка = ПолучитьНавигационнуюСсылку(Ссылка, "Файл");
КонецПроцедуры

Получение картинки из справочника:
&НаСервере
Функция ПолучитьКартинку(Товар)
    Результат = Справочники.Товары.НайтиПоНаименованию(Товар);
    Возврат Результат.Картинка;
КонецФункции

У Табличной части реквизит Картинка (Поле картинки)
В Вашем первом посте ссылка на пример, там работа со справочником, тут - с документом.
Будут вопросы - пишите (сюда ИЛИ личка ИЛИ Почта - в почту захожу чаще).

Автор: l2d808 12.06.18, 11:44

Я окончательно, и надеюсь, не бесповоротно запутался...
Расскажу о задаче с самого начала...

Есть документ: с реквизитом товар и реквизитами в табличной части комментарий и фото.
Этих фото, может быть любое количество.
Привязка этих фото должна идти к созданному документу(этому самому) так как через день будет создан еще один документ
уже с новыми фото(актуальными). Но через какое-то время, будет необходимо просмотреть все старые документы.
По-скольку, я только начинаю учить 1с83 мне многое не понятно.(до этого писал на 1с77)
Пожалуйста, помогите нубу. Желательно сначала.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
http://pro1c.org.ua