Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику ed.kharkov ::: Спасибо сказали: 3 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
03.07.18, 14:38 как передать переменную с клиента на сервер
Petre @ Сегодня, 15:25 * ,
ТекущиеДанные недоступны на сервере.

На сервере можно получить так:

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    СтрокаТЧ = Объект.СписокЗЧ[Элементы.СписокЗЧ.ТекущаяСтрока];
    
    // . . .

КонецПроцедуры
lolmatrix,
26.06.18, 10:33 При вводе на основании перезаполнить реквизит введенного документа
l2d808 @ Сегодня, 11:12 * ,
Добрый день.

Так может достаточно будет написать вот так

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, ТекстЗаполнения, СтандартнаяОбработка)
        Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ВведенняВиведенняТранспортногоЗасобуНаПідприємство") Тогда
              Документ = ДанныеЗаполнения;    
              ТранспортнийЗасіб = ДанныеЗаполнения.ТранспортнийЗасіб;
        КонецЕсли;
КонецПроцедуры


В процедура ПослеЗаписи() вобще не нужна в данном случае.
l2d808, Vofka,

RSS Текстовая версия Сейчас: 18.07.18, 7:01
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне