Версия для печати темы (http://pro1c.org.ua/index.php?s=c83efb8ace2bb1264a4fd98e1e52ba32&showtopic=48188)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Вывод на макет картинки

Автор: And1001 05.10.18, 9:40

Здравствуйте уважаемые программисты. Просьба помочь с выводом на макет картинки. Пример кода :

&НаСервере
Функция СформироватьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    НоменклатураПрисоединенныеФайлы.ВладелецФайла.Ссылка КАК ВладелецФайлаСсылка,
    |    Номенклатура.ФайлКартинки КАК ФайлКартинки,
    |    Номенклатура.Ссылка КАК Ссылка
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура
    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.НоменклатураПрисоединенныеФайлы КАК НоменклатураПрисоединенныеФайлы
    |        ПО Номенклатура.ФайлКартинки = НоменклатураПрисоединенныеФайлы.Ссылка";    
    ТабИтог = Запрос.Выполнить().Выбрать();
    ТабДок = Новый ТабличныйДокумент;
    Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет");  
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Шапка);
    Рез=Макет.ПолучитьОбласть("Результат");
    Пока ТабИтог.Следующий() Цикл
        Рез.Параметры.НаимНоменклатуры = ТабИтог.ВладелецФайлаСсылка.Наименование;
        ДанныеКартинки = УправлениеНебольшойФирмойСервер.ПолучитьДвоичныеДанныеФайла(ТабИтог.ФайлКартинки);
        Если ЗначениеЗаполнено(ДанныеКартинки) Тогда
            Рез.Параметры.Картинка = Новый Картинка(ДанныеКартинки);
        КонецЕсли;            
        ТабДок.Вывести(Рез);
    КонецЦикла;
    возврат  ТабДок;
КонецФункции

В итоге выводится слово "картинка". Другие методы, описанные в интернете мне не помогли.

Автор: sanek6662009@gmail.com 05.10.18, 20:29

And1001 @ Сегодня, 10:40 * ,
http://pro1c.org.ua/redirect.php?https://www.vdgb.ru/kompaniya/tehpodderzhka-1s/faq/vyvod-kartinki-izobrazheniya-na-pechat-v-maket-tablichnyj-dokument/

Автор: And1001 08.10.18, 12:55

Разобрался. В параметр нельзя передавать изображение. Изображение передается в объект рисунок ( на макете Таблица => Рисунки => Картинка). Затем передавать в этот объект полученные из двоичных данных нашу картинку.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
http://pro1c.org.ua