Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

11 страниц V   1 2 3 > » 

>  Внешние источники данных, запись из 1С в базу MySQL
хакерок
Отправлено: 04.01.19, 10:55


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Bernet @ Сегодня, 1:06 * ,
Если будете заполнять базу данных на разный языках перед заполнением текстовых данных понадобиться id языка.

Делел когда то выгрузку в следующем порядке.

    Connection = Новый COMОбъект("ADODB.Connection");
    Базовый_MySQL.ПодключитьсяКБазе(Connection);
    
        Работа_С_Opencart.ОчиститьПрайсЛистИнтернетМагазина(Connection);
        Работа_С_Opencart.ВыгрузитьГруппыАтрибутов(Connection);
        Работа_С_Opencart.ВыгрузитьХарактеристикиНоменклатуры(Connection);
        Работа_С_Opencart.ВыгрузитьПроизводителей(Connection);
        Работа_С_Opencart.ВыгрузитьГруппы(Connection);
        Работа_С_Opencart.ВыгрузитьГруппыФильтров(Connection);
        Работа_С_Opencart.ВыгрузитьФильтрыГрупп(Connection);
        Работа_С_Opencart.ВыгрузитьЭлементыВсехГрупп(Connection);

   Connection.Close();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148694 · Ответов: 18 · Просмотров: 1330
 

>  Внешние источники данных, запись из 1С в базу MySQL
хакерок
Отправлено: 03.01.19, 22:16


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Bernet @ Сегодня, 15:39 * ,
Попробуйте ТекущуюДату() перед внесением обработать функцией

Функция СтрокаДата(Дата) Экспорт
    Возврат Строка(Формат(Дата,"ДФ=yyyy-MM-dd"));
КонецФункции


или вообще не заполнять
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148671 · Ответов: 18 · Просмотров: 1330
 

>  Внешние источники данных, запись из 1С в базу MySQL
хакерок
Отправлено: 03.01.19, 16:02


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Bernet @ Сегодня, 15:39 * ,
Тоже пробовал записывать данные с использованием класса ВнешниеИсточникиДанных похоже метод Записать() создаёт SQL запрос совместимый с MS SQL и MS Access.
Будет время могу поделится основными частями записи в MySQL бесплатно.Bernet @ Сегодня, 15:39 * ,
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148666 · Ответов: 18 · Просмотров: 1330
 

>  Внешние источники данных, запись из 1С в базу MySQL
хакерок
Отправлено: 03.01.19, 14:10


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Bernet @ Вчера, 11:14 * ,
Можно начать с модуля который будет работать с MySQL.

Я уже решал такую задачу.
Можно почитать здесь что получилось

Небольшой пример
&НаСервере
Процедура ПодключитьсяКБазе(Connection) Экспорт
    
    СтрокаПодключения  =  "Driver={"+Справочники.НастройкиБазыДанныхВИнтернете.ИспользуемыеНастройки.ИмяДрайвера+"};Server="+Справочники.НастройкиБазыДанныхВИнтернете.ИспользуемыеНастройки.Server+";Port=3306;Database="+Справочники.НастройкиБазыДанныхВИнтернете.ИспользуемыеНастройки.Database+";User="+Справочники.НастройкиБазыДанныхВИнтернете.ИспользуемыеНастройки.User+";Password="+Справочники.НастройкиБазыДанныхВИнтернете.ИспользуемыеНастройки.Password+";";
    Попытка
        Connection.Open(СтрокаПодключения);
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;

КонецПроцедуры // ПодключитьсяКБазе()
&НаСервере
Процедура ОчиститьТаблицу(Connection,НаименованиеТаблицы) Экспорт  

    
    
    Command = Новый COMОбъект("ADODB.Command");
    Command.ActiveConnection = Connection;
    
    Command.CommandText = "TRUNCATE TABLE `"+НаименованиеТаблицы+"`";
    RecordSet = Новый COMОбъект("ADODB.RecordSet");

    Попытка
          RecordSet = Command.Execute();
    Исключение
       Сообщить(ОписаниеОшибки());    
    КонецПопытки;

    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148660 · Ответов: 18 · Просмотров: 1330
 

>  распознать вид элемента формы в 1с 8
хакерок
Отправлено: 25.05.18, 16:18


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Gigi @ Сегодня, 16:32 * ,
В общем модуле тебе доступен объект Метаданные там вся конфигурация попробуй с ним поработать.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141936 · Ответов: 11 · Просмотров: 862
 

>  Программное заполнение реквизита при флаге СвязиПараметровВыбора
хакерок
Отправлено: 25.05.18, 16:08


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


kapacb @ Сегодня, 16:55 * ,
Когда то у меня тоже такой вопрос возникал.
Помоему там для того чтоб автоматически заполнялось нужно
кроме указания Связи параметра выбора нужно заполнить Параметр Выбора
и ни надо в обработчике ничего писать


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141935 · Ответов: 6 · Просмотров: 593
 

>  распознать вид элемента формы в 1с 8
хакерок
Отправлено: 25.05.18, 15:27


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Gigi @ Сегодня, 16:11 * ,
Делаешь реквизит формы например ВводСуммы тип Число перетаскиваете на форму вот у тебя поле вода на форме.

Нажимаешь на этот элемент в форме там есть обработчик ПриИзменени

В нём пишешь
Сообщить(ВводСуммы)



  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141932 · Ответов: 11 · Просмотров: 862
 

>  Программное заполнение реквизита при флаге СвязиПараметровВыбора
хакерок
Отправлено: 25.05.18, 15:18


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


kapacb @ Вчера, 11:38 * ,
Посмотрите свойство реквизита Документ. Там может быть проставлена связь
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141930 · Ответов: 6 · Просмотров: 593
 

>  нужна помощ с динамическим спискам
хакерок
Отправлено: 25.05.18, 15:12


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


kanibal23 @ 17.05.18, 13:36 * ,
Зайдите в настройки списка и поставте отбор например дата не пустая
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141929 · Ответов: 9 · Просмотров: 547
 

>  распознать вид элемента формы в 1с 8
хакерок
Отправлено: 25.05.18, 15:09


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Gigi @ Сегодня, 15:58 * ,
Опишите что хочете сделать в форме может и подскажем куда копать
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141927 · Ответов: 11 · Просмотров: 862
 

>  распознать вид элемента формы в 1с 8
хакерок
Отправлено: 25.05.18, 14:58


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Gigi @ Сегодня, 15:51 * ,
Небольшая подсказка
Сообщить(Элементы[ЭлИмя].Вид);

В процессе происходит выдача строкового предстваления объекта Элементы[ЭлИмя].Вид в строку.

Сообщить(Строка(Элементы[ЭлИмя].Вид) = "Поле ввода")


может дать тебе Истина

Тоесть Элементы[ЭлИмя].Вид это не строка а объект
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141925 · Ответов: 11 · Просмотров: 862
 

>  Связь основного документа с документом на основании
хакерок
Отправлено: 04.05.18, 15:42


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Orion-PS @ Вчера, 21:58 * ,
создайТЕ запрос к базе данных который даст ВАМ ссылку на созданный документ и ВАША задача будет почти решена.

 ! 

Правила: 1
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141294 · Ответов: 4 · Просмотров: 690
 

>  результат запроса в текстовый документ и обратно
хакерок
Отправлено: 05.04.18, 11:13


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


pavels @ Вчера, 23:28 * ,
Проще всего Вам будет сделать отчёт в котором есть кнопка котороой можно сохранить в тексовый документ.

Вам поможет книга "Профессиональная разработка в системе «1с:ПредПриятие 8»" -> Глава 16 Сложные аналитические отчеты -> Пример 1. набор данных – запрос

Подставляете в пример свой запрос и получите отчёт.


  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140449 · Ответов: 3 · Просмотров: 471
 

>  Ошибка преобразования данных XML
хакерок
Отправлено: 03.04.18, 20:58


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Цитата(kosstess @ 02.04.18, 22:54) *
Обработка.КонвертацияОбъектовРаспределенныхИнформационныхБаз

Эта обработка на компьютере источник и приемнике отличается.
Попытаться сделать процесc создания xml и чтения одинаковой обработкой.
В крайнем случае сравнить процесс чтения и записи и исправить отличия.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140379 · Ответов: 4 · Просмотров: 1666
 

>  Как программно переоткрыть форму владельца
хакерок
Отправлено: 03.04.18, 20:44


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Ефремов @ Сегодня, 7:40 * ,
Если произошли изменения в базе данных то для обновления того что показывают открытые формы можно использовать
"Оповещения об изменнния" можно прочитать в книге "Профессиональная разработка в системе ..." -> Разработка форм ->Обновление данных в динамических списках.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #140378 · Ответов: 4 · Просмотров: 911
 

>  Хочу изучить типовую конфигурацию?
хакерок
Отправлено: 23.03.18, 18:36


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Надоело с нуля писать различные простые конфигурации. Хочу освоить типовое решение. Что посоветуете?
  Форум: Тематическое общение · Просмотр сообщения: #139997 · Ответов: 7 · Просмотров: 469
 

>  Позиционирование в динамическом списке.
хакерок
Отправлено: 23.03.18, 17:36


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Alex78 @ Сегодня, 10:26 * ,
В числе полей запроса обязательно должно быть поле ссылка и галочка Использовать всегда.

Vofka @ Сегодня, 9:19 * ,
Стоит поднять тему какие типовые конфигурации будут востребованы ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139995 · Ответов: 11 · Просмотров: 691
 

>  Хочу изучить типовую конфигурацию?
хакерок
Отправлено: 22.03.18, 11:01


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Цитата(logist @ 21.03.18, 18:22) *
УТ11

Конф. для Украины устарели?
  Форум: Тематическое общение · Просмотр сообщения: #139914 · Ответов: 7 · Просмотров: 469
 

>  Хочу изучить типовую конфигурацию?
хакерок
Отправлено: 21.03.18, 18:36


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Vofka,
С платформой вроде разобрался и использую. Думаю разобраться с типовыми решениями что посоветуете БСП, УТ 3.x ?
  Форум: Тематическое общение · Просмотр сообщения: #139896 · Ответов: 7 · Просмотров: 469
 

>  Хочу изучить типовую конфигурацию?
хакерок
Отправлено: 21.03.18, 18:09


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


logist,
С платформой вроде разобрался и использую. Думаю разобраться с типовыми решениями что посоветуете УТ 3.x ?
  Форум: Тематическое общение · Просмотр сообщения: #139894 · Ответов: 7 · Просмотров: 469
 

>  Позиционирование в динамическом списке.
хакерок
Отправлено: 21.03.18, 16:06


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Bernet @ Сегодня, 15:22 * ,
у меня вот этот кусок работает

&НаКлиенте
Процедура ВводКодаПриИзменении(Элемент)
    
    Номенклатура = БазовыйНоменклатура.ПолучитьНоменклатуруПоКодуТовара(Число(ВводКода));
  Если Не Номенклатура.Пустая() Тогда
      Элементы.Дерево.ТекущаяСтрока =БазовыйНоменклатура.ПолучитьГруппуНоменклатуры(Номенклатура);
      Элементы.Список.ТекущаяСтрока =Номенклатура;
  Иначе
      ВводКода= "";
  КонецЕсли;

КонецПроцедуры


Цитата(хакерок @ 21.03.18, 15:17) *
  Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию("Картопля");
  Если Не Номенклатура.Пустая() Тогда
      Элементы.СписокНоменклатура1.ТекущаяСтрока =Номенклатура;
  КонецЕсли;


И ещё чтобы это работало нужно в реквизите СписокНоменклатура там где Настройка списка указать Основная таблица Справочник.Номенклатура
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139874 · Ответов: 11 · Просмотров: 691
 

>  Позиционирование в динамическом списке.
хакерок
Отправлено: 21.03.18, 15:17


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Alex78 @ Сегодня, 11:28 * ,
    Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию("Картопля");
  Если Не Номенклатура.Пустая() Тогда
      Элементы.СписокНоменклатура1.ТекущаяСтрока =Номенклатура;
  КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139871 · Ответов: 11 · Просмотров: 691
 

>  Сумма в документе по строкам
хакерок
Отправлено: 19.03.18, 21:51


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Аннет @ Сегодня, 21:32 * ,
В созданном документе становиТЕСЬ на столбец Цена.
У него есть обработчик ПриИзменении.
&НаКлиенте
Процедура СписокЦенаПриИзменении(Элемент)
Строка = Элемент.Родитель.ТекущиеДанные;    
Строка.Сумма = Строка.Цена*Строка.Количество;
КонецПроцедуры



 ! 

Правила: 1
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139795 · Ответов: 2 · Просмотров: 461
 

>  Определить блюдо по ингредиенту
хакерок
Отправлено: 19.03.18, 19:51


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Светлана0000 @ 17.03.18, 20:15 * ,
&НаСервере
Процедура ВКакихБлюдахНаСервере()
    
    Ингредиент = Справочники.Ингредиенты.НайтиПоНаименованию("Картопля");    
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Блюда.Ссылка КАК Блюдо
        |ИЗ
        |    Справочник.Блюда КАК Блюда
        |ГДЕ
        |    Блюда.Ингредиенты.Ингредиент = &Ингредиент";
    
    Запрос.УстановитьПараметр("Ингредиент", Ингредиент);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
        
    Сообщение = Новый СообщениеПользователю();
    Сообщение.Текст = Строка(ВыборкаДетальныеЗаписи.Блюдо);
    Сообщение.Сообщить();
        
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура ВКакихБлюдах(Команда)
    ВКакихБлюдахНаСервере();
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139793 · Ответов: 3 · Просмотров: 696
 

>  Определить блюдо по ингредиенту
хакерок
Отправлено: 17.03.18, 16:40


Оратор
*****

Группа: Пользователи
Сообщений: 258
Регистрация: 24.07.09
Из: Київ
Пользователь №: 1187


Светлана0000 @ Сегодня, 11:38 * ,
Идите от простого к сложному. Сделайте в отдельной обработке запрос который по ссылке на инградиент выведет все товары куда он входит. И потом далее делайте...
Из вопроса не понятна как у вас хранятся борщи и картошка и что такое ВтИнгридиенты.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139723 · Ответов: 3 · Просмотров: 696
 

11 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 25.06.19, 14:11
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне