Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

7 страниц V   1 2 3 > » 

>  При экспорте в CVS обрезает строку
kot488
Отправлено: 04.01.18, 10:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Цитата(Vofka @ 28.12.17, 10:01) *
возможно визуально символ на экране выглядит как пробел, но на самом деле то не пробел.



Спасибо. Переделали позицию и все норм стало
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #136923 · Ответов: 5 · Просмотров: 201
 

>  При экспорте в CVS обрезает строку
kot488
Отправлено: 28.12.17, 10:08


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Цитата(Moloko @ 28.12.17, 9:51) *
То, что пишет Google, не пробовали?
"Как преобразовать файл Excel в CSV:
1. В рабочей книге Excel откройте вкладку Файл (File) и нажмите Сохранить как (Save as). Кроме этого, диалоговое окно Сохранение документа (Save as) можно открыть, нажав клавишу F12.
2. В поле Тип файла (Save as type) выберите CSV (разделители – запятые) (CSV (Comma delimited))."
А сохранять табличный документ в xls, надеюсь, умеет каждый.



Если бы нужно было это делать единожды, то и код не нужен быд бы.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #136745 · Ответов: 5 · Просмотров: 201
 

>  При экспорте в CVS обрезает строку
kot488
Отправлено: 28.12.17, 9:32


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


В 1С есть обработка которая подключается к firebird, вытагивает прайс и импортирует в csv. Экспорт проходит нормально, но с одной позицией проблема. При экспорте режит эту позицию пополом и получается не коректное отображение.

Вот код обработки
Функция ПолучитьНоменклатуру()

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|    PRAJS_LIST.KOD_USLUGI.KOD_PODGRUPPY_USLUGI.KOD_GRUPPY_USLUG.KOD_GRUPPY_USLUG КАК ВнутреннийКодГруппыУслуг,
|    PRAJS_LIST.KOD_USLUGI.KOD_PODGRUPPY_USLUGI.KOD_GRUPPY_USLUG.NAZVANIYE_GRUPPY_USLUG КАК НазваниеГруппыУслуг,
|    PRAJS_LIST.KOD_USLUGI.KOD_PODGRUPPY_USLUGI.KOD_PODGRUPPY_USLUG КАК ВнутреннийКодПодгруппыУслуг,
|    PRAJS_LIST.KOD_USLUGI.KOD_PODGRUPPY_USLUGI.NAZVANIYE_PODGRUPPY_USLUG КАК НазваниеПодгруппыУслуг,
|    PRAJS_LIST.KOD_USLUGI КАК ВнутреннийКодУслуги,
|    PRAJS_LIST.KOD_USLUGI.NAZVANIYE_USLUGI КАК НазваниеУслуги,
|    PRAJS_LIST.KASSOVYJ_KOD КАК КассовыйКодУслуги,
|    PRAJS_LIST.CYENA КАК ЦенаУслуги

|ИЗ
|    ВнешнийИсточникДанных.MEDUCHET.Таблица.PRAJS_LIST КАК PRAJS_LIST
|ГДЕ
|    PRAJS_LIST.KASSOVYJ_KOD > 0
|    И PRAJS_LIST.CYENA > 0
|    И PRAJS_LIST.PRINTING = -1
|    И PRAJS_LIST.DYEJSTVITYELNYJ = -1
|
|УПОРЯДОЧИТЬ ПО
|    ВнутреннийКодГруппыУслуг";

Результат = Запрос.Выполнить();
ТаблицаЗначений = Результат.Выгрузить();
возврат ТаблицаЗначений;
КонецФункции //
Функция СоздатьЗаголовкиCSV(ТаблицаЗначений,разделитель)
    разделитель = ";";
    колонкиТЗ=ТаблицаЗначений.колонки;
    Для каждого колонка Из колонкиТЗ Цикл
        стрКолонки = "" + стрКолонки + колонка.Имя + разделитель;
    КонецЦикла;
    Возврат стрКолонки;
КонецФункции

Функция ЧислоВСтроку(Ч)

Возврат СтрЗаменить(Строка(Ч),Символы.НПП,"");
КонецФункции



Функция СоздатьДанныеCSV(ТаблицаЗначений,разделитель)
    строка = СтрЗаменить(строка, Символы.НПП, "");
    текст="";
    для каждого запись из ТаблицаЗначений Цикл
        если текст="" тогда
            текст=СоздатьЗаголовкиCSV(ТаблицаЗначений,разделитель)
                + Символы.ПС;    
        КонецЕсли;    
                
        сообщить(запись.НазваниеУслуги);
        текст = текст + ЧислоВСтроку(запись.ВнутреннийКодГруппыУслуг)
            + разделитель + запись.НазваниеГруппыУслуг
            + разделитель + ЧислоВСтроку(запись.ВнутреннийКодПодгруппыУслуг)
            + разделитель + запись.НазваниеПодгруппыУслуг
            + разделитель + ЧислоВСтроку(запись.ВнутреннийКодУслуги)
            + разделитель + запись.НазваниеУслуги
            + разделитель + ЧислоВСтроку(запись.КассовыйКодУслуги)
            + разделитель + ЧислоВСтроку(запись.ЦенаУслуги)
            + Символы.ПС;        
    КонецЦикла;
        
    //сообщить(текст);
    Возврат текст;

КонецФункции //
Функция ЗаписатьCSV(текст,имяФайла)              
    кодировка = КодировкаТекста.UTF8;
    
    ТекстовыйФайлЗапись = Новый ЗаписьТекста(имяФайла,Кодировка);            
    ТекстовыйФайлЗапись.ЗаписатьСтроку(текст);
    ТекстовыйФайлЗапись.Закрыть();    
    Возврат 0;

КонецФункции //
// Основная логика:
Функция ВыгрузитьВCSV(имяФайлаCSV);
    
    разделитель = ";";
    ТаблицаЗначений = ПолучитьНоменклатуру();
    текст = СоздатьДанныеCSV(ТаблицаЗначений,разделитель);
    ЗаписатьCSV(текст,имяФайлаCSV);
    КонецФункции



Должно быть в одну строку, а делает пополам



В источнике никаких символов кроме пробела нет, подскажите пожалуйста в чем может быть проблема?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #136740 · Ответов: 5 · Просмотров: 201
 

>  Поступление товаров и услуг на основании заказа поставщику
kot488
Отправлено: 27.10.17, 19:01


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


получается еще и регистра накопления нужно допиливать?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #134051 · Ответов: 4 · Просмотров: 267
 

>  Поступление товаров и услуг на основании заказа поставщику
kot488
Отправлено: 27.10.17, 17:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


awp @ Сегодня, 1:32 * ,

Судя по точкам остановки, то это формирование на основании счета, оно работает отлично.

ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.СчетНаОплатуПоставщика") Тогда

            СкопироватьТовары(Основание);
            СкопироватьВозвратнуюТару(Основание);
            СкопироватьУслуги(Основание);
            СкопироватьОборудование(Основание);
            СкопироватьОбъектыСтроительства(Основание);
            СкопироватьБланки(Основание);

        КонецЕсли;


На основании заказа

Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
        
        Если Не Основание.ВидОперации = Перечисления.ВидыОперацийЗаказПокупателя.Переработка Тогда
            Возврат;
        КонецЕсли;

        ВидОперации = Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ВПереработку;
        

        // Табличные части заполняем только если взаиморасчеты ведутся не по расчетным документам.
        Сделка = Основание;

        Если Сделка.Проведен Тогда

            СкладОрдер     = Основание.СкладГруппа;
            ВидПоступления = Перечисления.ВидыПоступленияТоваров.НаСклад;

            // Заполним табличные части неполученными ТМЦ по заказу поставщику.
            ЗаполнитьТоварыПоОстаткамУпр("ВПереработку");

        КонецЕсли;



Получается заполнение идет по этой процедуре?
Процедура ЗаполнитьТоварыПоОстаткамУпр(СтатусПартииСтр = "Купленный") Экспорт

  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #134050 · Ответов: 4 · Просмотров: 267
 

>  Поступление товаров и услуг на основании заказа поставщику
kot488
Отправлено: 26.10.17, 20:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Есть УТП 1.2, в заказе поставщика есть колонка КодУКТВЭДВ. Не могу сделать что бы на основании заказа можно было сформировать поступление с заполнеными строками УКТВЭДВ. Колонку добавил, при ручном выборе все проставляет. Если делать на основании счет все формирует отлично, и заказ и поступление. Если делать на основании заказа то нечего не подставляет.
Может кто то делал, подскажите где искать заполнение на основании заказ.
Спасибо.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #133997 · Ответов: 4 · Просмотров: 267
 

>  МІНІ-ФП54.01 и Бухгалтерия для Украины 1.2
kot488
Отправлено: 13.10.17, 14:37


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


sava1 @ Сегодня, 15:31 * ,

Понял, спасибо)
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #133479 · Ответов: 5 · Просмотров: 362
 

>  МІНІ-ФП54.01 и Бухгалтерия для Украины 1.2
kot488
Отправлено: 13.10.17, 14:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


nik389 @ Вчера, 14:29 * ,

Скачал их обработку, пробую открыть в 1С, ошибка
Ошибка инициализации модуля: ВнешняяОбработка.ФискальныПринтерЮнисистем_Mini_T_FP.МодульОбъекта
по причине:
{ВнешняяОбработка.ФискальныПринтерЮнисистем_Mini_T_FP.МодульОбъекта(2197)}: Поле объекта не обнаружено (ТООшибкиОбщие)

У 1С пишут что работает только с
Компоненты предназначены для следующих конфигураций:

1С:Предприятие 8 Торговля для ЧП Украины;
1С:Предприятие 8 Розница для Украины, редакция 1.0;
1С:Предприятие 8 Розница для Украины, редакция 2.0;
1С:Предприятие 8 Управление торговлей для Украины, редакция 2.3;
1С:Предприятие 8 Управление торговлей для Украины, редакция 3.1;
1С:Предприятие 8 Управление производственным предприятием для Украины;
1С:Предприятие 8 Управление торговым предприятием для Украины.


Получается для Бухгалтерии нужно танцы с бубном?
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #133477 · Ответов: 5 · Просмотров: 362
 

>  МІНІ-ФП54.01 и Бухгалтерия для Украины 1.2
kot488
Отправлено: 10.10.17, 14:02


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Поделитесь пожалуйста опытом обьединения данного чуда с 1С. Насколько понял, то берем обработку, с ее помощью подключаем его к 1С, и по идее все должно работать. Но негде не смог найти, драйвера к нему нужно покупать у артсофта, или винда его сама подцепляет. Аппарат пока в руках не держал, проверить нет возможности. Так что буду благодарен за любую информацию
  Форум: Работа с торговым оборудованием · Просмотр сообщения: #133305 · Ответов: 5 · Просмотров: 362
 

>  Загрузка данных по odbc и создание документа
kot488
Отправлено: 14.09.17, 16:00


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


logist @ 06.09.17, 18:16 * ,


Получило вот таким образом, но не получается поставить количество, есоли можете, подскажите как сделать

&НаСервере
Процедура ПоехалиНаСервере()
   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
    |ldo56_zayavki_upakovka.emailzakaz Как EMail,
    |ldo56_zayavki_upakovka.FIO Как ФИО,
    |ldo56_zayavki_upakovka.upakovka Как Упаковка,  
    |ldo56_zayavki_upakovka.kolichestvo Как Количество,
    |ldo56_zayavki_upakovka.mb3 Как Заказчик,
    |ldo56_zayavki_upakovka.tadavremyazakaza Как ДатаСоздания
    |ИЗ
    |ВнешнийИсточникДанных.Сайт.Таблица.ldo56_zayavki_upakovka КАК ldo56_zayavki_upakovka";  
          
Результат = Запрос.Выполнить().Выгрузить();
Для Каждого ЭлементРезультата из Результат Цикл
    Попытка
        НовыйДокумент = Документы.Упаковка.СоздатьДокумент();
        НовыйДокумент.Заказчик        = Справочники.Представительства.НайтиПоНаименованию(ЭлементРезультата.Заказчик);
        НовыйДокумент.ФИО       = ЭлементРезультата.ФИО;
        НовыйДокумент.EMail       = ЭлементРезультата.EMail;
        НоваяСтрока = Документы.Упаковка.СоздатьДокумент();
        НовыйДокумент.УпаковочныйМатериал.Добавить().УпаковочныйМатериал = Справочники.УпаковочныйМатериал.НайтиПоНаименованию(ЭлементРезультата.Упаковка);
        
        
        НовыйДокумент.Дата            = ТекущаяДата();
        
        НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение);
           Исключение
       КонецПопытки;
КонецЦикла;
  
КонецПроцедуры
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #132181 · Ответов: 3 · Просмотров: 299
 

>  Загрузка данных по odbc и создание документа
kot488
Отправлено: 06.09.17, 16:12


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Имеется сайт где посетитель заполняет форму заявки. Информация с этой фирмы ложится в таблицу MySQL.
Нужно как то реализовать автоматическое создание документов согласно заявкам.
Подключение к MySQL таблице реализовал, данные через запрос получаю. Подскажите пожалуйста где можно посмотреть пример автосоздания документа. Что бы можно было делать через фоновые задачи.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #131800 · Ответов: 3 · Просмотров: 299
 

>  Соединить в строку ссылку и текст
kot488
Отправлено: 28.04.17, 17:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Цитата(logist @ 28.04.17, 17:49) *
Тема = Строка(ДанныеЗаполнения) + "  "



Он заполняет все с документа, а мне нужно просто слово Декларация " + ДанныеЗаполнения.НомерДекларации;

Что бы слово Декларация было всегда а вот ДанныеЗаполнения.НомерДекларации; всегда будут меняться
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126261 · Ответов: 4 · Просмотров: 633
 

>  Соединить в строку ссылку и текст
kot488
Отправлено: 28.04.17, 15:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Подскажите пожалуйста, есть процедура. Она заполняет извещение на основании документа.
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
    // Даний фрагмент побудований конструктором.
    // При повторному використанні конструктора, внесені вручну зміни будуть втрачені!!!
    Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДекларацияПочта") Тогда
        // Заповнення шапки
        Тема = ДанныеЗаполнения.НомерДекларации;
        Копии = ДанныеЗаполнения.ОтправительEMail;
        Получатели = ДанныеЗаполнения.ПолучательEmail;
        ИмяОтправителя = ДанныеЗаполнения.СетьКурьерскихСлужб;
        АдресОтправителя = Справочники.ПочтовыеЯщики.НайтиПоКоду("000000001");
        ПочтовыйЯщик = Справочники.ПочтовыеЯщики.НайтиПоКоду("000000001");
    КонецЕсли;
    //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры


Подскажите пожалуйста, как можно задать статический текст с переменной, что бы Тема = ДанныеЗаполнения.НомерДекларации; при выводе было Документ и номер декларации. Как их склеить?

 ! 

Правила: 4
 
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126257 · Ответов: 4 · Просмотров: 633
 

>  Залипла дата в документах
kot488
Отправлено: 25.04.17, 14:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


sava1 @ Сегодня, 14:54 * ,

Там и кода особо нет при открытии

&НаКлиенте
Процедура УстановитьПараметрыОтбораПользователя()        
    
    ЭлементыОтбора = Список.Отбор.Элементы;        
    ЭлементыОтбора.Очистить();                            
    
    Если Не ОтборОрганизация.Пустая() Тогда        
                
        ЭлементОтбораОрганизация = ЭлементыОтбора.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        
        ЭлементОтбораОрганизация.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Организация");
        ЭлементОтбораОрганизация.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
        ЭлементОтбораОрганизация.Использование = Истина;
        ЭлементОтбораОрганизация.ПравоеЗначение = ОтборОрганизация;
    
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ОрганизацияФильтрПриИзменении(Элемент)
    
    УстановитьПараметрыОтбораПользователя();
    
КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ОтборОрганизация = Пользователи.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "ОсновнаяОрганизация");    
    
КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    УстановитьПараметрыОтбораПользователя();    
    
КонецПроцедуры


Помог ребут службы sql
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126063 · Ответов: 10 · Просмотров: 544
 

>  Залипла дата в документах
kot488
Отправлено: 25.04.17, 13:45


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


sava1 @ Сегодня, 14:40 * ,
savepic глючит(

ТекущаяДата() 25.04.2017 14:43:35
РабочаяДата() {(1,1)}: Процедура или функция с указанным именем не определена (РабочаяДата)
РабочаяДата 25.04.2017 0:00:00

Если зайти в конфигуратор и запустить отладку, и открыть документ то даты правильные.
Если зайти в базу не через отладку то дата 03.04
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126056 · Ответов: 10 · Просмотров: 544
 

>  Залипла дата в документах
kot488
Отправлено: 25.04.17, 13:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


sava1 @ Сегодня, 14:30 * ,

Я правильно смотрю?

  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126054 · Ответов: 10 · Просмотров: 544
 

>  Залипла дата в документах
kot488
Отправлено: 25.04.17, 13:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


sava1 @ Сегодня, 14:13 * ,


Где это можно посмотреть? не могу найти(
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126050 · Ответов: 10 · Просмотров: 544
 

>  Залипла дата в документах
kot488
Отправлено: 25.04.17, 13:10


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


sava1 @ Сегодня, 14:07 * ,
В параметрах текущая дата компьютера. Если заходить через конфигуратор то все ок
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126047 · Ответов: 10 · Просмотров: 544
 

>  Залипла дата в документах
kot488
Отправлено: 25.04.17, 12:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Есть в самописной базе документ. В нем есть кнопка заполнить с помощью которой в него заполняются все определенные документы указанного типа. На скрине документ правильный, с правильными датами. Но дата в заголовке почему то 03.04.2017


Это под моей учетной записью.
А у некоторых пользователей, в этом документе отображается дата что документы созданы 03.04


Хотя если зайти в сам документ то в нем правильная дата, 23.04. И даже документы от 31.03 пользователю показывает как 03.04

Что за глюк? Кеш почистил


и все новые документы тоже создаются с датой 03.04
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #126043 · Ответов: 10 · Просмотров: 544
 

>  Вывести в отчет весь товар который был продан с определенной наценкой
kot488
Отправлено: 03.04.17, 12:29


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Подскажите пожалуйста, не нашел такого стандартного отчета. Нужно вывести список всех позиций, которые были продану за 2016 год, у которых наценка больше 40% от цены закупки. УТП 1.0.84
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #125220 · Ответов: 3 · Просмотров: 497
 

>  Отбор документов по контрагенту
kot488
Отправлено: 24.03.17, 15:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Цитата(Vidocq05 @ 24.03.17, 13:44) *
А какой код здесь УстановитьПараметрыОтбораПользователя() ?


Вот что там
Процедура УстановитьПараметрыОтбораПользователя()    
    
    ЭлементыОтбора = Список.Отбор.Элементы;        
    ЭлементыОтбора.Очистить();                            
    
    Если Не Организация.Пустая() Тогда
        
        // Создадим группу компановки ИЛИ
        ГруппаКомпоновкиОтбор = ЭлементыОтбора.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
        ГруппаКомпоновкиОтбор.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИли;
          //Отбор по отправителю
          ЭлементОтбораКурьеркаОтправитель = ГруппаКомпоновкиОтбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
          ЭлементОтбораКурьеркаОтправитель.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ОтправительСлужбаДоставки");
          ЭлементОтбораКурьеркаОтправитель.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
          ЭлементОтбораКурьеркаОтправитель.Использование = Истина;
          ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = Организация;
          //Отбор по получателю
          ЭлементОтбораКурьеркаОтправитель = ГруппаКомпоновкиОтбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
          ЭлементОтбораКурьеркаОтправитель.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ПолучательСлужбаДоставки");
          ЭлементОтбораКурьеркаОтправитель.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
          ЭлементОтбораКурьеркаОтправитель.Использование = Истина;
          ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = Организация;
    
    КонецЕсли;
    
КонецПроцедуры


Посмотрел список документов, от пользователя которому не доступно поле Плательщик, у них тоже делается отбор по Вашему коду выше, и все отображается только список документов в которых контрагент 000002643
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124696 · Ответов: 15 · Просмотров: 980
 

>  Отбор документов по контрагенту
kot488
Отправлено: 24.03.17, 13:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Vidocq05 @ Сегодня, 12:40 * ,

Убрал строку, ошибок никаких нет, не знаю для чего оно


Прописал еще вот что, и заработало

&НаКлиенте
Процедура ПриОткрытии(Отказ)
        Если ЗначениеЗаполнено(Организация) Тогда
        УстановитьПараметрыОтбораПользователя();
    КонецЕсли;
    [b]УстановитьПараметрыОтбораПлательщикПользователя();[/b]
    
КонецПроцедуры


Но как только заходишь в базу под нужным пользователем его сеанс подвисает, много документом в базе. А есди сделать по автору документа, это не ускорит?

Или может можно сделать в отборе что бы не брались во внимание документы которые младше 01.01.2017?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124686 · Ответов: 15 · Просмотров: 980
 

>  Отбор документов по контрагенту
kot488
Отправлено: 24.03.17, 11:44


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Цитата(Vidocq05 @ 24.03.17, 11:26) *
ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = НайтиКонтрагентСервер("000002643");



А это куда вписвать?

&НаКлиенте
Процедура УстановитьПараметрыОтбораПлательщикПользователя()    
    
    ЭлементыОтбора = Список.Отбор.Элементы;        
    ЭлементыОтбора.Очистить();                            
    
    Если Не Контрагент.Пустая() Тогда
        
        // Создадим группу компановки ИЛИ
        ГруппаКомпоновкиОтбор = ЭлементыОтбора.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
        ГруппаКомпоновкиОтбор.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИли;
          //Отбор по отправителю
          ЭлементОтбораКурьеркаОтправитель = ГруппаКомпоновкиОтбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
          ЭлементОтбораКурьеркаОтправитель.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Плательщик");
          ЭлементОтбораКурьеркаОтправитель.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
          ЭлементОтбораКурьеркаОтправитель.Использование = Истина;
          ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = НайтиКонтрагентСервер("000002643");
          
    КонецЕсли;
    
    КонецПроцедуры

&НаСервереБезКонтекста
Функция НайтиКонтрагентСервер(Код)
  
    Контрагент = Справочники.Контрагенты.НайтиПоКоду(Код);
    Возврат Контрагент;

КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124682 · Ответов: 15 · Просмотров: 980
 

>  Отбор документов по контрагенту
kot488
Отправлено: 24.03.17, 9:40


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


logist @ Вчера, 20:28 * ,
Цитата(logist @ 23.03.17, 20:28) *
ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = Справочники.Контрагенты.НайтиПоКоду("000002643");



Вот такой вид должен иметь запрос?
Процедура УстановитьПараметрыОтбораПлательщикПользователя()    
    
    ЭлементыОтбора = Список.Отбор.Элементы;        
    ЭлементыОтбора.Очистить();                            
    
    Если Не Контрагент.Пустая() Тогда
        
        // Создадим группу компановки ИЛИ
        ГруппаКомпоновкиОтбор = ЭлементыОтбора.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
        ГруппаКомпоновкиОтбор.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИли;
          //Отбор по отправителю
          ЭлементОтбораКурьеркаОтправитель = ГруппаКомпоновкиОтбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
          ЭлементОтбораКурьеркаОтправитель.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Плательщик");
          ЭлементОтбораКурьеркаОтправитель.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
          ЭлементОтбораКурьеркаОтправитель.Использование = Истина;
          ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = Справочники.Контрагенты.НайтиПоКоду("000002643");
        
    
    КонецЕсли;
    
КонецПроцедуры


ПРи проверке говорит что переменная не определена
{Документ.ДекларацияПочта.Форма.ФормаСписка.Форма(88,55)}: Змінна не визначена (Справочники)
ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = <<?>>Справочники.Контрагенты.НайтиПоКоду("000002643"); (Перевірка: Тонкий клієнт)


Вот что у меня в реквизитах формы


Сделал вот так
&НаКлиенте
Процедура УстановитьПараметрыОтбораПлательщикПользователя()    
    
    ЭлементыОтбора = Список.Отбор.Элементы;        
    ЭлементыОтбора.Очистить();                            
    
    Если Не Контрагент.Пустая() Тогда
        
        // Создадим группу компановки ИЛИ
        ГруппаКомпоновкиОтбор = ЭлементыОтбора.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
        ГруппаКомпоновкиОтбор.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИли;
          //Отбор по отправителю
          ЭлементОтбораКурьеркаОтправитель = ГруппаКомпоновкиОтбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
          ЭлементОтбораКурьеркаОтправитель.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Плательщик");
          ЭлементОтбораКурьеркаОтправитель.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
          ЭлементОтбораКурьеркаОтправитель.Использование = Истина;
          ЭлементОтбораКурьеркаОтправитель.ПравоеЗначение = Контрагент.НайтиПоКоду("000002643");
        
    
    КонецЕсли;
    
КонецПроцедуры


Захожу в список документов, отбор не делает тоже. Пробую отобрать документы в ручную, и при выборе контрагента выскакивает ошибка Метод обьекта не обнаружен (НайтиПоКоду)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124663 · Ответов: 15 · Просмотров: 980
 

>  Отбор документов по контрагенту
kot488
Отправлено: 23.03.17, 18:53


Завсегдатай
****

Группа: Пользователи
Сообщений: 163
Регистрация: 28.11.11
Пользователь №: 12943


Цитата(logist @ 23.03.17, 18:19) *
так у вас же это уже написано:

Но не хватает строки что бы взять указанного контрагента, правильно?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #124631 · Ответов: 15 · Просмотров: 980
 

7 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 23.01.18, 15:41
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне