Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Vladal ::: Спасибо сказали: 32 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
27.11.18, 23:51 Как сменить булевое значение заполнения по умолчанию на булевую константу?
Цитата(Gigi @ 27.11.18, 20:29) *
А константа это не элемент конфигурации?

Элемент. А вот её значение - в области пользовательских данных, а не конфигуратора. Сейчас значение одно, через час другое. А если это значение перечисления, предопределенный элемент справочника, плана счетов или ПВХ, то к нему есть доступ из свойств автозаполнения.
Цитата(Gigi @ 27.11.18, 20:29) *
Пока все внимание акцентирую только на кодинг.

Да. Понимание архитектуры 1С 8 облегчит работу.
Цитата(Gigi @ 27.11.18, 20:29) *
А константа это не элемент конфигурации? Так же как на пример перечисление?

Константа и перечисления - объекты конфигурации.
Только значение перечисления задано в конфигураторе, а значение константы задано в пользовательском режиме. Это если "на пальцах".

Цитата(Gigi @ 27.11.18, 20:29) *
Но суть в том, что если константа "Обслуживание" имеет значение Истина тогда база грузиться, а если ложь то нет.
...
Конечно разумнее было бы создать константу с именем не "Обслуживание", а "Отключение" .. это было бы уместнее к значению по умолчанию.

Да. Это хорошо, что пришли к такому выводу.
Цитата(Gigi @ 27.11.18, 20:29) *
В противном случае придется в других процедурах везде менять. Что думаю и придется делать.
Ладно .. это так ..для ясного понимания негодования...
спасибо

Да, такое тоже бывает, когда надо переписывать код на оптимальный.

Суть негодования понятна. Особенно, когда "бросили на амбразуру" и плыви, как хочешь.
Gigi,
27.11.18, 17:29 Как сменить булевое значение заполнения по умолчанию на булевую константу?
Цитата(Gigi @ 27.11.18, 8:19) *
Ну конечно ... "создайте" ... "доработайте" А в опциях просто сменить значение заполнения константы по умолчанию без "создайте/доработайте" это конечно невозможно.

Если Вы разработчик в 1С - есть ресурсы для обучения или тут же на форуме можно обсудить.
Если Вы - пользователь 1С, хоть и продвинутый, то наверно это создает сложности.

Потом: константа и её значения находятся в области данных информационной базы, поэтому в конфигураторе нельзя задать значение заполнения. Но если бы это была ссылка на объект с предопределенными данными - то да, в значении заполнения можно указать этот предопределенный элемент.

Цитата(Vofka @ 27.11.18, 16:36) *
Зачем вы так жестоко с человеком?

Я не хотел.


Цитата(Gigi @ 27.11.18, 10:09) *
просто длина одного шага вперед должна быть 100 см, а не 95.

Либо нестандартизированная линейка. Как, например, дешевая китайская рулетка, шкала которой не совпадает с эталоном.
Может, Вы ожидаете неоправданно большего от системы, которая рассчитана под другие задачи.
Так что разработчики 1С сделали километр из 1000 эталонных метров, а Вы ожидаете от этого километра 1024 "китайских" метра.
Увы.

Цитата(Gigi @ 25.11.18, 12:43) *
Дело в том, что когда создаешь булевый реквизит объекта, там есть опция "ЗначениеЗаполнения". Обычно по умолчанию всегда стоит Ложь. И поэтому есть возможность сменить на Истину. А вот когда создаешь тот же булевый тип но константу, такая опция как "ЗначениеЗаполнения", и вовсе отсутствует. ПОЧЕМУ? По крайней мере че то ее не нахожу.
А нужно что бы значение созданной булевой константы было не Ложь, а ИСТИНА!
Никто не подскажет пути как это сделать?
Буду опять признателен!

Итак, в форме элемента/группы справочника в обработчике ПриОткрытии можно добавить проверку на то, что это новый объект и заполнять нужный реквизит значением из константы.

Вот пример:

Процедура ПриОткрытии()
    
    Если ЭтоНовый() Тогда
        ЗначениеРеквизита = Константы.БулеваяКонстанта.Получить();
        НовыйРеквизит = ЗначениеРеквизита;
    КонецЕсли;
    
КонецПроцедуры


Но это надо дописывать ручками. А вот чтобы это прописать в свойства реквизита, мне пока неизвестно.


Цитата(Gigi @ 27.11.18, 10:09) *
Просто кое где не до конца удобна.

Зато не надо в notepad.exe или nano писать текст программы и компилировать его из командной строки )))
Gigi,
26.11.18, 15:41 Как сменить булевое значение заполнения по умолчанию на булевую константу?
з - зубожиння


Создайте свою обработку или доработайте обработчик обновления информационной базы, который бы заполнял значения новых реквизитов.
Gigi,
24.10.18, 20:05 Получение данных с COM порта
Цитата(SeverinPasha @ 23.10.18, 13:29) *
Если учесть, если на карте имеется номер 0000255740 (десятеричный) и 039,01335 (некий ТЕКСТОВЫЙ код).
Помогите связать результат вывода с данными которые по идее должны выводиться(написаны на карте)


Супер! Я ждал этого от Вас!
Алгоритм был найден на форуме разработчиков ПО работы с RFID-метками.
Процедуры конвертации чисел между системами счислений найдены на Мисте или Инфостарте.

Процедура КнопкаСчитатьRFIDНажатие(Элемент)
    
    СчитанноеЗначение = "";
    Результат = ВвестиСтроку(СчитанноеЗначение, "Считайте данные карточки RFID", 10, Ложь);
    Если НЕ Результат Тогда
        Возврат;
    КонецЕсли;
    
    // Преобразование 10-ричного серийного номера dec1 (0000255740) в 10-ричные данные (039,01335) dec2, хранящиеся в памяти карточки.
    // Алгоритм преобразования:
    // dec1 преобразовать в hex
    // Старшие 4 байта hex составляют целую часть dec2,
    // младшие 4 байта hex составляют дробную часть dec2.
    
    ДанныеHEX = Прав("00000000" + ОбщегоНазначения.Из_10_В_Любую(СчитанноеЗначение, 16), 8);     // с лидирующими нолями
    ЦелаяЧасть = Прав("000" + ОбщегоНазначения.Из_Любой_В_10(Сред(ДанныеHEX, 1, 4), 16), 3);     // старшие 4 байта в 10-ричное
    ДробнаяЧасть = Прав("00000" + Формат(ОбщегоНазначения.Из_Любой_В_10(Сред(ДанныеHEX, 5, 4), 16), "ЧГ=0"), 5); // младшие 4 байта в дробную часть
    
    НомерДес1 = СчитанноеЗначение;
    НомерДес2 = "" + ЦелаяЧасть + "," + ДробнаяЧасть;
    
КонецПроцедуры


процедуры из модуля ОбщегоНазначения:

Функция Из_10_В_Любую(Знач Значение=0, Нотация=36) Экспорт
    
    Если Нотация <= 0 Тогда
        Возврат ""
    КонецЕсли;
    Значение = Число(Значение);
    Если Значение <= 0 Тогда
        Возврат "0"
    КонецЕсли;
    Значение = Цел(Значение);
    Результат = "";
    Пока Значение>0 Цикл
        Результат = Сред("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Значение%Нотация + 1, 1) + Результат;
        Значение = Цел(Значение/Нотация);
    КонецЦикла;
    
    Возврат Результат;
    
КонецФункции

Функция Из_Любой_В_10(Знач Значение="0", Нотация=36) Экспорт
    
    Если Нотация <= 0 Тогда
        Возврат 0
    КонецЕсли;
    Значение = СокрЛП(Значение);
    Если Значение = "0" Тогда
        Возврат 0
    КонецЕсли;
    Результат = 0;
    Длина = СтрДлина(Значение);
    Для Х = 1 По Длина Цикл
        М = 1;
        Для У = 1 По Длина-Х Цикл
            М = М*Нотация
        КонецЦикла;
        Результат = Результат + (Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ", Сред(Значение, Х, 1)) - 1)*М;
    КонецЦикла;
    
    Возврат Окр(Результат);
    
КонецФункции
SeverinPasha,
11.10.18, 5:08 Программист 1С, Одесса
Цитата(Flexy @ 09.10.18, 21:50) *
В старт посте 12К. Я что-то пропустил???
Это ЗП на испытательном сроке. Рассуждаю, что после испытательного должно быть около 16 или выше.

Э.... То и на испытательном сроке надо работать не с 9 до 18, а с 9 до 15?

Цитата(Flexy @ 09.10.18, 22:45) *
От куда такие вакансии

// да тут не только мягкий знак, тут и пробел западает. Я не придираюсь. Отнюдь.

Вот откуда: из рынка
https://www.work.ua/jobs-программист+1с/

Сегодня в топе обычные торговцы - "Червоний Маркет", 35 тыс, торгуют мелочевкой по низким ценам. Летом предлагали еще по 30 тыс.

Листаем дальше
- Эко Маркет. Белая зарплата, 30-35 тыс. Считайте ФОТ сами.
- Мета Капитал уже в топ вылез. Наверно робот Ворка его поднял. 45.
- Агромарс, УПП, от 35. Давно не следил, на УПП это мало или норм?
- Какая-то жадная галера, до 20 грн предлагает. Там точно нужны вьюноши с горящими глазами и широкими ушами, чтобы по ним поездить.
- Кривой Рог, недоработа в Харькове - в пределах 20, не рассматриваем.
- Одесса. Витол. 35 грн в месяц.
- опять Харьков, 12500, и из тех 12 тыс скромно 4 на карточку.
- Теллур Харьков. 10 тыс. Это позорище.
- ВиЯр - торговля, 30 грн.
- галера Фортолис - пишут 30, но наверно при условии закрытия 700 часов в месяц. Ладно, утрирую, меньше.
- КТ Украина, производитель инструментов. 30 тыс. Наверно УПП или что похуже - УТП.
- еще одна галера ИТ-фабрика, 40 в потолке.
- ювелирные магазины ищут программиста-консультанта на 25 тыс.
- Адамакс, оптовая торговля, дистрибьюция - ищет младшего специалиста-падавана под присмотр ведущего программиста, 20 тыс.
- Розетка. 52 тыс. Но зато какие требования! Между прочим, довольно интересный там зоопарк технологий.

Это Киев. Учитывая стоимость съемного жилья в Киеве и Одессе - они на равных.

Дальше.
- ломбард Благо - 40 тыс на УТ. Каждые 3-4 месяца эта вакансия висит месяц
- ТПК Алеф - х.з. что там, тоже 40 тыс.
- АВК - кондитерский концерн. Последний раз видел от них вакансию в мае, повторно в июле. УПП, 45 было тогда. Сейчас не пишут.
- завод меллопластиковых окон как-то вяло ищет на 20 тыс, может найдется студент из Одессы, который месяца 3 поработает на 12 с бесплатными обедами и найдет ту вакансию
- дальше какие-то ФОПы ищут в Полтаву и Киев по 15 и 17 тыс, скорее всего субподряд на распилы.
- торговая компания Будпостач - 40 тыс

Вот откуда эти деньги?
Да просто кто жмется, кто не жмется.

Если бы у нас была экономика стабильная как в Германии, Чехии, Польще, то и знали бы, что, например, рабочий на заводе - 20-22 тыс в месяц получает, программист 25-30, инженер на заводе до 40 и т.д. В любом городе, на любом заводе.
Вкруговую примерно одинаковые цены на рабочую силу.

А пока мы наблюдаем местами нормальных контор, и пока еще много охреневших бояр, считающих "да я вот вам, мерзким людишкам, РАБОТУ ДАЮ!!!!1111адын"
awp, cos12, Мичман Харитонов,
07.10.18, 9:53 Программист 1С, Одесса
-тся/-ться,

Я нанимаю Вас на 8000 грн, это аж в 2 раза дороже минимальной зарплаты.
awp,
03.10.18, 9:36 Как Свернуть даные по нескольким значениям группировочных колонок
Цитата(Sirius83 @ 03.10.18, 0:29) *
Например Строка Код 33 должна включать в себя 34 и 37.

Добавьте свою новую колонку, куда для строк с кодами 33, 34 и 37 будете помещать условный идентификатор "Код33", а для остальных - их обычный. Потом эту колонку включить в свертку вместо той, по которой сейчас сворачивается.

Как пример: в цикле перебрать все строки таблицы и прописать:

ТЗ.ДобавитьКолонку("ГруппировкаКод");
...
цикл по перебору ...

    Если Код = 33 Или Код = 34 Или Код = 37 Тогда
        СтрокаТЗ.ГруппировкаКод = "33";
        СтрокаТЗ.Вид = "Вина виноградні";
    Иначе
        СтрокаТЗ.ГруппировкаКод = СтрокаТЗ.Код;
    КонецЕсли;

КонецЦикла;

// Было: (как пример)
//ТЗ.Свернуть("Код, Вид", "НачОстаток, реализация1, реализация2, реализация3");

// Заменить на:
ТЗ.Свернуть("ГруппировкаКод, Вид", "НачОстаток, реализация1, реализация2, реализация3");


Затем отсортировать и вывести таблицу.

Но это если просто свернуть.
А если свернуть по группировке, сохраняя данные вложенных строк (34 и 37), то надо подумать чуть больше.
Sirius83,
28.09.18, 13:22 Получить две последние цены товара
Смотрите, пользуйтесь.

ВЫБРАТЬ
    Номенклатура.Ссылка КАК Номенклатура
ПОМЕСТИТЬ втНоменклатура
ИЗ
    Справочник.Номенклатура КАК Номенклатура
ГДЕ
    Номенклатура.Родитель = &Родитель
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ЦеныНоменклатуры.Период КАК Период,
    ЦеныНоменклатуры.Активность,
    ЦеныНоменклатуры.ТипЦен,
    ЦеныНоменклатуры.Номенклатура КАК Номенклатура,
    ЦеныНоменклатуры.Цена КАК Цена
ПОМЕСТИТЬ втЦеныНоменклатуры
ИЗ
    РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
ГДЕ
    ЦеныНоменклатуры.Период <= &ДатаПолученияЦен
    И ЦеныНоменклатуры.Активность
    И ЦеныНоменклатуры.ТипЦен = &ТипЦен
    И ЦеныНоменклатуры.Номенклатура В
            (ВЫБРАТЬ
                втНоменклатура.Номенклатура
            ИЗ
                втНоменклатура КАК втНоменклатура)
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    втНоменклатура.Номенклатура КАК Номенклатура,
    ЕСТЬNULL(втЦеныНоменклатуры.Цена, 0) КАК ПоследняяЦена,
    ЕСТЬNULL(втЦеныНоменклатуры.Период, ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)) КАК ДатаПосленейЦены
ПОМЕСТИТЬ втПоследняяЦена
ИЗ
    втНоменклатура КАК втНоменклатура
        ВНУТРЕННЕЕ СОЕДИНЕНИЕ втЦеныНоменклатуры КАК втЦеныНоменклатуры
        ПО втНоменклатура.Номенклатура = втЦеныНоменклатуры.Номенклатура
            И (втЦеныНоменклатуры.Период В
                (ВЫБРАТЬ ПЕРВЫЕ 1
                    втЦеныНоменклатуры.Период КАК Период
                ИЗ
                    втЦеныНоменклатуры КАК втЦеныНоменклатуры
                ГДЕ
                    втЦеныНоменклатуры.Период <= &ДатаПолученияЦен
                    И втЦеныНоменклатуры.Номенклатура = втНоменклатура.Номенклатура
                УПОРЯДОЧИТЬ ПО
                    Период УБЫВ))
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    втПоследняяЦена.Номенклатура КАК Номенклатура,
    втПоследняяЦена.ПоследняяЦена КАК ПоследняяЦена,
    втПоследняяЦена.ДатаПосленейЦены КАК ДатаПосленейЦены,
    ЕСТЬNULL(втЦеныНоменклатуры.Цена, 0) КАК ПредпоследняяЦена,
    ЕСТЬNULL(втЦеныНоменклатуры.Период, ДАТАВРЕМЯ(1, 1, 1, 0, 0, 0)) КАК ДатаПредпоследнейЦены
ИЗ
    втПоследняяЦена КАК втПоследняяЦена
        ЛЕВОЕ СОЕДИНЕНИЕ втЦеныНоменклатуры КАК втЦеныНоменклатуры
        ПО втПоследняяЦена.Номенклатура = втЦеныНоменклатуры.Номенклатура
            И (втЦеныНоменклатуры.Период В
                (ВЫБРАТЬ ПЕРВЫЕ 1
                    втЦеныНоменклатуры.Период КАК Период
                ИЗ
                    втЦеныНоменклатуры КАК втЦеныНоменклатуры
                ГДЕ
                    втЦеныНоменклатуры.Период < втПоследняяЦена.ДатаПосленейЦены
                    И втЦеныНоменклатуры.Номенклатура = втПоследняяЦена.Номенклатура
                УПОРЯДОЧИТЬ ПО
                    Период УБЫВ))

УПОРЯДОЧИТЬ ПО
    Номенклатура,
    ДатаПосленейЦены,
    ДатаПредпоследнейЦены
АВТОУПОРЯДОЧИВАНИЕ


В результате будет таблица с последними двумя ценами номенклатуры с указанием дат установки цены.

Если надо сгруппировать по товару, то просто в последнем подзапросе таблицы не соединять, а объединять и потом сгруппировать по номенклатуре.

cos12,
26.09.18, 9:14 Подключение магнитного ридера для 1С
Цитата(SeverinPasha @ 25.09.18, 10:06) *
Но лично меня сйчас больше интересует программный код для работы считки с 1с.

Считыватели могут работать по-разному.
- Один будет постоянно слать в ком-порт своё состояние:
- нули если нет ничего;
- номер карты (тот самый серийный номер из 13 символов);
- ИЛИ данные карты (та цифра в формате ХХХ,ХХХХХХ);
- Другой будет слать однократно только при изменении состояния:
- либо 0 либо номер карты
- Третий будет слать, но ему надо в ком-порт отправить некую команду
(хорошо, если это RS232, хуже если это Dallas или RS485 - те заточены для обмена данными железяками напрямую без компьтера).

Для "отладки" работы с такими железяками я просто в ардуинку заливал скетч, который понимал набор команд из документации производителя и выдавал ответ в соответствии с документацией.
Потом спокойно писал обработку работы с данным типом весов, чтобы не сидеть в весовой и не мешать людям работать.

Так что нужна марка, модель чтобы по нему найти документацию.
Да и прозвонить разработчикам чтобы получить консультацию, или написать на сайте производителя или дилера дело нехитрое.

Это лирика.

Цитата(awp @ 25.09.18, 10:09) *
Думаю ПО есть, но оно платное.

Или закрытое, и заточено только на непосредственную запись данных карточек в память контролера считывателя.

Цитата(andr_andrey @ 25.09.18, 9:39) *
У нас тоже был настроен для обмена по COM-порту, но предварительно настраивал техник, после этого тупо опрос по протоколу описанному в документации.

Кстати, да.
Несколько раз встречал оборудование, которое можно перенастроить на обмен по разным протоколам.
Как пример: автомобильные весы постоянно слали в порт "поток сознания", пара нажатий кнопок, выбор режима настройки, и они шлют данные только по запросу "GW".
Но это если производитель такую фишку предусмотрит.

Цитата(SeverinPasha @ 25.09.18, 10:28) *
А поделиться из солидарности Вы конечно же не сможеТЕ?)))

Конечно, могу. Но не имею права распространять готовый продукт - я подписал соглашение с работодателем.

Могу написать, как делал, привести пример кода. А целиком системы у меня нет, не имею такой привычки. Могу на досуге порыться в архиве своих заметок или на форумах и снова найти информацию.



Если есть конкретный вопрос, я дам конкретный ответ и постараюсь помочь решить эту проблему.
Такой вариант устроит?
andr_andrey, SeverinPasha,
30.08.18, 9:44 Редактирование процедуры в модуле объекта документа не изменяет
Цитата(Oleksa_Kan @ 30.08.18, 9:51) *
не нажал "Обновить конфигурацию баз данных".

Цитата(Vladal @ 30.08.18, 8:40) *
Навскидку - Вы сделали это в своей копии базы.

О!
Я был почти у цели.
... теряю навыки, старею...
Oleksa_Kan,
30.08.18, 7:40 Редактирование процедуры в модуле объекта документа не изменяет
Навскидку - Вы сделали это в своей копии базы.
Либо если еще вызов в других местах.
Поищите текст Документы.ЗаказПоставщику.Создать.
Может, подписка срабатывает.

Скоро смогу открыть УТП и посмотреть, что там такое.
Oleksa_Kan,
02.08.18, 12:24 УТП. Документ Ввод в эксплуатацию ОС не списывает партии
Разобрался.

Причина: Поступившее оборудование записали в ТЧ Товары, а надо было в ТЧ Оборудование. Хотя и вид операции документа был Оборудование.

Решение: доработал ПТиУ так, чтобы при выборе операции Оборудование номенклатура с видом номенклатуры Оборудование переносилась из ТЧ Товары в ТЧ Оборудование.
Добавил соответствующие проверки номенклатуры для ТЧ Товары и Оборудование, как в типовой проверке ТЧ Услуги.

Vofka,
07.07.17, 16:55 "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
Цитата(Acid @ 06.07.17, 10:36) *
Ну если вспомнить как в этот медок, можно сказать "примусово" загоняли различными методами, и при поддержке властей.

И при поддержки тех, неправильных властей.
Цитата(Acid @ 06.07.17, 11:59) *
Причина банальна - передел кормового места.

Есть мнение, что "медок" принадлежит бывшему в 2012 году министру доходов и сборов. Я сам лично не видел документы, но версия звучит убедительно.
XBrut,
29.11.16, 16:36 Необходимо получить основную единицу измерения в отчет
Сильно доработанная УПП? Наверно, еще древнего релиза, без этих единиц. Но не это суть.

Как можно однозначно определить, какую из множества единиц измерения конкретной номенклатуры использовать сейчас?
Может, это Номенклатура.БазоваяЕдиницаИзмерения?
Как вы сами определяете, какую из единиц брать?

Зная ответ на этот вопрос можно будет и научить запрос выбирать эту единицу.

Откройте форму элемента номенклатуры и посмотрите на единицы измерения под наименованием и артикулом, и на вкладке "Единицы".
У меня в УПП в списке на вкладке "Единицы" строка с единицей хранения остатокв выделена жирным.
AldemaH,
29.11.16, 13:25 Необходимо получить основную единицу измерения в отчет
AldemaH @ Сегодня, 12:55 * , AldemaH @ Сегодня, 12:55 * ,
Цитата(AldemaH @ 29.11.16, 12:55) *
в отчет по продажам нужно получить общий вес проданной продукции.

Конечно, будут все единицы присоединяться -- они же просто присоединены к номенклатуре. Будет несколько единиц - все и попадут в соединение.

В типовых у номенклатуры есть ЕдиницаХраненияОстатков. Вот её и надо использовать.

Как вариант:
...
    ЕдиницыИзмерения.Вес как ЕдВес,
    ПродажиОбороты.КоличествоОборот * ЕдиницыИзмерения.Вес КАК ОбщийВес
ИЗ
    РегистрНакопления.Продажи.Обороты(&ДатаНачала, &ДатаКонец, Авто, ) КАК ПродажиОбороты
    ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
        ПО ПродажиОбороты.Номенклатура = ЕдиницыИзмерения.Владелец
                    И ПродажиОбороты.Номенклатура.ЕдиницаХраненияОстатокв = ЕдиницыИзмерения.Ссылка

Таким образом получим вес товара в указанных единицах:
ПродажиОбороты.КоличествоОборот * ЕдиницыИзмерения.Вес * ЕдиницыИзмерения.Коэффицицент

1000 попугаев * 0,080 кг * 1 = 80 кг

Хотя, по идее, надо пересчитать из единицы хранения остатков в единицы отчета, используя коэффициенты этих единиц по формуле:

Регистр.Количество / (едХраненияОстатков.Коэффициент * едОтчетов.Коэффициент)

p.s. Что такое "гр"? граммы обозначаются "г", гривны обозначаются "грн". "гр" - грибы?
AldemaH,
29.08.16, 15:29 Начисление отпуска организаций - в расчете календарных дней по среднему попадают дни отпуска за свой счет
Цитата(andr_andrey @ 22.08.16, 11:16) *
Vladal @ 19.08.16, 17:41 *,
Идеально - исправление поставщиком конфигурации.
Поставкой обновления и обновлялись.
Написали в 1С, получили ответ, что в некоторых случаях табель может отражать некоторые невыходы, и при расчетах они будут отражаться верно.
но лучше использовать документ НевыходыВОрганизации.

Решили изменением запроса.
Vofka,
27.07.16, 8:44 Продажники 1С, Специалисты техподдержки, программисты
Цитата(anatol_ua @ 20.07.16, 13:10) *
1. Менеджер по продажам 1С, Киев
6000-12000 грн
возраст от 25 до 40 лет;
пол любой;

2. Технический специалист по 1С (консультант), Киев
5000-8000 грн
возраст от 25 до 40 лет;
пол любой;

3. Программист 1С, Киев
6000-12000 грн
возраст от 25 до 40 лет;
пол любой;

Остальные подробности - на собеседовании, которое проводят менеджер по персоналу и коммерческий директор.

Резюме отправлять на адрес vakans_centerit@ukr.net

1. Очень маленькие зарплаты. Разве что для студентов, живущих вместе с родителями в родительскойц квартире и питаются за их счет.
2. Ограничение по возрасту законно? хотя ничего не мешает "старикам после 40 лет" отказывать по надуманным причинам, типа нашли более успешного кандидата.
3. Адрес на UKR.NET говорит о том, что "крупная компания возьмет в аренду степлер".
4. Зарплата - это грязными? вместе с НДФЛ и сборами или еще и вместе с ФОТ? Все остальное "при личной беседе с финдиректором" или как там, настораживает.
cos12,
19.07.16, 8:50 Некорректное отображение нац.символов в базе sql после экспорта данных из 1с
Цитата(andrew76 @ 14.07.16, 11:31) *
Наконец-то форум ожил...Проблема решилась применением инструкции N' перед строковым параметром:
помогаешь им тут... а они через три дня приходят и попрекают...

Цитата(andrew76 @ 14.07.16, 11:31) *
Фрагмент кода:
ТекстЗапросаADO ="Insert into tbQarindosh (MainID,Lastname,Firstname,Patronymic,Qarindoshligi,DataRoj,
MestoRoj_country,IshJoyi,BirthTown,YashashJoyi) Values ('" + un + "',N'"+Фам_род+"',.....)

Должно работать с символами национальных алфавитов (Узбекистан,Казахстан,Киргизия,Туркмения) на основе кирилицы.

Привёл бы сразу этот код из 1С, Вам бы сразу и помогли.
Цитата(andrew76 @ 11.07.16, 8:38) *
После заливки данных в базу sql через 1С 8.2 в базе sql некорректно отображаются символы нац.алфавита.


Есть ведь разница между сферическим "После заливки данных в базу sql через 1с 8.2 в базе sql некорректно отображаются символы нац. алфавита." - неизвестно, Вы их там льёшь и конкретным "Insert into ... Values (N'" + un + "', N'"+Фам_род+"'..."
andrew76,
11.07.16, 14:41 Булево в таблице значений
Добавлю один из своих шаблонов:

// Определение флажка в колонке "Пометка"
Пометка = ЭлементыФормы.ТабличнаяЧасть.Колонки.Пометка;
Пометка.Видимость = Истина;
Пометка.Ширина = 3;
Пометка.ТекстШапки = "";
Пометка.Данные = "";
Пометка.ДанныеФлажка = "Пометка";
Пометка.РежимРедактирования = РежимРедактированияКолонки.Непосредственно;
Пометка.ИзменениеРазмера = ИзменениеРазмераКолонки.НеИзменять;


Разумеется, в табличной части, связанной с этим табличным полем должна быть колонка "Пометка".
Примерно так:

ТабличнаяЧасть = документОбъект.ТабличнаяЧасть.Скопировать();
ТабличнаяЧасть.Колонки.Вставить(0, "Пометка", Новый ОписаниеТипов("Булево"));
dqwerty,
23.11.15, 10:06 Установка Рабочей даты работы с документами
Цитата(Нонна @ 21.11.15, 15:38) *
А вообще в 1С открываю для себя каждый день что-то новое.
В таком случае посоветую Вакм прочитать книжку из коробки "Руководство пользователя" - по платформе и вторую - с названием конфигурации. например "Управление производственным предприятием" или "Управление торговлей" и т.д. Либо пройти пользовательские курсы в учебном центре.
Нонна,
21.11.15, 8:09 Установка Рабочей даты работы с документами
Добрый день! Хочу поделиться с вами одной очень удобной примочкой: если нажать alt-f2, то появится калькулятор!

Добрый день! Хочу поделиться с вами одной очень удобной примочкой: если нажать на клавиатуре ctrl-f, то в восьмёрке появится окно поиска, а в семерке для этого нажмите ctrl-f3.

Добрый день! Хочу поделиться с вами одной очень удобной примочкой: если прочитать руководство пользователя, то там не только про "рабочую дату" можно прочитать, но и про то, что -- это просто невероятно! -- что некоторые документы можно вводить на основании других и даже можно просто в документе выбрать документ-основание и нажать кнопку "заполнить по основанию" и он заполнится! И не надо будет вводить каждый раз все строки заново!

Добрый день! Хочу поделиться с вами одной очень удобной примочкой: если в списке документов или справочника нажать f9, то появится новый точно такой же документ или справочник и даже иногда у них будут совпадать все реквизиты!


Давайте больше таких статей и новостей!

Потому что даже некоторые разработчики не знают различие между "рабочей датой" и "текущей" и всегда заполняют новые реквизиты для пакетного ввода функцией ТекущаяДата() и тогда хоть трижды установите "рабочую дату" концом прошлого месяца, а реквизит будет заполняться системной.
Ну да, в таком случае можно сменить дату компьютера. Если пользователь с админскими правами в операционке.
Acid,
06.10.09, 9:12 Поддержите меня.
> Та ну. Какая прибыль диджусу от ихних же смс-ок?
Минимум, Абонент тратит деньги, а потом вынужден пополнять свой счет.

>И когда Вы все успеваете!
>Утром, перед работой
А у меня утренний ... м-м-м ... Жена утром теплая, ласковая ...
+1 с номера +380989381732
Vofka,

RSS Текстовая версия Сейчас: 16.12.18, 15:19
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне