Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

320 страниц V   1 2 3 > » 

>  Вложенный отчет по Контрагентам и Продажам с отбором
logist
Отправлено: Сегодня, 15:26


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Constantus @ 24.05.17, 18:21) *
как теперь сделать, чтобы при отборе номенклатуры, также высвечивались все товары по точке, независимо от того, продавались товары или нет...

Как-то так (работоспособность не проверялась)

ВЫБРАТЬ
    ДвиженияНоменклатуры.Склад,
    ДвиженияНоменклатуры.Номенклатура,
    ДвиженияНоменклатуры.ХарактеристикаНоменклатуры,
    ДвиженияНоменклатуры.КоличествоОстаток,
    ПродажиНоменклатуры.Контрагент,
    ПродажиНоменклатуры.КоличествоПродажи
ИЗ
    (ВЫБРАТЬ
        Склады.Ссылка КАК Склад,
        ВложенныйЗапрос.Номенклатура КАК Номенклатура,
        ВложенныйЗапрос.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
        ВложенныйЗапрос.Количество КАК КоличествоОстаток
    ИЗ
        Справочник.Склады КАК Склады
            ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
                ТоварыНаСкладахОстатки.Склад КАК Склад,
                ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура,
                ТоварыНаСкладахОстатки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
                ЕСТЬNULL(ТоварыНаСкладахОстатки.КоличествоОстаток, 0) КАК Количество
            ИЗ
                РегистрНакопления.ТоварыНаСкладах.Остатки(&КонецПриода, ) КАК ТоварыНаСкладахОстатки
            
            ОБЪЕДИНИТЬ
            
            ВЫБРАТЬ
                ТоварыНаСкладахОбороты.Склад,
                ТоварыНаСкладахОбороты.Номенклатура,
                ТоварыНаСкладахОбороты.ХарактеристикаНоменклатуры,
                ЕСТЬNULL(ТоварыНаСкладахОбороты.КоличествоОборот, 0)
            ИЗ
                РегистрНакопления.ТоварыНаСкладах.Обороты(&НачалоПриода, &КонецПриода, , ) КАК ТоварыНаСкладахОбороты) КАК ВложенныйЗапрос
            ПО Склады.Ссылка = ВложенныйЗапрос.Склад) КАК ДвиженияНоменклатуры
        ПОЛНОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
            Контрагенты.Ссылка КАК Контрагент,
            ПродажиОбороты.Номенклатура КАК Номенклатура,
            ПродажиОбороты.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
            ЕСТЬNULL(ПродажиОбороты.КоличествоОборот, 0) КАК КоличествоПродажи
        ИЗ
            Справочник.Контрагенты КАК Контрагенты
                ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.Продажи.Обороты КАК ПродажиОбороты
                ПО (ПродажиОбороты.Контрагент = Контрагенты.Ссылка)) КАК ПродажиНоменклатуры
        ПО ДвиженияНоменклатуры.Номенклатура = ПродажиНоменклатуры.Номенклатура
            И ДвиженияНоменклатуры.ХарактеристикаНоменклатуры = ПродажиНоменклатуры.ХарактеристикаНоменклатуры
  Форум: Система компоновки данных · Просмотр сообщения: #127610 · Ответов: 6 · Просмотров: 192
 

>  Потрібно акт інвентар. ОЗ та Інв. картка ОЗ
logist
Отправлено: Сегодня, 14:41


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Злюка545 @ 24.05.17, 13:47) *
Можна десь скачати файли?

Что значит файлы? Вам нужны просто файлы макетов печатных форм, или вам нужно прикрутить их в уже имеющиеся документы, или у вас и документов нет из которых они должны печататься?
  Форум: Платформа 7.7 · Просмотр сообщения: #127609 · Ответов: 1 · Просмотров: 129
 

>  Ползунок вертикальной прокрутки
logist
Отправлено: Сегодня, 14:38


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(andr_andrey @ 25.05.17, 14:19) *
Просто динамический список ассоциируется с управляемыми формами

У программиста, пользователь может это называть как угодно.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #127608 · Ответов: 8 · Просмотров: 177
 

>  Хранение цвета в реквизите справочника
logist
Отправлено: Сегодня, 14:31


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Учитывая что платформа 8.2, списал бы это на неё, потому, что она хранит пользовательские настройки в файлах, и возможно окрашивание не происходит потому что по какой-то причине не прочитался файл. Плюс - это Рарус, а там могут быть какие-то свои приколы, например при открытии формы выполняется какая-то внешняя компонента, которая, при каких-то условиях, чхала на вашу раскраску smile.gif
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #127607 · Ответов: 12 · Просмотров: 565
 

>  ПКО не формируется на основании Отчета о розничных продажах
logist
Отправлено: Сегодня, 14:21


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Как вариант - не было оплат за наличные. Без видимости исходных данных - дать какой-то конкретный ответ невозможно, покажите хотя бы скрин отчета, первой и второй вкладки.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #127606 · Ответов: 1 · Просмотров: 79
 

>  требуется программист 1С 8.1, Киев;
logist
Отправлено: Сегодня, 14:19


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(UkrStaff @ 26.05.17, 14:47) *
Заработная плата: 20000-25000 грн.

Цитата(UkrStaff @ 26.05.17, 14:47) *
высокий уровень заработной платы (по результату собеседования);

Взаимоисключающие вещи.

Уточните, вы ищите для своей организации, или для другой, если другой - то какой?

Цитата(UkrStaff @ 26.05.17, 14:47) *
Условия собеседования: телефонное интервью (первый этап)

А второй этап, третий...?
  Форум: Предложения работы · Просмотр сообщения: #127605 · Ответов: 1 · Просмотров: 120
 

>  "1С:Підрядник будівництва 4.0. Керування фінансами"
logist
Отправлено: Сегодня, 13:37


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Не надо создавать одинаковые темы в разных разделах!
  Форум: Корзина · Просмотр сообщения: #127604 · Ответов: 1 · Просмотров: 70
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 23.05.17, 17:40


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 23.05.17, 17:17) *
и как все просто оказывается.

учитесь правильно объяснять задачи, без кучи хрени которой вы сопровождаете свои тексты.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127351 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 23.05.17, 15:40


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 23.05.17, 16:25) *
Платформа 8.2.

Тогда всё просто
&НаКлиенте
Процедура КнопкаДобавитьСтроку(Команда)
    ВыбранноеЗначение = ОткрытьФормуМодально("Справочник.ТОЧКА_тест1.ФормаВыбора",,ЭтаФорма);
    Если ВыбранноеЗначение <> Неопределено Тогда
        НоваяСтрока = Объект.Таб_Точка.Добавить();
        НоваяСтрока.Реквизит2 = ВыбранноеЗначение;    
        // здесь попутно заполняем РЕквизит1
    КонецЕсли;    
КонецПроцедуры
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127334 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 23.05.17, 15:08


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 23.05.17, 15:19) *
И реагирует так:

Извиняюсь, не заменил что тема про платформу 8.2, там действительно такого нет. Озвучьте версию вашей платформы, а так же включена ли поддержка модальных окон (вдруг платформа 8.3.х.х)
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127332 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 23.05.17, 12:46


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


&НаКлиенте
Процедура КнопкаДобавитьСтрокуОбработка(ВыбранноеЗначение, ДопПараметры) Экспорт
    Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда
        НоваяСтрока = Объект.Таб_Точка.Добавить();
        НоваяСтрока.Реквизит2 = ВыбранноеЗначение;    
        // здесь попутно заполняем РЕквизит1
    КонецЕсли;    
КонецПроцедуры

&НаКлиенте
Процедура КнопкаДобавитьСтроку(Команда)
    Оповещение = Новый ОписаниеОповещения("КнопкаДобавитьСтрокуОбработка", ЭтаФорма);
    ОткрытьФорму("Справочник.ТОЧКА_тест1.ФормаВыбора",,ЭтаФорма,,,,Оповещение);
КонецПроцедуры


Только не используйте стандартную команду добавить строку в ТЧ, создайте отдельную команду обработчик которой будет КнопкаДобавитьСтроку
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127322 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 23.05.17, 0:59


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 23.05.17, 1:30) *
Под переменной "ЗначениеКотороеСодержитСсылку" имеется ввиду какая нибудь константа наименования созданного и существующего элемента списка?

Под переменной имеет ввиду ссылка на ваш справочник, как её получить в эту переменную я не могу догадаться до сих пор, потому что из рассказов не могу ничего понять.
Выложите скрины метаданных, стрелочками укажите что куда должно попадать.

  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127302 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 22.05.17, 23:44


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 23.05.17, 0:27) *
я просто удивляюсь почему я опять не понят

потому что вы пишите кучу бесполезного текста который сбивает с толку, вместо того что бы четко описать задачу и предоставить какие-то исходные метаданные.

Цитата(Gigi @ 23.05.17, 0:27) *
ПРИСВОИТЬ КОНКРЕТНОЕ УКАЗАННОЕ В КОДЕ ЗНАЧЕНИЕ ССЫЛКИ!!!! ДА... ЗНАЧЕНИЕ ССЫЛКИ ... ВСЕГО ЛИШЬ ... и ничего сверх того!

Элементы.Таб_Точка.ТекущиеДанные.Реквизит2 = ЗначениеКотороеСодержитСсылку;
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127274 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 22.05.17, 17:17


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 22.05.17, 18:11) *
ЧТО ТУТ НЕ ПОНЯТНОГО?

Вообще нихрена не понятно, до сих пор. Из того что понятно можно предположить, что-то такое, но если это добавление новой строки - работать не будет, т.к. не понятна задача в целом.

&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаОбъекта(вхОбъект)
    Возврат вхОбъект.ОбъектПринадИмя;    
КонецФункции

&НаКлиенте
Процедура ФормаОткрытиеОбработка(СсылкаРеузльтат, СтрокаТЧ) Экспорт
    Если ЗначениеЗаполнено(СсылкаРеузльтат) И СтрокаТЧ <> Неопределено Тогда
        // Либо СсылкаРеузльтат это и есть ссылка на выбранный справочник
        СтрокаТЧ.ИмяРеквизитаКоторомуНадоПрисвоить = ПолучитьЗначениеРеквизитаОбъекта(СсылкаРеузльтат);
    КонецЕсли;    
КонецПроцедуры

&НаКлиенте
Процедура ФормаОткрытие()
    СтрокаТЧ = Элементы.Таб_Точка.ТекущиеДанные;
    Оповещение = Новый ОписаниеОповещения("ФормаОткрытиеОбработка", ЭтаФорма, СтрокаТЧ);
    
    Если СтрокаТЧ = Неопределено Тогда
        ОткрытьФорму("Справочник.ТОЧКА_тест1.ФормаОбъекта",,ЭтаФорма,,,,Оповещение);
    Иначе
        ОткрытьФорму("Справочник.ТОЧКА_тест1.ФормаОбъекта",Новый Структура("Ключ", СтрокаТЧ.Точка),ЭтаФорма,,,,Оповещение);
    КонецЕсли;
КонецПроцедуры


Цитата(Gigi @ 22.05.17, 18:11) *
Мне просто нужно так же Вголопить просто ТЕКСТ в реквизит ссылки.
ПРОСТО ВКЛИНИТЬ ТЕКСТ!

Не понимаю что это значит. Кто-то понимает?

Это что-то типа: я несу на тарелке помидор, но это должен быть огурец?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127270 · Ответов: 22 · Просмотров: 502
 

>  Программно выбрать ссылку для строки табличной части справочника
logist
Отправлено: 22.05.17, 16:35


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Gigi @ 22.05.17, 16:09) *
И текст наименования выбранного вставляется в реквизит ссылки.

Не понятно, если у вас поле содержит ссылку как вы туда текст вставите, и зачем его вставлять? Честно, прочитал несколько раз, так и не понял что же надо сделать.

Цитата(Gigi @ 22.05.17, 17:24) *
Не знаю, на сколько правильный путь, но не сработало.

И не сработает, потому что вы Предопределенное значение это что-то что уже предопределено в конфигурации, а не значение какого-то реквизита, в этой функции не может быть более двух точек, и после второй должно быть наименование предопределенного элемента а не реквизит.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #127267 · Ответов: 22 · Просмотров: 502
 

>  Редактирование макета Заказ покупателя
logist
Отправлено: 22.05.17, 12:14


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Inna-14 @ 22.05.17, 12:32) *
Я просто не понимаю, где можно настроить

Что значит настроить? Выборка шапки документа должна получать комментарий (или как там у вас реализовано), в макете должно быть поле с параметром идентичный названию поля в выборке, и где-то в коде он должен заполнятся.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #127257 · Ответов: 10 · Просмотров: 333
 

>  "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
logist
Отправлено: 21.05.17, 20:52


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Что-то эти украинские разработки не не шибко развились (если развились вообще), а в начале 2014-го только ленивый не пробовал запустить соцсеть "заменитель".
  Форум: Офф-топик · Просмотр сообщения: #127234 · Ответов: 279 · Просмотров: 9347
 

>  Редактирование макета Заказ покупателя
logist
Отправлено: 21.05.17, 16:02


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(ВАТРИЧЪ @ 20.05.17, 12:31) *
но здесь нет такой возможности.

Возможность есть, почитайте правила.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #127229 · Ответов: 10 · Просмотров: 333
 

>  Надо изменить ограничение на максимально допустимый размер файла (50 мб)
logist
Отправлено: 21.05.17, 16:00


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Sudo @ 20.05.17, 9:18) *
При попытке добавить файл

Куда добавить?
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #127228 · Ответов: 3 · Просмотров: 263
 

>  "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
logist
Отправлено: 19.05.17, 16:13


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(onsamuy @ 19.05.17, 16:25) *
Еще один дебил

Это лишь подтверждение того, что большинство т.н. "ассоциаций" кого либо - просто сборище людей которые нифига не разбираются в предмете своей ассоциации. К тому же, человек который представляет разработчиков ПО говорит такое про частоту обновлений - просто абсурд, именно поэтому национального ПО нет, потому что оно нифига не развивается под такими ассоциациями.
  Форум: Офф-топик · Просмотр сообщения: #127182 · Ответов: 279 · Просмотров: 9347
 

>  помощь в написании кода в процедуре ПриИзменении
logist
Отправлено: 19.05.17, 13:54


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Вы упорно не хотите читать правила. Тема уезжаете в корзину.
  Форум: Корзина · Просмотр сообщения: #127174 · Ответов: 1 · Просмотров: 67
 

>  Не могу добавить инвентарный номер необоротного актива
logist
Отправлено: 19.05.17, 12:59


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Юля @ 19.05.17, 12:04) *
Это бухгалтер видет так учет

Бухгалтер не правильно ведет учет, инвентарных номеров с дробью не должно быть.
Методика присвоения инвентарных номеров описана в методических рекомендация по ведению учета основных средств утвержденной приказом минфина №11 от 23.01.2015, в разделе 2, пункты 3-5, и для субъектов государственного сектора это является обязательным.
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #127169 · Ответов: 6 · Просмотров: 255
 

>  "Вконтакте", "Одноклассники", "Яндекс" та "1С" заблокують - указ Порошенка
logist
Отправлено: 18.05.17, 15:13


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Vofka @ 18.05.17, 16:08) *
Браузеру Опера пофиг на блокировки

Любому браузеру который использует "ускоритель" (и т.п. режимы), т.е. обрабатывает запрос через свои сервера - пофиг на эти блокировки.
  Форум: Офф-топик · Просмотр сообщения: #127086 · Ответов: 279 · Просмотров: 9347
 

>  Конфигурация " с нуля" - законность использования/продажи
logist
Отправлено: 18.05.17, 14:31


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Мичман Харитонов @ 18.05.17, 15:30) *
А польская лицензия у нас действует, или она только для Польши?

Лицензия действует на программный продукт, остальное не важно.
  Форум: Офф-топик · Просмотр сообщения: #127076 · Ответов: 11 · Просмотров: 418
 

>  Конфигурация " с нуля" - законность использования/продажи
logist
Отправлено: 18.05.17, 14:20


Про1С-ник
Иконка группы

Группа: Команда
Сообщений: 8690
Регистрация: 07.07.09
Из: Харьков
Пользователь №: 961


Цитата(Мичман Харитонов @ 18.05.17, 14:55) *
"Технологическая платформа", допустим, есть, была легально куплена.

Есть есть легально купленная среда разработки - то можете легально продавать свою конфигурацию.
  Форум: Офф-топик · Просмотр сообщения: #127067 · Ответов: 11 · Просмотров: 418
 

320 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 28.05.17, 20:28
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне