Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

12 страниц V   1 2 3 > » 

>  Игнорируется ограничение прав.
Vladal
Отправлено: Сегодня, 8:34


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Schlesinger @ Вчера, 16:36 * ,
Откройте в Конфигураторе эту роль, проверьте ее свойства - какие права на документы.
И убедитесь, что у пользователя (в режиме конфигуратора) только эта роль.
  Форум: Вся 1С · Просмотр сообщения: #154854 · Ответов: 2 · Просмотров: 49
 

>  Консоль запросов 1С 8 / SQL
Vladal
Отправлено: Сегодня, 7:22


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


sertak @ Вчера, 13:50 * ,
Всю интригу сломали.
  Форум: Отчеты / Обработки · Просмотр сообщения: #154852 · Ответов: 8 · Просмотров: 271
 

>  Проблема отображения записей в справочнике через RLS (1c 8.2.19.106)
Vladal
Отправлено: Вчера, 10:54


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(andrew76 @ 19.08.19, 11:35) *
Только сейчас RLS блокирует весь справочник у пользователя

А если чтение сделать на конкретное поле с адресом?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #154813 · Ответов: 10 · Просмотров: 109
 

>  Проблема отображения записей в справочнике через RLS (1c 8.2.19.106)
Vladal
Отправлено: Вчера, 10:30


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(andrew76 @ 19.08.19, 11:22) *
надо именно отдельные записи (вернее отдельные реквизиты) в справочнике ФизЛица.

ОК.

А адреса тоже хранятся в справочнике физлиц?
Тогда РЛС на реквизит. В настройках прав на право Чтение выбрать проверяемые поля. Например, Адрес (если он хранится в справочнике Физлица) и справа условие, по которому оно будет доступно.

Естественно, во всех запросах к чтения Адреса по этому справочнику добавить РАЗРЕШЕННЫЕ.

Честно, сейчас проверить нет возможности.

Но я писал RLS к документу, вычисляя его возможность чтения по сотруднику, его руководителю, чтобы руководитель подразделения видел только документы своих сотрудников.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #154810 · Ответов: 10 · Просмотров: 109
 

>  Курс расчетов отличный от курса системы
Vladal
Отправлено: Вчера, 10:24


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Первое, что приходит на ум - добавить РС.КурсВалютПоставщика.
Но это в моём контексте, так как мы пишем свою ИС для финансов.


Цитата(TamerLan.TK @ 17.08.19, 10:31) *
РКО платим по курсу поставщика 25,25 * 55 = 1388,75 грн (указываем в форме документа, Сумма расчетов / курс)
Рузьльтат: система всеравно пересчитывает по курсу 26 и светит долг пере поставщиком 1,59 USD (1388,75/26=53,41USD / 55-53,41=1,59)

А в документах этого контрагента можно вручную установить его курс валюты?
  Форум: 1С Управление небольшой фирмой для Украины · Просмотр сообщения: #154809 · Ответов: 1 · Просмотров: 44
 

>  Проблема отображения записей в справочнике через RLS (1c 8.2.19.106)
Vladal
Отправлено: Вчера, 10:18


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


andrew76 @ 17.08.19, 14:45 * ,
Не понятно, это типовая конфигурация? В типовых есть отдельный регистр сведений КонтактнаяИнформация, который и надо блокировать.
А так - блокируется таблица Справочник.Физлица

ФизЛица ГДЕ ФизЛица.ДоступРазрешен = 1          //(вариант если Тип реквизита Числовой)
ФизЛица ГДЕ ФизЛица.ДоступРазрешен = Истина  //(вариант если Тип реквизита Логический)
Это излишние условия, можно оставить только
ФизЛица ГДЕ ФизЛица.ДоступРазрешен
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #154806 · Ответов: 10 · Просмотров: 109
 

>  Запрос АПИ к Новой почте
Vladal
Отправлено: Вчера, 10:11


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Их демо-пример работает?

https://devcenter.novaposhta.ua/1c
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154805 · Ответов: 10 · Просмотров: 110
 

>  ЗУП 2.1 - Как оформить больничный и сразу за ним отпуск?
Vladal
Отправлено: 06.08.19, 15:04


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Кадровик говорит, что не получилось ни так, ни так.
Первый вариант, говорит, как у нас и был.

Жаль.
Будут править ручками табель.

Вообще, логичнее было ставить не "выход на работу" 06.08, а именно "окончание больничного" 05.08.
Тогда бы всё ок было, день на день бы не накладывался.

Видимо, бага. Кто там вхож к партнерам - отрапортуйте...
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #154450 · Ответов: 4 · Просмотров: 126
 

>  Публикация http сервиса windows server 2012 R2 x64 + IIS
Vladal
Отправлено: 06.08.19, 9:49


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Ставил по инструкции с Инфостарта, винда 64-битная. Сервис взлетел и работал непрерывно месяц, пока ходил на собеседования и показывал какой я молодец.

База публикуется, если запустить конфигуратор от имени администратора.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154442 · Ответов: 3 · Просмотров: 305
 

>  Консоль запросов 1С 8 / SQL
Vladal
Отправлено: 06.08.19, 9:47


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Игрался с внешними источниками недавно. Тоже добавил поле для запроса и поле для вывода и писал select'ы )))
  Форум: Отчеты / Обработки · Просмотр сообщения: #154441 · Ответов: 8 · Просмотров: 271
 

>  ЗУП 2.1 - Как оформить больничный и сразу за ним отпуск?
Vladal
Отправлено: 06.08.19, 9:27


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


ЗУП 2.1.

Сотрудник по приказу был отправлен в отпуск с 6.08.
Но с 1.08 по 5.08 был на больничном и оформили Невыход - 01.08 больничный, 06.08 - рабочий.

И теперь эти документы конфликтуют и не проводятся в любой очередности.

Как правильно сделать это в 1С? В какой последовательности?
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #154440 · Ответов: 4 · Просмотров: 126
 

>  Работа с QR Code при помощи типовой КомпонентаПечатиQRКода
Vladal
Отправлено: 26.07.19, 13:58


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


А вот и обработка с компонентой формирования qr-кода и вызовом функций генерирования картинки
qr-code.zip
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154142 · Ответов: 7 · Просмотров: 457
 

>  Формирование QR-кодов нативными средствами 1С (компонента из БСП)
Vladal
Отправлено: 23.07.19, 15:45


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Вытащил из БСП компоненту и пример кода для формирования QR-кодов.

Процедуры и функции общих модулей также скопировал в модуль обработки, чтобы они были доступны в любой конфигурации.

// к теме Работа с QR Code при помощи типовой КомпонентаПечатиQRКода
  Форум: Отчеты / Обработки · Просмотр сообщения: #154050 · Ответов: 1 · Просмотров: 229
 

>  Работа с QR Code при помощи типовой КомпонентаПечатиQRКода
Vladal
Отправлено: 23.07.19, 15:38


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


kosalex @ 09.07.19, 14:01 * ,
Вопрос решился?

В БСП есть процедура генерации QR-кодов. Хотя когда-то давно вставлял код на JavaScript, встроенном в поле HTML-документа и его дергал для получения .bmp-картинки. Её-то и подставлял в печатную форму.

Вот пример, отвязанный от БСП. А сама компонента находится в общем макете КомпонентаПечатиQRКода
Код
// Возвращает двоичные данные для формирования QR кода.
//
// Параметры:
//  QRСтрока         - Строка - данные, которые необходимо разместить в QR-коде.
//
//  УровеньКоррекции - Число - уровень погрешности изображения при котором данный QR-код все еще возможно 100%
//                             распознать.
//                     Параметр должен иметь тип целого и принимать одно из 4 допустимых значений:
//                     0(7% погрешности), 1(15% погрешности), 2(25% погрешности), 3(35% погрешности).
//
//  Размер           - Число - определяет длину стороны выходного изображения в пикселях.
//                     Если минимально возможный размер изображения больше этого параметра - код сформирован не будет.
//
// Возвращаемое значение:
//  ДвоичныеДанные  - буфер, содержащий байты PNG-изображения QR-кода.
//
// Пример:
//  
//  // Выводим на печать QR-код, содержащий в себе информацию зашифрованную по УФЭБС.
//
//  QRСтрока = УправлениеПечатью.ФорматнаяСтрокаУФЭБС(РеквизитыПлатежа);
//  ТекстОшибки = "";
//  ДанныеQRКода = УправлениеПечатью.ДанныеQRКода(QRСтрока, 0, 190, ТекстОшибки);
//  Если Не ПустаяСтрока(ТекстОшибки)
//      ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОшибки);
//  КонецЕсли;
//
//  КартинкаQRКода = Новый Картинка(ДанныеQRКода);
//  ОбластьМакета.Рисунки.QRКод.Картинка = КартинкаQRКода;
//
Функция ДанныеQRКода(QRСтрока, УровеньКоррекции, Размер) Экспорт
    
    //УстановитьОтключениеБезопасногоРежима(Истина);
    ГенераторQRКода = КомпонентаФормированияQRКода();
    Если ГенераторQRКода = Неопределено Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Попытка
        ДвоичныеДанныеКартинки = ГенераторQRКода.GenerateQRCode(QRСтрока, УровеньКоррекции, Размер);
    Исключение
        ЗаписьЖурналаРегистрации(НСтр("ru = 'Формирование QR-кода'", ОбщегоНазначения.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка, , , ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
    КонецПопытки;
    
    Возврат ДвоичныеДанныеКартинки;
    
КонецФункции

Функция КомпонентаФормированияQRКода()
    
    ТекстОшибки = НСтр("ru = 'Не удалось подключить внешнюю компоненту для генерации QR-кода. Подробности в журнале регистрации.'");
    
    //--QRCodeGenerator = ОбщегоНазначения.ПодключитьКомпонентуИзМакета("QRCodeExtension", "ОбщийМакет.КомпонентаПечатиQRКода");
    QRCodeGenerator = ПодключитьКомпонентуИзМакета("QRCodeExtension", "КомпонентаПечатиQRКода");
    Если QRCodeGenerator = Неопределено Тогда
        ОбщегоНазначения.СообщитьПользователю(ТекстОшибки);
    КонецЕсли;
    
    Возврат QRCodeGenerator;
    
КонецФункции

// Подключает компоненту, выполненную по технологии Native API и COM.
// Компонента должна храниться в макете конфигурации в виде ZIP-архива.
//
// Параметры:
//  Идентификатор   - Строка - идентификатор объекта внешней компоненты.
//  ПолноеИмяМакета - Строка - полное имя макета конфигурации, хранящего ZIP-архив.
//
// Возвращаемое значение:
//  AddIn, Неопределено - экземпляр объекта внешней компоненты или Неопределено, если не удалось создать.
//
// Пример:
//
//  ПодключаемыйМодуль = ОбщегоНазначения.ПодключитьКомпонентуИзМакета(
//      "CNameDecl",
//      "ОбщийМакет.КомпонентаСклоненияФИО");
//
//  Если ПодключаемыйМодуль <> Неопределено Тогда
//      // ПодключаемыйМодуль содержит созданный экземпляр подключенной компоненты.
//  КонецЕсли;
//
//  ПодключаемыйМодуль = Неопределено;
//
Функция ПодключитьКомпонентуИзМакета(Идентификатор, ПолноеИмяМакета) Экспорт

    ПодключаемыйМодуль = Неопределено;
    
    Если Не МакетСуществует(ПолноеИмяМакета) Тогда
        ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru = 'Не удалось подключить внешнюю компоненту ""%1"" на сервере
                       |из %2
                       |по причине:
                       |Подключение на сервере не из макета запрещено'"),
            Идентификатор,
            ПолноеИмяМакета);
    КонецЕсли;
    
    Местоположение = ПолноеИмяМакета;
    СимволическоеИмя = Идентификатор + "SymbolicName";
    
    Если ПодключитьВнешнююКомпоненту(Местоположение, СимволическоеИмя) Тогда
        
        Попытка
            ПодключаемыйМодуль = Новый("AddIn." + СимволическоеИмя + "." + Идентификатор);
            Если ПодключаемыйМодуль = Неопределено Тогда
                ВызватьИсключение НСтр("ru = 'Оператор Новый вернул Неопределено'");
            КонецЕсли;
        Исключение
            ПодключаемыйМодуль = Неопределено;
            ТекстОшибки = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
        КонецПопытки;
        
        Если ПодключаемыйМодуль = Неопределено Тогда
            
            ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                НСтр("ru = 'Не удалось создать объект внешней компоненты ""%1"", подключенной на сервере
                           |из макета ""%2"",
                           |по причине:
                           |%3'"),
                Идентификатор,
                Местоположение,
                ТекстОшибки);
            
            ЗаписьЖурналаРегистрации(
                НСтр("ru = 'Подключение внешней компоненты на сервере'",
                    КодОсновногоЯзыка()),
                УровеньЖурналаРегистрации.Ошибка,,,
                ТекстОшибки);
            
        КонецЕсли;
        
    Иначе
        
        ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru = 'Не удалось подключить внешнюю компоненту ""%1"" на сервере
                       |из макета ""%2""
                       |по причине:
                       |Метод ПодключитьВнешнююКомпоненту вернул Ложь.'"),
            Идентификатор,
            Местоположение);
        
        ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Подключение внешней компоненты на сервере'",
                КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,,,
            ТекстОшибки);
        
    КонецЕсли;
    
    Возврат ПодключаемыйМодуль;
    
КонецФункции

// Проверка существования макета по метаданным конфигурации и расширений.
//
// Параметры:
//  ПолноеИмяМакета - Строка - полное имя макета.
//
// Возвращаемое значение:
//  Булево - признак существования макета.
//
Функция МакетСуществует(ПолноеИмяМакета)
    
    Макет = Метаданные.НайтиПоПолномуИмени(ПолноеИмяМакета);
    Если ТипЗнч(Макет) = Тип("ОбъектМетаданных") Тогда
        
        Шаблон = Новый Структура("ТипМакета");
        ЗаполнитьЗначенияСвойств(Шаблон, Макет);
        ТипМакета = Неопределено;
        Если Шаблон.Свойство("ТипМакета", ТипМакета) Тогда
            Возврат ТипМакета <> Неопределено;
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат Ложь;
    
КонецФункции

// Возвращает код основного языка конфигурации, например "ru".
//
// Возвращаемое значение:
//  Строка - код языка.
//
Функция КодОсновногоЯзыка() Экспорт
    
    Возврат Метаданные.ОсновнойЯзык.КодЯзыка;
    
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154049 · Ответов: 7 · Просмотров: 457
 

>  Ошибка изменить форму
Vladal
Отправлено: 23.07.19, 15:17


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(XacTLa @ 22.07.19, 17:26) *
Спасибо кто откликнулся я в принципе так и думал что лучше самому разобраться

Кто откликнулся, наверняка уже знаю ответы.
А для потомков поделитесь решением этой проблемы?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154048 · Ответов: 2 · Просмотров: 156
 

>  Печатная форма. Порядок строк.
Vladal
Отправлено: 23.07.19, 14:24


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(1cProger @ 18.07.19, 15:31) *
 Для Каждого Выборка ИЗ ТЗ Цикл

А эта ТЗ как формируется? Из запроса?
Тогда в запросе добавить итоги по группировке и обходить уже готовые группировки и не придется рисовать
Цитата(1cProger @ 18.07.19, 15:31) *
Если Клиент1 <> Выборка.Клиент ТОГДА

Просто неизвестны исходные данные и наверно можно было бы одним запросом обойтись и сделать на СКД одним проходом.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154047 · Ответов: 6 · Просмотров: 355
 

>  Запрос по ОЛЕ не читает значение "булево"
Vladal
Отправлено: 23.07.19, 8:49


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(mut @ 22.07.19, 19:43) *
А в регистре ТоварыВПути точно есть измерение Склад? Он как-бы нелогичен там.

А его как бы нулями забивают. "00000000" как Склад

Там некорректно составлен запрос под конкретную задачу.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154042 · Ответов: 10 · Просмотров: 268
 

>  Запрос по ОЛЕ не читает значение "булево"
Vladal
Отправлено: 22.07.19, 16:13


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(Мичман Харитонов @ 22.07.19, 11:26) *
И <<?>>Склад.НеПоказыватьВБухгалтерии = &НеПоказыватьВБухгалтерии
" Поле точно есть, имя правильное. Что я не так-то делаю?

Во втором запросе присоединяется необъектный тип Строка
""000000000"" КАК Склад,

Соответственно, у строки "00000000" нет поля НеПоказыватьВБухгалтерии
Это справедливо и для первой части запроса - на выходе литерал с кодом склада, а не ссылка на справочник Склады.

Советую присоединять не нолики, а пустую ссылку типа склад:
Значение(Справочник.Склады.ПустаяСсылка) как СкладСсылка
Либо поле НеПоказыватьВБухгалтерии вывести дополнительно в запросе - чтобы каждый раз не дергать соединение со справочником Склады, как это сделано с наименованием: Номенклатура.Наименование, код с точкой и другие реквизиты:

|        ТоварыНаСкладеОстатки.Номенклатура.Наименование КАК НоменклатураНаименование,
|        ТоварыНаСкладеОстатки.Номенклатура.КодСТочкой КАК КодСТочкой,
|        ТоварыНаСкладеОстатки.Склад КАК СкладСсылка,
|        ТоварыНаСкладеОстатки.Склад.КодСклада КАК Склад,
|        ТоварыНаСкладеОстатки.Склад.НеПоказыватьВБухгалтерии КАК СкладНеПоказыватьВБухгалтерии,
|        ТоварыНаСкладеОстатки.Склад.Наименование КАК СкладНаименование,
...

|        ТоварыВПутиОстатки.Номенклатура.КодСТочкой КАК КодСТочкой,
|        Значение(Справочник.Склады.ПустаяСсылка) как СкладСсылка,
|        ""000000000"" КАК Склад,
|        Истина КАК СкладНеПоказыватьВБухгалтерии, // или Ложь, что там надо по умолчанию
|        ""Товары в пути"" КАК СкладНаименование,
|        ТоварыВПутиОстатки.КоличествоОстаток,


И с условиями будет все ОК.
В первой части запроса ОК и так, а во второй условие "И Склад.НеПоказыватьВБухгалтерии = &НеПоказыватьВБухгалтерии" привести в соответствии с логикой "склада ТоварыВПути по умолчанию" - если он не отражается в БУ, то и не надо присоединять вторую часть запроса.

Цитата(Мичман Харитонов @ 22.07.19, 11:45) *
В источнике показывает, только при выводе булево представляет как да/нет

Это "бантики" визуализации. Не обращайте внимание.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154020 · Ответов: 10 · Просмотров: 268
 

>  Запрос для нахождения номенклатуры которой нету на остатках и не было движения более года
Vladal
Отправлено: 22.07.19, 14:34


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(Schlesinger @ 18.07.19, 17:54) *
А разве нельзя получить эту информацию из стандартных отчётов?

Можно. Выгрузив их в Эксель и сделав сводную таблицу.
Либо стандартный по Партиям и смотреть глазками, нет ли других документов движения по данному товару с характеристиками, кроме приходной накладной, или перемещение между складами здвинуло только эту партию, а больше не покупали.

Можно стандартными. Это будет не скучно.

ВЫБРАТЬ РАЗЛИЧНЫЕ
    Номенклатура.Ссылка КАК Номенклатура
ПОМЕСТИТЬ втНоменклатура
ИЗ
    Справочник.Номенклатура КАК Номенклатура
ГДЕ
    Номенклатура.Ссылка В ИЕРАРХИИ(&СписокНоменклатуры)
    И НЕ Номенклатура.ЭтоГруппа
;



////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗЛИЧНЫЕ
    ПартииТоваровНаСкладахОстатки.ДокументОприходования КАК ДокументОприходования,
    ПартииТоваровНаСкладахОстатки.Номенклатура КАК Номенклатура,
    ПартииТоваровНаСкладахОстатки.Склад КАК Склад,
    ПартииТоваровНаСкладахОстатки.КоличествоОстаток
ПОМЕСТИТЬ втОстатки
ИЗ
    РегистрНакопления.ПартииТоваровНаСкладах.Остатки(
            ,
            Номенклатура В
                (ВЫБРАТЬ
                    втНоменклатура.Номенклатура
                ИЗ
                    втНоменклатура)) КАК ПартииТоваровНаСкладахОстатки
ГДЕ
    ПартииТоваровНаСкладахОстатки.ДокументОприходования.Дата МЕЖДУ &Дата1 И &Дата2
    И ПартииТоваровНаСкладахОстатки.ДокументОприходования.СкладОрдер = &СкладОрдер
;



////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗЛИЧНЫЕ
    ПартииТоваровНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток,
    ПартииТоваровНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура,
    ПартииТоваровНаСкладахОстаткиИОбороты.Склад КАК Склад,
    ПартииТоваровНаСкладахОстаткиИОбороты.ДокументОприходования КАК ДокументОприходования,
    ПартииТоваровНаСкладахОстаткиИОбороты.Регистратор КАК Регистратор,
    ПартииТоваровНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток,
    ПартииТоваровНаСкладахОстаткиИОбороты.КоличествоПриход,
    ПартииТоваровНаСкладахОстаткиИОбороты.КоличествоРасход
ПОМЕСТИТЬ втОбороты
ИЗ
    РегистрНакопления.ПартииТоваровНаСкладах.ОстаткиИОбороты(
            ,
            ,
            Регистратор,
            ,
            (ДокументОприходования, номенклатура) В
                (ВЫБРАТЬ
                    втОстатки.ДокументОприходования,
                    втОстатки.Номенклатура
                ИЗ
                    втОстатки КАК втОстатки)) КАК ПартииТоваровНаСкладахОстаткиИОбороты
ГДЕ
    ПартииТоваровНаСкладахОстаткиИОбороты.ДокументОприходования.Дата МЕЖДУ &Дата1 И &Дата2
    И ПартииТоваровНаСкладахОстаткиИОбороты.ДокументОприходования.СкладОрдер = &СкладОрдер
;



////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗЛИЧНЫЕ
    втОстатки.КоличествоОстаток КАК КоличествоОстаток,
    втОстатки.Номенклатура КАК Номенклатура,
    втОстатки.Склад КАК Склад,
    втОстатки.ДокументОприходования КАК ДокументОприходования,
    втОбороты.Регистратор КАК Регистратор
ИЗ
    втОстатки КАК втОстатки
        ЛЕВОЕ СОЕДИНЕНИЕ втОбороты КАК втОбороты
        ПО втОстатки.Номенклатура = втОбороты.Номенклатура
            И втОстатки.ДокументОприходования = втОбороты.ДокументОприходования
            И втОстатки.ДокументОприходования <> втОбороты.Регистратор
СГРУППИРОВАТЬ ПО
    втОстатки.Номенклатура,
    втОстатки.ДокументОприходования,
    втОстатки.Склад,
    втОстатки.КоличествоОстаток,
    втОбороты.Регистратор
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154019 · Ответов: 3 · Просмотров: 307
 

>  Не работает УниверсальныйОтчет в веб-клиенте. Свойство "Параметр" не поддерживается элементом коллекции пользовательских настроек компоновки данных.
Vladal
Отправлено: 22.07.19, 13:32


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Пришло обновление БСП 3.0.3.
Ошибка не исчезла.
А жаль.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #154018 · Ответов: 9 · Просмотров: 536
 

>  Какое решение выбрать для обмена УТП для Украины 1.2.52 с МЕДок?
Vladal
Отправлено: 22.07.19, 11:08


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(ru5 @ 22.07.19, 12:06) *
1с+Фредо - вполне самодостаточная связь для мелких предприятий. Единственно мне не нравится загрузка входящих НН - много ручной работы.
1с+ Медок +onesync - не хочу рекламировать - но для меня как пользователя больше подходит т.к. все автоматизировано и продумано. Вроде как есть связка 1с+Фредо+ onesync - нужно

А в МЕДок групповая выгрузка-загрузка НН происходит? В нашем пакете Медка этого нет, нужно докупать модуль.

Цитата(ru5 @ 22.07.19, 12:06) *
Сравнивал на контроль проверки на ошибки и неточности загруженного отчета в Медок и Фредо - в результате Медок выигрывает

Хм... в чем суть теста? Камеральная проверка сумм или реквизитов контрагентов?
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #154014 · Ответов: 11 · Просмотров: 270
 

>  Какое решение выбрать для обмена УТП для Украины 1.2.52 с МЕДок?
Vladal
Отправлено: 22.07.19, 11:06


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Petre @ Сегодня, 11:38 * ,
Забавно.
Напоминает борьбу БЕСТ-Звита и МЕДок. Вернее, админресурсов Медка с БЕСТом.

++ Узнал у франча, что в нашей подписке ИТС есть подписка и на ФРЕДО, одна лицензия на одну фирму, локально.

Нужно попробовать перевести эту организацию на ФРЕДО...
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #154012 · Ответов: 11 · Просмотров: 270
 

>  Какое решение выбрать для обмена УТП для Украины 1.2.52 с МЕДок?
Vladal
Отправлено: 22.07.19, 10:31


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


Цитата(Petre @ 22.07.19, 10:57) *
"ФРЕДО" - новое название "Звит1С"

Дистрибутив в 640 мегабайт не внушает оптимизма. (или отдельные только DLL+EXE - 82 МБ)
Из их хелпа https://fredo.com.ua/help/ понял, что там самостоятельная система со своей БД, аналог Медка.
Но... только для обмена НН и первички между 1С и МЕДок это мне кажется излишним.

Правда, я и 1С:Звит никогда не видел. Это и был аналог Медка со своей базой данных или только интерфейс между Медком и 1С?

Прошу прощения, что отвечаю не оперативно.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #154005 · Ответов: 11 · Просмотров: 270
 

>  Какое решение выбрать для обмена УТП для Украины 1.2.52 с МЕДок?
Vladal
Отправлено: 22.07.19, 9:21


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


О! Спасибо!

Нашел процедуру ВыгрузитьВоФРЕДО() и РегламентированныйОтчетМенеджерЗвит1С, который используется ФРЕДО. Ажно 4 раза, против 4000+ МенеджерЗвит1С

Какие тенденции рынка? Чтобы потом не пришлось "пересаживаться" на другой продукт?
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #154001 · Ответов: 11 · Просмотров: 270
 

>  Какое решение выбрать для обмена УТП для Украины 1.2.52 с МЕДок?
Vladal
Отправлено: 22.07.19, 8:40


Оратор
*****

Группа: Пользователи
Сообщений: 327
Регистрация: 20.05.09
Из: Украина
Пользователь №: 539


В наличии УТП для Украины 1.2.52.3, последняя. Для обмена с МЕДок пользовались самописной обработкой выгрузки/загрузки НН и Приложений.

Задача: выбрать типовое решение для обмена XML с МЕДок из нашей УТП и назад.

Хотим перейти на типовой обмен, я в этом не понимаю, но слышал про 1С:Звит, Фризвит, которые работают с типовыми решениями для Украины (или встроены) и делают обмен с МЕДок нативно.

Подскажите, что сейчас актуально.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #153998 · Ответов: 11 · Просмотров: 270
 

12 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.08.19, 16:21
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!