Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику vbi ::: Спасибо сказали: 51 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
04.06.18, 19:55 Получить программно документы по отбору в форме списка документа
Четкого ответа на тему нет, вот рабочий вариант. Может кому пригодится:
     Источник =  Новый ОписаниеИсточникаДанных(ДокументСписок);    
      Построитель = Новый ПостроительЗапроса;
      Построитель.ИсточникДанных = Источник;
      Построитель.Выполнить();
      ТЗ = Построитель.Результат.Выгрузить();
И делов то) Чтоб в следующий раз в поиске в Гугл найти ответ в этой теме.
Vofka,
16.11.17, 14:32 Інтеграційна стиковка для 1С 7.7 та M.E.Doc
Вот, случайно наткнулся. Может еще пригодится.
ulisses,
10.01.14, 9:26 HTTPСоединение.Получить() - Пустой ответ сервера
Разобрались сами. Проблема была в том, что был настроен редирект всех страниц 302 на другую одну страницу php.
Тема закрыта
ignsv, Vofka,
12.11.13, 12:20 HTTPСоединение.Получить() возвращает XML с кракозябрами
Вообщем выяснил, текст приходит в cp1251, на виндовсе все в кодировке cp1250. Если текст который пришол отобразить как cp1250 - отображается нормально.
Например вот фрагмент: "Íŕčěĺíîâŕíčĺ"
Здесь можно проверить.

Получается нужно написать конвертер cp1251 -> cp1250. Нигде не могу найти описание как это сделать.
mister-x,
18.02.13, 10:43 Вывод таблицы значений в красивый отчет с расшифровками
Если кому нужно таблицу значений представить как красивый отчет с расшифровками, передаете в функцию ТЗ - она возвращает Табличный документ. Функция работает на сервере, потому ее можно использовать и на клиент-серверном варианте.

Домустим у Вас есть ТЗ с колонками "РеализацияТоваровУслуг" и СуммаДокумента.

Функция вернет вот такой табличный документ:



Здесь представлена обработка с этой функцией, макетом оформления (для некоторых конфигураций этот макет будет необходим), а так же процедурой, которая демонстрирует работу функции (помимо ТЗ в функцию еще нужно передать описание заголовков колонок. Там как раз есть пример). Обработка выводит ТабличныйДокумент на экран. Выше - как раз его скриншот.

[attachment=681:TZ_to_Report.zip]
Alex_Alex, bohdan-k, galamm, igvlagor, iswat, mment11, nika, sava1, siancom, Vofka,
15.02.13, 14:44 Отчет из таблицы значений с помощью построителя
Вообщем кому нужно будет ТЗ в красивый отчетик вывести - вот простой работающий пример smile.gif
Meest,
15.02.13, 12:08 Отчет из таблицы значений с помощью построителя
Разобрался, вот так работает:
    Построитель.ИсточникДанных=Новый ОписаниеИсточникаДанных(ТЗ);       
    Построитель.ИсточникДанных.Колонки[1].Измерение=Истина;     // Регистратор    
    Построитель.ИсточникДанных.Колонки[0].Итог="СУММА(Сумма)";  // Сумма
    Построитель.ЗаполнениеРасшифровки = ВидЗаполненияРасшифровкиПостроителяОтчета.ЗначенияГруппировок; /// Тут ЗначенияГруппировок а не Расшифровка :)  
    Построитель.ЗаполнитьНастройки();
Vofka,
04.04.12, 10:02 Как запустить предприятие 8.2 из командной строки, указав путь к базе?
Собственно такая проблема у меня появилась. Нужно пользователям в настройке запуска Windows прописать запуск 1С предприятия, указав под какой базой войти в предприятие.
Вроде не вопрос:
Цитата
"C:\Program Files\1cv82\8.2.14.528\bin\1cv8.exe" enterprise /S server_name\base_name

Но вот не хотелось указывать конкретно релиз программы в командной строке. А если установить новый релиз? Перепрописывать всем пользователям путь?

Цитата
"C:\Program Files\1cv82\common\1cestart.exe" enterprise /S server_name\base_name
- вроде запускает нужную базу, но открывает ее под управляемым интерфейсом (открывается пустое окно управляемого интерфейса), даже если я явно передаю параметр запуска в обычном интерфейсе.

Не долго думая, решил написать батник, который будет выбирать последний релиз 1С 8.2 и запускать его, передавая параметры. И все получилось.

1. В папке "C:\Program Files\1cv82\" создаем bat-файл с иминем "start1c.bat" и следующим содержимым:
Цитата
@echo off
for /f "delims=" %%* in ('dir/O:-N 8.2* /B /S 2^>nul') do (
start %%*\bin\1cv8.exe %1 %2 %3 %4 %5 %6 %7 %8 %9
exit /B
)


2. В поле запуска приложения при входе пользователя прописываем команду
Цитата
C:\Progra~1\1cv82\start1c enterprise /S server_name\base_name

3. В поле рабочего каталога обязательно указываем
Цитата
C:\Progra~1\1cv82\


И все работает.

Что делает батник? Он получает список папок в рабочем каталоге с полным путем, которые начинаются на "8.2" и отсортированы по убыванию. Таким образом нужный каталог будет находится первым в списке. По списку запускается перебор, и первому же (нужному) пути каталога приклеивается "\bin\1cv8.exe", потом приклеиваются параметры и запускается 1С. Так как для запуска 1С используется команда "start", батник не ожидает окончания работы 1С и завершается. 1С же продолжает работу. Таким образом мы запускаем 1С один раз именно самой последней версии указав конкретную базу и режим предприятия. smile.gif

P. S. Если у Вас 64-битная система и 1С установлена в "C:\Program Files (x86)\1cv82", то вместо "C:\Progra~1\" нужно писать "C:\Progra~2\"
Vofka,
10.03.12, 18:04 При формировании "тяжелого" отчета 1С вылетает
Предисловие smile.gif

1. Есть компьютер А и компьютер Б, соеденены сетью;
2. На обоих компьютерах установлена 1С 8.2;
3. Есть база УТП, которая лежит на компьютере А, которая розшарена для компьютера Б.

Описание проблемы (развязка):

Если на компьютере А запустить 1С (под любым пользователем войти в базу, указанную в пункте 3) и попытатся сформировать оборотку - 1С вылетает с ошибкой виндовс: "... приложение будет закрыто ..." (точное сообщение не скажу, это все обяснял друг а я ему советовал что сделать).

На компьютере Б прописан путь к базе (3), и если там запустить 1С, войти в базу по локалке, сформировать оборотку - все работает прекрасно.

Как лечили (обьяснял другу что сделать):

1. Проверка базы (все галочки кроме проверки ссылочной целосности): Нашло кучу ошибок, исправило, но эта проблема осталась.
2. Удаляли личные данные пользователей 1С: без толку
3. Переустанавливали 1С: без толку
4. Друг даже переустановил Windows: без толку (Windows XP, 2Gb RAM, 2.хз Ггерц процессор)
5. Копировали базу в другое место: без толку
6. Копировали базу на компьютер Б: На Б локально нормально работает, а если запускать с А по сетке - вылетает.

Очевидно проблема наверно в самом компьютере (либо дрова плохие, хотя ставились с родного диска, либо что-то с железом). Все что знаю, написал, больше буду знать только в понедельник.

Может есть идеи? Что еще можно попробовать? Может винда кривая? Может проверить виртуальную память? Помогите добрым словом smile.gif
sash-88,
21.02.12, 16:24 Программное заполнение Платежки и ПКО заказами по ФИФО/ЛИФО
В стандартной конфигурации УТП для Украины, в таких документах, как "Платежное поручение входящее" и "Приходный кассовый ордер" есть пункт меню "Заполнить" табличной части "Расшифровка платежа". Этот пункт запускает стандартную обработку, открывает ее форму, а она в свою очередь подбирает неоплаченные заказы.

Иногда бывает необходимо в цикле программно заполнить платежные документы сделками по ФИФО или ЛИФО. Многие пишут все вручную, либо пытаются вытащить алгоритм из той обработки заполнения, мотивируя "там же диалоговое окно открывается, как ее использовать программно?"

На самом деле все просто. Вот код заполнения неоплаченными сделками в цикле по ФИФО Платежных поручений входящих и Приходных кассовых ордеров. Может кому пригодится:

Платежное поручение входящее:
 Для Каждого Платежка Из ТаблицаПлатежек Цикл
             ОбрОб=Обработки.ПодборПараметровРасшифровкиПлатежа.Создать();

             ОбрОб.КурсДокумента                    =1;        // Если есть валюта - получить
             ОбрОб.КратностьДокумента            =1;        // Если есть валюта - получить
            
             ДокОб = Платежка.Ссылка.ПолучитьОбъект();
             ДокОб.РасшифровкаПлатежа.Очистить();
            
             ОбрОб.ДокументСсылка                 =Платежка.Ссылка;
             ОбрОб.ТипЗадолженности                =">0";
             ОбрОб.Контрагент                    =ДокОб.Контрагент;
             ОбрОб.ФормаОплаты                    =Перечисления.ВидыДенежныхСредств.Безналичные;
             ОбрОб.ИмяРегистраПлан                ="ПланируемыеПоступленияДенежныхСредств";
             ОбрОб.ВидОперацииПлан                =Перечисления.ВидыОперацийПланируемоеПоступлениеДС.ОплатаПокупателя;
             ОбрОб.БанковскийСчетКасса            =ДокОб.СчетОрганизации;
             ОбрОб.Организация                    =ДокОб.Организация;
             ОбрОб.ВалютаДокумента                =ДокОб.ВалютаДокумента;
             ОбрОб.ДатаДок                        =ДокОб.Дата;
             ОбрОб.ВидОперацииДок                =Перечисления.ВидыОперацийПоступлениеБезналичныхДенежныхСредств.ОплатаПокуп
ателя;
             ОбрОб.РасшифровкаПлатежаДок            =ДокОб.РасшифровкаПлатежа;
             ОбрОб.СуммаДляПодбора                =ДокОб.СуммаДокумента;
             ОбрОб.ПлатежПоСуммеВзаиморасчетов    =Ложь;
             ОбрОб.ЕстьПодбор                    =Ложь;
             ОбрОб.ОтражатьВБухгалтерскомУчете = ДокОб.ОтражатьВБухгалтерскомУчете;
            
             ОбрОб.УчитыватьФактическиеЗадолженности=Истина;
             ОбрОб.УчитыватьОперативныеЗадолженности=Ложь;
             ОбрОб.ПодбиратьСумму=Истина;
             ОбрОб.СпособЗаполнения="ФИФО"; // Если нужно "ЛИФО"
             ОбрОб.ПоЗаявкам=Ложь;
             ОбрОб.ПодбиратьПланируемыеДвижения=Ложь;
             ОбрОб.НеПревышатьЗапланированныхЗначений=Ложь;
             ОбрОб.ВключенныеВПлатежныйКалендарь=Истина;
             ОбрОб.ЗаполнитьРасшифровкуПоДолгам(Истина,Ложь);
        
             Для Каждого Строка Из ДокОб.РасшифровкаПлатежа Цикл
                 ДокОб.ОпределитьСчетаУчетаРасчетовСКонтрагентом(Строка);
                 УправлениеДенежнымиСредствами.ПересчитатьСуммуНДС(Строка);    
             КонецЦикла;
            
             Попытка
                 ДокОб.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный);
             Исключение
                 Сообщить(ОписаниеОшибки());
             КонецПопытки;
КонецЦикла;


Приходные кассовые ордера:
 Для Каждого ПКО Из ТаблицаПКО Цикл
             ОбрОб=Обработки.ПодборПараметровРасшифровкиПлатежа.Создать();
            
             ДокОб = ПКО.Ссылка.ПолучитьОбъект();
             ДокОб.РасшифровкаПлатежа.Очистить();
            
             ОбрОб.КурсДокумента                    =1; // Если есть валюта - получить
             ОбрОб.КратностьДокумента            =1; // Если есть валюта - получить
             ОбрОб.ДокументСсылка                 =ПКО.Ссылка;
             ОбрОб.ТипЗадолженности                =">0";
             ОбрОб.Контрагент                    =ДокОб.Контрагент;
             ОбрОб.ФормаОплаты                    =Перечисления.ВидыДенежныхСредств.Наличные;
             ОбрОб.ИмяРегистраПлан                ="ПланируемыеПоступленияДенежныхСредств";
             ОбрОб.ВидОперацииПлан                =Перечисления.ВидыОперацийПланируемоеПоступлениеДС.ОплатаПокупателя;
             ОбрОб.БанковскийСчетКасса            =ДокОб.Касса;
             ОбрОб.Организация                    =ДокОб.Организация;
             ОбрОб.ВалютаДокумента                =ДокОб.ВалютаДокумента;
             ОбрОб.ДатаДок                        =ДокОб.Дата;
             ОбрОб.ВидОперацииДок                =Перечисления.ВидыОперацийПоступлениеБезналичныхДенежныхСредств.ОплатаПокуп
ателя;
             ОбрОб.РасшифровкаПлатежаДок            =ДокОб.РасшифровкаПлатежа;
             ОбрОб.СуммаДляПодбора                =ДокОб.СуммаДокумента;
             ОбрОб.ПлатежПоСуммеВзаиморасчетов    =Истина;
             ОбрОб.ЕстьПодбор                    =Ложь;
             ОбрОб.ОтражатьВБухгалтерскомУчете = ДокОб.ОтражатьВБухгалтерскомУчете;
             ОбрОб.ВидОперацииДок                = ДокОб.ВидОперации;
             ОбрОб.ВалютаДокумента                =ДокОб.ВалютаДокумента;            
             ОбрОб.УчитыватьФактическиеЗадолженности=Истина;
             ОбрОб.УчитыватьОперативныеЗадолженности=Ложь;
             ОбрОб.ПодбиратьСумму=Истина;
             ОбрОб.СпособЗаполнения="ФИФО";     // Если нужно "ЛИФО"
             ОбрОб.ПоЗаявкам=Ложь;
             ОбрОб.ПодбиратьПланируемыеДвижения=Ложь;
             ОбрОб.НеПревышатьЗапланированныхЗначений=Ложь;
             ОбрОб.ВключенныеВПлатежныйКалендарь=Истина;
             ОбрОб.ЗаполнитьРасшифровкуПоДолгам(Истина,Ложь);

             Для Каждого Строка Из ДокОб.РасшифровкаПлатежа Цикл
                 ДокОб.ОпределитьСчетаУчетаРасчетовСКонтрагентом(Строка);
                 УправлениеДенежнымиСредствами.ПересчитатьСуммуНДС(Строка);    
             КонецЦикла;
            
             Попытка
                 ДокОб.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный);
             Исключение
                 Сообщить(ОписаниеОшибки());
             КонецПопытки;
КонецЦикла;
Irina_, nmf, Oksi_K, Vofka,
20.01.12, 17:56 Улыбнуло
Случай вчера был с моей женой (она со мной на одной фирме работает, только бухгалтером). Вечером решила померить температуру, придремала. Когда я забирал у нее градусник, спросоня выдала фразу "Я ж еще только по одной организации температуру померяла..." biggrin.gif
5_kopeek, Ardi, MATEVI, Pepe, Zaval,
17.01.12, 17:15 Конфигурация "Конвертация данных"
Мы при переносе делали так:
в 7.7 создавали служебный документ остатков с кнопочкой заполнить. При нажатии на Заполнить табличная часть заполняется актуальными остатками.
в 8 создавали аналогичный документ с кнопкой "Распаковать"

Настраили конвертацию так чтобы эти документы выгружались из 7.7 в 8 (вместе с переносом справочников настройка конвертации занимает 15 мин.)

Далее заполнили служебный документ в 7.7, выыгрузили через обработку конвертации в XML, загрузили через другую обработку в 8.

Нажали в 8 в служебніх документах кнопку "Распаковать" - при этом создаются документы с остатками (оприходования или др.)
Такой метод не вынуждает долго ковырятся в конвертации а позволяет быстро настроить перекидку.
Кроме того такую процедуру перекидки можно выполнять несколько раз в день, если клиент захотел чтото у себя в 7.7 поменять задним числом.
alex040269, Егор Динин,
17.01.12, 16:20 Как программно ввести налоговую на основании реализации?
Вроде ничего сложного :
Док = Обработки.ФормированиеНалоговыхНакладных.СоздатьДокумент();
Док.Заполнить(РеализацияСсылка);


Но на втором этапе из модуля объекта налоговой вызывается открытие формы. А потом если попытатся записать - то записывается пустой документ, хотя в форме все заполнено.

Как программно заполнить налоговую на основании реализации, так чтобы не открывалась форма налоговой?
Fabri,
18.11.11, 10:59 Как установить интервал отображения в форме списка документа?
Разобрался сам 63000000.gif !
Так не работает:
Элементы.Список.Период = СтруктураПараметров.Период;

а так работает:
ЗаполнитьЗначенияСвойств(Элементы.Список.Период,СтруктураПараметров.Период);

Ну или так:
    Элементы.Список.Период.Вариант = СтруктураПараметров.Период.Вариант;
        Элементы.Список.Период.ДатаНачала = СтруктураПараметров.Период.ДатаНачала;
        Элементы.Список.Период.ДатаОкончания = СтруктураПараметров.Период.ДатаОкончания;

Оказывается, что когда мы присваиваем период, он есть ссылкой на объект в памяти, и потому заменяется другим объектом, мы просто заменяем объект периода на другой, вместо того, чтоб устанавливать его атрибуты smile.gif
Отсюда правило: никогда не писать "Период = " даже в сравнении, т. к. сравниватся будут ссылки на объекты а не их значения. Тут уже начинают работать правила ООП smile.gif))
Vofka,
04.11.11, 13:00 1С Документооборот 8
Цитата(logist @ 04.11.11, 12:03) *
1С:Архив это не конфигурация 1С, а отдельный программный продукт. И "Конвертация данных" тут никак не поможет.


Честно говоря не знал...
Гдето видел, что на августовском ИТС 2007 года есть статья "Интеграция 1С : Архива 2.5 и 1 С : Предприятия 8.0"

Есть так же внешняя компонента для работы с 1С:Архивом. Вот еще код, может поможет:

Попытка
    ЗагрузитьВнешнююКомпоненту("ArcDocAddIn.dll");    
Исключение
    Сообщить("Не удаётся загрузить внешнюю компоненту 1С:Архива", СтатусСообщения.Важное);
    Сообщить("  " + ОписаниеОшибки());
    Возврат;
КонецПопытки;
    
Попытка
    ТестовыйAPI = Новый("AddIn.AddInExtension");    
Исключение
    Сообщить("Не удаётся подключиться к API 1С:Архива", СтатусСообщения.Важное);
    Сообщить("  " + ОписаниеОшибки());
    Возврат;
КонецПопытки;    


API = Новый("AddIn.AddInExtension");
ОтветАрхива = API.OpenDocument(UID);
Сообщить(ОтветАрхива);


Я думаю вместе с дистрибутивом программы должна быть документация по API 1С:Архива. Используя его и компоненту можно перетащить документы в конфигурацию.

Или вытащите данные в "1С Документооборот ПРОФ" а потом из нее Конвертацией данных
ip82,
04.11.11, 11:48 1С Документооборот 8
Смотря какие документы. Есть такая конфигурация "Конвертация данных". С помощью ее можно просто настроить правила переноса: устанавливаете какие объекты одной конфигурации переходят в какие объекты другой, а так же реквизиты. После этого с помощью специальных обработок и сформированных правил обмена переносите данные. Поискав в интернете, Вы найдете много написанного об этом.
ip82,
03.11.11, 17:26 Приси записи номенклатуры в наименование добавить код
Сори...
Объект.УстановитьНовыйКод("");

rolleyes.gif

Вот, проверил у себя: 100% работает:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ДокОбъект = РеквизитФормыВЗначение("Объект");
    Если ДокОбъект.ЭтоНовый() Тогда
         ДокОбъект.УстановитьНовыйКод("");
    КонецЕсли;
    ЗначениеВРеквизитФормы(ДокОбъект,"Объект");
КонецПроцедуры


&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Объект.Наименование = Объект.Наименование + Объект.Код;
КонецПроцедуры
Irina_,
03.11.11, 17:05 Непонятная ошибка XDTO
Блин!!! icon_bang.gif наверно опять баги платформы (8.2.14.537)

Так работает:
       СтруктураРеквизитовДокумента = 0;  
       мВалютаРегламентированногоУчета = 0;
       СтруктураРеквизитовДляФормыЦеныВалюты = ПолучитьСтруктуруРеквизитовДляФормыЦеныВалюты(СтруктураРеквизитовДокумента, "Товары", мВалютаРегламентированногоУчета, 0);
       Возврат;


33000000.gif
Vofka,
03.11.11, 16:35 Приси записи номенклатуры в наименование добавить код
Цитата
ПриСоданииНаСервере вызывается даже при открытии существующего элемента....хорошо там вызывать УстановитьНовыйКод ?

Да. Ведь (тем более на сервере) проверить условие нового:

Если Объект.ЭтоНовый() Тогда
     УстановитьНовыйКод("");
КонецЕсли;


Скажете, получилось ли.
Irina_,
03.11.11, 16:11 Приси записи номенклатуры в наименование добавить код
Вызовите
УстановитьНовыйКод(<ПрефиксКода>);
и все. Можна вызвыть при создании на сервере.

При создании на сервере вызываете УстановитьНовыйКод(<ПрефиксКода>);

а ПередЗаписью на клиенте Объект.Наименование = Объект.Наименование + Объект.Код;
Irina_,
03.11.11, 16:04 Приси записи номенклатуры в наименование добавить код
Объект.Наименование = Объект.Наименование + Объект.Код;

так должно работать - только что проверил у себя - работает. При чем на Веб-клиенте! ))
Irina_,
03.11.11, 16:00 Приси записи номенклатуры в наименование добавить код
А "ПередЗаписью"?
Объект.Наименование = Объект.Наименование + Объект.Код;

Кстате, представим что вы записали номенклатуру как надо, потом открываете - и наименование у Вас такое "Товар00001" (с кодом, так ведь?). А теперь если ее еще раз записать, тогда наименование будет такое "Товар0000100001". Нехорошо smile.gif
Irina_,
17.10.11, 10:44 Веб клиент: Не работает печать
Кстате в файловом варианте, после 5-минутного зависания (как и в DB2) имеем такую ошибку:
Цитата
Помилка роботи сеансу
Помилка при виконанні запиту POST до ресурсу /e1cib/moxel:
через:
Сеанс відсутній або вилучений
ID=1cffdd79-a019-4434-a609-ea7ccc1f362e, File=src\SeanceContextBasImpl.cpp(909)


Значит проблема не в DB2...

О! Теперь другая ошибка в файловом варианте:


Кстате после нажатия на кнопку печати строка состояния постоянно пишет следующее:


Проблема решена! Ошибка крылась в платформе 8.2.13.219! В 8.2.14.533 работает нормально!
mister-x,
11.10.11, 15:55 Как программно ввсести на основании документ
Спасибо! ща попробую! Я нашел другую реализацию, более сложную:

&НаКлиенте
Процедура ВвестиЧекККМ_Опт(Команда)
    АдресДокумента = СоздатьЧекККМНаСервере(Элементы.Список.ТекущиеДанные.Ссылка);
    ПараметрыОткрываемойФормы=Новый Структура;
    ПараметрыОткрываемойФормы.Вставить("АдресГотовогоОбъекта",АдресДокумента);
    ОткрытьФорму("Документ.ЧекККМ_Опт.Форма.ФормаДокументаУпр",ПараметрыОткрываемойФормы);
КонецПроцедуры

&НаСервереБезКонтекста
Функция СоздатьЧекККМНаСервере(Основание)
    ЧекККМ = Документы.ЧекККМ_Опт.СоздатьДокумент();
    ЧекККМ.Дата=ТекущаяДата();
    ЧекККМ.Заполнить(Основание);
    АдресДокумента=ПоместитьВоВременноеХранилище(ЧекККМ,Новый УникальныйИдентификатор);
    Возврат АдресДокумента;
КонецФункции


Ну и в самом чеке ККМ в упр. форме:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("АдресГотовогоОбъекта") Тогда
        НовыйДокумент=ПолучитьИзВременногоХранилища(Параметры.АдресГотовогоОбъекта);
        ЗначениеВРеквизитФормы(НовыйДокумент,"Объект");
    КонецЕсли;
КонецПроцедуры


Цитата(Vofka @ 11.10.11, 13:38) *
В 8.1 и в 8.2 (толстый клиент) в процедуру ПриПолученииДанных тоже пару раз заходит, этого тоже до сих пор никто объяснить не может dry.gif , поэтому, возможно, стОит смириться...



Цитата(kivals @ 11.10.11, 15:35) *
Неверный сам подход: если созданный объект не нужно записывать (перед открытием формы), то нужно просто открыть форму, указав что вводится объект на основании:
ПараметрыФормы = Новый Структура("Основание", Основание);
ОткрытьФорму("Документ.ЧекККМ_Опт.ФормаОбъекта", ПараметрыФормы);

Спасибо, работает! Работают оба варианта, но я выберу тот что проще! smile.gif
kivals,
07.10.11, 11:49 Как получить значение скрытой колонки?
Я вот уже долго мучаюсь.
Вот есть у меня управляемая форма списка. Получается произвольным запросом. Запрос возвращает много всяких полей. В элементе формы "Список" я добавил несколько колонок, указал источник данных. Некоторые скрыл. Но при активации строки списка мне нужно получить значение скрытой колонки.
Если я создаю колонку, делаю видимость = "Ложь" то программно не могу потом получить значение этой колонки. Как до нее добратся?

Может как-то через текущую строку таблицы формы получить значение из динамического списка?

Отключал пользовательскую видимость, а обычную включал - все равно не достучатся.

Разобрался сам. В конструкторе форм там где отображается динамический список (справа), развернув его, нужно отметить галочками в колонке "Использовать всегда" напротив тех реквизитов, которые нужно, и не обязательно их вставлять в таблицу формы.
Vofka,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 15.11.18, 8:44
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне