Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Bernet ::: Спасибо сказали: 209 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
06.11.18, 16:54 Конфігурація для транспорту
sasha007 @ Сегодня, 14:39 * ,
Дешифровать код можете попробовать с помощью этой обработки.
А допиливать можно сколько угодно и что угодно - вопрос времени и денег
sasha007,
30.10.18, 12:37 Готовы купить 50 аппаратных ключей 1C:CRM PROF редакция 1.3 (платформа 8.3 в режиме совместимости с 8.2 1С:Предприятие 8.2 (8.2.18.61))
АлександраШ @ Сегодня, 11:37 * ,
В чем проблема?) Звоните туда
АлександраШ,
30.10.18, 10:06 Установить пароль на открытие формы в самой среде разработки
Gigi @ Сегодня, 9:54 * ,
Даже зашифрованные типовые модули, которые когда открываешь пишут "Исходный текст модуля отсутствует", т.е. модуль зашифрован и закрыт - можно сломать, было бы желание. Абсолютной защиты нет.
Сломать можно например с помощью данной обработки
Пароли же ломаются ещё проще, так что не вижу смысла заморачиваться этим
и это только один из способов

Gigi @ Сегодня, 9:54 * ,
Защита которую я не смог пока сломать это когда например в типовых конфигурациях есть участки кода, которые обращаются к какой-то внешней компоненте, написанной на стороннем языке, в ней что-то происходит и данные возвращаются в 1С. Так сейчас устроено лицензирование в новых конфигурациях. Т.е. модули расшифровать мы можем, повыкидывать кучу кода можем, но основные участки которые требуют наличие этой компоненты работать не будут, соответственно получаем конфигурацию с обрезанным функционалом.
Gigi,
30.10.18, 9:47 Установить пароль на открытие формы в самой среде разработки
Gigi @ Сегодня, 9:41 * ,
Все эти пароли можно сломать при желании - не вижу особого смысла
Но если по теме то можно так
Gigi,
25.10.18, 11:34 Сохранить табличный документ в формат JPG
Gigi @ Сегодня, 12:08 * ,
Наверняка можно, но нужно какую-то стороннюю библиотеку искать, 1С не сконвертирует

P.S. Как вариант погуглить какой-нибудь онлайн-сервис который переконвертирует и у которого есть API, отправлять туда PDF а в ответ получать JPG

P.P.S Первая же ссылка
Gigi,
11.10.18, 11:09 Изменение документа "при открытии"
VovanKaban @ Сегодня, 12:04 * ,
Это значит что в событии меняются какие-то реквизиты. Посмотрите где устанавливается реквизит и оберните установку этого реквизита таким образом:
Если ЭтоНовый() Тогда
    // тут присвоение всех реквизитов по умолчанию
КонецЕсли;


Индексировать базу и менять даты это все не с этой оперы.
У вас вешается модифицированность объекта - это значит при открытии формы меняются реквизиты объекта
VovanKaban,
14.09.18, 14:44 Програмная установка стандартного периода СКД
twilight_dream @ Вчера, 17:18 * ,
неправильно к параметрам обращаетесь, используйте
Цитата
КомпоновщикНастроекКомпоновкиДанных
twilight_dream,
12.09.18, 15:17 Проблема со штрихкодом (Ocvita Barcode). Печать по ширине компоненты
bizisoft @ Сегодня, 15:48 * ,
ну тут либо размер картинки со штрихкодом вылазит за область макета либо как тут описано - штрихкод с нулем в конце (но я не проверял действительно есть ли проблема)
bizisoft,
09.08.18, 11:40 Отчет по проданным товарам
Юля @ Сегодня, 12:21 * ,
В разрезе товаров только оборотка, других отчетов там нет. Две диаграмки по продажам, одна из которых по ном. группам.
Если оборотка не устраивает то нужно заказывать отчет
Юля,
08.08.18, 10:23 Поиск!
alexgoro @ Вчера, 21:06 * ,
Переопубликовал на fex.net
alexgoro,
04.07.18, 13:07 Настройка рабочего стола
Gigi @ Сегодня, 13:10 * ,
Ну вот то как у меня отображается
смотрите в сторону общих команд, у вас там есть нечто похожее на вызов вашей формы. команда "ПОЛЕЗНЫЙ_ОТПУСК" - может она в интерфейс выведена, хз
Gigi,
04.07.18, 10:39 Настройка рабочего стола
Gigi @ Сегодня, 11:33 * ,
Сюда
или
сюда
на ваш выбор

Вы бы с данными аккуратнее были, а то начальство накажет за то что слили базу
Gigi,
28.06.18, 16:55 Настройка рабочего стола
Gigi @ Сегодня, 17:12 * ,
В свойствах корня дерева конфигурации правой кнопкой мыши -> Открыть модуль управляемого приложения
Gigi,
28.06.18, 15:54 Настройка рабочего стола
Gigi @ Сегодня, 16:14 * ,
В конфигураторе в дереве метаданных открываете свойства корня конфигурации, в свойствах есть "Рабочая область начальной страницы" - в ней наверно и есть ваша форма. Только если уберете её оттуда она исчезнет для всех пользователей.


У нас сегодня гос. выходной, мало кто сидит за компом, все гуляют
Gigi,
27.06.18, 11:45 Почему структура в модуле обработки не работает!
Gigi @ Сегодня, 12:42 * ,
Скорее всего у вас есть реквизит формы или объекта с названием "Филиалы" поэтому и возникла такая ситуация
Gigi,
27.06.18, 10:32 Почему структура в модуле обработки не работает!
Gigi @ Сегодня, 11:25 * ,
выложите полностью процедуру. то что вы показали должно работать в любом модуле
Gigi,
25.06.18, 14:35 Как отобразить указанный динамический список во вкладке(странице) общей формы
Gigi @ Сегодня, 15:26 * ,
Ищите как изменить/установить основную таблицу/текст запроса динамического списка
Gigi,
25.06.18, 13:56 Программно отправить сообщение на почту через внешнюю обработку. Версия платформы: 8.3.10.2667, версия конфигуратора: 2.4.1.206
@lex @ Сегодня, 14:52 * ,
В этой теме уже отвечали на этот вопрос
@lex,
21.06.18, 15:42 Справочник (иерархия элементов): определить есть ли у элемента подчиненные элементы
Constantus @ Сегодня, 15:41 * ,
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
|     СпрСтатьи.Ссылка
|ИЗ
|    Справочник.СтатьиДвиженияДенежныхСредств КАК СпрСтатьи
|ГДЕ
|    СпрСтатьи.Ссылка В ИЕРАРХИИ (&Статья)
|    И СпрСтатьи.Ссылка <> &Статья
|";
Запрос.УстановитьПараметр("Статья", СтрокаПлатеж.СтатьяДвиженияДенежныхСредств);
Результат = Запрос.Выполнить();
Если  НЕ Результат.Пустой() Тогда
    Сообщить("Низзяя");
Иначе
     // делайте что угодно
КонецЕсли;
Constantus,
20.06.18, 8:42 Отправить письмо на почту посредством 1С
barul4ik @ Сегодня, 9:40 * ,
Эту утилиту нужно было юзать с платформой 8.2, которая не поддерживала SSL-шифрование. 8.3 уже поддерживает, использовать эту утилиту уже не обязательно
Gigi,
19.06.18, 10:40 Отправить письмо на почту посредством 1С
Gigi @ Сегодня, 11:33 * ,
У меня такой код в самописной конфигурации работал, правда с gmail, для mail.ru только порты могут быть другие, а так принцип тот же
Код
Функция ОтправитьУведомлениеНаПочтуПользователю(СтруктураПараметров) Экспорт
    
    ТекстОшибок = "";
    
    ПолучательПисьма = Неопределено;
        
    СтруктураПараметров.Свойство("ПолучательПисьма", ПолучательПисьма);
    
    УчетнаяЗаписьДляРассылки = Константы.УчетнаяЗаписьДляРассылки.Получить();
    Если НЕ ЗначениеЗаполнено(УчетнаяЗаписьДляРассылки) Тогда
        ТекстОшибок = ТекстОшибок + "Не выбрана учетная запись для рассылки уведомлений на почту.";
        Возврат ТекстОшибок;
    КонецЕсли;
    
    Если ПолучательПисьма = Неопределено Тогда
        ТекстОшибок = ТекстОшибок + Символы.ПС + "Не указана почта получателя уведомления!";
        Возврат ТекстОшибок;
    КонецЕсли;
    
    Профиль = ПолучитьИнтернетПочтовыйПрофиль(УчетнаяЗаписьДляРассылки);
    
    ИнтернетПочта = Новый ИнтернетПочта;
    
    Попытка
        ИнтернетПочта.Подключиться(Профиль);
    Исключение
        
        ТекстОшибок = ТекстОшибок + Символы.ПС + (Строка(УчетнаяЗаписьДляРассылки) + ". " + ОписаниеОшибки());
        Возврат ТекстОшибок;
        
    КонецПопытки;
    
    ПочтовоеСообщение = Новый ИнтернетПочтовоеСообщение;
                            
    ПочтовоеСообщение.Кодировка = "utf-8";
    ПочтовоеСообщение.ИмяОтправителя  = СокрЛП(УчетнаяЗаписьДляРассылки.АдресЭлектроннойПочты);
    ПочтовоеСообщение.Отправитель     = СокрЛП(УчетнаяЗаписьДляРассылки.АдресЭлектроннойПочты);
    ПочтовоеСообщение.Тема            = "Тема";
    
    Получатель = ПочтовоеСообщение.Получатели.Добавить();
    Получатель.Адрес           = СокрЛП(ПолучательПисьма);
    Получатель.ОтображаемоеИмя = СокрЛП(ПолучательПисьма);
    Получатель.Кодировка       = "utf-8";

    ТекстСообщения = ПочтовоеСообщение.Тексты.Добавить();
    ТекстСообщения.Кодировка = "utf-8";
    Если УчетнаяЗаписьДляРассылки.КодировкаПисемПоУмолчанию = "HTML" Тогда
        ТекстСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;    
    ИначеЕсли УчетнаяЗаписьДляРассылки.КодировкаПисемПоУмолчанию = "TEXT" Тогда    
        ТекстСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
    КонецЕсли;
    ТекстСообщения.Текст = ПолучитьТекстДляУведомленияНаПочту(ТекстСообщения.ТипТекста, СтруктураПараметров);
    
    Попытка
        ИнтернетПочта.Послать(ПочтовоеСообщение);
    Исключение
        ТекстОшибок = ТекстОшибок + Символы.ПС + (Строка(УчетнаяЗаписьДляРассылки) + ". " + ОписаниеОшибки());
        Возврат ТекстОшибок;    
    КонецПопытки;
    
КонецФункции

Функция ПолучитьИнтернетПочтовыйПрофиль(УчетнаяЗапись) Экспорт

    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    Профиль.АдресСервераPOP3 = УчетнаяЗапись.POP3Сервер;
    Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
    Если УчетнаяЗапись.ВремяОжиданияСервера > 0 Тогда
        Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжиданияСервера;
    КонецЕсли;
    Профиль.Пароль           = УчетнаяЗапись.Пароль;
    Профиль.Пользователь     = УчетнаяЗапись.Логин;
    Профиль.ПортPOP3         = УчетнаяЗапись.ПортPOP3;
    Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
    
    Профиль.ИспользоватьSSLSMTP = Истина;
    Профиль.ИспользоватьSSLPOP3 = Истина;
    
    Если УчетнаяЗапись.ТребуетсяSMTPАутентификация Тогда
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
        Профиль.ПарольSMTP         = УчетнаяЗапись.ПарольSMTP;
        Профиль.ПользовательSMTP   = УчетнаяЗапись.ЛогинSMTP;
    Иначе
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
        Профиль.ПарольSMTP         = "";
        Профиль.ПользовательSMTP   = "";
    КонецЕсли;
    
    Возврат Профиль;

КонецФункции


УчетнаяЗапись - это справочник, где хранятся логин, пароль и все остальные настойки доступа к почте. Сравните с вашим, может быстрее найдете в чем проблема
Gigi,
19.06.18, 9:49 Отправить письмо на почту посредством 1С
Gigi @ Сегодня, 10:18 * ,
Кстати, добавьте строки:
Профиль.ИспользоватьSSLSMTP = Истина;
Профиль.ИспользоватьSSLPOP3 = Истина;

SSL шифрование обязательно и для gmail и для mail.ru вроде бы
Gigi,
19.06.18, 9:28 Отправить письмо на почту посредством 1С
Gigi @ Сегодня, 10:18 * ,
Судя по всему что-то не так с почтой, вы уверены что правильно ввели email адрес?
Gigi,
18.06.18, 14:53 Обработка: отбор по подразделению
Constantus @ Сегодня, 15:43 * ,
"+?(ЗначениеЗаполнено(Подразделение), "И ВложенныйЗапрос.Подразделение = &Подразделение", ?(Ошибочные, "И ВложенныйЗапрос.Подразделение = ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)", ""))+"
Constantus,
18.06.18, 11:09 Обработка: отбор по подразделению
Constantus @ Сегодня, 11:53 * ,
|    ИЗ
|        Документ.СписаниеТоваров КАК СписаниеТоваров
|    ГДЕ
|        СписаниеТоваров.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&Дата1, ДЕНЬ) И КОНЕЦПЕРИОДА(&Дата2, ДЕНЬ)
|        И СписаниеТоваров.Проведен = ИСТИНА
|        И СписаниеТоваров.НаДоход = ИСТИНА
|        И СписаниеТоваров.ПометкаУдаления = ЛОЖЬ) КАК ВложенныйЗапрос
|ГДЕ
|    ВложенныйЗапрос.Организация = &Организация
|    "+?(ЗначениеЗаполнено(Подразделение), "И ВложенныйЗапрос.Подразделение = &Подразделение", "")+"
|
|СГРУППИРОВАТЬ ПО
|    ВложенныйЗапрос.Статус,
|    ВложенныйЗапрос.Номенклатура,
|    ВложенныйЗапрос.Организация,
|    ВложенныйЗапрос.Подразделение
|
|УПОРЯДОЧИТЬ ПО
|    Статус,
|    Номенклатура
|АВТОУПОРЯДОЧИВАНИЕ";

    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("Подразделение", Подразделение);
    Запрос.УстановитьПараметр("Дата1", ДатаНачала);
    Запрос.УстановитьПараметр("Дата2", ДатаОкончания);
Constantus,

8 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 17.12.18, 3:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне