Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

8 страниц V   1 2 3 > » 

>  Как в СКД вывести значения в колонки.
Vidocq05
Отправлено: Вчера, 17:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


bizisoft @ 18.01.19, 14:58 * ,
На вашей картинке на РИС 7.1 и РИС 7.2 Вы показываете настройки колонок. Сделайте такой же скриншот, только настроек строк.
  Форум: Система компоновки данных · Просмотр сообщения: #149155 · Ответов: 6 · Просмотров: 141
 

>  Как в СКД вывести значения в колонки.
Vidocq05
Отправлено: 16.01.19, 11:38


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(bizisoft @ 16.01.19, 10:15) *
Единственно не понял, что подразумевается под ресурсами

В СКД есть вкладка "Ресурсы", туда добавляете сумму и количество.
  Форум: Система компоновки данных · Просмотр сообщения: #149003 · Ответов: 6 · Просмотров: 141
 

>  Разработка механизма гибкой настройки прав доступа
Vidocq05
Отправлено: 26.12.18, 15:06


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(sava1 @ 26.12.18, 12:29) *
Если очень хочется - смотрите в сторону БСП

Спасибо. Вроде похоже на то, что нужно. Буду разбираться.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148422 · Ответов: 2 · Просмотров: 135
 

>  Разработка механизма гибкой настройки прав доступа
Vidocq05
Отправлено: 26.12.18, 11:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


УТП 1.2 (обычные формы)

Нужно разработать механизма гибкой настройки прав доступа. Например, сегодня запретить Пупкину С.М. редактировать документы старше 3-х дней, а завтра разрешить, и т.п.
Базового механизма, что есть в УТП недостаточно.
Просто добавить дополнительные роли не подходит, т.к. "хотелок" у руководства по поводу прав доступа очень много и придется создавать целую кучу ролей.
Нужен механизм универсальный и гибкий.
Пока есть общее представление: создать несколько дополнительных ролей с RLS и несколько дополнительных справочников. Но конкретно я еще не придумал. Поиск в интернете ничего не дал, только общее понятие ролей, RLS и работа с ними.

В общем нужна сама идея. Кто что подскажет?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148408 · Ответов: 2 · Просмотров: 135
 

>  Выделение текста итогов в отчете
Vidocq05
Отправлено: 21.12.18, 14:33


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


VolkMen @ Сегодня, 11:15 * ,
Отчет не имеет настроек, поэтому нельзя.
Есть 2 варианта:
1. Нанять программиста 1С чтобы он сделал на основе этого отчета внешний отчет.
2. Если Вам это нужно, например, для красоты при печати, то сохраните результат отчета как табличный документ или как документ эксель, ну а там редактируйте его как хотите.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #148305 · Ответов: 2 · Просмотров: 151
 

>  Можно ли имея ссылку на строку таб. части получить ссылку на объект?
Vidocq05
Отправлено: 17.12.18, 12:44


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


twilight_dream @ 14.12.18, 19:02 * ,
На сколько я знаю - никак.
Но должен быть другой способ получить ссылку. Опишите более подробно где и как вы получаете "строкаТЧ", откуда куда передаете ...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #148164 · Ответов: 2 · Просмотров: 155
 

>  Почему из модуля объекта нельзя вызвать команду записи элемента метаданных текущего объекта
Vidocq05
Отправлено: 07.12.18, 16:13


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Gigi @ 07.12.18, 16:03) *
Короче ничего не пойму....

Что не понятного. Вы нажимаете "Записать", срабатывает Ваш код в "ПередЗаписью". В нем просходит попытка записи объекта справочника, при этом опять срабатывает Ваш код в "ПередЗаписью" в котором опять происходит попытка записи объекта справочника и так до бесконечности.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #147899 · Ответов: 28 · Просмотров: 782
 

>  Почему из модуля объекта нельзя вызвать команду записи элемента метаданных текущего объекта
Vidocq05
Отправлено: 07.12.18, 15:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Gigi @ 07.12.18, 15:51) *
В том и все дело что это "ПередЗаписью".

В данном случае это одно и тоже - уходит в вечный цикл.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #147897 · Ответов: 28 · Просмотров: 782
 

>  Почему из модуля объекта нельзя вызвать команду записи элемента метаданных текущего объекта
Vidocq05
Отправлено: 07.12.18, 15:42


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Gigi @ 07.12.18, 15:20) *
Процедура вписана в справочнике: "ТЕСТ_УникальнаяСвязь_1"

Если Вы свой код вписали например в процедуру "ПриЗаписи" то ваш код уходит в вечный цикл и клиент вырубается.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #147894 · Ответов: 28 · Просмотров: 782
 

>  Выборка запросом по ТаблицеЗначений
Vidocq05
Отправлено: 04.12.18, 14:01


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(bizisoft @ 04.12.18, 12:57) *
Добавил
Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;

Это лишнее, и можно убрать.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #147779 · Ответов: 9 · Просмотров: 236
 

>  Запрет на ввод даты больше текущей в документе с сообщением в УФ
Vidocq05
Отправлено: 03.12.18, 18:12


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Не знаю как в УФ, а в обычных есть свойство формы "ИспользоватьРежимПроведения". Его описание:

Свойство Использовать режим проведения может принимать следующие значения:
● Неоперативный – документ всегда будет проводиться в неоперативном режиме. Если отсутствуют права на неоперативное проведение, будет выдано исключение.
● Оперативный – документ всегда будет проводиться в оперативном режиме. Если отсутствуют права на неоперативное проведение, то будет выдано исключение при попытке провести документ прошлого периода.
● Запрашивать – система всегда будет запрашивать текущий режим проведения.
● Автоматически – в этом случае система работает по следующему алгоритму:
● если дата документа меньше текущей, выполняется неоперативное проведение;
● если дата документа равна текущей, выполняется оперативное проведение;
● если дата документа больше текущей, выдается исключение;
● если невозможно провести документ в выбранном режиме (не хватает прав доступа и т. д.), также будет выдано исключение;
● если на стороне клиента режим проведения неизвестен, то в параметр РежимПроведения обработчика события ПередЗаписью будет передано
значение Неопределено.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #147749 · Ответов: 5 · Просмотров: 195
 

>  Прерывание "вечного цикла" фонового задания
Vidocq05
Отправлено: 28.11.18, 10:01


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


asilkhan @ Сегодня, 8:54 * ,
Понятно относительно. Код выложите.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #147572 · Ответов: 2 · Просмотров: 157
 

>  При ПолучитьОбъект(); выдает Элемент не выбран!
Vidocq05
Отправлено: 15.11.18, 16:35


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Правильней было бы создать реквизит обработки например с именем "СсылкаНаДок" с типом "ДокументСсылка.УстановкаЦенНоменклатуры", а не "Номер" и "Дата". И у Вас был бы код

Док = Объект.СсылкаНаДок.ПолучитьОбъект();
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #147193 · Ответов: 11 · Просмотров: 422
 

>  Не работает перетаскивание в дереве значений
Vidocq05
Отправлено: 24.10.18, 16:22


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Изначально я нашел в интернете кусок кода без каких либо разъяснений.
Процедура ПереместитьСтрокуДерева(Дерево, ПеремещаемаяСтрока, НовыйРодитель, Уровень = 0)
  
   Если Уровень = 0 Тогда
              
       НоваяСтрока = НовыйРодитель.Строки.Добавить();
       ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);
       ПереместитьСтрокуДерева(Дерево, ПеремещаемаяСтрока, НоваяСтрока, Уровень + 1);
      
       Если ПеремещаемаяСтрока.Родитель = Неопределено Тогда
           Дерево.Строки.Удалить(ПеремещаемаяСтрока);
       Иначе
           ПеремещаемаяСтрока.Родитель.Строки.Удалить(ПеремещаемаяСтрока);
       КонецЕсли;
      
   Иначе
      
       Для Каждого Стр ИЗ ПеремещаемаяСтрока.Строки Цикл
           НоваяСтрока = НовыйРодитель.Строки.Добавить();
           ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);
           ПереместитьСтрокуДерева(Дерево, Стр, НоваяСтрока, Уровень + 1);
       КонецЦикла;
      
   КонецЕсли;
      
КонецПроцедуры

Я его сначала не совсем понял, но потом разобрался. И в результате получилось обычное перетаскивание в дереве значений. Вот код:
Процедура МаршрутыТППроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
    СтандартнаяОбработка = Ложь;
КонецПроцедуры

Процедура МаршрутыТППеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)    
    ПереместитьСтрокуДерева(МаршрутыТП, ПараметрыПеретаскивания.Значение, Строка);        
КонецПроцедуры

Процедура ПереместитьСтрокуДерева(Дерево, ПеремещаемаяСтрока, НовыйРодитель, Уровень = 0)
  
   Если Уровень = 0 Тогда
              
       НоваяСтрока = НовыйРодитель.Строки.Добавить();
       ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);
       ПереместитьСтрокуДерева(Дерево, ПеремещаемаяСтрока, НоваяСтрока, Уровень + 1);
      
       Если ПеремещаемаяСтрока.Родитель = Неопределено Тогда
           Дерево.Строки.Удалить(ПеремещаемаяСтрока);
       Иначе
           ПеремещаемаяСтрока.Родитель.Строки.Удалить(ПеремещаемаяСтрока);
       КонецЕсли;
      
   Иначе
      
       Для Каждого Стр ИЗ ПеремещаемаяСтрока.Строки Цикл
           НоваяСтрока = НовыйРодитель.Строки.Добавить();
           ЗаполнитьЗначенияСвойств(НоваяСтрока, ПеремещаемаяСтрока);
           ПереместитьСтрокуДерева(Дерево, Стр, НоваяСтрока, Уровень + 1);
       КонецЦикла;
      
   КонецЕсли;
      
КонецПроцедуры

Это не совсем так, как мне нужно, но дальше я разберусь.
Всем спасибо!
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146567 · Ответов: 4 · Просмотров: 304
 

>  Не работает перетаскивание в дереве значений
Vidocq05
Отправлено: 24.10.18, 12:55


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


sava1 @ Сегодня, 13:13 * ,
Нет, ничего не определено.
Я предполагал, что достаточно поставить галочки "РазрешитьНачалоПеретаскивания" и "РазрешитьПеретаскивание" и перетаскивание в дереве значений будет работать как и в таблице значений (ну хотя бы в пределах ветки). В интернете простого (т.е. без всяких заморочек) примера перетаскивания в дереве значений не нашел.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146563 · Ответов: 4 · Просмотров: 304
 

>  Не работает перетаскивание в дереве значений
Vidocq05
Отправлено: 24.10.18, 10:59


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Доброго времени суток.

Обычные формы.
На форме есть табличное поле (ТП) с типом дерево значений. Установлены галочки "РазрешитьНачалоПеретаскивания" и "РазрешитьПеретаскивание". ТП заполняю запросом. Но перетаскивание не работает, не в пределах ветки, нигде.
Делаю тип ТП таблица значений - все ОК.
В интернете только находил, что должно работать. Ну если перетаскивать в другую ветку, то нужно программно менять родителя. Но это потом.
Сейчас меня интересует, почему не работает базовый механизм перетаскивания.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146561 · Ответов: 4 · Просмотров: 304
 

>  совместима ли бухгалтерия для украины 2.0 с платформой 3.11
Vidocq05
Отправлено: 16.10.18, 12:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


SvetaS @ Сегодня, 13:17 * ,
Цитата(Petre @ 16.10.18, 13:12) *
Практикую следующее.
1. Включаю поддержку с возможностью изменений, устанавливая запрет для всех объектов, кроме корня конфигурации.
2. Переключаю режим совместимости на 8.3.7 (выше - вызывает проблемы).
3. Добавляю расширение.

Можно так. Но обновлять конфигурацию в полностью автоматическом режиме уже не получится.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146337 · Ответов: 14 · Просмотров: 496
 

>  совместима ли бухгалтерия для украины 2.0 с платформой 3.11
Vidocq05
Отправлено: 16.10.18, 11:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(SvetaS @ 16.10.18, 12:30) *
нужно чтобы конфигурация не была снята с поддержки, в этом и был вопрос

Если Вам нужно, что бы конфигурация находилась на полной поддержке и использовать расширения, ответ - этого сделать нельзя.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146331 · Ответов: 14 · Просмотров: 496
 

>  совместима ли бухгалтерия для украины 2.0 с платформой 3.11
Vidocq05
Отправлено: 16.10.18, 11:23


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(SvetaS @ 16.10.18, 11:55) *
кто может сделать адаптацию "Бухгалтерию для Украины 2.0" под платформу 3.11, для использования механизма расширений?

Сделать то можно, но для этого нужно отключить режим совместимости + скорее всего нужно будет вносить корректировки в конфигурацию. Результат - конфигурация снята с поддержки. В данном случае смысла в расширениях не вижу.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146328 · Ответов: 14 · Просмотров: 496
 

>  "Ошибка при выполнении файловой операции" при обновлении конфигурации
Vidocq05
Отправлено: 28.09.18, 8:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Vladal @ Вчера, 13:02 * ,
Ну это то понятно. Стоял вопрос, почему так происходит и что делать, что бы этого избежать, ну или уже потом исправить.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145806 · Ответов: 5 · Просмотров: 1075
 

>  "Ошибка при выполнении файловой операции" при обновлении конфигурации
Vidocq05
Отправлено: 26.09.18, 15:56


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


levi @ Сегодня, 15:37 * ,
Спасибо.
Оказывается это довольно не редкий случай.

Пробовал, но не помогло:
1. Снял с поддержки через меню конфигурация, настройка поддержки;
2. Далее через сравнение и объединение объединил с подготовленной типовой cf-кой того же релиза. В этот момент он спрашивает о возможности поставить на поддержку, согласился.
3. Снял все галки при сравнении/объединении.
4. Принял измененя.

Помогло:
В настройке поддержки установил для всей конфигурации "Редактируется с сохранением поддержки" с установленной галочкой "Установить для подчиненных объектов".
Естественно для всех объектов конфигурации установился режим "Редактируется с сохранением поддержки", что не очень хорошо, т.к. были объекты с режимом "Объект поставщика не редактируется".
Ну судя по всему, из-за этого режима и была проблема. Наверное к одному из объектов был применен данный режим хотя сам объект был изменен.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145734 · Ответов: 5 · Просмотров: 1075
 

>  "Ошибка при выполнении файловой операции" при обновлении конфигурации
Vidocq05
Отправлено: 26.09.18, 10:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


База серверная. Конфигурация УТП 1.2. Платформа 8.3.2442. SQL Server 2008.
Обновил конфигурацию с 1.2.41.1 на 1.2.42.2 - все ОК. Далее обновляю с 1.2.42.2 на 1.2.43.1 - вроде все ОК, но конфигурация поставщика перестала быть доступной. При попытке обновить конфигурацию на следующий релиз, или открыть конфигурацию поставщика, или сохранить конфигурацию поставщика выдает ошибку "Ошибка при выполнении файловой операции".
Кто нибудь сталкивался с таким? Что я делаю не так?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145719 · Ответов: 5 · Просмотров: 1075
 

>  Универсальный отчет задваивает группировки
Vidocq05
Отправлено: 17.09.18, 12:23


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


twilight_dream @ 15.09.18, 9:58 * ,
Установите галочку "Расширенная настройка" и проанализируйте какие настройки установлены во вкладках "Общие", "Группировки" и "Дополнительные поля".
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145457 · Ответов: 2 · Просмотров: 322
 

>  Как сделать отчет периодами за каждый день
Vidocq05
Отправлено: 17.09.18, 12:06


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


burza @ 14.09.18, 12:37 * ,
Прошу прощения. Сейчас работой пригрузили, нет времени. Постараюсь выделить время в ближайшие дни.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145455 · Ответов: 17 · Просмотров: 654
 

>  Как сделать отчет периодами за каждый день
Vidocq05
Отправлено: 12.09.18, 9:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 181
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(burza @ 11.09.18, 12:53) *

По ссылке ничего нет.
Цитата(burza @ 12.09.18, 9:21) *
Поможете, или то было просто так сказано.

Попытаюсь. Кидайте отчет и конфигурацию.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #145317 · Ответов: 17 · Просмотров: 654
 

8 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 22.01.19, 12:47
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне