Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


>  Добавление вычисляемого поля в динамический список
ed.kharkov
Отправлено: 11.07.18, 10:10


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


Andrian @ Сегодня, 11:06 * ,
Обратите внимание на соединения в запросе, а именно на соединение с регистром сведений СостоянияЗаказовКлиентов.
Если в этом регистре несколько записей для одно заказа, то это может быть причиной ошибки.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143245 · Ответов: 8 · Просмотров: 145
 

>  Обнаружено дублирование ключевых значений в колонках: ссылка
ed.kharkov
Отправлено: 11.07.18, 10:08


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


Andrian @ Сегодня, 11:01 * ,
Обратите внимание на соединения в запросе, а именно на соединение с регистром сведений СостоянияЗаказовКлиентов.
Если в этом регистре несколько записей для одно заказа, то это может быть причиной ошибки.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143244 · Ответов: 4 · Просмотров: 117
 

>  Добавление вычисляемого поля в динамический список
ed.kharkov
Отправлено: 10.07.18, 14:09


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


Andrian @ Сегодня, 14:46 * ,
Добрый день.

РАЗНОСТЬДАТ(<Дата1>, <Дата2>, ДЕНЬ)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143220 · Ответов: 8 · Просмотров: 145
 

>  При запросе в условие выдает несоответствие типу
ed.kharkov
Отправлено: 09.07.18, 8:47


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


Добрый день.
Можно сам текст запроса?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143191 · Ответов: 2 · Просмотров: 96
 

>  как передать переменную с клиента на сервер
ed.kharkov
Отправлено: 03.07.18, 15:07


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


lolmatrix @ Сегодня, 15:55 * ,
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
   СписокЗЧНаименованиеПриИзмененииНаСервере();
   Прочитать();
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143097 · Ответов: 6 · Просмотров: 209
 

>  как передать переменную с клиента на сервер
ed.kharkov
Отправлено: 03.07.18, 14:38


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


Petre @ Сегодня, 15:25 * ,
ТекущиеДанные недоступны на сервере.

На сервере можно получить так:

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    СтрокаТЧ = Объект.СписокЗЧ[Элементы.СписокЗЧ.ТекущаяСтрока];
    
    // . . .

КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143091 · Ответов: 6 · Просмотров: 209
 

>  Веб-клиент: СписокВыбора в табличной части документа
ed.kharkov
Отправлено: 02.07.18, 11:43


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


kapacb @ Сегодня, 12:25 * ,
Написать серверную функцию, которая будет получать значение поля 1 и возвращать значения, которыми надо заполнить список выбора.
В процедуре ПриАктивизацииСтроки вызывать эту функцию.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143036 · Ответов: 14 · Просмотров: 232
 

>  Веб-клиент: СписокВыбора в табличной части документа
ed.kharkov
Отправлено: 02.07.18, 11:20


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


Как вариант можно попробовать при активизации строки заполнять список выбора поля 2 если есть выбранное значение в поле 1.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143034 · Ответов: 14 · Просмотров: 232
 

>  Веб-клиент: СписокВыбора в табличной части документа
ed.kharkov
Отправлено: 02.07.18, 9:10


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


kapacb @ Сегодня, 9:51 * ,
Согласен, есть определенные неудобства....
А "НачалоВыбораИзСписка" тоже не работает?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143024 · Ответов: 14 · Просмотров: 232
 

>  Веб-клиент: СписокВыбора в табличной части документа
ed.kharkov
Отправлено: 02.07.18, 8:37


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


kapacb @ Сегодня, 9:13 * ,
Добрый день.

А если попробовать заполнять список выбора второго поля при изменении значения первого поля?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143021 · Ответов: 14 · Просмотров: 232
 

>  При вводе на основании перезаполнить реквизит введенного документа
ed.kharkov
Отправлено: 26.06.18, 10:33


Общительный
**

Группа: Пользователи
Сообщений: 11
Регистрация: 25.06.18
Пользователь №: 61191


l2d808 @ Сегодня, 11:12 * ,
Добрый день.

Так может достаточно будет написать вот так

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, ТекстЗаполнения, СтандартнаяОбработка)
        Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ВведенняВиведенняТранспортногоЗасобуНаПідприємство") Тогда
              Документ = ДанныеЗаполнения;    
              ТранспортнийЗасіб = ДанныеЗаполнения.ТранспортнийЗасіб;
        КонецЕсли;
КонецПроцедуры


В процедура ПослеЗаписи() вобще не нужна в данном случае.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142933 · Ответов: 2 · Просмотров: 135
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 17.07.18, 21:10
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне