Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5, свеженьких 3
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

4 страниц V   1 2 3 > » 

>  Как отобразить в панели действий общую форму с общими реквизитами
Gigi
Отправлено: Вчера, 13:04


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Для того, что бы перейти к сути малое вступление...
Как то на этом форуме меня обвиняли, что я иду не правильным путем решения той или иной задачи. И что поэтому изобретаю велосипед.
Вообще к этому может быть разное отношение... для меня лично главное, это удобство юза и наглядность отображения. Вот что, самое важное. Все остальное второстепенно.
Поэтому главное это цель а уже потом все остальное... велосипед или самокат.
Т.е. сама среда разработки нужна, для того, что бы данные отображались, как требуется для дела. И тут просто не всех устраивает другой подход... когда делаешь только то, что навязывает платформа и когда не можешь сделать так как нужно и удобно для твоего случая. В связи с чем приходиться извиваться и действительно велосипед изобретать. Тогда как если среда не позволяет отобразить данные в желаемом формате то, это уже проблема не программиста, а самой среды разработки.
Ладно перейду к сути..
Что мне нужно?
На самом деле ничего особенного...
Допустим есть подсистема с именем "Абоненты"
И как мы знаем у подсистем обычно две панели (панель навигации и панель действий)
В панели навигации допустим строка справочника "Объекты". А в панели действий как обычно, естественно форма списка этого справочника.
Это в обычном случае.
Мне нужно следующее...
И тут хочу опять подчеркнуть... не важно как это вписывается в стандарт платформы... а важно только то возможно ли так отобразить, чисто для пользователя
Так вот, мне нужно, создать подсистему с именем самой организации бухгалтерии.
И где и как я хочу, что бы данные самой организации отображались.
Допустим переходим в подсистему с именем организации и так же видим две панели.
Только в панели навигации допустим видим строку: "Организация"
Нажимаем на эту строку и уже в панели действия видим не какой то список, как обычно, а просто Форму с полями общих реквизитов (Форму на подобие ФормыЭлемента) которая полностью занимает всю панель действий.
Т.е. общую форму с полями общих реквизитов организации и группами вкладок как в ФормеЭлемента .
На пример видим форму с полями: юр/физ адрес, Директор, ГлавБух... банковские реки... ИНН, БИК и т.д.
И все это на самой панели действий вместо какого либо формы списка.
Вот собственно что нужно.
Как это сделать?
и можно ли это?
Если да, то как?
И какие действия нужно сделать в разделе платформы с именем: "общие"

Буду ОЧЕНЬ признателен за помощь!










  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128900 · Ответов: 0 · Просмотров: 54
 

>  Установить режим Только просмотр на реквизит ТЧ
Gigi
Отправлено: 26.06.17, 10:18


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ 23.06.17, 17:41 * ,
Все понял!
Всем спасибо!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128848 · Ответов: 5 · Просмотров: 212
 

>  Установить режим Только просмотр на реквизит ТЧ
Gigi
Отправлено: 23.06.17, 16:05


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Кто ни-будь не подскажет как это сделать ... программно естественно.
так:
Объект.ТЧимя.ТЧреквизит.ТолькоПросмотр=ИСТИНА; //ЛОЖЬ

Не хочет с...а!
Пробовал по другому ... разные варианты ... тоже капризничает ... зараза.
Опять методом тыка... никак не попаду.
Поэтому нужна помощь..
Буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128784 · Ответов: 5 · Просмотров: 212
 

>  Можно ли создать один реквизит, с двумя типами
Gigi
Отправлено: 19.06.17, 14:34


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ Сегодня, 14:28 * ,
Цитата
В типовых конфигурациях непосредственное удаление без проверки на наличие ссылок ЗАПРЕЩЕНО.
Это можно настроить правами, в правах на всех объекты у обычных пользователей забирайте галочку "Интерактивное удаление помеченных" - тогда пользователь сможет максимум пометить на удаление. Непосредственно удалить он не сможет. У него не будет в меню красного крестика.

Отлично!
Другое дело ... а то думал ... в SQL просто не работал ... видимо там тоже не желательно что либо удалять
Ладно! Пока не знаю на счет галочки на
Цитата(Bernet @ 19.06.17, 14:16) *
"Составной тип"

насколько применим, но надеюсь не разочарует.
Ладно! Спасибо!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128556 · Ответов: 5 · Просмотров: 233
 

>  Можно ли создать один реквизит, с двумя типами
Gigi
Отправлено: 19.06.17, 14:23


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Bernet @ Сегодня, 14:16 * ,
Цитата(Bernet @ 19.06.17, 14:16) *
Удаление объекта на который есть ещё где-то ссылка априори не есть правильно! Это нарушает целостность базы данных и в принципе идет в расход с идеологией баз данных в целом.

Согласен! Только это 20-ти пользователям не объяснишь smile.gifsmile.gif.
БЕСПОЛЕЗНО!
А что если и вовсе просто запретить удаление?
Дело в том, что по умолчанию можно удалять. Без запрета. Правда до этого нужно пометить. После чего ссылки удаляются автоматический ... должно так...
Но почему то, я этот вопрос не пойму. Тестил... вроде пометил, и потом удалил. А реквизит ссылки в документе все равно написал: "<Объект не найден>"
Блиин! Почему?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128553 · Ответов: 5 · Просмотров: 233
 

>  Можно ли создать один реквизит, с двумя типами
Gigi
Отправлено: 19.06.17, 14:09


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Здравствуйте!
Меня интересует один вопрос, который может не очень простой и обычный.
Допустим у нас есть справочник и документ. Последний имеет ссылку, на какой ни-будь реквизит справочника. И допустим пользователь один элемент справочника, на который ссылался созданный документ пометил, а потом удалил.
Не для кого не секрет, что в таком случае, происходит следующее:
Во первых: после удаления в реквизите ссылки документа который ссылался на удаленный элемент справочника появляется надпись: «<Объект не найден>…..»
Во вторых: допустим код удаленного элемента: «000000055»….если после этого, создать новый элемент то, система может повторить этот же код опять. И это не совсем устаивает . Нужно, что бы созданный код никогда больше не повторялся. Вне зависимости от удаления или создания нового элемента.
Поэтому главный вопрос.
Нельзя ли сделать следящее.
Что бы реквизит оставался ссылкой пока элемент ссылки не удален. Но как только элемент подвергся удалению, вместо надписи: «<Объект не найден>…..», что бы реквизит приобретал другой тип. Тип строки.
Ведь обычно чисто по СТАНДАРТУ на один реквизит один тип. А нужно, что бы был один реквизит, с двумя типами.
И что бы значение реквизита оставалось, а тип менялся в зависимости от того или иного действия.
Есть ли такая возможность в платформе 1С и можно ли это сделать?
Если да то, как?
Буду признателен!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128551 · Ответов: 5 · Просмотров: 233
 

>  Передать и вставить значение в ФормыВыбора
Gigi
Отправлено: 19.06.17, 8:30


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Gigi @ Вчера, 13:16 * ,
Понял ошибку...
Для тех, которые тоже сталкивались...
&НаКлиенте
Процедура СубТочка_Выбрать(Команда)
Если Объект.Код = ""  Тогда
Предупреждение("Для определения суб-точек учета объект не сохранен!");
Перейти ~Выход;
КонецЕсли;
//================= ЗАПУСК 1==========================
ФормаВыбор_ТочкиСнабж=ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
//-------------------------------------------
ВыбранныйЭл_ТочкиСнабж = ФормаВыбор_ТочкиСнабж.ОткрытьМодально();
//-------------------------------------------
Если ВыбранныйЭл_ТочкиСнабж=Неопределено Тогда Перейти ~Выход; КонецЕсли;
//-------------------------------------------
ПараметрыЭлемента = Новый Структура("Ключ",ВыбранныйЭл_ТочкиСнабж);
ФормаОбъектаПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", ПараметрыЭлемента);
            ТочкаСнабж_Имя=ФормаОбъектаПолучить.Объект.Наименование;
//==================== ЗАПУСК 2 =======================
ФормаВыбор_ТочкиПодключ = ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
ВыбранныйЭл_ТочкиПодключ = ФормаВыбор_ТочкиПодключ.ОткрытьМодально();
//-------------------------------------------
Если ВыбранныйЭл_ТочкиПодключ=Неопределено Тогда Перейти ~Выход; КонецЕсли;
//-------------------------------------------
ПараметрыЭлемента = Новый Структура("Ключ",ВыбранныйЭл_ТочкиПодключ);
ФормаОбъектаПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", ПараметрыЭлемента);
            ТочкаПодключ_Имя=ФормаОбъектаПолучить.Объект.Наименование;
//=======================================================
Если ВыбранныйЭл_ТочкиСнабж<>Неопределено и ВыбранныйЭл_ТочкиПодключ<>Неопределено Тогда
Если Вопрос("Определить подключение учетной точки: «"+ТочкаПодключ_Имя+"» к точке учета: «"+ТочкаСнабж_Имя+"»?",РежимДиалогаВопрос.ДаНет,,,"Создение суб-точки учета")=КодВозвратаДиалога.Да Тогда
// Действие ....    
КонецЕсли;
КонецЕсли;
//=======================================================
~Выход:;
КонецПроцедуры

Если кто доработает то буду признателен.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128536 · Ответов: 2 · Просмотров: 239
 

>  Передать и вставить значение в ФормыВыбора
Gigi
Отправлено: 18.06.17, 12:16


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Сталкнулся с проблемой ... требуеться Ваша помощь.
Нужно два раза запустить ФормуВыбора и в самим всавленную поля пойска каждой вставитть нужное значения выбора элемента.
Внизу процедура кнопки.
И дело в том, что то, что обозначено коментарием: "ЗАПУСК 1" работает нормально. Т.е. когда форма открылась нужное значение успешно всавляеться в нужное поле Формы на верхней ее панели.
А уже во втором судчае (в месте обозначеном: "ЗАПУСК 2"), никак не получаеться получить то же самое, что и при ЗАПУСКЕ 1
Т.е. перемнные: Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения); актуальны, но вторая: "ТочкаСнабжения" НУ НИКАК НЕ ВСТАВЛЯЕТЬСЯ в поле формы: "ТочкаСнабжения"
Не пойму в чем причина.
Расчитываю на Вашу помощь
&НаКлиенте
Процедура СубТочка_Выбрать(Команда)
Если Объект.Код = ""  Тогда
Предупреждение("Для определения суб-точек учета объект не сохранен!");
Перейти ~Выход;
Иначе
ОБЪЕКТимя=Объект.Найменование;
КонецЕсли;
//=============== ЗАПУСК 1 ============================
ФормаВыбор_ТочкаСнабжение=ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
ФормаВыбор_ТочкаСнабжение.ОбъектПринадлежности=ОБЪЕКТимя;
//-------------------------------------------
Выбор_ТочкаСнабжение = ФормаВыбор_ТочкаСнабжение.ОткрытьМодально();
//=====================================================
Если Выбор_ТочкаСнабжение <> Неопределено Тогда
//=============== ЗАПУСК 2 ============================
знВыборПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", новый Структура("Ключ", Выбор_ТочкаСнабжение));
знТочкаСнабжения=знВыборПолучить.Объект.Найменование;
//################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,); //ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.Форма.ФормаВыбора",,);
//ТУТ ПОЛЕ ФормыВыбора: "ТочкаСнабжения", НУ НИКАК НЕ ХОЧЕТ ПРИНИМАТЬ ЗНАЧЕНИЕ ПЕРЕМЕННОЙ; "ТочкаСнабжения". НИКАК ЗАРАЗА!
//УЖЕ ПРИ ВТОРОМ ЗАПУСКЕ ФормыВыбора ПРОСТО ИГНОРИРУЕТ ЕЕ ... ПРОПУСКАЕТ
ФормаВыбор_ТочкаПодключение.ТочкаСнабжения=знТочкаСнабжения;
ФормаВыбор_ТочкаПодключение.Открыть();
Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения);
//################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
КонецЕсли;
//===========================================
~Выход:;
КонецПроцедуры

Буду очень признателен Вам!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128509 · Ответов: 2 · Просмотров: 239
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 16.06.17, 9:19


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Gigi @ Вчера, 19:54 * ,
Уже решил вопрос.
Не знаю настолько вяжется но вроде, нормально работает! Без какого либо сбоя.
Вот в таком формате:
//########## МОДУЛЬ ФОРМЫ ЭЛЕМЕНТА СПРАВОЧНИКА: "ОБЪЕКТ" ##########
//Кнопка в форме справочника "ОБЪЕКТ" в командной панели динамического списка Справочника "ТОЧКА"
&НаКлиенте
Процедура Кнопка_ДобавитьТочкуУчета(Команда)
//===========================================
Если Объект.Код = ""  Тогда
Предупреждение("Для определения точек учета объект не сохранен!");
Перейти ~Выход;
КонецЕсли;
//===========================================
Форма_ТОЧКА = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", новый Структура("Ключ", ,,ЭтаФорма));
//===========================================
ЭлементОбъекта=SubFx_СерверПойскЗапись.ПолучитьЭлементОбъектаПоКодуНомеру("Справочники","ОБЪЕКТ",Объект.Код); //функция из обшего модуля для получающая объект по коду/номеру
Форма_ТОЧКА.Объект.БалансоваяПринадлежность=ЭлементОбъекта; // Линия присваивания  реквизиту справочника ТОЧКА в данном случае с именем: "БалансоваяПринадлежность"
//===========================================
Форма_ТОЧКА.ОткрытьМодально();
//===========================================
Отобор_ТочкиУчета(); //Процедура отбора динамического списка справочника: "ТОЧКА" с увязкой их балансовой принадлежности.
~Выход:;
КонецПроцедуры

//########## МОДУЛЬ ФОРМЫ ЭЛЕМЕНТА СПРАВОЧНИКА: "ТОЧКА" ##########
&НаКлиенте
Процедура ПриОткрытии(Отказ)
//===================================================
Если Объект.Код="" и Объект.БалансоваяПринадлежность.Пустая() тогда
стрПредупреждение="Данный способ обычного создания новой учетной точки НЕ РЕКОМЕНДУЕТСЯ!
|Так как при нем нужно в ручном режиме указывать некоторые парамметры учетной точки. От которых зависит правильный учет данных!
|Что бы нужные для учета параметры устанавливались автоматический, новую учетную точку необходимо создавать ТОЛЬКО В ФОРМЕ ОБЪЕКТА!
|-----------------------------------------------------------------------------
|Открыть форму создания новой учетной точки?";
    Если Вопрос(стрПредупреждение,РежимДиалогаВопрос.ДаНет,,,"Создение точки учета обычным путем")=КодВозвратаДиалога.Да Тогда
    Иначе
    Отказ = Истина;
    КонецЕсли;        
КонецЕсли;
//===================================================
КонецПроцедуры

Вот собственно все что нужно было для преследуемой простой цели.
А что касается Владелец..Подчиненный.. Родитель... сынок и т.д.
Все это конечно очень хорошо и удобно. Но не всегда.
Как мне самому думается, владелец-подчиненный очень удобен, когда у одного справочника много справочников в подчинении ... пять шесть или двадцать.
Тогда та самая боковая панель навигации нужна и очень удобна.
Но в моем случае, речь всего лишь об одном владельце и подчиненном. А эта боковая панель ничему для всего лишь одной строки с боку.
В таком случае удобнее, роль этой строки перенести в группы(вкладки) с динамическим списком с нужными отбором.
Понятное дело, что это не совсем по стандарту, но лично для меня это НЕ АРГУМЕНТ!
Потому, что важно не то по стандарту или нет, а только то как удобнее пользоваться. Вот что важнее..
я почему все это говорю.
На эту тему ... в другой рубрике:
авто-запись данных на сервер для реквизита ссылка
я был понят не правильно. и спор так затянулся, что наверно владелец сайта подумал.... когда они закончат эту свою болтовню smile.gifsmile.gif
На этот раз думаю буду правильно понят.
Вот собственно и все
Ладно! В любом случае спасибо Всем!













  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128472 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 19:54


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


sava1 @ Сегодня, 17:30 * ,
Цитата(sava1 @ 15.06.17, 17:30) *
Вы вооще понимаете принцып асинхронных вызовов и работу клиент-сервера?
Вы никогда не найдете открытые формы , кроме своих.


Ну да... вообще как все работает в этом слабо... признаюсь.
просто разбираться в принципе работ и вдаваться во все это на это пока нет времени. Надо заканчивать то. что затянулось.
Все это ..... это уже отдельная история. Это надо сесть и во всем шаг за шагом доскональна разобраться.
А пока надо просто срочно сделать работу и успеть пока директор в отпуске. Что бы предложить практичный и работающий вариант разработки.
Хотя и написанный на очень грубом языке.
Мне просто нужно просто где то обозначить то, что указанная форма открыта и то, что форма закрыта
Если я события открытия и закрытия формы запишу на сервер, то как мне думается получиться чехорда.
Потому, что как мне понимается сервер ведь общего доступа. А клиент индивидуального. И каждый пользователь будет влиять на запись Да или Нет.
Блиин! Я уже думаю, может с каждым открытием формы создавать какой-нибудь блокнот с именем :"достало уже учиться" ... и с закрытием его удалять.
И так и дать понять машине указанная форма открыта или закрыта.
Вот до такого извращения уже дохожу.
Не мог бы кто подсказать что нибудь получше, чем этот ужас?
Мне просто нужно обозначить одно единственное!
ОТКРЫТА ЛИ УКАЗАННАЯ ФОРМА?
Всего лишь
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128440 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 17:24


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


sava1 @ Сегодня, 17:15 * ,
Цитата(sava1 @ 15.06.17, 17:15) *
Они в очереди будут стоять?

Не понял при чем очередь..
Просто дело в том, что на пример один пользователь открыл форму, и параметр из перечисления на форме стал "да". т.е. форма отрыта.
И в это самое время, вдруг бац и другой на другом компе закрыл эту форму пока у первого не закрыта и параметр стал "нет".
Иными словами повлияет ли все это негативно... не будет ли коллапс.
В таком случае нужно, что бы параметры открытости или закрытости формы работали только для одного компа.
И вопрос... решает ли этот вопрос такое решение:
Цитата(Gigi @ 15.06.17, 16:50) *
Хотя продолжая данную тему, а что если в перечислении создать элемент "ДаНет" с двумя значениями: Да/Нет
И вставить реквизит со ссылкой на этот элемент перечисления в нужную форму.
И таким образом регистрировать ПриОткрытии (Да) ПриЗакритии(Нет)
Это конечно изврат но все таки... как будет работать?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128434 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 17:09


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(Petre @ 15.06.17, 16:56) *
О чем это вы?


Нужно без этого

Gigi @ Сегодня, 17:06 * ,
Мне нужно просто установить обмен данными между справочниками ПО СВОЕМУ УСМОТРЕНИЮ!
Без использования Владелец.
Ладно! Видимо это невозможно!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128432 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 16:59


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(Gigi @ 15.06.17, 16:50) *
Это конечно изврат но все таки... как будет работать?

Так что, возвращаясь к такому решению вопрос.
Такое решение не опасно?
Ведь на клиенте пользователей будет несколько.
И вообще наСервере на клиенте. Последнее означает ли то, что событие смены параметра будет иметь отношение только к компьютеру одного пользователя?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128424 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 16:50


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Gigi @ Сегодня, 16:29 * ,
Хотя продолжая данную тему, а что если в перечислении создать элемент "ДаНет" с двумя значениями: Да/Нет
И вставить реквизит со ссылкой на этот элемент перечисления в нужную форму.
И таким образом регистрировать ПриОткрытии (Да) ПриЗакритии(Нет)
Это конечно изврат но все таки... как будет работать?


Цитата(logist @ 15.06.17, 16:37) *
Почему не устраивает?

Боковая панель навигации, которая появляться когда делаешь через Владелец. В моем случае думаю она совсем не нужна.
Мне просто нужно установить обмен данными между двумя справочниками без использования Владелец-подчиненный
А то "владелец", "родитель! Хорошо что еще бабушки и дедушки нет! smile.gifsmile.gif
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128411 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 16:33


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Всем привет!
Уважаемые специалисты. не подскажете как получить список всех открытых управляемых Форм на клиенте для 1С 8.2?
Пожалуйста на примере кода если можно.
Буду признателен!


Gigi @ Сегодня, 16:27 * ,
Нарыл вот такое решение:
 Процедура СписокОткрытыхФорм() Экспорт
Для Каждого Справочник Из Метаданные.Справочники Цикл
   Для Каждого ТекФорма Из Справочник.Формы Цикл
       Форма = Справочники[Справочник.Имя].ПолучитьФорму(ТекФорма.Имя);
       Если Форма.Открыта() Тогда
           Сообщить(Справочник.Имя + " " + ТекФорма.Имя);
       КонецЕсли;
   КонецЦикла;
КонецЦикла;
КонецПроцедуры

Гуууу... тоже НЕ РАБОТАЕТ!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128404 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 16:29


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


logist @ Сегодня, 16:23 * ,
Это я знаю, но сделать через "Владелец" просто так не совсем устраивает.
Ладно перехожу к новой теме и формулирую тему иначе:
Вот так:
Получить список открытых форм
Буду признателен:
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128405 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 15:56


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


sava1 @ Сегодня, 16:54 * ,
Цитата(sava1 @ 15.06.17, 16:54) *
У основного окна нет содержимого.

Открываемое окно должно быть пустым. А форма с которой она должна быть открыта содержит данные.
Основное окно (т.е. самое верхнее и последнее) не содержит данные
Получить надо ФормуОбъекта, но что бы она определяла, открыта ли та форма с которой ее запустили.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128397 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 15:53


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Flexy @ Сегодня, 16:43 * ,
Так я тоже уже пробовал:
Через "ПолучитьСодержимое();"
Пишет:
Цитата
{Справочник.ТОЧКА.Форма.ФормаЭлемента.Форма(45)}: Ошибка при установке значения атрибута контекста (Окно)
Для Каждого Окно Из КоллекцияОкон Цикл
по причине:
Несоответствие типов

Пока даже так не хочет

Gigi @ Сегодня, 16:48 * ,
КоллекцияОкон = ПолучитьОкна();
Для Каждого Окно Из КоллекцияОкон Цикл
    Если Не Окно.Основное Тогда
        Сообщить("!!");
       // Форма = Окно.ПолучитьСодержимое();
       // Форма.Закрыть();
    КонецЕсли;
КонецЦикла;

И так тоже пишет то же самое
Никак не получается блин!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128395 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 15:43


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Petre @ Сегодня, 16:40 * ,
Да на клиенте
&НаКлиенте
Процедура ПриОткрытии(Отказ)
КоллекцияОкон = ПолучитьОкна();
    Для Каждого Окно Из КоллекцияОкон Цикл
        КоллекцияСодержимое = Окно.Содержимое;
        Для Каждого Содержимое Из КоллекцияСодержимое Цикл
            Сообщить(Содержимое.ИмяФормы);
        КонецЦикла;
    КонецЦикла;
КонецПроцедуры

Короче .. ругается...
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128392 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 15:33


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Цитата(Petre @ 15.06.17, 16:31) *
Приложение управляемое?

Да!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128390 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 15:26


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Flexy @ Сегодня, 16:09 * ,
СПАСИБО!
Ша проверю!

Flexy @ Сегодня, 16:09 * ,
Цитата(Flexy @ 15.06.17, 16:09) *
КоллекцияОкон = ПолучитьОкна();
    Для Каждого Окно Из КоллекцияОкон Цикл
        КоллекцияСодержимое = Окно.Содержимое;
        Для Каждого Содержимое Из КоллекцияСодержимое Цикл
            Сообщить(Содержимое.ИмяФормы);
        КонецЦикла;
    КонецЦикла;

Блин! Не работает!
Пишет:
Цитата
{Справочник.ТОЧКА.Форма.ФормаЭлемента.Форма(35)}: Поле объекта не обнаружено (Содержимое)
КоллекцияСодержимое = Окно.Содержимое;




Gigi @ Сегодня, 16:22 * ,
Код для 1С 8.2? Или как?

Gigi @ Сегодня, 16:23 * ,
Цитата
Содержимое (Content)
Использование:
Только чтение.
Описание:
Тип: СписокКомпонентXS.
Содержит список всех компонент схемы.
Доступность:
Сервер, толстый клиент, внешнее соединение.


Блин! Как быть?
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128386 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 15:08


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Flexy @ Сегодня, 15:33 * ,
Я просто новичок в 1С так что ....
Короче не получается.

Gigi @ Сегодня, 15:54 * ,
А таким маккаром:
Окна = ПолучитьОкна();
Для каждого Окно из Окна Цикл
  Сообщить(Окно.Заголовок);
КонецЦикла;

Ругается.
Буду признателен если помощь не по тому, что написано в это дурацком синтаксис помощнике.
Который наверно "нужен" тому, который и без него все итак знает. smile.gifsmile.gif
Пожалуйста НА ПРИМЕРЕ! Если возможно!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128383 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 14:28


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Flexy @ Сегодня, 15:15 * ,
Я имею ввиду случай определения открытости или закрытости формы другого справочника.
На пример я открыл форму справочника: "ОБЪЕКТ". В группе(вкладке) которого имеется динамический список справочника: "ТОЧКА".
Где в командной строке последнего имеется лично созданная кнопка создания нового элемента того же справочника: "ТОЧКА".
Что нужно...
Что бы ПриОткрытии справочника "ТОЧКА", можно было определить открыта ли форма справочника: ОБЪЕКТ.
Вот что нужно.
А так я тоже знаю, что в таком виде:
Сообщить(ЭтаФорма.Открыта());

команда работает.
Мне просто нужно то же самое, только для формы не родного справочника.
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128377 · Ответов: 30 · Просмотров: 671
 

>  Проверка открытия формы Справочника/документа
Gigi
Отправлено: 15.06.17, 14:01


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Добрый день.
Как можно проверить открыта ли форма определенного Справочника/Документа или нет?
Пример:
Форма = Справочники.Объект.ПолучитьФорму("ФормаОбъекта");
Если Форма.Открыта() тогда
//-*-*-*-*
КонецЕсли;

НЕ РАБОТАЕТ!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128373 · Ответов: 30 · Просмотров: 671
 

>  Отменить создание документа в 1С 8
Gigi
Отправлено: 08.06.17, 13:06


Говорящий
***

Группа: Пользователи
Сообщений: 77
Регистрация: 13.04.17
Пользователь №: 55529


Vidocq05 @ Сегодня, 13:35 * ,
Спасибо!
Вот удивляюсь... как сам не догнал? smile.gif
Это исходя из:
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Не говорит а, просто кричит само за себя... smile.gif
Ладно! Спасибо!
  Форум: Программирование управляемых форм 1С 8.2 · Просмотр сообщения: #128098 · Ответов: 2 · Просмотров: 260
 

4 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 29.06.17, 0:36
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне