Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Bernet ::: Спасибо сказали: 253 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
Вчера, 13:18 Запрос АПИ к Новой почте
alex1c @ Сегодня, 10:10 * ,
Ориентируюсь на стыковку которую писал сам через json. У меня работало. Во-первых адрес сервиса неправильно указываете, во-вторых тип соединения:
АдресСервиса = "api.novaposhta.ua";
СоединениеHTTP = Новый HTTPСоединение(АдресСервиса,
        ,
        ,
        ,
        ,
        ,
        Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено));

В третьих, запрос выглядит таким образом:
ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(, Символы.Таб);
    
    ЗаписьJSON = Новый ЗаписьJSON;
    ЗаписьJSON.ПроверятьСтруктуру = Ложь;
    ЗаписьJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
    
    ЗаписьJSON.ЗаписатьНачалоОбъекта();
    
    ЗаписьJSON.ЗаписатьИмяСвойства("apiKey");
    ЗаписьJSON.ЗаписатьЗначение(КлючAPI);    
    
    ЗаписьJSON.ЗаписатьИмяСвойства("modelName");
    ЗаписьJSON.ЗаписатьЗначение("Address");    
    
    ЗаписьJSON.ЗаписатьИмяСвойства("calledMethod");
    ЗаписьJSON.ЗаписатьЗначение("getCities");    
    
    ЗаписьJSON.ЗаписатьКонецОбъекта();
    
    ЗапросСтрока = ЗаписьJSON.Закрыть();

АдресСервиса = "/v2.0/json/";

ЗапросHTTP = Новый HTTPЗапрос(АдресСервиса);
    ЗапросHTTP.Заголовки.Вставить("Content-Type",     "application/json");
    
    ЗапросHTTP.УстановитьТелоИзСтроки(ЗапросСтрока, "UTF-8", ИспользованиеByteOrderMark.НеИспользовать);

        Ответ = СоединениеHTTP.ОтправитьДляОбработки(ЗапросHTTP);
alex1c,
14.07.19, 21:31 Не могу найти работу с опытом
TabletPSC @ Сегодня, 20:40 * ,
Знакомая ситуация, у меня опыт также 7 лет, мне 27. Работал на двух франчах, и двух предприятиях (на второе перешел месяц назад). На каждой фирме проработал по 2 года, после чего решал что пора что-то менять и расти дальше, в принципе в финансовом плане так и получалось. Больше опыта - больше людей которым ты нужен.

Сказать могу одно: франча подходит только тем кто хочет чему-то научиться, или студентам-альтруистам которые готовы работать за еду/опыт. Заработать нормальные деньги, если не выбьетесь там в руководители проектов не получится. И то, начальство будет каждый месяц задрачивать за сертификаты/часы и рассказывать что вы не заслуживаете такой зарплаты и вообще ты им ещё и должен оказывается...

Работать штатным программистом на фирме лучше, есть свои плюсы/минусы. Из плюсов - меньше распыляешь на все, легче работать с какой-то одной конфигурацией и досконально её изучить. Меньше парят мозги за фактические трудозатраты, меньше треплют нервы. Скажем так, на такой работе, можно спокойно работать, делать свое дело и получать денежку. Из минусов - меньше развития и изучения чего-то нового (зависит от потребностей фирмы, был опыт когда на фирме изучил больше новых вещей чем на франче). Плюс ко всему никто не мешает брать подработку на вечера и обрасти своей клиентской базой.

P.S. Что касается вашего случая, если Вы ориентируетесь на ЗП 40-50к, вроде для столицы это нормально, вакансии есть и на work.ua и на rabota.ua, с вашим опытом думаю заберут с руками и ногами. Либо пробовать фриланс, но тут наверно будет труднее выйти на такую сумму, хотя кто как умеет крутиться. Лично мне фрилансом выйти на уровень своей ЗП было очень трудно, но опять же, я совмещал с работой.
TabletPSC,
21.06.19, 9:23 как удалить все записи регистра
lolmatrix @ 18.06.19, 12:26 * ,

Цитата
как удалить записи регистра все
- удалит все записи из регистра
НаборЗаписей = РегистрыНакопления.ИМЯВАШЕГОРЕГИСТРА.СоздатьНаборЗаписей();
НаборЗаписей.Прочитать();
НаборЗаписей.Очистить();
НаборЗаписей.Записать();


Цитата
или по условию
- удалить только по выбранному документу
НаборЗаписей = РегистрыНакопления.ИМЯВАШЕГОРЕГИСТРА.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(ССЫЛКА_НА_ДОКУМЕНТ_РЕГИСТРАТОР);
НаборЗаписей.Прочитать();
НаборЗаписей.Очистить();
НаборЗаписей.Записать();


cos12,
22.05.19, 8:20 "1С:Предприятие 8. Управляющий" отзывы
nysysimara @ Сегодня, 7:40 * ,
Мне нравится УТП - как по мне, её более чем достаточно, есть и бух и упр учет) Если хотите что-то поновее типа "управляшек" (управляемые формы) то либо УТ либо УНФ - чисто упр. учет, тут что больше нравится.
А так, то в принципе надо отталкиваться от ваших потребностей и хотелок. Чем занимается фирма? Какими документами/отчетами пользуется? и т.д. исходя из этого и плясать
nysysimara,
17.04.19, 13:23 Пучить полный адрес файла внешней обработки при ее открытии
andr_andrey @ Сегодня, 14:10 * ,
В обычных формах:
Сообщить(ЭтотОбъект.ИспользуемоеИмяФайла);

В управляемых:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ПутьКОбработке = ПолучитьИспользуемоеИмяФайла();
    Сообщить(ПутьКОбработке);
    
КонецПроцедуры

&НаСервере
Функция ПолучитьИспользуемоеИмяФайла()
    
    ТекущийОбъект = РеквизитФормыВЗначение("Объект");
    
    Возврат ТекущийОбъект.ИспользуемоеИмяФайла;
    
КонецФункции
Gigi,
17.04.19, 11:51 Пучить полный адрес файла внешней обработки при ее открытии
Gigi @ Сегодня, 12:03 * ,
У внешних обработок есть свойство "ИспользуемоеИмяФайла"
     Сообщить(ЭтотОбъект.ИспользуемоеИмяФайла);
Gigi,
17.04.19, 8:38 Аналитик-консультант 1с
Kateryna6789 @ Вчера, 21:46 * ,
Зависит от города и фирмы
Примерно диапазон можно увидеть тут
Kateryna6789,
15.04.19, 10:54 Можно ли зайти в базу на сервере из другой конфигурации.
Gigi @ Сегодня, 11:39 * ,
Цитата
Просто одну конфу из другой базы в целом использовать для другой.

Без обменов - только COM-соединение с базой, но это все будет достаточно сложно, т.к. придется писать код на получение каких-то данных, их временное хранение где-то или вывод куда-то, их изменение и запись. При большом количестве объектов этот будет немалый гемор.

P.S. опять же, это по сути своей тот же обмен, пусть даже и без записи во вторую базу. А просто взять и "наложить" данные одной базы на другую - нельзя.
Gigi,
15.04.19, 10:09 Можно ли зайти в базу на сервере из другой конфигурации.
Gigi @ Сегодня, 10:58 * ,
Чтоб вы понимали - любой из перечисленных мной способов предполагает запросы к базе, т.е. вам с какой-то периодичностью надо вытягивать данные с той базы. Естественно, чем больше данных надо выгружать тем больше и время обмена. По сути то, что вы хотите - есть обмен между двумя базами по какому-то расписанию
Gigi,
15.04.19, 9:25 Можно ли зайти в базу на сервере из другой конфигурации.
Меня укачивает от такого количества текста :-)


Если вопрос в том можно ли отобразить данный одной базы через другую - да, можно. Делать либо соединение через COM и выводить нужные данные, либо писать какой-то веб-сервис, либо делать файловые загрузки-выгрузки.
Вариантов масса - вопрос для чего и какой объем данных
Gigi,
28.03.19, 14:17 Прописать текст запуска 1С с параметрами адреса базы. имени пользователя, пароля и т.д. в ярлыке запуска 1С с рабочего стола
Gigi @ Сегодня, 13:55 * ,
Ознакомтесь, тут все есть
Gigi,
07.03.19, 16:37 Удаление всех изображений из товара
Tseka @ Сегодня, 16:28 * ,
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
|    ХранилищеДопИнфы.Ссылка
|ИЗ
|    Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДопИнфы
|ГДЕ
|     ХранилищеДопИнфы.Объект = &Номенклатура
|";

Запрос.УстановитьПараметр("Номенклатура", ВАШАНОМЕНКЛАТУРА);

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий Цикл

    КартинкаОбъекта = Выборка.Ссылка.ПолучитьОбъект();
    КартинкаОбъект.ПометкаУдаления = ИСТИНА;
    КартинкаОбъект.Записать();

КонецЦикла;
Tseka,
06.03.19, 16:08 Обработка: сортировка по датам перекрестном запросе
Constantus @ Сегодня, 15:55 * ,
Правой кнопкой мыши по элементам формы (в левой части окна) и "Добавить группу колонок". Делаете её горизонтальной, перетаскиваете туда две ваших колонки и все. Проверьте чтобы стояла галочка "Отображать в шапке". В итоге в шапке получите объединенные колонки, а в строках будет обычная строка.
Constantus,
03.03.19, 18:54 Выпадающие списки на форме
DenitScout @ Сегодня, 16:15 * ,
Для справочника "Дом" укажите Владельца = справочник "Улицы", для справочника "Квартиры" укажите владельца = справочник "Дом"
nmf,
28.02.19, 10:25 Никому web-мани не надо?
Vofka @ Сегодня, 10:22 * ,
Когда-то выводил QIWI и WebMoney с помощью этого сервиса.
Смотрел на каком сервисе лучший курс и хорошие отзывы
Gazulo, Vofka,
20.02.19, 9:11 Работа и подключение Фискального Регистратора Datecs Exelio FPU-550es в 1с v.7
Pepe @ Вчера, 21:51 * ,
Когда-то своим клиентам для этого регистратора ставили драйвер АртСофта, кажется с ним было норм. Но это было под 8-ку. Можно взять за основу если она у вас есть
Pepe,
18.02.19, 12:28 Внешние печатные формы: как добраться до кода обработки данных (запроса)?
Constantus @ Сегодня, 12:26 * ,
Цитата(Constantus @ 18.02.19, 12:26) *
 Если Мастера Тогда
        ТабДокумент = ОбработкаОбъект.ПечатьМастеров(Ссылка, Неопределено);
    ИначеЕсли Отверстия Тогда    
        ТабДокумент = ОбработкаОбъект.ПечатьНестандартныхОтверстий(Ссылка, Неопределено);
    Иначе    
        ТабДокумент = ОбработкаОбъект.ПечатьДляКомплектовщиков(Ссылка, Неопределено);
    КонецЕсли;

смотрите в модуле объекта обработки эти процедуры, там скорее всего запросы
Constantus,
15.02.19, 14:40 Работа с Деревом в обработке: группирует данные, а не нужно
Constantus @ Сегодня, 13:11 * ,
скорее всего в этих строчках проблема, судя по всему на основании этого массива дальше товары добаляются, а тут проверка если товар уже есть в массиве - то его не добавляем
Если шаг = 0 И массНоменклатур.Найти( тСтрокаНоменклатуры.ЗаказНоменклатура ) = Неопределено Тогда
массНоменклатур.Добавить( тСтрокаНоменклатуры.ЗаказНоменклатура );
Constantus,
29.01.19, 13:10 Не отображается динамический список из запроса к временной таблице
SV71 @ Сегодня, 13:08 * ,
Динамические списки не поддерживают временные таблицы. Можно использовать вложенные
SV71,
29.01.19, 12:32 1С 8.3 (упр. приложение) и Powershell
rodrigezrobert @ Сегодня, 12:02 * ,
делал создание доменных пользователей из 1С через LDAP
наипался конечно, но вроде работает, до сих пор создаем
rodrigezrobert,
24.01.19, 14:04 Изменения в конфигурации пропадают на следующий день
Acid @ Сегодня, 12:54 * ,
Периодически такое бывает, походу это какие-то глюки с хранилищем, но с чем связаны непонятно.
Бывает такое что смотришь в своей копии - код есть, смотришь в рабочей базе - его нет, обновляешься полностью с хранилища, говорит что изменений нет, типа все обновлено. В итоге выкручиваюсь таким образом: захватываю модуль, ставлю какой-то символ чтобы повесить модифицированность и отменяю захват - в итоге мне прилетает объект с хранилища с моим кодом. Хотя до этого показывало что изменений нет и все ок. Как это победить не знаю, от чего появляется тоже, но такое раз в пару месяцев случается.
Acid, mister-x,
17.01.19, 14:08 Отчет по перемещению ОС
KriAn @ Сегодня, 13:19 * ,
Такого отчета нету, в ОСВ тянет последнее местонахождение по ОС. Чтобы смотреть историю за период нужно программировать новый отчет
KriAn,
04.01.19, 9:34 Внешние источники данных, запись из 1С в базу MySQL
Vofka @ Сегодня, 9:23 * ,
У таблиц внешнего источника данных есть свойство "Тип данных таблицы внешнего источника данных", которое может быть равно "Объектные данные" и "Необъектные данные" типа. У таблиц объектного типа новый объект добавляется через функцию СоздатьОбъект() а у необъектного типа через МенеджерЗаписи или НаборЗаписей




 ! 

Правила: 8
 
Vofka,
04.01.19, 0:06 Внешние источники данных, запись из 1С в базу MySQL
Sarm @ Сегодня, 23:30 * ,
Знал бы прикуп..) буду искать, как работает это в других обменах я не знаю, может там не используется объект "Внешний источник данных"

Что ж, господа, решение найдено. При добавлении внешнего источника данных убрал галочку с поля "column" таблицы "oc_category" и вуаля - запись в базу идет без проблем. Уж без этого поля как-то обойдусь, его в админке если что вручную проставить можно будет.

Что я понял:
1. "Column" ключевое слово - использовать во внешних источниках нельзя, иначе ODBC драйвер стопориться (хотя в phpMyAdmin вылазит сообщение, но запрос все равно выполнить можно).
2. Во внешних источниках данных у таблиц "объектного" типа можно инсертить записи только по одной
3. Во внешних источниках данных у таблиц "необъектного" типа можно писать набор записей и единичные записи.

Для таблиц объектного типа думаю надо попробовать использовать stored-процедуру - но с этим разберусь уже позже, пока я рад что я смог выгрузить категории и они у меня на сайте появились - это уже успех :-)

Всем спасибо за терпение и участие.
Alegzander, Sarm, Vofka,
03.01.19, 23:21 Внешние источники данных, запись из 1С в базу MySQL
Кажется разобрался, решил попробовать воссоздать полностью эту таблицу "oc_category" в новой базе и при попытке создать колонку с именем "column" - MySQL ругнулся что это зарезервированное слово. Если посмотреть на текст ошибки то собственно с этого поля ошибка и начинается, так что подозреваю проблема именно в этом
Цитата
right syntax to use near 'column,`sort_order`

единственное что мне остается непонятным - это как разработчики OpenCarta смогли создать таблицу с такой колонкой - у меня в ручную такое воспроизвести не получается. Может надо базу SQL-запросом создавать,я хз.
Теперь надо придумать как обойти это - удалить колонку я не могу, я хз как это повлияет на сайт, но и передать данные оно не дает, даже если я её не заполняю.
Sarm,

9 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 20.08.19, 14:38
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!