Версия для печати темы (http://pro1c.org.ua/index.php?s=7a69ea1c381b3ac84b0106508c942d5a&showtopic=47136)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование в 1С Предприятие 8.3 _ Как передать параметр объекта с формы в вывод

Автор: burza 09.08.18, 12:14

Вот воспользовался статьей уважаемого Vofka http://pro1c.org.ua/index.php?showtopic=5684&st=0&gopid=144196&#entry144196

Как в форму партии передать параметр Номенклатуру из строки на которой открывается форма

    ТекстЗапроса = "ВЫБРАТЬ 
        |    ПоступлениеТоваровУслугТовары.Номенклатура КАК Номен,
        |    ПоступлениеТоваровУслугТовары.Цена КАК Цена,
        |    ПоступлениеТоваровУслугТовары.Ссылка.Партнер,
        |    ПоступлениеТоваровУслугТовары.Ссылка.Дата КАК Дата,
        |    ПоступлениеТоваровУслугТовары.Ссылка
        |ИЗ
        |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
        |ГДЕ
        |    ПоступлениеТоваровУслугТовары.Номенклатура = &Номенклатура
        |УПОРЯДОЧИТЬ ПО
        |    Дата ";
    СтруктураПараметров = Новый Структура("Номенклатура", );
// Будем считать, что на форме есть ТаблицаЗначений с именем НашаТаблица
ПоместитьДанныеЗапросаВТаблицу(ТекстЗапроса, СтруктураПараметров, Партия);


Сейчас выгружает всю номенклатуру.То есть как передать название номенклатуры (Вулиця широка)чтобы только оно отображалось. ну можно было его потом выбрать и затянуться в строку Партия.

Автор: dvv 09.08.18, 15:49

сюда - &Номенклатура передайТЕ нужную номенклатуру


 ! 

http://pro1c.org.ua/index.php?act=announce&id=2: 1
 

Автор: burza 10.08.18, 9:03

dvv @ Вчера, 16:49 * ,
Спасибо кеп!
Вы наверное не поняли вопроса. У меня формируется форма партии когда я открываю реквизит партия на форме основной и на какой строке я открываю партию нужно чтобы формировалась только та номенклатура что на основной форме.

burza @ Сегодня, 10:02 * ,
Такое не катит

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
        ТекстЗапроса = "ВЫБРАТЬ
        |    ПоступлениеТоваровУслугТовары.Номенклатура КАК Номен,
        |    ПоступлениеТоваровУслугТовары.Цена КАК Цена,
        |    ПоступлениеТоваровУслугТовары.Ссылка.Партнер,
        |    ПоступлениеТоваровУслугТовары.Ссылка.Дата КАК Дата,
        |    ПоступлениеТоваровУслугТовары.Ссылка
        |ИЗ
        |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
        |ГДЕ
        |    ПоступлениеТоваровУслугТовары.Номенклатура = &Номенклатура
        |УПОРЯДОЧИТЬ ПО
        |    Дата ";
        
    СтруктураПараметров = Новый Структура("Номенклатура", Книга());
   ПоместитьДанныеЗапросаВТаблицу(ТекстЗапроса, СтруктураПараметров, Партия);
    
КонецПроцедуры

&НаСервере
Функция Книга()
    Возврат Справочники.Номенклатура.НайтиПоНаименованию("100 казок. Том 2");
КонецФункции

Автор: sava1 10.08.18, 9:19

передавайте в параметры Формы партий

Автор: burza 10.08.18, 10:08

sava1 @ Сегодня, 10:19 * ,

&НаКлиенте
Процедура ТоварыПартияОткрытие(Элемент, СтандартнаяОбработка)
    
    Форма = ПолучитьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаПартии");
    Форма.Открыть();
    
КонецПроцедуры


как?

Автор: sava1 10.08.18, 10:22

Тогда добавьте реквизит формы - Номенклатура
и

Форма = получитьФорму.....
Форма.Открыть()
Форма.Номенклатура = ТекущаяНоменклатура;


но правильнее

параметры = новый структура;
параметры.Вставить("ТекущаяНоменклатура",Номенклатура)
ОткрытьФорму(ИмяФормы,параметры)


а в Форме партий

приСозданииНаСервере
    текущаяНоменклатура = Параметры.ТекущаяНоменклатура
    // и сразу можем обрабатывать

Автор: burza 10.08.18, 14:07

sava1 @ Сегодня, 11:22 * ,
ошибочка

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(7379)}: Поле объекта недоступно для записи (Параметры)
    параметры = новый структура;

Автор: sava1 10.08.18, 15:04

назвать по-другому.
У формы документа свой набор - Параметры

назовите ПараметрыА и передавайте в форму ПараметрыА

в открытой форме это будут Параметры.

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
http://pro1c.org.ua