Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

5 страниц V   1 2 3 > » 

>  Печать Расчетная ведомость(произвольная)
Gazulo
Отправлено: 07.02.18, 16:04


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


logist @ Сегодня, 13:53 * ,
а как тогда загрузить картинку из своего локального компа?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138308 · Ответов: 8 · Просмотров: 194
 

>  Печать Расчетная ведомость(произвольная)
Gazulo
Отправлено: 07.02.18, 7:58


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


logist @ Вчера, 22:15 * ,
изображение должно быть по ссылке или может быть и локально на компе?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138288 · Ответов: 8 · Просмотров: 194
 

>  Печать Расчетная ведомость(произвольная)
Gazulo
Отправлено: 06.02.18, 21:38


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


logist @ Сегодня, 19:33 * ,
я все делаю как в пункте 8. что не так?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138255 · Ответов: 8 · Просмотров: 194
 

>  Печать Расчетная ведомость(произвольная)
Gazulo
Отправлено: 06.02.18, 17:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


logist @ Сегодня, 16:07 * ,
в макете он есть

 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138252 · Ответов: 8 · Просмотров: 194
 

>  Печать Расчетная ведомость(произвольная)
Gazulo
Отправлено: 06.02.18, 16:00


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Добрый день. Конфигурация УТП 1.2.44.2. При формировании Расчетной ведомости (произвольная), период, итог и группировки выводятся на русском языке.
Язык формирования печ. форм украинский, интерфейс платформы украинский, региональный настройки укранские.
В чем ошибка? Спасибо.

 ! 

Правила: 8
 
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138249 · Ответов: 8 · Просмотров: 194
 

>  1C 7.7 Проводки по зп
Gazulo
Отправлено: 05.02.18, 16:48


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Valerka1 @ Сегодня, 16:32 * ,
сначала в ОсновноеНазначение хоз. операция, если не заполнена тогда в подразделении хоз. операция, если и там не заполнено тогда в категории
проще посмотрите в основном назначении сотрудников, чтоб были заполнены хоз. операции. и к ним проводки
  Форум: 1С Комплексный учет 7.7 для Украины · Просмотр сообщения: #138186 · Ответов: 10 · Просмотров: 251
 

>  1C 7.7 Проводки по зп
Gazulo
Отправлено: 05.02.18, 16:28


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Valerka1 @ Сегодня, 16:05 * ,
Вот процедура для получения хоз. операции:
// порядок: Назначение => Подраделение => Категория
Функция ПолучитьХозОперацию(Сотрудник)                                
    ХозОперация = "";
    
    ОснНазн = Сотрудник.ОсновноеНазначение.Получить(КонМесяца(ДатаДок));
    
    Если ПустоеЗначение(ОснНазн.ХозОперация) = 0 Тогда
        ХозОперация = ОснНазн.ХозОперация;
    Иначе
        Подразделение = ОснНазн.МестоРаботы.Владелец;
        Пока (ПустоеЗначение(Подразделение.Родитель) = 0) и (ПустоеЗначение(Подразделение.ХозОперация) = 1) Цикл  
            Подразделение = Подразделение.Родитель;
        КонецЦикла;
        ХозОперация = Подразделение.ХозОперация;
        
        Если ПустоеЗначение(ХозОперация) = 1 Тогда
            Попытка
                Категория = ОснНазн.МестоРаботы.Должность.Категория;
            Исключение
                глКомментарий("Не могу определить Категорию по Назначению "+ОснНазн+" для Сотрудника "+Сотрудник,1);
                Категория = 0;
            КонецПопытки;
            ХозОперация = Категория.ХозОперация;
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат ХозОперация;
КонецФункции
  Форум: 1С Комплексный учет 7.7 для Украины · Просмотр сообщения: #138184 · Ответов: 10 · Просмотров: 251
 

>  1C 7.7 Проводки по зп
Gazulo
Отправлено: 05.02.18, 15:55


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Valerka1 @ Сегодня, 15:41 * ,
Справочники - Прочие- Формирование проводок-Хоз. операции. Где то там надо искать проблему
  Форум: 1С Комплексный учет 7.7 для Украины · Просмотр сообщения: #138181 · Ответов: 10 · Просмотров: 251
 

>  Обережно грабля: ошибка в ППВ в 1.2.45.1
Gazulo
Отправлено: 01.02.18, 18:02


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Vofka @ Сегодня, 14:51 * ,
Напевно йде мова про новий реліз УТП 1.2.45.1 де переробили процедуру, але в чому питання не відомо)
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #138055 · Ответов: 7 · Просмотров: 400
 

>  1с 8.3 УПП 1.3 Код який працює в файловому режимі непрацює в серверному.
Gazulo
Отправлено: 01.02.18, 11:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


s.vitaliy @ Сегодня, 10:07 * ,
"РежимДиалогаВопрос", "Предупреждение" все це , я так розумію, виклики вікна, які є неможливими на сервері..треба превіряти Если Клиент
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #138034 · Ответов: 9 · Просмотров: 228
 

>  Макет табличного документа
Gazulo
Отправлено: 29.01.18, 10:31


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Vofka @ Сегодня, 10:13 * ,
аа...різниця в таб1 і таб2
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #137859 · Ответов: 8 · Просмотров: 291
 

>  Макет табличного документа
Gazulo
Отправлено: 29.01.18, 10:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Vofka @ Сегодня, 9:28 * ,
я не те саме вище написав?
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #137857 · Ответов: 8 · Просмотров: 291
 

>  Макет табличного документа
Gazulo
Отправлено: 28.01.18, 18:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


cao0603 @ Вчера, 9:45 * ,
//где надо сворачивать
Таб.НачатьАвтогруппировкуСтрок();
Для Каждого текСтрока Из ТЗ Цикл    
        Таб.Вывести(Обл,1);
КонецЦикла;
Таб.ЗакончитьАвтогруппировкуСтрок();


//где не надо
Для Каждого текСтрока Из ТЗ Цикл    
        Таб.Вывести(Обл);
КонецЦикла;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #137840 · Ответов: 8 · Просмотров: 291
 

>  Макет табличного документа
Gazulo
Отправлено: 26.01.18, 22:39


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


cao0603 @ Сегодня, 17:15 * ,
напишите код для сворачивания только для той части что должна свернуться..


"применяю обход по группировкам и свернуть" напишите код как это делается , чтобы знать чем помочь
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #137800 · Ответов: 8 · Просмотров: 291
 

>  После обновления 1С не загружаются налоговые накладные
Gazulo
Отправлено: 21.01.18, 18:30


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


sveta333 @ Сегодня, 17:59 * ,
Треба дивитись наглядно..інформації не достатньо
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #137468 · Ответов: 4 · Просмотров: 307
 

>  Медова стиковка: Статус податкової накладної "Документ не передавався"
Gazulo
Отправлено: 21.01.18, 17:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Irzik @ 19.01.18, 20:50 * ,
це я розумію, що не співпадають ИДД , але нічого того що ви описали не робилось..накладні не видалялись...може бути проблема при перекидці?
  Форум: Прочее 1С 8 · Просмотр сообщения: #137466 · Ответов: 2 · Просмотров: 222
 

>  После обновления 1С не загружаются налоговые накладные
Gazulo
Отправлено: 21.01.18, 8:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


sveta333 @ Сегодня, 2:38 * ,
Якою обробкою завантажуєте накладні? і яка помилка виникає?
  Форум: Остальные конфигурации 1С 8 · Просмотр сообщения: #137457 · Ответов: 4 · Просмотров: 307
 

>  Медова стиковка: Статус податкової накладної "Документ не передавався"
Gazulo
Отправлено: 19.01.18, 17:49


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Всім доброго дня. Виникла проблемка при передачі податкових накладних через Медову стиковку( 5.5). Деякі податкові накладні в стиковці відображаються як не передані("Документ не передаввся"), хоча податкові є в медку і передають в медок тільки через медову стиковку..В чому може бути проблема? ДЯкую


 ! 

Правила: 4,5
 
  Форум: Прочее 1С 8 · Просмотр сообщения: #137430 · Ответов: 2 · Просмотров: 222
 

>  1с начала подвисать при работе
Gazulo
Отправлено: 11.01.18, 22:13


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Alexandro @ Сегодня, 18:47 * ,
70-80 мб что то маловато для базы на платформе 8.
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #137114 · Ответов: 7 · Просмотров: 358
 

>  Как программно разрешить или запретить сохранение реквизита...
Gazulo
Отправлено: 25.12.17, 18:52


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Victor Skif @ Вчера, 23:08 * ,
Примерно так
Сообщить("Ваше сообщение");
ВашРеквизит = "";
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #136660 · Ответов: 13 · Просмотров: 516
 

>  Сканирование в поле ввода, без возможности ввода руками.
Gazulo
Отправлено: 22.12.17, 16:48


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Batchir @ Сегодня, 11:04 * ,
Спасибо.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136609 · Ответов: 33 · Просмотров: 742
 

>  Сканирование в поле ввода, без возможности ввода руками.
Gazulo
Отправлено: 22.12.17, 9:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Batchir @ Сегодня, 9:01 * ,
да но все сейчас работает и без драйверов SCANOPOS , а теперь значит мне на каждый комп его надо поставить, а это порядка 20-30 машин))). Я думал как то без этого справиться, хотел только доработать саму конфигурацию..
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136580 · Ответов: 33 · Просмотров: 742
 

>  Сканирование в поле ввода, без возможности ввода руками.
Gazulo
Отправлено: 21.12.17, 22:20


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Batchir @ Сегодня, 15:56 * ,
Написал обработку
Вот код

&НаКлиенте
Перем ОбъектДрайвера;

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Сообщить(Источник);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ОписаниеОшибки = "";
    Попытка
        ProgID = "AddIn.Scanner";
        ПодключитьВнешнююКомпоненту(ProgID);
        ОбъектДрайвера = Новый (ProgID);
    Исключение
        ОписаниеОшибки = "Невозможно подключить внешнюю компоненту";
    КонецПопытки;
    Если ОписаниеОшибки <> "" Тогда
        Сообщить(ОписаниеОшибки);
    КонецЕсли;
КонецПроцедуры


Но не срабатывает процедура ВнешнееСобытие

Gazulo @ Сегодня, 21:22 * ,
Получилось так:
    ProgID = "AddIn.Scaner45";
        ПодключитьВнешнююКомпоненту(ProgID);
        ОбъектДрайвера = Новый (ProgID);
        ОбъектДрайвера.DataEventEnabled=1;
        ОбъектДрайвера.стараяВерсия=1;
        ОбъектДрайвера.autoDisable=0;
        ОбъектДрайвера.УстройствоВключеноПриCтарте = 1;
        ОбъектДрайвера.УстройствоВключено = 1;


Но немного тормозит...

Gazulo @ Сегодня, 21:59 * ,
при создании драйвера где то 10 секунд и после того как просканировно карточку 10 секунд примерно..
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136538 · Ответов: 33 · Просмотров: 742
 

>  Сканирование в поле ввода, без возможности ввода руками.
Gazulo
Отправлено: 21.12.17, 17:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Batchir @ Сегодня, 15:56 * ,
Да можно пробывать и так, на для этого надо на каждом рабочем месте ставить драйвера SCANOPOS ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136536 · Ответов: 33 · Просмотров: 742
 

>  Сканирование в поле ввода, без возможности ввода руками.
Gazulo
Отправлено: 21.12.17, 15:47


Завсегдатай
****

Группа: Пользователи
Сообщений: 118
Регистрация: 25.10.12
Пользователь №: 21566


Alex78 @ Вчера, 11:57 * ,
а как быть если не сканер, а считыватель магнитных карт??
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136530 · Ответов: 33 · Просмотров: 742
 

5 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 21.02.18, 7:17
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне