Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


>  ПланСчетов Ограничение использования
avel1976
Отправлено: 01.11.18, 18:54


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Petre @ 30.10.18, 10:08 * ,
А там вторая часть кода, которая проверяет.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146789 · Ответов: 9 · Просмотров: 212
 

>  ПланСчетов Ограничение использования
avel1976
Отправлено: 29.10.18, 22:57


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Moloko @ Сегодня, 23:49 * ,
Интерфейс пользователя написан только с теми документами и отчетами которые ему нужны. До оборотно-сальдовой, к регистрам у него нет доступа, кнопки "Операции", "Сервис" и "Переключение интерфейса" убраны.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146703 · Ответов: 9 · Просмотров: 212
 

>  ПланСчетов Ограничение использования
avel1976
Отправлено: 29.10.18, 21:46


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


И еще в догонку в процедуре при изменении счета
Процедура СчетПриИзменении(Элемент)
    Если РольДоступна("ВашаРоль") Тогда        
        Если Счет.Код = "311" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли  Счет.Код = "361" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли  Счет.Код = "362" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли Счет.Код = "69" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        ИначеЕсли Счет.Код = "683" Тогда
            ОбработкаИзмененияСчета();
            ОбновитьПанельНастроек();
        Иначе
            Предупреждение("Рахунок " + Счет + " для перегляду заборонено! ");
            Счет = "";
            Возврат;
        КонецЕсли;    
    КонецЕсли;    
    ОбработкаИзмененияСчета();
    ОбновитьПанельНастроек();
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146701 · Ответов: 9 · Просмотров: 212
 

>  ПланСчетов Ограничение использования
avel1976
Отправлено: 29.10.18, 17:26


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Задача решена. Делюсь, может кому пригодится. В модуле формы "Список" и в модуле формы "Выбор" создаем процедуру "ПередОткрытием" и пишем следующий код:
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если РольДоступна("ВашаРоль") Тогда
        ЭтаФорма.Отбор.Код.ВидСравнения = ВидСравнения.ВСписке;
        СЗ = Новый СписокЗначений;
        СЗ.Добавить("311");
        СЗ.Добавить("361");
        СЗ.Добавить("69");
        СЗ.Добавить("6431");
        СЗ.Добавить("6432");
        СЗ.Добавить("6412");
        ЭтаФорма.Отбор.Код.Значение = СЗ;
        ЭтаФорма.Отбор.Код.Использование = ИСТИНА;
                //Запретим пользователю менять установленные счета
        ЭлементыФормы.Список.НастройкаОтбора.Код.Доступность = Ложь;
    КонецЕсли;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146699 · Ответов: 9 · Просмотров: 212
 

>  ПланСчетов Ограничение использования
avel1976
Отправлено: 29.10.18, 8:53


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Vofka @ Сегодня, 9:46 * ,
А как лучше реализавать? Через планы видов характеристик или может есть попроще вариант?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146684 · Ответов: 9 · Просмотров: 212
 

>  ПланСчетов Ограничение использования
avel1976
Отправлено: 27.10.18, 16:28


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Добрый день. Поставили такую задачу: необходимо пользователю ограничить выбор бух.счетов в оборотно-сальдовой ведомости и остальных отчетах, скажем чтобы пользователь мог сделать отчет по 311, 361, но не мог сделать отчет по 661. Подскажите, пожалуйста, возможно ли такое сделать программно? Спасибо за ответ.

Конфигурация
"Управление торговым предприятием для Украины", редакция 1.2. (1.2.45.2), Обычные формы

1С:Предприятие 8.3 (8.3.10.2561)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146645 · Ответов: 9 · Просмотров: 212
 

>  Налоговая накладная по рознице
avel1976
Отправлено: 23.03.17, 0:37


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Здравствуйте. С 22.03.2017 налоговая ввела новые требования по заполнению итоговой налоговой накладной по рознице за день. Требуют, чтобы товары группировались по коду УКТ ЗЕД и ДКПП, колонки 4,5,6,7 были пустыми, а была только сумма. Но 1С так не формирует налоговую накладную. При обращении на линию поддержки 1С, оператор сказал, что обновления не предвидится, так как нет нормативных документов. Подскажите, кто и как выходил из данного положения. Заполнять ручками - не реально, около 500 строк наименований. Спасибо.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #124566 · Ответов: 1 · Просмотров: 724
 

>  Обработка для выгрузки расходных накладных в формате mmo
avel1976
Отправлено: 19.12.16, 15:32


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


VasilyKushnir, Здравствуйте, поделитесь пожалуйста обработкой для файлов *.mmo dedov1976@ukr.net Спасибо.
  Форум: Остальные конфигурации 1С 7.7 · Просмотр сообщения: #120800 · Ответов: 11 · Просмотров: 19658
 

>  Выбор в группе из списка
avel1976
Отправлено: 07.12.16, 23:27


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Нашел и ответ.

        |    И (Хозрасчетный.Регистратор.Контрагент В ИЕРАРХИИ (&Контрагент)
        |            ИЛИ Хозрасчетный.Регистратор.Контрагент В (&Контрагент))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #120306 · Ответов: 1 · Просмотров: 852
 

>  Выбор в группе из списка
avel1976
Отправлено: 07.12.16, 14:32


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Добрый день!
1С:Підприємство 8.3 (8.3.7.1949) "Управление торговым предприятием для Украины", редакция 1.2.
Разработка конфигурации: "ABBYY Ukraine", 2007-2016 (1.2.38.1) Обычное приложение.

Подскажите пожалуйста, как выбрать группу из списка. Нужно, чтобы можно было выбрать несколько групп в одном запросе. Ниже приведет текст запроса.

Спасибо.


Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Хозрасчетный.Период,
        |    Хозрасчетный.Регистратор,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор),
        |    Хозрасчетный.СчетДт КАК СчетДт,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.СчетДт),
        |    Хозрасчетный.СчетКт КАК СчетКт,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.СчетКт),
        |    Хозрасчетный.Организация,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Организация),
        |    СУММА(Хозрасчетный.Сумма) КАК Сумма,
        |    Хозрасчетный.Регистратор.Проведен,
        |    Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение КАК РегистраторДоговорКонтрагентаПодразделение,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение),
        |    Хозрасчетный.Регистратор.Контрагент КАК РегистраторКонтрагент,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор.Контрагент),
        |    Хозрасчетный.Регистратор.Ответственный,
        |    ПРЕДСТАВЛЕНИЕ(Хозрасчетный.Регистратор.Ответственный)
        |ИЗ
        |    РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
        |ГДЕ
        |    Хозрасчетный.Период МЕЖДУ &НачПериода И &КонПериода
        |    И Хозрасчетный.СчетДт В(&БухСчет)
        |    И Хозрасчетный.Организация = &Организация
        |    И Хозрасчетный.Регистратор.Проведен = ИСТИНА
        |    И Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение В(&Подразделение)
        |    И Хозрасчетный.Регистратор.Контрагент В ИЕРАРХИИ(&Контрагент)
        |    И Хозрасчетный.Регистратор.Контрагент В(&Контрагент)
        |
        |СГРУППИРОВАТЬ ПО
        |    Хозрасчетный.СчетДт,
        |    Хозрасчетный.СчетКт,
        |    Хозрасчетный.Период,
        |    Хозрасчетный.Регистратор,
        |    Хозрасчетный.Организация,
        |    Хозрасчетный.Регистратор.Проведен,
        |    Хозрасчетный.Регистратор.ДоговорКонтрагента.Подразделение,
        |    Хозрасчетный.Регистратор.Контрагент,
        |    Хозрасчетный.Регистратор.Ответственный
        |
        |УПОРЯДОЧИТЬ ПО
        |    РегистраторДоговорКонтрагентаПодразделение,
        |    РегистраторКонтрагент
        |ИТОГИ ПО
        |    РегистраторДоговорКонтрагентаПодразделение,
        |    РегистраторКонтрагент";
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #120295 · Ответов: 1 · Просмотров: 852
 

>  Внутреннее перемещение безналичных денежных средств
avel1976
Отправлено: 10.08.16, 7:09


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Егор Динин @ Сегодня, 7:21 *,

Как организация.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #115322 · Ответов: 3 · Просмотров: 1062
 

>  Внутреннее перемещение безналичных денежных средств
avel1976
Отправлено: 09.08.16, 22:19


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Здравствуйте. Подскажите пожалуйста, каким документом можно сделать внутреннее перемещение безналичных ДС между филиалами предприятия. "Управление торговым предприятием для Украины", редакция 1.2. На данный момент на предприятии между филиалами используются авизовки. Спасибо.
  Форум: 1С Управление Торговым Предприятием 8 · Просмотр сообщения: #115302 · Ответов: 3 · Просмотров: 1062
 

>  Обновление конфигурации
avel1976
Отправлено: 11.04.16, 17:22


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


andr_andrey @ Сегодня, 8:44 *,
У меня платформа 8.2.19 не увидела обновлений 1.2.35 и 1.2.36. Установил платформу 8.3 все обновления встали без проблем.
  Форум: Платформа 8 · Просмотр сообщения: #111315 · Ответов: 15 · Просмотров: 5764
 

>  Обновление конфигурации
avel1976
Отправлено: 11.04.16, 6:11


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Почитайте внимательно описание конфигурации. Все конфигурации начиная с 1.2.34 не работают на платформе 8.2 переходите на 8.3 Вы там увидите все обновления.
  Форум: Платформа 8 · Просмотр сообщения: #111300 · Ответов: 15 · Просмотров: 5764
 

>  Обмен документами между 1С 8.2 УПП и КБ Ощадбанка
avel1976
Отправлено: 11.04.16, 3:27


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


По поводу "ОщадБанка", в недавном времени я сам стал "счастливчиком" этого банка. Пришлось все переписывать. Но все по порядку. Для выгрузки выписок из клиент банка применяю формат "Выгрузка данных Ощадбанк dbf" Скачал из сайта "Ощада" форму для файла DBF, какие поля и в какой последовательности должны идти(очень важно), взял обработку клиент-банк для Аваля(dbf) переписал в соответствии с рекомендациями Ощадбанка. Все прекрасно работает на загрузку и выгрузку документов. Если интересно, могу поделится обработкой. Пешите в личку.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #111299 · Ответов: 24 · Просмотров: 5303
 

>  Налоговая накладная 2015
avel1976
Отправлено: 11.04.16, 3:12


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Доброго верни всем участникам форума. У меня к Вам вопрос. Мною в основную конфигурацию, 1С 8.2 "Бухгалтерия" была добавлена форма для выписки счета на реализацию путевок. После обновления и перехода на платформу 1С 8.3 в обработке формирование налоговых накладных, в списке выборе документа на основании не отображается мой счет. Счета выписываются по моей форме, в свойствах документа указано, что выступает документом-основанием для налоговой накладной. В старой версии данный документ отображался в списке выбора. Пожалуйста, подскажите где может быть причина. Спасибо.
  Форум: Бухгалтерия 8, редакция 1 для Украины · Просмотр сообщения: #111298 · Ответов: 1 · Просмотров: 771
 

>  Не присваивается значение переменной
avel1976
Отправлено: 08.09.15, 14:20


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Цитата(Petre @ 08.09.15, 15:13) *
Открываем "Обробки/КорректировкаДвижений/Реквізити/ДокументОбъект" и в его свойствах добавляем новый тип.

блин, как все просто. СПАСИБО.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102748 · Ответов: 2 · Просмотров: 1182
 

>  Не присваивается значение переменной
avel1976
Отправлено: 08.09.15, 13:59


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Доброго дня уважаемые форумчане. Возникла такая проблема, не присваивается значение переменной. Создал я методом копирования документа "РеализацияТоваровУслуг" документ "РеализацияПутевок" подкорректировал все данные и реквизиты. Реализация создается на основании счета, документ проводится, но проблема в том, что не вызывается результат проведения документа. При отладке выяснилось, что есть такое выражение:
// Открывает ОсновнуюФорму ручной корректировки
//
Процедура РучнаяКорректировкаОсновнаяФорма(ЭтоНовый,Ссылка,ЭтотОбъект)  Экспорт
    
    Если НЕ ЭтоНовый Тогда
        ФормаНастройки = Обработки.КорректировкаДвижений.ПолучитьФорму("ОсновнаяФорма", ЭтотОбъект, Строка(Ссылка));
        ФормаНастройки.ДокументОбъект = ЭтотОбъект;
        
        Если ФормаНастройки.Открыта() Тогда
            Для Каждого СтрокаТаблицыРегистров из ФормаНастройки.Регистры Цикл
                СтрокаТаблицыРегистров.Прочитан = Ложь;
                //СтрокаТаблицыРегистров.Отрисован = Ложь;
            КонецЦикла;
            
            КолСтраниц = ФормаНастройки.ЭлементыФормы.ОсновнаяПанель.Страницы.количество()-1;
            Для НомерСтраницы = 0 По КолСтраниц Цикл
                Страница = ФормаНастройки.ЭлементыФормы.ОсновнаяПанель.Страницы[КолСтраниц-НомерСтраницы];
                Если Страница.Видимость и Страница.Значение="" Тогда
                    ФормаНастройки.ЭлементыФормы.ОсновнаяПанель.Страницы.Удалить(ФормаНастройки.ЭлементыФормы.ОсновнаяПанель.Страницы.Индекс(Страница));
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        
        ФормаНастройки.Открыть();
    КонецЕсли;
    
КонецПроцедуры // РучнаяКорректировкаОсновнаяФорма()

здесь не присваивается значение переменной "ЭтотОбъект" ФормаНастройки.ДокументОбъект.

Оригинальная реализация проходит все нормально и без проблем. Помогите найти где собака зарыта.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102746 · Ответов: 2 · Просмотров: 1182
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 13:30


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


ПАРДОН, ребятки..... Поменял. Сечас вставлю там запрос.

Чудненько. Все получилось. ОГРОМНОЕ СПАСИБО.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102170 · Ответов: 14 · Просмотров: 2319
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 13:25


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Цитата(sava1 @ 19.08.15, 14:23) *
замените на
ОбластьДанных.Параметры.Товар = "Это моя строка";


Не изменило.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102168 · Ответов: 14 · Просмотров: 2319
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 13:21


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Коректировал запрос и поднял строку перед вывести. Ничего не добавилось.

Цитата(sava1 @ 19.08.15, 14:18) *
Пардон - прощелкал.
Так и хочеться написать - Весь код в студию. Но представляю сколько его там - и молчу.


//ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьКолонкаТовар = Макет.Область("Товар");
    Если Не ВыводитьКоды Тогда
        ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки +
                                            Макет.Область("КолонкаКодов").ШиринаКолонки;
    КонецЕсли;
    Если НЕ ЕстьСкидки Тогда
        ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки +
                                            Макет.Область("СуммаБезСкидки").ШиринаКолонки +
                                            Макет.Область("СуммаСкидки").ШиринаКолонки;
    КонецЕсли;
    
    СуммаБезСкидки    = 0;
    СуммаСкидки     = 0;
    Сумма            = 0;
    СуммаНДС         = 0;
    
    ОбластьНомера = Макет.ПолучитьОбласть("Строка|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("Строка|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Строка|Данные");
    ОбластьСкидки = Макет.ПолучитьОбласть("Строка|Скидка");
    ОбластьСуммы  = Макет.ПолучитьОбласть("Строка|Сумма");
    ОбластьТовар  = Макет.ПолучитьОбласть("Строка|Товар");

    Для каждого ВыборкаСтрокТовары Из ЗапросТовары Цикл

        Если НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.Номенклатура) Тогда
            Сообщить(НСтр("ru='В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.';uk='В одному з рядків не заповнене значення номенклатури - рядок під час друку буде пропущений.'"), СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;

        ОбластьТовар.Параметры.Номенклатура = "" + ВыборкаСтрокТовары.Номенклатура +" - "+ ВыборкаСтрокТовары.ФИО;
        ОбластьНомера.Параметры.НомерСтроки = ЗапросТовары.Индекс(ВыборкаСтрокТовары) + 1;
        
        ТабДокумент.Вывести(ОбластьНомера);
        
        
        Если ВыводитьКоды Тогда
            Если Колонка = "Артикул" Тогда
                ОбластьКодов.Параметры.Артикул = ВыборкаСтрокТовары.Артикул;
            Иначе
                ОбластьКодов.Параметры.Артикул = ВыборкаСтрокТовары.Код;
            КонецЕсли;
            ТабДокумент.Присоединить(ОбластьКодов);
        КонецЕсли;

        ОбластьДанных.Параметры.Заполнить(ВыборкаСтрокТовары);
        ОбластьДанных.Параметры.Товар = СокрЛП(ВыборкаСтрокТовары.Товар);
        ТабДокумент.Присоединить(ОбластьДанных);

        Если ЕстьСкидки Тогда
            ОбластьСкидки.Параметры.Заполнить(ВыборкаСтрокТовары);
            ТабДокумент.Присоединить(ОбластьСкидки);
        КонецЕсли;

        ОбластьСуммы.Параметры.Заполнить(ВыборкаСтрокТовары);
        ТабДокумент.Присоединить(ОбластьСуммы);
        
        СуммаБезСкидки = СуммаБезСкидки + ВыборкаСтрокТовары.СуммаБезСкидки;
        СуммаСкидки    = СуммаСкидки    + ВыборкаСтрокТовары.СуммаСкидки;
        Сумма          = Сумма           + ВыборкаСтрокТовары.Сумма;
        СуммаНДС       = СуммаНДС        + ВыборкаСтрокТовары.СуммаНДС;

    КонецЦикла;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102165 · Ответов: 14 · Просмотров: 2319
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 13:05


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Тоже самое не выводит.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102160 · Ответов: 14 · Просмотров: 2319
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 12:58


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Цитата(sava1 @ 19.08.15, 10:38) *
Открываем процедуру вывода на печать, ищем где заполняются параметры
типа
Область.Параметры.Товар = .....

, после всего заполнения перед выводом области пишем свое:
Область.Параметры.Товар = ""+табЧасть.Номенклатура+" - "+Ответственный......+ДатаДокумента


ОбластьНомера = Макет.ПолучитьОбласть("Строка|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("Строка|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Строка|Данные");
    ОбластьСкидки = Макет.ПолучитьОбласть("Строка|Скидка");
    ОбластьСуммы  = Макет.ПолучитьОбласть("Строка|Сумма");
    ОбластьТовар  = Макет.ПолучитьОбласть("Строка|Товар");

    Для каждого ВыборкаСтрокТовары Из ЗапросТовары Цикл

        Если НЕ ЗначениеЗаполнено(ВыборкаСтрокТовары.Номенклатура) Тогда
            Сообщить(НСтр("ru='В одной из строк не заполнено значение номенклатуры - строка при печати пропущена.';uk='В одному з рядків не заповнене значення номенклатури - рядок під час друку буде пропущений.'"), СтатусСообщения.Важное);
            Продолжить;
        КонецЕсли;


        ОбластьНомера.Параметры.НомерСтроки = ЗапросТовары.Индекс(ВыборкаСтрокТовары) + 1;
        ТабДокумент.Вывести(ОбластьНомера);
        ОбластьТовар.Параметры.Товар = "" + ЗапросТовары.Колонки.Номенклатура +" - "+ ЗапросТовары.Колонки.ФИО;


Не получается вывести. Компилируется без ошибок и форму выводит, но поля ФИО нет. Что-то я делаю не так не пойму.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102158 · Ответов: 14 · Просмотров: 2319
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 9:33


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


В форме я добавил колонки, в модуле сделал выборку новых колонок при формировании на печать. В макете каждая колонка соответствует колонке в форме. Как сделать так чтобы (расскажу по рисунку) в колонке "Путевки"
где стоит значение <Товар>, добавить колонку из формы, ну например, <Дата>. Я разделял строку в макете и добавлял значения, но результат не тот, много пробелов между данными.

  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102146 · Ответов: 14 · Просмотров: 2319
 

>  Вывод на печать несколько колонок в одной
avel1976
Отправлено: 19.08.15, 9:05


Общительный
**

Группа: Пользователи
Сообщений: 25
Регистрация: 19.08.15
Из: Україна, Миргород
Пользователь №: 45395


Здравствуйте уважаемые форумчане. Возник такой вопрос, есть счет на оплату покупателя в программе вводятся данные в разные колонки (номенклатура,дата, фамилия и т.д.), так вот, помогите пожалуйста как можно в печатной форме вывести данные из колонок дата, фамилия в колонку номенклатура. Платформа 1С Предприятие 8,2. Спасибо.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #102144 · Ответов: 14 · Просмотров: 2319
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 19.11.18, 20:07
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне