Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

3 страниц V   1 2 3 >

>  Предложение: продавать пароль для распаковки скачанных архивов
sanek6662009@gma...
Отправлено: 16.11.18, 17:05


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Возможно просто в колонтитулах писать "ЧИТАЙТЕ ПРАВИЛА" или что-то в этом роде?
  Форум: http://pro1c.org.ua/ · Просмотр сообщения: #147225 · Ответов: 4 · Просмотров: 170
 

>  После переноса платформы и конфигурации начались жуткие тормоза в работе
sanek6662009@gma...
Отправлено: 13.11.18, 20:03


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


awp @ Сегодня, 17:15 * ,
Виндовс 10 корпоративная + стандартный рдп, жутко тормозила отрисовка в 1с, а при подключении к серверу через тим вивер 1с летает. Как решим проблему - напишу
  Форум: Платформа 7.7 · Просмотр сообщения: #147096 · Ответов: 4 · Просмотров: 254
 

>  После переноса платформы и конфигурации начались жуткие тормоза в работе
sanek6662009@gma...
Отправлено: 13.11.18, 16:20


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Мичман Харитонов @ Сегодня, 9:12 * ,
Файловая

Тема закрыта, решение найдено. Проблема была в самом рдп.
  Форум: Платформа 7.7 · Просмотр сообщения: #147093 · Ответов: 4 · Просмотров: 254
 

>  После переноса платформы и конфигурации начались жуткие тормоза в работе
sanek6662009@gma...
Отправлено: 12.11.18, 18:49


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Всем доброго времени суток, есть 1с 7.7.027 и самописная конфигурация, стояло все это чудо на серваке с вин 10 и рдп, все нормально работало, по определенным причинам пришлось сменить сервер (на более мощный, i7 6700, озу 64гб, и ssd)после переноса платформы и конфигурауии начались жуткие тормоза в работе, особенно в журналах. Кто что подскажет?


 ! 

Правила: 4
 
  Форум: Платформа 7.7 · Просмотр сообщения: #147069 · Ответов: 4 · Просмотров: 254
 

>  Обработка - Декомпилятор объектов
sanek6662009@gma...
Отправлено: 10.11.18, 10:59


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Bernet @ Вчера, 11:39 * ,
Ну надежда есть)
  Форум: Отчеты / Обработки · Просмотр сообщения: #147018 · Ответов: 9 · Просмотров: 2557
 

>  Обработка - Декомпилятор объектов
sanek6662009@gma...
Отправлено: 08.11.18, 22:05


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


а есть ли у кого такая-же для 7.7 27-го релиза?
  Форум: Отчеты / Обработки · Просмотр сообщения: #146975 · Ответов: 9 · Просмотров: 2557
 

>  Отчет
sanek6662009@gma...
Отправлено: 18.10.18, 15:20


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Deads @ Сегодня, 15:56 * ,
Вы разделом не ошиблись?
  Форум: Конфигурация "1С:Конвертация данных" · Просмотр сообщения: #146402 · Ответов: 1 · Просмотров: 117
 

>  Как отразить больничные листы при начале работы с программой (вводе остатков)
sanek6662009@gma...
Отправлено: 13.10.18, 7:47


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


eact @ Сегодня, 8:20 * ,
Цыфра не может братся из ни от куда, как говорили выше, сложно понять проблему по фото. В 1с все взаимосвязано, и волшебства не бывает, если Вы внимательно читали статью, которую я Вам скидывал, то даже больничный вводится на основании. Проведя документ, можно отследить его движение по регистрам и понять откуда цыфра. И тогда Вы уже поймете в чем суть и что не так делаете.
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #146273 · Ответов: 11 · Просмотров: 327
 

>  Как отразить больничные листы при начале работы с программой (вводе остатков)
sanek6662009@gma...
Отправлено: 13.10.18, 5:04


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


eact @ Вчера, 23:05 * ,
Документ начисление, в котором у Вас непонятки
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #146271 · Ответов: 11 · Просмотров: 327
 

>  Как отразить больничные листы при начале работы с программой (вводе остатков)
sanek6662009@gma...
Отправлено: 12.10.18, 21:14


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


eact @ Сегодня, 21:48 * ,
Попробуйте после проведения документа поднять подчиненные
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #146254 · Ответов: 11 · Просмотров: 327
 

>  Как отразить больничные листы при начале работы с программой (вводе остатков)
sanek6662009@gma...
Отправлено: 12.10.18, 18:19


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


это должно помочь
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #146252 · Ответов: 11 · Просмотров: 327
 

>  Реестр документов Заказ покупателя
sanek6662009@gma...
Отправлено: 12.10.18, 7:41


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


awp @ Сегодня, 8:39 * ,
Можно) но попытка решить штатными средствами 32000000.gif
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146230 · Ответов: 8 · Просмотров: 282
 

>  Автоматически подтягивался представитель организации
sanek6662009@gma...
Отправлено: 12.10.18, 7:38


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


pingvin_vlad @ 05.04.18, 16:00 * ,
В настройках пользователей выставьте "основной представитель организации" и будет Вам счастье
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146228 · Ответов: 1 · Просмотров: 354
 

>  Реестр документов Заказ покупателя
sanek6662009@gma...
Отправлено: 11.10.18, 14:49


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


awp @ Сегодня, 15:40 * ,
спасибо, но когда это делается по 20 а то и 30 раз за день, крайне не удобно

sanek6662009@gmail.com @ Сегодня, 15:49 * ,
а когда еще и две валюты, то еще более не удобно
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146210 · Ответов: 8 · Просмотров: 282
 

>  Деление на валюты
sanek6662009@gma...
Отправлено: 11.10.18, 14:40


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Всем доброго времени суток, столкнулся с такой ситуацией:
Руководство хочет работать с двумя валютами одновременно (грн. и usd), чтобы документы были в валюте товара.
Имея на руках типовую УТ 10.3 и поковыряв её понял что штатными средствами этого не сделать.
Штатная УТ может создать, сохранить и распечатать документ в валюте договора контрагента.

Но задача есть задача....

Вот код обработки:
Функция ПолучитьСтрЦЕны(Номенклатура,ТипЦен,Дата)
    
    стрРез = Новый Структура;
    стрРез.Вставить("Валюта","");
    стрРез.Вставить("Цена",0);
    //стрРез.Вставить("Валюта","");    
    
    З = Новый Запрос;
    Т = "ВЫБРАТЬ
        |    ЦеныНоменклатурыСрезПоследних.Валюта,
        |    ЦеныНоменклатурыСрезПоследних.Цена,
        |    ЦеныНоменклатурыСрезПоследних.Номенклатура,
        |    ЦеныНоменклатурыСрезПоследних.ТипЦен,
        |    ЦеныНоменклатурыСрезПоследних.Период
        |ИЗ
        |    РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
        |            &Дата,
        |            ТипЦен = &ТипЦен
        |                И Номенклатура = &Номенклатура) КАК ЦеныНоменклатурыСрезПоследних";
    З.УстановитьПараметр("Номенклатура",Номенклатура);
    З.УстановитьПараметр("ТипЦен",ТипЦен);
    З.УстановитьПараметр("Дата",Дата);
    З.Текст = Т;
    выб = З.Выполнить().Выбрать();
    Если выб.Следующий() Тогда
        стрРез.Валюта = выб.Валюта;
        стрРез.Цена = выб.Цена;
    КонецЕсли;
    Возврат стрРез;

КонецФункции

Функция НайтиДоговорКОнтрагента(Контрагент, Валюта)
    
    рез = "";
    
    З = Новый Запрос;
    Т = "ВЫБРАТЬ
    |    ДоговорыКонтрагентов.Ссылка
    |ИЗ
    |    Справочник.ДоговорыКонтрагентов КАК ДоговорыКонтрагентов
    |ГДЕ
    |    ДоговорыКонтрагентов.Владелец = &Владелец
    |    И НЕ ДоговорыКонтрагентов.ПометкаУдаления
    |    И ДоговорыКонтрагентов.ВидДоговора = &ВидДоговора
    |    И ДоговорыКонтрагентов.ВалютаВзаиморасчетов = &ВалютаВзаиморасчетов";
    З.Текст = Т;
    З.УстановитьПараметр("Владелец",Контрагент);
    З.УстановитьПараметр("ВидДоговора",Перечисления.ВидыДоговоровКонтрагентов.СПокупателем);
    З.УстановитьПараметр("ВалютаВзаиморасчетов",Валюта);
    
    выб = З.Выполнить().Выбрать();
    Если выб.Следующий() Тогда
        рез = выб.Ссылка;
    //Иначе
    //    сО = Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
    //    сО.Наименование = "С покупателем (ГРН)";
    //    сО.Владелец = Контрагент;
    //    сО.ВалютаВзаиморасчетов = Справочники.Валюты.НайтиПоКоду("980");
    //    сО.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем;
    //    сО.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоДоговоруВЦелом;
    //    сО.СхемаНалоговогоУчета = Справочники.СхемыНалоговогоУчетаПоДоговорамКонтрагентов.ПоПервомуСобытию;
    //    сО.Записать();
    //    рез = сО.Ссылка;
    КонецЕсли;
    
    Возврат рез;
    
КонецФункции

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    дО = выбЗаказ.ПолучитьОбъект();
    тз = дО.Товары.Выгрузить();
    тз.Колонки.Добавить("Валюта");
    тз.Колонки.Добавить("ЦенаВал");
    тз.Колонки.Добавить("СуммаВал");
    тз.Колонки.Добавить("Договор");
    
    Для каждого стр из тз Цикл
        стрЦены = ПолучитьСтрЦЕны(стр.Номенклатура,дО.ТипЦен,дО.Дата);
        стр.Валюта = стрЦены.Валюта;
        стр.ЦенаВал = стрЦены.Цена;
        стр.СуммаВал = стр.Цена *  стр.Количество;
        
        стр.Договор = НайтиДоговорКОнтрагента(дО.Контрагент,стр.Валюта);
        
    КонецЦикла;    
    
    тзНаФОрме = тз;
    ЭлементыФОрмы.тзНаФОрме.СоздатьКолонки();
    
    дО_грн = Документы.ЗаказПокупателя.СоздатьДокумент();    
    ЗаполнитьЗначенияСвойств(дО_грн,дО,,"Номер");
    дО_грн.ДоговорКонтрагента = НайтиДоговорКОнтрагента(дО_грн.Контрагент,Справочники.Валюты.НайтиПоКоду("980"));
    Для каждого стр из  тз Цикл
        Если стр.Валюта.код = "980" Тогда
        НоваяСтрока = дО_грн.Товары.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСТрока,стр);
        НоваяСтрока.ЦЕна = стр.ЦЕнаВал;
        НоваяСтрока.Сумма = стр.СуммаВал;
        КонецЕсли;
    КонецЦикла;
    ф = дО_грн.ПолучитьФорму("ФормаДокумента");
    ф.Открыть();
    
    //дО_грн = Документы.ЗаказПокупателя.СоздатьДокумент();
    //дО_грн.ДоговорКонтрагента = НайтиДоговорКОнтрагента(дО_грн.Контрагент,Справочники.Валюты.НайтиПоКоду("980"));
    //ЗаполнитьЗначенияСвойств(дО_грн,дО,,"Номер");
    дО.Товары.Очистить();
    Для каждого стр из  тз Цикл
        Если стр.Валюта.код = "840" Тогда
        НоваяСтрока = дО.Товары.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСТрока,стр);
        НоваяСтрока.ЦЕна = стр.ЦЕнаВал;
        НоваяСтрока.Сумма = стр.СуммаВал;
        КонецЕсли;
    КонецЦикла;
    ф = дО.ПолучитьФорму("ФормаДокумента");
    ф.Открыть();
    
КонецПроцедуры


тоесть имея у контрагента 2 договора, в данном случае гривна и доллар, при нажатии на кнопку обработка уберет из документа позиции, которые не соответсвуют валюте договора и создаст документ с ними в нужной валюте.

тестировалась на УТ 10.3 (обычное приложение)
думаю для УТП и УПП тоже подойдёт. На других - тестите, главное условие : наличие у контрагента двух договоров с разными валютами и коды валют должны братся из класификатора, в противном случае прийдется немного допилить.

а вот собственно и обработка, пароль стандартный: Прикрепленный файл  DelenieZakazovPokupatelya.zip ( 7.81 килобайт ) Кол-во скачиваний: 1

  Форум: Отчеты / Обработки · Просмотр сообщения: #146207 · Ответов: 0 · Просмотров: 188
 

>  Реестр документов Заказ покупателя
sanek6662009@gma...
Отправлено: 11.10.18, 14:23


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


awp @ Сегодня, 15:15 * ,
да, всё супер, но нет итоговой суммы по документам, как в отчёте реестр документов
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146206 · Ответов: 8 · Просмотров: 282
 

>  Реестр документов Заказ покупателя
sanek6662009@gma...
Отправлено: 11.10.18, 14:12


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Всем доброго времени суток!
Скорее всего вопрос на уровне 1-го класса, но уже всю голову сломал.
Подскажите начинающему, как вывести реестр документов из "Форма Списка" штатными средствами или может с небольшой доработкой?
Смотрел код отчета "Реестр документов" но как его подставить в нужное мне место ума не приложу.

По факту что нужно:
при определённой сортировке в списке документов вывести их реестр
как это сделать? help.gif
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146202 · Ответов: 8 · Просмотров: 282
 

>  На электронные ресурсы ГФС осуществляются кибератаки
sanek6662009@gma...
Отправлено: 09.10.18, 18:33


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Володя Гройсман @ Сегодня, 19:00 * ,
Этот народ не победим)
  Форум: Бухгалтерский учет, налоги, последние изменения... · Просмотр сообщения: #146127 · Ответов: 1 · Просмотров: 70
 

>  Перенос справочников из Бухгалтерии в УТП
sanek6662009@gma...
Отправлено: 09.10.18, 11:19


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Блин, а кто-то слышал об конфигурации "Конверктация данных", даже я, начинающий в 1с и то с помощью нее смог сделать переезд с 7.7 самописной в УТ 10.3 за один день. Выгружаете структуры метаданных, создаете правила обмена и с помощью универсального обмена xml переносите все что Вам нужно. И ни каких сторонних обработок.

sanek6662009@gmail.com @ Сегодня, 12:17 * ,
Если нужны правила обмена, могу помочь, нужны лишь файлы структуры метаданных
  Форум: Конфигурация "1С:Конвертация данных" · Просмотр сообщения: #146112 · Ответов: 17 · Просмотров: 14654
 

>  Загрузка курсов валют за период с сайта НБУ или Приватбанка, для 7.7
sanek6662009@gma...
Отправлено: 09.10.18, 11:10


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Dyusha @ Сегодня, 11:34 * ,
Классно)
  Форум: Программы, внешние компоненты, прочее · Просмотр сообщения: #146111 · Ответов: 9 · Просмотров: 1053
 

>  Быстрый поиск по столбцу
sanek6662009@gma...
Отправлено: 08.10.18, 14:51


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Егор Динин @ Сегодня, 9:48 * ,
в большей части так и делаем, но к огромному счастью клиентами фирмы также являются люди в возрасте, не привыкшие к компьютерам)

Petre @ Сегодня, 9:39 * ,
спасибо огромное, как всегда решение на самом видном месте)
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146078 · Ответов: 3 · Просмотров: 254
 

>  Быстрый поиск по столбцу
sanek6662009@gma...
Отправлено: 07.10.18, 20:37


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


Всем привет, помогите, кто чем может... help.gif
При подборе номенклатуры, став на столбец с наименованием, начать вводить первые буквы и 1с автоматически начнет искать по введенным данным, как тоже самое реализовать в столбце "код"? поиск находящийся вверху очень не удобен, так как некоторые из клиентов привыкли диктовать коды, а в частых заказах количество позицый превышает 400 шт.


п.с. ут 10.3 типовая
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #146050 · Ответов: 3 · Просмотров: 254
 

>  Подойдет ли для Украины УТ 11 для России?
sanek6662009@gma...
Отправлено: 06.10.18, 10:07


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


vital105 @ Сегодня, 9:45 * ,
Для "спасибо" кнопка специальная есть)
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #146031 · Ответов: 8 · Просмотров: 285
 

>  Подойдет ли для Украины УТ 11 для России?
sanek6662009@gma...
Отправлено: 05.10.18, 20:49


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


vital105 @ Сегодня, 21:42 * ,
Не особо, если откинуть региональные особености. По факту УТ 3 для Украины - это УТ 11 для России, с изменненой обложкой
  Форум: Управление торговлей для Украины редакция 3 (Уп... · Просмотр сообщения: #146015 · Ответов: 8 · Просмотров: 285
 

>  Вывод на макет картинки
sanek6662009@gma...
Отправлено: 05.10.18, 20:29


Говорящий
***

Группа: Пользователи
Сообщений: 52
Регистрация: 19.07.18
Из: Днепр
Пользователь №: 61573


And1001 @ Сегодня, 10:40 * ,
вот Вам пару примеров
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #146013 · Ответов: 2 · Просмотров: 285
 

3 страниц V   1 2 3 >

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 19.12.18, 3:51
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне