Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Rayne ::: Спасибо сказали: 16 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
23.07.14, 10:55 Задание на поступление на работу
Процедура ВидЦеныПриИзменении(Элемент)
      //здесь перебираем в цикле строки табличной части ТМЦ, в каждой вызываем хитрую процедуру РозничнаяЦена()
      Для каждого СтрокаТабличнойЧастиИз ТабличнаяЧасть1 Цикл
              СтрокаТабличнойЧасти.Цена = РаботаСоСправочниками.РозничнаяЦена(Дата, СтрокаТабличнойЧасти.ТМЦ);
               РасчетСуммы.РасчитатьСумму(СтрокаТабличнойЧасти);
      КонецЦикла;  
КонецПроцедуры


Совет: всегда давайте реквизитам и табличным частям осмысленные названия. Для примера, посмотрите, каким образом построен вызов процедур при изменении цен в стандартных документах (реализацию можно взять).
pt_denis,
23.07.14, 7:45 Проблема со структурой подчиненности докум.
Похвальна, конечно, тяга к знаниям smile.gif Я далеко не всех своих могла заставить конфигуратор открыть, когда связи не было, чтобы я продиктовала, что сделать...

У вас есть два варианта для действий:
1. Использовать вид взаиморасчетов "По счетам"
2. Лучше, конечно, обратиться к специалисту, хоть задачка и простенькая. Если сами что-то делаете - нужно обязательно сделать копию базы данных перед проведением опытов. А еще лучше - опыты проводить на копии.

Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказПоставщику")
Или (ТипЗнч(Основание) = Тип("ДокументСсылка.СчетНаОплатуПоставщика")
И ДоговорКонтрагента.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоСч етам) Тогда
         Сделка = Основание;
//djess-------- комментарии пишем обязательно, когда что-то меняем
         ДокументОснование = Основание; //это заполнение вашего добавленного реквизита
//djess----------------------------------------------------------------------------------
ИначеЕсли (ТипЗнч(Основание) = Тип("ДокументСсылка.СчетНаОплатуПоставщика")
И ДоговорКонтрагента.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоЗа казам)
И ТипЗнч(Основание.ДокументОснование) = Тип("ДокументСсылка.ЗаказПоставщику") Тогда
         Сделка = Основание.ДокументОснование;
Иначе
         Сделка = Неопределено;
КонецЕсли;


В критериях отбора отметить его флажком.

Плюс стоит иметь в виду, что при обновлениях это обязательно всплывет и причинит определенные неудобства, если будет обновляться документ "Поступление товаров (услуг)". Особенно если обновляетесь сами, без помощи специалиста.
djess,
23.07.14, 7:37 Не тянутся данные в Налоговые Накладные
Цитата(djess @ 23.07.14, 0:57) *
а как быть,если нет заказа,счета,реализации?

При вводе на основании документа "Налоговая накладная" из документа "Платежное поручение входящее" пользователю предлагается открыть обработку заполнения налоговой накладной номенклатурным составом. В самой обработке предлагается выбрать счет (или реализацию). Если счета/реализации нет, то заполнять номенклатурный состав в документе "Налоговая накладная" только вручную.

Цитата(djess @ 23.07.14, 0:57) *
на одном компьютере все идет как надо,все тянется, все действия те же, документы создавались на одном основании и по одному принципу. На втором же-не получается ((


Так не бывает, если на этих компьютерах открывается одна и та же база.

Цитата(djess @ 23.07.14, 0:57) *
я имела ввиду вкладку "номенклатура"-туда не тянутся записи,которые должны бы тянуться из "основания" (сумма,и прочие заполняемые колонки)

Если "Налоговая накладная" вводится на основании "Реализация товаров (услуг)", и есть первое событие, то все заполняется. Если первого события нет - опять предлагается открыть обработку заполнения налоговой накладной. Проверить необходимо регистры "Ожидаемый и подтвержденный НДС продаж" (или приобретений, если речь идет о закупках) и "Продажи (налоговый учет)". Можно проверить с помощью Отчеты - Универсальные (можно взять Остатки/обороты или Универсальный отчет).
djess,
21.07.14, 7:35 Проблема со структурой подчиненности докум.
1. Сделайте копию базы данных.
2. Сообщение при открытии базы данных свидетельствует о том, что изменения в структуру базы данных вы не внесли, а только сохранили конфигурацию. Для внесения изменений необходимо:
Главное меню - Конфигурация - Обновить конфигурацию базы данных.
djess,
17.07.14, 10:08 Движения по регистру накопления.
Была тут где-то тема, где обсуждалось, почему нельзя движения по партиям достать запросом в обработке проведения самого документа

Данные по регистрам при проведении документа

А консолью проверять бесполезно - момент уже не тот, движения уже есть в базе.
Powerman,
17.07.14, 10:03 Автозаполнение пустого поля ввода табличного поля
В случае, когда новая строка:

// Процедура - обработчик события "ПриНачалеРедактирования" табличной части
Процедура СоставПриНачалеРедактирования(Элемент, НоваяСтрока)

    СтрокаТабличнойЧасти = ЭлементыФормы.Состав.ТекущиеДанные;

    Если НоваяСтрока Тогда
                Если НЕ ЗначениеЗаполнено(СтрокаТабличнойЧасти.ВидДеятельностиНДС) Тогда
                       СтрокаТабличнойЧасти.ВидДеятельностиНДС = Перечисления.ВидыДеятельностиНДС.Облагаемая;
                       СтрокаТабличнойЧасти.ВидНалоговойДеятельности = Справочники.ВидыНалоговойДеятельности.ОблагаемаяПоОбычнойСтавке;                      
                       СтрокаТабличнойЧасти.СтатьяКнигиПриобретения = ОпределитьСтатьюНалоговойДекларации(СтрокаТабличнойЧасти);
                КонецЕсли;
    КонецЕсли;    


КонецПроцедуры


А табличное поле на основании заполняется из заказа? Если да - то процедура ОбработкаЗаполнения в модуле документа.
Veizdem,
25.06.14, 12:06 Получить количество строк у не записанного документа
Цитата(Log1c @ 25.06.14, 12:21) *
в ЭлементыФормы нет Товары, я так понимаю что если Товары это ТЧ документа, а не ТЧ формы то и не должно её быть в ЭлементыФормы.


Если у Вас на форме есть табличная часть для заполнения, то определенно есть элемент формы типа ТабличноеПоле. Значит, к нему можно обратиться. Но, как уже сказали выше, отрабатывает и Товары.Количество() даже для не записанных документов.
Log1c,
12.06.14, 12:48 Данные по регистру при проведении документа
Видимо, разница все-таки есть... Стало интересно, проверила на УТ.

Движения.Продажи - заполнены, можно обратиться к ним.

Для каждого Движение из Движения.Продажи Цикл
   //...
КонецЦикла;
maxst22, Powerman,
12.06.14, 7:51 Проблема при отборе в СКД
Цитата
ЭлементОтбора.ПравоеЗначение = Справочники.Номенклатура.НайтиПоНаименованию(Номенклатура);


Доставило... Для поля типа СправочникСсылка поискать в справочнике по наименованию, хотя Номенклатура - и так уже СправочникСсылка.

По поводу отбора - либо в самой СКД добавьте такой отбор и сделайте его по умолчанию отключенным, либо перед присвоением значения проверяйте, есть ли отбор в КомпоновщикНастроек.Настройки.Отбор.Элементы
rpodgornyy,
22.05.14, 13:54 Возврат товаров поставщику
Такой настройки нет.

Можно только включить, чтобы у пользователя закладку было всегда видно, и не нужно было ее включать каждый раз в документе.
mact,
22.05.14, 13:14 Возврат товаров поставщику
Настройка называется "Показывать в документах счета учета"
mact,
22.05.14, 11:21 Обработка и процедура замены записей документа
1. Тема не в том разделе. Читайте внимательно, где создаете темы.
2. У Вас в цикле документ-объект записывается столько раз, сколько строк в документе. 47046430.gif
3. Есть есть регистры накопления/сведений, привязанные к документу, то они перезаписываются при проведении. У вас режим записи документа явно не указан, так что ваши документы просто записываются. (Причем, каждый по много раз)
4. Нужно бы узнать, почему нельзя воспользоваться процедурой ЗаполнитьЗначенияСвойств, а каждой строке что-то переприсваивать?
Vofka,
10.04.14, 15:18 Не видно изменений после сохранения справочник Номенклатура
Перейти -> Счета учета номенклатуры

Счета учета номенклатуры - регистр сведений.

progr33,
04.04.14, 15:31 Заполнение переходящего больничного листаа
Эти два документа делают одинаковые движения по основным начислениям и меняют состояния работника. Поэтому или тот, или другой. Снимайте с проведения "Невыходы и одноразовые выплаты"...
girenko,
03.04.14, 13:08 Нумерация строк в таблицах
В Выбранных полях на нужном поле правой кнопкой мыши, пункт Установить заголовок пробовали?
Agapov_Stas,

RSS Текстовая версия Сейчас: 16.07.19, 22:54
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!