Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Bernet ::: Спасибо сказали: 195 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
04.07.18, 13:07 Настройка рабочего стола
Gigi @ Сегодня, 13:10 * ,
Ну вот то как у меня отображается
смотрите в сторону общих команд, у вас там есть нечто похожее на вызов вашей формы. команда "ПОЛЕЗНЫЙ_ОТПУСК" - может она в интерфейс выведена, хз
Gigi,
04.07.18, 10:39 Настройка рабочего стола
Gigi @ Сегодня, 11:33 * ,
Сюда
или
сюда
на ваш выбор

Вы бы с данными аккуратнее были, а то начальство накажет за то что слили базу
Gigi,
28.06.18, 16:55 Настройка рабочего стола
Gigi @ Сегодня, 17:12 * ,
В свойствах корня дерева конфигурации правой кнопкой мыши -> Открыть модуль управляемого приложения
Gigi,
28.06.18, 15:54 Настройка рабочего стола
Gigi @ Сегодня, 16:14 * ,
В конфигураторе в дереве метаданных открываете свойства корня конфигурации, в свойствах есть "Рабочая область начальной страницы" - в ней наверно и есть ваша форма. Только если уберете её оттуда она исчезнет для всех пользователей.


У нас сегодня гос. выходной, мало кто сидит за компом, все гуляют
Gigi,
27.06.18, 11:45 Почему структура в модуле обработки не работает!
Gigi @ Сегодня, 12:42 * ,
Скорее всего у вас есть реквизит формы или объекта с названием "Филиалы" поэтому и возникла такая ситуация
Gigi,
27.06.18, 10:32 Почему структура в модуле обработки не работает!
Gigi @ Сегодня, 11:25 * ,
выложите полностью процедуру. то что вы показали должно работать в любом модуле
Gigi,
25.06.18, 14:35 Как отобразить указанный динамический список во вкладке(странице) общей формы
Gigi @ Сегодня, 15:26 * ,
Ищите как изменить/установить основную таблицу/текст запроса динамического списка
Gigi,
25.06.18, 13:56 Программно отправить сообщение на почту через внешнюю обработку. Версия платформы: 8.3.10.2667, версия конфигуратора: 2.4.1.206
@lex @ Сегодня, 14:52 * ,
В этой теме уже отвечали на этот вопрос
@lex,
21.06.18, 15:42 Справочник (иерархия элементов): определить есть ли у элемента подчиненные элементы
Constantus @ Сегодня, 15:41 * ,
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
|     СпрСтатьи.Ссылка
|ИЗ
|    Справочник.СтатьиДвиженияДенежныхСредств КАК СпрСтатьи
|ГДЕ
|    СпрСтатьи.Ссылка В ИЕРАРХИИ (&Статья)
|    И СпрСтатьи.Ссылка <> &Статья
|";
Запрос.УстановитьПараметр("Статья", СтрокаПлатеж.СтатьяДвиженияДенежныхСредств);
Результат = Запрос.Выполнить();
Если  НЕ Результат.Пустой() Тогда
    Сообщить("Низзяя");
Иначе
     // делайте что угодно
КонецЕсли;
Constantus,
20.06.18, 8:42 Отправить письмо на почту посредством 1С
barul4ik @ Сегодня, 9:40 * ,
Эту утилиту нужно было юзать с платформой 8.2, которая не поддерживала SSL-шифрование. 8.3 уже поддерживает, использовать эту утилиту уже не обязательно
Gigi,
19.06.18, 10:40 Отправить письмо на почту посредством 1С
Gigi @ Сегодня, 11:33 * ,
У меня такой код в самописной конфигурации работал, правда с gmail, для mail.ru только порты могут быть другие, а так принцип тот же
Код
Функция ОтправитьУведомлениеНаПочтуПользователю(СтруктураПараметров) Экспорт
    
    ТекстОшибок = "";
    
    ПолучательПисьма = Неопределено;
        
    СтруктураПараметров.Свойство("ПолучательПисьма", ПолучательПисьма);
    
    УчетнаяЗаписьДляРассылки = Константы.УчетнаяЗаписьДляРассылки.Получить();
    Если НЕ ЗначениеЗаполнено(УчетнаяЗаписьДляРассылки) Тогда
        ТекстОшибок = ТекстОшибок + "Не выбрана учетная запись для рассылки уведомлений на почту.";
        Возврат ТекстОшибок;
    КонецЕсли;
    
    Если ПолучательПисьма = Неопределено Тогда
        ТекстОшибок = ТекстОшибок + Символы.ПС + "Не указана почта получателя уведомления!";
        Возврат ТекстОшибок;
    КонецЕсли;
    
    Профиль = ПолучитьИнтернетПочтовыйПрофиль(УчетнаяЗаписьДляРассылки);
    
    ИнтернетПочта = Новый ИнтернетПочта;
    
    Попытка
        ИнтернетПочта.Подключиться(Профиль);
    Исключение
        
        ТекстОшибок = ТекстОшибок + Символы.ПС + (Строка(УчетнаяЗаписьДляРассылки) + ". " + ОписаниеОшибки());
        Возврат ТекстОшибок;
        
    КонецПопытки;
    
    ПочтовоеСообщение = Новый ИнтернетПочтовоеСообщение;
                            
    ПочтовоеСообщение.Кодировка = "utf-8";
    ПочтовоеСообщение.ИмяОтправителя  = СокрЛП(УчетнаяЗаписьДляРассылки.АдресЭлектроннойПочты);
    ПочтовоеСообщение.Отправитель     = СокрЛП(УчетнаяЗаписьДляРассылки.АдресЭлектроннойПочты);
    ПочтовоеСообщение.Тема            = "Тема";
    
    Получатель = ПочтовоеСообщение.Получатели.Добавить();
    Получатель.Адрес           = СокрЛП(ПолучательПисьма);
    Получатель.ОтображаемоеИмя = СокрЛП(ПолучательПисьма);
    Получатель.Кодировка       = "utf-8";

    ТекстСообщения = ПочтовоеСообщение.Тексты.Добавить();
    ТекстСообщения.Кодировка = "utf-8";
    Если УчетнаяЗаписьДляРассылки.КодировкаПисемПоУмолчанию = "HTML" Тогда
        ТекстСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;    
    ИначеЕсли УчетнаяЗаписьДляРассылки.КодировкаПисемПоУмолчанию = "TEXT" Тогда    
        ТекстСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
    КонецЕсли;
    ТекстСообщения.Текст = ПолучитьТекстДляУведомленияНаПочту(ТекстСообщения.ТипТекста, СтруктураПараметров);
    
    Попытка
        ИнтернетПочта.Послать(ПочтовоеСообщение);
    Исключение
        ТекстОшибок = ТекстОшибок + Символы.ПС + (Строка(УчетнаяЗаписьДляРассылки) + ". " + ОписаниеОшибки());
        Возврат ТекстОшибок;    
    КонецПопытки;
    
КонецФункции

Функция ПолучитьИнтернетПочтовыйПрофиль(УчетнаяЗапись) Экспорт

    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    Профиль.АдресСервераPOP3 = УчетнаяЗапись.POP3Сервер;
    Профиль.АдресСервераSMTP = УчетнаяЗапись.SMTPСервер;
    Если УчетнаяЗапись.ВремяОжиданияСервера > 0 Тогда
        Профиль.ВремяОжидания = УчетнаяЗапись.ВремяОжиданияСервера;
    КонецЕсли;
    Профиль.Пароль           = УчетнаяЗапись.Пароль;
    Профиль.Пользователь     = УчетнаяЗапись.Логин;
    Профиль.ПортPOP3         = УчетнаяЗапись.ПортPOP3;
    Профиль.ПортSMTP         = УчетнаяЗапись.ПортSMTP;
    
    Профиль.ИспользоватьSSLSMTP = Истина;
    Профиль.ИспользоватьSSLPOP3 = Истина;
    
    Если УчетнаяЗапись.ТребуетсяSMTPАутентификация Тогда
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
        Профиль.ПарольSMTP         = УчетнаяЗапись.ПарольSMTP;
        Профиль.ПользовательSMTP   = УчетнаяЗапись.ЛогинSMTP;
    Иначе
        Профиль.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
        Профиль.ПарольSMTP         = "";
        Профиль.ПользовательSMTP   = "";
    КонецЕсли;
    
    Возврат Профиль;

КонецФункции


УчетнаяЗапись - это справочник, где хранятся логин, пароль и все остальные настойки доступа к почте. Сравните с вашим, может быстрее найдете в чем проблема
Gigi,
19.06.18, 9:49 Отправить письмо на почту посредством 1С
Gigi @ Сегодня, 10:18 * ,
Кстати, добавьте строки:
Профиль.ИспользоватьSSLSMTP = Истина;
Профиль.ИспользоватьSSLPOP3 = Истина;

SSL шифрование обязательно и для gmail и для mail.ru вроде бы
Gigi,
19.06.18, 9:28 Отправить письмо на почту посредством 1С
Gigi @ Сегодня, 10:18 * ,
Судя по всему что-то не так с почтой, вы уверены что правильно ввели email адрес?
Gigi,
18.06.18, 14:53 Обработка: отбор по подразделению
Constantus @ Сегодня, 15:43 * ,
"+?(ЗначениеЗаполнено(Подразделение), "И ВложенныйЗапрос.Подразделение = &Подразделение", ?(Ошибочные, "И ВложенныйЗапрос.Подразделение = ЗНАЧЕНИЕ(Справочник.Подразделения.ПустаяСсылка)", ""))+"
Constantus,
18.06.18, 11:09 Обработка: отбор по подразделению
Constantus @ Сегодня, 11:53 * ,
|    ИЗ
|        Документ.СписаниеТоваров КАК СписаниеТоваров
|    ГДЕ
|        СписаниеТоваров.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&Дата1, ДЕНЬ) И КОНЕЦПЕРИОДА(&Дата2, ДЕНЬ)
|        И СписаниеТоваров.Проведен = ИСТИНА
|        И СписаниеТоваров.НаДоход = ИСТИНА
|        И СписаниеТоваров.ПометкаУдаления = ЛОЖЬ) КАК ВложенныйЗапрос
|ГДЕ
|    ВложенныйЗапрос.Организация = &Организация
|    "+?(ЗначениеЗаполнено(Подразделение), "И ВложенныйЗапрос.Подразделение = &Подразделение", "")+"
|
|СГРУППИРОВАТЬ ПО
|    ВложенныйЗапрос.Статус,
|    ВложенныйЗапрос.Номенклатура,
|    ВложенныйЗапрос.Организация,
|    ВложенныйЗапрос.Подразделение
|
|УПОРЯДОЧИТЬ ПО
|    Статус,
|    Номенклатура
|АВТОУПОРЯДОЧИВАНИЕ";

    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("Подразделение", Подразделение);
    Запрос.УстановитьПараметр("Дата1", ДатаНачала);
    Запрос.УстановитьПараметр("Дата2", ДатаОкончания);
Constantus,
06.06.18, 9:09 Набор универсальных обработок
belik2017 @ Сегодня, 9:54 * ,
У вас язык украинский в базе стоит скорее всего, а в обработке нету представления на украинском - поэтому и пустые поля
belik2017,
05.06.18, 11:10 Универсальный отчет: выводить не все показатели по ресурсам
Constantus @ Сегодня, 11:56 * ,
УниверсальныйОтчет.ДобавитьПоказатель("Количество",, Истина);
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоНачальныйОстаток",, Ложь,, "Количество");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоПриход",,           Ложь,, "Количество");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоРасход",,           Ложь,, "Количество");
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОборот",,           Ложь,, "Количество");

Останется включенный только конечный остаток
Constantus,
16.05.18, 8:00 Конкурент 1С
Цитата
вони періодично реагують запах грошей

Увы, в нашей стране половина населения реагирует только на это, во всех остальных случаях - без признаков жизни
awp,
15.05.18, 15:40 Добавить колонку с контрагентом на котором стоит резерв данной номенклатуры
ЮлияЛебешева @ Сегодня, 16:34 * ,
В вашем случае тогда должна быть группировка по Заказу покупателя, раз оттуда Контрагента тащите.
Добавьте:
1. ЗаказПокупателя в выбранные поля в запросе
2. ЗаказПокупателя в группировки
Цитата
УниверсальныйОтчет.ДобавитьИзмерениеСтроки("ЗаказПокупателя");

3. Теперь можно вывести контрагента как дополнительное поле (пример):
// УниверсальныйОтчет.ДобавитьДополнительноеПоле(<ПутьКДанным>, <Размещение>, <Положение>);
ЮлияЛебешева,
09.05.18, 18:39 Шаблон цінника окремо гривні окремо копійки Розница 1.0
1. Нужно в макете выделить два поля с параметрами отдельно для целой и дробной части.
2. При печати в обработке в момент вывода в таб. документ нужно программно передать параметры для целой и дробной части. Целую часть можно выделить форматированием (как писал выше) а дробную формулой: ВашеЧисло - Цел(ВашеЧисло). Полученный результат и будет ваша дробная часть
tomol22,
26.04.18, 16:12 Как сохранить порядок списка в соответствии
Gigi @ Сегодня, 17:09 * ,
Не замечал раньше такого, но действительно 1С пересортировало коллекцию с соответствием. А соответствие вы уже никак не отсортируете, используйте ТаблицуЗначений - там строки в каком порядке зададите так и будет
Gigi,
26.04.18, 11:21 Функция: Найти(Тект,Значение)
Цитата
Синтаксис:

Найти(<Строка>, <ПодстрокаПоиска>)
Параметры:

<Строка> (обязательный)
Тип: Строка.
Исходная строка.

<ПодстрокаПоиска> (обязательный)
Тип: Строка.

Искомая подстрока.

Возвращаемое значение:
Тип: Число.
Позиция первого знака найденной подстроки. Нумерация символов в строке начинается с 1. Если строка не содержит указанной подстроки, то возвращается 0.
Описание:

Функция является устаревшей! Рекомендуется использовать функцию СтрНайти.
Находит первое вхождение искомой строки как подстроки в исходной строке.

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).

Примечание:
Если параметр <ПодстрокаПоиска> - пустая строка, то возвращает 1.
Если оба параметра - пустые строки, то возвращает 1.


Читайте какой тип должен быть у второго параметра и что возвращается в случае пустой строки
Gigi,
19.04.18, 20:54 Записать структуру в реквизит с типом ХранилищеЗначения
Запись в хранилище значения:
СтруктураПример = Новый Структура;
СтруктураПример.Вставить("Январь", "Январь");
СтруктураПример.Вставить("Февраль", "Февраль");
СтруктураПример.Вставить("Март", "Март");

ХранилищеЗнч = Новый ХранилищеЗначения(СтруктураПример);

Чтение из хранилища значения:
СтруктураПример = ХранилищеЗнч .Получить();
Если СтруктураПример  <> Неопределено Тогда
      Сообщить(СтруктураПример.Январь);
КонецЕсли;
Gigi,
19.04.18, 16:54 Модуль НабораЗаписей в регистре сведений
Gigi @ Сегодня, 17:49 * ,
Перенесите код в процедуру "ПередЗаписью"
Gigi,
19.04.18, 16:17 Модуль НабораЗаписей в регистре сведений
Для Каждого Запись Из ЭтотОбъект Цикл
    
    Запись.январь_февраль = Запись.январь + Запись.февраль;
    
КонецЦикла;
Gigi,

7 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 23.07.18, 2:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне