Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Bernet ::: Спасибо сказали: 160 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
19.01.18, 16:55 Не работает таблично поле для отборов
Mongrel @ Сегодня, 16:52 * ,
Не путайте Параметры и Отборы, понятия разные.
Путь к данным укажите "КомпоновщикНастроек.Настройки.Отбор" у табличного поля и будут ваши отборы
Mongrel,
19.01.18, 10:10 Медовая стыковка, ошибка: Для передачі документів в 1с необхідно виконати необхідні налаштування
Felix6 @ Сегодня, 10:09 * ,
Должно работать, это в 4.х версии были такие проблемы. Если хотите могу по ТВ глянуть, если что пишите в личку
Felix6,
17.01.18, 14:15 История изменений конфигурации
maks_75 @ Сегодня, 13:13 * ,
Вроде бы нет такого
maks_75,
16.01.18, 16:17 Скрыть столбец макета
кусочек кода в качестве примера
ТабДок = Новый ТабличныйДокумент; 
Макет = ПолучитьМакет("МакетРазвернутогоОтчета");

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапкаОсновное = Макет.ПолучитьОбласть("Шапка|Основное");
ОбластьШапкаФакт = Макет.ПолучитьОбласть("Шапка|Факт");

ОбластьСтрокаОсновное = Макет.ПолучитьОбласть("Строка|Основное");
ОбластьСтрокаОсновное = Макет.ПолучитьОбласть("Строка|Факт");

ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаОсновное);

МассивПериодов = Запрос.Выполнить().Выгрузить().Свернуть("ПериодМесяц");

Для Каждого Стр Из МассивПериодов Цикл
ОбластьШапкаФакт.Параметры.Заголовок = Стр.ПериодМесяц;
ТабДок.Присоединить(ОбластьШапкаФакт);
Конеццикла;

скопипизжено отсюда
Gigi,
12.01.18, 10:11 1с начала подвисать при работе
Alexandro @ Вчера, 18:47 * ,
Кроме как в 1С больше висяков нигде не наблюдаете?
Как вариант могу предложить следующее:
1. Запустить "Тестирование и исправление ошибок", через Конфигуратор -> Администрирование, посмотреть что выдаст. (!Предварительно выгрузить резервную копию базы)
2. Раз база файловая можно прогнать её через утилиту "chdbfl.exe", которая находится в папке bin программы. Как правило это стандартный путь C:\Program Files (x86)\1cv8\ВашаВерсия1С\bin (!Предварительно выгрузить резервную копию базы)
3. Чтобы отсеять вероятность проблем с железом - можно выгрузить копию базу на другой комп/ноут, развернуть там и попробовать воспользоваться тем же подбором, посоздавать пару документов - если все ок - значит проблема с железякой или ПО того компьютера где установлена 1С сейчас.
Alexandro,
11.01.18, 9:00 Связать УПП 1.3 и Документооборот 2.0
AleksWhite7 @ Сегодня, 8:38 * ,
Когда-то, года 3-4 назад, делал нечто подобное с помощью Бесшовной интеграции ДО и УПП
Посмотрите, почитайте, может устроит вариант
AleksWhite7,
05.01.18, 15:06 Запрет на изменение некоторых настроек отчета СКД для пользователей
info230a02 @ Сегодня, 11:42 * ,
Добавляете форму "Форма настроек" в отчете, сгенерируется форма по умолчанию, далее уже на самой форме для выделенного поля можно установить свойство "ТолькоПросмотр"
aprameja, info230a02,
05.01.18, 11:57 Запрос для получения остатков по дням
выполнил ваш запрос в консоли - немного не то и данные не сгруппированы, сейчас попробую переделать

Вот такая вот штука получилась - вытягивает последние остатки на дату заказа. P.S. предполагается использование Складов в Заказах - если не используете то везде Склад удалите в запросе
Запрос - Остатки на даты заказов
ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ЗаказПокупателяТовары.Ссылка КАК Заказ,
    ЗаказПокупателяТовары.Ссылка.Дата КАК Период,
    ЗаказПокупателяТовары.Ссылка.СкладГруппа КАК Склад,
    ЗаказПокупателяТовары.Номенклатура,
    СУММА(ЗаказПокупателяТовары.Количество) КАК Количество
ПОМЕСТИТЬ ВтЗаказы
ИЗ
    Документ.ЗаказПокупателя.Товары КАК ЗаказПокупателяТовары
ГДЕ
    ЗаказПокупателяТовары.Ссылка.Дата МЕЖДУ &НачДата И &КонДата

СГРУППИРОВАТЬ ПО
    ЗаказПокупателяТовары.Ссылка,
    ЗаказПокупателяТовары.Ссылка.Дата,
    ЗаказПокупателяТовары.Ссылка.СкладГруппа,
    ЗаказПокупателяТовары.Номенклатура
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ТоварыНаСкладахОстаткиИОбороты.Склад КАК Склад,
    ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура,
    ТоварыНаСкладахОстаткиИОбороты.Период КАК Период,
    ТоварыНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток КАК КонечныйОстаток
ПОМЕСТИТЬ ВтОстатки
ИЗ
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(
            &НачДата,
            &КонДата,
            Секунда,
            ДвиженияИГраницыПериода,
            Номенклатура В
                (ВЫБРАТЬ
                    ВтЗаказы.Номенклатура
                ИЗ
                    ВтЗаказы КАК ВтЗаказы
                СГРУППИРОВАТЬ ПО
                    ВтЗаказы.Номенклатура)) КАК ТоварыНаСкладахОстаткиИОбороты
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ВтЗаказы.Период КАК Период,
    ВтЗаказы.Номенклатура КАК Номенклатура,
    ВтЗаказы.Склад КАК Склад,
    МАКСИМУМ(ВтОстатки.Период) КАК ПериодОстатков
ПОМЕСТИТЬ ВтДатыОстатков
ИЗ
    ВтЗаказы КАК ВтЗаказы
        ЛЕВОЕ СОЕДИНЕНИЕ ВтОстатки КАК ВтОстатки
        ПО ВтЗаказы.Период >= ВтОстатки.Период

СГРУППИРОВАТЬ ПО
    ВтЗаказы.Период,
    ВтЗаказы.Номенклатура,
    ВтЗаказы.Склад
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ВтДатыОстатков.Период,
    ВтДатыОстатков.ПериодОстатков,
    ВтДатыОстатков.Номенклатура,
    ВтДатыОстатков.Склад,
    СУММА(ВтОстатки.КонечныйОстаток) КАК КонечныйОстаток
ПОМЕСТИТЬ ВтОстаткиИтог
ИЗ
    ВтДатыОстатков КАК ВтДатыОстатков
        ЛЕВОЕ СОЕДИНЕНИЕ ВтОстатки КАК ВтОстатки
        ПО ВтДатыОстатков.Номенклатура = ВтОстатки.Номенклатура
            И ВтДатыОстатков.Склад = ВтОстатки.Склад
            И ВтДатыОстатков.ПериодОстатков = ВтОстатки.Период

СГРУППИРОВАТЬ ПО
    ВтДатыОстатков.Период,
    ВтДатыОстатков.ПериодОстатков,
    ВтДатыОстатков.Номенклатура,
    ВтДатыОстатков.Склад
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ РАЗРЕШЕННЫЕ
    ВтЗаказы.Заказ,
    ВтЗаказы.Номенклатура,
    ВтЗаказы.Склад,
    ВтЗаказы.Период,
    СУММА(ВтЗаказы.Количество) КАК КоличествоВЗаказе,
    СУММА(ЕСТЬNULL(ВтОстаткиИтог.КонечныйОстаток, 0)) КАК КоличествоОстаток
ИЗ
    ВтЗаказы КАК ВтЗаказы
        ЛЕВОЕ СОЕДИНЕНИЕ ВтОстаткиИтог КАК ВтОстаткиИтог
        ПО ВтЗаказы.Номенклатура = ВтОстаткиИтог.Номенклатура
            И ВтЗаказы.Склад = ВтОстаткиИтог.Склад
            И ВтЗаказы.Период = ВтОстаткиИтог.Период

СГРУППИРОВАТЬ ПО
    ВтЗаказы.Заказ,
    ВтЗаказы.Номенклатура,
    ВтЗаказы.Склад,
    ВтЗаказы.Период
aprameja, Mongrel,
04.01.18, 12:45 Запрос для получения остатков по дням
Mongrel @ Сегодня, 12:23 * ,
Ну так в качестве ваших дат будет дата заказа вместе со временем
Mongrel,
04.01.18, 10:56 Запрос для получения остатков по дням
Вот пример запроса на получение остатков по дням, в вашем случае "днями" будут даты ваших заказов, немного измените запрос и получите то что хотите:
Запрос
ВЫБРАТЬ РАЗРЕШЕННЫЕ
            ПлановыеДвиженияТовары.Период КАК Период,
            ПлановыеДвиженияТовары.Номенклатура КАК Номенклатура,
            ПлановыеДвиженияТовары.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
            ПлановыеДвиженияТовары.СкладОтправитель КАК Склад,
            ПлановыеДвиженияТовары.Ссылка.Сценарий КАК Сценарий,
            СУММА(ПлановыеДвиженияТовары.Количество) КАК Количество
        ПОМЕСТИТЬ ВтТовары
        ИЗ
            Документ.ПлановыеДвиженияТоваров.Товары КАК ПлановыеДвиженияТовары
        ГДЕ
            ПлановыеДвиженияТовары.Ссылка = &Ссылка
        
        СГРУППИРОВАТЬ ПО
            ПлановыеДвиженияТовары.Период,
            ПлановыеДвиженияТовары.Номенклатура,
            ПлановыеДвиженияТовары.ХарактеристикаНоменклатуры,
            ПлановыеДвиженияТовары.СкладОтправитель,
            ПлановыеДвиженияТовары.Ссылка.Сценарий
;
        
        ////////////////////////////////////////////////////////////////////////////////
        ВЫБРАТЬ РАЗРЕШЕННЫЕ
            ПланТоваров.Номенклатура КАК Номенклатура,
            ПланТоваров.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
            ПланТоваров.Склад КАК Склад,
            ПланТоваров.Сценарий КАК Сценарий,
            ПланТоваров.КоличествоКонечныйОстаток КАК КонечныйОстаток,
            ПланТоваров.Период КАК ПериодОстатков
        ПОМЕСТИТЬ ВтОстатки
        ИЗ
            РегистрНакопления.ПланТоваровНаСкладах.ОстаткиИОбороты(&ДатаНач, &ДатаКон, День, ДвиженияИГраницыПериода, ) КАК ПланТоваров
        
        ИНДЕКСИРОВАТЬ ПО
            Номенклатура,
            ХарактеристикаНоменклатуры,
            Склад,
            Сценарий,
            ПериодОстатков
;
        
        ////////////////////////////////////////////////////////////////////////////////
        ВЫБРАТЬ РАЗРЕШЕННЫЕ
            РеглКалендарь.ДатаКалендаря КАК ДатаКалендаря
        ПОМЕСТИТЬ ВтДатыПериода
        ИЗ
            РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РеглКалендарь
        ГДЕ
            РеглКалендарь.ДатаКалендаря МЕЖДУ &ДатаНач И &ДатаКон
        
        ИНДЕКСИРОВАТЬ ПО
            ДатаКалендаря
;
        
        ////////////////////////////////////////////////////////////////////////////////
        ВЫБРАТЬ РАЗРЕШЕННЫЕ
            ВтДатыПериода.ДатаКалендаря КАК ДатаКалендаря,
            ВтОстатки.Номенклатура КАК Номенклатура,
            ВтОстатки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
            ВтОстатки.Склад КАК Склад,
            ВтОстатки.Сценарий КАК Сценарий,
            МАКСИМУМ(ВтОстатки.ПериодОстатков) КАК ПериодОстатков
        ПОМЕСТИТЬ ВтСписокДатОстатков
        ИЗ
            ВтДатыПериода КАК ВтДатыПериода
                ЛЕВОЕ СОЕДИНЕНИЕ ВтОстатки КАК ВтОстатки
                ПО ВтДатыПериода.ДатаКалендаря >= ВтОстатки.ПериодОстатков
        
        СГРУППИРОВАТЬ ПО
            ВтДатыПериода.ДатаКалендаря,
            ВтОстатки.ХарактеристикаНоменклатуры,
            ВтОстатки.Номенклатура,
            ВтОстатки.Склад,
            ВтОстатки.Сценарий
        
        ИНДЕКСИРОВАТЬ ПО
            ПериодОстатков,
            Сценарий,
            Склад,
            Номенклатура,
            ХарактеристикаНоменклатуры
;
        
        ////////////////////////////////////////////////////////////////////////////////
        ВЫБРАТЬ РАЗРЕШЕННЫЕ
            ВтСписокДатОстатков.ДатаКалендаря,
            ВтСписокДатОстатков.Сценарий,
            ВтСписокДатОстатков.Склад,
            ВтСписокДатОстатков.Номенклатура,
            ВтСписокДатОстатков.ХарактеристикаНоменклатуры,
            СУММА(ВтОстатки.КонечныйОстаток) КАК КонечныйОстаток
        ПОМЕСТИТЬ ВтОстаткиИтог
        ИЗ
            ВтСписокДатОстатков КАК ВтСписокДатОстатков
                ЛЕВОЕ СОЕДИНЕНИЕ ВтОстатки КАК ВтОстатки
                ПО ВтСписокДатОстатков.Номенклатура = ВтОстатки.Номенклатура
                    И ВтСписокДатОстатков.ХарактеристикаНоменклатуры = ВтОстатки.ХарактеристикаНоменклатуры
                    И ВтСписокДатОстатков.Склад = ВтОстатки.Склад
                    И ВтСписокДатОстатков.Сценарий = ВтОстатки.Сценарий
                    И ВтСписокДатОстатков.ПериодОстатков = ВтОстатки.ПериодОстатков
        
        СГРУППИРОВАТЬ ПО
            ВтСписокДатОстатков.ДатаКалендаря,
            ВтСписокДатОстатков.Сценарий,
            ВтСписокДатОстатков.Склад,
            ВтСписокДатОстатков.Номенклатура,
            ВтСписокДатОстатков.ХарактеристикаНоменклатуры
;
        
        ////////////////////////////////////////////////////////////////////////////////
        ВЫБРАТЬ РАЗРЕШЕННЫЕ
            ВтТовары.Номенклатура КАК Номенклатура,
            ВтТовары.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
            ВтТовары.Сценарий КАК Сценарий,
            ВтТовары.Склад КАК Склад,
            ВтТовары.Период КАК Период,
            СУММА(ВтТовары.Количество) КАК КоличествоРасход,
            СУММА(ЕСТЬNULL(ВтОстаткиИтог.КонечныйОстаток, 0)) КАК КонечныйОстаток
        ИЗ
            ВтТовары КАК ВтТовары
                ЛЕВОЕ СОЕДИНЕНИЕ ВтОстаткиИтог КАК ВтОстаткиИтог
                ПО ВтТовары.Номенклатура = ВтОстаткиИтог.Номенклатура
                    И ВтТовары.ХарактеристикаНоменклатуры = ВтОстаткиИтог.ХарактеристикаНоменклатуры
                    И ВтТовары.Сценарий = ВтОстаткиИтог.Сценарий
                    И ВтТовары.Склад = ВтОстаткиИтог.Склад
                    И ВтТовары.Период = ВтОстаткиИтог.ДатаКалендаря
        
        СГРУППИРОВАТЬ ПО
            ВтТовары.Номенклатура,
            ВтТовары.ХарактеристикаНоменклатуры,
            ВтТовары.Сценарий,
            ВтТовары.Склад,
            ВтТовары.Период
        УПОРЯДОЧИТЬ ПО
            ВтТовары.Склад,
            ВтТовары.Период        
        ";
aprameja, Mongrel,
07.12.17, 17:56 Создание окон типа "балун" в 1с (платформа 8.2.19.106)
andrew76 @ Сегодня, 17:54 * ,
Ссылка в личке
andrew76,
07.12.17, 17:26 Создание окон типа "балун" в 1с (платформа 8.2.19.106)
andrew76 @ Сегодня, 17:25 * ,
В упр формах возможен вот такой вариант. В обычных так не сделаете.
andrew76,
05.12.17, 16:28 Как чесать левое ухо левой, а правое ухо правой рукой в 1С 8.2
Gigi @ Сегодня, 16:15 * ,
Вы просто сначала изучите возможности платформы, разберитесь как с ней работать, а то кидаетесь на амбразуры, стучите себя в грудь и громко кричите, что 1С это гавно.
Элементарно, то о чем вы спрашивали в прошлой теме решается довольно просто и без костылей о которых вы писали (насчет замены файла базы и т.д.) - опять же, это вы делаете без элементарных знаний "Как это работает" и при этом кричите что это неудобно и рагульно.... Конечно рагульно, если изобретать велосипеды или ломать существующие.

levi, Vidocq05,
05.12.17, 14:31 Как чесать левое ухо левой, а правое ухо правой рукой в 1С 8.2
Цитата
Это только у бога нет ошибок

Я бы не был в этом так уверен 44000000.gif
levi, Vidocq05,
04.12.17, 16:08 Заполнить табличную часть документа из справочника
Должно работать, хз.
При смене типа реквизиты очищаются ещё... т.е. надо заново проставить единицы измерения у ингредиентов...

Светлана0000,
04.12.17, 16:01 Заполнить табличную часть документа из справочника
Везде проставлии одинаковый тип? И в Блюдах и в Ингредиентах?
P.S. Если изменили на Справочник, тогда в коде
&НаСервере
функция ПолучитьЕдиницуИзмеренияИнгридиентаНаСервере(Ингредиент)
    
    Если НЕ ЗначениеЗаполнено(Ингредиент) Тогда
        Возврат Справочники.ЕдиницаИзмерения.ПустаяСсылка();
    Иначе
        Возврат Ингредиент.ЕдиницаИзмерения;
    КонецЕсли;
    
КонецФункции

вместо этой строки
Цитата
Возврат Перечисления.ЕдиницаИзмерения.ПустаяСсылка();

должно быть
Цитата
Возврат Справочники.ЕдиницаИзмерения.ПустаяСсылка();

Светлана0000,
04.12.17, 15:51 Заполнить табличную часть документа из справочника
Светлана0000 @ Сегодня, 15:44 * ,
Проверьте типы реквизитов и их привязку с элементами на форме, при изменении типа реквизита путь к данным может очищаться. Откройте форму, откройте свойства поля на форме и посмотрите есть ли привязка к вашему реквизиту (поле "ПутьКДанным") - если нету - проставьте
Светлана0000,
04.12.17, 9:23 Заполнить табличную часть документа из справочника
Светлана0000 @ Вчера, 21:01 * ,
Добавьте событие "ПриИзменении" для колонки "Ингредиент" справочника "Блюда" и пропишите такой код:

&НаКлиенте
Процедура ИнгредиентыИгредиентПриИзменении(Элемент)
    
    ТекущиеДанные = Элементы.Ингредиенты.ТекущиеДанные;
    
    Если ТекущиеДанные = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    ТекущиеДанные.ЕдиницаИзмерения = ПолучитьЕдиницуИзмеренияИнгридиентаНаСервере(ТекущиеДанные.Ингредиент);
    
КонецПроцедуры

&НаСервере
функция ПолучитьЕдиницуИзмеренияИнгридиентаНаСервере(Ингредиент)
    
    Если НЕ ЗначениеЗаполнено(Ингредиент) Тогда
        Возврат Перечисления.ЕдиницаИзмерения.ПустаяСсылка();
    Иначе
        Возврат Ингредиент.ЕдиницаИзмерения;
    КонецЕсли;
    
КонецФункции


P.S. Я бы на вашем месте делал Единицы Измерения справочником, а не перечислением. Рано или поздно придете к тому, что надо будет добавить новую единицу и придется лезть в конфигуратор.
Светлана0000,
01.12.17, 15:14 Заполнить табличную часть документа из справочника
Скинул ссылку на конфу в личку
Светлана0000,
01.12.17, 13:02 Заполнить табличную часть документа из справочника
Выложите конфигурацию сюда
И скажите как вы хотите чтобы работало, тогда перестанем тыкать пальцем в небо
Светлана0000,
30.11.17, 0:26 Заполнить табличную часть документа из справочника
logist @ Вчера, 23:36 * ,
Да, наверно я на умняк упал. Сори. Попробую проще объяснить.

Светлана0000 @ Вчера, 23:56 * ,
Допустим у вас есть:
1) Таб. часть "Блюда" с колонкой "Блюдо" (Тип Справочник "Блюда")
2) Таб. часть "Перечень блюд" с колонками: "Блюдо" (Справочник "Блюда"), "Ингридиент" (Справочник "Ингридиенты"), "КоличествоИнгридиентов" (Число)
3) Добавьте в командную панель таб. части "Ингридиенты" кнопку "Заполнить по блюдам". В Обработчике этой кнопки пишем следущее:
&НаКлиенте
Процедура ЗаполнитьПереченьБлюд(Команда)
    
       ЗаполнитьИнгридиентыПоБлюдамНаСервере();

КонецПроцедуры

&НаСервере
Процедура ЗаполнитьИнгридиентыПоБлюдамНаСервере()

      Запрос = Новый Запрос;
      Запрос.Текст = ""ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    БлюдаИнгредиенты.Ссылка КАК Блюдо,
        |    БлюдаИнгредиенты.Игредиент КАК Ингредиент,
        |    БлюдаИнгредиенты.Количество КАК КоличествоИнгредиентов,
        |    БлюдаИнгредиенты.ЕдиницаИзмерения
        |ИЗ
        |    Справочник.Блюда.Ингредиенты КАК БлюдаИнгредиенты
        |ГДЕ
        |    БлюдаИнгредиенты.Ссылка В (&МассивБлюд)";

       Запрос.УстановитьПараметр("МассивБлюд", Объект.Блюда.ВыгрузитьКолонку("Блюдо"));

       Выборка = Запрос.Выполнить().Выбрать();
       Пока Выборка.Следующий() Цикл
          
               НоваяСтрока = Объект.ПереченьБлюд.Добавить();
               ЗаполнитьЗначенияСвойство(НоваяСтрока, Выборка);
                                  
      КонецЦикла;

КонецПроцедуры
Светлана0000,
27.11.17, 7:20 Заполнить табличную часть документа из справочника
Светлана0000 @ Вчера, 19:31 * ,
Основная ваша ошибка в том, что вы выбираете наименования в запросах, а не ссылки. Я почти уверен что типы ваших реквизитов это ссылки на справочники, а не строковые выражения - как минимум из-за этого поля могут не заполняться. Во-вторых, тут в запросе не нужно внутреннее соединение с таб. частью заказов - тут опять же нет указания с каким именно документом вы связываетесь, оно возьмет абсолютно все заказы, достаточно как в моем примере просто параметром указать ссылку на Блюдо. Надеюсь разницу между ссылкой и строкой вы понимаете, если нет - то сначала прочитайте хоть какую-то книгу по 1С, даже того же Радченко: Пособие разработчика.
&НаСервере
Процедура ЗаполнитьПоляНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    БлюдаИнгредиенты.Ссылка КАК Блюдо,
        |    БлюдаИнгредиенты.Игредиент КАК Ингредиент,
        |    БлюдаИнгредиенты.Количество КАК КоличествоИнгредиентов,
        |    БлюдаИнгредиенты.ЕдиницаИзмерения
        |ИЗ
        |    Справочник.Блюда.Ингредиенты КАК БлюдаИнгредиенты
        |ГДЕ
        |    БлюдаИнгредиенты.Ссылка = &Блюдо";
        
      Запрос.УстановитьПараметр("Блюдо", Объект.Блюдо); // Объект.Блюдо - это ваш реквизит Блюдо из Заказа

      Выборка = Запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий() Цикл
          
               НоваяСтрока = Объект.ПереченьБлюд.Добавить();
               // если у вас в табличной части Заказа типы ингридиентов не строки, и имена реквизитов совпадают с тем, что у вас в запросе тогда так:
               ЗаполнитьЗначенияСвойство(НоваяСтрока, Выборка);
              
               // или если имена реквизитов не совпадают тогда так:
                НоваяСтрока.ИмяВашегоИнгридиента = Выборка.Ингридиент;
                НоваяСтрока.КоличествоВашегоИнгридиента = Выборка.КоличествоИнгредиентов;
                // и т.д.
                  
      КонецЦикла;

КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьПоля(Команда)
    ЗаполнитьПоляНаСервере();
КонецПроцедуры
Светлана0000,
22.11.17, 11:58 Задать ширину растянуть форму
Могу предложить вот такой вот вариант. Флажки ваши не растянутся, т.к. у групп должна быть одинаковая ширина, флажки не вмещаются поэтому и обрезает заголовки. Максимум что можно сделать - это заголовок флажков отобразить сверху, чтобы флагам было больше места. А так группы теперь одинаковые
Gigi,
22.11.17, 9:18 Задать ширину растянуть форму
Попробуйте поместить группу "Рубли" и группу "Квт/ч" в какую-то вышестоящую группу, этой вышестоящей группе выставьте в свойствах "Ширина подчиненных элементов" - Одинаковая, и "Группировка" - Горизонтальная
Gigi,
20.11.17, 13:04 Почему не удается в параметры построителя отчетов поместить границу регистра накопления
redking @ Сегодня, 12:59 * ,
Так чтоб границей спозиционироваться на одном документе не знаю как сделать. А по какой причине не хотите отбор по регистратору сделать?
redking,

6 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 23.01.18, 15:42
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне