Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 3, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

6 страниц V   1 2 3 > » 

>  В данной транзакции уже происходили ошибки...
Vidocq05
Отправлено: 13.07.18, 9:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Constantus @ 13.07.18, 6:48) *
Хотелка начальника... Он хочет видеть на форме списка Заявок сделан ли РКО по данной Заявке или нет...

Может есть другой способ отразить закрытую Заявку?

Если это нужно только для того, что-бы видеть на форме списка Заявок сделан ли РКО, то как вариант, сделайте реквизит в форме списка (не реквизит объекта) Заявок "РКО" и получайте ссылки на РКО "ПриВыводеСтроки" в табличном поле Заявок.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143341 · Ответов: 18 · Просмотров: 287
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
Vidocq05
Отправлено: 10.07.18, 16:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Leschyu @ Сегодня, 16:57 * ,
Из просторов интернета:

Сам сканер ШК при сканировании генерит КОД, который может состоять собственно из самого ШК и префикса с суффиксом... Для того, чтобы сработало "внешнее событие" и ОбработкаВнешнегоСобытия() - должен быть в настройках программы(драйвера) корректно описан СУФФИКС ШК - т.е. спец.символ(последовательность спец.символов), которые "говорят" что ШК "закончился"... можно его "обрабатывать"... т.е.
- со сканера идет: <Префикс><ОтсканированныйШК><Суффикс>;
- <Префикс> и <Суффикс> настраиваются по книжке с настройками сканера;
- если правильно В ДРОВАХ настроены <Префикс> и <Суффикс> (т.е. такие же, как у сканера), то дрова их отбрасывают, оставляя <ОтсканированныйШК> для 1С-ны.
- если правильно В ДРОВАХ настроен <Суффикс>, то по его приходу и генерится "Внешнее событие". Иначе - ждем это событие до второго пришествия...
- <Суффикс> - это символ(спец.код), который говорит компу о том, что переданная от железа последовательность закончилась;
- <Префикс> - символ, позволяющий отличать "нашу" последовательность (со сканера) от "не нашей" (с фиг знает еще какого устройства) или, например, <префикс> можно использовать чтобы отличать наши "внутренние" ШК от ШК производителей/поставщиков.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143230 · Ответов: 18 · Просмотров: 453
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
Vidocq05
Отправлено: 10.07.18, 15:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Leschyu @ Сегодня, 16:07 * ,
По видимому с драйвером косяк. По драйверу ничего не подскажу.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143227 · Ответов: 18 · Просмотров: 453
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
Vidocq05
Отправлено: 10.07.18, 13:49


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Leschyu @ Сегодня, 14:03 * ,
Что находится в "Источник", "Событие", "Данные"?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143218 · Ответов: 18 · Просмотров: 453
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
Vidocq05
Отправлено: 10.07.18, 12:28


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Leschyu @ 10.07.18, 12:30) *
для того, что бы ОбработкаВнешнегоСобытия сработала нужно нажать любую клавишу либо кликнуть мышкой

Она точно не срабатывает? В отладчике проверяли? Возможно она сработала и нужно просто обновить форму, или еще что то.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143212 · Ответов: 18 · Просмотров: 453
 

>  Печать комплекта
Vidocq05
Отправлено: 10.07.18, 9:54


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Andrian @ Сегодня, 10:23 * ,
Все равно вопрос не совсем понятен. Можете сбросить Ваши печатные формы и написать для каких они документов?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143206 · Ответов: 3 · Просмотров: 154
 

>  Печать комплекта
Vidocq05
Отправлено: 10.07.18, 8:23


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Andrian @ Вчера, 16:37 * ,
Вопрос не ясен. Какая конфигурация? Куда вы не можете добавить внешнюю печатную форму?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143203 · Ответов: 3 · Просмотров: 154
 

>  Подписка на событие: Проверка заполнения и правильного выбора реквизита документов
Vidocq05
Отправлено: 06.07.18, 11:43


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Constantus @ Вчера, 16:02 * ,
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               |    Подразделения.Ссылка КАК Ссылка1,
               |    Подразделения.Наименование,
               |    Подразделения.ГруппаВыбора
               |ИЗ
               |    Справочник.Подразделения КАК Подразделения
               |ГДЕ
               |    Подразделения.ГруппаВыбора = ИСТИНА
               |    И Подразделения.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка", Источник.Подразделение);
Результат = Запрос.Выполнить();
Если  НЕ Результат.Пустой() Тогда
    Сообщить("Данное подразделение является группой Подразделений. Использовать нельзя. Необходимо выбрать подразделение внутри этой группы.");
    Источник.Подразделение = Справочники.Подразделения.ПустаяСсылка();
    Отказ = Истина;
Иначе
     // делайте что угодно
КонецЕсли;


Если у Вас нету ничего в "Иначе", тогда я думаю лучше сделать так:
Процедура ПроверкаПодразделенияПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
    
    Подразделение = Источник.Подразделение;
    Если Не ЗначениеЗаполнено(Подразделение) Тогда
        Сообщить("Необходимо выбрать нужное подразделение!");
        Отказ = Истина;
    ИначеЕсли Подразделение.ГруппаВыбора = Истина Тогда
        Сообщить("Данное подразделение является группой Подразделений. Использовать нельзя. Необходимо выбрать подразделение внутри этой группы.");
        Источник.Подразделение = Справочники.Подразделения.ПустаяСсылка();
        Отказ = Истина;
    КонецЕсли;

По сути одно и тоже, но вроде как понятнее и читабельнее.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143179 · Ответов: 7 · Просмотров: 212
 

>  Подписка на событие: Проверка заполнения и правильного выбора реквизита документов
Vidocq05
Отправлено: 05.07.18, 14:07


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Constantus @ 05.07.18, 11:47) *
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               |    Подразделения.Ссылка КАК Ссылка1,
               |    Подразделения.Наименование,
               |    Подразделения.ГруппаВыбора
               |ИЗ
               |    Справочник.Подразделения КАК Подразделения
               |ГДЕ
               |    Подразделения.ГруппаВыбора = ИСТИНА
               |    И Подразделения.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка", Источник.Подразделение);
Результат = Запрос.Выполнить();
Если  НЕ Результат.Пустой() Тогда
    Сообщить("Данное подразделение является группой Подразделений. Использовать нельзя. Необходимо выбрать подразделение внутри этой группы.");
    Источник.Подразделение = Справочники.Подразделения.ПустаяСсылка();
    Отказ = Истина;
Иначе
     // делайте что угодно
КонецЕсли;


А какой смысл в этом куске кода? Просто любопытно.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #143164 · Ответов: 7 · Просмотров: 212
 

>  Табличные части из Эксель документа
Vidocq05
Отправлено: 13.06.18, 10:27


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Lexveritas @ 12.06.18, 17:03) *
НО!
Есть "ХАрактеристикаНоменклатуры" справочник подчиненный владельцу...
Как Здесь быть?


НоваяСтрока.ХарактеристикаНоменклатуры = Справочники.ХарактеристикаНоменклатуры.НайтиПоНаименованию(СокрЛП(Excel.Cells(Сч, "КолонкаХарактеристики").Text),,,НоваяСтрока.Номенклатура);

  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142489 · Ответов: 8 · Просмотров: 317
 

>  Не регулярные конфликты блокирования
Vidocq05
Отправлено: 04.06.18, 10:05


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


vbi @ Сегодня, 10:28 * ,
Воспользуйтесь конфигурацией "Центр управления производительностью"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142183 · Ответов: 2 · Просмотров: 238
 

>  не работает система оповещения
Vidocq05
Отправлено: 30.05.18, 18:03


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(kanibal23 @ 30.05.18, 16:02) *
Вот только заковырка если так написать то ошибка в ВЫБРАТЬ

Телепатирую. У регистре нету реквизитов "НачалоПериод" и "КонецПериода".

kanibal23 @ Сегодня, 15:19 * ,
В модуле управляемого приложения определяете переменную
Перем глПоследняяДатаВремяЧата Экспорт

Далее
&НаКлиенте
Процедура ПриНачалеРаботыСистемы()
  
    глПоследняяДатаВремяЧата = ТекущаяДата();

    ПодключитьОбработчикОжидания("ОбработатьОжидание",5,);

КонецПроцедуры

Общий модуль
&НаСервере
Функция ПроверитьНаличиеСообщенийСервер() Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    СообщенияЧата.Текст
                   |ИЗ
                   |    РегистрСведений.СообщенияЧата КАК СообщенияЧата
                   |ГДЕ
                   |    СообщенияЧата.ДатаВремя МЕЖДУ &ДатаНачала И  &ДатаОкончания";
                  
    Запрос.УстановитьПараметр("ДатаНачала", глПоследняяДатаВремяЧата);
    Запрос.УстановитьПараметр("ДатаОкончания", ТекущаяДата());    
    Выборка = Запрос.Выполнить().Выбрать();    
       ТекстСообщения = "";
    Если Выборка.Следующий() Тогда
        ТекстСообщения = Выборка.Текст;
    КонецЕсли;

    глПоследняяДатаВремяЧата = ТекущаяДата()+1;

    Возврат ТекстСообщения;  
  
КонецФункции


kanibal23 @ Сегодня, 15:19 * ,
Даже лучше так
&НаСервере
Функция ПроверитьНаличиеСообщенийСервер() Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    СообщенияЧата.Текст
                   |ИЗ
                   |    РегистрСведений.СообщенияЧата КАК СообщенияЧата
                   |ГДЕ
                   |    СообщенияЧата.ДатаВремя МЕЖДУ &ДатаНачала И  &ДатаОкончания";
                  
    Запрос.УстановитьПараметр("ДатаНачала", глПоследняяДатаВремяЧата);
    ДатаОкончания = ТекущаяДата();
    Запрос.УстановитьПараметр("ДатаОкончания", ДатаОкончания);    
    Выборка = Запрос.Выполнить().Выбрать();    
       ТекстСообщения = "";
    Если Выборка.Следующий() Тогда
        ТекстСообщения = Выборка.Текст;
    КонецЕсли;

    глПоследняяДатаВремяЧата = ДатаОкончания + 1;

    Возврат ТекстСообщения;  
  
КонецФункции
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #142047 · Ответов: 6 · Просмотров: 261
 

>  Вставить реквизит формы документа в отбор СКД
Vidocq05
Отправлено: 30.05.18, 17:13


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Lexveritas @ 30.05.18, 16:10) *
 Форма = ПолучитьФорму("Документ.ЗаказПокупателя.Форма.ФормаДокумента");
    НомерЗаказа = Форма.Номер;

Судя по всему здесь НомерЗаказа равен пустой строке.

Lexveritas @ Сегодня, 16:10 * ,
Вообще задача не понятна. Например, при открытии какой формы срабатывает Ваш код?
  Форум: Система компоновки данных · Просмотр сообщения: #142046 · Ответов: 8 · Просмотров: 335
 

>  Как обновить налоговую накладную?
Vidocq05
Отправлено: 30.05.18, 10:14


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


new_1c @ Вчера, 17:58 * ,
Буду отвечать по УТП, в БП скорее всего также.
Если у вас обе конфигурации одного релиза, то скорее всего там где новая налоговая это внешний регламентированный отчет. Если это так, то в базе где новее налоговая в режиме предприятия заходите в справочник "Регламентированные отчеты", находите элемент "Налоговая накладная" и сохраняете в файл. Во второй базе загружаете.
  Форум: Бухгалтерия 8, редакция 1 для Украины · Просмотр сообщения: #142034 · Ответов: 2 · Просмотров: 234
 

>  Звернення з форми до довідника
Vidocq05
Отправлено: 23.05.18, 16:33


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(Flexy @ 23.05.18, 17:20) *
&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
ТранспортнийЗасіб.ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

Тогда наверное так:
&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
    ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141844 · Ответов: 8 · Просмотров: 216
 

>  Звернення з форми до довідника
Vidocq05
Отправлено: 23.05.18, 16:18


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


l2d808 @ Сегодня, 17:04 * ,
Похоже у Вас управляемые формы. Я в них не очень силен. Попробуйте так:
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
    Объект.ТипТранспортногоЗасобу=Объект.МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141841 · Ответов: 8 · Просмотров: 216
 

>  Звернення з форми до довідника
Vidocq05
Отправлено: 23.05.18, 15:57


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


l2d808 @ Сегодня, 16:32 * ,
Для обычных форм так:
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
    ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141838 · Ответов: 8 · Просмотров: 216
 

>  МаршрутныйЛистПроизводства
Vidocq05
Отправлено: 22.05.18, 9:03


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(logist @ 21.05.18, 23:37) *
Экстрасенсы по внешним обработкам выехали, ожидайте...

Цитата(XacTLa @ 22.05.18, 8:16) *
ее нет смысла показывать

Похоже Вам придется их дожидаться.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141795 · Ответов: 5 · Просмотров: 175
 

>  Обработка для выгрузки документов с УТ в самописную базу
Vidocq05
Отправлено: 10.05.18, 11:01


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Цитата(burza @ 10.05.18, 11:38) *
Этот код взял и просто создал все документы по новому(они уже есть)! Мне не нужно загружать документы каждый раз новые.
Мне чтобы менялись только данные в документе а документы оставались прежние.
То есть так нету проверки на уже имеющиеся документы.

Нет, всетаки я Вас не понял.
Последний код, что я писал, искал документ в базе и если находил то проверял сумму документа и если она отличается то сумма перезаполняется и документ перезаписывается.
В предпоследнем моем коде происходило тоже самое, плюс если документ не находился то создавался новый и заполнялся данными и записывался.
А что нужно Вам?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141440 · Ответов: 20 · Просмотров: 621
 

>  Обработка для выгрузки документов с УТ в самописную базу
Vidocq05
Отправлено: 10.05.18, 10:51


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


burza @ Сегодня, 11:38 * ,
Тогда так:
Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

                    Если НЕ Док.Пустая Тогда

                           Если Док.СуммаДокумента = Выборка.СуммаДокумента Тогда
                                  Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                                  Продолжить;
                           КонецЕсли;

                           НачатьТранзакцию();
                           Док = Док.ПолучитьОбъект;
                           Док.СуммаДокумента = Выборка.СуммаДокумента;
                           Док.Записать();
                           ЗафиксироватьТранзакцию();
                    
                    КонецЕсли;
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141438 · Ответов: 20 · Просмотров: 621
 

>  Обработка для выгрузки документов с УТ в самописную базу
Vidocq05
Отправлено: 10.05.18, 10:30


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


Допустил ошибку. Вот так правильно

Если НЕ Док.Пустая() Тогда


Цитата(Petre @ 10.05.18, 11:26) *
Судя по ошибке, возвращается что-то другое...

Возвращает пустую ссылку.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141434 · Ответов: 20 · Просмотров: 621
 

>  Обработка для выгрузки документов с УТ в самописную базу
Vidocq05
Отправлено: 10.05.18, 10:25


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


burza @ Сегодня, 11:09 * ,
Конечно не работает. Вы вдумайтесь в смысл выполнения кода.
&НаСервере
Процедура ПровестиИмпортВходящихПлатежей()
    
    ВыборкаБазДляИмпорта = РегистрыСведений.СоединенияСБазамиДанныхУТ.Выбрать();
    
    Пока ВыборкаБазДляИмпорта.Следующий() Цикл
        Если (ВыборкаБазДляИмпорта.ЗагружатьПриходБезналичный) Тогда
            Сообщить(ВыборкаБазДляИмпорта.СтрокаСоединения);
            
            СоединениеБух = СоединитьсяСБазой(ВыборкаБазДляИмпорта.СтрокаСоединения);
            Если СоединениеБух = неопределено тогда
                Сообщить("Произошла ошибка при соединении с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Внимание);
            Продолжить;
            иначе
                Сообщить("Успешно соединились с базой предприятия " + ВыборкаБазДляИмпорта.СтрокаСоединения, СтатусСообщения.Информация);
            конецЕсли;

            // Создаём запрос для выборки всех исходящих платежей за период
            запр =  СоединениеБух.NewObject("Запрос");
            запр.Текст = "ВЫБРАТЬ
            |    ЗаказКлиента.Номер КАК Номер,
            |    ЗаказКлиента.Дата,
            |    ЗаказКлиента.СуммаОплаты КАК СуммаОплаты,
            |    ЗаказКлиента.СуммаДокумента КАК СуммаДокумента,
            |    ЗаказКлиента.ЧислоПутевок КАК ЧислоПутевок,
            |    ЗаказКлиента.Санаторий.Наименование КАК Санаторий,
            |    ЗаказКлиента.Партнер.Наименование КАК Партнер,
            |    ЗаказКлиента.РуководительГруппы.Наименование КАК РуководительГруппы,
            |    ЗаказКлиента.Контрагент.Наименование КАК  Контрагент
            |ИЗ
            |    Документ.ЗаказКлиента КАК ЗаказКлиента
            |ГДЕ
            |    ЗаказКлиента.Дата МЕЖДУ &НачалоПериода И &КонецПериода
            |    И ЗаказКлиента.Проведен = ИСТИНА
            |    И ЗаказКлиента.ПометкаУдаления = ЛОЖЬ
            |   И НЕ ЗаказКлиента.СуммаДокумента = &СуммаДокумента";
            
            запр.УстановитьПараметр("НачалоПериода", Объект.НачалоПериода);
            запр.УстановитьПараметр("КонецПериода", Объект.КонецПериода);
            запр.УстановитьПараметр("СуммаДокумента", 0);
        

            Выборка = запр.Выполнить().Выбрать();
            
                        
            Пока Выборка.Следующий() Цикл
                Сообщить("Загрузка документа №" + Выборка.Номер);

                // Это уже не нужно и функцию можете удалить
                //Если ПроверитьСуществованиеДокумента(Выборка.Номер, Выборка.СуммаДокумента, НачалоГода(Выборка.Дата), КонецГода(Выборка.Дата)) тогда
                        //Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                        
                
                   // Иначе    
        
                    Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);

                    Если НЕ Док.Пустая Тогда

                           Если Док.СуммаДокумента = Выборка.СуммаДокумента Тогда
                                  Сообщить("Загрузка №" + Выборка.Номер + " невозможна, поскольку документ уже был загружен");
                                  Продолжить;
                           КонецЕсли;

                           НачатьТранзакцию();
                           Док = Док.ПолучитьОбъект();

                    Иначе
                          
                           НачатьТранзакцию();
                           Док = Документы.СписокЗаявокУТ.СоздатьДокумент();

                    КонецЕсли;
                    
                    Док.Контрагент = Выборка.Контрагент;
                    Док.ЧислоПутевок = Выборка.ЧислоПутевок;
                    Док.СуммаДокумента = Выборка.СуммаДокумента;
                    Док.НомерЗаявки = Выборка.Номер;
                    Док.Санаторий =  ПодобратьСанаторий(Выборка.Санаторий);
                    Док.РуководительГруппы = Выборка.РуководительГруппы;
                    Док.Партнер   = Выборка.Партнер;
                    Док.Дата  = Выборка.Дата;
                    Док.Оплачено  = Выборка.СуммаОплаты;
                    Док.Записать();
                    ЗафиксироватьТранзакцию();

                //КонецЕсли;

            КонецЦикла;
            

        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141432 · Ответов: 20 · Просмотров: 621
 

>  Обработка для выгрузки документов с УТ в самописную базу
Vidocq05
Отправлено: 10.05.18, 10:06


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


burza @ Сегодня, 11:02 * ,
Выложите полностью код.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141430 · Ответов: 20 · Просмотров: 621
 

>  Обработка для выгрузки документов с УТ в самописную базу
Vidocq05
Отправлено: 10.05.18, 9:59


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


burza @ Сегодня, 10:37 * ,
Если у Вас документы с периодической нумерацией, тогда нужно так:
Док = Документы.СписокЗаявокУТ.НайтиПоНомеру(Выборка.Номер, Выборка.Дата);
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #141428 · Ответов: 20 · Просмотров: 621
 

>  Обмен данными между УТП Укр. и базой на базе БСП
Vidocq05
Отправлено: 01.05.18, 11:17


Завсегдатай
****

Группа: Пользователи
Сообщений: 141
Регистрация: 08.02.13
Из: Сумы
Пользователь №: 24478


vdn12 @ Сегодня, 10:08 * ,
Особо плотно не работал с обменами. Но я думаю скорее всего причина в том, что БСП не получает ответ то УТП о том, что данные получены и поэтому отсылает их повторно.
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #141166 · Ответов: 2 · Просмотров: 351
 

6 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 23.07.18, 15:49
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне