Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику podcast ::: Спасибо сказали: 33 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
06.10.17, 14:32 Перенос документов с бухгалтерии 1.2 в бухгалтерию 1.2
Юля @ Сегодня, 15:28 * ,
На ИТС есть обработка универсальный обмен данными в xml, или в гугле посмотрите.
Юля,
03.10.17, 16:27 Внешняя печатная форма
Pavlik1c @ Сегодня, 17:22 * ,
Свяжите свой запрос, и получите инвентарный номер.
Запрос.Текст =
     "ВЫБРАТЬ
     |    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство,
     |    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер
     |ИЗ
     |    РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних(&Дата, Организация = &Организация И ОсновноеСредство В (&ОсновноеСредство)) КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних";
    
    Результат = Запрос.Выполнить().Выбрать();
Pavlik1c,
18.09.17, 12:46 Не створюється новий звіт по ЄСВ
Юля @ Сегодня, 13:27 * ,
Скорей всего, у вас указана Налоговая в карточке организации с сентября.
Юля,
12.09.17, 9:44 Обработка для удаление Префикса в коде Номенклатуры.
Здравствуйте, последние время при обмене с Медком он создаёт номенклатуру с кодом "MED", и после этого пользователи создают номенклатуру и в код проставляется Префикс "MED".
Обработка перенумирует Номенклатуру с Кодом "MED", и при создание новой номенклатуры коды будут заполнятся корректно.
Vofka,
11.09.17, 15:10 Способ отладки прав пользователя
Володька @ Сегодня, 15:53 * ,
В отладке в конфигураторе Администрирование - Журнал регистрации, там покажет на какой регистр нету прав, Ошибка доступа должно быть, смотрите у пользователя Права на этот регистр.
Чаще всего это ограничения по Организациям или Контрагентам.
Володька,
06.09.17, 8:36 УТП Управленческая фактически выплаченная зарплата
Bernet @ Сегодня, 9:13 * ,
Типовое вряд ли что то есть, по выплате только в документе печатная форма, так только Расчетная ведомость может что то показать.
Bernet,
05.09.17, 12:32 Как подключится с одной базы к другой?
Vidocq05 @ Сегодня, 12:48 * ,
Получение остатков с другой базы.
// Выполняет подключение к базе-приемнику по заданным параметрам.
// Возвращает проинициализированную обработку УниверсальныйОбменДаннымиXML базы-приемника,
// которая будет использоваться для загрузки данных в базу-приемник.
//
// Параметры:
//  Нет.
//
//  Возвращаемое значение:
//  ОбработкаОбъект - УниверсальныйОбменДаннымиXML - обработка базы-приемника для загрузки данных в базу-приемник
//
Функция ВыполнитьПодключениеКИБПриемнику() Экспорт
    
    РезультатПодключения = Неопределено;
    
    СтруктураПодключения = Новый Структура();
    СтруктураПодключения.Вставить("ФайловыйРежим", ТипИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("АутентификацияWindows", Ложь);
    СтруктураПодключения.Вставить("КаталогИБ", КаталогИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("ИмяСервера", ИмяСервераИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("ИмяИБНаСервере", ИмяИнформационнойБазыНаСервереДляПодключения);
    СтруктураПодключения.Вставить("Пользователь", ПользовательИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("Пароль", ПарольИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("ВерсияПлатформы", ВерсияПлатформыИнформационнойБазыДляПодключения);
    
    ОбъектПодключения = ПодключитсяКИнформационнойБазе(СтруктураПодключения);
    
    Если ОбъектПодключения = Неопределено Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Попытка
        РезультатПодключения = ОбъектПодключения;
    Исключение
        
        Текст = НСтр("ru='При попытке создания обработки УниверсальныйОбменДаннымиXML произошла ошибка: %1';uk='При спробі створення обробки УниверсальныйОбменДаннымиXML сталася помилка: %1'");
        Текст = ПодставитьПараметрыВСтроку(Текст, КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
        СообщитьПользователю(Текст);
        РезультатПодключения = Неопределено;
    КонецПопытки;
    
    Возврат РезультатПодключения;
    
КонецФункции
&НаСервере
Процедура СформироватьНаСервере()
    
    Connection = ВыполнитьПодключениеКИБПриемникуНаСервере();
    
    ЗапросУТ=Connection.NewObject("Запрос");
    
    ЗапросУТ.Текст="ВЫБРАТЬ
    |    ТоварыНаСкладахОстатки.Номенклатура.Наименование КАК Номенклатура,
    |    ТоварыНаСкладахОстатки.ВНаличииОстаток КАК Остаток,
    |    ТоварыНаСкладахОстатки.Номенклатура.Артикул КАК Артикул
    |ПОМЕСТИТЬ ВТ
    |ИЗ
    |    РегистрНакопления.ТоварыНаСкладах.Остатки(&ДатаНачала, НЕ Номенклатура.Артикул ПОДОБНО """") КАК ТоварыНаСкладахОстатки
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    ТоварыПереданныеНаКомиссиюОстатки.АналитикаУчетаНоменклатуры.Номенклатура.Наименование КАК Номенклатура,
    |    ТоварыПереданныеНаКомиссиюОстатки.КоличествоОстаток,
    |    ТоварыПереданныеНаКомиссиюОстатки.АналитикаУчетаНоменклатуры.Номенклатура.Артикул
    |ИЗ
    |    РегистрНакопления.ТоварыПереданныеНаКомиссию.Остатки(&ДатаНачала, НЕ АналитикаУчетаНоменклатуры.Номенклатура.Артикул ПОДОБНО """") КАК ТоварыПереданныеНаКомиссиюОстатки
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |    ВложенныйЗапрос.Номенклатура,
    |    ВложенныйЗапрос.Остаток,
    |    ВложенныйЗапрос.Артикул
    |ИЗ
    |    (ВЫБРАТЬ
    |        ВТ.Номенклатура КАК Номенклатура,
    |        СУММА(ВТ.Остаток) КАК Остаток,
    |        ВТ.Артикул КАК Артикул
    |    ИЗ
    |        ВТ КАК ВТ
    |    
    |    СГРУППИРОВАТЬ ПО
    |        ВТ.Артикул,
    |        ВТ.Номенклатура) КАК ВложенныйЗапрос";
    
    ЗапросУТ.УстановитьПараметр("ДатаНачала", Объект.ДатаФормированияОстатков);
    
    РезультатЗапроса = ЗапросУТ.Выполнить();
КонецПроцедуры
Vidocq05,
09.08.17, 12:38 Отправка документов непосредственно из 1С
Bernet @ Сегодня, 13:06 * ,
Почитайте ссыль.
Bernet,
05.07.17, 15:55 Нет полных прав но есть возможность добавлять пользователе
Pavlik1c @ Сегодня, 16:39 * ,
У роли Пользователь есть доступ к Справочнику Пользователи, ограничьте в ролях.
Pavlik1c,
23.06.17, 8:48 Смещение даты/времени при оперативном проведении
Bernet @ Вчера, 17:53 * ,
Константа стоит Проверять разницу во времени?
Bernet,
04.04.17, 9:14 Как начислить премию(надбавку)ЗУП ред. 2.1
Юля @ Сегодня, 9:09 * ,
Проверьте в виде расчета базовые расчеты.
Юля,
22.03.17, 17:34 Как убрать должность главного бухгалтера в документах
Лелуш Ламперуж @ Сегодня, 17:32 * ,
Смотрю в каких документах и какие должности, но если править печатные формы, то да, их только через конфигуратор, если что обращайтесь помогу.
Лелуш Ламперуж,
22.03.17, 17:29 Как убрать должность главного бухгалтера в документах
Лелуш Ламперуж @ Сегодня, 16:58 * ,
Проверьте Регистр сведений Ответственные лица организации.
Лелуш Ламперуж,
17.03.17, 10:35 Как правильно начислять индексацию зарплаты?
Лелуш Ламперуж @ Сегодня, 10:30 * ,
Проставьте "Дату изменения", потом рассчитайте с комментарием.
Лелуш Ламперуж,
17.03.17, 10:22 Как правильно начислять индексацию зарплаты?
Лелуш Ламперуж @ Сегодня, 10:01 * ,
Введите на основание документа "Приём на работу", документ "Изменение параметров расчёта индексации", там будет реквизит в верхней ТЧ "Дата изменения" заполните его, а скрин который вы выложили, это вроде документ "Изменение параметров расчёта индексации (По должности)", почитайте изменения в Законодательстве когда нужно устанавливать базовый месяц по должности.
Лелуш Ламперуж,
17.03.17, 9:53 Как правильно начислять индексацию зарплаты?
Лелуш Ламперуж @ Сегодня, 9:48 * ,
Рассчитайте с комментарием, посмотрите какой базовый месяц установлен, если не правильно, то вносите документ "Изменение параметров расчёта индексации", и там устанавливайте нужный базовый месяц. Или выложите скрин комментария расчета.
Лелуш Ламперуж,
16.03.17, 14:57 Не правильно записывает движения по регистру накопления
Yevhenii @ Сегодня, 14:38 * ,
 Если (СуммаОплатыТмп>=ПлатимТЕМП и СуммаОплатыТмп>0) Тогда
            ДокОбъект = ВыборкаДетальныеЗаписи.СсылкаДокПродажи.ПолучитьОбъект();
            ДокОбъект.ОплатаПоДок =ПлатимТЕМП;
            ДокОбъект.Оплата = Истина;
            ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
            
            // регистр ПродажаМатериала Приход
            Движение = Движения.ПродажаМатериала.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
            Движение.Период = Дата;
            Движение.Контрагент = Контрагент;
            Движение.Дата = Дата;
            Движение.СтоимостьДолл = ПлатимТЕМП;
            Движение.СтоимостьГрн = (ПлатимТЕМП*ВыборкаДетальныеЗаписи.КурсДокПродажи);
            
                Движения.Записать(); // !!!Вроде ж нужно записать.

        
            //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
            СуммаОплатыТмп=СуммаОплатыТмп-ПлатимТЕМП;
            ОбновитьДопИнфоВсех();
        ИначеЕсли (СуммаОплатыТмп<ПлатимТЕМП и СуммаОплатыТмп>0) Тогда
            ДокОбъект = ВыборкаДетальныеЗаписи.СсылкаДокПродажи.ПолучитьОбъект();
            ДокОбъект.ОплатаПоДок =СуммаОплатыТмп;
            ДокОбъект.Записать(РежимЗаписиДокумента.Запись);
            
            // регистр ПродажаМатериала Приход
            
            Движение = Движения.ПродажаМатериала.Добавить();
            Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
            Движение.Период = Дата;
            Движение.Контрагент = Контрагент;
            Движение.Дата = Дата;
            Движение.СтоимостьДолл = СуммаОплатыТмп;
            Движение.СтоимостьГрн = (СуммаОплатыТмп*ВыборкаДетальныеЗаписи.КурсДокПродажи);
            Движения.Записать();

            //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
            
            СуммаОплатыТмп=0;
            ОбновитьДопИнфоВсех();
            
        КонецЕсли;
Yevhenii,
16.03.17, 9:31 Способ отражения начисления по умолчанию
drug_com @ Сегодня, 0:29 * ,
Так как отражение ФОТ не получиться, можно только премию, отнести на один счет, если указать в "Способе отражение в бух учете" нужное отражение, в самом виде расчета.
drug_com,
10.03.17, 13:59 Как добавить в личную карточку сотрудника данные о стаже и учёбе
Лелуш Ламперуж @ Сегодня, 13:48 * ,
Заходите в карточку ФизЛица, переходите на кладку Персональные данные, на нужной табличной части нажимаете Правую кнопку мыши - выбираете добавить.
Лелуш Ламперуж,
09.03.17, 10:29 Печать ведомости начисления зарплаты
Лелуш Ламперуж @ Сегодня, 10:25 * ,
Расчет зарплаты организации - Отчеты - Расчетная ведомость организации. В отчетах посмотрите там есть ещё пару отчетов в которых можете увидеть начисления.
Лелуш Ламперуж,
10.02.17, 13:50 Как сделать так чтобы базовый месяц индексации программа брала дату создания посады или последние изменения посады?
Юля @ Сегодня, 13:07 * ,
Нужно внести документ "Изменение параметров расчета индексации (по должностям)".
Юля,
06.02.17, 15:57 Как учесть праздничные дни при начислении зарплаты сотрудникам
djmn_alexander @ Сегодня, 15:55 * ,
Мой пост выше сделайте как написал, будет всё нормально.
djmn_alexander,
01.02.17, 10:08 Выплаты в натуральной форме
zag3 @ Вчера, 11:58 * ,
Пробуйте создать два вида расчета первый Стоимость уплаченных страховых взносов, а второй Коэффициент, и настраивайте налоги соответственно.
zag3,
19.01.17, 11:54 Работает ли СообщениеПользователю в управляемой форме обычного приложения?
Yevhenii @ Сегодня, 11:23 * ,
Функции общего назначения помещайте в блок для клиента и сервера. Если в такой функции встречаются клиентские вызовы, например Сообщить или Состояние, то берите их в скобки ЕслиКлиент.
Yevhenii,
18.01.17, 12:43 Приказ о приеме на работу в 1С8
ЯраЯровая @ Сегодня, 12:11 * ,
Тут два варианта, правильный создать документ Ввод сведений о плановых начислениях работников и добавить там Взносы, либо отменить проведение приема добавить Взносы и провести, ну так не очень правильно.
Да взносы по нему рассчитывались, если не много месяцев то перезаполнить ТЧ Взносы в документах Начисления.
ЯраЯровая,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 22.10.17, 14:00
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне