Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 7
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику podcast ::: Спасибо сказали: 43 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
13.12.17, 9:34 Кадровое перемещение не проводится
Ariesod @ Вчера, 17:46 * ,
Проверить документ Кадровое перемещение в ТЧ удержание на дубли, похоже что вы ввели кого два раза.
Ariesod,
12.12.17, 17:17 Кадровое перемещение не проводится
Ariesod @ Сегодня, 15:25 * ,
Похоже что у вас в документе уже есть такая строка, а вы добавили её ещё раз.
Ariesod,
12.12.17, 14:16 Кадровое перемещение не проводится
Ariesod @ Сегодня, 12:22 * ,
Выложите скрин ТЧ Удержание и Регистр Плановые удержания.
Ariesod,
12.12.17, 10:22 Кадровое перемещение не проводится
Ariesod @ Сегодня, 10:07 * ,
Удержание на которое ругается был введён документ в этом периоде, уберите с документа это удержание и должно провестись, Кадровое перемещение проводят если меняется должность или подразделение, а просто для повышение оклада достаточно Ввод сведений и желательно что б документ заполнялся при изменении Сотрудника, а не вручную.
Ariesod,
11.12.17, 14:25 Загрузка зарплаты из Excel
Юля @ Сегодня, 14:08 * ,
На основании вашего документа есть возможность внести документ для изменение базового месяца.
Юля,
06.12.17, 10:40 Алименты (база-НДФЛ)*25%
Zene4ka @ Сегодня, 10:01 * ,
В Бухгалтерія никак, в ЗУП или УТП ещё можно как то формулы настроить.
Zene4ka,
30.11.17, 9:27 8.0.13.32 В отладке не срабатывает параметр запроса.В консоли отчетов срабатывает.
Sergey.pro1c.org.ua @ Сегодня, 0:35 * ,
Попробуйте не равно, а Подобно.
Sergey.pro1c.org.ua,
08.11.17, 15:16 Запуск фонового завдання
SaintDaemon @ Сегодня, 15:01 * ,
Я вам это и пытаюсь объяснить, в типовой конфигурации при начале работы системы есть проверка, если база файловая, тогда подключается обработчик ожидания для выполнения Регламентного задания, можно сделать обработку в которой подключите Обработчик ожидания для вашего Регламентного задания, или сделайте как в типовой.
Процедура ПриНачалеРаботыСистемы()
    ЭтоФайловаяИБ = ОпределитьЭтаИнформационнаяБазаФайловая();
        
    Если ЭтоФайловаяИБ Тогда
                    
        ПользовательДляВыполненияРеглЗаданий = Константы.ПользовательДляВыполненияРегламентныхЗаданийВФайловомВарианте.Получить();
        
        Если мТекущийПользователь = ПользовательДляВыполненияРеглЗаданий Тогда
            
            // с интервалом секунд вызываем процедуру работы с регламентными заданиями
            ПоддержкаРегламентныхЗаданиеДляФайловойВерсии();
            
            ПодключитьОбработчикОжидания("ПоддержкаРегламентныхЗаданиеДляФайловойВерсии", глЗначениеПеременной("глКоличествоСекундОпросаОбмена"));
            
            ИнтервалДляОпроса = Константы.ИнтервалДляОпросаРегламентныхЗаданийВФайловомВарианте.Получить();
            
            Если ИнтервалДляОпроса = Неопределено
                ИЛИ ИнтервалДляОпроса = 0 Тогда
                
                ИнтервалДляОпроса = 60;    
                
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЕсли;
КонецПроцедуры // ПриНачалеРаботыСистемы()


Функция ОпределитьЭтаИнформационнаяБазаФайловая(СтрокаСоединенияСБД = "") Экспорт
            
    СтрокаСоединенияСБД = ?(ПустаяСтрока(СтрокаСоединенияСБД), СтрокаСоединенияИнформационнойБазы(), СтрокаСоединенияСБД);
    
    // в зависимости от того файловый это вариант БД или нет немного по-разному путь в БД формируется
    ПозицияПоиска = Найти(Врег(СтрокаСоединенияСБД), "FILE=");
    
    Возврат ПозицияПоиска = 1;    
    
КонецФункции

// процедура служит для поддержки работы регламентных заданий в файловой версии
Процедура ПоддержкаРегламентныхЗаданиеДляФайловойВерсии() Экспорт
    
    ВыполнитьОбработкуЗаданий();
    
КонецПроцедуры
MATEVI,
30.10.17, 15:32 Событие ПриИзменении нужно добавлять текст в наименование другого реквизита
Krushiv @ Сегодня, 14:53 * ,
&НаКлиенте
Процедура ЧерныйСписокПриИзменении(Элемент)
    
    Если  ЧерныйСписок Тогда
        Объект.Наименование = "Черный список " + Объект.Наименование;
    КонецЕсли;
        
КонецПроцедуры
Krushiv,
06.10.17, 14:32 Перенос документов с бухгалтерии 1.2 в бухгалтерию 1.2
Юля @ Сегодня, 15:28 * ,
На ИТС есть обработка универсальный обмен данными в xml, или в гугле посмотрите.
Юля,
03.10.17, 16:27 Внешняя печатная форма
Pavlik1c @ Сегодня, 17:22 * ,
Свяжите свой запрос, и получите инвентарный номер.
Запрос.Текст =
     "ВЫБРАТЬ
     |    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство,
     |    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер
     |ИЗ
     |    РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних(&Дата, Организация = &Организация И ОсновноеСредство В (&ОсновноеСредство)) КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних";
    
    Результат = Запрос.Выполнить().Выбрать();
Pavlik1c,
18.09.17, 12:46 Не створюється новий звіт по ЄСВ
Юля @ Сегодня, 13:27 * ,
Скорей всего, у вас указана Налоговая в карточке организации с сентября.
Юля,
12.09.17, 9:44 Обработка для удаление Префикса в коде Номенклатуры.
Здравствуйте, последние время при обмене с Медком он создаёт номенклатуру с кодом "MED", и после этого пользователи создают номенклатуру и в код проставляется Префикс "MED".
Обработка перенумирует Номенклатуру с Кодом "MED", и при создание новой номенклатуры коды будут заполнятся корректно.
Vofka,
11.09.17, 15:10 Способ отладки прав пользователя
Володька @ Сегодня, 15:53 * ,
В отладке в конфигураторе Администрирование - Журнал регистрации, там покажет на какой регистр нету прав, Ошибка доступа должно быть, смотрите у пользователя Права на этот регистр.
Чаще всего это ограничения по Организациям или Контрагентам.
Володька,
06.09.17, 8:36 УТП Управленческая фактически выплаченная зарплата
Bernet @ Сегодня, 9:13 * ,
Типовое вряд ли что то есть, по выплате только в документе печатная форма, так только Расчетная ведомость может что то показать.
Bernet,
05.09.17, 12:32 Как подключится с одной базы к другой?
Vidocq05 @ Сегодня, 12:48 * ,
Получение остатков с другой базы.
// Выполняет подключение к базе-приемнику по заданным параметрам.
// Возвращает проинициализированную обработку УниверсальныйОбменДаннымиXML базы-приемника,
// которая будет использоваться для загрузки данных в базу-приемник.
//
// Параметры:
//  Нет.
//
//  Возвращаемое значение:
//  ОбработкаОбъект - УниверсальныйОбменДаннымиXML - обработка базы-приемника для загрузки данных в базу-приемник
//
Функция ВыполнитьПодключениеКИБПриемнику() Экспорт
    
    РезультатПодключения = Неопределено;
    
    СтруктураПодключения = Новый Структура();
    СтруктураПодключения.Вставить("ФайловыйРежим", ТипИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("АутентификацияWindows", Ложь);
    СтруктураПодключения.Вставить("КаталогИБ", КаталогИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("ИмяСервера", ИмяСервераИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("ИмяИБНаСервере", ИмяИнформационнойБазыНаСервереДляПодключения);
    СтруктураПодключения.Вставить("Пользователь", ПользовательИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("Пароль", ПарольИнформационнойБазыДляПодключения);
    СтруктураПодключения.Вставить("ВерсияПлатформы", ВерсияПлатформыИнформационнойБазыДляПодключения);
    
    ОбъектПодключения = ПодключитсяКИнформационнойБазе(СтруктураПодключения);
    
    Если ОбъектПодключения = Неопределено Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Попытка
        РезультатПодключения = ОбъектПодключения;
    Исключение
        
        Текст = НСтр("ru='При попытке создания обработки УниверсальныйОбменДаннымиXML произошла ошибка: %1';uk='При спробі створення обробки УниверсальныйОбменДаннымиXML сталася помилка: %1'");
        Текст = ПодставитьПараметрыВСтроку(Текст, КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
        СообщитьПользователю(Текст);
        РезультатПодключения = Неопределено;
    КонецПопытки;
    
    Возврат РезультатПодключения;
    
КонецФункции
&НаСервере
Процедура СформироватьНаСервере()
    
    Connection = ВыполнитьПодключениеКИБПриемникуНаСервере();
    
    ЗапросУТ=Connection.NewObject("Запрос");
    
    ЗапросУТ.Текст="ВЫБРАТЬ
    |    ТоварыНаСкладахОстатки.Номенклатура.Наименование КАК Номенклатура,
    |    ТоварыНаСкладахОстатки.ВНаличииОстаток КАК Остаток,
    |    ТоварыНаСкладахОстатки.Номенклатура.Артикул КАК Артикул
    |ПОМЕСТИТЬ ВТ
    |ИЗ
    |    РегистрНакопления.ТоварыНаСкладах.Остатки(&ДатаНачала, НЕ Номенклатура.Артикул ПОДОБНО """") КАК ТоварыНаСкладахОстатки
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    ТоварыПереданныеНаКомиссиюОстатки.АналитикаУчетаНоменклатуры.Номенклатура.Наименование КАК Номенклатура,
    |    ТоварыПереданныеНаКомиссиюОстатки.КоличествоОстаток,
    |    ТоварыПереданныеНаКомиссиюОстатки.АналитикаУчетаНоменклатуры.Номенклатура.Артикул
    |ИЗ
    |    РегистрНакопления.ТоварыПереданныеНаКомиссию.Остатки(&ДатаНачала, НЕ АналитикаУчетаНоменклатуры.Номенклатура.Артикул ПОДОБНО """") КАК ТоварыПереданныеНаКомиссиюОстатки
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |    ВложенныйЗапрос.Номенклатура,
    |    ВложенныйЗапрос.Остаток,
    |    ВложенныйЗапрос.Артикул
    |ИЗ
    |    (ВЫБРАТЬ
    |        ВТ.Номенклатура КАК Номенклатура,
    |        СУММА(ВТ.Остаток) КАК Остаток,
    |        ВТ.Артикул КАК Артикул
    |    ИЗ
    |        ВТ КАК ВТ
    |    
    |    СГРУППИРОВАТЬ ПО
    |        ВТ.Артикул,
    |        ВТ.Номенклатура) КАК ВложенныйЗапрос";
    
    ЗапросУТ.УстановитьПараметр("ДатаНачала", Объект.ДатаФормированияОстатков);
    
    РезультатЗапроса = ЗапросУТ.Выполнить();
КонецПроцедуры
Vidocq05,
09.08.17, 12:38 Отправка документов непосредственно из 1С
Bernet @ Сегодня, 13:06 * ,
Почитайте ссыль.
Bernet,
05.07.17, 15:55 Нет полных прав но есть возможность добавлять пользователе
Pavlik1c @ Сегодня, 16:39 * ,
У роли Пользователь есть доступ к Справочнику Пользователи, ограничьте в ролях.
Pavlik1c,
23.06.17, 8:48 Смещение даты/времени при оперативном проведении
Bernet @ Вчера, 17:53 * ,
Константа стоит Проверять разницу во времени?
Bernet,
04.04.17, 9:14 Как начислить премию(надбавку)ЗУП ред. 2.1
Юля @ Сегодня, 9:09 * ,
Проверьте в виде расчета базовые расчеты.
Юля,
22.03.17, 17:34 Как убрать должность главного бухгалтера в документах
Лелуш Ламперуж @ Сегодня, 17:32 * ,
Смотрю в каких документах и какие должности, но если править печатные формы, то да, их только через конфигуратор, если что обращайтесь помогу.
Лелуш Ламперуж,
22.03.17, 17:29 Как убрать должность главного бухгалтера в документах
Лелуш Ламперуж @ Сегодня, 16:58 * ,
Проверьте Регистр сведений Ответственные лица организации.
Лелуш Ламперуж,
17.03.17, 10:35 Как правильно начислять индексацию зарплаты?
Лелуш Ламперуж @ Сегодня, 10:30 * ,
Проставьте "Дату изменения", потом рассчитайте с комментарием.
Лелуш Ламперуж,
17.03.17, 10:22 Как правильно начислять индексацию зарплаты?
Лелуш Ламперуж @ Сегодня, 10:01 * ,
Введите на основание документа "Приём на работу", документ "Изменение параметров расчёта индексации", там будет реквизит в верхней ТЧ "Дата изменения" заполните его, а скрин который вы выложили, это вроде документ "Изменение параметров расчёта индексации (По должности)", почитайте изменения в Законодательстве когда нужно устанавливать базовый месяц по должности.
Лелуш Ламперуж,
17.03.17, 9:53 Как правильно начислять индексацию зарплаты?
Лелуш Ламперуж @ Сегодня, 9:48 * ,
Рассчитайте с комментарием, посмотрите какой базовый месяц установлен, если не правильно, то вносите документ "Изменение параметров расчёта индексации", и там устанавливайте нужный базовый месяц. Или выложите скрин комментария расчета.
Лелуш Ламперуж,

2 страниц V   1 2 >
RSS Текстовая версия Сейчас: 18.12.17, 5:23
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне