Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 5
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

30 страниц V   1 2 3 > » 

>  Парсер сайта и код ошибки 301
kosalex
Отправлено: Вчера, 22:33


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 22:27 * ,
ТП не отвечает) наверное этот вопрос не связан с курсами и проблемами обменников) по этому и игнор. Заголовки пробую в данный момент) Опишусь.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #137438 · Ответов: 4 · Просмотров: 63
 

>  Парсер сайта и код ошибки 301
kosalex
Отправлено: Вчера, 22:05


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 21:33 * ,

Сервер = "bestchange.ru";
    КаталогЗагрузки = "D:/Bestchange_parser";
    Соединение = Новый HTTPСоединение(Сервер,,,,,,Новый ЗащищенноеСоединениеOpenSSL);
    
    ЧтениеХТМЛ = Новый ЧтениеHTML;
    ПостроительДОМ = Новый ПостроительDOM;
    
    
    //Генерируем имя файла на диске, в который запишется страница сайта
    ИмяФайла = КаталогЗагрузки + "/Give/" + "give.html";
    
    //Загружаем нужную нам страницу в каталог
    Ресурс = "www.bestchange.ru";
    Заголовки = Новый Соответствие;
    Запрос = Новый HTTPЗапрос(Ресурс,Заголовки);
    Ответ = Соединение.Получить(Запрос, ИмяФайла);
    
    Если Ответ.КодСостояния = 301 Тогда
        Ответ = Соединение.Получить(Ответ.Заголовки.Получить("Location"),ИмяФайла);    
    КонецЕсли;
    
    //Начинаем чтение нашего файла
    ЧтениеХТМЛ.ОткрытьФайл(ИмяФайла, "UTF-8");
    //Загружаем всю структуру документа в DOM                                                                                        
    ДокументХТМЛ = ПостроительДОМ.Прочитать(ЧтениеХТМЛ);
    
    //Получаем все элементы TABLE
    ЭлементыTABLE = ДокументХТМЛ.ПолучитьЭлементыПоИмени("curr_tab");


Переменная Location при Ресурс = "www.bestchange.ru" становиться "https://www.bestchange.ru/www.bestchange.ru", при переходе на "https://www.bestchange.ru/www.bestchange.ru", становится "https://www.bestchange.ru/https://www.bestchange.ru/www.bestchange.ru".

Если Ресурс = "https://www.bestchange.ru", то Location будет равна "https://www.bestchange.ru/https://www.bestchange.ru", при переходе по этому адресу Location = "https://www.bestchange.ru/https://www.bestchange.ru/https://www.bestchange.ru"

Как же быть?))

Плиз, помогите! Ведь код есть, просто скопировать и попробовать. У меня уже нет вариантов как получить эту страницу... перепробовал все что было в голове... :-(
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #137435 · Ответов: 4 · Просмотров: 63
 

>  Парсер сайта и код ошибки 301
kosalex
Отправлено: Вчера, 21:09


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток! Пишу обработку для парсинга сайта bestchange.ru

Есть такой код:
Сервер = "bestchange.ru";
    
    КаталогЗагрузки = "D:/Bestchange_parser";
    Соединение = Новый HTTPСоединение(Сервер,,,,,,Новый ЗащищенноеСоединениеOpenSSL);
    
    ЧтениеХТМЛ = Новый ЧтениеHTML;
    ПостроительДОМ = Новый ПостроительDOM;
    //Генерируем имя файла на диске, в который запишется страница сайта
    ИмяФайла = КаталогЗагрузки + "/Give/" + "give.html";
    //Загружаем нужную нам страницу в каталог
    
    Ресурс = "bestchange.ru";
    Ответ = Соединение.Получить(Ресурс, ИмяФайла);
    //Начинаем чтение нашего файла
    ЧтениеХТМЛ.ОткрытьФайл(ИмяФайла, "UTF-8");
    //Загружаем всю структуру документа в DOM                                                                                        
    ДокументХТМЛ = ПостроительДОМ.Прочитать(ЧтениеХТМЛ);
    
    //Получаем все элементы TABLE
    ЭлементыTABLE = ДокументХТМЛ.ПолучитьЭлементыПоИмени("curr_tab");


В переменной "Ответ" получаю 301, адрес в заголовке 'Location' становиться "https://www.bestchange.ru/https://bestchange.ru", в общем проблема в том что эта переменная меняется, если отправлю значение переменной location, то "Ответ" будет опять 301 но уже "https://www.bestchange.ru/https://bestchange.ru/https://www.bestchange.ru/https://bestchange.ru"

как получить содержимое сайта?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #137433 · Ответов: 4 · Просмотров: 63
 

>  1С и facebook
kosalex
Отправлено: 31.12.17, 4:12


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 1:47 * ,
проблема видать будет только с одним) с вебсервисами :-) Никогда не юзал...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136831 · Ответов: 4 · Просмотров: 257
 

>  Заголовки GET запроса
kosalex
Отправлено: 31.12.17, 1:19


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Есть такой код:
ЗаголовокЗапроса = Новый Соответствие;
        ЗаголовокЗапроса.Вставить("Api-key",Ключ);
        ЗаголовокЗапроса.Вставить("Sign",Сигн)


Когда отправляю на сервер, то порядок меняется, на первом месте стоит "Sign", а нужно чтобы стояло "Api-key". И как такое сделать в "Соответствии" ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136829 · Ответов: 1 · Просмотров: 168
 

>  1С и facebook
kosalex
Отправлено: 30.12.17, 23:17


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 23:11 * ,
Это понимаю, за приложение в фейсбуке видел, читал. А вот куда там слать свой запрос не пойму...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136827 · Ответов: 4 · Просмотров: 257
 

>  1С и facebook
kosalex
Отправлено: 30.12.17, 14:57


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток! Нужно сделать пост из 1С в фейсбук. Покопавшись в интернете ничего подобного не нашел, только другие языки. Прошу помощи, знающие люди, подскажите как общаться с api фейсбук из 1С и реально это вообще? Код под другие языки в интернете видел.

kosalex @ Сегодня, 14:34 * ,

как подключиться, использовать SDK в 1С? что то не пойму :-)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136823 · Ответов: 4 · Просмотров: 257
 

>  Выполнение JavaScript в фоновом задании
kosalex
Отправлено: 24.12.17, 1:29


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


kosalex @ Вчера, 23:54 * ,
Решение нашел здесь http://anton.fly7.ru/sha/
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136650 · Ответов: 4 · Просмотров: 231
 

>  Выполнение JavaScript в фоновом задании
kosalex
Отправлено: 23.12.17, 23:54


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


sava1 @ Сегодня, 22:08 * ,
Вы имеете ввиду открыть еще одну копию программы ?

У меня обработка, которая запускает фоновое задание. В обработке есть цикл который постоянно мониторит таблицу. Фоновое задание выполняет анализ данных и пишет в РС. В обработке выборка из этого РС и в таблицу.


sava1 @ Сегодня, 22:08 * ,
база у меня файловая.

sava1 @ Сегодня, 22:08 * ,
и запускаю через "Запустить от имени администратора" сам конфигуратор и далее F5

kosalex @ Сегодня, 21:19 * ,

а что делает этот скрипт HTML.Write("<script>TransformString = function(x,y){return x.toString(y?y:16)}</script>"); ?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136635 · Ответов: 4 · Просмотров: 231
 

>  Выполнение JavaScript в фоновом задании
kosalex
Отправлено: 23.12.17, 21:19


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Здравствуйте! Реализую подключение к API которое использует шифрование SHA512. На просторах интернета нашел такое решение
Секрет = Константы.Секрет.Получить();
    Текст = Новый COMОбъект("System.Text.UTF8Encoding");
    Криптография = Новый COMОбъект("System.Security.Cryptography.HMACSHA512");
    Криптография.Key = Текст.GetBytes_4(Секрет);
    ХешБайт = Криптография.ComputeHash_2(Текст.GetBytes_4(Запись.Значение)).Выгрузить();
    HTML = Новый COMОбъект("htmlfile");
    HTML.Open("text/html");
    HTML.Write("<script>TransformString = function(x,y){return x.toString(y?y:16)}</script>");
    ЯваСкрипт = HTML.documentElement.document.Script;
    
    Хеш = "";
    Для Каждого Байт Из ХешБайт Цикл
        Символ = ЯваСкрипт.TransformString(Байт);
        Хеш = Хеш + ?(СтрДлина(Символ) = 2, Символ, "0"+Символ);
    КонецЦикла;


Проблема заключается в следующем, если запустить этот код не в фоновом задании то строка "ЯваСкрипт = HTML.documentElement.document.Script;" отрабатывает нормально, "Script" существует. А вот когда запускается в фоне, то вылетает с ошибкой что "Script" нет такого. Подскажите как быть, что делать?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #136633 · Ответов: 4 · Просмотров: 231
 

>  Все время увеличивается номер, даже если не записывать объект
kosalex
Отправлено: 14.11.16, 9:50


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Здравствуйте! Есть объект бизнес процесс, при создании автоматически как и надо увеличивается номер, но если этот объект с номером 001 создать копированием и не записать и еще раз создать то номер будет 003, как это исправить чтобы номер не увеличивался при каждом создании но не записи объекта?

kosalex @ Сегодня, 9:20 * ,


решил - в свойствах конфигурации включил "Освобождать номер автоматически"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #119169 · Ответов: 0 · Просмотров: 593
 

>  Из множества А вычесть множество Б в запросе
kosalex
Отправлено: 28.10.16, 13:52


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 14:46 * ,
Вот оно))

ВЫБРАТЬ
    ОсновныеНачисленияРаботниковОрганизаций.Сотрудник,
    СУММА(ОсновныеНачисленияРаботниковОрганизаций.Результат) КАК Результат
ИЗ
    РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизаций
ГДЕ
    ОсновныеНачисленияРаботниковОрганизаций.ПериодРегистрации = &ПериодРегистрации
    И НЕ ОсновныеНачисленияРаботниковОрганизаций.Сотрудник В
                (ВЫБРАТЬ
                    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Сотрудник КАК Сотрудник
                ИЗ
                    Документ.РегистрацияРазовыхНачисленийРаботниковОрганизаций.ОсновныеНачисления КАК РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления
                ГДЕ
                    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Ссылка = &Ссылка
                СГРУППИРОВАТЬ ПО
                    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Сотрудник)
    И ОсновныеНачисленияРаботниковОрганизаций.Результат <> 0

СГРУППИРОВАТЬ ПО
    ОсновныеНачисленияРаботниковОрганизаций.Сотрудник
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118340 · Ответов: 9 · Просмотров: 955
 

>  Из множества А вычесть множество Б в запросе
kosalex
Отправлено: 28.10.16, 13:41


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


По моему получилось :-)

ВЫБРАТЬ
    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Сотрудник КАК Сотрудник,
    СУММА(РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Результат) КАК Результат
ПОМЕСТИТЬ ВТ_НеНужныеСотрудники
ИЗ
    Документ.РегистрацияРазовыхНачисленийРаботниковОрганизаций.ОсновныеНачисления КАК РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления
ГДЕ
    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Ссылка = &Ссылка

СГРУППИРОВАТЬ ПО
    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Сотрудник
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ОсновныеНачисленияРаботниковОрганизаций.Сотрудник,
    СУММА(ОсновныеНачисленияРаботниковОрганизаций.Результат) КАК Результат
ИЗ
    РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизаций,
    ВТ_НеНужныеСотрудники КАК ВТ_НеНужныеСотрудники
ГДЕ
    ОсновныеНачисленияРаботниковОрганизаций.ПериодРегистрации = &ПериодРегистрации
    И НЕ ОсновныеНачисленияРаботниковОрганизаций.Сотрудник В
                (ВЫБРАТЬ
                    ВТ_НеНужныеСотрудники.Сотрудник
                ИЗ
                    ВТ_НеНужныеСотрудники)

СГРУППИРОВАТЬ ПО
    ОсновныеНачисленияРаботниковОрганизаций.Сотрудник


logist @ Сегодня, 14:38 * ,
Читал) Я по вашему примеру сделал.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118336 · Ответов: 9 · Просмотров: 955
 

>  Из множества А вычесть множество Б в запросе
kosalex
Отправлено: 28.10.16, 13:31


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 14:26 * ,

ВЫБРАТЬ
    ОсновныеНачисленияРаботниковОрганизаций.Сотрудник КАК Сотрудник,
    СУММА(ОсновныеНачисленияРаботниковОрганизаций.Результат) КАК Результат
ПОМЕСТИТЬ ВТ_НужныеСотрудники
ИЗ
    РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизаций
ГДЕ
    ОсновныеНачисленияРаботниковОрганизаций.ПериодРегистрации = &ПериодРегистрации

СГРУППИРОВАТЬ ПО
    ОсновныеНачисленияРаботниковОрганизаций.Сотрудник
;

////////////////////////////////////////////////////////////////////////////////
ВЫБРАТЬ
    ВТ_НужныеСотрудники.Сотрудник,
    ВТ_НужныеСотрудники.Результат
ИЗ
    Документ.РегистрацияРазовыхНачисленийРаботниковОрганизаций.ОсновныеНачисления КАК РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления,
    ВТ_НужныеСотрудники КАК ВТ_НужныеСотрудники
ГДЕ
    РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Ссылка = &Ссылка
    И НЕ ВТ_НужныеСотрудники.Сотрудник.Ссылка В (РегистрацияРазовыхНачисленийРаботниковОрганизацийОсновныеНачисления.Сотрудник)


вот так делаю всё равно присутствует сотрудник...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118333 · Ответов: 9 · Просмотров: 955
 

>  Из множества А вычесть множество Б в запросе
kosalex
Отправлено: 28.10.16, 13:05


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток!
Легкая задача...а результат не получается...

Есть ТаблицаА с сотрудниками, и ТаблицаБ с сотрудниками, нужно получить ТаблицаС в которой будут сотрудники которых нет в ТаблицаБ.

Другими словами нужно из ТаблицаА удалить сотрудников которые есть в ТаблицаБ.

Дайте пример плиз...

Пробую и через ВТ, и вложенным запросом, всё равно сотрудники остаются...
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #118329 · Ответов: 9 · Просмотров: 955
 

>  Чудеса с одним и тем же отчетом
kosalex
Отправлено: 30.06.16, 10:50


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Acid @ Сегодня, 10:43 *,

Нажимал, результат - ничего не изменяется)
  Форум: Корзина · Просмотр сообщения: #113993 · Ответов: 3 · Просмотров: 382
 

>  Чудеса с одним и тем же отчетом
kosalex
Отправлено: 30.06.16, 10:38


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток!
Есть самописная база, в ней отчет на СКД, запускаю под "пользователь1" - отчет работает и настройки видны. Запускаю этот же отчет с этого же компьютера под "пользователь2" - отчет не работает, настройки пустые...
Права у пользователей одинаковые.



Кэш чистил, результата ноль.

Подскажите в чём фокус?
  Форум: Корзина · Просмотр сообщения: #113990 · Ответов: 3 · Просмотров: 382
 

>  Подбор у поля ввода в списке выбора
kosalex
Отправлено: 14.06.16, 14:39


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Petre @ Сегодня, 14:31 *,
Можно пример?
Проблема в том что, номера содержат АН1234АА, АН3333АА, АН6666АА, так вот пользователю нужно ввести АН9999АА, он вводит АН и подтягивается один из номеров который уже есть с списке выбора.
Хочет ввести АН9999АА, а получает АН1234АА
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #113591 · Ответов: 5 · Просмотров: 902
 

>  Подбор у поля ввода в списке выбора
kosalex
Отправлено: 14.06.16, 14:22


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


logist @ Сегодня, 14:02 *,

мне нужно дать возможность пользователю в это поле ввести номер которого нет, чтобы сразу не подставлялся номер который похож по первым двум символам.
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #113588 · Ответов: 5 · Просмотров: 902
 

>  Подбор у поля ввода в списке выбора
kosalex
Отправлено: 14.06.16, 13:58


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток!
На форме есть поле ввода со списком выбора. При открытии формы заполняю этот список. Например в списке получается две записи "АН 1234 АА" и "АН 7654 АА". Пользователю нужно ввести например "АН 4444 АА", при вводе "АН" программа сразу подтягивает "АН 1234 АА", а нужно дать пользователю возможность написать "АН 4444 АА". Как такое реализовать?
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #113582 · Ответов: 5 · Просмотров: 902
 

>  Выбор значение из списка значения у поля выбора
kosalex
Отправлено: 02.06.16, 13:36


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток!
Помогите плиз...
На форме есть поле ввода с режимом выбор из списка.Список заполняется программно при открытии формы из справочника.
Когда пользователь вводит в это поле значение, программа проверят есть ли это значение в справочнике, если нету то создает его и добавляет в список выбора.
В чем проблема, когда пользователь выбирает добавленное в список значение, то поле остается пустым....
Вот код:

Процедура НоменклатураОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    ПоискВСписке = Справочники.Номенклатура.НайтиПоНаименованию(Текст,Истина);
    
    Если ПоискВСписке.Пустая() Тогда //Создадим номенклатуру
        обНоменклатура = Справочники.Номенклатура.СоздатьЭлемент();
        обНоменклатура.Наименование = Текст;
        обНоменклатура.Записать();
        Элемент.СписокВыбора.Добавить(обНоменклатура.Ссылка,обНоменклатура.Наименование,,);
        ВыбЗначение = ВыбратьИзСписка(Элемент.СписокВыбора,ЭлементыФормы.Номенклатура,ЭлементыФормы.Номенклатура.СписокВыбора.Количество()-1);
        ЭлементыФормы.Номенклатура.Значение = ВыбЗначение.Значение;
        
    КонецЕсли;
    
КонецПроцедуры
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #113163 · Ответов: 0 · Просмотров: 487
 

>  Переброс данных COM
kosalex
Отправлено: 12.05.16, 12:59


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


Доброго времени суток! Подскажите плиз...а то не получается...перепробовал уже все...


Есть база1 и база2, из базы1 перебрасываются данные в базу2, и в базе1 и в базе2 есть одно и тоже перечисление.

Не получается получить индекс перечисления...
Не получается получить перечисление.


Вот один из вариантов как пишу:
ИмяПеречисления = "ТипыВагонов";
ИндексПеречисления = БазаЮЖД.Перечисления[ИмяПеречисления].Индекс(Строка.ТипВагона);
ИмяЗначениеПеречисления = БазаЮЖД.Метаданные().Перечисления[ИмяПеречисления].EnumValues.Get(ИндексПеречисления).Name;
ЗначениеПеречисления = Перечисления[ИмяПеречисления][ИмяЗначениеПеречисления];
ТипВагона = ЗначениеПеречисления;


Получаю, метод "Индекс" не найден...

аааууу. Подскажите...

Для Каждого Строка Из ДанныеИзСЖД Цикл
ИмяПеречисления = "ТипыВагонов";
ИндексПеречисления = БазаСЖД.Перечисления[ИмяПеречисления].Индекс(Строка.ТипВагона);
ИмяЗначениеПеречисления = БазаСЖД.Метаданные().Перечисления[ИмяПеречисления].EnumValues.Get(ИндексПеречисления).Name;
ЗначениеПеречисления = Перечисления[ИмяПеречисления][ИмяЗначениеПеречисления];
ТипВагона = ЗначениеПеречисления;
КонецЦикла;



Ошибка:
{ОбщийМодуль.КФЗ_Весовая.Модуль(914)}: Ошибка при вызове метода контекста (Индекс)
ИндексПеречисления = БазаСЖД.Перечисления[ИмяПеречисления].Индекс(Строка.ТипВагона);
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.7.1949): Несоответствие типов (параметр номер '1')



Пожалуйста, подскажите!


ИндексПеречисления = XMLЗначение(Тип("ПеречислениеСсылка.ТипыВагонов"),БазаСЖД.XMLString(Строка.ТипВагона));



Так возвращает пустую строку.

В Строка.ТипВагона - находиться ComОбъект...почему?

Как решить эту простую задачку...ппц...

Решилось...ребят...сор...тупка просто))
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #112373 · Ответов: 1 · Просмотров: 492
 

>  Помогите доработать запрос 1с для УТП (1с 8.3)
kosalex
Отправлено: 23.04.16, 21:33


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


передать массивом и поставить условие "В"
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #111886 · Ответов: 2 · Просмотров: 546
 

>  Помогите с запросом
kosalex
Отправлено: 25.03.16, 10:11


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


pablo @ Сегодня, 10:01 *,
3. Если Сотрудника уволили посреди месяца, в запросе должны отбираться записи только до даты увольнения. Оставшиеся записи по сменам должны быть с заполненной датой и реквизитами работника, но без молока (0 количество)

Видно что уже попили чай/кофе :-)
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #110384 · Ответов: 5 · Просмотров: 690
 

>  Помогите с запросом
kosalex
Отправлено: 25.03.16, 9:54


Почти ветеран
******

Группа: Пользователи
Сообщений: 732
Регистрация: 04.04.13
Пользователь №: 26110


pablo @ Сегодня, 9:49 *,
Цитата(pablo @ 25.03.16, 9:49) *
А теперь эту же фразу, но растяните на несколько предложений.


покажите пример
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #110380 · Ответов: 5 · Просмотров: 690
 

30 страниц V   1 2 3 > » 

Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 20.01.18, 3:14
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне