Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 8, свеженьких 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
batlcat
Отправлено: 18.07.18, 10:24


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


ВЫ не замечаете некоторого диссонанса в том как его опознала система и от кого ждет события 1С

Попробуйте поменять "HID устройства" такой же как его опознала система



Согласно ссылке на тех поддержку сканер дожен нормально работать в режиме эмуляции СОМ порта

https://support.honeywellaidc.com/s/article...face-with-Linux

Думаю в таком режиме будет работать более предсказуемо

Voyager 1300g у меня на оборудовании с linux embedded работают как раз в режиме эмуляции COM
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143501 · Ответов: 18 · Просмотров: 829
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
batlcat
Отправлено: 13.07.18, 12:46


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Вопрос
Как он у вас настроен
Клавиатура или эмуляции СОМ
Сможете показать диалог настройки в 1С
На какой порт вы его настроили

И покажите
lsusb
Интересно все же что за сканер у вас
Как он опознавался в системе
Подставилось родное в качестве драйвера или [Generic USB K/B]
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143347 · Ответов: 18 · Просмотров: 829
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
batlcat
Отправлено: 10.07.18, 15:27


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Leschyu @ Сегодня, 16:07 * ,
lsusb

И посмотреть что он отдает

sudo tail -f /dev/[порт на который он зацепился]
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143226 · Ответов: 18 · Просмотров: 829
 

>  Не срабатывает ОбработкаВнешнегоСобытия при сканировании штрих кода
batlcat
Отправлено: 10.07.18, 15:01


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Версия библиотеки какая (версия драйвера) ???

Вроде как в ноябрьской что то исправляли касаемо работы в Linux
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #143223 · Ответов: 18 · Просмотров: 829
 

>  Перехід з редакції 1.2 на 2.0
batlcat
Отправлено: 12.06.18, 10:35


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Юля @ Сегодня, 9:59 * ,
Платформа 8.3.10.хххх
Клиент 32, сервер 64 вылетает с такой же ошибкой если просто нажать сохранить

А если через меню "Конфигурация"-"Конфигурация базы данных"-"Обновить конфигурацию базы данных на сервере"

Обновление и реструктуризация проходят без ошибок.
  Форум: Бухгалтерия 8, редакция 2 для Украины · Просмотр сообщения: #142458 · Ответов: 6 · Просмотров: 397
 

>  8.3.11.3034 Обвернуть сеанс клиентского подключения в SSH
batlcat
Отправлено: 15.03.18, 16:51


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


uanr81 @ Сегодня, 15:12 * ,

В ssh сеси пробрасывавший порты
1540
1541
1560
1561

ssh -L 1540:127.0.0.1:1540 -L 1541:127.0.0.1:1541 -L 1560:127.0.0.1:1560 -L 1561:127.0.0.1:1561 -l [пользователь] [адрес сервера]

на локальной машине (где запукскаеш ssh клиент) в файл Host
Добавить нечто подобное
*************
127.0.0.1 1CServer
*************
1С клиент не понимает IP в поле сервер и имя localhost тоже ее не устраивает поэтому "1CServer"
И пробывать работть в конфигураторе в качастве сервера 1С указав "1CServer"

!!!!!!!!!!!!!!!!!!!
Если в момент сохранения конфигурации у вас притормозится или оборвется соединение вы с вероятностью 99,999% убьете базу
  Форум: Программирование в 1С Предприятие 8.3 · Просмотр сообщения: #139673 · Ответов: 3 · Просмотров: 528
 

>  Выгрузка физлиц из ЗУП в БП 2.0
batlcat
Отправлено: 22.08.17, 14:35


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


В стандартной боработке выгрузки из ЗуП в Бп 2.0 поиск физлиц осуществяется по Коду и !!!Дате рождения!!!


 ! 

Правила: 4,5
 
  Форум: 1С Зарплата и Управление Персоналом 8 · Просмотр сообщения: #131159 · Ответов: 2 · Просмотров: 577
 

>  При створенні XML файлу виникає декілька проблем підкажіть як їх можна вирішити
batlcat
Отправлено: 24.05.17, 12:17


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Цитата(leo10k10 @ 23.05.17, 17:53) *
ДанныеXML.УстановитьАтрибут("xmlns" + "-" + "xsi", "http" + "-" + "//www.w3.org/2001/XMLSchema-instance");


ДанныеXML.УстановитьПространствоИмен("http://www.w3.org/2001/XMLSchema-instance","xsi");
  Форум: Программирование в 1С Предприятие 7.7 · Просмотр сообщения: #127403 · Ответов: 10 · Просмотров: 1375
 

>  Интеграционная стыковка для 1С 8.2 и M.E.Doc
batlcat
Отправлено: 06.04.16, 9:43


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


ru5 @ Сегодня, 11:05 *,
Функционал по просмотру xml добавления его в базу 1с

Процедура ДействияФормыXMLРаспечатать(ДанныеXML) экспорт
    
    Если ПустаяСтрока(ДанныеXML) Тогда
        Предупреждение(НСтр("ru='XML не был загружен!';uk='XML не був завантажений!'"));
        Возврат;    
    КонецЕсли;    
    // Проверим файл на корректность
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл(ДанныеXML);
    ЧтениеXML.ИгнорироватьПробелы = Истина;
    Попытка
        ЧтениеXML.Прочитать();
    Исключение
        
        Предупреждение(НСТр("ru='Данный файл содерижит информацию в закодированном виде и не является стандартым текстовым XML-файлом."
"Необходимо воспользоваться специализированным программным обеспечением для его расшифровки.';uk='Зазначений файл містить інформацію в закодованому вигляді та не являє собою стандартний текстовий XML-файл."
"Необхідно скористатися спеціалізованим програмним забезбеченням для його розшифрування.'"));
                            
        Возврат;
    КонецПопытки;
    
    // определим номер схемы документа
    C_DOC     = "";
    C_DOC_SUB = "";
    C_DOC_VER = "";
    
    Пока ЧтениеXML.Прочитать() Цикл
        
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            
            ТекУзел = ВРЕГ(ЧтениеXML.Имя);
            
            Если ТекУзел = "C_DOC" Тогда
                ЧтениеXML.Прочитать();
                C_DOC = ЧтениеXML.Значение;
                Продолжить;
            ИначеЕсли ТекУзел = "C_DOC_SUB" Тогда
                ЧтениеXML.Прочитать();
                C_DOC_SUB = ЧтениеXML.Значение;
                C_DOC_SUB = Формат(Число(C_DOC_SUB), "ЧЦ=3; ЧВН=");
                Продолжить;
            ИначеЕсли ТекУзел = "C_DOC_VER" Тогда                              
                ЧтениеXML.Прочитать();
                C_DOC_VER = ЧтениеXML.Значение;
                C_DOC_VER = Формат(Число(C_DOC_VER), "ЧЦ=2; ЧВН=");
                Прервать;
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЦикла;        
    ЧтениеXML.Закрыть();
    
    ВерсияДокумента = "" + C_DOC + C_DOC_SUB + C_DOC_VER;
    
    // найдем подходящую форму налоговой (регл. отчет)
    Если  (C_DOC     = "J12" ИЛИ C_DOC     = "F12")
        И (C_DOC_SUB = "010" ИЛИ C_DOC_SUB = "012") Тогда
        
        Если C_DOC_SUB = "010" Тогда
            ИмяОтчета = "РегламентированныйОтчетНалоговаяНакладная";
        ИначеЕсли C_DOC_SUB = "012" Тогда    
            ИмяОтчета = "РегламентированныйОтчетПриложение2КНалоговойНакладной";
        КонецЕсли;
        
    Иначе
        
        // не тот XML подсунули
        Предупреждение(НСТр("ru='Загруженный файл не является XML образом Налоговой накладной или Приложения 2 к налоговой накладной!';uk='Завантажений файл не є XML образом Податкової накладної або Додатка 2 до податкової накладної!'"));
        Возврат;    
        
    КонецЕсли;
        
    ТекОтчет = РегламентированнаяОтчетность.РеглОтчеты(ИмяОтчета);
    Если ТекОтчет = Неопределено Тогда
        ТекстОшибки = НСтр("ru='Не удалось открыть для просмотра отчет ';uk='Не вдалося відкрити для перегляду звіт '")+ИмяОтчета+"""";
        Предупреждение(ТекстОшибки);
        Возврат;    
    КонецЕсли;
    
    Попытка
        МакетПоказателейЗвит1С = ТекОтчет.ПолучитьМакет("ПоказателиЗвит1С");
    Исключение
        ТекстОшибки = НСтр("ru='Не удалось определить для просмотра требуемую форму отчета ';uk='Не вдалося визначити для перегляду необхідну форму звіту  '")+ИмяОтчета+"""";
        Предупреждение(ТекстОшибки);
        Возврат;    
    КонецПопытки;
    МакетПоказателейЗвит1С.КодЯзыкаМакета = "ru";
    
    ИмяФормыПросмотра = "";
    ОбластьСтруктура = МакетПоказателейЗвит1С.ПолучитьОбласть("Структура");
    Для сч = 1 По ОбластьСтруктура.ВысотаТаблицы Цикл
        
        ИмяСхемыЗвит1С = СокрЛП(ОбластьСтруктура.Область(сч, 1, сч, 1).Текст);
        
        Если ВерсияДокумента = ИмяСхемыЗвит1С Тогда
            ИмяФормыПросмотра = СокрЛП(ОбластьСтруктура.Область(сч, 3, сч, 3).Текст);
            Прервать;
        КонецЕсли;
        
    КонецЦикла;
    
    // откроем отчет и загрузим в него данные XML
    Попытка
        ФормаПросмотра = ТекОтчет.ПолучитьФорму(ИмяФормыПросмотра);
    Исключение
        ТекстОшибки = НСтр("ru='Не удалось открыть для просмотра требуемую форму отчета';uk='Не вдалося відкрити для перегляду необхідну форму звіту '")+ИмяОтчета+"""";
        Предупреждение(ТекстОшибки);
        Возврат;    
    КонецПопытки;
    
    Попытка
        ТабличныйДокумент = ФормаПросмотра.ЗагрузитьТекстXMLНаФорму(ДанныеXML);
        УдалитьФайлы(ДанныеXML);
    Исключение
        ТекстОшибки = НСтр("ru='Не удалось открыть для просмотра требуемую форму отчета. Возможно не обновлены встроенные регламентированные отчеты';uk='Не вдалося відкрити для перегляду необхідну форму звіту. Можливе не оновлені вбудовані регламентовані звіти'")+ИмяОтчета+"""";
        Предупреждение(ТекстОшибки);
        Возврат;    
    КонецПопытки;                            
    
    // откроем печатную форму на просмотр
    ТабличныйДокумент.Показать(НСТР("ru='ОЗНАКОМИТЕЛЬНАЯ печатная форма входящего документа';uk='ОЗНАЙОМЛЮЮЧА друкована форма вхідного документа'"));    
КонецПроцедуры

Функция НайтиКвитанцию(Квитан)Экспорт
    Результат ="";
    Попытка
    Если Квитан.RecordCount()<1 тогда
         Возврат Результат;
    КонецЕсли    
   Исключение
   КонецПопытки;
    ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ИгнорироватьПробелы = Истина;
    Пока НЕ Квитан.EOF Цикл
        Попытка
            XML=Сокрлп(Квитан.Fields.Item("KVT_TEXT").value);
            ЧтениеXML.УстановитьСтроку(XML);
            // определим номер схемы документа
            C_DOC     = "";
            C_DOC_SUB = "";
            C_DOC_VER = "";
            
            Пока ЧтениеXML.Прочитать() Цикл
                
                Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
                    
                    ТекУзел = ВРЕГ(ЧтениеXML.Имя);
                    
                    Если ТекУзел = "C_DOC" Тогда
                        ЧтениеXML.Прочитать();
                        C_DOC = ЧтениеXML.Значение;
                        Продолжить;
                    ИначеЕсли ТекУзел = "C_DOC_SUB" Тогда
                        ЧтениеXML.Прочитать();
                        C_DOC_SUB = ЧтениеXML.Значение;
                        C_DOC_SUB = Формат(Число(C_DOC_SUB), "ЧЦ=3; ЧВН=");
                        Продолжить;
                    ИначеЕсли ТекУзел = "C_DOC_VER" Тогда                              
                        ЧтениеXML.Прочитать();
                        C_DOC_VER = ЧтениеXML.Значение;
                        C_DOC_VER = Формат(Число(C_DOC_VER), "ЧЦ=2; ЧВН=");
                        Прервать;
                    КонецЕсли;
                    
                КонецЕсли;
                
            КонецЦикла;        
            ЧтениеXML.Закрыть();
            
            ВерсияДокумента = "" + C_DOC + C_DOC_SUB + C_DOC_VER;
            
            // найдем подходящую форму налоговой (регл. отчет)
            Если  (C_DOC     = "J12" ИЛИ C_DOC     = "F12")
                И (C_DOC_SUB = "010" ИЛИ C_DOC_SUB = "012") Тогда
                ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
                Текст = Новый ТекстовыйДокумент;
                Текст.УстановитьТекст(XML);
                Текст.Записать(ИмяВременногоФайла, "windows-1251");
                Результат =ИмяВременногоФайла;
                
                Прервать;
            КонецЕсли;    
        Исключение
        КонецПопытки;        
        Квитан.Next();
    КонецЦикла;
      Возврат Результат;

КонецФункции


просмотр
ДействияФормыXMLРаспечатать(НайтиКвитанцию(Квитан));


Запись в базу
//******"
                Попытка
                    //Если ЭлементыФормы.фЗагрузкаXML.Значение И (ИмяБазы="БУ" ИЛИ ИмяБазы="УТП" или ИмяБазы="УСХ") тогда
                        primДокументы = App.GetPrimaryDocs();
                        Квитан=primДокументы.getdockvt("",Отчет.Cardcode);
                        ИмяВременногоФайла=НайтиКвитанцию(Квитан);
                        Если Не ПустаяСтрока(ИмяВременногоФайла) тогда
                        ННВх.ДанныеXML = Новый ХранилищеЗначения(Новый ДвоичныеДанные(ИмяВременногоФайла), Новый СжатиеДанных(9));
                        ННВх.ЕстьXML   = Истина;
                        УдалитьФайлы(ИмяВременногоФайла);
                        Конецесли;
                    //Конецесли;
                Исключение
                    Сообщить(Нстр("ru = 'Не удалось загрузить XML!';uk = 'Не вдолося завантажити XML!'"));
                КонецПопытки;
//******"
  Форум: Прочее 1С 8 · Просмотр сообщения: #111025 · Ответов: 611 · Просмотров: 136637
 

>  Логотип поставщика в счет-фактуре.
batlcat
Отправлено: 20.11.15, 13:52


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Должно работать так
Шапка.Рисунки.Картинка.Картинка =Производитель.ОсновноеИзображение.Хранилище.Получить();


У меня по крайней мере работает

И рекомендую еще прикрутить ImageMagick для подгонки размера в печатной форме

У меня реализовано вот так
         Формат=НРег(Строка(Карт.Формат())); 
         ИмяФайла = ПолучитьИмяВременногоФайла(Формат);
         Карт.Записать(ИмяФайла);  
        
         СистемнаяИнформация = Новый СистемнаяИнформация;
    
         Если СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86 ИЛИ СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Windows_x86_64  Тогда
             Фото       = Новый COMОбъект("ImageMagickObject.MagickImage.1");
             Ответ = Фото.Convert( ИмяФайла , "-trim" , "-set", "colorspace", "RGB ", "-colorspace", "gray", "-contrast",  "-resize", Размер , "-contrast" , "-normalize" , ИмяФайла);
         ИначеЕсли СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Linux_x86 ИЛИ СистемнаяИнформация.ТипПлатформы = ТипПлатформы.Linux_x86_64  Тогда
            СтрокаЗапуска = "convert  -trim -set colorspace RGB -colorspace gray -contrast -resize " + Размер + " -contrast -normalize " + ИмяФайла + " "  + ИмяФайла;
            КомандаСистемы(СтрокаЗапуска);
            //ЗапуститьПриложение(СтрокаЗапуска);
            // Сообщить(СтрокаЗапуска);
        Конецесли;
  Форум: Программирование обычных форм 1С 8.2 и не интер... · Просмотр сообщения: #105309 · Ответов: 6 · Просмотров: 2038
 

>  Технологическая платформа 8.3
batlcat
Отправлено: 29.04.15, 22:17


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Выложили релиз Технологическая платформа 8.3 8.3.6.1977

https://users.v8.1c.ru/distribution/version...;ver=8.3.6.1977
  Форум: Новости 1С · Просмотр сообщения: #98589 · Ответов: 24 · Просмотров: 12817
 

>  В НН счет-фактура как договор-постаки/предоставления услуг
batlcat
Отправлено: 03.04.15, 1:36


Общительный
**

Группа: Пользователи
Сообщений: 12
Регистрация: 03.04.13
Пользователь №: 26052


Плюсы и минусы у каждого свои индивидуальные smile.gif

Для нужного человеку функционала нужно всего добавить 7 строк кода в конфигурациию
А печатная форма даже если копи пасте большей части из конфигурации несколько сот строк, которые еще через отладку нужно пропустить

Нужно еще убедится что вся эта беда экспортируется в XML и 1СЗвіт

Поэтому по трудозатратам в данном конкретном случае ковырнуть конфигурацию в разы проще.

Насчет пункта III
Обращения игнорируются
Видимо все усилия брошены на развитие конфигураций с новым интерфейсом

Есть надежда на новый механизм Расширений и сравнений (внешне diff утилиты) в новой платформе 8.3.6
  Форум: Управление торговлей для Украины редакция 2 (Уп... · Просмотр сообщения: #97759 · Ответов: 12 · Просмотров: 3776
 


Новые сообщения  Открытая тема (есть новые ответы)
Опрос  Опрос (есть новые голоса)
Нет новых сообщений  Открытая тема (нет новых ответов)
Нет новых голосов  Опрос (нет новых голосов)
Популярная тема  Горячая тема (есть новые ответы)
Закрыта  Закрытая тема
Нет новых  Горячая тема (нет новых ответов) Перемещена  Тема перемещена
 

RSS Текстовая версия Сейчас: 23.10.18, 14:08
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне