Версия для печати темы (http://pro1c.org.ua/index.php?s=6d3e21cb698fa7b9dc32b6e7f5ad597f&showtopic=9677)

Нажмите сюда для просмотра этой темы в обычном формате

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7 _ Программирование обычных форм 1С 8.2 и не интерфейсной логики _ Нумерация строк в справочнике

Автор: bereznoy 07.11.12, 23:57

Справочник контрагентов, при использовании различных отборов, иногда инетерсно а какое количество контрагентов у меня по конкретным отборам, вот и задался целью сделать колонку в которой просто будет номер строки по порядку, пытаюсь делать чере ПриВыводеСтрокиСписка, но не получается, ДанныеСтроки.Номер = ДанныеСтроки.Номер +1; не катит, подскажите как это лучше сделать

Автор: Ardi 08.11.12, 0:01

Добавить одно поле "Кво" а не колонку. И выводить туда количество.

Чтобы узнать к-во придётся воспользоваться объектом "ПостроительОтчета" - загонять в него отборы и получать количество.

Автор: Vofka 08.11.12, 9:10

Пользуйтесь ПКМ\Вывести список и будет всем счастье.

Автор: AnryMc 08.11.12, 9:58

Форма списка - Событие: ОбновлениеОтображения


Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(СправочникСписок);
Выборка = Построитель.Результат.Выбрать();
колвоДокументов = Выборка.Количество();

ЭлементыФормы.Надпись1.Значение=колвоДокументов;

//!!! Отображает количество "видимых" строк с учетом иерархии.!!!

Автор: bereznoy 08.11.12, 21:52

Цитата(AnryMc @ 08.11.12, 9:58) *
Форма списка - Событие: ОбновлениеОтображения


Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(СправочникСписок);
Выборка = Построитель.Результат.Выбрать();
колвоДокументов = Выборка.Количество();

ЭлементыФормы.Надпись1.Значение=колвоДокументов;

//!!! Отображает количество "видимых" строк с учетом иерархии.!!!

Что то я такого события не нашел (((

Автор: Vofka 08.11.12, 22:11

Как это печально sad.gif . Телепатирую, что ищется в событиях табличного поля... Вам же русским языком написали:

Цитата(AnryMc @ 08.11.12, 9:58) *
Форма списка - Событие: ОбновлениеОтображения

Это событие ФОРМЫ. faceoff.gif

Автор: Ardi 08.11.12, 22:34

Цитата(Zaval @ 07.11.12, 2:18) *
Все не так, причем начиная с приемки Задачи. Перезвоните мне со служебного телефона .....................

Так какой там корпоративный номер? Пора что-то делать!!

Автор: bereznoy 08.11.12, 22:48

Цитата(Vofka @ 08.11.12, 22:11) *
Как это печально sad.gif . Телепатирую, что ищется в событиях табличного поля... Вам же русским языком написали:

Это событие ФОРМЫ. faceoff.gif


Вообще то я понял, насколько мне стало известно "ОбновлениеОтображения" было в 8.1, в 8.2 уже нет, вот скрин, покажите мне где
русским языком написанно "ОбновлениеОтображения"


Автор: Ardi 08.11.12, 22:58

Цитата(Vofka @ 08.11.12, 23:11) *
ФОРМЫ


Автор: Vofka 08.11.12, 23:01

Танкисты, по танкам! 05061.gif

Автор: bereznoy 08.11.12, 23:12

Цитата(Vofka @ 08.11.12, 23:01) *
Танкисты, по танкам! 05061.gif

44000000.gif мдаааа, теперь увидел

Автор: Vofka 08.11.12, 23:23

Пожалуйста.

Автор: bereznoy 08.11.12, 23:49

Цитата(AnryMc @ 08.11.12, 9:58) *
Форма списка - Событие: ОбновлениеОтображения


Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(СправочникСписок);
Выборка = Построитель.Результат.Выбрать();
колвоДокументов = Выборка.Количество();

ЭлементыФормы.Надпись1.Значение=колвоДокументов;

//!!! Отображает количество "видимых" строк с учетом иерархии.!!!

А если без учета иерархии?

Автор: AnryMc 09.11.12, 10:15

Цитата(bereznoy @ 08.11.12, 23:49) *
А если без учета иерархии?


Можно изваратиться так:

Процедура Кнопка1Нажатие(Элемент)
СтарыйПросмотр1=ЭлементыФормы.СправочникСписок.ИерархическийПросмотр;
СтарыйПросмотр2=ЭлементыФормы.СправочникСписок.ПросмотрГруппИЭлементов;

ЭлементыФормы.СправочникСписок.ИерархическийПросмотр=Ложь;
ЭлементыФормы.СправочникСписок.ПросмотрГруппИЭлементов=ИспользованиеГруппИЭлемен
тов.Элементы;

Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(СправочникСписок);
Выборка = Построитель.Результат.Выбрать();
колвоДокументов = Выборка.Количество();

ЭлементыФормы.Надпись2.Значение=колвоДокументов;

ЭлементыФормы.СправочникСписок.ИерархическийПросмотр=СтарыйПросмотр1;
ЭлементыФормы.СправочникСписок.ПросмотрГруппИЭлементов=СтарыйПросмотр2;
КонецПроцедуры


Но тогда лучше вызывать нажатием кнопки...

Автор: DiamonDUZ 04.01.19, 12:24

Добрый день! Задача точно такая же

только обращение нужно прописать к элементу формы. Плиз у кого это получилось. Можете написать подробно с начала. С добавления реквизита в форму.

Процедура ОбновлениеОтображения()
Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(СправочникСписок);
Выборка = Построитель.Результат.Выбрать();
колвоДокументов = Выборка.Количество();

//обТекущаяСтрока       = ЭтаФорма.ЭлементыФормы.СправочникСписок.ТекущаяСтрока;
//Если Не обТекущаяСтрока.ЭтоГруппа = Истина Тогда
//обТекущаяСтрока.ПП = "1";
//КонецЕсли;
ТекСтрока = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
КонецПроцедуры



ЭлементыФормы.Надпись1.Значение=колвоДокументов;

Украинский 1С форум: всё про 1С 8.3, 1С 8.2, 1С 8.1, 1С 8.0, 1С 7.7
http://pro1c.org.ua