Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 2
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Запрос по ОЛЕ не читает значение "булево" [раздел Программирование в 1С Предприятие 8.3]
Автор Мичман Харитонов — 22.07.19, 10:26 — 7 комментариев
Доброго дня!
Бухгалтерия для Украины 1.2, платформа 8.3.7.1860
Обращаюсь запросом по ОЛЕ к самописной учетной базе, платформа та же.

Запрос
В8 = Новый COMОбъект("V83.Application");
.........
Если Истина Тогда
            ЗапросОЛЕ = В8.NewObject("Запрос");

ТекстЗапроса = "ВЫБРАТЬ
            |        ТоварыНаСкладеОстатки.Номенклатура КАК Номенклатура,
            |        ТоварыНаСкладеОстатки.Номенклатура.Наименование КАК НоменклатураНаименование,
            |        ТоварыНаСкладеОстатки.Номенклатура.КодСТочкой КАК КодСТочкой,
            |        ТоварыНаСкладеОстатки.Склад.КодСклада КАК Склад,
            |        ТоварыНаСкладеОстатки.Склад.Наименование КАК СкладНаименование,
            |        ТоварыНаСкладеОстатки.КоличествоОстаток КАК ОстатокУпр,
            |        ТоварыНаСкладеОстатки.СуммаОстаток КАК СебестоимостьУпр
            |    ИЗ
            |        РегистрНакопления.ТоварыНаСкладе.Остатки("+
            ?(ДатаСравнения = '00010101',"","
            |                &Дата")+", Истина"+
            ?(Склад.Пустая(),""," И Склад.КодСклада  = &КодСклада") + "
            |                И Склад.ВидУчета <> &ВидУчета
            |                И Склад.НеПоказыватьВБухгалтерии = &НеПоказыватьВБухгалтерии
            |                И Фирма.КодОрганизации  = &КодБухОрганизации" +
            ?(Номенклатура.Пустая(),"","
            |                И Номенклатура В Иерархии(&Номенклатура)") + "
            |) КАК ТоварыНаСкладеОстатки" +
            
            ?(Склад.Пустая() или Склад = Справочники.Склады.ТоварыВПути,"
            |
            |ОБЪЕДИНИТЬ ВСЕ
            |
            |ВЫБРАТЬ
            |        ТоварыВПутиОстатки.Номенклатура,
            |        ТоварыВПутиОстатки.Номенклатура.Наименование,
            |        ТоварыВПутиОстатки.Номенклатура.КодСТочкой КАК КодСТочкой,
            |        ""000000000"" КАК Склад,
            |        ""Товары в пути"" КАК СкладНаименование,
            |        ТоварыВПутиОстатки.КоличествоОстаток,
            |        ТоварыВПутиОстатки.СуммаОстаток
            |    ИЗ
            |        РегистрНакопления.ТоварыВПути.Остатки("+
            ?(ДатаСравнения = '00010101',"","
            |                &Дата")+", Фирма.КодОрганизации  = &КодБухОрганизации" +
            ?(Номенклатура.Пустая(),"","
            |                И Номенклатура В Иерархии(&Номенклатура)") + "
            |                И Склад.НеПоказыватьВБухгалтерии = &НеПоказыватьВБухгалтерии
            |) КАК ТоварыВПутиОстатки", "");

            
            ЗапросОЛЕ.Текст = ТекстЗапроса;
            ЗапросОЛЕ.УстановитьПараметр("Дата", ДатаСравнения);
            ЗапросОЛЕ.УстановитьПараметр("КодБухОрганизации", Организация.Код);
            ЗапросОЛЕ.УстановитьПараметр("ВидУчета", В8.Перечисления.ВидыУчета.Торговля);
            ЗапросОЛЕ.УстановитьПараметр("НеПоказыватьВБухгалтерии", ЛОЖЬ);


Спотыкается на булевом значении, Склад.НеПоказыватьВБухгалтерии.
Ошибка
"{Отчет.СравнениеОстатковТоваровБухИУпр.МодульОбъекта(173)}: Ошибка при вызове метода контекста (Выполнить)
Результат = ЗапросОЛЕ.Выполнить();
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.3.7.1860): {(30, 7)}: Поле не найдено "Склад.НеПоказыватьВБухгалтерии"
И <<?>>Склад.НеПоказыватьВБухгалтерии = &НеПоказыватьВБухгалтерии
" Поле точно есть, имя правильное. Что я не так-то делаю?
Просмотров: 58, последний комментарий от Vladal   
Какое решение выбрать для обмена УТП для Украины 1.2.52 с МЕДок? [раздел 1С Управление Торговым Предприятием 8]
Автор Vladal — 22.07.19, 8:40 — 10 комментариев
В наличии УТП для Украины 1.2.52.3, последняя. Для обмена с МЕДок пользовались самописной обработкой выгрузки/загрузки НН и Приложений.

Задача: выбрать типовое решение для обмена XML с МЕДок из нашей УТП и назад.

Хотим перейти на типовой обмен, я в этом не понимаю, но слышал про 1С:Звит, Фризвит, которые работают с типовыми решениями для Украины (или встроены) и делают обмен с МЕДок нативно.

Подскажите, что сейчас актуально.
Просмотров: 80, последний комментарий от ru5   
Видео уроки по 1С Предприятие 8 Управление торговлей для Украины (ред. 2.3) [раздел Обучающее видео]
Автор macho210386 — 20.07.19, 10:14 — 0 комментариев
Плейлист содержит разнообразные уроки по начальному заполнению справочников и констант, ведению складского учета, настройке рабочего места кассира и т.п. Приятного просмотра.
Просмотров: 66, оставить комментарий   
Видео уроки по 1С Предприятие 8 Бухгалтерия для Украины (ред. 2.0) [раздел Обучающее видео]
Автор macho210386 — 20.07.19, 10:06 — 0 комментариев
Плейлист с уроками начиная от первоначальной настройки конфигурации заканчивая выведением финансового результата.
Просмотров: 57, оставить комментарий   
Печатная форма. Порядок строк. [раздел Программирование в 1С Предприятие 8.3]
Автор 1cProger — 18.07.19, 14:31 — 4 комментариев
Здравствуйте.
Недавно начал изучать 1С, тренируюсь в печатной форме. Подскажите, как сделать вывод отдельных элементов не после каждого клиента, а в самом конце?


Клиент1 = "";
    Для Каждого Выборка ИЗ ТЗ Цикл
    Если Клиент1 <> Выборка.Клиент ТОГДА
    СчМин = 0;
    КонецЕсли;
    ОбластьЗаголовок.Параметры.Дата = Формат(ТЗ[0].Дата, "ДЛФ=DD");
    СчМин = СчМин+Выборка.ЗатраченноеВремя;
    ИтоговаяСтрока.Параметры.Всего = СчМин/60;
    Если Клиент1 <> Выборка.Клиент ТОГДА
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьСписокКонцультацийШапка);
    КонецЕсли;
    ОбластьСписокКонцультаций.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(ОбластьСписокКонцультаций);
    ТабДок.Вывести(ИтоговаяСтрока);
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();    
    Клиент1 = Выборка.Клиент;
    КонецЦикла;
Просмотров: 128, последний комментарий от Vofka   
План счетов (ограничение вывода счетов из списка для роли пользователя) [раздел Программирование в 1С Предприятие 8.3]
Автор jojojoba2 — 18.07.19, 13:35 — 1 комментариев
Добрый день.

Подскажите пожалуйста, как можно в ОборотноСальдоваяВедомостьПоСчету(в форме отчета при выборе счета) сделать список из 5-ти нужных счетов(чтобы все счета не выводились) или из общего списка были доступны только 5 и при этом только для определенной роли. Возможно RLS, но если можно пример запроса RLS.
Может есть какие-то стандартные решения(например в конфигураторе заполнить в поле счета ,которые будут видны для опреденной роли).Куда копать?


Спасибо.
Просмотров: 62, последний комментарий от pablo   
Запрос для нахождения номенклатуры которой нету на остатках и не было движения более года [раздел Программирование в 1С Предприятие 8.3]
Автор vladis222 — 18.07.19, 13:25 — 3 комментариев
Здравствуйте, прошу вашей помощи,по заданию,мне необходимо сформировать список товаров(РегистрНакопления ТоварыОрганизаций), которых на заданную дату <=0, то есть либо нет либо отрицательное число. Более того, необходимо чтобы по этим товарам не было движения более 1 года. То есть если для нахождения остатков необходимо воспользоваться виртуальной таблицей Остатки,то для проверки того что не было движения более года - Остатки и Обороты... И все это объединить воедино... Я написал запрос только для части товаров, которых <=0, подскажите,пожалуйста,как дописать запрос...
ВЫБРАТЬ
    Товар.Наименование,
    ТоварыОрганизацийОстатки.КоличествоОстаток
ИЗ
     Справочник.Номенклатура КАК Товар
     ЛЕВОЕ СОЕДИНЕНИЕ
     РегистрНакопления.ТоварыОрганизаций.Остатки КАК ТоварыОрганизацийОстатки
     ПО  Товар.Ссылка = ТоварыОрганизацийОстатки.Номенклатура
     ГДЕ ТоварыОрганизацийОстатки.КоличествоОстаток < 0 ИЛИ ТоварыОрганизацийОстатки.КоличествоОстаток ЕСТЬ NULL



 ! 

Правила: 3, 4
 
Просмотров: 120, последний комментарий от Vladal   
Проблемы с библиотекой стандартных подсистем (БСП) [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор a1994y — 18.07.19, 11:33 — 3 комментариев
Управления торговлей 10.3, платформа 8.2.19 обычные формы.

Проблема в том что из библиотеки стандартных подсистем необходима подсистема (Версионирование) но какую бы я версию БСП не качал, даже старую 2010 года, он добавляет все формы (Управляемые). Может я что то не так делаю или во всех версиях БСП управляемые формы?
Просмотров: 78, последний комментарий от pablo   
CRC-8 для последовательности байтов [раздел Программирование в 1С Предприятие 7.7]
Автор Винила — 18.07.19, 8:13 — 4 комментариев
Добрый день!
1с 7.7. Есть ли у кого пример (обработка), которая подсчитывает контрольную сумму алгоритмом CRC-8 для последовательности байтов. Вот [необходимо зарегистрироваться для просмотра ссылки] пример, в котором полином и начальное значение те, которые мне нужны, но аргумент - число, а мне нужно последовательность байтов.

Спасибо!
Просмотров: 97, последний комментарий от Винила   
Обработка заполнения Расходной Накладной остатками номенклатуры на складе [раздел Программирование в 1С Предприятие 7.7]
Автор Sirius83 — 17.07.19, 10:28 — 2 комментариев
1С 7,7 7.70.27 ABBY Торговля + Склад
Доброго дня,
Прошу помощи:
Ищу Обработку заполнения Расходной Накладной остатками номенклатуры на складе.
Заранее благодарен.
Просмотров: 109, последний комментарий от Винила   
Ошибка изменить форму [раздел Программирование в 1С Предприятие 8.3]
Автор XacTLa — 16.07.19, 21:33 — 1 комментариев
Пытался настроить форму для списка заказов клиентов зашел в все функции далее изменить форму и добавил характеристику и выдало такую ошибку
Неверно заполненная характеристика
по причине:
Неоднозначное имя характеристики. заказ (Заказ клиента)

Как сбросить до стандартного в форму не дает зайти выбрасывает

Платформа: 1С:Предприятие 8.3 (8.3.9.2309)
Конфигурация: 1С:ERP Управление предприятием 2.0 (2.0.9.66)
Просмотров: 61, последний комментарий от XacTLa   
RONGTA RLS 1000 как подключить к 1с? [раздел Работа с торговым оборудованием]
Автор MuxteN — 16.07.19, 19:32 — 0 комментариев
RONGTA RLS 1000 как подключить к 1с? У кого есть готовое решение или драйвер. очень нужна ваша помощь. Прошу помочь.


1С 8.3. Конфигурация УНФ. Управляемые формы.
Просмотров: 82, оставить комментарий   
Данные из регистратора через СКД [раздел Программирование в 1С Предприятие 8.3]
Автор Володька — 16.07.19, 15:05 — 3 комментариев
Добрый день, бьюсь с проблемой, не знаю, как так сделать:
Конфигурация УТ3.1
1. Есть Регистр накопления ТоварыНаСкладах, использую ОстаткиИОбороты.
Получаю таблицу 1
Номенклатура, Регистратор, Начало, Приход, Расход, Конец.
Группировка Номенклатура, Регистратор.
2. Регистраторами этой таблицы выступают очень много документов, но почти у всех (кроме КорректировкиРегистров) есть Табличная часть Товары с полями (Цена или Сумма)
Вопрос, уважаемые знатоки:
Как мне их объединить и получить любое из этих полей (сумма или цена) в таблицу 1?
Просмотров: 149, последний комментарий от fly   
Дождаться закрытия формы и выполнить код в документе открытия этой формы [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 16.07.19, 9:57 — 4 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, БСП, УФ

Из формы одного документа открываем другой документ. После его проведения и закрытия нужно выполнить код документа открытия (модуль формы):

&НаКлиенте
Процедура Контроль(Команда)
    ВвестиДокументКонтроля();
    УстановитьДоступностьПоПравамИСтатусам();

КонецПроцедуры


ВвестиДокументКонтроля(); - создает новый документ, что-то там творят, проводят и закрывают.

УстановитьДоступностьПоПравамИСтатусам(); - обновляет форму, из которой открывался новый документ (открывает/закрывает доступ к элементам формы и т.д.)

Но запуск открытия формы идет не модальный, следовательно вторая процедура срабатывает сразу и не срабатывает так как нужно.

Как дождаться закрытия формы нового документа и перечитать, обновить данные родной формы?
Просмотров: 105, последний комментарий от awp   
при печати заработной платы не пишет сумму [раздел Бухгалтерия 8, редакция 1 для Украины]
Автор na1kon — 15.07.19, 18:00 — 7 комментариев
Всем добрый вечер, столкнулся с проблемой, 1с 8.3, редакция 1.2.51.1, суть в том что при печати Выплаты заработной платы по ведомостям, не печатает сумму текстом, ее конечно можно редактировать в ручную, но в других базах заполняет автоматически... вот на скрине пометил красным
Просмотров: 160, последний комментарий от andreydv87   
Как заполнить Стоку Копии письма в документе "Электронные Письма" [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор alexandr_f — 15.07.19, 11:09 — 2 комментариев
Нужно послать письмо через документ Электронные Письма.
Все есть - только не могу понять формат заполнения Строки Копия (нужно послать в несколько адресов). что-то сохраняется только последний адрес


 ! 

Правила: 4
 
Просмотров: 81, последний комментарий от alexandr_f   
Отбор в запросе по уникальному индентификатору [раздел Программирование в 1С Предприятие 8.3]
Автор Constantus — 15.07.19, 10:45 — 4 комментариев
Приветствую, Форумчане!
1с8.3.12, самопис, БСП, УФ

Создаю массив уникальных индентификаторво "КлючСтроки" из ТЧ

    Для Каждого Ключа Из Объект.Окантовано Цикл
        МассивКлючей = Новый Массив;
        МассивКлючей.Добавить(Ключа.КлючСтроки);
    КонецЦикла;



Имеется некий запрос, где пытаюсь исключить из записей все данные, где есть такиеже КлючиСвязи (УИД)

"ВЫБРАТЬ
    |    ЗаказМодельИКомплектация.Ссылка КАК Заказ,
    |    ЗаказМодельИКомплектация.Номенклатура,
    |    ЗаказМодельИКомплектация.Модель КАК Модель,
    |    ЗаказМодельИКомплектация.РазмерИзделия КАК Размер,
    |    ЗаказМодельИКомплектация.ПолировкаИзделия КАК Полировка,
    |    ЗаказМодельИКомплектация.КлючСтроки
    |ИЗ
    |    Документ.Заказ.МодельИКомплектация КАК ЗаказМодельИКомплектация
    |ГДЕ
    |    ЗаказМодельИКомплектация.Ссылка = &ТТН
    |    И НЕ ЗаказМодельИКомплектация.КлючСтроки В (&ПараметрКлючей)

    Запрос.УстановитьПараметр("ТТН", Объект.ВыбранныйЗаказ);
    Запрос.УстановитьПараметр("ПараметрКлючей", МассивКлючей);


Выдает ошибку, что нельзя сравнивать неограниченную длину и несовместимые типы.

Везде "КлючСтроки" тип одинаковый "УникальныйИдентификатор"

Как правильно провести операцию исключения из запроса с

И НЕ ЗаказМодельИКомплектация.КлючСтроки В (&ПараметрКлючей)


Просмотров: 122, последний комментарий от fly   
Не могу найти работу с опытом [раздел Тематическое общение]
Автор TabletPSC — 14.07.19, 19:40 — 10 комментариев
Добрый день.

Надеюсь не ошибся с разделом.

1. Опишу вкратце мой опыт.
2. Проблемы с которыми столкнулся при поиске нового места работы.


1. Собственно мне 26 лет, попал в 1С через курсы в франч (живу в мегаполисе Украинском), ставка была на около 175 грн за час. Работал на сопровождении. Сдал профа через несколько месяцев после устройства во франач, готовился на специалиста, из-за серьёзной загрузки бросил эту затею. Проработал во франче около 2-ух лет. От меня требовали : взять заявку, прийти, анализ, тз, сделать, оплата от клиента. Иногда привлекал аналитиков или консультантов на проект. В основном пачками задачи по сопровождению конфигураций БП, УТ, УТП, УПП, Розница, ЗУП, КА и их аналоги на упр формах примерно 50% обычные 50% упр. Из внедрений которые доверили это было отраслевая БП с большими различиями(доработки) по З,П., Розница в местный ресторан. УТ + интеграции с разными web сервисами типа Битрикс в местный магазин.

Ушел с франча, в связи с тем, что вектор задач был не в 1 области, очень обширный + "От меня требовали : взять заявку, прийти, анализ, тз, сделать, оплата от клиента.", а в этой цепочке могли случится трудности (на последнем этапе) и денег я своих и не видел по несколько месяцев.

Устроился в контору которая занималась EDI по России.
Было несколько решений на основе 1С и их интеграций в клиентские конфы. Моя задача состояла (и других ребят) разработка нового функционала, поддержка текущий решений внедренных и внедрение новых. Так после 7 месяцев, удалось поработать ведущим программистом, т.к. резко упал круг областей знаний по сравнению с франчом, удлось очень быстро освоится.

Помимо знакомства с большинством упр/обыч формы российскими конфами, ежедневно работал с xml/json/web сервисами/sql.
Из знакового: делал серьёзный рефракторинг решений, углублялся в быстроедествие того или иного участков кода. Так же удалось поруководить, придумать архитектуру, и в том числе и разрабатывать вместе командой(около 5 человек + 3 консультанта) решения работе с (Меркурием)

Ушел на втором году работы, сменилось начальство и был ад.

Дальше попал в производственную контору.

УНф+производственный модуль отраслевой + УПП + БП + ЗУП. Сопровождал в месте с еще 1 человеком + 1 аналитик + 1 аутсорс.

Из знакового : был хаос на складах, разработал систему под ячеечное хранение. Успешно внедрил, пользуются. Интеграции с telegram, трекинг заказов. Почтовые сервисы(украина/россия/казахстан) тоже интеграции. Интеграции с google docs.

Попросил меня уйти через время(причина была рандномная)

Собственно опыта у меня набралось около 4-5 лет.

2. Вышел на рынок, разместил резюме, полились звонки.

Я в принципе не привередлив, уживаюсь нормально с коллективом. К разного рода переработкам отношусь спокойно. Не опаздываю. Т.е. меня устраивают в большинстве случаев почти все предложения в вакансиях кроме з.п.

Примерно как проходит собеседование с очередным откликом ( моим или их):
Тестовое по их желанию делаю, вопросов возникало в 2% случаев и то на месте решались.
Опыт работодателя обычно устраивает, часто упоминают об этом в процессе разговора.
В конце(или начале) обычно говорим о з.п., процентов 95 это вопросы их по типу "Сколько вы бы хотели?". Я отвечал все подряд, все перепробовал. В основном я ссылаюсь на ставки во франчах(знакомые) и аутсорс(есть опыт периодеческий) и множу их на 160 или 120 рабочих часов. Ставки разные, мало ребят знаю с опытом которые работают ниже 300, да и сам брал периодически от старых клиентов от 300 до 500 за час в зависимости, что там за работа.

За последние 4 месяца, я видел около 2-3 откликов которые хоть как-то коррелируються с моими мыслями. В основном это в 2 даже в 3 раза ниже того, на, что я примерно думал (выше).

Хотелось бы ваших советов.
Что так все плачевно на фирмах?
Может я перегибаю и цифры действительно ниже в 2-3 раза?
Может есть какие-то мысли или какой был у вас опыт с устройством на работу и ожидаемые/реальные доходы.

p.s. +- на том же аутсорсе мне на жизнь хватает. Я просто ищу параллельно, что-то своё.
Просмотров: 277, последний комментарий от awp   
Выгрузить категорию на сайт [раздел Программирование в 1С Предприятие 8.3]
Автор burza — 12.07.19, 13:42 — 1 комментариев
нужно выгрузить на сайт категории с родителями, только не стоковые а я сделал сам где по иерархии будет лежать товар на сайте. нужно выгрузить свои категории на сайт а не те которые есть в объекта номенклатуры.
То есть в 1С своя иерархия а на сайте другая.


где тут это подправить?

Процедура ПутьКатегории(ТекОбъект, ВерхнийКод)
    ТекУровень = ТекОбъект.Уровень();
    Если ТекУровень > УровеньКорневойКатегории Тогда
        ПутьКатегории(ТекОбъект.Родитель, ВерхнийКод);
    КонецЕсли;
    CategoryPath(ВерхнийКод, СокрЛП(ЗаменитьПрефиксы(ТекОбъект.Код)), Строка(ТекУровень - УровеньКорневойКатегории));
КонецПроцедуры

//******************************************************************************
// Рекурсивная процедура заполнения описания категорий
Процедура КатегорииТовара(ТекОбъект, ВерхнийКод, ВерхнийУровень)
    
    ТекУровень = ТекОбъект.Уровень();
    Если ТекУровень > УровеньКорневойКатегории Тогда      
        КатегорииТовара(ТекОбъект.Родитель, ВерхнийКод, ВерхнийУровень);
        КодРодителя = СокрЛП(ЗаменитьПрефиксы(ТекОбъект.Родитель.Код));
        Топ = "0";
    Иначе
        КодРодителя = "0";
        Топ = "1";
    КонецЕсли;     
    Если ТекУровень < ВерхнийУровень Тогда
        ТекКод    = СокрЛП(ЗаменитьПрефиксы(ТекОбъект.Код));
        ТекИмя    = СокрЛП(ТекОбъект.Наименование);
        Описание  = СокрЛП(ТекОбъект.Описание);
        ИмяЧПУ = СокрЛП(?(Транслитерация, Транслит(ТекИмя), ТекИмя));
        ИмяЧПУ = СтрЗаменить(СтрЗаменить(СтрЗаменить(ИмяЧПУ, " ", "-"), "+", "_"), "&", "_");
        ЧислоСтолбцов = 1;
        meta_title = "";
        meta_description = "";
        meta_keyword = "";
        seo_title =  "";
        seo_h1 =  "";    
        Category(ТекКод,
                    КодРодителя,
                    ТекИмя,
                    ИмяЧПУ,
                    СокрЛП(Описание),
                    Топ,
                    Строка(ТекущаяДата()),
                    ФорматДВ,
                    ЧислоСтолбцов,
                    meta_title,
                    meta_description,
                    meta_keyword,
                    seo_title,
                    seo_h1,
                    ?(Перезаписывать, "0", "1")
                    );                    
        Product2Category(ВерхнийКод, ТекКод, Топ);
        ПутьКатегории(ТекОбъект, ТекКод);
    КонецЕсли;    
КонецПроцедуры
Просмотров: 124, последний комментарий от burza   
Событие отмены в списке значений [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 12.07.19, 10:11 — 6 комментариев
Всем привет!
Гууу ... Не на что уже нет настроения... Просто нет ... все ПУСТО ВОКРУГ.
Ладно пардон ... не обращайте внимание ...
Вот код простого типа:
спЗначений = Новый СписокЗначений();
спЗначений.Добавить("Значение1","Представление1");
спЗначений.Добавить("Значение2","Представление2");
ВыбранныйЭлементСписка = спЗначений .ВыбратьЭлемент();
Если ВыбранныйЭлементСписка = Неопределено Тогда  Возврат; КонецЕсли;

Но это когда без флажков. Т.е. когда нужно сделать один единственный выбор.
Теперь код для множественного выбора в списке.
//==========================    
    ствПеречень=Новый Соответствие();
    ствПеречень.Вставить("Значение1","Представление1");
    ствПеречень.Вставить("Значение2","Представление2");
    ствПеречень.Вставить("Значение3","Представление3");
    ствПеречень.Вставить("Значение4","Представление4");
//-----------------------------------------------    
    ствВыбрНеВыбрЗначения=Новый Соответствие();
    спЗначений = Новый СписокЗначений();
    Для Каждого Эл Из ствПеречень Цикл
        спЗначений.Добавить(Эл.Ключ,Эл.Значение);
    КонецЦикла;
    спЗначений.ЗаполнитьПометки(Истина);  
//-----------------------------------------------
    Если спЗначений.ОтметитьЭлементы("Выводить") Тогда
        Для Каждого знВыбор Из спЗначений Цикл
            Если знВыбор.Пометка Тогда
                ствВыбрНеВыбрЗначения.Вставить(знВыбор.Значение,Истина);
            Иначе
                ствВыбрНеВыбрЗначения.Вставить(знВыбор.Значение,Ложь);
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
//==========================    
Если Вопрос("Создать отчет данных энергосистемы в формате Excel?",РежимДиалогаВопрос.ДаНет,,,"Отчет в формате Эксель")=КодВозвратаДиалога.Нет Тогда Возврат; КонецЕсли;

Короче что надо ... опять очередная ерунда. .. с которой уже сижу час и опять ищу методом тыка.
Во втором варианте кода нужно зафиксировать событие когда пользователь нажал на кнопку отменить.
В первом простом варианте это как указано делается таким путем:
Если ВыбранныйЭлементСписка = Неопределено Тогда  Возврат; КонецЕсли;

Нужно то же самое только для второго варианта ... т.е. для списка значений с множественным выбором.
Ибо согласно выше указанного кода диалог вопроса:
Если Вопрос("Создать отчет данных энергосистемы в формате Excel?",РежимДиалогаВопрос.ДаНет,,,"Отчет в формате Эксель")=КодВозвратаДиалога.Нет Тогда Возврат; КонецЕсли;

в любом случае всплывает. Даже в случае если пользователь в окне списка значений нажал на кнопку отменить.
А нужно что бы действие переходило на следующую линию кода только тогда когда нажали на кнопку "Ок". А когда нажали на "Отменить" нужно что бы действие останавливалось.
Вот что нужно...
И вот эта вот ерунда. С которой уже сижу час.
Так что если можно строчу кода в помощь.
Буду признателен!

Gigi @ Сегодня, 10:31 * ,
Вы куда все подевались уважаемые? ))
Гууу... я вроде просил строчку кода. Всего одну строчку ..
Не думаю что больше нужно будет. Хотя от этой системы всего можно ожидать. Потому что в ней наверно "сложное всегда просто", как и все гениальное )).. а не наоборот.
Короче вопрос открыт..
Жду вашего отклика!
И буду признателен!

Просмотров: 178, последний комментарий от Gigi   
RSS Текстовая версия Сейчас: 22.07.19, 18:25
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!