Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 4, свеженьких 1
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )


Свернуть

> Добро пожаловать на наш форум

Здравствуйте уважаемый посетитель. К сожалению вы не были распознаны форумом как зарегистрированный пользователь. Для полноценного использования возможностей нашего форума вам необходимо зарегистрироваться. Если вы уже зарегистрированы на форуме, то вам необходимо пройти авторизацию, используя Ваш логин и пароль.

Логин:   
Пароль:
 

Форум:

Новые темы (за 20 дней):

Последние сообщения:

Наши сервисы:

Дополнительно:

Новости для бухгалтера:

 
Что лучше изучать 8.2 (обычный интерфейс) или 8.3 С УП интерфесом? [раздел Вся 1С]
Автор kvital — 25.06.18, 17:31 — 0 комментариев
Что лучше изучать 8.2 (обычный интерфейс) или 8.3 С УП интерфесом?
Просмотров: 15, оставить комментарий   
События обычных форм объектов, работа с модулем формы [раздел Вся 1С]
Автор kvital — 25.06.18, 17:28 — 0 комментариев
Где можно найти литературу События обычных форм объектов, работа с модулем формы? Или уроки.

Или изучать только управляющее 8.3 ??? Незнаю что делать.
Просмотров: 13, оставить комментарий   
Этикетка товара [раздел Программирование в 1С Предприятие 8.3]
Автор XacTLa — 25.06.18, 15:32 — 0 комментариев
1С:Предприятие 8.3 (8.3.9.2309)
1С:ERP Управление предприятием 2.0 (2.0.9.66)

Не могу понять как мне создать этикетку с назначением товара, а именно что бы был номер заказа на этикетке при печати. Что бы информацию брать с назначения товара с производства. Уже все облазил не могу понять как.
Просмотров: 24, оставить комментарий   
Программно отправить сообщение на почту через внешнюю обработку. Версия платформы: 8.3.10.2667, версия конфигуратора: 2.4.1.206 [раздел Программирование в 1С Предприятие 8.3]
Автор @lex — 25.06.18, 13:52 — 1 комментариев
Добрый день, подскажите, пожалуйста, как отправить сообщение на почту программно из внешней обработки?
Процедура ОтправитьНаСервере()

    ПараметрыПочты = новый ИнтернетПочтовыйПрофиль;
    ПараметрыПочты.АдресСервераSMTP = "smtp.mail.ru";
    ПараметрыПочты.ПортSMTP = 465;
    ПараметрыПочты.АутентификацияSMTP = СпособSMTPАутентификации.БезАутентификации;
    ПараметрыПочты.ПользовательSMTP = emailОтправителя;
    ПараметрыПочты.ПарольSMTP = парольОтправителя;
    Письмо=новый ИнтернетПочтовоеСообщение;
    Письмо.Получатели.Добавить(emailПолучателя);
    Письмо.Тексты.Добавить("тест", ТипТекстаПочтовогоСообщения.HTML);
    Подключение=новый ИнтернетПочта;
    Попытка
        Подключение.Подключиться(ПараметрыПочты);
        Подключение.Послать(Письмо);
        Сообщить ("Письмо отправлено успешно.");
    Исключение
        Сообщить ("Письмо не отправлено." + ОписаниеОшибки());
    КонецПопытки;
КонецПроцедуры


Выдает ошибку {ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(23)}: Ошибка при вызове метода контекста (Подключиться): Произошла ошибка при работе с SMTP. Код ошибки: 25 (Отказ в установлении соединения со стороны сервера.
Подскажите, что не так в коде?
Просмотров: 34, последний комментарий от Bernet   
С помощью ЗагрузкаДанныхИзТабличногоДокумента необходимо загрузить номенклатуру товаров. [раздел 1С Управление Торговым Предприятием 8]
Автор Константин Кирков — 25.06.18, 13:19 — 5 комментариев
1С:Предприятие 8.3 (8.3.10.2252)
"Управление торговым предприятием для Украины", редакция 1.2.

Скачал обработку ЗагрузкаДанныхИзТабличногоДокумента.epf для управляемых форм (8.2 и 8.3) вот отсюда: [необходимо зарегистрироваться для просмотра ссылки]

Попытался ее открыть из 1с:Предприятие, но не открылся файл. Я тогда зашел в Конфигуратор и там открылся.
Но, что дальше делать, сообразить не могу.

Просмотров: 67, последний комментарий от Константин Кирков   
Как отобразить указанный динамический список во вкладке(странице) общей формы [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 25.06.18, 9:07 — 10 комментариев
Всем привет!
Хотел спросить Вас можно ли сделать как шас изложу или нет.
Знаю что по моему 1С не позволяет это сделать... что очень жаль. Потому, что не охота делать двойную работу.
Но решил уточнить... мало ли может это возможно.
Короче в чем суть...
Дело в том, что я в метаданных создал документ ... ну на пример с именем: "ПОЛЕЗНЫЙ_ОТПУСК_Акты"
И кроме ФормыДокумента еще добавил ФормуСписка. А в форме списка в командной строке предусмотрел разные кнопки по выводу разных отчетов. Почти всех относительно данного объекта. И этих отчетов (кнопок) не мало. Потребовалось даже создавать дополнительную командную строку с кнопками. Но это один вопрос.
Теперь другой ... главный ... чего и касается тема
Дело в том, кроме этого списка есть другие аналогичные созданные формы списка тоже с многочисленными кнопками.
Что нужно?
Нужно все эти списки разместить на рабочий стол. И тут продлена в том, что когда ты в платформе делаешь следующее: Конфигурация/Открыть рабочую область начальной страницы. Там вроде можно указанные формы списков отобразить, но недостаток в том, что ОЧЕНЬ УЗКИЕ ВОЗМОЖНОСТИ. И они в том, таким путем как там можно отобразить только два или максимум три списка. А если решить больше то получиться визуальная сумятица. Поэтому в таком случае нужно в формате вкладок т.е. распределить разные списки по страницам формы. Ну как на любой форме (Страницы/Страница). Но так в Рабочей области начальной страницы не предусмотрено.
Поэтому тогда другой путь. Создать общую форму и там делать что угодно. Но тут (где уже теперь подходу к выше указанной теме) уже другая проблема. Проблема не возможности отобразить в странице формы указанный список формы. Т.е. сделать то же самое что в Рабочей области начальной страницы только все это внутри одной из страниц(вкладок) общей формы. Т.е. в общей форме, так же как и в любой другой вообще списки можно отобразить создав реквизит, потом присвоив типу "ДинамическийСписок" потом выбрав объект и скопировав реквизит в страницу формы. На сколько я знаю только так. А меня так не устраивает.
Поэтому можно ли в страницу формы вставить не просто динамический список, а указанную ФормуСписка?
Как в случае с Рабочей областью начальной страницы?
Вот собственно и вопрос?
Буду признателен!
Просмотров: 178, последний комментарий от Gigi   
С/С в мясном производстве [раздел 1С Управление небольшой фирмой для Украины]
Автор ddzhafarow — 24.06.18, 10:02 — 0 комментариев
Добрый день. Уже около недели пробую решить проблему - безрезультатно. Поэтому решил обратиться к Вам, уважаемые форумчане.

ВОПРОС №1
Столкнулся со следующей проблемой:
При процессе обваливания полутуши (разборка), мы получаем мясо и субпродукты (жир, жилка).
Пример:
Вход
Полутуша 100 кг (10000 у.е.)
Выход
Мясо 70 кг
Жир 10 кг
Жилка 20 кг

Цена продажи на рынке:
Жир: 50 у.е./кг
Жилка: 60 у.е./кг

Как в реальности мы считаем с/с мяса:
1. Считаем вероятную сумму продажи субпродуктов: 50*10 + 60*20 = 1700 у.е.
2. Отнимаем эту сумму от входящего сырья: 10000-1700 = 8300 у.е.
3. Делим остаток на кол-во мяса: 8300/70 = 118,6 у.е./кг

Как это возможно реализовать в унф?


ВОПРОС №2
На производстве 2 процесса:
1. Забой скота
2. Обвалка мяса

Есть косвенная затрата (Ножи обвалки), но она относиться только к обвалке.
С обвалки выходит 3 продукта, как это описано в ВОПРОСЕ №1: Мясо, жир жилка. Входит на обвалку полуфабрикат "полутуша"

Внимание вопрос:
Как сделать так, что Затрата легла на себестоимость только обвалки и только на себестоимость мяса?

Я это сделал так:
1. Создал счет прямых затрат: Затраты на полутуши.
2. В номенклатуре "Полутуши" учет затрат привязал ко счету Затраты на полутуши
3. Создал счет прямых затрат: Инвентарь обвалки. Метод распределения: По прямым затратам на себестоимость продукции с фильтром по счету Затраты на полутуши
4. Создал номенклатуру Ножи обвалки и подвязал их ко счету Инвентарь обвалки

Моим способом я достигаю того, что эти затраты ложатся только на обвалку, но они ложатся как на мясо, так и на жир, так и на жилку.
Как быть в данной ситуации

Буду благодарен любым советам!)
Спасибо
Просмотров: 63, оставить комментарий   
Проблема вигрузки залишків номенклатури з регістру. [раздел Программирование в 1С Предприятие 7.7]
Автор Sirius83 — 23.06.18, 22:12 — 2 комментариев
Конфігурація бухгалтерия+торговля+производство+зарплата+кадры+Cash&Carry+розница+(торговля)+урб support, присутній як бухгалтерський облік так і оперативний, документи по оперативному і бух. обліку при проведенні записують дані в Регистр.Остатки. Задача вигрузити в текстовий файл згруповані залишки ТМЦ на кожну дату в періоді.
написав таке:

Код
Процедура Сформировать()
    КаталогВыгрузкиФайлы = КаталогВыгрузки + "\CSVFiles";
    Текст = СоздатьОбъект("Текст");
    Текст.ДобавитьСтроку("ProductID;Data;Qty;Summ");
    ДатаТек = ДатаНачало;
    
        Запр = СоздатьОбъект("Запрос");
                
        ТекстЗапр = "
    
        |Период с ДатаНачало по ВыбКонПериода;
        |ТМЦ = Регистр.Остатки.ТМЦ;
        |Кво = Регистр.Остатки.Кво;
        |СуммаОсн = Регистр.Остатки.СуммаОсн;
        |Условие (ТМЦ в выбТМЦ);
        |Группировка ТМЦ;
        |Функция ККво = КонОст(Кво);
        |Функция КСуммаОсн = КонОст(СуммаОсн);";

        
        Если Запр.Выполнить(ТекстЗапр)=0 Тогда
            Возврат;
        КонецЕсли;
        
        Пока ДатаТек <= ВыбКонПериода Цикл
            
            Пока Запр.Группировка("ТМЦ")=1 Цикл
                Если Запр.ТМЦ.Выбран()=0 Тогда
                    Продолжить;
                КонецЕсли;
                Если Запр.ТМЦ.ЭтоГруппа()=1 Тогда
                    Продолжить;
                Иначе
                    Текст.ДобавитьСтроку(СокрЛП(Запр.ТМЦ.Код) + ";" + ПреобразоватьДату(ДатаТек) + ";" + ОбработкаСтроки(СокрЛП(Запр.ККво)) + ";" +  СтрЗаменить(СокрЛП(Запр.КСуммаОсн), ",", "."));
                КонецЕсли;
            КонецЦикла;
            ДатаТек = ДатаТек + 1;
        КонецЦикла;
    
    Текст.ДобавитьСтроку("");
    Текст.Записать(КаталогВыгрузкиФайлы + "\Stocks.csv");

КонецПроцедуры


Результат на кожну дату один й той самий результат, та ще й відрізняється від реального.
Будь-ласка допоможіть, (сильно не сваріть, ятільки вчуся)
Просмотров: 85, последний комментарий от Sirius83   
Как можно через форму справочника, при выборе из другого справочника-подтянуть всю строку с реквизитами [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kvital — 22.06.18, 18:02 — 5 комментариев
Как можно через форму справочника, при выборе из другого справочника-подтянуть всю строку с реквизитами.В одном справочнике есть реквезиты и в другом.
Просмотров: 147, последний комментарий от Prospero   
1C 8.3 УНФ не запускается база с загруженной конфигурации [раздел 1С Управление небольшой фирмой для Украины]
Автор hawkk — 22.06.18, 9:36 — 0 комментариев
Здравствуйте! Прошу помощи.

Собственно досталась конфигурация УНФ, в самой конфигурации дописано время работы пользователя.
После загрузки конфигурации и запуске базы ругается, что нет пользователя в справочнике. Как запустить базу?

Сама ошибка:

Цитата
Платформа: 1С:Предприятие 8.3 (8.3.10.2299)
Конфигурация: Управление небольшой фирмой для Украины, редакция 1.6
Локализация для Украины: ООО "" (1.6.2.2) (http://1c.ua/v8/RegionalSolutions_UA_UNF.php)
Copyright © ДП "Еврософтпром", 2011-2016. Все права защищены
(http://www.1c.ua)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент
Локализация: Информационная база: русский (Украина), Сеанс: русский
Вариант интерфейса: Такси

Ошибки:
--------------------------------------------------------------------------------
22.06.2018 10:34:56
{Обработка.Чат.Форма.Форма.Форма(150)}: Ошибка при получении значения атрибута контекста (ТекущийПользователь)
Запрос.УстановитьПараметр("Получатель", ПараметрыСеанса.ТекущийПользователь);
по причине:
{ОбщийМодуль.ПользователиСлужебный.Модуль(293)}: Авторизация не выполнена. Работа системы будет завершена.
Пользователь: Админ не найден в справочнике "Пользователи".

При попытке добавления пользователя в справочник возникла ошибка:
"Недопустимое обращение к необновленным параметрам работы программы
(например, к некоторым параметрам сеанса):
- если это обращение выполняется из формы на начальной странице
(рабочем столе), то необходимо убедиться, что в ней имеется вызов
процедуры ОбщегоНазначения.ПриСозданииНаСервере;
- в остальных случаях необходимо перенести вызов прикладного кода
после обновления параметров работы программы.".

Обратитесь к администратору.
ВызватьИсключение СтрШаблон(
Просмотров: 81, оставить комментарий   
Справочник (иерархия элементов): форма списка раскрывать дерево субэлементы при нажатии мыши [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 22.06.18, 9:49 — 0 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Изменил форму списка справочника статьи движения ДС, добавив слева деревозначений для навигации по списку. Все вроде работает, но есть неудобство: справа дерево раскрывается только при двойном клике на элементе слева.

Есть аналогичные справочники ("Подразделения"), там при нажатии на элемент на Дереве сразу раскрывается весь список суб-подразделений.

Сравнил обе формы, вроде все индентично. Где я не дотянул?

Разобрался. Нужно было в основном окне выбрать в связях по родителю
СправочникДерево.ПриАктивизацииСтроки
Просмотров: 67, оставить комментарий   
Как правильно перенести документы [раздел Программирование в 1С Предприятие 8.3]
Автор Володька — 22.06.18, 8:53 — 3 комментариев
Ситуация банальна, после последнего бэкапа есть работа пользователей, как перенести эту работу в бэкап?
Что для этого делают гуру?

1С БП 2.0, Файловая база.
Просмотров: 89, последний комментарий от Bernet   
Как из четырех справочников, сделать такую форму как на картинке [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор kvital — 21.06.18, 15:05 — 2 комментариев

1С:Предприятие 8.3 (8.3.11.2867)(В режиме совместимости 8.2 обычные формы)
Добрый день. Читаю книгу Максим Радченко- 1С:Программирование для начинающих ..... Разработка в системе "1С:Предприятие 8.3".
Там даётся в УП (управляющей форме Дневник). Попробовал в примитивном виде сделать на обычном приложение, невыходит.
Сейчас хожу на курсы 1С, хотел уточнить у предподавателя - вопрос остался без ответа. Хотя весь курс по работе с обычным приложением.
Итого: вопрос как можно по минимому написать программу дневник. Применяя в работе в основном Реквизит и Формы-Списка?
Или есть другие варианты?
Просмотров: 119, последний комментарий от kvital   
Справочник (иерархия элементов): определить есть ли у элемента подчиненные элементы [раздел Программирование обычных форм 1С 8.2 и не интерфейсной логики]
Автор Constantus — 21.06.18, 14:41 — 2 комментариев
Приветствую, форумчане!
"Управление торговлей 10.3", (Моби-С 5.5). "ABBYY Ukraine", 2003-2014 (2.3.20.1)

Имеется справочник "Статьи движения ДС" (иерархия элементов)

Стоит такая задача: при выборе элемента этого справочника сделать проверку на наличие у этого элемента подчиненных элементов, если есть то выдать сообщение, что такой элемент выбирать нельзя. Ессли элемент без подчиненных, то пожалуйста...

    Если СтрокаПлатеж.СтатьяДвиженияДенежныхСредств.Родитель = Неопределено Тогда
        Сообщить("Низзяяяя");
        Возврат;
    КонецЕсли;


Этот номер естественно не прошел.
Просмотров: 90, последний комментарий от Bernet   
Как добавить команду в контекстное меню для реквизита табличной части в 1с 8 [раздел Программирование в 1С Предприятие 8.3]
Автор Gigi — 21.06.18, 13:10 — 0 комментариев
Всем привет!
Никто не подскажет как сделать то о чем наименование темы.
Сделал как указано [необходимо зарегистрироваться для просмотра ссылки], но все равно НИКАКОГО ЭФФЕКТА!
Выставил контекстное меню реквизита ТЧ; добавил туда кнопку; снял галку с "Автозапонение".
Ничего не изменилось. Открыв 1С предприятие контекстное меню отображает обычные стандартные команды.
Никто не подскажет почему так и как сделать...
Буду признателен!

Gigi @ Сегодня, 13:58 * ,
smile.gifsmile.gif Пардон!
Уже разобрался!
Там просто контекстное меню не самой ТЧ в целом, а только одного реквизита ТЧ.
Поэтому нужно было смотреть контекстное меню в режиме редактирования поля.
Ладно! Все ясно ... Ерунда...
Приношу извинения!
пока!
Просмотров: 440, оставить комментарий   
Использование планировщика [раздел Программирование в 1С Предприятие 8.3]
Автор Orion-PS — 20.06.18, 20:35 — 3 комментариев
Добрый день!
Кто пользовался планировщиком в 1С, подскажите, пожалуйста, где нужно вводить начальные настройки планировщика?
Просмотров: 120, последний комментарий от Bernet   
В конфигураторе "Ввод на основании" не определяет одно поле [раздел Программирование в 1С Предприятие 8.3]
Автор Andrian — 20.06.18, 12:39 — 2 комментариев
Всем привет, хочу попросить помощи
В общем, есть в дереве конфигурации документа СчетНаОплату вкладка "Ввод на основании", все бы хорошо, но у меня все поля заполняются из документа в документ, кроме стандартного реквизита "Номер", а он капец как нужен!
Просмотров: 115, последний комментарий от Andrian   
В Звіт про роздрібні продажі не поппадають чеки [раздел 1С Управление небольшой фирмой для Украины]
Автор Юля — 20.06.18, 11:26 — 15 комментариев
Привіт, і знову проблема з УНФ (1.6.5.2), При закритті зміни в звіт про роздрібні продажі не потрапляють чеки зи зміну, звіт архівується , але пустий , таке буває досить часто, зміна закривається без чеків. Хочемо заповнити вручну, тобто відкриваємо потрбний звіт про роз.продажі, там є функція заповнити по продажам за зміну, але він не заповнюється, дата автоматично міняється на поточну і все. Вручну забивати всі чеки не реально? допоможіть(
Просмотров: 222, последний комментарий от Bernet   
Помогите исправить ошибку [раздел Программирование в 1С Предприятие 8.3]
Автор kanibal23 — 19.06.18, 14:58 — 2 комментариев
есть процедура СписокПриАктивизацииСтроки

Она формирует мини отчет
строка повібору

&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
    ТекСтрока = Элементы.Список.ТекущаяСтрока;    
    Если ТекСтрока = Неопределено   Тогда         
        Возврат;
    Иначе
        СписокПриАктивизацииСтрокиНаСервере(ТабДок, ТекСтрока);
    КонецЕсли;    
КонецПроцедуры


И сам код для отчета заполнения ТабДок

&НаСервереБезКонтекста
Процедура СписокПриАктивизацииСтрокиНаСервере(ТабДок, ТекСтрока)
    
    Макет = ПолучитьОбщийМакет("ДляУчетаМостерской");
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ДокументПриёмОборудования.Номер,
        |    ДокументПриёмОборудования.Дата,
        |    ДокументПриёмОборудования.Сотрудник,
        |    ДокументПриёмОборудования.Инв,
        |    ДокументПриёмОборудования.Подразделение,
        |    ДокументПриёмОборудования.МастерскиеСклады,
        |    ДокументПриёмОборудования.Модель,
        |    ДокументПриёмОборудования.НормерЗадачи,
        |    ПриёмОборудования1.ПриОсмотреВыевленоЧчто,
        |    ПроксимаCсервис.ПроведёныеРаботы КАК ПричинаОтправкиВнРем,
        |    Резерв.ПроведёныеРаботы,
        |    РезервСписания.ПроведёныеРаботы КАК ПричинаСписания,
        |    ДокументПриёмОборудования.Подразделение.ПовнаНазва,
        |    ДокументПриёмОборудования.Паломка,
        |    ДокументПриёмОборудования.Керівник,
        |    ДокументПриёмОборудования.Пользователь,
        |    ДокументПриёмОборудования.Телефон1,
        |    ДокументПриёмОборудования.Телефон2,
        |    ДокументПриёмОборудования.Телефон,
        |    Резерв.КомуРезерв,
        |    Резерв.Ссылка,
        |    ДокументПриёмОборудования.МОЛ,
        |    Резерв.Дата КАК ДатаГотовности,
        |    ПриёмОборудования1.Ссылка КАК СсылкаВыевл,
        |    ПроксимаCсервис.Ссылка КАК СсылкаСервис,
        |    Резерв.Ссылка КАК СсылкаГот,
        |    РезервСписания.Ссылка КАК СсылкаСпис,
        |    РезервСписания.Дата КАК Дата1,
        |    ДокументПриёмОборудования.Помещение,
        |    ДокументПриёмОборудования.Корпус
        |ИЗ
        |    Документ.ПриёмОборудования КАК ДокументПриёмОборудования
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПриёмОборудования1 КАК ПриёмОборудования1
        |        ПО ДокументПриёмОборудования.Номер = ПриёмОборудования1.НомерРасписки
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.Резерв КАК Резерв
        |        ПО ДокументПриёмОборудования.Номер = Резерв.НомерРасписки
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.РезервСписания КАК РезервСписания
        |        ПО ДокументПриёмОборудования.Номер = РезервСписания.НомерРасписки
        |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПроксимаCсервис КАК ПроксимаCсервис
        |        ПО ДокументПриёмОборудования.Номер = ПроксимаCсервис.НомерРасписки
        |ГДЕ
        |    ДокументПриёмОборудования.Ссылка = &Ссылка
        |
        |СГРУППИРОВАТЬ ПО
        |    ДокументПриёмОборудования.Номер,
        |    ДокументПриёмОборудования.Дата,
        |    ДокументПриёмОборудования.Сотрудник,
        |    ДокументПриёмОборудования.Инв,
        |    ДокументПриёмОборудования.Подразделение,
        |    ДокументПриёмОборудования.МастерскиеСклады,
        |    ДокументПриёмОборудования.Модель,
        |    ДокументПриёмОборудования.НормерЗадачи,
        |    ПриёмОборудования1.ПриОсмотреВыевленоЧчто,
        |    ПроксимаCсервис.ПроведёныеРаботы,
        |    Резерв.ПроведёныеРаботы,
        |    РезервСписания.ПроведёныеРаботы,
        |    ДокументПриёмОборудования.Паломка,
        |    ДокументПриёмОборудования.Керівник,
        |    ДокументПриёмОборудования.Пользователь,
        |    ДокументПриёмОборудования.Телефон1,
        |    ДокументПриёмОборудования.Телефон2,
        |    ДокументПриёмОборудования.Телефон,
        |    ДокументПриёмОборудования.Подразделение.ПовнаНазва,
        |    Резерв.КомуРезерв,
        |    Резерв.Ссылка,
        |    ДокументПриёмОборудования.МОЛ,
        |    Резерв.Дата,
        |    ПриёмОборудования1.Ссылка,
        |    ПроксимаCсервис.Ссылка,
        |    РезервСписания.Ссылка,
        |    Резерв.Ссылка,
        |    РезервСписания.Дата,
        |    ДокументПриёмОборудования.Помещение,
        |    ДокументПриёмОборудования.Корпус";
    
    Запрос.УстановитьПараметр("Ссылка", ТекСтрока);
    
    РезультатЗапроса = Запрос.Выполнить();
    

    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    
    ТабДок.Очистить();
    ТабДок.НачатьАвтогруппировкуСтрок();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
        ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
    КонецЦикла;
    
    ТабДок.ЗакончитьАвтогруппировкуСтрок();

КонецПроцедуры


Работает почти как часики но загвоздка в том что если в списке стоит группировка и при выборе строки группировки выдоит ошибку

{ОбщаяФорма.УчетМастерской.Форма(128)}: Ошибка при вызове метода контекста (Выполнить)
РезультатЗапроса = Запрос.Выполнить();
по причине:
{(43, 35)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
неограниченной длины и поля несовместимых типов.
ДокументПриёмОборудования.Ссылка <<?>>= &Ссылка

как и где что добавить что б этой ошибки не было что бы оно не обращало внимание на строку группировки
Просмотров: 109, последний комментарий от kanibal23   
как передать переменную с клиента на сервер [раздел Программирование в 1С Предприятие 8.3]
Автор lolmatrix — 19.06.18, 14:33 — 1 комментариев
Здравствуй, уважаемые специалисты, помогите пожалуйста новичку, НаКлиенте получаю переменную , ее надо передать наСервер, как можно это сделать ,
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.СписокЗЧ.ТекущиеДанные;
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    Запчасть = СтрокаТЧ.Наименование;

Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";

    Запрос.УстановитьПараметр("Запчасть", Запчасть);

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ТД.Цена =  ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;

КонецПроцедуры
Просмотров: 83, последний комментарий от Vofka   
RSS Текстовая версия Сейчас: 25.06.18, 19:36
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне