Заказы на доработку 1С (сервис удаленной работы)

Хранилище

База знаний
Неназначенных незавершенных заказов: 6
Бесплатные отчеты, обработки, конфигурации, внешние компоненты для 1С Статьи, описание работы, методики по работе с 1С

Здравствуйте, гость ( Войти | Зарегистрироваться )

История благодарностей участнику Flexy ::: Спасибо сказали: 215 раз
Дата поста: В теме: За сообщение: Спасибо сказали:
23.05.18, 16:46 Подключение фискального регистратора по RDP соединению
f12 @ Сегодня, 16:32 * ,
Проброс COM (или в какой там порт воткнут регистратор на локальном ПК) через RDP.
1. В RDP клиенте в настройках локальных ресурсов есть вкл / выкл данная это опция.
2. На стороне сервера терминалов в настройках проверить, что проброс порта в сервер терминалов разрешен.
f12,
23.05.18, 16:20 Звернення з форми до довідника
&НаСервере
Процедура МодельТранспортногоЗасобуПриИзмененииСервер()
ТранспортнийЗасіб.ТипТранспортногоЗасобу=МодельТранспортногоЗасобу.ТипТранспортногоЗасобу;
КонецПроцедуры

&НаКлиенте
Процедура МодельТранспортногоЗасобуПриИзменении(Элемент)
МодельТранспортногоЗасобуПриИзмененииСервер();
КонецПроцедуры


Для получения ".ТипТранспортногоЗасобу" нужно сервер вызывать. На клиенте нет этих данных.
l2d808,
22.05.18, 22:09 Выбрать часть текста из строки
Цитата(Prospero @ 22.05.18, 21:22) *
ИМХО

Действительно, спешил...не проверял...Спасибо icon_beer17.gif
Lexveritas,
22.05.18, 20:08 Выбрать часть текста из строки
ОткрСкобка = Найти(Наименование, "(");
ЗакрСкобка = Найти(Наименование, ")");
Если ОткрСкобка = 0 ИЛИ ЗакрСкобка = 0 Тогда
Возврат;
КонецЕсли;
Конструкция = Сред(Наименование, ОткрСкобка + 1, ЗакрСкобка -1);
Lexveritas,
11.05.18, 22:13 Обработка для Новой Почты
Цитата(RomWeb @ 10.05.18, 20:54) *
На УП она не работает

Работает, если встроить обработку в конфигурацию и запускать приложение в режиме "толстый клиент". Проверенно.
Володька,
06.04.18, 20:40 Как бы я выдавливал 1С с рынка.
crazy.gif
Фантазеры! Тема из разряда: "Давайте напишем свой бесплатный Open-source Windows".

P.S. Вы приблизительно понимаете сколько бабла и человеко-часов было потрачено на разработку платформы и тех же типовых конфигураций?
logist,
21.11.17, 13:47 в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
andreykyiv@bigmir.net @ Сегодня, 13:18 * ,
У меня на этом релизе работает: 8.3.8.2027.
andreykyiv@bigmir.net,
15.11.17, 23:06 в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Попробуйте: st*******/UT3/ru_RU/?C=isdi
andreykyiv@bigmir.net,
15.11.17, 12:40 в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Встроенная справка 1С (по кнопке F1):
Запуск 1С:Предприятие 8 в режиме веб-клиента
Для запуска веб-клиента необходимо в адресной строке веб-браузера ввести адрес следующего вида:
http://hostt
где host – адрес сайта, соответствующего информационной базе.

Веб-клиент не поддерживает параметры командной строки толстого и тонкого клиентов. Для веб-клиента существуют свои параметры запуска. Они указываются в строке веб-браузера после символа "?", параметры разделяются символом "&".

Синтаксис строки запроса: http://host?ИмяПараметра1=ЗначениеПараметр...чениеПараметра2

Пример: http://localhost/demo?C=userParameter

Параметры командной строки в режиме веб-клиента
iTaxi — режим интерфейса "Такси".

itdi – режим интерфейса с использованием закладок.

isdi – режим интерфейса с использованием отдельных окон (используется по умолчанию).

andreykyiv@bigmir.net,
14.11.17, 14:49 в УТ3 для Украины после установки платформы 8.3.10 нет варианта открытия документов в отдельных окнах
Нужно добавить в дополнительные параметры базы ключ /isdi
andreykyiv@bigmir.net, cos12,
09.11.17, 13:28 Работа с 1С при помощи powershell через OLE
$Base1C = New-Object -comobject V83.ComConnector


$Base1C | Get-Member -MemberType Methods

Name                  MemberType Definition
----                  ---------- ----------
Connect               Method     IDispatch Connect (string)
ConnectAgent          Method     IServerAgentConnection ConnectAgent (string)
ConnectWorkingProcess Method     IWorkingProcessConnection ConnectWorkingProcess (string)
kihor,
07.11.17, 13:15 Отчет по двум запросам
Цитата(ranis @ 07.11.17, 13:01) *
И что сделать?

Выводить в одну таблицу два отчета:
Таб = СоздатьОбъект("ТабличныйДокумент");
//Вывод первого отчета
// Вывод второго отчета
Таб.Показать();

Или в разные шаблоны:
Таб = СоздатьОбъект("ТабличныйДокумент");
Таб.ИсходнаяТаблица("Отчет_1");
// Вывод отчета
Таб.Показать();
Таб = СоздатьОбъект("ТабличныйДокумент");
Таб.ИсходнаяТаблица("Отчет_2");
// Вывод второго отчета в другой шаблон
Таб.Показать();
ranis,
07.11.17, 12:55 Отчет по двум запросам
Табличный документ - переменная "Таб". Перезаписывается, после первого запроса. Она же и выводиться последней.
Таб.ВывестиСекцию("Итого"); 
...
Таб = СоздатьОбъект("Таблица");
ranis,
03.11.17, 12:53 Валовая прибыль розници по подразделениям не показывает возврат
Pashaboston @ Сегодня, 12:50 * ,
Сделайте Расчет себестоимости. Если не изменяет память, после этого отчет должен будет показать данный товар с отрицательной валовой прибылью.
Pashaboston,
16.10.17, 16:14 Как можно сохранить значения ТЗ в нормальный документ в формате csv?
lensky @ Сегодня, 15:18 * ,
тДок = Новый ТекстовыйДокумент;
Для Каждого Строка Из ТЗ Цикл
тДок.ДобавитьСтроку(Строка.Знач1 + ";" + Строка.Знач2 + ";" + Строка.Знач3);
КонецЦикла;
тДок.Записать("D:\MyCsv.csv");
lensky,
12.10.17, 11:56 УникальныйИдентификатор() запросом
Цитата(lensky @ 12.10.17, 11:40) *
А как отобрать по данным КА из ТЗ (запрос выгружен в ТЗ) УИД и добавить отдельной колонкой. Прошу прощение за наглость, конечно, но я начинающий.

Т = Запрос.Выполнить().Выгрузить();
Т.Колонки.Добавить("УИД");
Для Каждого Стр Из Т Цикл
Стр.УИД = Стр.Контрагент.УникальныйИдентификатор();
КонецЦикла;
lensky,
12.10.17, 10:18 УникальныйИдентификатор() запросом
lensky @ Сегодня, 10:15 * ,
В запросе - никак.
УИД = Выборка.Контрагент.УникальныйИдентификатор();
lensky,
11.10.17, 10:06 Помогите пожалуйста поправить запрос
"ВЫБРАТЬ
|    Номенклатура.Ссылка КАК Товар
|ПОМЕСТИТЬ втТовары
|ИЗ
|    Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|    Номенклатура.Ссылка В ИЕРАРХИИ(&Категория)
|    И Номенклатура.ЭтоГруппа = ЛОЖЬ
|    И Номенклатура.ПометкаУдаления = ЛОЖЬ
|    И НЕ Номенклатура.ВидНоменклатуры В (&ВидыНоменклатуры)
|
|ИНДЕКСИРОВАТЬ ПО
|    Товар
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ
|    втТовары.Товар,
|    ЕСТЬNULL(ТоварыНаСкладахОстатки.КоличествоОстаток, 0) КАК Остаток,
|    ЕСТЬNULL(ЦеныНоменклатурыСрезПоследних.Цена, 0) КАК Цена
|ИЗ
|    втТовары КАК втТовары
|        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ТоварыНаСкладах.Остатки(
|                ,
|                Номенклатура В
|                        (ВЫБРАТЬ
|                            втТовары.Товар
|                        ИЗ
|                            втТовары)
|                    И Склад = &СкладОстатков) КАК ТоварыНаСкладахОстатки
|        ПО втТовары.Товар = ТоварыНаСкладахОстатки.Номенклатура
|        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
|                ,
|                Номенклатура В
|                        (ВЫБРАТЬ
|                            втТовары.Товар
|                        ИЗ
|                            втТовары)
|                    И ТипЦен = &ТипЦенНоменклатуры) КАК ЦеныНоменклатурыСрезПоследних
|        ПО втТовары.Товар = ЦеныНоменклатурыСрезПоследних.Номенклатура
|
|УПОРЯДОЧИТЬ ПО
|    втТовары.Товар.Наименование"
berkut_0,
03.10.17, 11:40 Программное управление справочниками и документами в режиме "ТолькоПросмотр"
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
       Отказ = Не ОбщийМодульПроверкаДоступа.ПроверитьДоступ(ТекущийПользователь, ТекущийДокумент);
           // ТолькоПросмотр = ОбщийМодульПроверкаДоступа.ПроверитьДоступ(ТекущийПользователь, ТекущийДокумент);
КонецПроцедцры

...

// Общий модуль
Функция ПроверитьДоступ(ТекущийПользователь, ТекущийДокумент) Экспорт
      Запрос = НовыйЗапрос("ВЫБРАТЬ РежимПросмотра ИЗ РегистрСВ ... ГДЕ Пользователь = &ТекущийПользователь И Документ = &ТекущийДокумент);
      Результат = Запрос.Выполнить().Выбрать();
     РазрешенДоступ = Ложь;
      Если Результат.Следующий() Тогда
      Разрешен.Доступ = Результат.РежимПросмотра;
      КонецЕсли;

      Возврат РазрешенДоступ;

КонецФункции
Constantus,
01.09.17, 21:45 как очистить сообщение на сервере
Ооочень много букв. На сервере нет форм в явном виде, что бы отработал данный метод.
Вы наверное не очень понимаете архитектуру "клиент-сервер".

Если по делу, то имхо метода такая:
1. С клиента вызываете функцию на сервере, которая делает что-то и возвращает результат на клиента.
2. На клиенте получаете результат и обрабатываете его.
3. Если в процессе обработки результат нужно выводить/очищать сообщения на клиенте - используете для этого методы доступные на клиенте.

Реализацию процента выполнения процедуры/функции описали выше. Так же, можно посмотреть более детально, как это реализовано в БСП.

Цитата(sava1 @ 01.09.17, 14:53) *
Цитата(Gigi @ 01.09.17, 15:21)
нет времени разбираться.

А написать столько буков есть?

laugh.gif
Gigi,
31.08.17, 11:30 Список значений в строку
Спис = Новый СписокЗначений;
Спис.Добавить(1);
Спис.Добавить(2);
Спис.Добавить(3);
Спис.Добавить(4);
Спис.Добавить(5);
Результат = "";
Для Каждого Элем Из Спис Цикл
Результат = ?(Спис.Индекс(Элем) > 0,  Результат+","+Элем.Значение, Результат+Элем.Значение)     
КонецЦикла;
salton,
25.08.17, 17:00 Не получается добавить нужные колонки в номенклатуру
ГДЕ
    НЕ СпрНоменклатура.ЭтоГруппа И
    ЦеныНоменклатурыСрезПоследних.ВидЦены.Наименование = ""Розничная""
Bulzavr,
21.08.17, 10:53 Аналог функции ПолучитьЦенуНоменклатуры
ПродажиСервер.ПолучитьЦенуПоОтбору(ПараметрыОтбора)
ЗакупкиСервер.ПолучитьЦенуПоОтбору(ПараметрыОтбора)
Pashaboston,
12.08.17, 14:35 Отчеты в скд
Murano @ Сегодня, 13:50 * ,
Е.Ю. Хрусталева - Разработка сложных отчетов.

А вообще пройдитесь поиском по форуму...данных на эту тему полно.
Murano,
08.08.17, 15:12 Как перенести журнал регистрации полностью в регистр сведений
ЕстьОшибки = Ложь;
    
    Попытка
        
        ТЗ = Новый ТаблицаЗначений;
        ВыгрузитьЖурналРегистрации(ТЗ);
        
        // Запись ТЗ в РС
        Рег = РегистрыСведений.РегЖР.СоздатьНаборЗаписей();
        Рег.Загрузить(ТЗ);
        Рег.Записать();
        
    Исключение
        
        ЕстьОшибки = Истина;
        //Сообщить(ОписаниеОшибки());
        
    КонецПопытки;
    
    Если Не ЕстьОшибки Тогда
        // Очистка ЖР
        Фильтр = Новый Структура; // пустой фильтр
        ОчиститьЖурналРегистрации(Фильтр);
    КонецЕсли;
cao0603,

8 страниц V   1 2 3 > » 
RSS Текстовая версия Сейчас: 25.05.18, 3:06
1С Предприятие 8.3, 1С Предприятие 8.2, 1С Предприятие 8.1, 1С Предприятие 8.0, 1С Предприятие 7.7, Литература 1С, Общие вопросы по администрированию 1С, Методическая поддержка 1С - всё в одном месте: на Украинском 1С форуме!

Курсы валют: доллар США к гривне Курсы валют: евро к гривне Курсы валют: российский рубль к гривне